Содержание
Fax Voip Windows Fax Service Provider
T.38 и аудио факс, SIP, H.323

https://www.t38faxvoip.ru/fsp

Позволяет Microsoft Fax и приложению Факсы и сканирование, которые встроены в Windows, отправлять и принимать T.38 и аудио факсы через VoIP. ECM (Коррекция ошибок). Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

Содержание

Введение

Новое в версии 4.3.1

История предыдущих версий

Установка Fax Voip FSP

Установка пробной версии

Функции

Системные требования

Удаление предыдущей версии

Microsoft .NET Framework 4.5

Запуск программы установки

Настройка Fax Voip FSP

Настройка линии SIP

Настройка линии H.323

Установка Средства просмотра фотографий в Windows Server

Диспетчер Fax Voip FSP

Запуск диспетчера Fax Voip FSP

Опции меню в системном трее

Панель управления Fax Voip FSP

IP-телефония

SIP

Параметры SIP

Параметры прокси-сервера

Учетные записи SIP

Параметры учетных записей SIP

Добавление (или изменение) учетной записи SIP

Управление учетными записями SIP

Тестирование учетной записи SIP

Параметры восстановления SIP регистрации

Параметры T.38 факса

Параметры аудио факса

H.323

Параметры H.323

H.323 гейткипер

Параметры T.38 факса

Параметры аудио факса

Маршрутизация исходящих VOIP вызовов

Добавление или изменение правил для исходящих вызовов

Управление правилами для исходящих вызовов

Параметры маршрутизации исходящих VOIP вызовов

Общие параметры

Параметры факса

Параметры аудио

Маршрутизация входящих VOIP вызовов

Добавление или изменение правил для входящих VOIP вызовов

Управление правилами для входящих VOIP вызовов

Параметры маршрутизации входящих VOIP вызовов

Общие параметры

Параметры факса

Агент пользователя

Методы маршрутизации для входящих факсов

Отправить по электронной почте

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры E-mail

Параметры формата

Шаблоны электронной почты

Сохранить в папке

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры сохранения

Параметры формата

Печать

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры печати

Пользовательская маршрутизация входящих факсов

Требования к пользовательскому приложению (информация для разработчика)

Пример пользовательского приложения

Методы маршрутизации для исходящих факсов

Уведомления о доставке по электронной почте

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры E-mail

Параметры формата

Шаблоны электронной почты

Сохранить в папке

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры сохранения

Параметры формата

Печать

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры печати

Пользовательская маршрутизация исходящих факсов

Требования к пользовательскому приложению (информация для разработчика)

Пример пользовательского приложения

Факс

Параметры факса

Интеллектуальная повторная передача факса

Набор номера

Общие сведения о правилах набора номера

Таймауты факса

Параметры конвертации в факс

Параметры printto

Исправление ассоциаций файлов в Windows 11 и Windows 10

Параметры просмотра факсов

Отправка факса с помощью утилиты SendFax.exe

Параметры командной строки SendFax.exe

Настройка и запуск SendFax.exe

Титульные страницы (SendFax.exe)

Сведения об отправителе (SendFax.exe)

Уведомления о доставке на е-mail (оригинал)

Параметры SMTP (служба факсов Windows)

Параметры SendFax.exe

Получатели факса

Документы

Конвертация в факс

Титульная страница

Сведения об отправителе

Важность и время отправки факса

Уведомления на е-mail (оригинал)

Отслеживание факса (графический интерфейс)

Мониторинг факса

Просмотр свойств факса

Работа с факсом

Отслеживание факса (режим консоли)

Аудио

Параметры аудио

Аудио кодеки

Параметры аудио кодеков

Требования к аудио кодекам для передачи факсов

Электронная почта

Факс-на-почту, почта-на-факс и уведомления о доставке

Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows

Почта-на-факс

Параметры почта-на-факс

Набор номера (почта-на-факс)

Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс)

Титульные страницы (почта-на-факс)

Сведения об отправителе (почта-на-факс)

Правила для почты (почта-на-факс)

Добавление или изменение правил

Управление правилами

Параметры правил для почты

Общие параметры

Набор номера

Уведомления о доставке

Вложения электронной почты

Титульные страницы

Сведения об отправителе

Время отправки факса

Шаблоны электронной почты

Отправка факсов через e-mail

Создание сообщения электронной почты

Отправка титульных страниц

Вложения электронной почты

Использование PDF файлов в качестве вложений электронной почты

Блокирование нежелательных адресов электронной почты

Уведомление на e-mail о результатах отправки факса

Почта-на-факс в качестве службы Windows

Устранение неполадок функции почта-на-факс

Часто задаваемые вопросы (FAQ)

Просмотр журнала функции почта-на-факс

Общие инструкции по восстановлению функции почта-на-факс

Использование вложений электронной почты с именами файлов на национальных языках

Параметры SMTP

Параметры OAuth 2.0

Получение и установка сертификата безопасности электронной почты

Отправка пробного e-mail

Параметры POP3 / IMAP

Параметры OAuth 2.0

Тестирование POP3 / IMAP

Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0

Google (Gmail.com)

Microsoft (Office 365, Hotmail, Outlook.com)

Yahoo.com

Yandex.ru

Mail.ru

Шаблоны электронной почты

Получен новый факс

Факс успешно отправлен

Не удалось отправить факс

Не удалось создать задание факса

Общие параметры и протоколы

Общие параметры

Журналы Fax Voip FSP

Журналы маршрутизации входящих факсов

Журналы маршрутизации исходящих факсов

Журналы электронной почты

Журналы SendFax.exe

Многоязычная поддержка

Добавление языкового профиля

Редактирование языкового профиля

Языковые файлы

Служба факсов Windows

Установка службы факсов

Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10

Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022

Настройка службы факсов

Windows 11

Windows Server 2022

Совместное использование ресурсов факса

Настройка факс сервера (Windows Server 2022)

Настройка факс клиента (Windows 11)

Конфигурирование идентификатора и заголовка факса

Windows 11

Windows Server 2022

Доступ к факсам другого пользователя

Регистрация провайдера службы факсов

Отправка и получение факсов

Отправка факсов

Отправка факса из приложения Windows

Отправка факса из Fax Voip FSP

Настройка сведений об отправителе

Настройка качества изображения

Утилита командной строки SendFax.exe

Отправка факса с использованием другой учетной записи

Получение факсов

Мониторинг и уведомления

Caller ID и номер вызываемого абонента (DID)

Получение Caller ID и DID

Передача Caller ID (SIP)

Передача Caller ID (H.323)

Примеры настройки с операторами VoIP

YouMagic (МТТ)

Телфин

Мультифон (Мегафон)

DellMont (Betamax)

Лицензии

Виды лицензий

Просмотр текущей лицензии

Покупка лицензии

Добавление/изменение лицензии

Обновление Fax Voip FSP до версии 4

Политика лицензионной поддержки

Часто задаваемые вопросы

Архивация и восстановление

Сохранение текущих параметров и файлов

Восстановление параметров и файлов

Удаление Fax Voip FSP

Чтобы удалить Fax Voip FSP

Запуск Fax Voip FSP через подключение к удаленному рабочему столу (RDP)

Настройка RDP на компьютере, к которому требуется подключиться

Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP)

Проблемы Виртуальных Машин

Часто задаваемые вопросы

Техническая поддержка

Удаленная поддержка

Другие продукты

Fax Voip T.38 Модем

Fax Voip T.38 Консоль

Fax Voip Softphone

Windows Mail Restore Tool for Windows 10, 8.1 and 7

Copyright © FaxVoip Software, LLC, 2008-2024. Все права защищены.


Введение
Fax Voip Windows Fax Service Provider
T.38 и аудио факс, SIP, H.323

https://www.t38faxvoip.ru/fsp

Позволяет Microsoft Fax и приложению Факсы и сканирование, которые встроены в Windows, отправлять и принимать T.38 и аудио факсы через VoIP. ECM (Коррекция ошибок). Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip FSP

Fax Voip Windows Fax Service Provider (Fax Voip FSP) позволяет Microsoft Fax и приложению Факсы и сканирование Windows, которые встроены в Windows, отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы с использованием вашей VoIP (SIP или H.323) инфраструктуры без каких-либо дополнительных затрат.

Служба факсов Windows и приложение Факсы и сканирование Windows представляют собой интегрированное факс программное обеспечение включенное во все версии Windows. Microsoft Fax является расширяемой факс платформой, которую можно использовать для развертывания совместно используемых факс ресурсов в вашей организации. Пользователи внутри организации могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере, а также использовать локальные факс устройства, привязанные к их компьютерам. Факс администраторы могут конфигурировать, управлять и следить за этими общими ресурсами факсов. Централизованное управление общими факс-устройствами на базе сервера означает более простое управление и техническое обслуживание, а также низкую стоимость. Пользователи факса могут отправлять и получать факсы без необходимости использования ручных факс-аппаратов, экономя при этом время и силы.

Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Также корректно определяется сигнал 'занято'. Использование провайдера службы факсов (Fax Service Provider, FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.

Fax Voip FSP позволяет приложению Windows Fax and Scan получать Caller ID и Номер вызываемого абонента (DID) - через Сведения о маршрутизации.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Функция Почта-на-факс позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Расширение маршрутизации Fax Voip FSP позволяет маршрутизировать входящие факсы в зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), используя следующие методы маршрутизации для входящих факсов : отправить по электронной почте , сохранить в папке , печать . Пользовательская маршрутизация входящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов : уведомления о доставке по электронной почте , сохранить в папке , печать позволяют маршрутизировать исходящие факсы в зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса. Пользовательская маршрутизация исходящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса.

Fax Voip FSP был успешно протестирован с YouMagic , Телфин , Мультифон , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими операторами IP-телефонии.


Новое в версии 4.3.1

Новое в версии 4.3.1 (Январь 2024)

  • Исправлены HTTPS и некоторые другие ссылки в приложении.
  • Исправлены ссылки HTTPS в руководстве пользователя.

Новое в версии 4.2.1 (Март 2023)

  • Добавлена поддержка OAuth 2.0 (современная проверка подлинности) при отправке сообщений электронной почты через сервер SMTP.
  • Добавлена поддержка OAuth 2.0 (современная проверка подлинности) при приеме сообщений электронной почты через сервер POP3 / IMAP.
  • Метод SecureSmtpClient для отправки сообщений электронной почты через SMTP. Поддержка OAuth 2.0 (современная проверка подлинности). Implicit SSL, Explicit SSL (STARTTLS). Кодировка UTF-8. Подробный лог при отправке сообщения электронной почты через SMTP.
  • В панели управления Fax Voip FSP реализована процедура получения Refresh Token (OAuth 2.0) с использованием Internet Explorer, WebBrowser (.Net) или веб-браузера по умолчанию.
  • Fax Voip FSP был успешно протестирован с Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и некоторыми другими провайдерами электронной почты OAuth 2.0.
  • Корректное отображение номера и описания ошибки при использовании метода CDO.Message для отправки сообщений электронной почты через SMTP. Исправлено.
  • Некоторые другие улучшения.

Новое в версии 4.1.1 (Сентябрь 2022)

  • Добавлена поддержка Windows 11 и Windows Server 2022.
  • Наконец удалена поддержка Windows XP, Windows Server 2003 и Windows Vista.
  • Добавлена поддержка TLS версии 1.2 при использовании SMTP и защищенного соединения (SSL). Может быть критично при использовании метода маршрутизации для входящих факсов 'Отправить по электронной почте' , метода маршрутизации для исходящих факсов 'Уведомления о доставке по электронной почте' и функции Почта-на-факс .
  • Добавлена поддержка TLS версии 1.2 при использовании POP3 / IMAP и защищенного соединения (SSL). Может быть критично при использовании функции Почта-на-факс .
  • Добавлены некоторые комментарии о том, как использовать Fax Voip FSP с аккаунтом Gmail после 30 Мая 2022 года ( Параметры SMTP , Параметры POP3 / IMAP ).
  • Новые стили и иконки для лучшей совместимости с Windows 11.
  • Обновленная справочная система.
  • Некоторые другие улучшения.


История предыдущих версий

Новое в версии 4.3.1 ››

Новое в версии 3.3.1 (Октябрь 2021)

  • В панели управления Fax Voip FSP добавлена страница Набор номера (телефония Microsoft) . На этой странице вы можете настроить правила набора номера (TAPI) и проверить, как будет преобразован номер факса, введенный в каноническом формате, и как он будет отображаться в программе Факсы и сканирование Windows. В руководстве пользователя добавлены инструкции по настройке правил набора номера (глава Общие сведения о правилах набора номера ).
  • При использовании функции Почта-на-факс и Правил для почты , добавлена возможность преобразования номера факса в неканонический формат перед созданием задания факса, в том числе с использованием правил набора номера (TAPI), настроенных в параметрах Телефон и модем в панели управления Windows.
  • При использовании функции Почта-на-факс и Правил для почты , появилась возможность добавления префикса перед номером факса. В частности, это можно использовать для маршрутизации факсов от различных пользователей электронной почты через разные учетные записи SIP. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов (параметры Если номер начинается с цифр и Удалить цифры...).
  • При использовании параметра Удалить цифры в правиле маршрутизации исходящих VOIP вызовов, теперь можно удалять не только цифры, но и любые другие символы в начале номера.
  • Исправлены некоторые проблемы с поиском записей DNS SRV, в частности при использовании прокси. Критично для некоторых провайдеров, таких как Deutsche Telekom (tel.t-online.de), которые больше не используют записи типа A для определения IP-адреса SIP сервера. Иногда это можно использовать для автоматического определения правильного номера порта, используемого SIP сервером.
  • В панели управления Fax Voip FSP добавлены команды, позволяющие копировать правила маршрутизации или учетные записи SIP. Применимо к учетным записям SIP , маршрутизации исходящих VOIP вызовов , маршрутизации входящих VOIP вызовов , методам маршрутизации для входящих факсов ( отправить по электронной почте , сохранить в папке , печать ), методам маршрутизации для исходящих факсов ( уведомления о доставке по электронной почте , сохранить в папке , печать ) и правилам для почты . Может быть полезно при создании большого количества схожих правил или учетных записей SIP.
  • В панели управления Fax Voip FSP добавлены команды, позволяющие разрешить или запретить использование выбранных правил. Применимо к методам маршрутизации для входящих факсов ( отправить по электронной почте , сохранить в папке , печать ) и методам маршрутизации для исходящих факсов ( уведомления о доставке по электронной почте , сохранить в папке , печать ).
  • Настройка службы факсов Windows для архивирования всех успешно отправленных факсов в папку Отправленные. Необходимо для обеспечения правильной работы методов маршрутизации для исходящих факсов .
  • Возможность настройки параметра Использовать код устройства передающего абонента (TSID) (служба факсов Windows) с помощью команды 'Переустановить компоненты Fax Voip FSP' в панели управления Fax Voip FSP .
  • Некоторые другие улучшения.

Новое в версии 3.2.1 (Октябрь 2020)

  • Метод маршрутизации Уведомления о доставке по электронной почте для исходящих факсов. Отправка уведомлений на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса. В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, уведомление о доставке может быть отправлено различным e-mail адресатам. Отправка уведомлений нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата прикрепляемого факса: TIFF, PDF или SFF. Настраиваемые шаблоны электронной почты. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени. Этот метод является заменой для функции Уведомления о доставке на e-mail. Работает независимо от учетной записи пользователя, под которой было создано задание факса (основная проблема в предыдущей реализации). Старый функционал полностью удален из приложения.
  • Метод маршрутизации Сохранить в папке для исходящих факсов. Копирование исходящих факсов в заданные папки в зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса. Сохранение исходящих факсов в одной или нескольких папках. Возможность выбора формата сохранения факса: TIFF, PDF или SFF. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени.
  • Метод маршрутизации Печать для исходящих факсов. Печать исходящих факсов в зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса. Печать исходящих факсов на один или несколько принтеров.
  • Пользовательская маршрутизация исходящих факсов . Позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Прилагается пример кода.
  • Новая переменная %FaxAccount% была добавлена в шаблоны электронной почты Факс успешно отправлен и Не удалось отправить факс , а также в шаблоны имен файлов для исходящих факсов. Заменяется именем учетной записи пользователя, который отправил факс.
  • Лицензия 'Fax Voip FSP расширенная маршрутизация факсов: E-mail, Сохранить в папке, Печать' теперь применяется как к методам маршрутизации для входящих факсов , так и к методам маршрутизации для исходящих факсов .
  • Таймауты факса : время ожидания ответа на вызов, время установки связи с факсом, время передачи страницы факса, максимальная продолжительность вызова. Использование этих опций позволяет Fax Voip FSP принудительно завершить VoIP вызов и освободить ресурсы факса (виртуальные устройства Fax Voip Line).
  • Вспомогательный механизм принудительного восстановления SIP регистрации . Может быть полезен в случае нестабильной регистрации.
  • Формат сжатия TIFF для факсов, принятых через линии Fax Voip FSP, был изменен с CCITT T.4 на CCITT T.6 в соответствии с требованиями службы факсов и рекомендациями ITU-T T.6 . Исправлены некорректные значения в тегах TIFF файла: номера 282 (XResolution) и 283 (YResolution). В частности, исправлена проблема с печатью принятых факсов в приложении 'Факсы и сканирование Windows'.
  • Исправлена ​​ошибка, которая могла привести к частичной потере настроек при нажатии кнопки <Применить> и последующем закрытии окна панели управления Fax Voip FSP.
  • В предыдущих версиях пользователь мог указать двузначное число в параметре Удалить цифры в правиле маршрутизации исходящих VOIP вызовов, что приводило к ошибке при исходящем вызове. Исправлено. Имеющийся код позволяет удалить не более 9 первых цифр набираемого номера.
  • В руководстве пользователя добавлены инструкции по настройке факс-сервера (операционная система Windows Server) для совместного использования с клиентскими компьютерами (глава Совместное использование ресурсов факса ).
  • В руководстве пользователя добавлены инструкции о том, как просматривать факсы, созданные другим пользователем, и управлять ими (глава Доступ к факсам другого пользователя ). Добавлены инструкции о том, как отправить факс от имени учетной записи другого пользователя (глава Отправка факса с использованием другой учетной записи ).
  • В руководстве пользователя добавлены инструкции о том, как включить методы маршрутизации для исходящих факсов и функцию интеллектуальной повторной передачи факса в Windows 7 и Windows Server 2008R2, где они не работают по умолчанию. Чтобы устранить проблему, необходимо вручную установить исправление (KB2535158), предоставленное Microsoft.
  • Некоторые другие улучшения.

Новое в версии 3.1.1 (Октябрь 2019)

  • Утилита командной строки SendFax.exe . Отправка факса одному или нескольким получателям. Поддержка отправки нескольких документов, титульных страниц, оригинальных уведомлений о доставке на e-mail. Отслеживание факса . Настройка и запуск SendFax.exe из панели управления Fax Voip FSP .
  • Интеллектуальная повторная передача факса : при повторе после неудачи, передача факса начинается с первой страницы, которая не была успешно передана, чтобы избежать повторной отправки уже переданных страниц.
  • В шаблонах электронной почты , возможность выбрать региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени.
  • Индивидуальные шаблоны электронной почты при использовании метода маршрутизации отправить по электронной почте для входящих факсов (расширение маршрутизации Fax Voip FSP).
  • Настраиваемые шаблоны имен файлов при использовании метода маршрутизации сохранить в папке для входящих факсов (расширение маршрутизации Fax Voip FSP). Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов при использовании метода маршрутизации отправить по электронной почте для входящих факсов (расширение маршрутизации Fax Voip FSP). Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов при использовании функций Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) и Уведомления о доставке на e-mail. Настраиваемые форматы даты и времени.
  • Обновленная справочная система.
  • Некоторые другие улучшения.

Новое в версии 2.4.1 (Апрель 2019)

  • Добавлена поддержка Windows Server 2019.
  • Исправлена ошибка в библиотеке Fax Voip FSP, которая неизбежно вызывала сбой службы факсов Windows при отправке факса без указания идентификатора факса TSID (поле 'Номер факса' в 'Сведениях об отправителе'), в случае если опция 'Использовать код устройства передающего абонента (TSID)' отключена в настройках факс сервера.
  • При настройке службы факсов Windows для отправки/получения факсов через устройства Fax Voip FSP, с использованием Панели управления Fax Voip FSP, теперь можно настроить параметры отправки/получения, а также задать идентификаторы факса TSID/CSID.
  • Создание ярлыка 'Факсы и сканирование' на рабочем столе. В Windows 8 и более поздних версиях, создание ярлыка 'Факсы и сканирование' в меню 'Пуск'. В ОС Windows Server, создание ярлыка 'Диспетчер службы факсов' на рабочем столе и в меню 'Пуск'.
  • В Windows 10, Windows Server 2019 и Windows Server 2016, исправление ошибки в программе Факсы и сканирование Windows, из-за которой кнопка 'Переслать по электронной почте' неактивна, в то время как e-mail клиент с поддержкой MAPI установлен в системе.
  • В Панели управления Fax Voip FSP, на вкладке 'Инструменты' ленты, добавлены команды для управления Контактами Windows (Адресная книга).
  • Обновленная справочная система.
  • Некоторые другие улучшения.

Новое в версии 2.3.1 (Декабрь 2017)

  • Функция Почта-на-факс . Позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений. Функция Почта-на-факс может быть сконфигурирована для работы в качестве службы Windows.
  • Правила для почты (почта-на-факс) . В зависимости от адреса электронной почты, позволяют переопределить следующие параметры: уведомления о доставке, вложения электронной почты, титульные страницы, сведения об отправителе, важность и время отправки факса, шаблоны электронной почты. Блокирование нежелательных адресов электронной почты.
  • Уведомления о доставке на e-mail. Уведомление направляется на заранее заданный адрес электронной почты, чтобы подтвердить успешную доставку факса. Копия отправленного факса может быть прикреплена к сообщению электронной почты в формате TIFF, PDF или SFF. Можно указать несколько получателей e-mail, в том числе с использованием полей Копия и Скрытая копия.
  • Новые настраиваемые шаблоны электронной почты , для использования с функциями Почта-на-факс и Уведомления о доставке на e-mail: Факс успешно отправлен , Не удалось отправить факс , Не удалось создать задание факса .
  • Прямая конвертация в факс . Позволяет конвертировать в факс (TIFF) некоторые из наиболее популярных форматов без использования печати. Поддерживаемые форматы: PDF, TIFF, SFF, QFX, BMP, JPEG, GIF, PNG, ICO, WMF (EMF). В настоящее время используется с функцией Почта-на-факс.
  • Функция Исправить команды printto . Исправляет проблемы печати из-под службы Windows и восстанавливает стандартные ассоциации файлов. Поддерживаемые форматы: TXT, BMP, DIB, EMF, GIF, ICO, JFIF, JPE, JPEG, JPG, JXR, PNG, RLE, TIF, TIFF, WDP, WMF.
  • При прямом преобразовании из PDF в TIFF, исправлена ошибка с зависанием процесса и 100% загрузкой ЦП, с некоторыми PDF файлами. Ранее обнаружено в Fax Voip T38 Fax and Voice, версии 7.1.1 - 7.5.1.
  • При прямом преобразовании из PDF в TIFF, исправлена ошибка с неспособностью конвертировать файлы PDF с именами в Юникод (не на английском языке). Эта проблема в настоящее время присутствует во всех версиях Fax Voip T38 Fax and Voice, включая 7.5.1.
  • Исправлена проблема с SIP регистрацией с некоторым оборудованием (например Oktell ) и VoIP операторами (например YouMagic , T38FAX.com , mondotalk.com ). RFC3261 утверждает, что регистратор должен возвращать ВСЕ регистрации, однако мы должны иметь дело только с теми ответами от регистратора, которые мы действительно запрашивали. Иногда регистратор пытается быть умным и настраивает поле Contact с использованием внешнего IP-адреса в соответствии с 'Via rport'. IMHO это ошибка, поскольку не соответствует тому, что подразумевается в RFC3261/10.2.4 и 10.3 шаг 7. В ответ должен быть включен оригинальный Contact, а также дополнительный Contact, но регистратор этого не делает.
  • Некоторые другие улучшения.

Новое в версии 2.2.1 (Сентябрь 2017)

  • Расширение маршрутизации Fax Voip FSP, интегрированное в службу факсов Windows.
  • Метод маршрутизации Отправить по электронной почте для входящих факсов (Расширение маршрутизации Fax Voip FSP). Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Отправка e-mail нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата доставки факса: TIFF, PDF или SFF.
  • Метод маршрутизации Сохранить в папке для входящих факсов (Расширение маршрутизации Fax Voip FSP). Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Сохранение входящих факсов в одной или нескольких папках. Возможность выбора формата сохранения факса: TIFF, PDF или SFF.
  • Метод маршрутизации Печать для входящих факсов (Расширение маршрутизации Fax Voip FSP). Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Печать входящих факсов на один или несколько принтеров.
  • Пользовательская маршрутизация входящих факсов (Расширение маршрутизации Fax Voip FSP). Позволяет легко добавить любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Прилагается пример кода.
  • Поддержка SMTP. CDO.Message, System.Net.Mail. Implicit SSL, Explicit SSL (STARTTLS). Отправка e-mail сообщений в кодировке UTF-8. Отправка e-mail сообщений подписанных цифровой подписью: прозрачная подпись, непрозрачная подпись. Игнорирование недействительного SSL сертификата сервера при отправке e-mail сообщений с использованием SSL. Встроенный SMTP клиент для тестирования отправки e-mail.
  • Поддержка POP3 / IMAP (в настоящее время зарезервировано для будущего использования). Поддержка POP3 SSL. Поддержка IMAP SSL. Игнорирование недействительного SSL сертификата сервера при получении e-mail сообщений с использованием SSL. Возможность тестирования подключения к серверу POP3 / IMAP.
  • Настраиваемые шаблоны электронной почты . В настоящее время используется с методом маршрутизации Отправить по электронной почте для входящих факсов.
  • Реализована поддержка Адресной книги (Контакты Windows). Возможность выбора получателей электронной почты из Адресной книги.
  • Добавлены новые журналы отладки для Расширения маршрутизации Fax Voip FSP, методов маршрутизации для входящих факсов, отправки и приема электронной почты.
  • Добавлен новый тип лицензии: Лицензия Fax Voip FSP расширенная маршрутизация факсов (E-mail, сохранить в папке, печать).
  • Исправлены различные проблемы с лицензиями на компьютерах с включенной политикой FIPS для криптографических алгоритмов.
  • Исправлена ошибка отмены регистрации провайдера Fax Voip FSP в 64-разрядных версиях Windows 2003 и Windows XP.
  • Некоторые другие улучшения.

Новое в версии 2.1.1 (Июнь 2017)

  • Первоначальный публичный выпуск.


Установка Fax Voip FSP

  • Установка пробной версии
  • Функции
  • Системные требования
  • Удаление предыдущей версии
  • Microsoft .NET Framework 4.5
  • Запуск программы установки
  • Настройка Fax Voip FSP
  • Установка Средства просмотра фотографий в Windows Server


Установка пробной версии

Установка Fax Voip FSP ››

Программное обеспечение Fax Voip FSP может быть установлено в качестве временной пробной версии.

Fax Voip провайдер для службы факсов Windows позволяет вам:

  • Отправлять T.38 и аудио (поверх кодека G.711) факсы через SIP и H.323 сети IP-телефонии с использованием Службы факсов Windows и приложения Факсы и сканирование Windows.
  • Принимать T.38 и аудио (поверх кодека G.711) факсы через SIP и H.323 сети IP-телефонии с использованием Службы факсов Windows и приложения Факсы и сканирование Windows.
  • Использовать функцию Почта-на-факс . Титульные страницы , правила для почты , шаблоны электронной почты .
  • Использовать методы маршрутизации для входящих факсов (Расширение маршрутизации Fax Voip FSP): отправить по электронной почте , сохранить в папке , печать , пользовательская маршрутизация .
  • Использовать методы маршрутизации для исходящих факсов : уведомления о доставке по электронной почте , сохранить в папке , печать , пользовательская маршрутизация .
  • Использовать утилиту командной строки SendFax.exe для отправки факсов.

Ограничения пробной версии:

  • Пробная лицензия может быть использована один раз на данном компьютере.
  • Пробный период времени составляет 15 дней и начинает действовать с момента установки программного обеспечения.
  • Допускается использование 2-х факсимильных устройств* Fax Voip Line со Службой факсов Windows.
  • Допускается использование 2-х правил для каждого метода маршрутизации для входящих факсов : отправить по электронной почте , сохранить в папке , печать .
  • Допускается использование 2-х правил для каждого метода маршрутизации для исходящих факсов : уведомления о доставке по электронной почте , сохранить в папке , печать .
  • Окно с напоминанием об использовании незарегистрированной версии появляется каждые 30 минут и останавливает программу при отсутствии действий со стороны пользователя.

Примечания

  • (* : Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, Enterprise или Datacenter Edition, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем. Будьте внимательны при покупке многолинейных лицензий.
  • При покупке лицензии, используйте вкладку Лицензия в Панели управления Fax Voip FSP для активации приобретенного лицензионного ключа. Переустановка программного обеспечения не требуется. Индивидуальные настройки будут сохранены.


Функции

Установка Fax Voip FSP ››

Провайдер службы факсов Windows (FSP)

  • Fax Voip T.38/G.711FAX Device Provider (FSP) интегрированный в Службу факсов Windows
  • Факсимильные устройства* Fax Voip Line для Службы факсов Windows
  • Отправка и получение факсов через приложение Факсы и сканирование Windows
  • Отправка факса из любого приложения Windows через принтер факсов
  • Поддержка титульных страниц факсов
  • Идентификатор факса (TCID, CSID), Заголовок факса (название организации)
  • Визуальные и звуковые уведомления о факсах, Монитор факсов
  • Интеллектуальная повторная передача факса: при повторе после неудачи, передача факса начинается с первой страницы, которая не была успешно передана, чтобы избежать повторной отправки уже переданных страниц
  • Таймауты факса: время ожидания ответа на вызов, время установки связи с факсом, время передачи страницы факса, максимальная продолжительность вызова
  • Утилита командной строки SendFax.exe. Отправка факса одному или нескольким получателям. Поддержка отправки нескольких документов, титульных страниц, оригинальных уведомлений о доставке на e-mail. Отслеживание факса. Настройка и запуск SendFax.exe из панели управления Fax Voip FSP
  • Fax Class 1, UTI-T V.27ter/V.29/V.17, T.30 Fax Group 3 до 14.400 бит/с
  • Коррекция ошибок (ECM) - поддержка со Службой факсов Windows
  • T.38 Fax через IP в режиме реального времени
  • T.38 UDPTL Redundancy
  • Принудительное переключение в режим T.38 немедленно или через заданный интервал времени
  • Принудительное переключение в режим T.38 при обнаружении CNG или CED сигнала факса
  • Аудио факс поверх кодека G.711 через IP в режиме реального времени
  • Автоматическое переключение в режим аудио (поверх кодека G.711) факса если T.38 не доступен
  • Раздельные настройки факса для SIP/H.323, исходящих/входящих, T.38/аудио факсов
  • Голосовая реплика перед передачей факса
  • Поддержка Caller ID
  • Поддержка Номера вызываемого абонента (DID) в Факсы и сканирование Windows через поле Сведения о маршрутизации
  • Простая интеграция со службой факсов Windows. Настройка службы факсов Windows для отправки/получения факсов через устройства Fax Voip FSP в одно действие. Автоматическая установка приложения Факсы и сканирование Windows (роли Факс-сервера) во время установки Fax Voip FSP. Создание ярлыков на рабочем столе и в меню 'Пуск'. В Windows 11 и Windows 10, автоматическое исправление ошибок в службе факсов Windows и приложении Факсы и сканирование (кнопка 'Переслать по электронной почте' неактивна и т.д.)

Методы маршрутизации для входящих факсов (Расширение маршрутизации Fax Voip FSP)

  • Расширение маршрутизации Fax Voip FSP, интегрированное в Службу факсов Windows
  • Маршрутизация входящих факсов: метод Отправить по электронной почте. Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Маршрутизация входящих факсов: метод Сохранить в папке. Настраиваемые шаблоны имен файлов
  • Маршрутизация входящих факсов: метод Печать
  • Пользовательская маршрутизация входящих факсов

Методы маршрутизации для исходящих факсов

  • Маршрутизация исходящих факсов: метод Уведомления о доставке по электронной почте. Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Маршрутизация исходящих факсов: метод Сохранить в папке. Настраиваемые шаблоны имен файлов
  • Маршрутизация исходящих факсов: метод Печать
  • Пользовательская маршрутизация исходящих факсов

SIP / H.323

  • Поддержка SIP через UDP и SIP через TCP
  • SIP прокси-сервер
  • Поддержка нескольких учетных записей SIP (Одновременные SIP регистрации), Имя пользователя для авторизации, Домен/Realm, SIP контакт URL, Таймаут регистрации, принудительная регистрация
  • Прямая маршрутизация SIP вызовов
  • Поддержка H.323, Fast Start, H.245 Tunneling, Список телефонных номеров
  • Регистрация на H.323 гейткипере, Поиск гейткипера, Время жизни
  • H.235 MD5 аутентификация при регистрации на гейткипере
  • Прямая маршрутизация H.323 вызовов
  • Поддержка схемы Tel URI (только с SIP)
  • Аудио форматы: G.711-uLaw-64k, G.711-ALaw-64k, G.723.1, G.726-32k, GSM-06.10, iLBC, SpeexNB, SpeexWB
  • Поддержка STUN сервера
  • Маршрутизация исходящих и входящих VOIP вызовов
  • Переопределение параметров через маршрутизацию вызовов: Имя пользователя (Caller ID Number), Отображаемое имя (Caller ID Name), Максимальная скорость передачи факса, ECM, принудительное переключение в режим T.38 по таймеру и при обнаружении CED/CNG сигнала факса, T.38 UDPTL Redundancy, голосовая реплика перед передачей факса
  • Настраиваемый Агент пользователя SIP/H.323
  • Caller ID Number, Caller ID Name

Поддержка E-mail: почта-на-факс, факс-на-почту, уведомления о доставке

  • Почта-на-факс. Поддержка нескольких вложений e-mail. Титульные страницы, сведения об отправителе
  • Правила для почты (почта-на-факс). Переопределение параметров в зависимости от адреса e-mail: правила набора номера, уведомления о доставке, вложения электронной почты, титульные страницы, сведения об отправителе, важность и время отправки факса, шаблоны электронной почты. Блокирование нежелательных адресов электронной почты
  • Факс-на-почту (Маршрутизация входящих факсов: метод Отправить по электронной почте). Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Уведомления о доставке на e-mail (Маршрутизация исходящих факсов: метод Уведомления о доставке по электронной почте). Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Настраиваемые шаблоны электронной почты. Настраиваемые форматы даты и времени
  • Поддержка SMTP. Поддержка OAuth 2.0 (современная проверка подлинности). SecureSmtpClient, CDO.Message, System.Net.Mail. Implicit SSL, Explicit SSL (STARTTLS). Поддержка TLS версии 1.2. Кодировка UTF-8
  • Отправка сообщений электронной почты подписанных цифровой подписью. Прозрачная подпись. Непрозрачная подпись
  • Поддержка POP3/IMAP. Поддержка OAuth 2.0 (современная проверка подлинности). Поддержка SSL. Поддержка TLS версии 1.2
  • Игнорирование недействительного SSL сертификата сервера электронной почты

Прочее

  • Панель управления Fax Voip FSP. Интерфейс ленты (Ribbon)
  • Диспетчер Fax Voip FSP
  • Прямая конвертация в факс. Поддерживаемые форматы: PDF, TIFF, SFF, QFX, BMP, JPEG, GIF, PNG, ICO, WMF (EMF)
  • Функция 'Исправить команды printto'. Поддерживаемые форматы: TXT, BMP, DIB, EMF, GIF, ICO, JFIF, JPE, JPEG, JPG, JXR, PNG, RLE, TIF, TIFF, WDP, WMF
  • Простая установка и настройка
  • Многоязычная поддержка. Простой механизм для перевода программы на любой язык
  • Поддержка Адресной книги (Контакты Windows)
  • Проверка на наличие новых версий программы
  • Функции резервного копирования и восстановления
  • Выборочное сохранение настроек и данных пользователя при переустановке программы
  • Поддержка Юникод
  • Полная совместимость с визуальными стилями операционной системы
  • Русскоязычный интерфейс**
  • Руководство пользователя на русском языке**

Примечания

  • (* : Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, Enterprise или Datacenter Edition, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем. Будьте внимательны при покупке многолинейных лицензий.
  • (** : Файлы поддержки русского языка устанавливаются только при использовании русскоязычного инсталлятора (не поставляются со стандартной версией на английском языке).


Системные требования

Установка Fax Voip FSP ››

Поддерживаемые платформы*

  • Windows 11
  • Windows 10, Windows 10 64-bit
  • Windows Server 2022, Windows Server 2019, Windows Server 2016
  • Windows 8.1, Windows 8.1 64-bit, Windows Server 2012 R2 **
  • Windows 8, Windows 8 64-bit, Windows Server 2012 **
  • Windows 7, Windows 7 64-bit, Windows Server 2008 R2 **

Дополнительные системные требования

  • Intel-совместимый компьютер с 32-битным или 64-битным (x64) процессором
  • Microsoft.NET Framework 4.5 или более поздний
  • Служба факсов Windows (Факсы и сканирование Windows) - обязательно
  • Средство просмотра фотографий Windows, желательно
  • Adobe Acrobat Reader 11, Reader DC 2023 или более ранние версии, желательно
  • Acrobat Wrapper v.11.2.0.51 или более поздние версии (чтобы использовать PDF файлы в качестве вложений e-mail с функцией почта-на-факс), желательно
  • IrfanView Software (для просмотра факсов в формате SFF), желательно

Fax – совместимое программное обеспечение

  • Служба факсов Windows (Факсы и сканирование Windows)

Рекомендуемые операторы VOIP

  • YouMagic (МТТ) (поддержка T.38)
  • Телфин (поддержка T.38)
  • Мультифон (Мегафон) (только факс поверх кодека G.711)
  • T38FAX (США, поддержка T.38)
  • CALLCentric (США, поддержка T.38)
  • babyTEL (США/Канада, поддержка T.38)
  • MondoTalk (Австралия, поддержка T.38)
  • DellMont (Betamax) : VoipBuster , Nonoh и другие (только факс поверх кодека G.711, качество сильно зависит от страны)

SIP PBX – совместимое программное обеспечение

  • Axon PBX
  • 3CX VOIP Phone System (Enterprise Edition)

H.323 – совместимое программное обеспечение

  • GNU Gatekeeper
  • SoLink Control Server

Требования к сети

  • Сетевое подключение локального компьютера к SIP или H.323 серверу

Примечания

  • (* : Компания FaxVoip Software не дает никаких гарантий и не несет никакой ответственности, если программа Fax Voip FSP не будет работать правильно, будучи установленной на Виртуальную машину любого типа. В случае возникновения специфических проблем при подобных установках, техническая поддержка не предоставляется.
  • (** : Ограниченная поддержка. Некоторые функции могут не работать или работать неправильно. Операционные системы Windows 7 и Windows 8/8.1 больше не поддерживаются корпорацией Майкрософт.
  • (*** : Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, Enterprise или Datacenter Edition, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем. Будьте внимательны при покупке многолинейных лицензий.


Удаление предыдущей версии

Установка Fax Voip FSP ››

Установщик Fax Voip FSP автоматически проверяет, не установлен ли Fax Voip FSP и какая версия Fax Voip FSP установлена, и предлагает удалить Fax Voip FSP перед началом новой установки. Таким образом, нет необходимости отдельно запускать стандартную процедуру деинсталляции.

Чтобы сохранить предыдущие настройки Fax Voip FSP, а также файлы, созданные в процессе работы программы, следуйте инструкциям главы Удаление программного обеспечения Fax Voip FSP настоящего справочного руководства. Если вы подозреваете, что ваша конфигурация повреждена по какой-то причине, вы должны удалить предыдущие настройки. Кроме того, до удаления или переустановки программы, вы можете сохранить текущие параметры и файлы , что позволит сохранить, а в дальнейшем восстановить ваши параметры и файлы.

При обновлении с версии 3.1.1 или более ранней, настройки функции Уведомления о доставке на e-mail не могут быть импортированы из старой версии. В Fax Voip FSP версии 3.2.1 эта функция заменена методом маршрутизации Уведомления о доставке по электронной почте .


Microsoft .NET Framework 4.5

Microsoft .NET Framework 4.5 или более поздней версии

Установка Fax Voip FSP ››

Основные модули Fax Voip FSP написаны на языке C/C ++ и на самом деле не используют Microsoft .Net Framework. Все необходимые компоненты среды выполнения библиотек C++, установлены во всех поддерживаемых операционных системах по умолчанию.

Для работы графического интерфейса пользователя (GUI) и некоторых других модулей требуется установка Microsoft .Net Framework 4.5 или более поздней версии.

Microsoft .Net Framework 4.8 (совместимый с .Net Framework 4.5) включен в Windows 11 и Windows Server 2022. Установка .NET Framework для этих операционных систем не требуется.

Microsoft .Net Framework 4.6-4.8 (совместимый с .Net Framework 4.5) включен в Windows 10, Windows Server 2019 и Windows Server 2016. Установка .NET Framework для этих операционных систем не требуется. Установленная версия .Net Framework зависит от версии Windows 10, подробнее см. Версии и зависимости платформы .NET Framework .

Microsoft .Net Framework 4.5.1 (совместимый с .Net Framework 4.5) включен в Windows 8.1 и Windows Server 2012R2. Установка .NET Framework для этих операционных систем не требуется.

Microsoft .Net Framework 4.5 включен в Windows 8 и Windows Server 2012. Установка .NET Framework для этих операционных систем не требуется.

При установке на компьютер с Windows 7 или Windows Server 2008R2, для нормальной работы Fax Voip FSP требуется, чтобы Microsoft .NET Framework 4.5 или более поздней версии был установлен на вашем компьютере. Вам следует убедиться, что Microsoft .NET Framework 4.5 уже установлен и установить его при необходимости. Это может быть сделано перед установкой программы Fax Voip FSP или в процессе установки.

Для проверки необходимости установки .NET Framework 4.5

1. Из меню Пуск выберите Панель управления. В Панели управления выберите Программы, а затем нажмите Удаление программы.

2. В окне Удаление или изменение программы пролистайте список приложений, чтобы увидеть, есть ли в нем Microsoft .NET Framework 4.5 или более поздней версии.

3. Закройте окно.

Установка .NET Framework 4.5 в ручном режиме

Вы можете скачать веб-установщик Microsoft .NET Framework 4.5 с web-сайта Fax Voip FSP.

1. Перейдите на веб-сайт Fax Voip FSP на страницу загрузки .

2. Найдите и воспользуйтесь следующей ссылкой:

Microsoft .Net Framework 4.5 dotNetFx45_Full_setup.exe 982КБ

3. После того как вы скачаете установочный файл, запустите его и установите .NET Framework 4.5 на ваш компьютер. Заметим, что установку следует осуществлять от имени Администратора.

Установка .NET Framework через Центр обновления Windows

Microsoft рекомендует производить установку или обновление .NET Framework через Центр обновления Windows. Чтобы установить или обновить .NET Framework 4.5 на вашем компьютере с Windows 7 или Windows Server 2008R2, выполните следующие шаги:

1. Из меню Пуск выберите Все программы, а затем нажмите Центр обновления Windows.

2. На странице Центр обновления Windows нажмите Поиск обновлений чтобы найти все доступные обновления.

3. После завершения поиска, нажмите на ссылку Важных обновлений:... доступны в панели Загрузка и установка обновлений для компьютера.

4. Выберите обновление Microsoft .NET Framework 4.5 (4.5.1, 4.5.2...) как показано на рисунке ниже, а затем нажмите OK.

5. На следующей странице нажмите кнопку Установить обновления.

6. Программа Центр обновления Windows автоматически загрузит и установит выбранные обновления.

7. После установки .NET Framework 4.5, рекомендуется повторить процедуру обновления для получения последней версии .NET Framework со всеми исправлениями и дополнениями. На странице Центр обновления Windows нажмите Поиск обновлений.

8. По окончании поиска, отметьте обновления, касающиеся пакета Microsoft .NET Framework 4.5 а затем нажмите кнопку OK.

9. На следующей странице нажмите кнопку Установить обновления.

10. Программа Центр обновления Windows автоматически загрузит и установит выбранные обновления.

Установка .NET Framework при запуске программы установки

При установке на компьютер с Windows 7 или Windows Server 2008R2, установщик Fax Voip T.38 Модем автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена. Если Microsoft .NET Framework 4.5 не установлен, программа установки предложит установить Microsoft .NET Framework.

Выберите один из предлагаемых вариантов и нажмите Далее:

Установить .NET Framework 4.5 и продолжить установку (рекомендовано)

При выборе этой опции, запускается программа установки Microsoft .NET Framework 4.5, включенная в установочный пакет Fax Voip T.38 Модем. Примите условие лицензионного соглашения и нажмите кнопку Установить. Следует учесть, что все необходимые компоненты загружаются с веб-сайта Microsoft в процессе установки и это может занять значительное время.

По завершению установки .NET Framework 4.5, вы сможете продолжить установку Fax Voip T.38 Модем.

Открыть Windows Update для загрузки и установки последней версии .NET Framework

При выборе этой опции, открывается окно Windows Update. Установите последнюю версию Microsoft .NET Framework через Windows Update как описано выше. По завершению установки .NET Framework 4.5, вам следует запустить установщик Fax Voip T.38 Модем повторно.

Примечания

  • Требуемая версия Microsoft .NET Framework уже включена в Windows 11, Windows 10, Windows 8/8.1, Windows Server 2022, Windows Server 2019, Windows Server 2016 и Windows Server 2012/2012R2. Установка .NET Framework для этих операционных систем не требуется.
  • В Windows 7 или Windows Server 2008R2, установщик Fax Voip FSP автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена, и предлагает утановить правильную версию, если она не установлена.


Запуск программы установки

Установка Fax Voip FSP ››

Чтобы установить Fax Voip FSP, следуйте инструкциям ниже:

1. Запустите файл setup.exe с установочного диска Fax Voip FSP или ZIP архива.

2. При установке на компьютер с Windows 7 или Windows Server 2008R2, установщик Fax Voip FSP автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена. Если Microsoft .NET Framework 4.5 не установлен, программа установки предложит установить Microsoft .NET Framework, подробнее см. главу Microsoft .NET Framework 4.5 настоящего справочного руководства.

3. Программа установки Fax Voip FSP автоматически проверяет, не установлен ли уже Fax Voip FSP и какая версия Fax Voip FSP установлена, и предлагает удалить Fax Voip FSP перед началом новой установки. Для продолжения установки нажмите Далее. При переустановке или обновлении, вы можете выбрать, какие предыдущие настройки и файлы, созданные в процессе работы программы должны быть сохранены, подробнее см. в главе Удаление программного обеспечения Fax Voip FSP настоящего справочного руководства.

Дождитесь окончания удаления предыдущей версии.

4. В окне, сообщающем о готовности начать установку Fax Voip FSP, нажмите Далее.

5. Далее запускается основной Мастер установки Fax Voip FSP.

6. Нажмите Далее. Следуйте инструкциям мастера. На странице Все готово для начала установки нажмите Установить.

7. Программа установки проверяет, установлена ли Служба факсов Windows на вашем компьютере и выводит соответствующее диалоговое окно, если не установлена. Чтобы установить Службу факсов Windows, нажмите OK. Чтобы установить Службу факсов Windows вручную, см. главу Установка службы факсов настоящего справочного руководства. Если вы устанавливаете Службу факсов Windows после установки Fax Voip FSP, не забудьте зарегистрировать Fax Voip FSP со службой факсов, см. главу Регистрация провайдера службы факсов настоящего справочного руководства.

8. В Windows 11 и поздних версиях Windows 10, компонент Факсы и сканирование Windows всегда установлен и не может быть удален в Компонентах Windows. В Windows 10 (ранние версии), Windows 8/8.1 и Windows 7, программа установки Fax Voip T.38 Модем автоматически установит компонент Факсы и сканирование Windows.

9. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2, программа установки Fax Voip FSP автоматически установит роль Факс-сервера.

10. В Windows 2012/2012R2 и Windows 2008R2, программа установки Fax Voip FSP дополнительно устанавливает компонент Возможности рабочего стола, если он не установлен.

11. Программа установки Fax Voip FSP автоматически настраивает Службу Fax Voip FSP и Службу факсов Windows, а затем запускает службы. В процессе настройки, Служба факсов Windows может быть перезапущена несколько раз. Подробности см. в главе Регистрация провайдера службы факсов настоящего справочного руководства.

12. В заключительном окне Мастера установки Fax Voip FSP выберите Да, перезагрузить компьютер сейчас, а затем нажмите Готово.

Примечания

  • Перезагрузка операционной системы после установки Fax Voip FSP не всегда необходима. Тем не менее, не рекомендуется игнорировать этот шаг, поскольку некоторые функции могут не работать должным образом непосредственно после установки.


Настройка Fax Voip FSP

Установка Fax Voip FSP ››

При первом запуске Fax Voip FSP, Панель управления Fax Voip FSP должна появиться на экране. После установки программы и перезагрузки компьютера, Fax Voip FSP обычно запускается автоматически. Если по каким-либо причинам этого не произошло, вы можете запустить Fax Voip FSP вручную. Для этого вы можете воспользоваться ярлыком Fax Voip FSP на рабочем столе.

При первом запуске Панели управления Fax Voip FSP открывается вкладка Учетные записи SIP.

Чтобы настроить Fax Voip FSP для работы по протоколу SIP, следуйте инструкциям в разделе Настройка линии SIP .

Чтобы настроить Fax Voip FSP для работы по протоколу H.323, следуйте инструкциям в разделе Настройка линии H.323 .


Настройка линии SIP

Установка Fax Voip FSP ›› Настройка Fax Voip FSP ››

В данной главе показано, как быстро настроить Fax Voip FSP для работы с SIP провайдером на примере Российского провайдера IP-телефонии YouMagic (проект оператора МТТ ), который качественно поддерживает передачу факсов по T.38, а также предоставляет прямые телефонные номера в Москве и некоторых других городах, что удобно с точки зрения организации входящей факсимильной связи с использованием Fax Voip FSP. Другим примером SIP провайдера с поддержкой T.38 является Телфин . Аудио факс (факс поверх кодека G.711) поддерживается в таких сетях как Мультифон (проект оператора сотовой связи Мегафон ) и VoipBuster (либо его аналоги). С примерами подключения к конкретным SIP операторам вы можете ознакомиться в главе Примеры настройки с операторами VOIP настоящего справочного руководства.

Для настройки Fax Voip FSP, выполните следующие шаги:

1. В дереве Панели управления Fax Voip FSP нажмите IP-телефония.

2. Поставьте флажок у параметра Включить SIP.

3. (Опционально). В поле Сервер STUN введите имя STUN сервера, если это необходимо в силу особенностей вашей сети или рекомендовано вашим SIP провайдером. (Примеры: 'stun.voipbuster.com', 'stun.sipnet.ru', 'sip.mtt.ru',...).

4. Нажмите кнопку <Применить>.

5. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите SIP.

6. В полях Интерфейс SIP/UDP и Интерфейс SIP/TCP, выберите из списка или введите адреса сетевых интерфейсов для прослушивания SIP запросов через UDP и TCP. В полях для указания порта, введите номера портов. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Во избежание конфликтов, при выборе номера порта, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP. По умолчанию, Fax Voip FSP использует порт 5069 для UDP и TCP. Если вы не планируете использовать SIP через TCP, вы можете снять галочку у параметра Включить SIP через TCP.

7. Нажмите кнопку <Применить>.

8. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

9. Чтобы добавить Учетную запись SIP, нажмите Добавить.

10. В окне Учетная запись SIP, введите ваше имя пользователя (SIP-ID) и пароль, соответственно в поля Имя пользователя и Пароль.

.

11. В поле Сервер регистрации, введите имя или IP-адрес SIP сервера регистрации. Может также содержать номер порта. Если сервер регистрации использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.voipbuster.com', 'voip.mtt.ru', 'sip.telphin.com:5068', '192.168.0.5:5065', ...).

12. (Опционально). В поле Прокси-сервер введите имя или IP-адрес SIP прокси-сервера, используемого для регистрации. Может также содержать номер порта. Если используется порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.myproxy.com', 'voice.telphin.com:5068', '192.168.1.3:5065', ...).

13. (Опционально). Нажмите кнопку <Подробно>.

14. (Опционально). При необходимости заполните поля Имя для авторизации, Домен/Realm и SIP контакт URL. Заметим, что обычно следует оставлять эти поля пустыми. Неправильные данные в этих полях могут привести к проблемам при осуществлении SIP регистрации и при входящих вызовах.

15. В поле Таймаут регистрации измените значение таймаута (если это необходимо). По умолчанию используется таймаут 180 секунд.

16. При необходимости выберите Транспорт. По умолчанию используется SIP через UDP. Заметим, что SIP через TCP может не поддерживаться на стороне вашего SIP провайдера.

17. Нажмите кнопку <OK> чтобы зафиксировать изменения.

18. Ваша Учетная запись SIP будет отображена в Списке учетных записей SIP. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP.

19. Вам будет предложено создать правило для исходящих вызовов. Нажмите кнопку <Да>, чтобы создать правило по умолчанию.

20. Будет отображена вкладка Маршрутизация исходящих VOIP вызовов. Правило по умолчанию означает, что все исходящие вызовы маршрутизируются с использованием первой Учетной записи SIP без преобразования номера с поддержкой как T.38, так и аудио (факс поверх кодека G.711) режимов факса.

21. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите Входящие маршруты. Будет отображена вкладка Маршрутизация входящих VOIP вызовов. Убедитесь, что в настройках присутствует правило, обрабатывающее входящие вызовы SIP (правило по умолчанию создается в процессе установки Fax Voip FSP). Правило по умолчанию для входящих SIP вызовов означает, что все входящие вызовы из любой SIP сети будут маршрутизированы через Службу факсов Windows с поддержкой T.38.

22. Состояние регистрации вашей Учетной записи SIP будет отображено в столбце Статус регистрации в Списке учетных записей SIP. Если настройки выполнены правильно, вы увидите сообщение 'Зарегистрирован'.


Настройка линии H.323

Установка Fax Voip FSP ›› Настройка Fax Voip FSP ››

В данной главе показано, как быстро настроить Fax Voip FSP для работы по H.323. Большинство провайдеров, предоставляющих услуги IP-телефонии по протоколу H.323, используют аутентификацию пользователя по его IP-адресу. Для настройки Fax Voip FSP в этом случае обычно достаточно выбрать вариант работы Не использовать гейткипер и указать имя или IP-адрес узла H.323 вашего поставщика услуг в поле Шлюз H.323 при создании правила Маршрутизации исходящих VOIP вызовов.

В некоторых случаях может потребоваться регистрация на H.323 гейткипере. Для настройки Fax Voip FSP в этом случае необходимо выбрать вариант работы Использовать гейткипер, указать IP-адрес гейткипера и выбрать опцию Набор номера через гейткипер при создании правила Маршрутизации исходящих VOIP вызовов. При регистрации на гейткипере может потребоваться H.235 аутентификация с логином и паролем. На рисунках ниже используется пример такого подключения по H.323 c авторизацией по логину и паролю. Использование H.235 аутентификации удобно для случая динамического IP-адреса компьютера.

Для настройки Fax Voip FSP, выполните следующие шаги:

1. В дереве Панели управления Fax Voip FSP нажмите IP-телефония.

2. Поставьте флажок у параметра Включить H.323.

3. (Опционально). В поле Сервер STUN введите имя STUN сервера, если это необходимо в силу особенностей вашей сети или рекомендовано вашим H.323 провайдером. (Примеры: 'stun.voipbuster.com', 'stun.sipnet.ru', 'sip.mtt.ru',...).

4. Нажмите кнопку <Применить>.

5. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите H.323.

6. В поле Интерфейс H.323, выберите из списка или введите адрес сетевого интерфейса для прослушивания H.323 запросов. В поле для указания порта, введите номер порта. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Во избежание конфликтов, при выборе номера порта, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по H.323. По умолчанию, Fax Voip FSP использует порт 1722.

7. Сделайте необходимые настройки параметров Включить Fast Start и Включить H.245 Tunneling, согласно требованиям вашей H.323 сети.

8. Добавьте ваш H.323 телефонный номер в список Номера телефонов. Для добавления номера нажмите кнопку <Добавить>. Телефонные номера, заданные в этом списке, используются в процессе регистрации с H.323 гейткипером (список телефонных номеров на которые возможны входящие звонки). Во время исходящего вызова H.323, верхний номер из этого списка будет передан удаленной стороне как Caller ID Number.

9. Нажмите кнопку <Применить>.

10. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите H.323, затем нажмите Гейткипер.

11. Сделайте необходимые настройки нижеперечисленных параметров:

Режим гейткипера

Не использовать гейткипер (по умолчанию)

В этом режиме Fax Voip FSP функционирует как независимый H.323 узел и не регистрируется на H.323 гейткипере. Все входящие H.323 вызовы должны быть маршрутизированы непосредственно на IP-адрес и порт на котором работает Fax Voip FSP. Этот режим предпочтителен в случае когда H.323 провайдер использует ваш IP-адрес для идентификации (наиболее распространенный метод привязки используемый для аутентификации).

Использовать гейткипер

В этом режиме Fax Voip FSP должен быть зарегистрирован на H.323 гейткипере.

Поиск гейткипера

В этом режиме Fax Voip FSP способен найти H.323 гейткипер автоматически. Опция полезна при регистрации на гейткипере расположенном в вашей локальной сети.

Адрес

IP-адрес или имя сервера где находится H.323 гейткипер.

Время жизни

Продолжительность времени (в секундах) в течении которого действительна регистрация на H.323 гейткипере. Заметим, что этот параметр может быть переопределен самим гейткипером в процессе регистрации.

H.235 аутентификация

Поставьте галочку если для регистрации на гейткипере необходима аутентификация. Аутентификация осуществляется согласно стандарта H.235 и MD5 алгоритма хэширования.

Логин

H.235 логин для авторизации.

Пароль

H.235 пароль для авторизации.

12. Чтобы иметь возможность совершать исходящие H.323 вызовы, необходимо создать правила Маршрутизации исходящих VOIP вызовов. Заметим, что Fax Voip FSP не создает правила для исходящих H.323 вызовов автоматически. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите Исходящие маршруты.

13. Для добавления нового правила Маршрутизации исходящих VOIP вызовов нажмите Добавить.

14. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в области Маршрутизировать вызов, в группе VOIP протокол, выберите опцию H.323. Выберите вариант Шлюз H.323 и задайте имя или IP-адрес H.323 узла, на который следует маршрутизировать H.323 вызовы. Либо выберите вариант Набор номера через гейткипер, чтобы маршрутизировать вызовы через H.323 гейткипер. Нажмите кнопку <OK>.

15. На рисунке ниже все исходящие вызовы будут маршрутизированы через H.323 гейткипер. Нажмите кнопку <Применить> чтобы сохранить правила Маршрутизации исходящих VOIP вызовов.

16. В дереве Панели управления Fax Voip FSP нажмите IP-телефония, затем нажмите Входящие маршруты. Будет отображена вкладка Маршрутизация входящих VOIP вызовов. Убедитесь, что в настройках присутствует правило, обрабатывающее входящие вызовы H.323 (правило по умолчанию создается в процессе установки Fax Voip FSP). Правило по умолчанию для входящих H.323 вызовов означает, что все входящие вызовы из любой H.323 сети будут маршрутизированы через Службу факсов Windows с поддержкой T.38.

17. Если используется регистрация на H.323 гейткипере, состояние H.323 регистрации будет отображаться на вкладке Гейткипер. Если настройки выполнены правильно, вы увидите сообщение 'Зарегистрирован' в области Статус гейткипера.


Установка Средства просмотра фотографий в Windows Server

Установка Средства просмотра фотографий в Windows Server 2012R2

Установка Fax Voip FSP ››

Для просмотра факсов (файлы формата TIFF), обычно используется приложение Средство просмотра фотографий Windows. Обратите внимание, что это приложение обычно не устанавлено по умолчанию в Windows Server 2012/2012R2 и Windows Server 2008R2.

Чтобы установить Средство просмотра фотографий Windows в Windows Server 2012/2012R2 или Windows Server 2008R2, вам необходимо установить компонент Возможности рабочего стола.

1. Переключитесь на панель Поиск, наберите диспетчер серверов, а затем нажмите Диспетчер серверов.

2. В Диспетчере серверов, выберите Добавить роли и компоненты.

3. В окне Мастера добавления ролей и компонентов, на странице Выбор компонентов, поставьте флажок около компонента Возможности рабочего стола.

4. Нажмите Далее, а затем нажмите Установить.

5. По завершении установки, Windows уведомит вас о необходимости перезагрузки сервера для завершения процесса установки.

6. После перезагрузки убедитесь, что Средство просмотра фотографий Windows установлено. На компьютере с Windows Server 2012R2, щелкните правой кнопкой мыши кнопку Пуск, а затем нажмите Выполнить. В окне Выполнить, введите следующую команду: rundll32 shimgvw.dll,ImageView_Fullscreen. Нажмите OK. Приложение Средство просмотра фотографий Windows должно запуститься.


Диспетчер Fax Voip FSP

  • Запуск диспетчера Fax Voip FSP
  • Опции меню в системном трее


Запуск диспетчера Fax Voip FSP

Диспетчер Fax Voip FSP ››

Чтобы запустить Диспетчер Fax Voip FSP, в меню Пуск выберите Fax Voip FSP, а затем нажмите Fax Voip FSP.

Кроме того, вы можете воспользоваться ярлыком Fax Voip FSP на рабочем столе.


Опции меню в системном трее

Диспетчер Fax Voip FSP ››

Когда Fax Voip FSP запущен, его значок отображается в системном трее.

Для доступа к меню Fax Voip FSP, щелкните значок Fax Voip FSP в системном трее правой кнопкой мыши и появится всплывающее меню, изображенное на рисунке ниже:

В меню доступны следующие команды:

Отправить факс

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Факсы и сканирование Windows

Нажмите чтобы запустить Факсы и сканирование Windows.

Диспетчер службы факсов

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Адресная книга (Контакты Windows)

Нажмите чтобы открыть Адресную книгу (Контакты Windows).

Панель управления Fax Voip FSP

Нажмите чтобы открыть Панель управления Fax Voip FSP . Вы также можете сделать двойной щелчок по значку в системном трее.

Перезапуск служб

Нажмите чтобы перезапустить службу факсов и Службу Fax Voip FSP. Эта команда также перезапускает подсистему почты (службу Fax Voip FSP Mail).

Справка

Нажмите чтобы открыть файл справки.

О программе

Вывод сведений о программе, ее версии и авторских правах.

Выход

Нажмите чтобы закрыть Диспетчер Fax Voip FSP.


Панель управления Fax Voip FSP

Fax Voip провайдер для службы факсов Windows - панель управления

Чтобы открыть Панель управления Fax Voip FSP, нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

Следующие основные кнопки всегда доступны в нижней части Панели управления Fax Voip FSP:

<Применить>

Используйте эту кнопку чтобы сохранить изменения ваших настроек. Обратите внимание, что все изменения вступают в силу немедленно.

<OK>

Используйте эту кнопку чтобы сохранить изменения ваших настроек и закрыть Панель управления Fax Voip FSP. Обратите внимание, что все изменения вступают в силу немедленно. Если Служба Fax Voip FSP не запущена, она запускается. Если Служба факсов Windows не запущена, она запускается.

<Отмена>

Используйте эту кнопку чтобы закрыть Панель управления Fax Voip FSP без сохранения изменений в настройках.

<Справка>

Используйте эту кнопку для вызова справочной системы.

В строке состояния отображается следующая информация:

Служба факсов Windows

Текущее состояние Службы факсов Windows. Следует понимать, что служба факсов может автоматически останавливаться, если она не используется приложениями и ни одно факсимильное устройство не настроено на прием факсов.

Служба Fax Voip FSP

Текущее состояние Службы Fax Voip FSP.

SIP регистрация

Текущее состояние SIP регистраций (Зарегистрирован или Не зарегистрирован). Этот индикатор работает при запущенной Службе Fax Voip FSP и включенной опции Включить SIP (более детально см. в главе Параметры IP-телефонии ). Этот индикатор также показывает текущее число успешных SIP регистраций (первая цифра) и полное количество записей в списке учетных записей SIP (вторая цифра).

Команды ленты в Панели управления Fax Voip FSP

Следующие команды доступны в меню Файл:

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Отправить пробный факс (Ctrl + T)

Нажмите чтобы создать и отправить пробную страницу факса с использованием принтера факсов.

Факсы и сканирование Windows (Ctrl + W)

Нажмите чтобы запустить Факсы и сканирование Windows.

Диспетчер службы факсов (Ctrl + M)

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Перезапустить службу факсов Windows

Нажмите чтобы перезапустить службу факсов.

Перезапустить

Нажмите чтобы перезапустить службу факсов.

Запустить

Нажмите чтобы запустить службу факсов.

Остановить

Нажмите чтобы остановить службу факсов.

Перезапустить службу Fax Voip FSP

Нажмите чтобы перезапустить Службу Fax Voip FSP.

Перезапустить

Нажмите чтобы перезапустить Службу Fax Voip FSP.

Запустить

Нажмите чтобы запустить Службу Fax Voip FSP.

Остановить

Нажмите чтобы остановить Службу Fax Voip FSP.

Перезапуск всех служб (Ctrl + R)

Нажмите чтобы перезапустить службу факсов и Службу Fax Voip FSP. Эта команда также перезапускает подсистему почты (службу Fax Voip FSP Mail).

Справка (F1)

Нажмите чтобы открыть файл справки. Для вызова справочной системы вы также можете использовать кнопку Вызов справки, расположенную в правом верхнем углу ленты.

Выход (Ctrl + X)

Нажмите чтобы закрыть Панель управления Fax Voip FSP.

Быстрый доступ к настройкам Fax Voip FSP

Параметры IP-телефонии

Нажмите чтобы перейти к настройкам общих параметров IP-телефонии , таких как STUN сервер, отображаемое имя и имя пользователя по умолчанию.

Параметры SIP

Задайте порт для приема SIP запросов. Укажите дефолтные параметры прокси-сервера для исходящих SIP вызовов, если это необходимо. Подробности см. в главах Параметры SIP и Параметры прокси-сервера настоящего справочного руководства.

Учетные записи SIP

Нажмите чтобы сконфигурировать учетные записи SIP для регистрации на сервере поставщика услуг IP-телефонии.

Параметры T.38 факса (SIP)

Нажмите чтобы сконфигурировать режим включения T.38. Укажите, должно ли приложение принудительно отправлять T.38 ре-инвайт. Подробности см. в главе Параметры T.38 факса (SIP) настоящего справочного руководства.

Маршрутизация исходящих VOIP вызовов

Нажмите чтобы сконфигурировать маршрутизацию исходящих вызовов . Должно присутствовать хотя бы одно правило.

Маршрутизация входящих VOIP вызовов

Нажмите чтобы сконфигурировать маршрутизацию входящих вызовов . Должно присутствовать хотя бы одно правило.

Аудио кодеки

Выберите аудио кодеки , которые будут использоваться приложением. Должен быть выбран хотя бы один аудио кодек.

Журналы приложения

В случае проблем воспользуйтесь журналами отладки. Подробности см. в главе Журналы Fax Voip FSP настоящего справочного руководства.

Лицензии

Просмотр и управление вашими лицензиями .

Следующие команды доступны на вкладке Главная:

Факсы и сканирование Windows

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Факсы и сканирование Windows (Ctrl + W)

Нажмите чтобы запустить Факсы и сканирование Windows.

Служба факсов Windows

Диспетчер службы факсов (Ctrl + M)

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Запустить

Нажмите чтобы запустить службу факсов.

Остановить

Нажмите чтобы остановить службу факсов.

Перезапустить

Нажмите чтобы перезапустить службу факсов.

Принтер факсов

Принтер факсов (Ctrl + P)

Отображение свойств принтера факсов.

Отправить пробный факс (Ctrl + T)

Нажмите чтобы создать и отправить пробную страницу факса с использованием принтера факсов.

Служба Fax Voip FSP

Перезапуск всех служб (Ctrl + R)

Нажмите чтобы перезапустить службу факсов и Службу Fax Voip FSP. Эта команда также перезапускает подсистему почты (службу Fax Voip FSP Mail).

Запустить

Нажмите чтобы запустить Службу Fax Voip FSP.

Остановить

Нажмите чтобы остановить Службу Fax Voip FSP.

Перезапустить

Нажмите чтобы перезапустить Службу Fax Voip FSP.

Большинство команд вкладки Главная также доступны в меню Файл.

Следующие команды доступны на вкладке Вид:

Области

Панель навигации

Нажмите чтобы отобразить или скрыть Панель навигации.

Строка состояния

Нажмите чтобы отобразить или скрыть строку состояния.

Лента

Снимите флажок чтобы скрыть ленту (Ribbon). Подтвердите переключение в классический режим. Требуется перезапуск Панели управления Fax Voip FSP.

Строка меню

Поставьте флажок чтобы отобразить классическое меню. Подтвердите переключение в классический режим. Требуется перезапуск Панели управления Fax Voip FSP.

Текущее представление

Стиль панели навигации

Эта опция позволяет вам выбрать тематический стиль Панели навигации в соответствии с темами предоставляемыми операционной системой. Просто выберите желаемый стиль из выпадающего списка.

Стиль HTML справки

Эта опция позволяет вам выбрать тематический стиль панели инструментов окна справки в соответствии с темами предоставляемыми операционной системой. Просто выберите желаемый стиль из выпадающего списка.

Цвета ленты

Стандартные цвета

Выберите этот вариант, чтобы применить стандартную цветовую схему (определяется операционной системой).

Настроить цвета

Выберите этот вариант, чтобы настроить цвета ленты. Обратите внимание, что эта опция не работает правильно в Windows 11, Windows 10 версии 1809 или более поздней, Windows Server 2022 и в Windows Server 2019.

Цвет фона

Выберите основной цвет фона для настраиваемой ленты.

Цвет выделения

Выберите основной цвет выделения для настраиваемой ленты (только Windows 7).

Цвет текста

Выберите основной цвет текста для настраиваемой ленты.

Вид по умолчанию

Восстановить умолчания

Используйте эту опцию для восстановления внешнего вида по умолчанию для Панели управления Fax Voip FSP и ее отдельных компонентов. Эта функция не изменяет ваши SIP, H.323 и прочие параметры.

Большинство команд вкладки Вид также доступны в контекстном меню Панели навигации.

Следующие команды доступны на вкладке Инструменты:

Переустановить Fax Voip FSP

Переустановить компоненты Fax Voip FSP

Нажмите, чтобы восстановить компоненты службы факсов Windows, переустановить службу Fax Voip FSP и зарегистрировать провайдера Fax Voip и Расширение маршрутизации Fax Voip FSP для работы со службой факсов. Подробности см. в главе Регистрация Fax Voip провайдера для службы факсов Windows (FSP) со службой факсов настоящего справочного руководства.

Контакты Windows

Контакты Windows

Нажмите, чтобы открыть папку Контакты.

Создать контакт

Добавление нового контакта.

Найти людей

Поиск людей в контактах пользователя.

Адресная книга

Нажмите, чтобы открыть Адресную книгу (Контакты Windows).

Архивация и восстановление

Экспорт настроек

Создание резервной копии текущей конфигурации.

Импорт настроек

Восстановление настроек из резервной копии.

Некоторые команды ленты содержатся в так называемых контекстных вкладках, которые доступны в зависимости от контекста. Эти команды описаны отдельно в соответствующих главах.

Панель быстрого доступа представляет собой небольшую, настраиваемую панель инструментов, которая содержит набор команд, заданных приложением или выбранных пользователем.

По умолчанию, Панель быстрого доступа расположена в строке заголовка окна Панели управления Fax Voip FSP, но также может быть настроена для отображения под лентой. В дополнение к отображенным командам, Панель быстрого доступа также включает в себя настраиваемое выпадающее меню, которое содержит полный набор команд Панели быстрого доступа по умолчанию (скрытых или отображенных), а также параметры настройки Панели быстрого доступа и ленты. Почти все элементы управления ленты могут быть добавлены на Панель быстрого доступа через контекстное меню, как показано на рисунке ниже.


IP-телефония

Параметры IP-телефонии

Панель управления Fax Voip FSP ››

Отображаемое имя

Введенный здесь текст отображается на дисплее удаленного телефона или факс-аппарата когда Fax Voip FSP совершает исходящий вызов (Caller ID NAME). По умолчанию используется имя 'FaxVoip FSP'. Отображаемое имя может быть переопределено в настройках SIP, H.323 и Маршрутизации исходящих VOIP вызовов.

Имя пользователя

По умолчанию, Fax Voip FSP использует Имя пользователя заданное в этом поле. По умолчанию используется имя 'FaxVoip'. Значение из этого поля используется как значение по умолчанию для параметров Имя пользователя SIP и H.323 ID, но может быть переопределено в настройках SIP и H.323. Имя пользователя также может быть переопределено через SIP регистрацию и в настройках Маршрутизации исходящих VOIP вызовов. Если Имя пользователя состоит только из цифр и не переопределено использованием прочих настроек, то на удаленной стороне оно будет определяться как Caller ID NUMBER.

Voip протоколы

По крайней мере одна из нижеследующих опций должна быть выбрана:

Включить SIP

Выберите эту опцию если Вы планируете использовать Fax Voip FSP для работы в SIP сетях.

Включить H.323

Выберите эту опцию если Вы планируете использовать Fax Voip FSP для работы в сетях H.323.

Параметры сети

Диапазон портов RTP

Диапазон RTP портов используемый Fax Voip FSP. По умолчанию используются порты от 5000 до 5998.

Сервер STUN (и порт)

Адрес и порт используемого STUN сервера. Может быть полезен при использовании NAT для определения вашего IP-адреса. Эта опция может быть полезна как при работе через SIP так и при работе по H.323. Заметим, что STUN порт по умолчанию 3478. Если STUN сервер использует порт 3478, вы можете не вводить ':3478' в этом поле.

Примеры:

stun.sipnet.ru

stun.voipbuster.com

stun.yourstunserver.com:3478


SIP

Панель управления Fax Voip FSP ›› IP-телефония ››

  • Параметры SIP
  • Параметры прокси-сервера
  • Учетные записи SIP
  • Параметры T.38 факса (SIP)
  • Параметры аудио факса (SIP)


Параметры SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ››

Отображаемое имя SIP

По умолчанию, в качестве Отображаемого имени SIP используется Отображаемое имя, заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить. Отображаемое имя SIP используется только при работе по протоколу SIP. Введенный здесь текст отображается на дисплее удаленного телефона или факс-аппарата когда Fax Voip FSP совершает исходящий вызов (Caller ID NAME). Отображаемое имя SIP может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Использовать отображаемое имя по умолчанию

Чтобы иметь возможность изменить Отображаемое имя SIP, снимите галочку. Если эта опция включена, то в качестве Отображаемого имени SIP будет использовано Отображаемое имя, заданное в Параметрах IP-телефонии.

Имя пользователя SIP

По умолчанию в качестве Имени пользователя SIP используется Имя пользователя заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить. Имя пользователя SIP используется только при работе по протоколу SIP. Если Имя пользователя SIP состоит из одних цифр, при прямом исходящем SIP вызове без использования SIP регистрации и аутентификации, Имя пользователя SIP будет передано удаленной стороне как Caller ID NUMBER. Имя пользователя SIP может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Использовать имя пользователя по умолчанию

Чтобы иметь возможность изменить Имя пользователя SIP, снимите галочку. Если эта опция включена, то в качестве Имени пользователя SIP будет использовано Имя пользователя заданное в Параметрах IP-телефонии.

Интерфейс SIP/UDP (и порт)

Интерфейс/порт для прослушивания SIP/UDP запросов. Все входящие вызовы SIP через UDP должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для SIP через UDP используется порт 5060. Если вы используете порт 5060, можно не вводить '5060' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP.

Примеры:

192.168.0.2

* : 5070

Включить SIP через UDP

Включите эту опцию если предполагается использование SIP через UDP.

Интерфейс SIP/TCP (и порт)

Интерфейс/порт для прослушивания SIP/TCP запросов. Все входящие вызовы SIP через TCP должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для SIP через TCP используется порт 5060. Если вы используете порт 5060, можно не вводить '5060' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP/TCP.

Включить SIP через TCP

Включите эту опцию если предполагается использование SIP через TCP.


Параметры прокси-сервера

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ››

Заметим что при использовании нижеописанного функционала, глобальные параметры прокси-сервера будут автоматически использоваться со всеми SIP регистрациями и всеми исходящими SIP вызовами, за исключением случаев когда заданы индивидуальные параметры прокси-сервера для отдельно взятой SIP регистрации или правила Маршрутизации исходящих VOIP вызовов, которое применяется к исходящему вызову. Неаккуратное использование глобальных параметров прокси-сервера может привести к проблемам с набором номера (для исходящих вызовов) и к проблемам прохождения голоса или факса (для входящих вызовов). Таким образом, для неопытных пользователей мы не рекомендуем включать опцию Использовать прокси-сервер. Если ваш SIP провайдер требует (или поддерживает) использование Прокси-сервера, мы рекомендуем задавать параметры прокси-сервера непосредственно для SIP регистрации (Учетная запись SIP) и в правилах Маршрутизации исходящих VOIP вызовов ассоциированных с этим провайдером. Однако, эта опция может быть полезна для продвинутых пользователей. Например, если вы не хотите использовать функцию SIP регистрация, вы можете ввести данные авторизации на сервере вашего SIP провайдера в Параметрах прокси-сервера (Имя пользователя, Пароль, Адрес SIP сервера) и использовать эти настройки для осуществления исходящих вызовов через сеть вашего провайдера.

Использовать прокси-сервер

Поставьте галочку если вы хотите задать и использовать глобальные настройки прокси-сервера.

Адрес прокси (и порт)

IP-адрес или имя прокси-сервера. При использовании UDP или TCP транспорта, по умолчанию используется порт 5060. Номер порта можно не вводить если используется порт по умолчанию. Заметим что в случае использования глобального прокси-сервера, этот прокси-сервер будет использоваться со всеми SIP регистрациями и всеми правилами Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Примеры:

sip.outboundserver.com

myoutbound.com : 5080

192.168.0.5 : 5075

SIP через UDP

Выберите чтобы использовать SIP через UDP. Эта опция используется по умолчанию. Заметим что в случае использования глобальных Параметров прокси-сервера, выбранный транспорт будет применяться ко всем SIP регистрациям и всем правилам Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

SIP через TCP

Выберите чтобы использовать SIP через TCP. Если вы планируете использовать TCP, пожалуйста спросите у вашего SIP провайдера поддерживает ли он SIP через TCP. Заметим что в случае использования глобальных Параметров прокси-сервера, выбранный транспорт будет применяться ко всем SIP регистрациям и всем правилам Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Имя пользователя (не обязательно)

Имя пользователя для авторизации с прокси.

Пароль (не обязательно)

Пароль для авторизации с прокси.


Учетные записи SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ››

  • Параметры учетных записей SIP
  • Добавление или изменение учетной записи SIP
  • Управление учетными записями SIP
  • Тестирование учетной записи SIP
  • Параметры восстановления SIP регистрации


Параметры учетных записей SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

Fax Voip FSP поддерживает работу с несколькими Учетными записями SIP и позволяет осуществлять Одновременные SIP регистрации. Вы можете работать одновременно с несколькими SIP серверами, и (или) регистрировать несколько Учетных записей SIP на одном и том же сервере. Функция Одновременных SIP регистраций позволяет принимать входящие вызовы из различных SIP сетей. Для осуществления исходящих вызовов с использованием различных Учетных записей SIP, следует сделать соответствующие настройки правил Маршрутизации исходящих VOIP вызовов. Fax Voip FSP поддерживает SIP регистрацию через UDP и через TCP. Максимальное поддерживаемое количество Учетных записей SIP не ограничено.

Список учетных записей SIP содержит следующую информацию:

имя@сервер

Учетная запись пользователя на сервере SIP провайдера. Состоит из двух частей: имя пользователя (SIP-ID) и имя (IP-адрес) сервера. Вторая часть также может содержать номер порта. Если сервер использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде.

Прокси-сервер (опционально)

Отображает адрес SIP прокси-сервера, который используется с текущей учетной записью (если задан). Имя (IP-адрес) прокси-сервера также может содержать номер порта. Если прокси-сервер использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. Значок => перед именем прокси-сервера сообщает о том, что при текущей регистрации используются глобальные параметры прокси, заданные в Параметрах прокси-сервера . Если для данной регистрации задан индивидуальный прокси-сервер, то всегда будет использоваться UDP транспорт. Чтобы работать с прокси-сервером по TCP, необходимо использовать глобальные Параметры прокси-сервера .

Транспорт

Отображает транспорт (UDP или TCP) используемый для текущей учетной записи при регистрации. По умолчанию, этот же транспорт используется при входящих вызовах через текущую регистрацию.

Статус регистрации

Это поле отображает состояние SIP регистрации для текущей учетной записи (OK либо описание ошибки). Этот индикатор работает когда Служба Fax Voip FSP запущена.

Имя для авторизации (опционально)

Имя пользователя для авторизации.

Домен (опционально)

Домен учетной записи.

Контакт (опционально)

Позволяет переопределить поле Contact в SIP сообщении REGISTER. В зависимости от настроек SIP сервера позволяет перенаправить входящий вызов на другой номер или даже на другой SIP узел.

Таймаут

Таймаут SIP регистрации. По умолчанию 180 секунд.

Параметры восстановления

Дополнительные опции для принудительного восстановления SIP регистрации, в случае если она нестабильна по каким-либо причинам. См. также главу Параметры восстановления SIP регистрации настоящего справочного руководства.

Force=да

Fax Voip FSP принудительно отправляет запрос REGISTER с заданной периодичностью.

Force=нет

Функция принудительного восстановления отключена.

Timeout=...мин

Интервал между отправкой REGISTER, в минутах. Может быть установлен от 1 до 999 минут.

Check= да

Fax Voip FSP не отправляет REGISTER если аккаунт зарегистрирован.

Check = нет

Принудительный запрос отправляется независимо от текущего статуса регистрации.

UnReg= да

Fax Voip FSP пытается отменить текущую регистрацию перед отправкой принудительного запроса.

UnReg= нет

Fax Voip FSP отправляет REGISTER без отправки предварительной команды на отмену регистрации.

Delay=...сек

Интервал между отправкой команд отмены регистрации и REGISTER, в секундах. Может быть установлен от 1 до 10 секунд.

Если SIP регистрация не может быть осуществлена согласно текущей конфигурации программы, Fax Voip FSP не загружает и игнорирует учетную запись при запуске приложения.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip FSP не загружает и игнорирует все учетные записи SIP.
  • Если опция Включить SIP через UDP отключена (SIP через UDP не используется, см. Параметры SIP ), Fax Voip FSP не загружает и игнорирует учетные записи которые используют SIP через UDP.
  • Если опция Включить SIP через TCP отключена (SIP через TCP не используется, см. Параметры SIP ), Fax Voip FSP не загружает и игнорирует учетные записи которые используют SIP через TCP.

Учетные записи SIP, которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом.

В контекстной вкладке Учетные записи SIP, на ленте доступны следующие команды:

Учетные записи SIP

Добавить (Ctrl + N)

Нажмите чтобы добавить Учетную запись SIP.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранной Учетной записи SIP. Может быть полезно при создании большого количества схожих записей. Чтобы отредактировать вновь созданную запись, выберите ее и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения Учетной записи SIP. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одной или более Учетной записи SIP. Удаляемая запись должна быть выделена.

Удалить (Del)

Нажмите для удаления одной или более Учетной записи SIP. Удаляемая запись должна быть выделена.

Удалить все записи

Нажмите чтобы удалить все записи в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений Учетных записей SIP. Одна из записей должна быть выделена.

Вверх (Ctrl + U)

Переместить выбранный элемент вверх.

Вниз (Ctrl + D)

Переместить выбранный элемент вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Регистрация

Используйте эти команды, чтобы вручную зарегистрироваться на SIP сервере или отменить регистрацию. Одна или несколько записей должны быть выделены. См. также главу Тестирование учетной записи SIP настоящего справочного руководства.

Зарегистрировать

Нажмите чтобы зарегистрировать учетную запись на SIP сервере.

Зарегистрировать

Нажмите чтобы зарегистрировать учетную запись на SIP сервере.

Отменить регистрацию

Нажмите чтобы отменить регистрацию на SIP сервере.

Большинство команд из контекстной вкладки Учетные записи SIP также доступны в контекстном меню списка.


Добавление/изменение учетной записи SIP

Добавление (или изменение) учетной записи SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Чтобы добавить Учетную запись SIP, нажмите Добавить. Для редактирования существующей Учетной записи SIP, выделите ее и нажмите Править (или сделайте двойной щелчок мышью на выбранной записи).

4. В окне Учетная запись SIP, нажмите кнопку <Подробно>, чтобы просматривать и редактировать дополнительные параметры.

5. Сделайте необходимые настройки для выбранной (или новой) Учетной записи SIP.

Параметры учетной записи SIP

Имя пользователя

Идентификатор SIP аккаунта. Обычно это ваше Имя пользователя или телефонный номер.

Пароль

Пароль для авторизации.

Сервер регистрации

IP-адрес или имя SIP сервера регистрации. Может также содержать номер порта. Если сервер регистрации использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.voipbuster.com', 'sip.telphin.com:5068', 'voip.mtt.ru', '192.168.0.2:5065', ...).

Прокси-сервер (опционально)

IP-адрес или имя SIP прокси-сервера, используемого для регистрации. Может также содержать номер порта. Если используется порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.myproxy.com', 'voice.telphin.com:5068', '192.168.0.5:5065', ...). Если Прокси-сервер задан в этом поле, Fax Voip FSP всегда осуществляет процедуру регистрации используя SIP через UDP. Чтобы работать с прокси-сервером с использованием TCP транспорта, следует использовать глобальные Параметры прокси-сервера .

Имя для авторизации (опционально)

Имя пользователя для авторизации. Обычно не требуется.

Домен/Realm (опционально)

Домен учетной записи. Обычно не требуется.

SIP контакт URL (опционально)

Позволяет переопределить поле Contact в SIP сообщении REGISTER. Обычно не требуется. В зависимости от настроек SIP сервера позволяет перенаправить входящий вызов на другой номер или даже на другой SIP узел. Если вы не понимаете назначение этого параметра, оставьте поле пустым. Неправильные данные в этом поле могут привести к проблемам при осуществлении SIP регистрации и при входящих вызовах.

Таймаут регистрации

Таймаут SIP регистрации. По умолчанию 180 секунд.

Транспорт

При использовании Параметров прокси-сервера по умолчанию, будет использован транспорт, заданный в параметрах прокси-сервера. Если в поле Прокси-сервер задан индивидуальный (для текущей регистрации) прокси-сервер, будет использоваться SIP через UDP. Заметим, что TCP может не поддерживаться на стороне вашего сервера или SIP провайдера.

SIP через UDP (по умолчанию)

Используйте эту опцию для осуществления регистрации и приема входящих SIP вызовов через UDP.

SIP через TCP

Используйте эту опцию для осуществления регистрации и приема входящих SIP вызовов через TCP.

Восстановление SIP регистрации

Используйте только если регистрация не является стабильной по каким-либо причинам. Подробнее см. в главе Параметры восстановления SIP регистрации настоящего справочного руководства.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Используйте команды Вверх и Вниз чтобы изменить порядок предпочтений Учетных записей SIP.

8. Заметим, что непосредственно после добавления или редактирования Учетной записи SIP, Статус регистрации для этой учетной записи не будет отображаться или может быть отображен неправильно.

9. Вы можете протестировать учетную запись перед тем как сохранять ее. См. главу Тестирование учетной записи SIP настоящего справочного руководства.

10. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Все изменения вступают в силу немедленно.

Статус SIP регистрации для каждой Учетной записи SIP отображается в столбце Статус регистрации. Суммарная информация отображается в строке состояния.


Управление учетными записями SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Чтобы изменить порядок предпочтений Учетных записей SIP, используйте команды Вверх и Вниз. Одна из Учетных записей SIP должна быть выделена.

4. Для удаления одной или более Учетной записи SIP, выберите запись и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Все изменения вступают в силу немедленно.


Тестирование учетной записи SIP

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

Учетные записи SIP регистрируются при запуске Службы Fax Voip FSP. Также вы можете вручную зарегистрироваться на SIP сервере или отменить регистрацию. Этот функционал можно использовать в следующих случаях:

  • Временно приостановить, а затем возобновить регистрацию для одной или более учетных записей SIP.
  • Вручную восстановить регистрацию в случае потери регистрации, если по какой-либо причине она не может быть восстановлена автоматически.
  • Для тестирования регистрации непосредственно после добавления или редактирования учетной записи SIP (перед сохранением настроек).
  • Для исследования поведения SIP сервера при конфигурировании опции Принудительная регистрация. См. также главу Параметры восстановления SIP регистрации настоящего справочного руководства.

Рассматриваемые функции не могут быть использованы при остановленной Службе Fax Voip FSP. Обратите внимание, что эти функции используют данные, отображаемые в данный момент в списке учетных записей SIP, а не уже сохраненные настройки. Именно поэтому вы можете использовать их для тестирования вновь созданных или только что отредактированных учетных записей без нажатия кнопки <Применить>.

Чтобы зарегистрировать учетную запись SIP

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Убедитесь в том, что Служба Fax Voip FSP запущена. Для запуска Службы Fax Voip FSP нажмите Запустить на вкладке Главная ленты.

4. Выберите одну или более записей в списке учетных записей.

5. Нажмите Зарегистрировать либо выберите команду Зарегистрировать из выпадающего меню кнопки Зарегистрировать.

Чтобы отменить регистрацию

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Убедитесь в том, что Служба Fax Voip FSP запущена. Для запуска Службы Fax Voip FSP нажмите Запустить на вкладке Главная ленты.

4. Выберите одну или более записей в списке учетных записей.

5. Выберите команду Отменить регистрацию из выпадающего меню кнопки Зарегистрировать.


Параметры восстановления SIP регистрации

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

При нормальной эксплуатации Fax Voip FSP регистрирует учетные записи SIP при старте приложения, а затем регистрация поддерживается штатными методами путем отправки запроса REGISTER в соответствии с Таймаутом регистрации.

В некоторых случаях регистрация может быть нестабильной. В этой ситуации программа периодически не может принимать входящие вызовы. Типичные причины: слишком большой интервал обновления (см. Таймаут регистрации), нестабильное подключение к сети интернет, какие-либо временные проблемы на стороне поставщика SIP услуг и т.п. Даже в случае потери регистрации, как правило, Fax Voip FSP должен автоматически восстановить регистрацию через некоторое время. Однако, в отдельных случаях и по различным причинам этого не происходит, и программа остается незарегистрированной. Обычно вы можете устранить проблемы путем изменения Таймаута регистрации, указав в настройках Прокси-сервер и/или Сервер STUN и т.д.

К сожалению, в некоторых случаях несовместимости, все эти усилия могут не привести к желаемым результатам.

Описанные ниже опции позволяют решить проблему нестабильной SIP регистрации, независимо от причин ее возникновения. Fax Voip FSP периодически отправляет принудительный запрос REGISTER и восстанавливает SIP Регистрацию без необходимости перезапуска всего приложения. Рассматриваемые параметры настраиваются независимо друг от друга для различных учетных записей SIP. Обратите внимание, что это вспомогательный механизм. Нет необходимости использовать его, если проблемы со стабильностью регистрации отсутствуют.

Настройка параметров восстановления SIP регистрации

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Выделите учетную запись и нажмите Править (или сделайте двойной щелчок мышью на выбранной записи).

4. В окне Учетная запись SIP, нажмите кнопку <Подробно>.

5. Сделайте необходимые настройки в области Восстановление SIP регистрации.

Восстановление SIP регистрации

Принудительная регистрация каждые ... мин.

Если эта опция включена, Fax Voip FSP принудительно отправляет запрос REGISTER с заданной периодичностью. Интервал между запросами задается в минутах и может быть установлен от 1 до 999 минут. Не следует задавать слишком малый интервал, если в этом нет необходимости.

Регистрировать только если не зарегистрирован

Если опция включена, Fax Voip FSP не отправляет REGISTER если аккаунт зарегистрирован. Если опция выключена, запрос всегда передается независимо от текущего статуса регистрации.

Отменять текущую регистрацию

Поставьте флажок, чтобы отменить текущую регистрацию перед отправкой принудительного запроса. Реальная необходимость этой команды зависит от конкретного сервера, как правило не требуется.

Задержка между командами ... сек.

Интервал между отправкой команд отмены регистрации и REGISTER, в секундах. Может быть установлен от 1 до 10 секунд. Интервал в 1 секунду обычно достаточен. За исключением случая, когда сервер отвечает с большой задержкой.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Все изменения вступают в силу немедленно.

Примечания

  • Чтобы восстановить регистрацию вручную, см. главу Тестирование учетной записи SIP настоящего справочного руководства.


Параметры T.38 факса

Параметры T.38 факса (SIP)

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ››

Передача T.38 факса

Приведенные ниже параметры применяются к исходящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих T.38 факсов. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для исходящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Перекл. в T.38 после ... секунд

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CED сигнала от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 только при получении T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации исходящих VOIP вызовов.

Переключение в T.38 при получении CED

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CED сигнал). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 только при получении T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации исходящих VOIP вызовов.

Прием T.38 факса

Приведенные ниже параметры применяются к входящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих T.38 факсов. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для входящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Перекл. в T.38 после ... секунд

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CNG сигнала от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 немедленно после ответа на входящий вызов (0 секунд). Эту опцию можно переопределить в настройках Маршрутизации входящих VOIP вызовов.

Переключение в T.38 при получении CNG

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CNG сигнал). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации входящих VOIP вызовов.

T.38 UDPTL Redundancy

T.38 предоставляет возможности для устранения последствий потери пакетов за счет избыточности данных (T.38 redundancy). При отправке пакета к нему прикрепляются ноль, один, два, три или даже большее число ранее отправленных пакетов. (Спецификация не накладывает ограничений.) Это требует увеличенной пропускной способности сети (что все еще намного меньше чем если не использовать T.38) но при этом позволяет принимающему шлюзу реконструировать полную последовательность пакетов, даже при достаточно высоком уровне потери пакетов. Величина избыточности (T.38 redundancy) соответствует тому, сколько предыдущих пакетов повторяется с каждым пакетом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

Параметры T.38 redundancy для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.

Примечания

  • Отправка и получение факсов через VOIP по протоколу T.38 возможно только при наличии поддержки T.38 на стороне VoIP оператора. Мы рекомендуем спросить вашего SIP провайдера, поддерживают ли они T.38.
  • Чтобы использовать T.38, вам необходимо включить поддержку T.38 в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Большое количество параметров, отвечающих за переключение в режим T.38 (отправка T.38 ре-инвайт или ожидание T.38 ре-инвайта от противоположной стороны) позволяет настроить Fax Voip FSP при использовании с различными T.38 шлюзами.
  • В случае неудачного переключения на T.38, Fax Voip FSP всегда переключается обратно в режим аудио факса (факс поверх кодека G.711).
  • Все параметры, описанные в данном разделе, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры, описанные в данном разделе, применяются только к факсовым вызовам SIP. Для настройки аналогичных параметров для случая H.323, см. главу Параметры T.38 факса (H.323) настоящего справочного руководства.


Параметры аудио факса

Параметры аудио факса (SIP)

Панель управления Fax Voip FSP ›› IP-телефония ›› SIP ››

Передача аудио факса

Приведенные ниже параметры применяются к исходящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих аудио факсов. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для исходящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Прием аудио факса

Приведенные ниже параметры применяются к входящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих аудио факсов. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для входящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Примечания

  • Все параметры, описанные в данном разделе, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры, описанные в данном разделе, применяются только к факсовым вызовам SIP. Для настройки аналогичных параметров для случая H.323, см. главу Параметры аудио факса (H.323) настоящего справочного руководства.


H.323

Панель управления Fax Voip FSP ›› IP-телефония ››

  • Параметры H.323
  • H.323 гейткипер
  • Параметры T.38 факса (H.323)
  • Параметры аудио факса (H.323)


Параметры H.323

Панель управления Fax Voip FSP ›› IP-телефония ›› H.323 ››

Отображ. имя H.323

По умолчанию, в качестве Отображаемого имени H.323 используется Отображаемое имя, заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить. Отображаемое имя H.323 используется только при работе по протоколу H.323. Введенный здесь текст отображается на дисплее удаленного телефона или факс-аппарата когда Fax Voip FSP совершает исходящий вызов (Caller ID NAME). Отображаемое имя H.323 может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Использовать отображаемое имя по умолчанию

Чтобы иметь возможность изменить Отображаемое имя H.323, снимите галочку. Если эта опция включена, то в качестве Отображаемого имени H.323 будет использовано Отображаемое имя, заданное в Параметрах IP-телефонии.

H.323 ID

H.323 ID используется для идентификации Fax Voip FSP в качестве узла H.323 в процессе взаимодействия с другими элементами H.323 сети, в частности с H.323 гейткипером. По умолчанию в качестве H.323 ID Fax Voip FSP использует Имя пользователя заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить.

Использовать имя пользователя по умолчанию

Чтобы иметь возможность изменить H.323 ID, снимите галочку. Если эта опция включена, то в качестве H.323 ID будет использовано Имя пользователя заданное в Параметрах IP-телефонии.

Интерфейс H.323 (и порт)

Интерфейс/порт для прослушивания H.323 запросов. Все входящие H.323 вызовы должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для H.323 используется порт 1720. Если вы используете порт 1720, можно не вводить '1720' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по H.323.

Примеры:

192.168.0.2

* : 1722

Номера телефонов

Список Номера телефонов содержит цифровые телефонные номера ассоциированные с Fax Voip FSP с точки зрения H.323. Если H.323 ID состоит только из цифр, Fax Voip FSP автоматически добавляет его в список телефонных номеров. Если используется регистрация на H.323 гейткипере, используется H.235 аутентификация и H.235 логин состоит только из цифр, Fax Voip FSP автоматически добавляет H.235 логин в список телефонных номеров. Телефонные номера заданные в этом списке используются в процессе регистрации с H.323 гейткипером (список телефонных номеров на которые возможны входящие звонки). Во время исходящего вызова H.323, верхний номер из этого списка будет передан удаленной стороне как Caller ID NUMBER. Caller ID NUMBER может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов (поле Имя пользователя).

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтений телефонных номеров. Перед тем как использовать эти кнопки, вы должны выделить один из номеров.

<Добавить>

Используйте эту кнопку для добавления в список нового номера телефона.

<Удалить>

Используйте эту кнопку для удаления из списка одного или более номера телефона. Перед тем как удалять номера, вы должны выделить один или более номеров, которые вы хотите удалить.

Заметим, что вы также можете выполнить любое из вышеперечисленных действий, выбрав соответствующую команду из контекстного меню списка.

Включить Fast Start

Для включения режима Fast Start поставьте галочку. Для выключения режима снимите галочку.

Включить H.245 Tunneling

Для включения режима H.245 tunneling поставьте галочку. Для выключения режима снимите галочку.


H.323 гейткипер

Панель управления Fax Voip FSP ›› IP-телефония ›› H.323 ››

Режим гейткипера

Не использовать гейткипер (по умолчанию)

В этом режиме Fax Voip FSP функционирует как независимый H.323 узел и не регистрируется на H.323 гейткипере. Все входящие H.323 вызовы должны быть маршрутизированы непосредственно на IP-адрес и порт на котором работает Fax Voip FSP. Этот режим предпочтителен в случае когда H.323 провайдер использует ваш IP-адрес для идентификации (наиболее распространенный метод привязки используемый для аутентификации).

Использовать гейткипер

В этом режиме Fax Voip FSP должен быть зарегистрирован на H.323 гейткипере.

Поиск гейткипера

В этом режиме Fax Voip FSP способен найти H.323 гейткипер автоматически. Опция полезна при регистрации на гейткипере расположенном в вашей локальной сети.

Адрес

IP-адрес или имя сервера где находится H.323 гейткипер.

Время жизни

Продолжительность времени (в секундах) в течении которого действительна регистрация на H.323 гейткипере. Заметим, что этот параметр может быть переопределен самим гейткипером в процессе регистрации.

H.235 аутентификация

Поставьте галочку если для регистрации на гейткипере необходима аутентификация. Аутентификация осуществляется согласно стандарта H.235 и MD5 алгоритма хэширования.

Логин

H.235 логин для авторизации.

Пароль

H.235 пароль для авторизации.

Статус гейткипера

В этой области показывается состояние регистрации на H.323 гейткипере. Этот индикатор работает когда Служба Fax Voip FSP запущена, опция Включить H.323 включена (более детально см. в главе Параметры IP-телефонии ), выбран режим Использовать гейткипер и гейткипер действительно найден. Следующая информация может быть отображена:

      • Имя гейткипера
      • Подключение / Зарегистрирован / Ошибка (с описанием)
      • Время регистрации на гейткипере


Параметры T.38 факса

Параметры T.38 факса (H.323)

Панель управления Fax Voip FSP ›› IP-телефония ›› H.323 ››

Передача T.38 факса

Приведенные ниже параметры применяются к исходящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих T.38 факсов. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для исходящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Перекл. в T.38 после ... секунд

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CED сигнала от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 только при получении T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации исходящих VOIP вызовов.

Переключение в T.38 при получении CED

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CED сигнал). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 только при получении T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации исходящих VOIP вызовов.

Прием T.38 факса

Приведенные ниже параметры применяются к входящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих T.38 факсов. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для входящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Перекл. в T.38 после ... секунд

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CNG сигнала от противоположной стороны. По умолчанию, Fax Voip FSP переключается в T.38 немедленно после ответа на входящий вызов (0 секунд). Эту опцию можно переопределить в настройках Маршрутизации входящих VOIP вызовов.

Переключение в T.38 при получении CNG

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CNG сигнал). Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Эту опцию можно переопределить в настройках Маршрутизации входящих VOIP вызовов.

T.38 UDPTL Redundancy

T.38 предоставляет возможности для устранения последствий потери пакетов за счет избыточности данных (T.38 redundancy). При отправке пакета к нему прикрепляются ноль, один, два, три или даже большее число ранее отправленных пакетов. (Спецификация не накладывает ограничений.) Это требует увеличенной пропускной способности сети (что все еще намного меньше чем если не использовать T.38) но при этом позволяет принимающему шлюзу реконструировать полную последовательность пакетов, даже при достаточно высоком уровне потери пакетов. Величина избыточности (T.38 redundancy) соответствует тому, сколько предыдущих пакетов повторяется с каждым пакетом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

Параметры T.38 redundancy для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.

Примечания

  • Отправка и получение факсов через VOIP по протоколу T.38 возможно только при наличии поддержки T.38 на стороне VoIP оператора. Мы рекомендуем спросить вашего H.323 провайдера, поддерживают ли они T.38.
  • Чтобы использовать T.38, вам необходимо включить поддержку T.38 в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Большое количество параметров, отвечающих за переключение в режим T.38 (отправка T.38 ре-инвайт или ожидание T.38 ре-инвайта от противоположной стороны) позволяет настроить Fax Voip FSP при использовании с различными T.38 шлюзами.
  • В случае неудачного переключения на T.38, Fax Voip FSP всегда переключается обратно в режим аудио факса (факс поверх кодека G.711).
  • Все параметры, описанные в данном разделе, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры, описанные в данном разделе, применяются только к факсовым вызовам H.323. Для настройки аналогичных параметров для случая SIP, см. главу Параметры T.38 факса (SIP) настоящего справочного руководства.


Параметры аудио факса

Параметры аудио факса (H.323)

Панель управления Fax Voip FSP ›› IP-телефония ›› H.323 ››

Передача аудио факса

Приведенные ниже параметры применяются к исходящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих аудио факсов. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для исходящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов.

Прием аудио факса

Приведенные ниже параметры применяются к входящим факсам:

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих аудио факсов. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Макс. скорость

Максимальная скорость передачи факса для входящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Данный параметр может быть переопределен в настройках Маршрутизации входящих VOIP вызовов.

Примечания

  • Все параметры, описанные в данном разделе, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры, описанные в данном разделе, применяются только к факсовым вызовам H.323. Для настройки аналогичных параметров для случая SIP, см. главу Параметры аудио факса (SIP) настоящего справочного руководства.


Исходящие маршруты

Маршрутизация исходящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ››

В зависимости от набираемого номера исходящие вызовы могут быть маршрутизированы через различные SIP или H.323 сервера, направлены на H.323 гейткипер или осуществлены с использованием различных Учетных записей SIP (SIP регистраций). Максимальное поддерживаемое количество правил Маршрутизации исходящих VOIP вызовов не ограничено.

Fax Voip FSP всегда проверяет правила Маршрутизации исходящих VOIP вызовов, начиная с правила # 1. Вызов маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Если не существует ни одного правила, которому удовлетворяет вызов, вызов не может быть осуществлен. Чтобы осуществить исходящий вызов, вы должны иметь хотя бы одно правило в таблице Маршрутизации исходящих VOIP вызовов.

В зависимости от набираемого номера исходящие вызовы могут быть маршрутизированы через

  • SIP сеть
  • H.323 сеть

Правила различных типов (SIP или H.323) выделяются различными цветами в таблице Маршрутизации исходящих VOIP вызовов.

Исходящие вызовы SIP могут быть маршрутизированы

  • на SIP сервер с которым Fax Voip FSP зарегистрирован, вызов будет осуществлен с использованием выбранной Учетной записи SIP (с учетом Имени пользователя SIP)
  • на IP-адрес (имя SIP сервера) не ассоциированный ни с одной Учетной записью SIP

Исходящие вызовы H.323 могут быть маршрутизированы

  • на H.323 гейткипер с которым Fax Voip FSP зарегистрирован
  • на IP-адрес (имя H.323 сервера) не ассоциированный с H.323 гейткипером

Следующие правила преобразования могут применяться к набираемому номеру:

  • заданный префикс может быть добавлен к телефонному номеру
  • заданное количество первых цифр номера может быть удалено

Следующие параметры вызова и настройки факса могут быть установлены или переопределены в отдельно взятом правиле Маршрутизации исходящих VOIP вызовов:

  • UDP или TCP транспорт может быть выбран для SIP вызовов
  • Схема Tel URI может быть использована (только с исходящими SIP вызовами)
  • Имя пользователя (Caller ID Number)
  • Отображаемое имя (Caller ID Name)
  • Режим факса (T.38, факс поверх G.711)
  • Максимальная скорость передачи факса
  • ECM (коррекция ошибок)
  • Принудительное переключение в режим T.38 по таймеру
  • Принудительное переключение в режим T.38 при обнаружении CED сигнала факса
  • T.38 Redundancy
  • Голосовое сообщение перед передачей факса

Если в таблице Маршрутизации исходящих VOIP вызовов нет ни одного правила и существует хотя бы одна Учетная запись SIP в Списке учетных записей SIP, Fax Voip FSP автоматически предлагает создать правило по умолчанию для исходящих вызовов когда вы нажимаете кнопку <Применить>.

Правило по умолчанию следующее:

  • Все исходящие вызовы маршрутизируются с использованием первой Учетной записи SIP без преобразования номера с поддержкой как T.38, так и аудио (факс поверх кодека G.711) режимов факса.

Если правила какого-либо типа не могут быть использованы в текущей конфигурации программы, Fax Voip FSP не загружает эти правила при запуске приложения и игнорирует их.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip FSP не загружает и игнорирует правила которые маршрутизируют вызовы в SIP сеть.
  • Если опция Включить SIP через UDP отключена (SIP через UDP не используется, см. Параметры SIP ), Fax Voip FSP не загружает и игнорирует правила которые маршрутизируют вызовы по SIP с использованием UDP транспорта.
  • Если опция Включить SIP через TCP отключена (SIP через TCP не используется, см. Параметры SIP ), Fax Voip FSP не загружает и игнорирует правила которые маршрутизируют вызовы по SIP с использованием TCP транспорта.
  • Если опция Включить H.323 отключена (H.323 не используется, см. Параметры IP-телефонии ), Fax Voip FSP не загружает и игнорирует правила которые маршрутизируют вызовы в H.323 сеть.

Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом в таблице Маршрутизация исходящих VOIP вызовов.

Таблица Маршрутизация исходящих VOIP вызовов содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Если номер =

Задает формат набираемых телефонных номеров, для которых применяется данное правило. Например ' .* ' означает “любой номер”.

SIP/H.323

Указывает будет ли исходящий вызов направлен в SIP или H.323 сеть. В случае SIP, в этом поле указывается используемый транспорт (UDP или TCP) а также будет ли использоваться схема Tel URI в сообщении SIP INVITE.

Набирать номер

Задает правило преобразования набираемого телефонного номера. Например '<NUM>' означает что правило преобразования номера не применяется, '9<NUM>' означает что к номеру будет добавлен префикс – цифра 9, '<NUM-2>' означает что первые 2 цифры номера будут удалены.

Сервер

Отображает имя (IP-адрес) SIP или H.323 сервера на который маршрутизируется звонок.

<GK> означает что вызов будет направлен на H.323 гейткипер. В случае H.323, при использовании регистрации на H.323 гейткипере, следует понимать что исходящие H.323 вызовы на произвольные IP-адреса могут быть запрещены политикой гейткипера.

В случае SIP, в зависимости от того какое Имя Пользователя используется (см. ниже) и некоторых других параметров Fax Voip FSP, поведение может быть различным:

Вариант 1:

1. Сервер = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP существует по крайней мере 1 учетная запись

имя@сервер = '<name>@ sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован с использованием первой Учетной записи SIP, ассоциированной с заданным сервером.

Вариант 2:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP существует учетная запись

имя@сервер = 'NAME@sip.server.com'.

Исходящий вызов будет маршрутизирован с использованием этой Учетной записи SIP 'NAME@sip.server.com'.

Вариант 3:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. Имя сервера совпадает с именем прокси-сервера по умолчанию (см. Параметры прокси-сервера ). Имя пользователя совпадает с именем пользователя для прокси-сервера. Опция Использовать прокси-сервер включена.

Исходящий вызов будет маршрутизирован на прокси-сервер. Имя пользователя и пароль заданные в настройках прокси-сервера могут быть использованы для аутентификации.

Вариант 4:

1. Сервер = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP нет ни одной учетной записи

имя@сервер = '<name>@ sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием Имени пользователя SIP, которое задано в Параметрах SIP (по умолчанию FaxVoip). Этот метод может быть использован если авторизации не требуется.

Вариант 5:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP отсутствует учетная запись

username@registrar = 'NAME@sip.server.com'.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием имени пользователя NAME. Этот метод может быть использован если авторизации не требуется. Если NAME состоит из одних цифр, то это имя обычно передается удаленной стороне как Caller ID NUMBER.

Имя пользователя

В случае SIP, это Имя пользователя SIP (SIP-ID) которое используется с текущим правилом. Обычно совпадает с Именем пользователя одной из Учетных записей SIP. При использовании значения *<по умолчанию>, следует понимать что в этом случае Fax Voip FSP может использовать Имя пользователя заданное в одной из Учетных записей SIP, а может использовать Имя пользователя SIP, заданное в Параметрах SIP (по умолчанию FaxVoip). Различные варианты поведения рассмотрены выше в описании поля Сервер. Имя пользователя, состоящее из одних цифр, обычно передается удаленной стороне как Caller ID NUMBER.

В случае H.323, этот параметр позволяет переопределить используемый по умолчанию Caller ID Number. При использовании *<по умолчанию>, следует понимать что верхний номер из списка Номеров телефонов (см. Параметры H.323 ) будет определен на удаленной стороне как Caller ID Number.

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. В случае SIP, этот параметр переопределяет Отображаемое имя SIP, заданное в Параметрах SIP . В случае H.323, этот параметр переопределяет Отображаемое имя H.323, заданное в Параметрах H.323 . *<> означает, что используется Отображаемое имя SIP или Отображаемое имя H.323, заданное по умолчанию.

Прокси-сервер

Отображает адрес прокси-сервера, который используется при исходящих SIP вызовах (если задан). Не рекомендуется использовать различные прокси-сервера при осуществлении SIP регистрации и для исходящих вызовов, осуществляемых с использованием этой регистрации. Значок "=>" перед именем прокси-сервера указывает на использование прокси-сервера по умолчанию, заданного в Параметрах прокси-сервера .

Режим факса

Отображает Режим факса применяемый к данному правилу. G.711 означает факс поверх G.711. T.38 означает поддержку T.38 при исходящем вызове с использованием данного правила.

Параметры аудио факса

Индивидуальные параметры аудио факса, которые переопределяют общие параметры, заданные в Параметрах аудио факса (SIP) либо в Параметрах аудио факса (H.323) .

Переопределяемые Параметры аудио факса следующие:

MaxRate_out

Максимальная скорость передачи факса для исходящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>Аудио факс=>Передача аудио факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>Аудио факс=>Передача аудио факса=>Макс. скорость” (в случае H.323).

ECM_out (0 – отключено, 1 - включено)

Возможность использовать Коррекцию ошибок (ECM) для исходящих аудио факсов (факс поверх кодека G.711). Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>Аудио факс=>Передача аудио факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>Аудио факс=>Передача аудио факса=>Коррекция ошибок (ECM)” (в случае H.323).

Параметры T.38 факса

Индивидуальные параметры T.38 факса, которые переопределяют общие параметры, заданные в Параметрах T.38 факса (SIP) либо в Параметрах T.38 факса (H.323) .

Переопределяемые Параметры T.38 факса следующие:

T38MaxRate_out

Максимальная скорость передачи факса для исходящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>T.38 факс=>Передача T.38 факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>T.38 факс=>Передача T.38 факса=>Макс. скорость” (в случае H.323).

T38ECM_out (0 – отключено, 1 - включено)

Возможность использовать Коррекцию ошибок (ECM) для исходящих T.38 факсов. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Коррекция ошибок (ECM)” (в случае H.323).

T38SwitchOnTimer_out (Off – отключено, 0-20 – задержка в секундах)

Принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд), для исходящих факсов. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CED сигнала от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 после ... секунд” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 после ... секунд” (в случае H.323).

T38SwitchOnCED_out (0 – отключено, 1 - включено)

Принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CED сигнал) во время отправки факса. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 при получении CED” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 при получении CED” (в случае H.323).

T38Redundancy

T.38 Redundancy в формате I/LS/HS. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>T.38 UDPTL Redundancy” (в случае SIP) или в “H.323=>T.38 факс=>T.38 UDPTL Redundancy” (в случае H.323).

Аудио файл

Аудио файл для проигрывания перед передачей факса, после ответа на исходящий факсовый вызов. Переопределяет настройки по умолчанию, заданные в Параметрах аудио .

В контекстной вкладке Исходящие маршруты, на ленте доступны следующие команды:

Исходящие правила

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило Маршрутизации исходящих VOIP вызовов.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила Маршрутизации исходящих VOIP вызовов. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения правила Маршрутизации исходящих VOIP вызовов. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации исходящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации исходящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил Маршрутизации исходящих VOIP вызовов. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Исходящие маршруты также доступны в контекстном меню списка.


Добавление/изменение правила исходящего вызова

Добавление (или изменение) правил для исходящих вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизации исходящих вызовов, на вкладке Общие, задайте шаблон исходного формата набираемого номера для которого применяется данное правило. Выберите VOIP протокол, SIP или H.323. В случае SIP, в поле Сервер SIP, не забудьте указать имя или IP-адрес SIP сервера (узла SIP), на который следует направить вызов. Вы также можете выбрать транспорт (UDP или TCP) для использования с исходящими SIP вызовами. В случае H.323, в поле Шлюз H.323, не забудьте указать IP-адрес узла H.323, на который следует направить вызов, или выберите опцию Набор номера через гейткипер, чтобы направлять вызовы на H.323 гейткипер. Более подробную информацию можно найти в главе Параметры маршрутизации исходящих VOIP вызовов , в разделе Общие параметры .

5. Сконфигурируйте Параметры факса и Параметры аудио если это необходимо.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Чтобы изменить порядок предпочтений для правил Маршрутизации исходящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

8. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Все изменения вступают в силу немедленно.


Управление правилами исходящих вызовов

Управление правилами для исходящих вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Чтобы изменить порядок предпочтений для правил Маршрутизации исходящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Все изменения вступают в силу немедленно.


Параметры маршрутизации исходящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Маршрутизации исходящих VOIP вызовов.

  • Общие параметры
  • Параметры факса
  • Параметры аудио


Общие параметры

Общие параметры (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Общие параметры

Исходный формат набираемого номера

Этот набор опций позволяет применять правило ко всем, единственному или группе набираемых номеров.

Если номер =

Выберите эту опцию чтобы применять правило ко всем набираемым номерам или к единственному набираемому номеру.

Выберите <любой> чтобы правило применялось ко всем набираемым номерам.

Введите телефонный номер чтобы правило применялось только для этого номера.

Если номер начинается с цифр

Правило применяется к номерам с заданным префиксом.

Правило набора

Этот набор опций позволяет при необходимости преобразовать набираемый номер к требуемому формату.

Набирать номер =

Используйте эту опцию чтобы маршрутизировать вызовы без изменения исходного набираемого номера, либо если вы хотите маршрутизировать все вызовы на заданный номер.

Выберите <NUM> чтобы маршрутизировать вызовы без изменения исходного набираемого номера.

Введите телефонный номер чтобы маршрутизировать все вызовы на этот номер.

Удалить цифры ... Добавить...

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру и (или) удалить из набираемого номера первые несколько цифр или других символов (1-9). При применении опции Удалить цифры к исходному набранному номеру, который содержит символы, отличные от цифр, поведение может быть непредсказуемым (с некоторыми специальными символами). Рекомендуется протестировать перед тем как использовать.

Маршрутизировать вызов

Параметры, заданные в этой области, позволяют маршрутизировать вызов на заданный SIP или H.323 узел. Эти параметры также позволяют вам использовать определенную Учетную запись SIP (SIP регистрацию) для осуществления вызова или маршрутизировать вызов через H.323 гейткипер.

VOIP протокол

SIP

Выберите эту опцию чтобы осуществлять исходящие вызовы с использованием протокола SIP.

Транспорт

В этом поле вы можете выбрать транспорт, который будет использоваться для исходящих SIP вызовов. Выберите SIP через UDP чтобы использовать UDP. Выберите SIP через TCP чтобы использовать TCP. По умолчанию используется UDP. При использовании Параметров прокси-сервера по умолчанию, будет использован транспорт, заданный в параметрах прокси-сервера. Если в поле Прокси-сервер задан индивидуальный (для текущего правила) прокси-сервер, будет использоваться SIP через UDP. Заметим, что TCP может не поддерживаться на стороне вашего сервера или SIP провайдера.

Схема Tel URI

Если эта опция выбрана, Fax Voip FSP будет использовать Tel URI схему при совершении исходящих SIP вызовов. Tel URI схема может быть использована с SIP через UDP и с SIP через TCP. Сообщение SIP INVITE будет отсылаться в следующем формате:

SIP/SDP Request: INVITE tel:74957226655;phone-context=multifon.ru, with session description

Если эта опция отключена, сообщение SIP INVITE будет отсылаться в стандартном формате:

SIP/SDP Request: INVITE sip:74957226655@sipnet.ru, with session description

Заметим, что в случае использования Tel URI схемы, вы не можете задавать номер порта в поле Сервер SIP. Также следует понимать что далеко не каждый SIP сервер способен принимать SIP запросы с использованием Tel URI схемы, поэтому не следует включать данную опцию без необходимости. С другой стороны, насколько нам известно, некоторые сервера требуют использование Tel URI схемы. Именно поэтому мы и добавили такую возможность.

Сервер SIP

Имя или IP-адрес SIP узла или SIP сервера, на который будет маршрутизироваться вызов. Обычно совпадает с Сервером регистрации SIP одной из Учетных записей SIP (SIP регистрацией). Если заданы Учетные записи SIP, имя сервера может быть выбрано из раскрывающегося списка. Заметим, что в случае использования Tel URI схемы, вы не можете задавать номер порта в этом поле.

Прокси-сервер

Адрес прокси-сервера, который используется при исходящих SIP вызовах. Не рекомендуется использовать различные прокси-сервера при осуществлении SIP регистрации и для исходящих вызовов, осуществляемых с использованием этой регистрации. Эта опция переопределяет прокси-сервер по умолчанию, заданный в Параметрах прокси-сервера . Если вы задаете индивидуальный (для текущего правила) прокси-сервер в данном поле, то при осуществлении исходящих вызовов будет использоваться SIP через UDP. Чтобы работать с прокси-сервером по TCP, необходимо использовать глобальные Параметры прокси-сервера .

Имя пользователя

Имя пользователя (SIP-ID) которое используется с текущим правилом. Обычно совпадает с Именем пользователя одной из Учетных записей SIP. Имя пользователя, состоящее из одних цифр, обычно передается удаленной стороне как Caller ID Number. Если в таблице Учетные записи SIP есть записи, в которых Сервер регистрации совпадает с именем сервера заданным в поле Сервер SIP, то Имя пользователя может быть выбрано из раскрывающегося списка.

По умолчанию

Чтобы иметь возможность изменить Имя пользователя, снимите галочку. Если эта опция включена, Fax Voip FSP будет использовать либо Имя пользователя (или SIP-ID) из первой записи в таблице Учетные записи SIP, в которой Сервер регистрации совпадает с именем сервера заданным в поле Сервер SIP, либо Имя пользователя SIP по умолчанию, заданное в Параметрах SIP .

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. Эта опция переопределяет Имя пользователя SIP по умолчанию, заданное в Параметрах SIP .

По умолчанию

Чтобы задать Отображаемое имя, снимите галочку. Если эта опция включена, используется Имя пользователя SIP по умолчанию.

В зависимости от параметров Сервер SIP, Имя пользователя и некоторых других, поведение при исходящих вызовах может быть различным:

Вариант 1:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = "*<по умолчанию>"

3. В Списке учетных записей SIP существует по крайней мере 1 учетная запись

имя@сервер = '<name1>@sip.server.com', где <name1> - любое имя пользователя.

Исходящий вызов будет маршрутизирован с использованием первой Учетной записи SIP, ассоциированной с заданным сервером.

Вариант 2:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP существует учетная запись

имя@сервер = 'NAME@sip.server.com'

Исходящий вызов будет маршрутизирован с использованием этой Учетной записи SIP 'NAME@sip.server.com'.

Вариант 3:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. Имя сервера совпадает с именем прокси-сервера по умолчанию (см. Параметры прокси-сервера ). Имя пользователя совпадает с именем пользователя для прокси-сервера. Опция Использовать прокси-сервер включена.

Исходящий вызов будет маршрутизирован на прокси-сервер. Имя пользователя и пароль заданные в настройках прокси-сервера могут быть использованы для аутентификации.

Вариант 4:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP нет ни одной учетной записи

имя@сервер = '<name>@sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием Имени пользователя SIP, которое задано в Параметрах SIP (по умолчанию FaxVoip). Этот метод может быть использован если авторизации не требуется.

Вариант 5:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP отсутствует учетная запись

имя@сервер = 'NAME@sip.server.com'.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием имени пользователя NAME. Этот метод может быть использован если авторизации не требуется. Если NAME состоит из одних цифр, то это имя обычно передается удаленной стороне как Caller ID NUMBER.

H.323

Выберите эту опцию чтобы осуществлять исходящие вызовы с использованием протокола H.323.

Шлюз H.323

Имя или IP-адрес H.323 узла, на который будет маршрутизироваться вызов. При использовании регистрации на H.323 гейткипере, следует понимать что исходящие H.323 вызовы на произвольные IP-адреса могут быть запрещены политикой гейткипера.

Набор номера через гейткипер

Используйте эту опцию чтобы маршрутизировать вызовы через H.323 гейткипер.

Имя пользователя

Имя пользователя которое используется с текущим правилом. Этот параметр позволяет переопределить используемый по умолчанию Caller ID Number.

По умолчанию

Чтобы иметь возможность изменить Имя пользователя, снимите галочку. Если эта опция включена, верхний номер из списка Номеров телефонов (см. Параметры H.323 ) будет определен на удаленной стороне как Caller ID Number.

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. Эта опция переопределяет Отображаемое имя H.323 по умолчанию, заданное в Параметрах H.323 .

По умолчанию

Чтобы задать Отображаемое имя, снимите галочку. Если эта опция включена, используется Отображаемое имя H.323 по умолчанию.


Параметры факса

Параметры факса (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Параметры факса

Режимы факса

Режимы факса применяемые к текущему правилу.

Факс поверх G.711

Включите эту опцию чтобы отправлять аудио факсы.

T.38 факс

Включите эту опцию чтобы отправлять факсы по протоколу T.38.

Параметры аудио факса поверх G.711

Параметры, задаваемые в этой области, позволяют переопределить параметры передачи аудио факса по умолчанию.

Максимальная скорость

Используйте эту опцию, чтобы изменить максимальную скорость передачи факса для исходящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>Аудио факс=>Передача аудио факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>Аудио факс=>Передача аудио факса=>Макс. скорость” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих аудио факсов (факс поверх кодека G.711). Эта опция переопределяет настройки по умолчанию, заданные в “SIP=>Аудио факс=>Передача аудио факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>Аудио факс=>Передача аудио факса=>Коррекция ошибок (ECM)” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить настройки по умолчанию для Коррекции ошибок (ECM). Если данная опция включена, используются настройки по умолчанию.

Параметры T.38

Параметры, задаваемые в этой области, позволяют переопределить параметры передачи T.38 факса по умолчанию.

Максимальная скорость

Используйте эту опцию, чтобы изменить максимальную скорость передачи факса для исходящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>T.38 факс=>Передача T.38 факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>T.38 факс=>Передача T.38 факса=>Макс. скорость” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для исходящих T.38 факсов. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Коррекция ошибок (ECM)” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить настройки по умолчанию для Коррекции ошибок (ECM). Если данная опция включена, используются настройки по умолчанию.

Перекл. в T.38 после ... секунд

Эта опция отвечает за принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд), для исходящих факсов. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CED сигнала от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 после ... секунд” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 после ... секунд” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить поведение по умолчанию. Если данная опция включена, используются настройки по умолчанию.

Переключение в T.38 при получении CED

Эта опция отвечает за принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CED сигнал) во время отправки факса. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 при получении CED” (в случае SIP) или в “H.323=>T.38 факс=>Передача T.38 факса=>Переключение в T.38 при получении CED” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить поведение по умолчанию. Если данная опция включена, используются настройки по умолчанию.

T.38 Redundancy

Параметры, задаваемые в этой области, позволяют переопределить параметры по умолчанию для SIP T.38 Redundancy или H.323 T.38 Redundancy.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

По умолчанию

Снимите галочку, чтобы изменить параметры по умолчанию для SIP (или H.323) T.38 Redundancy. Если данная опция включена, используются параметры по умолчанию для SIP (или H.323) T.38 Redundancy.


Параметры аудио

Параметры аудио (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip FSP ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Параметры аудио

Аудио файл для проигрывания (WAV файл 8 kHz 16-бит или 8-бит Моно):

Аудио файл для проигрывания перед передачей факса, после ответа на исходящий факсовый вызов. Вы можете выбрать путь к файлу, нажав на кнопку справа от текстового поля. Для передачи через телефонную линию используются WAV (.wav) файлы формата 8 kHz 16-bit Mono либо 8 kHz 8-bit Mono. Пример аудио файла находится в папке *{CommonAppDataFolder}\FaxVoip FSP\Sounds\Fax после установки Fax Voip FSP. По умолчанию используется файл intro_fax_out.wav.

Реплика перед передачей факса

Установите этот флажок, чтобы воспроизводить выбранный аудиофайл перед отправкой факса. Подчеркнем, что использование этой опции не рекомендуется, если не предполагается, что на вызов отвечает человек.

По умолчанию

Снимите галочку, чтобы изменить Параметры аудио , заданные по умолчанию. Если данная опция включена, используются Параметры аудио по умолчанию.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Входящие маршруты

Маршрутизация входящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ››

Функция Маршрутизации входящих VOIP вызовов позволяет устанавливать различные маршруты для входящих вызовов, в зависимости от выполнения тех или иных начальных условий. В зависимости от вызывающего номера (Caller ID), вызываемого номера и прочих условий, входящий вызов может быть маршрутизирован через Службу факсов Windows с поддержкой T.38 или с использованием только режима аудио факса (факс поверх кодека G.711). Максимальное поддерживаемое количество правил Маршрутизации входящих VOIP вызовов не ограничено.

Существует два типа правил:

  • Правила применяемые к входящим SIP вызовам
  • Правила применяемые к входящим H.323 вызовам

Правила различных типов выделяются различными цветами в таблице Маршрутизации входящих VOIP вызовов.

Входящий вызов может быть маршрутизирован на:

  • Службу факсов Windows с поддержкой T.38
  • Службу факсов Windows как аудио факс (факс поверх кодека G.711)

Следующие параметры вызова и настройки факса могут быть установлены или переопределены в отдельно взятом правиле Маршрутизации входящих VOIP вызовов:

  • Режим факса (T.38, факс поверх G.711)
  • Максимальная скорость передачи факса
  • ECM (коррекция ошибок)
  • Принудительное переключение в режим T.38 по таймеру
  • Принудительное переключение в режим T.38 при обнаружении CNG сигнала факса
  • T.38 Redundancy

Fax Voip FSP всегда проверяет правила Маршрутизации входящих VOIP вызовов, начиная с правила # 1. Вызов маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Если не существует ни одного правила, которому удовлетворяет вызов, вызов не может быть осуществлен. Например, если правило # 1 применяется ко всем входящим SIP вызовам ('VOIP вызов откуда' = sip:.*; 'VOIP вызов куда = sip:.*), то все остальные правила # 2, # 3, и т.д. для входящих SIP вызовов никогда не выполнятся ни при каких условиях. Чтобы принимать входящие вызовы заданного типа (SIP или H.323), вы должны иметь хотя бы одно правило для этого типа вызовов в таблице Маршрутизации входящих VOIP вызовов.

Если в таблице Маршрутизации входящих VOIP вызовов нет ни одного правила, Fax Voip FSP автоматически предлагает создать правила для входящих вызовов по умолчанию когда вы нажимаете кнопку <Применить>.

Правила по умолчанию следующие:

  • Все входящие SIP вызовы с префиксом sip: маршрутизируются через Службу факсов Windows с поддержкой T.38
  • Все входящие H.323 вызовы маршрутизируются через Службу факсов Windows с поддержкой T.38

Если правила какого-либо типа не могут быть использованы в текущей конфигурации программы, Fax Voip FSP не загружает эти правила при запуске приложения и игнорирует их.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip FSP не загружает и игнорирует правила применяемые к входящим SIP вызовам.
  • Если опция Включить H.323 отключена (H.323 не используется, см. Параметры IP-телефонии ), Fax Voip FSP не загружает и игнорирует правила применяемые к входящим H.323 вызовам.

Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом в таблице Маршрутизация входящих VOIP вызовов.

Таблица Маршрутизация входящих VOIP вызовов содержит следующую информацию:

Правило

Уникальный номер текущего правила.

VOIP вызов откуда

Задает формат SIP или H.323 адреса вызывающей стороны для которого применяется текущее правило. SIP или H.323 адрес вызывающей стороны обычно имеет формат вида 'префикс:CallerID@имя_сервера'. В случае SIP, поддерживаются префиксы sip: и tel:. В случае H.323, поддерживается префикс h323:. Далее, первая часть это номер вызывающего абонента, вторая часть это имя SIP или H.323 сервера. Например, 'h323:.*' означает “H.323 вызов с любого номера и с любого H.323 сервера”, '(sip|tel):.*' означает “SIP вызов с любого номера, из любой sip сети и с любым из допустимых префиксов”, 'sip:.*@sip.mynetwork.com' означает “SIP вызов с любого номера, только с сервера sip.mynetwork.com”. Наибольшие проблемы могут возникнуть при попытке задать имя_сервера. Типичной является ситуация, когда вы вводите имя сервера в виде 'myserver.com', и это работает с точки зрения SIP регистрации, но при входящем вызове имя того же сервера выглядит как '@sip.myserver.com:5060'. В приведенном примере конструкция 'sip:.*@myserver.com' некорректна и работать не будет, правильная конструкция для поля VOIP вызов откуда должна быть записана как: 'sip:.*@sip.myserver.com:5060'.

VOIP вызов куда

Задает формат вызываемого номера для которого применяется текущее правило. В случае SIP, поддерживаются префиксы sip: и tel:. В случае H.323, добавляется стандартный h323: префикс. Например, '(sip|tel):.*' означает “вызов на любой номер с префиксом sip: или tel:”, 'sip:100@.*' означает “вызов на номер 100”.

Маршрут

Задает маршрут для входящего вызова. Приложение Fax Voip FSP всегда маршрутизирует вызовы через Службу факсов Windows (MS-FAX).

Режим факса

Отображает Режим факса применяемый к данному правилу. G.711 означает аудио факс поверх кодека G.711. T.38 означает поддержку T.38 при входящем вызове с использованием данного правила.

Параметры аудио факса

Индивидуальные параметры аудио факса, которые переопределяют общие параметры, заданные в Параметрах аудио факса (SIP) либо в Параметрах аудио факса (H.323) .

Переопределяемые Параметры аудио факса следующие:

MaxRate_in

Максимальная скорость передачи факса для входящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>Аудио факс=>Прием аудио факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>Аудио факс=>Прием аудио факса=>Макс. скорость” (в случае H.323).

ECM_in (0 – отключено, 1 - включено)

Возможность использовать Коррекцию ошибок (ECM) для входящих аудио факсов (факс поверх кодека G.711). Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>Аудио факс=>Прием аудио факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>Аудио факс=>Прием аудио факса=>Коррекция ошибок (ECM)” (в случае H.323).

Параметры T.38 факса

Индивидуальные параметры T.38 факса, которые переопределяют общие параметры, заданные в Параметрах T.38 факса (SIP) либо в Параметрах T.38 факса (H.323) .

Переопределяемые Параметры T.38 факса следующие:

T38MaxRate_in

Максимальная скорость передачи факса для входящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>T.38 факс=>Прием T.38 факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>T.38 факс=>Прием T.38 факса=>Макс. скорость” (в случае H.323).

T38ECM_in (0 – отключено, 1 - включено)

Возможность использовать Коррекцию ошибок (ECM) для входящих T.38 факсов. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Коррекция ошибок (ECM)” (в случае H.323).

T38SwitchOnTimer_in (Off – отключено, 0-20 – задержка в секундах)

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд), для входящих факсов. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CNG сигнала от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 после ... секунд” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 после ... секунд” (в случае H.323).

T38SwitchOnCNG_in (0 – отключено, 1 - включено)

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CNG сигнал) во время приема факса. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 при получении CNG” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 при получении CNG” (в случае H.323).

T38Redundancy

T.38 Redundancy в формате I/LS/HS. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>T.38 UDPTL Redundancy” (в случае SIP) или в “H.323=>T.38 факс=>T.38 UDPTL Redundancy” (в случае H.323).

В контекстной вкладке Входящие маршруты, на ленте доступны следующие команды:

Входящие правила

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило Маршрутизации входящих VOIP вызовов.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила Маршрутизации входящих VOIP вызовов. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения правила Маршрутизации входящих VOIP вызовов. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации входящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации входящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил Маршрутизации входящих VOIP вызовов. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Входящие маршруты также доступны в контекстном меню списка.


Добавление/изменение правила входящего VOIP вызова

Добавление (или изменение) правил для входящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Входящие маршруты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация входящих вызовов, на вкладке Общие, в области VOIP протокол, выберите тип входящих вызовов, могут быть SIP или H.323. В областях VOIP вызов откуда и VOIP вызов куда задайте условия, при которых применяется данное правило. В области Маршрутизировать вызов, не забудьте указать каким образом маршрутизировать входящий вызов: через Службу факсов Windows с поддержкой T.38 или через Службу факсов Windows с использованием только режима аудио факса (факс поверх кодека G.711). Более подробную информацию можно найти в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры .

5. Сконфигурируйте Параметры факса если это необходимо.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Чтобы изменить порядок предпочтений для правил Маршрутизации входящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

8. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации входящих VOIP вызовов. Все изменения вступают в силу немедленно.


Управление правилами входящих VOIP вызовов

Управление правилами для входящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Входящие маршруты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Чтобы изменить порядок предпочтений для правил Маршрутизации входящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации входящих VOIP вызовов. Все изменения вступают в силу немедленно.


Параметры маршрутизации входящих VOIP вызовов

Панель управления Fax Voip FSP ›› IP-телефония ›› Входящие маршруты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Маршрутизации входящих VOIP вызовов.

  • Общие параметры
  • Параметры факса


Общие параметры

Общие параметры (маршрутизация входящих VOIP вызовов)

Панель управления Fax Voip FSP ›› IP-телефония ›› Входящие маршруты ›› Параметры маршрутизации входящих VOIP вызовов ››

Общие параметры

VOIP протокол

В этой области вы можете выбрать тип входящих вызовов для которых применяется текущее правило. Правило может применяться к SIP или H.323 входящим вызовам.

SIP

Если выбрана эта опция, правило применяется к входящим SIP вызовам.

H.323

Если выбрана эта опция, правило применяется к входящим H.323 вызовам.

VOIP вызов откуда

Параметры этой области позволяют задать первую часть шаблона маршрута, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера (или имени пользователя), или к вызовам с определенной группы номеров. В то же время, SIP/H.323 правило может применяться к входящим вызовам с любого SIP (или H.323) узла или только к входящим вызовам с определенного SIP/H.323 узла (сервера).

Префиксы

sip:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sip: в первой части шаблона маршрута.

tel:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом tel: в первой части шаблона маршрута (TEL URI схема).

Вызывающий номер (имя) =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера (или имени пользователя).

Выберите <любой> чтобы принимать вызовы с любого номера.

Введите номер телефона (или имя пользователя) чтобы принимать вызовы только с этого телефонного номера (или имени пользователя).

Вызывающий номер (имя) начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Из VOIP сети

Опция Из VOIP сети может использоваться с входящими SIP и H.323 вызовами. Введите имя или IP-адрес SIP или H.323 узла (SIP/H.323 сервера), чтобы применять правило к вызовам только с этого узла (сервера). <любой> означает, что правило применяется к вызовам с любого SIP или H.323 узла. Будьте осторожны при использовании этого параметра. Типичной является ситуация, когда вы вводите имя сервера в виде 'sip.myserver.com', и это работает с точки зрения SIP регистрации, но при входящем вызове имя того же сервера выглядит как 'sip.myserver.com:5060', или даже содержит совершенно другое имя или IP-адрес. В приведенном примере конструкция 'sip.myserver.com' некорректна и работать не будет, правильная конструкция для поля Из VOIP сети должна быть записана как: 'sip.myserver.com:5060'.

VOIP вызов куда

Параметры этой области позволяют задать вторую часть шаблона маршрута, для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер (или имя пользователя), или на группу телефонных номеров.

Префиксы

sip:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sip: во второй части шаблона маршрута.

tel:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом tel: во второй части шаблона маршрута (TEL URI схема).

Вызываемый номер (имя) =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер (или имя пользователя).

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона (или имя пользователя) чтобы принимать вызовы, адресованные только на этот номер (или имя пользователя). Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона (или имя пользователя) может быть выбран из раскрывающегося списка.

Вызываемый номер (имя) начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс '2', как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 200,201,2000,2001 ,...,, но не будет применяться к входящим вызовам на номера 100,301,4002 ...

Маршрутизировать вызов

Параметры, заданные в этой области, позволяют задать маршрут для входящего вызова.

Служба факсов Windows

Приложение Fax Voip FSP всегда маршрутизирует вызовы через Службу факсов Windows.

T.38 авто

Используйте эту опцию для приема факсов по протоколу T.38. Если при использовании этой опции факс не может быть получен в режиме T.38, Fax Voip FSP переключается в режим приема аудио факса (факс поверх кодека G.711).

G.711 аудио

Используйте эту опцию для приема аудио факсов (факс поверх кодека G.711).


Параметры факса

Параметры факса (маршрутизация входящих VOIP вызовов)

Панель управления Fax Voip FSP ›› IP-телефония ›› Входящие маршруты ›› Параметры маршрутизации входящих VOIP вызовов ››

Параметры факса

Режимы факса

Режимы факса применяемые к текущему правилу.

Факс поверх G.711

Включите эту опцию чтобы принимать аудио факсы.

T.38 факс

Включите эту опцию чтобы принимать факсы по протоколу T.38.

Параметры аудио факса поверх G.711

Параметры, задаваемые в этой области, позволяют переопределить параметры приема аудио факса по умолчанию.

Максимальная скорость

Используйте эту опцию, чтобы изменить максимальную скорость передачи факса для входящих аудио факсов (факс поверх кодека G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>Аудио факс=>Прием аудио факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>Аудио факс=>Прием аудио факса=>Макс. скорость” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих аудио факсов (факс поверх кодека G.711). Эта опция переопределяет настройки по умолчанию, заданные в “SIP=>Аудио факс=>Прием аудио факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>Аудио факс=>Прием аудио факса=>Коррекция ошибок (ECM)” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить настройки по умолчанию для Коррекции ошибок (ECM). Если данная опция включена, используются настройки по умолчанию.

Параметры T.38

Параметры, задаваемые в этой области, позволяют переопределить параметры приема T.38 факса по умолчанию.

Максимальная скорость

Используйте эту опцию, чтобы изменить максимальную скорость передачи факса для входящих T.38 факсов. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Этот параметр переопределяет максимальную скорость передачи факса по умолчанию, заданную в поле “SIP=>T.38 факс=>Прием T.38 факса=>Макс. скорость” (в случае SIP) или в поле “H.323=>T.38 факс=>Прием T.38 факса=>Макс. скорость” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок (ECM) для входящих T.38 факсов. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Коррекция ошибок (ECM)” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Коррекция ошибок (ECM)” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить настройки по умолчанию для Коррекции ошибок (ECM). Если данная опция включена, используются настройки по умолчанию.

Перекл. в T.38 после ... секунд

Эта опция обеспечивает принудительное переключение в режим T.38 немедленно (0 секунд) или по истечении заданного интервала времени (1-20 секунд), для входящих факсов. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта либо CNG сигнала от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 после ... секунд” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 после ... секунд” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить поведение по умолчанию. Если данная опция включена, используются настройки по умолчанию.

Переключение в T.38 при получении CNG

Эта опция обеспечивает принудительное переключение в режим T.38 при обнаружении специфического тона факсимильного аппарата (CNG сигнал) во время приема факса. Fax Voip FSP отправляет T.38 ре-инвайт не дожидаясь получения T.38 ре-инвайта от противоположной стороны. Этот параметр переопределяет настройки по умолчанию, заданные в “SIP=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 при получении CNG” (в случае SIP) или в “H.323=>T.38 факс=>Прием T.38 факса=>Переключение в T.38 при получении CNG” (в случае H.323).

По умолчанию

Снимите галочку, чтобы изменить поведение по умолчанию. Если данная опция включена, используются настройки по умолчанию.

T.38 UDPTL Redundancy

Параметры, задаваемые в этой области, позволяют переопределить параметры по умолчанию для SIP T.38 Redundancy или H.323 T.38 Redundancy.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

По умолчанию

Снимите галочку, чтобы изменить параметры по умолчанию для SIP (или H.323) T.38 Redundancy. Если данная опция включена, используются параметры по умолчанию для SIP (или H.323) T.38 Redundancy.


Агент пользователя

Панель управления Fax Voip FSP ›› IP-телефония ››

Рассматриваемые здесь параметры используются для идентификации Fax Voip FSP в процессе взаимодействия с другими элементами SIP или H.323 сети. Позволяют информировать противоположную сторону о программе или оборудовании, которые использует пользователь.

Поставщик продукта

Информация о производителе программного обеспечения или оборудования SIP или H.323. По умолчанию FaxVoip Software.

Имя продукта

Информация об оборудовании или программном обеспечении. По умолчанию FaxVoip FSP.

Версия продукта

Информация о версии продукта. По умолчанию текущая версия Fax Voip FSP.

Код страны T.35

В Коде страны T.35 указывается страна нахождения производителя программного обеспечения или оборудования. По умолчанию 181 (США).

Расширение T.35

В Расширении T.35 указываются дополнительные коды стран. По умолчанию 0.

Код производителя

Код производителя идентифицирует производителя внутри страны. По умолчанию 1.

В таблице ниже показано, как используются эти параметры:

SIP / H.323 | Поле | Значение | Значение по умолчанию
SIP | User-Agent: | <Имя продукта> + <Версия продукта> | FaxVoip FSP 4.3.1
 | Organization: | <Поставщик продукта> | FaxVoip Software
 | Session Name (s): | <Имя продукта> + <Версия продукта> | FaxVoip FSP 4.3.1
H.323 | productID: | <Поставщик продукта> + <Имя продукта> | FaxVoip Software FaxVoip FSP
 | versionID: | <Версия продукта> | 4.3.1
 | t35CountryCode: | <Код страны T.35> | США (181)
 | T35Extension: | <Расширение T.35> | 0
 | manufacturerCode | <Код производителя> | 1


Методы маршрутизации для входящих факсов

Методы маршрутизации для входящих факсов: e-mail, сохранить в папке, печать, пользовательский

Панель управления Fax Voip FSP ››

В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Когда служба факсов принимает факс, она маршрутизирует принятый документ через каждый из методов маршрутизации факса, определяемых расширением маршрутизации факса.

Вы можете настроить Методы маршрутизации для входящих факсов чтобы маршрутизировать входящие факсы получателям в сети. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), к входящим факсам могут применяться различные действия. Эти действия определяются так называемыми правилами. Для каждого метода используются независимые наборы правил.

Методы маршрутизации факса, определенные в Расширении маршрутизации Fax Voip FSP, аналогичны методам маршрутизации, которые включены в Расширение маршрутизации Майкрософт (можно использовать на любом компьютере с Windows Server, например на Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012R2 и т.д.). Существенным отличием является возможность осуществлять маршрутизацию на основе номера вызываемого абонента (DID) и без привязки к конкретному факсимильному устройству. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса. Кроме того, методы маршрутизации факса, поставляемые с Fax Voip FSP, работают не только на компьютерах под управлением Windows Server, но и на любой рабочей станции, например Windows 11, Windows 10, Windows 8.1 и т.д.

Расширение маршрутизации Fax Voip FSP включает следующие методы маршрутизации для входящих факсов, которые могут быть настроены в Панели управления Fax Voip FSP:

Отправить по электронной почте

Входящие факсы могут быть доставлены по e-mail одному или более e-mail получателям.

Сохранить в папке

Входящие факсы могут быть скопированы в одну или более локальных или сетевых папок.

Печать

Этот метод позволяет автоматически печатать входящие факсы.

Пользовательский

Этот метод позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Использование этого метода не ограничено какими-либо лицензиями.

Страница Методы маршрутизации для входящих факсов содержит следующую информацию:

Метод для входящих

Название метода маршрутизации для входящих факсов.

Максимальное число правил

Общее количество правил, которые могут быть использованы. Это обычно сумма базовых и дополнительных правил.

Базовое

Количество базовых правил, которые могут быть использованы. Определяется как число лицензированных линий Fax Voip провайдер службы факсов Windows + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.

Расширенное

Количество дополнительных правил, определяемое лицензией Fax Voip FSP расширенная маршрутизация факсов (E-mail, сохранить в папке, печать).

В контекстной вкладке Методы для входящих, на ленте доступны следующие команды:

Методы для входящих

Отправить по электронной почте

Нажмите чтобы настроить правила метода Отправить по электронной почте для входящих факсов.

Сохранить в папке

Нажмите чтобы настроить правила метода Сохранить в папке для входящих факсов.

Печать

Нажмите чтобы настроить правила печати входящих факсов.

Пользовательская маршрутизация

Нажмите чтобы настроить пользовательскую маршрутизацию входящих факсов.

Кроме того, вы можете дважды щелкнуть метод в списке Методы маршрутизации для входящих факсов или выбрать команду Править из контекстного меню.

На следующей диаграмме представлен обзор процесса маршрутизации входящего факса:

На компьютере с Windows Server, вы можете видеть методы маршрутизации факса, определенные Расширением маршрутизации Fax Voip FSP, в Диспетчере службы факса (Microsoft), см. на рисунке ниже.

При настройке методов маршрутизации факса (Расширение маршрутизации Fax Voip FSP), обратите внимание на следующее:

  • Методы маршрутизации для входящих факсов должны быть настроены в Панели управления Fax Voip FSP.
  • Не следует включать или выключать методы маршрутизации факса для отдельно взятых факсимильных устройств Fax Voip Line в Диспетчере службы факса (Microsoft) или любым другим способом. Программное обеспечение Fax Voip FSP автоматически включает или выключает метод маршрутизации факса для всех устройств Fax Voip Line, в зависимости от наличия или отсутствия правил для этого метода.
  • При наличии лицензии Fax Voip FSP, вы можете использовать методы маршрутизации факса (Расширение маршрутизации Fax Voip FSP) не только с виртуальными устройствами Fax Voip Line, но также с другими факсимильными устройствами, установленными в вашей системе (аппаратные модемы и т.д.). В указанном случае вам необходимо вручную включить методы маршрутизации факса для ваших факсимильных устройств при помощи Диспетчера службы факса (Microsoft) или любым другим способом. Кроме того, скорее всего, вы не сможете маршрутизировать факсимильные сообщения на основе номера вызываемого абонента (DID), поскольку обычно он не передается в программное обеспечение Факсы и сканирование Windows.
  • На компьютере с Windows Server, вы можете задать порядок приоритетов для методов маршрутизации входящих факсов. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Маршрутизация входящих, щелкните Глобальные методы (см. рисунок выше). В области сведений щелкните правой кнопкой мыши требуемый метод, а затем выберите Вверх или Вниз. Следует понимать, что этот параметр практически не имеет эффекта, поскольку каждый метод, определяемый Расширением маршрутизации Fax Voip FSP, всегда выполняется в отдельном потоке. Такая архитектура значительно повышает надежность всего приложения, если сравнивать с нашими предыдущими реализациями (Fax Voip T38 Fax and Voice, версия 7).

Для просмотра журнала отладки для Расширения маршрутизации Fax Voip FSP, воспользуйтесь опцией Вести протокол модуля расширения маршрутизации Fax Voip FSP, более подробную информацию см. в главе Журналы Fax Voip FSP . Для просмотра детализированных журналов отладки для конкретных методов маршрутизации факса, воспользуйтесь опциями, описанными в главе Журналы маршрутизации входящих факсов настоящего справочного руководства.

Примечания

  • Для того чтобы использовать Методы маршрутизации для входящих факсов, у вас должна быть установлена лицензия Fax Voip провайдер службы факсов Windows: линии факса.
  • Разрешенное базовое количество правил для каждого метода определяется как количество лицензированных линий Fax Voip провайдер службы факсов Windows + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.
  • Для значительного увеличения максимального количества правил, вы можете приобрести отдельную лицензию Fax Voip FSP расширенная маршрутизация факсов (E-mail, сохранить в папке, печать). Заметим что эта лицензия не может быть использована если отсутствует лицензия Fax Voip провайдер службы факсов Windows: линии факса.
  • Использование Пользовательского метода маршрутизации не ограничено какими-либо лицензиями.


Отправить по электронной почте

Маршрутизация входящих факсов: отправить по электронной почте

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ››

Вы можете настроить метод маршрутизации Отправить по электронной почте чтобы маршрутизировать входящие факсы получателям по e-mail. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть отправлен различным e-mail адресатам.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Отправить по электронной почте, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Чтобы маршрутизировать входящие факсы посредством e-mail, вы должны:

  • Настроить службу факсов Windows для получения факсов через одну или несколько линий Fax Voip Line
  • Настроить параметры SMTP
  • Настроить шаблон электронной почты 'Получен новый факс' (если требуется)
  • Создать одно или более правил, в которых следует задать e-mail получателей и формат доставки факсов

Входящий факс может быть маршрутизирован одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Факсы могут доставляться по e-mail в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Отправить по электронной почте определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Отправить по электронной почте, воспользуйтесь опцией Вести протокол метода маршрутизации 'Отправить по электронной почте', более подробную информацию см. в главе Журналы маршрутизации входящих факсов настоящего справочного руководства. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: отправить по электронной почте содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон номера вызываемого абонента (DID), для которого применяется текущее правило. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Включено

Указывает, будет ли Fax Voip FSP отправлять сообщения e-mail. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Электронная почта

Список e-mail адресатов.

Копия

Список e-mail адресов которые будут использоваться в поле Копия сообщения электронной почты.

Скрытая копия

Список e-mail адресов которые будут использоваться в поле Скрытая копия сообщения электронной почты.

Вкладывать факс

Указывает, будет ли копия принятого факса прикреплена к сообщению электронной почты.

Формат

Формат доставки факса. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла для прикрепленного факса. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff.

Шаблоны e-mail

Указывает, используются ли для шаблона электронной почты 'Получен новый факс' пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Отправить по почте, на ленте доступны следующие команды:

Правила отправки по почте

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Отправить по электронной почте.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Отправить по электронной почте. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Отправить по электронной почте. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Отправить по электронной почте. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Отправить по электронной почте. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Отправить по электронной почте. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Отправить по почте также доступны в контекстном меню списка.


Добавление или изменение правил

Добавление или изменение правил метода “Отправить по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Отправить по электронной почте.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Отправка по электронной почте, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Общие параметры .

5. Перейдите на вкладку E-mail.

6. На вкладке E-mail, поставьте флажок у параметра После приема переслать факс по электронной почте чтобы включить правило. В области Выбрать получателей, задайте получателей сообщения e-mail. Адрес электронной почты и имя получателя сначала вводятся в поля Введите e-mail получателя и Введите имя получателя (не обязательно), после чего получатель добавляется в один из списков Получатели сообщения с помощью кнопок <Кому>, <Копия> и <Скрытая копия>. Для выбора получателей из адресной книги (Контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Параметры E-mail .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат доставки факса, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Если вы не хотите вкладывать факс в сообщение электронной почты, поставьте флажок Не вкладывать копию принятого факса. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Параметры формата .

9. Перейдите на вкладку Шаблоны.

10. На вкладке Шаблоны, укажите, следует ли для шаблона электронной почты 'Получен новый факс' использовать пользовательские настройки или настройки по умолчанию. Настройте шаблон электронной почты, который будет использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Шаблоны электронной почты .

11. Нажмите кнопку <OK> чтобы зафиксировать изменения.

12. Чтобы изменить порядок предпочтений для правил метода Отправить по электронной почте, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

13. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Отправить по электронной почте. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Отправить по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Отправить по электронной почте.

3. Чтобы изменить порядок предпочтений для правил метода Отправить по электронной почте, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода “Отправить по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Отправки по электронной почте.

  • Общие параметры
  • Параметры E-mail
  • Параметры формата
  • Шаблоны электронной почты


Общие параметры

Общие параметры (Отправить по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой>, чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс “1631”, как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры E-mail

Параметры E-mail (Отправить по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Параметры E-mail

После приема переслать факс по электронной почте

Данная опция позволяет разрешить или запретить отправку e-mail сообщений. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить отправку e-mail сообщений, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Выбрать получателей

В этой области, вы можете задать получателей e-mail сообщения.

Введите e-mail получателя

Адрес электронной почты добавляемого получателя изначально должен быть введен в это поле.

Введите имя получателя (не обязательно)

Имя добавляемого получателя изначально должно быть введено в это поле.

<Адресная книга>

Позволяет выбрать получателей e-mail сообщений из адресной книги (Контакты Windows).

Получатели сообщения

<Кому>

Используйте эту кнопку для добавления адресата в основной список получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из основного списка получателей e-mail сообщений.

<Копия>

Используйте эту кнопку для добавления адресата в список “Копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Копия” получателей e-mail сообщений.

<Скрытая копия>

Используйте эту кнопку для добавления адресата в список “Скрытая копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Скрытая копия” получателей e-mail сообщений.


Параметры формата

Параметры формата (Отправить по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Параметры формата

Формат доставки факса

В этой области можно выбрать формат доставки факса для текущего правила, а также указать, следует ли вкладывать копию принятого факса в сообщение электронной почты.

Доставлять входящие факсы в формате

Выберите формат доставки факса для текущего правила. Входящий факс может быть доставлен по e-mail как TIFF, PDF или SFF вложение.

Не вкладывать копию принятого факса

Поставьте флажок у этого параметра, если вы не хотите вкладывать факс в сообщение электронной почты.

Шаблон имени файла

В этой области можно указать шаблон имени файла для прикрепляемых факсов.

Использовать шаблон по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата доставки факса).

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %CallerID%, %StartTime%, %PagesReceived% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %CallerID%. Номер телефона вызывающего устройства.
      • %CalledNumber%. Номер телефона вызываемого абонента (DID).
      • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
      • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
      • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
      • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
      • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
      • %PagesReceived%. Количество страниц в принятом факсимильном документе.
      • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip Line 2.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата доставки факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Шаблоны электронной почты

Шаблоны электронной почты (Отправить по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблона электронной почты 'Получен новый факс' .

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующий шаблон доступен для редактирования: Получен новый факс.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Получен новый факс, см. Шаблоны электронной почты: Получен новый факс . Настройки шаблона на вкладке правила отправки по электронной почте делаются аналогично.


Сохранить в папке

Маршрутизация входящих факсов: сохранить в папке

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ››

Вы можете настроить метод маршрутизации Сохранить в папке чтобы копировать входящие факсы в заданные локальные или сетевые папки. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть скопирован в различные папки.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Сохранить в папке, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Чтобы сохранять входящие факсы в заданных папках, вы должны:

  • Настроить службу факсов Windows для получения факсов через одну или несколько линий Fax Voip Line
  • Создать одно или более правил, в которых следует задать имена папок и формат сохранения входящих факсов

Входящий факс может быть маршрутизирован в одну или более локальных или сетевых папок. Входящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Сохранить в папке определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Сохранить в папке, воспользуйтесь опцией Вести протокол метода маршрутизации 'Сохранить в папке', более подробную информацию см. в главе Журналы маршрутизации входящих факсов настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: сохранить в папке содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон номера вызываемого абонента (DID), для которого применяется текущее правило. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Включено

Указывает, будет ли Fax Voip FSP сохранять факсы в заданных папках. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Сохранить в папке

Отображает пути к папкам для хранения копий входящих факсов.

Формат

Задает формат сохранения входящих факсов. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла, используемый при копировании принятых факсов в заданные папки. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

В контекстной вкладке Сохранить в папке, на ленте доступны следующие команды:

Правила сохранения в папке

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Сохранить в папке.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Сохранить в папке. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Сохранить в папке. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Сохранить в папке. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Сохранить в папке также доступны в контекстном меню списка.

Примечания

  • Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке.


Добавление или изменение правил

Добавление или изменение правил метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Сохранить в папке.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Сохранение в папке, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Общие параметры .

5. Перейдите на вкладку Сохранить в папке.

6. На вкладке Сохранить в папке, поставьте флажок у параметра После приема скопировать факс в указанные папки чтобы включить правило. В области Сохранить в папке, задайте папки для сохранения входящих факсов. Путь к папке должен быть сначала выбран или введен в текстовое поле, после чего добавлен в список Сохранить в папках с помощью кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры сохранения .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат для сохранения входящих факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры формата .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке. В диалоговом окне, показанном на рисунке ниже, нажмите Да чтобы предоставить доступ к указанным папкам для учетной записи Network Service.

11. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

12. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Сохранить в папке. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Сохранить в папке.

3. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Сохранение в папке.

  • Общие параметры
  • Параметры сохранения
  • Параметры формата


Общие параметры

Общие параметры (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой>, чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс “1631”, как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры сохранения

Параметры сохранения (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры сохранения

После приема скопировать факс в указанные папки

Данная опция позволяет разрешить или запретить процедуру сохранения в папках. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить копирование факсов в указанные папки, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Сохранить в папке

В этой области, вы можете задать локальные или сетевые папки, в которых следует сохранять входящие факсы.

<Обзор>

Нажмите эту кнопку для выбора желаемой папки с использованием системного диалогового окна Обзор папок. Можно выбрать локальную или сетевую папку.

Вы также можете вручную ввести путь к папке в текстовое поле.

Сохранить в папках

<Добавить>

Используйте эту кнопку для добавления папки в список папок. Папка должна быть изначально выбрана или введена в текстовое поле.

<Удалить>

Используйте эту кнопку для удаления папки из списка папок.

Примечания

  • Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке.


Параметры формата

Параметры формата (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры формата

Формат сохранения входящих факсов

В этой области можно выбрать формат сохранения факса для текущего правила.

Сохранять входящие факсы в формате

Выберите формат сохранения для текущего правила. Входящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла, используемый при копировании принятых факсов в заданные папки.

Использовать шаблон по умолчанию

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %CallerID%, %StartTime%, %PagesReceived% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %CallerID%. Номер телефона вызывающего устройства.
      • %CalledNumber%. Номер телефона вызываемого абонента (DID).
      • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
      • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
      • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
      • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
      • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
      • %PagesReceived%. Количество страниц в принятом факсимильном документе.
      • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip Line 2.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата сохранения факса).

Примечания

  • При создании файлов с одинаковыми именами (например, если задан пользовательский шаблон имени файла без использования %переменных%), к имени файла добавляется порядковый номер. Например, если шаблон имени файла - 'FAX', а формат факса - 'PDF', факсы будут копироваться в заданную папку (папки) со следующими именами: FAX.pdf, FAX (2).pdf, FAX (3).pdf ....


Печать

Маршрутизация входящих факсов: печать

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ››

Вы можете настроить выборочную печать входящих факсов, используя метод маршрутизации Печать. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть напечатан с использованием различных принтеров.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Печать, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Чтобы осуществлять печать входящих факсов на заданный принтер, вы должны:

  • Настроить службу факсов Windows для получения факсов через одну или несколько линий Fax Voip Line
  • Создать одно или более правил, в которых следует задать имена принтеров

Входящий факс может быть маршрутизирован на один или несколько принтеров.

Максимально допустимое количество правил метода Печать определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Печать, воспользуйтесь опцией Вести протокол метода маршрутизации 'Печать', более подробную информацию см. в главе Журналы маршрутизации входящих факсов настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: печать содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон номера вызываемого абонента (DID), для которого применяется текущее правило. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Включено

Указывает, будет ли осуществляться печать входящих факсов. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Принтер

Отображает принтеры для печати входящих факсов.

В контекстной вкладке Печать, на ленте доступны следующие команды:

Правила печати

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Печать.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Печать. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Печать. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Печать. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Печать также доступны в контекстном меню списка.

Примечания

  • При использовании метода Печать, печать выполняется от имени учетной записи Network Service (Сетевая служба). По этой причине, выбранный принтер не должен выводить никаких дополнительных диалоговых окон перед печатью.


Добавление или изменение правил

Добавление или изменение правил метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Печать ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Печать.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Печать, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Общие параметры .

5. Перейдите на вкладку Печать.

6. На вкладке Печать, поставьте флажок у параметра Напечатать факс после приема чтобы включить правило. В области Выбор принтеров, задайте имена принтеров. Вам следует выбрать принтер в поле со списком, а затем добавить его в список Имена принтеров при помощи кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Параметры печати .

7. Нажмите кнопку <OK> чтобы зафиксировать изменения.

8. Чтобы изменить порядок предпочтений для правил метода Печать, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

9. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Печать. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Печать ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Печать.

3. Чтобы изменить порядок предпочтений для правил метода Печать, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Печать ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Печать.

  • Общие параметры
  • Параметры печати


Общие параметры

Общие параметры (Печать)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Печать ›› Параметры метода Печать ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой>, чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса.

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс “1631”, как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры печати

Параметры печати (Печать)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Печать ›› Параметры метода Печать ››

Параметры печати

Напечатать факс после приема

Данная опция позволяет включить или отключить печать входящих факсов. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить печать, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Выбор принтеров

В этой области, вы можете задать принтеры для печати входящих факсов.

Перед добавлением принтера, следует выбрать его в поле со списком.

Имена принтеров

<Добавить>

Используйте эту кнопку для добавления принтера в список принтеров. Принтер должен быть предварительно выбран в поле со списком.

<Удалить>

Используйте эту кнопку для удаления принтера из списка принтеров.


Пользовательская маршрутизация

Пользовательская маршрутизация входящих факсов

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ››

Пользовательский метод маршрутизации, определенный Расширением маршрутизации Fax Voip FSP, позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Использование этого метода не ограничено какими-либо лицензиями.

Этот метод предоставляет поставщикам программного обеспечения гибкий способ подключения приложений, которые маршрутизируют полученные факсимильные сообщения, используя различные методы маршрутизации. Эти методы маршрутизации могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д. Поставщик программного обеспечения отвечает за разработку функций своего метода, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации.

При выполнении Пользовательского метода маршрутизации (Расширение маршрутизации Fax Voip FSP), служба факсов Windows запускает указанное пользователем приложение после получения факса. Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу (файл TIFF) и другие важные параметры, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т. д., а затем выполнить любые требуемые действия. Пользовательское приложение должно автоматически завершать работу после выполнения. Приложение отвечает за удаление копии факса (файл TIFF) и папки, в которой она находится. Пользовательское приложение запускается с использованием учетной записи Network Service (Сетевая служба). Таким образом, учетная запись Network Service должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение. Подробнее см. в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

Пользовательское приложение, запускаемое после получения факса

Здесь вы можете выбрать приложение, которое будет запущено после получения факса. Вы можете выбрать приложение, нажав на кнопку справа от текстового поля, либо ввести путь к исполняемому файлу. Пример пользовательского приложения (RouteCustom.exe) можно найти в папке установки Fax Voip FSP, обычно C:\Program Files (x86)\FaxVoip FSP\RouteCustom.exe. См. также в главе Пример пользовательского приложения настоящего справочного руководства.

Создавать временную копию принятого факса (файл TIFF)

При выборе этой опции метод создает временную папку (в папке %temp% для учетной записи Network Service) и копирует принятый факс (файл TIFF) в эту папку. Временная папка (%temp%) для учетной записи Network Service обычно C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\. Путь к временному файлу TIFF передается в пользовательское приложение через аргумент командной строки TiffFileName. Пользовательское приложение отвечает за удаление временного TIFF файла и временной папки, в которой этот файл находится. Если флажок не установлен, метод не создает копию полученного факса, однако пользовательское приложение все равно может получить доступ к принятому факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Включить пользовательский метод маршрутизации

Программное обеспечение Fax Voip FSP автоматически включает или выключает Пользовательский метод маршрутизации факса (Расширение маршрутизации Fax Voip FSP) для всех устройств Fax Voip Line, в зависимости от того, установлен ли этот флажок или нет.


Требования к пользовательскому приложению

Требования к пользовательскому приложению (информация для разработчика)

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Пользовательская маршрутизация ››

Пользовательское приложение маршрутизации, указанное пользователем, запускается службой факсов Windows при выполнении Пользовательского метода маршрутизации (Расширение маршрутизации Fax Voip FSP), после получения факса. Индивидуальный разработчик отвечает за разработку этого приложения, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации. Функции приложения могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д.

Ниже приведены общие требования, которые должны быть приняты во внимание разработчиками программного обеспечения при написании пользовательских приложений.

Аргументы командной строки

Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу (файл TIFF) и другие важные параметры, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т. д.

Ниже приведен пример аргументов командной строки, переданных вашему приложению:

/@@@TiffFileName=C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\5547_c\FAX.tif

/@@@JobId=5547 /@@@ElapsedTime=00:00:55

/@@@ReceiveTime=07.28.2017@00:42:11 /@@@PageCount=1

/@@@Csid=Fax Voip FSP /@@@Tsid=(901) 222-3344

/@@@CallerId=19012223344 /@@@RoutingInfo=16314901610

/@@@ReceiverName=Fax Voip Line 0 /@@@ReceiverNumber=Fax Voip FSP

/@@@DeviceName=Fax Voip Line 0 /@@@DeviceId=24576

Аргументы командной строки приблизительно соответствуют элементам структуры FAX_ROUTE , см. ниже:

/@@@TiffFileName=

Временная копия файла TIFF, связанная с принятым факсимильным документом. Этот файл и временная папка, в которой он находится (в папке %temp% для учетной записи Network Service), должны быть удалены в пользовательском приложении маршрутизации после выполнения необходимых действий. Если флажок Создавать временную копию принятого факса (файл TIFF) не установлен, этот аргумент отсутствует в командной строке. См. также в главе Пользовательская маршрутизация входящих факсов настоящего справочного руководства.

/@@@JobId=

Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

/@@@ElapsedTime=

Представляет общее время, прошедшее между началом и окончанием приема факса в формате 'hh:mm:ss'.

/@@@ReceiveTime=

Время начала выполнения задания факса, связанного с приемом факсимильного документа, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@PageCount=

Количество страниц в принятом факсимильном документе.

/@@@Csid=

Идентификатор факса локального факсимильного устройства (Local Fax ID), принявшего факс. Обычно состоит из номера факса получателя и названия организации.

/@@@Tsid=

Идентификатор факса удаленного передающего факсимильного устройства, отправившего факс. Как правило, представляет собой комбинацию из номера факса отправителя и названия организации.

/@@@CallerId=

Идентифицирует вызывающее устройство, которое отправило факсимильный документ. Эта строка обычно содержит номер телефона вызывающего устройства.

/@@@RoutingInfo=

Cтрока маршрутизации для принятого факсимильного документа. Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в этой строке.

/@@@ReceiverName=

Согласно MSDN, имя получателя факсимильного документа (обычно совпадает с DeviceName и не используется).

/@@@ReceiverNumber=

Согласно MSDN, телефонный номер факсимильного устройства принявшего факс (обычно совпадает с Csid - идентификатором факса локального устройства, как правило не используется).

/@@@DeviceName=

Имя устройства, которое приняло факсимильный документ.

/@@@DeviceId=

Постоянный идентификатор линии принимающего факсимильного устройства.

Временная копия полученного факса (файл TIFF)

Если установлен флажок Создавать временную копию принятого факса (файл TIFF) (см. в главе Пользовательская маршрутизация входящих факсов настоящего справочного руководства), Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip FSP) создает временную папку и копирует принятый факс (файл TIFF) в эту папку. Временная папка создается в папке %temp% для учетной записи Network Service (Сетевая служба). Путь к временному файлу TIFF передается в пользовательское приложение через аргумент командной строки TiffFileName, см. выше.

Например,

/@@@TiffFileName=C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\5547_c\FAX.tif

Путь к файлу TIFF:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\5547_c\FAX.tif

Путь к временной папке:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\5547_c\

Временная папка, в которой находится файл TIFF (FAX.tif), может использоваться вашим пользовательским приложением для хранения временных файлов, создаваемых вашим приложением.

Пользовательское приложение отвечает за удаление временного TIFF файла и временной папки, в которой этот файл находится. Вы должны навсегда удалить временную папку в своем приложении после выполнения всех необходимых действий.

Если флажок Создавать временную копию принятого факса (файл TIFF) не установлен, Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip FSP) не создает копию полученного факса, однако пользовательское приложение все равно может получить доступ к принятому факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Запуск под учетной записью Network Service (Сетевая служба)

Пользовательское приложение запускается в контексте службы факсов Windows от имени учетной записи Network Service (Сетевая служба). Таким образом, учетная запись Network Service должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение.

Завершение приложения

Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip FSP) запускает пользовательское приложение маршрутизации в отдельном потоке путем вызова функции CreateProcess . Служба факсов Windows не отслеживает приложение после его запуска и не гарантирует его корректное завершение. Разработчик пользовательского приложения отвечает за правильное автоматическое завершение работы приложения после его выполнения.


Пример пользовательского приложения

Панель управления Fax Voip FSP ›› Методы маршрутизации для входящих факсов ›› Пользовательская маршрутизация ››

Пример пользовательского приложения маршрутизации (RouteCustom.exe) можно найти в папке установки Fax Voip FSP, обычно C:\Program Files (x86)\FaxVoip FSP\RouteCustom.exe.

Исходные коды (архив RouteCustom.zip) можно найти в папке данных Fax Voip FSP, обычно C:\ProgramData\FaxVoip FSP\Samples\RouteCustom.zip. Чтобы распаковать архив, щелкните его правой кнопкой мыши и выберите Извлечь все... из контекстного меню.

Пример кода - консольное приложение, написанное на языке Visual Basic .Net, которое может быть скомпилировано с использованием Microsoft Visual Studio 2013 или более поздней версии.

В этом примере демонстрируется использование пользовательского метода маршрутизации для входящих факсов, с учетом требований, предъявляемых к написанию такого приложения, см. также в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

  • Приложение анализирует предопределенную командную строку и заполняет внутреннюю структуру, где оно сохраняет путь к временному файлу TIFF и другие параметры маршрутизации, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т.д.
  • Записывает информацию о маршрутизации в стандартный ini-файл.
  • Копирует временный TIFF файл в указанную папку с уникальным именем, которое содержит дату и время получения факса.
  • Перед тем как завершить работу, приложение удаляет временную папку и временный файл TIFF, находящийся в этой папке.
  • Приложение автоматически завершается после выполнения всех необходимых действий.
  • Приложение использует папки и файлы, для которых учетная запись Network Service (Сетевая служба) заведомо имеет доступ на запись.

Чтобы использовать пример

1. Скопируйте файл RouteCustom.exe в папку установки Fax Voip FSP. Вы можете использовать другую папку, но убедитесь, что учетная запись Network Service (Сетевая служба) имеет доступ к используемой папке.

2. Откройте Панель управления Fax Voip FSP. Нажмите Методы для входящих, затем нажмите Пользовательский.

3. На странице Пользовательская маршрутизация входящих факсов, установите флажок Включить пользовательский метод маршрутизации.

4. В поле Пользовательское приложение, запускаемое после получения факса, введите путь к файлу RouteCustom.exe, либо выберите файл, нажав на кнопку справа от текстового поля.

5. Установите флажок Создавать временную копию принятого факса (файл TIFF).

6. Нажмите кнопку <Применить>, чтобы сохранить изменения.

После получения факса,

1. Откройте папку данных Fax Voip FSP в проводнике Windows, обычно C:\ProgramData\FaxVoip FSP\.

2. В подпапке RouteCustom найдите файл RouteCustom.ini.

3. В подпапке RouteCustom\Incoming Faxes найдите копию принятого факса.

4. Файл журнала маршрутизации RouteCustom.txt сохраняется в подпапке log.


Методы маршрутизации для исходящих факсов

Методы маршрутизации для исходящих факсов: e-mail, сохранить в папке, печать, пользовательский

Панель управления Fax Voip FSP ››

При отправке факсов, вы можете настроить Методы маршрутизации для исходящих факсов чтобы маршрутизировать исходящие факсы. В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, к исходящим факсам могут применяться различные действия. Эти действия определяются так называемыми правилами. Для каждого метода используются независимые наборы правил.

Следующие методы маршрутизации для исходящих факсов могут быть настроены:

Уведомления о доставке по электронной почте

Уведомление о доставке может быть отправлено на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса.

Сохранить в папке

Исходящие факсы могут быть скопированы в одну или более локальных или сетевых папок.

Печать

Этот метод позволяет автоматически печатать исходящие факсы.

Пользовательский

Этот метод позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Использование этого метода не ограничено какими-либо лицензиями.

Страница Методы маршрутизации для исходящих факсов содержит следующую информацию:

Метод для исходящих

Название метода маршрутизации для исходящих факсов.

Приоритет

Приоритетный порядок выполнения методов маршрутизации для исходящих факсов. Следует понимать, что методы маршрутизации для данного факса выполняются последовательно в одном потоке. Выполнение некоторых операций (отправка электронной почты, преобразование в другой графический формат, печать и т.д.) может занять определенное время, часто до нескольких секунд. Чтобы изменить порядок выполнения методов, используйте команды Вверх и Вниз, см. ниже.

Максимальное число правил

Общее количество правил, которые могут быть использованы. Это обычно сумма базовых и дополнительных правил.

Базовое

Количество базовых правил, которые могут быть использованы. Определяется как число лицензированных линий Fax Voip провайдер службы факсов Windows + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.

Расширенное

Количество дополнительных правил, определяемое лицензией Fax Voip FSP расширенная маршрутизация факсов (E-mail, сохранить в папке, печать).

В контекстной вкладке Методы для исходящих, на ленте доступны следующие команды:

Методы для исходящих

Уведомления на e-mail

Нажмите чтобы настроить правила метода Уведомления о доставке по электронной почте для исходящих факсов.

Сохранить в папке

Нажмите чтобы настроить правила метода Сохранить в папке для исходящих факсов.

Печать

Нажмите чтобы настроить правила печати исходящих факсов.

Пользовательская маршрутизация

Нажмите чтобы настроить пользовательскую маршрутизацию исходящих факсов.

Приоритет

Используйте команды ниже чтобы изменить порядок выполнения методов маршрутизации для исходящих факсов. Один из методов должен быть выделен.

Вверх (Ctrl + U)

Переместить выбранный метод вверх.

Вниз (Ctrl + D)

Переместить выбранный метод вниз.

Чтобы настроить метод маршрутизации, вы также можете дважды щелкнуть метод в списке Методы маршрутизации для исходящих факсов или выбрать команду Править из контекстного меню.

На следующей диаграмме представлен обзор процесса маршрутизации исходящего факса:

При использовании методов маршрутизации для исходящих факсов, обратите внимание на следующее:

  • Методы маршрутизации для исходящих факсов могут применяться только к факсам, отправляемым через виртуальные устройства Fax Voip Line, и не могут применяться к факсам, отправляемым через другие факсимильные устройства, установленные в вашей системе (аппаратные модемы и т.д.).
  • На компьютере с операционной системой Windows Server, для доступа к успешно отправленным факсам, необходимо настроить службу факсов для архивирования всех успешно отправленных факсов в папку Отправленные, см. ниже.
  • Для доступа к базе данных исходящих факсов, служба Fax Voip FSP (запускается под учетной записью локальной системы) должна иметь разрешения на Просмотр заданий для исходящих факсов и Просмотр архивов сообщений на факс-сервере, см. ниже.
  • Чтобы использовать Методы маршрутизации для исходящих факсов в Windows 7 или Windows Server 2008R2, необходимо вручную установить исправление (KB2535158), предоставленное Microsoft, см. ниже.

Для просмотра журнала отладки маршрутизации исходящих факсов, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов, более подробную информацию см. в главе Журналы маршрутизации исходящих факсов . Методы маршрутизации для исходящих факсов вызываются непосредственно из службы Fax Voip FSP и это отражается в соответствующем журнале отладки, используйте опцию Вести протокол модуля IP-телефонии, см. в главе Журналы Fax Voip FSP .

Примечания

  • Для того чтобы использовать Методы маршрутизации для исходящих факсов, у вас должна быть установлена лицензия Fax Voip провайдер службы факсов Windows: линии факса.
  • Разрешенное базовое количество правил для каждого метода определяется как количество лицензированных линий Fax Voip провайдер службы факсов Windows + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.
  • Для значительного увеличения максимального количества правил, вы можете приобрести отдельную лицензию Fax Voip FSP расширенная маршрутизация факсов (E-mail, сохранить в папке, печать). Заметим что эта лицензия не может быть использована если отсутствует лицензия Fax Voip провайдер службы факсов Windows: линии факса.
  • Использование Пользовательского метода маршрутизации не ограничено какими-либо лицензиями.

Настройка службы факсов для архивирования всех успешно отправленных факсов

На компьютере с операционной системой Windows Server, для доступа к успешно отправленным факсам, необходимо настроить службу факсов для архивирования всех успешно отправленных факсов в папку Отправленные. Обычно это настраивается автоматически при установке Fax Voip FSP, см. также Регистрация провайдера службы факсов .

Чтобы вручную настроить службу факсов для архивации всех входящих и отправленных факсов на компьютере с Windows Server, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Архивы, установите флажок Архивировать все факсы в папку. По умолчанию, входящие и отправленные факсы сохраняются в папке C:\ProgramData\Microsoft\Windows NT\MSFax. Нажмите Применить.

Предоставление доступа к заданиям исходящих факсов и архивам сообщений для службы Fax Voip FSP (учетной записи локальной системы)

Для доступа к базе данных исходящих факсов, служба Fax Voip FSP (запускается под учетной записью локальной системы) должна иметь разрешения на Просмотр заданий для исходящих факсов и Просмотр архивов сообщений на факс-сервере. Обычно это настраивается автоматически при установке Fax Voip FSP, см. также Регистрация провайдера службы факсов . Чтобы настроить разрешения вручную, выполните следующие действия:

1. В Windows 11 или Windows 10, в Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса..., а затем перейдите на вкладку Безопасность. На компьютере с Windows Server, в Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

2. На вкладке Безопасность, нажмите Дополнительно.

3. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения SYSTEM (СИСТЕМА) и нажмите Изменить. Если запись разрешения SYSTEM (СИСТЕМА) отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите SYSTEM либо СИСТЕМА, нажмите Проверить имена, нажмите OK.

4. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажки Просмотр заданий для исходящих факсов и Просмотр архивов сообщений. Нажмите OK. См. картинку ниже.

5. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.

Устранение неполадок в Windows 7 и Windows Server 2008R2 (применение исправления от Microsoft)

На компьютере с Windows 7 или Windows Server 2008R2, Методы маршрутизации для исходящих факсов обычно не работают по умолчанию. Это связано с тем, что служба Fax Voip FSP (запускается под учетной записью локальной системы), которая использует Fax Service Extended COM API, не может получить доступ к факсам, созданным под учетными записями других пользователей. Эта проблема возникает, даже если учетная запись локальной системы имеет необходимые разрешения для доступа к факсам всех пользователей (разрешения на Просмотр заданий для исходящих факсов и Просмотр архивов сообщений на факс-сервере), см. выше. Проблема описана в следующей статье на сайте Microsoft:

https://support.microsoft.com/en-us/help/2535158/an-application-that-uses-the-fax-service-extended-com-api-only-enumera

Чтобы устранить проблему, необходимо вручную установить исправление (KB2535158), предоставленное Microsoft. К сожалению, это исправление больше не доступно для загрузки с веб-сайта Microsoft. Вы можете найти необходимые установочные пакеты (как 64-битный, так и 32-битный) в папке установки Fax Voip FSP, скорее всего, путь будет следующим: C:\Program Files (x86)\FaxVoip FSP\FixJobEnum_Win7_2008R2\. Кроме того, вы можете загрузить необходимый установочный пакет с веб-сайта Fax Voip.

Чтобы устранить проблему в 64-разрядной версии Windows 7 или в Windows Server 2008R2, загрузите и установите следующий пакет:

https://www.t38faxvoip.com/downloads/Windows6.1-KB2535158-x64.zip

Чтобы устранить проблему в 32-разрядной версии Windows 7, загрузите и установите следующий пакет:

https://www.t38faxvoip.com/downloads/Windows6.1-KB2535158-x86.zip

После применения исправления необходимо перезагрузить компьютер.


Уведомления на e-mail

Маршрутизация исходящих факсов: уведомления о доставке по электронной почте

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ››

При отправке факсов, вы можете настроить метод маршрутизации Уведомления о доставке по электронной почте для отправки уведомлений на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса. Уведомления о доставке позволяют сообщать пользователям, был ли доставлен факс или нет. Обратите внимание, что этот функционал является полностью независимым от аналогичной функции, используемой совместно с функцией Почта-на-факс , см. описание параметра Уведомление о доставке на адрес электронной почты отправителя в главе Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) настоящего справочного руководства. Уведомление по электронной почте отправляется независимо от способа создания факса. В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, уведомление о доставке может быть отправлено различным e-mail адресатам.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Уведомления о доставке по электронной почте, начиная с правила # 1. Уведомление о доставке факса будет отправлено согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'Пользователь' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя или учетной записи факса.

Чтобы использовать функционал Уведомления о доставке по электронной почте, вы должны:

  • Настроить службу факсов Windows для отправки факсов через одну или несколько линий Fax Voip Line
  • Настроить параметры SMTP
  • Настроить шаблон электронной почты 'Факс успешно отправлен' (если требуется)
  • Настроить шаблон электронной почты 'Не удалось отправить факс' (если требуется)
  • Создать одно или более правил, в которых следует задать e-mail получателей и формат доставки факсов

Уведомление о доставке может быть отправлено одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Копия отправленного факса может быть прикреплена к сообщению электронной почты в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Уведомления о доставке по электронной почте определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации исходящего факса Уведомления о доставке по электронной почте, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов, более подробную информацию см. в главе Журналы маршрутизации исходящих факсов настоящего справочного руководства. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: уведомления о доставке по электронной почте содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

Пользователь

Учетная запись пользователя (учетная запись факса) отправившего факс, для которой применяется текущее правило. Правило может применяться к одной учетной записи факса или ко всем учетным записям.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли Fax Voip FSP отправлять сообщения e-mail. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя или учетной записи факса.

Электронная почта

Список e-mail адресатов.

Копия

Список e-mail адресов которые будут использоваться в поле Копия сообщения электронной почты.

Скрытая копия

Список e-mail адресов которые будут использоваться в поле Скрытая копия сообщения электронной почты.

Вкладывать факс

Указывает, будет ли копия отправленного факса прикреплена к сообщению электронной почты.

Формат

Задает формат файла для прикрепленного факса. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла для прикрепленного факса. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff.

Шаблоны e-mail

Указывает, используются ли для шаблонов электронной почты пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Уведомления на e-mail, на ленте доступны следующие команды:

Правила отправки по почте

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Уведомления о доставке по электронной почте.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Уведомления о доставке по электронной почте. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Уведомления о доставке по электронной почте. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Уведомления о доставке по электронной почте. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Уведомления о доставке по электронной почте. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Уведомления о доставке по электронной почте. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Уведомления на e-mail также доступны в контекстном меню списка.


Добавление или изменение правил

Добавление или изменение правил метода “Уведомления о доставке по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для исходящих, затем нажмите Уведомления на e-mail.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Уведомления о доставке по электронной почте, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Номер факса получателя и Имя пользователя (учетная запись факса)). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Общие параметры .

5. Перейдите на вкладку E-mail.

6. На вкладке E-mail, поставьте флажок у параметра После отправки факса отправить уведомление по электронной почте чтобы включить правило. В области Выбрать получателей, задайте получателей сообщения e-mail. Адрес электронной почты и имя получателя сначала вводятся в поля Введите e-mail получателя и Введите имя получателя (не обязательно), после чего получатель добавляется в один из списков Получатели сообщения с помощью кнопок <Кому>, <Копия> и <Скрытая копия>. Для выбора получателей из адресной книги (Контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Параметры E-mail .

7. Перейдите на вкладку Формат.

8. На вкладке Формат укажите, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла для прикрепляемого факса, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Параметры формата .

9. Перейдите на вкладку Шаблоны.

10. На вкладке Шаблоны, укажите, следует ли для шаблонов электронной почты использовать пользовательские настройки или настройки по умолчанию. Настройте шаблоны электронной почты, которые будут использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Шаблоны электронной почты .

11. Нажмите кнопку <OK> чтобы зафиксировать изменения.

12. Чтобы изменить порядок предпочтений для правил метода Уведомления о доставке по электронной почте, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

13. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Уведомления о доставке по электронной почте. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Уведомления о доставке по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для входящих, затем нажмите Уведомления на e-mail.

3. Чтобы изменить порядок предпочтений для правил метода Уведомления о доставке по электронной почте, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода Уведомления на e-mail

Параметры метода “Уведомления о доставке по электронной почте”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Уведомления о доставке по электронной почте.

  • Общие параметры
  • Параметры E-mail
  • Параметры формата
  • Шаблоны электронной почты


Общие параметры

Общие параметры (Уведомления о доставке по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Имя пользователя (учетная запись факса)

Параметры этой области позволяют выбрать, применять ли правило к одной учетной записи факса или ко всем учетным записям.

Применять правило для факсов, отправленных любым пользователем

Если выбрана эта опция, правило применяется к факсам, отправленным любым пользователем.

Учетная запись =

Если выбрана эта опция, правило применяется только к факсам, отправленным указанным пользователем. Имя пользователя (учетную запись факса) можно выбрать из раскрывающегося списка. На компьютере с Windows Server, учетные записи пользователей факса перечислены в Диспетчере службы факса (Microsoft) в разделе Учетные записи. Информация о пользователях факса хранится в подразделах раздела HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax\Accounts реестра.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры E-mail

Параметры E-mail (Уведомления о доставке по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Параметры E-mail

После отправки факса отправить уведомление по электронной почте

Данная опция позволяет разрешить или запретить отправку e-mail сообщений. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить отправку e-mail сообщений, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя или учетной записи факса.

Выбрать получателей

В этой области, вы можете задать получателей e-mail сообщения.

Введите e-mail получателя

Адрес электронной почты добавляемого получателя изначально должен быть введен в это поле.

Введите имя получателя (не обязательно)

Имя добавляемого получателя изначально должно быть введено в это поле.

<Адресная книга>

Позволяет выбрать получателей e-mail сообщений из адресной книги (Контакты Windows).

Получатели сообщения

<Кому>

Используйте эту кнопку для добавления адресата в основной список получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из основного списка получателей e-mail сообщений.

<Копия>

Используйте эту кнопку для добавления адресата в список “Копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Копия” получателей e-mail сообщений.

<Скрытая копия>

Используйте эту кнопку для добавления адресата в список “Скрытая копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Скрытая копия” получателей e-mail сообщений.


Параметры формата

Параметры формата (Уведомления о доставке по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Параметры формата

Формат доставки факса

В этой области можно указать, следует ли вкладывать копию факса в сообщение электронной почты и выбрать формат файла, в котором вы хотите получить копию отправленного факса (для текущего правила).

Вкладывать копию отправленного факса в формате:

Установите этот флажок, чтобы прикрепить копию факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию факса. Может быть TIFF, PDF или SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла для прикрепляемых факсов.

Использовать шаблон по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.
      • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Шаблоны электронной почты

Шаблоны электронной почты (Уведомления о доставке по электронной почте)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблонов электронной почты, см. главу Шаблоны электронной почты настоящего справочного руководства.

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующие шаблоны доступны для редактирования: Факс успешно отправлен, Не удалось отправить факс.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Факс успешно отправлен, см. Шаблоны электронной почты: Факс успешно отправлен . Настройки шаблона для правила Уведомления о доставке по электронной почте делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось отправить факс, см. Шаблоны электронной почты: Не удалось отправить факс . Настройки шаблона для правила Уведомления о доставке по электронной почте делаются аналогично.


Сохранить в папке

Маршрутизация исходящих факсов: сохранить в папке

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ››

При отправке факсов, вы можете настроить метод маршрутизации Сохранить в папке чтобы копировать исходящие факсы в заданные локальные или сетевые папки. В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, исходящий факс может быть скопирован в различные папки.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Сохранить в папке, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'Пользователь' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя или учетной записи факса.

Чтобы сохранять исходящие факсы в заданных папках, вы должны:

  • Настроить службу факсов Windows для отправки факсов через одну или несколько линий Fax Voip Line
  • Создать одно или более правил, в которых следует задать имена папок и формат сохранения исходящих факсов

Исходящий факс может быть маршрутизирован в одну или более локальных или сетевых папок. Исходящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Сохранить в папке определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации исходящего факса Сохранить в папке, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов, более подробную информацию см. в главе Журналы маршрутизации исходящих факсов настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: сохранить в папке содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

Пользователь

Учетная запись пользователя (учетная запись факса) отправившего факс, для которой применяется текущее правило. Правило может применяться к одной учетной записи факса или ко всем учетным записям.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли Fax Voip FSP сохранять факсы в заданных папках. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя или учетной записи факса.

Сохранить в папке

Отображает пути к папкам для хранения копий исходящих факсов.

Формат

Задает формат сохранения исходящих факсов. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла, используемый при копировании исходящих факсов в заданные папки. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

В контекстной вкладке Сохранить в папке, на ленте доступны следующие команды:

Правила сохранения в папке

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Сохранить в папке.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Сохранить в папке. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Сохранить в папке. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Сохранить в папке. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Сохранить в папке также доступны в контекстном меню списка.


Добавление или изменение правил

Добавление или изменение правил метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для исходящих, затем нажмите Сохранить в папке.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Сохранение в папке, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Номер факса получателя и Имя пользователя (учетная запись факса)). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Общие параметры .

5. Перейдите на вкладку Сохранить в папке.

6. На вкладке Сохранить в папке, поставьте флажок у параметра После отправки скопировать факс в указанные папки чтобы включить правило. В области Сохранить в папке, задайте папки для сохранения исходящих факсов. Путь к папке должен быть сначала выбран или введен в текстовое поле, после чего добавлен в список Сохранить в папках с помощью кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры сохранения .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат для сохранения исходящих факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры формата .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

11. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Сохранить в папке. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для исходящих, затем нажмите Сохранить в папке.

3. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода “Сохранить в папке”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Сохранение в папке.

  • Общие параметры
  • Параметры сохранения
  • Параметры формата


Общие параметры

Общие параметры (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Имя пользователя (учетная запись факса)

Параметры этой области позволяют выбрать, применять ли правило к одной учетной записи факса или ко всем учетным записям.

Применять правило для факсов, отправленных любым пользователем

Если выбрана эта опция, правило применяется к факсам, отправленным любым пользователем.

Учетная запись =

Если выбрана эта опция, правило применяется только к факсам, отправленным указанным пользователем. Имя пользователя (учетную запись факса) можно выбрать из раскрывающегося списка. На компьютере с Windows Server, учетные записи пользователей факса перечислены в Диспетчере службы факса (Microsoft) в разделе Учетные записи. Информация о пользователях факса хранится в подразделах раздела HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax\Accounts реестра.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры сохранения

Параметры сохранения (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры сохранения

После отправки скопировать факс в указанные папки

Данная опция позволяет разрешить или запретить процедуру сохранения в папках. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить копирование факсов в указанные папки, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя или учетной записи факса.

Сохранить в папке

В этой области, вы можете задать локальные или сетевые папки, в которых следует сохранять исходящие факсы.

<Обзор>

Нажмите эту кнопку для выбора желаемой папки с использованием системного диалогового окна Обзор папок. Можно выбрать локальную или сетевую папку.

Вы также можете вручную ввести путь к папке в текстовое поле.

Сохранить в папках

<Добавить>

Используйте эту кнопку для добавления папки в список папок. Папка должна быть изначально выбрана или введена в текстовое поле.

<Удалить>

Используйте эту кнопку для удаления папки из списка папок.


Параметры формата

Параметры формата (Сохранить в папке)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры формата

Формат сохранения исходящих факсов

В этой области можно выбрать формат сохранения факса для текущего правила.

Сохранять исходящие факсы в формате

Выберите формат сохранения для текущего правила. Исходящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла, используемый при копировании исходящих факсов в заданные папки.

Использовать шаблон по умолчанию

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.
      • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата сохранения факса).

Примечания

  • При создании файлов с одинаковыми именами (например, если задан пользовательский шаблон имени файла без использования %переменных%), к имени файла добавляется порядковый номер. Например, если шаблон имени файла - 'FAX', а формат факса - 'PDF', факсы будут копироваться в заданную папку (папки) со следующими именами: FAX.pdf, FAX (2).pdf, FAX (3).pdf ....


Печать

Маршрутизация исходящих факсов: печать

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ››

При отправке факсов, вы можете настроить выборочную печать исходящих факсов, используя метод маршрутизации Печать. В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, исходящий факс может быть напечатан с использованием различных принтеров.

Поведение определяется так называемыми правилами. Fax Voip FSP всегда проверяет правила метода Печать, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'Пользователь' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя или учетной записи факса.

Чтобы осуществлять печать исходящих факсов на заданный принтер, вы должны:

  • Настроить службу факсов Windows для отправки факсов через одну или несколько линий Fax Voip Line
  • Создать одно или более правил, в которых следует задать имена принтеров

Исходящий факс может быть маршрутизирован на один или несколько принтеров.

Максимально допустимое количество правил метода Печать определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации исходящего факса Печать, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов, более подробную информацию см. в главе Журналы маршрутизации исходящих факсов настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: печать содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

Пользователь

Учетная запись пользователя (учетная запись факса) отправившего факс, для которой применяется текущее правило. Правило может применяться к одной учетной записи факса или ко всем учетным записям.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли осуществляться печать исходящих факсов. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя или учетной записи факса.

Принтер

Отображает принтеры для печати исходящих факсов.

В контекстной вкладке Печать, на ленте доступны следующие команды:

Правила печати

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Печать.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Печать. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Печать. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Печать. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Печать также доступны в контекстном меню списка.

Примечания

  • При использовании метода Печать, печать выполняется от имени учетной записи SYSTEM (локальная система). По этой причине, выбранный принтер не должен выводить никаких дополнительных диалоговых окон перед печатью.


Добавление или изменение правил

Добавление или изменение правил метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Печать ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для исходящих, затем нажмите Печать.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Печать, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Номер факса получателя и Имя пользователя (учетная запись факса)). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Общие параметры .

5. Перейдите на вкладку Печать.

6. На вкладке Печать, поставьте флажок у параметра Напечатать факс после отправки чтобы включить правило. В области Выбор принтеров, задайте имена принтеров. Вам следует выбрать принтер в поле со списком, а затем добавить его в список Имена принтеров при помощи кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Параметры печати .

7. Нажмите кнопку <OK> чтобы зафиксировать изменения.

8. Чтобы изменить порядок предпочтений для правил метода Печать, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

9. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Печать. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Печать ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Методы для исходящих, затем нажмите Печать.

3. Чтобы изменить порядок предпочтений для правил метода Печать, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры метода “Печать”

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Печать ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Печать.

  • Общие параметры
  • Параметры печати


Общие параметры

Общие параметры (Печать)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Печать ›› Параметры метода Печать ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Имя пользователя (учетная запись факса)

Параметры этой области позволяют выбрать, применять ли правило к одной учетной записи факса или ко всем учетным записям.

Применять правило для факсов, отправленных любым пользователем

Если выбрана эта опция, правило применяется к факсам, отправленным любым пользователем.

Учетная запись =

Если выбрана эта опция, правило применяется только к факсам, отправленным указанным пользователем. Имя пользователя (учетную запись факса) можно выбрать из раскрывающегося списка. На компьютере с Windows Server, учетные записи пользователей факса перечислены в Диспетчере службы факса (Microsoft) в разделе Учетные записи. Информация о пользователях факса хранится в подразделах раздела HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax\Accounts реестра.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры печати

Параметры печати (Печать)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Печать ›› Параметры метода Печать ››

Параметры печати

Напечатать факс после отправки

Данная опция позволяет включить или отключить печать исходящих факсов. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить печать, снимите флажок. Если правило выключено, Fax Voip FSP принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя или учетной записи факса.

Выбор принтеров

В этой области, вы можете задать принтеры для печати исходящих факсов.

Перед добавлением принтера, следует выбрать его в поле со списком.

Имена принтеров

<Добавить>

Используйте эту кнопку для добавления принтера в список принтеров. Принтер должен быть предварительно выбран в поле со списком.

<Удалить>

Используйте эту кнопку для удаления принтера из списка принтеров.


Пользовательская маршрутизация

Пользовательская маршрутизация исходящих факсов

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ››

Пользовательский метод маршрутизации позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Использование этого метода не ограничено какими-либо лицензиями.

Этот метод предоставляет поставщикам программного обеспечения гибкий способ подключения приложений, которые маршрутизируют исходящие факсимильные сообщения, используя различные методы маршрутизации. Эти методы маршрутизации могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д. Поставщик программного обеспечения отвечает за разработку функций своего метода, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации.

При выполнении Пользовательского метода маршрутизации, служба Fax Voip FSP запускает указанное пользователем приложение после отправки факса. Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу и другие важные параметры, такие как номер факса получателя, TSID, CSID и т. д., а затем выполнить любые требуемые действия. Пользовательское приложение должно автоматически завершать работу после выполнения. Приложение отвечает за удаление копии факса (файл TIFF, PDF или SFF) и папки, в которой она находится. Пользовательское приложение запускается с использованием системной учетной записи Local System. Таким образом, учетная запись Local System должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение. Подробнее см. в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

Пользовательское приложение, запускаемое после отправки факса

Здесь вы можете выбрать приложение, которое будет запущено после отправки факса. Вы можете выбрать приложение, нажав на кнопку справа от текстового поля, либо ввести путь к исполняемому файлу. Пример пользовательского приложения (RouteOutCustom.exe) можно найти в папке установки Fax Voip FSP, обычно C:\Program Files (x86)\FaxVoip FSP\RouteOutCustom.exe. См. также в главе Пример пользовательского приложения настоящего справочного руководства.

Создавать временную копию отправленного факса в формате

При выборе этой опции метод создает временную папку (в папке %temp% для системной учетной записи Local System) и копирует исходящий факс (файл TIFF, PDF или SFF в зависимости от вашего выбора) в эту папку. Временная папка (%temp%) системной учетной записи Local System обычно C:\Windows\TEMP\. Путь к временному файлу (копия исходящего факса) передается в пользовательское приложение через аргумент командной строки FaxFileName. Пользовательское приложение отвечает за удаление копии факса и временной папки, в которой этот файл находится. Если флажок не установлен, метод не создает копию исходящего факса, однако пользовательское приложение все равно может получить доступ к факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Включить пользовательский метод маршрутизации

При выборе этой опции, программное обеспечение Fax Voip FSP применяет Пользовательский метод маршрутизации для всех исходящих факсов, отправляемых с помощью устройств Fax Voip Line.


Требования к пользовательскому приложению

Требования к пользовательскому приложению (информация для разработчика)

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Пользовательская маршрутизация ››

Пользовательское приложение маршрутизации, указанное пользователем, запускается службой Fax Voip FSP при выполнении Пользовательского метода маршрутизации, после отправки факса. Индивидуальный разработчик отвечает за разработку этого приложения, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации. Функции приложения могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д.

Ниже приведены общие требования, которые должны быть приняты во внимание разработчиками программного обеспечения при написании пользовательских приложений.

Аргументы командной строки

Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу и другие важные параметры, такие как номер факса получателя, TSID, CSID и т. д.

Ниже приведен пример аргументов командной строки, переданных вашему приложению:

/@@@FaxFileName=C:\WINDOWS\TEMP\201d656403e9a8c_oc\FAX.pdf

/@@@RecipientFaxNumber=19012223344 /@@@RecipientName=John Smith

/@@@SenderName=Dan Black /@@@SenderFaxNumber=(631) 490-2023

/@@@SenderTSID=(631) 490-2023 FAX /@@@SenderEmail=Dan@t38faxvoip.com

/@@@SenderCompany=FaxVoip Software, LLC /@@@SenderDepartment=Sales

/@@@SenderTitle=Sales Manager /@@@SenderOfficeLocation=14

/@@@SenderHomePhone=(425) 686-1097 /@@@SenderOfficePhone=(631) 490-1288

/@@@SenderAddress=324 6th Avenue\n10014 New York\nUSA /@@@SenderBillingCode=015

/@@@DocumentName=invoice07_10_20_003.pdf;Information.txt /@@@HasCoverPage=1

/@@@Subject=This is the subject line on the cover page of the fax.

/@@@PagesTotal=4 /@@@TiffSize=132386

/@@@CSID=(901) 222-3344 /@@@TSID=Fax Voip FSP /@@@Priority=1

/@@@SubmissionTime=07.10.2020@01:28:18 /@@@OriginalScheduledTime=07.10.2020@01:28:18

/@@@StartTime=07.10.2020@01:32:49 /@@@EndTime=07.10.2020@01:36:14 /@@@Duration=00:03:25

/@@@Retries=0 /@@@PagesTransferred=4 /@@@DeviceName=Fax Voip Line 0

/@@@Status=OK /@@@JobId=201d656bff5f86f /@@@BroadcastId=2001d656bff5f75e

/@@@FaxAccount=SERVER\Administrator

Аргументы командной строки приблизительно соответствуют элементам следующих объектов: FaxOutgoingJob , FaxOutgoingMessage , FaxRecipient , FaxSender , см. документацию Fax Service Extended COM Reference .

/@@@FaxFileName=

Временная копия факса (файл TIFF, PDF или SFF в зависимости от вашего выбора), связанная с отправляемым факсимильным документом. Этот файл и временная папка, в которой он находится (в папке %temp% для системной учетной записи Local System), должны быть удалены в пользовательском приложении маршрутизации после выполнения необходимых действий. Если флажок Создавать временную копию отправленного факса... не установлен, этот аргумент отсутствует в командной строке. См. также в главе Пользовательская маршрутизация исходящих факсов настоящего справочного руководства.

/@@@RecipientFaxNumber=

Номер факса получателя.

/@@@RecipientName=

Имя получателя. Отображается на титульной странице.

/@@@SenderName=

Имя отправителя.

/@@@SenderFaxNumber=

Номер факса отправителя.

/@@@SenderTSID=

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается в верхней части каждой страницы отправляемого факса. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание аргумента командной строки TSID.

/@@@SenderEmail=

Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.

/@@@SenderCompany=

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).

/@@@SenderDepartment=

Имя отдела отправителя.

/@@@SenderTitle=

Должность отправителя.

/@@@SenderOfficeLocation=

Номер офиса (комнаты) отправителя.

/@@@SenderHomePhone=

Номер домашнего телефона отправителя.

/@@@SenderOfficePhone=

Номер рабочего телефона отправителя.

/@@@SenderAddress=

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну. Для индикации переноса строк используется символ '\n'.

/@@@SenderBillingCode=

Код биллинга, связанный с отправителем.

/@@@DocumentName=

Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.

/@@@HasCoverPage=

Указывает, содержит ли факс титульную страницу. Допустимые значения: 1 - с титульной страницей, 0 - без титульной страницы.

/@@@Subject=

Содержит тему факса (отображается на титульной странице).

/@@@PagesTotal=

Общее количество страниц в исходящем факсе.

/@@@TiffSize=

Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с исходящим факсом, в байтах.

/@@@CSID=

Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.

/@@@TSID=

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с SenderTSID, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.

/@@@Priority=

Важность факса. Допустимые значения: 0 - низкая, 1 - обычная, 2 - высокая.

/@@@SubmissionTime=

Время формирования задания исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@OriginalScheduledTime=

Время, на которое первоначально была запланирована отправка факсимильного сообщения, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@StartTime=

Время начала передачи исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@EndTime=

Время окончания передачи исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@Duration=

Представляет общее время, прошедшее между началом и окончанием передачи факса в формате 'hh:mm:ss'.

/@@@Retries=

В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.

/@@@PagesTransferred=

Число успешно переданных страниц факса.

/@@@DeviceName=

Имя устройства, которое использовалось при отправке факса.

/@@@Status=

Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.

/@@@JobId=

Уникальный номер, который идентифицирует задание факса, связанное с отправкой факсимильного документа.

/@@@BroadcastId=

Уникальный номер, присвоенный заданию факса в процессе отправки. При отправке факса более чем одному получателю, будут созданы отдельные задания факса, но как часть одной и той же рассылки, они будут иметь один и тот же идентификатор рассылки (Broadcast ID).

/@@@FaxAccount=

Имя учетной записи пользователя, который отправил факс.

Временная копия отправленного факса

Если установлен флажок Создавать временную копию отправленного факса... (см. в главе Пользовательская маршрутизация исходящих факсов настоящего справочного руководства), Пользовательский метод маршрутизации создает временную папку и копирует исходящий факс (файл TIFF, PDF или SFF в зависимости от вашего выбора) в эту папку. Временная папка создается в папке %temp% для системной учетной записи Local System. Путь к временному файлу (копия исходящего факса) передается в пользовательское приложение через аргумент командной строки FaxFileName, см. выше.

Например,

/@@@FaxFileName=C:\WINDOWS\TEMP\201d656403e9a8c_oc\FAX.pdf

Путь к факсу (PDF формат):

C:\WINDOWS\TEMP\201d656403e9a8c_oc\FAX.pdf

Путь к временной папке:

C:\WINDOWS\TEMP\201d656403e9a8c_oc\

Временная папка, в которой находится факс (FAX.tif, FAX.pdf или FAX.sff), может использоваться вашим пользовательским приложением для хранения временных файлов, создаваемых вашим приложением.

Пользовательское приложение отвечает за удаление временной копии факса и временной папки, в которой она находится. Вы должны навсегда удалить временную папку в своем приложении после выполнения всех необходимых действий.

Если флажок Создавать временную копию отправленного факса... не установлен, Пользовательский метод маршрутизации не создает копию исходящего факса, однако пользовательское приложение все равно может получить доступ к факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Запуск под системной учетной записью Local System

Пользовательское приложение запускается в контексте службы Fax Voip FSP от имени системной учетной записи Local System. Таким образом, учетная запись Local System должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение.

Завершение приложения

Пользовательский метод маршрутизации запускает пользовательское приложение маршрутизации в отдельном потоке путем вызова функции CreateProcess . Служба Fax Voip FSP не отслеживает приложение после его запуска и не гарантирует его корректное завершение. Разработчик пользовательского приложения отвечает за правильное автоматическое завершение работы приложения после его выполнения.


Пример пользовательского приложения

Панель управления Fax Voip FSP ›› Методы маршрутизации для исходящих факсов ›› Пользовательская маршрутизация ››

Пример пользовательского приложения маршрутизации (RouteOutCustom.exe) можно найти в папке установки Fax Voip FSP, обычно C:\Program Files (x86)\FaxVoip FSP\RouteOutCustom.exe.

Исходные коды (архив RouteOutCustom.zip) можно найти в папке данных Fax Voip FSP, обычно C:\ProgramData\FaxVoip FSP\Samples\RouteOutCustom.zip. Чтобы распаковать архив, щелкните его правой кнопкой мыши и выберите Извлечь все... из контекстного меню.

Пример кода - консольное приложение, написанное на языке Visual Basic .Net, которое может быть скомпилировано с использованием Microsoft Visual Studio 2013 или более поздней версии.

В этом примере демонстрируется использование пользовательского метода маршрутизации для исходящих факсов, с учетом требований, предъявляемых к написанию такого приложения, см. также в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

  • Приложение анализирует предопределенную командную строку и заполняет внутреннюю структуру, где оно сохраняет путь к временной копии факса (файл TIFF, PDF или SFF в зависимости от вашего выбора) и другие параметры маршрутизации, такие как номер факса получателя, TSID, CSID и т.д.
  • Записывает информацию о маршрутизации в стандартный ini-файл.
  • Копирует временный TIFF, PDF или SFF файл в указанную папку с уникальным именем, которое содержит дату и время отправки факса.
  • Перед тем как завершить работу, приложение удаляет временную папку и временную копию факса, которая находится в этой папке.
  • Приложение автоматически завершается после выполнения всех необходимых действий.
  • Приложение использует папки и файлы, для которых системная учетная запись Local System заведомо имеет доступ на запись.

Чтобы использовать пример

1. Скопируйте файл RouteOutCustom.exe в папку установки Fax Voip FSP. Вы можете использовать другую папку, но убедитесь, что учетная запись Local System имеет доступ к используемой папке.

2. Откройте Панель управления Fax Voip FSP. Нажмите Методы для исходящих, затем нажмите Пользовательский.

3. На странице Пользовательская маршрутизация исходящих факсов, установите флажок Включить пользовательский метод маршрутизации.

4. В поле Пользовательское приложение, запускаемое после отправки факса, введите путь к файлу RouteOutCustom.exe, либо выберите файл, нажав на кнопку справа от текстового поля.

5. Установите флажок Создавать временную копию отправленного факса... . Выберите формат файла, в котором должна быть создана временная копия исходящего факса. Может быть TIFF, PDF или SFF.

6. Нажмите кнопку <Применить>, чтобы сохранить изменения.

После отправки факса,

1. Откройте папку данных Fax Voip FSP в проводнике Windows, обычно C:\ProgramData\FaxVoip FSP\.

2. В подпапке RouteOutCustom найдите файл RouteOutCustom.ini.

3. В подпапке RouteOutCustom\Outgoing Faxes найдите копию исходящего факса.

4. Файл журнала маршрутизации RouteOutCustom.txt сохраняется в подпапке log.


Факс

Панель управления Fax Voip FSP ››

  • Параметры факса
  • Интеллектуальная повторная передача факса
  • Набор номера
  • Таймауты факса
  • Параметры конвертации в факс
  • Параметры printto
  • Параметры просмотра факсов


Параметры факса

Панель управления Fax Voip FSP ›› Факс ››

Fax Voip FSP использует службу факсов Windows и приложение Факсы и сканирование Windows для отправки и получения факсов.

Нажмите, чтобы запустить факсы и сканирование Windows

Запустить приложение Факсы и сканирование Windows.

Нажмите, чтобы открыть диспетчер службы факсов

Открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Нажмите для отображения свойств принтера факсов

Отображение свойств принтера факсов.

Нажмите, чтобы отправить новый факс

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Нажмите, чтобы отправить пробную страницу факса

Нажмите чтобы создать и отправить пробную страницу факса с использованием принтера факсов.

Примечания

  • Для получения дополнительных сведений по настройке службы факса, обратитесь к разделу Служба факсов Windows .
  • Для получения дополнительных сведений по отправке и получению факсов, обратитесь к разделу Отправка и получение факсов .


Интеллектуальная повторная передача факса

Панель управления Fax Voip FSP ›› Факс ››

В Fax Voip FSP реализована система интеллектуальной повторной передачи факса. Вкратце, при повторе после неудачи, передача факса начинается с первой страницы, которая не была успешно передана, чтобы избежать повторной отправки уже переданных страниц.

Проблемы неполной передачи факса возникают из-за плохого качества телефонной линии, что отчасти обусловлено ростом IP-телефонии (VoIP). Процесс передачи факса, изначально разработаный для PSTN (коммутируемая телефонная сеть общего пользования), с большей трудностью завершает передачу и часто требует нескольких повторных попыток для завершения в среде VoIP. Кроме того, с увеличением количества страниц шансы на успешную передачу уменьшаются. В протоколе факса отсутствует система подсчета страниц, поэтому 100-страничный факс, передача которого прервалась после отправки 90 страниц, при следующей попытке будет передаваться заново начиная с первой страницы. Эта система приводит к путанице для получателя, который получает многочисленные копии одних и тех же страниц, и не уверен, когда факс завершен, а также приводит к продолжительным и долгим передачам, вместо отправки только оставшихся пропущенных страниц.

Система интеллектуальной повторной передачи факса позволяет доставить завершенный факс быстрее, чем без ее использования, а также сократить телефонные и компьютерные ресурсы, используемые факсом в случае незавершенной передачи, за счет отправки только оставшихся страниц не полностью отправленного факсимильного документа, а не документа целиком, включая страницы, которые уже были переданы.

Fax Voip FSP подсчитывает страницы в отправляемом факсимильном документе и отслеживает количество успешно и не успешно переданных страниц. В случае неудачной передачи факса, Fax Voip FSP сохраняет количество успешно переданных страниц и уникальный номер, идентифицирующий задание исходящего факса (присваивается факс-сервером), в своей внутренней коллекции. Когда факс-сервер перезапускает задание, Fax Voip FSP использует эту информацию и начинает отправку с первой страницы, которая не была успешно передана, а не с первой страницы факса.

При повторе после неудачи, начинать передачу факса с первой страницы, которая не была успешно передана, чтобы избежать повторной отправки уже переданных страниц.

Установите этот флажок, чтобы при повторе отправлять только оставшиеся страницы не полностью переданного факсимильного документа, а не весь документ, включая страницы, которые уже были переданы.

Нажмите для получения дополнительной информации

Нажмите, чтобы прочитать об интеллектуальной повторной передаче факса (текущая глава).

При использовании функции интеллектуальной повторной передачи факса, обратите внимание на следующее:

  • Fax Voip FSP хранит информацию о неудачных передачах факса и количестве успешно переданных страниц в своей внутренней коллекции. В текущей реализации эта информация не сохраняется где-либо на жестком диске или во внешней базе данных, и будет потеряна при перезапуске службы Fax Voip FSP. После перезапуска службы, любой повторно отправляемый факс будет передаваться начиная с первой страницы факса.
  • Для получения информации о количестве успешно переданных страниц факса и правильного связывания этой информации с уникальным номером, идентифицирующим задание исходящего факса, служба Fax Voip FSP (запускается под учетной записью локальной системы) должна иметь разрешение на Просмотр заданий для исходящих факсов на факс-сервере, см. ниже.
  • Чтобы использовать функцию интеллектуальной повторной передачи факса в Windows 7 или Windows Server 2008R2, необходимо вручную установить исправление (KB2535158), предоставленное Microsoft, см. ниже.

Количество повторов при отправке факса и интервал между ними (Windows 11)

1. В меню иконки Fax Voip FSP в системном трее выберите команду Факсы и сканирование Windows, либо нажмите Факсы и сканирование Windows в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса....

3. В окне Параметры факса, на вкладке Дополнительно, в области Повторный набор номера, в поле Число попыток, задайте максимальное число повторов передачи (0-99) перед тем как задание факса перейдет в состояние Предел повторов исчерпан. В поле Повторять набор номера через, задайте интервал в минутах (0-999) между концом предыдущей неудачной попытки передать факс и следующим повтором. Нажмите Применить.

Количество повторов при отправке факса и интервал между ними (Windows Server 2022)

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Исходящие, в области Передача факсов, в поле Число повторов, задайте максимальное число повторов передачи (0-99) перед тем как задание факса перейдет в состояние Предел повторов исчерпан. В поле Повтор через, задайте интервал в минутах (0-999) между концом предыдущей неудачной попытки передать факс и следующим повтором. Нажмите Применить.

Предоставление доступа к заданиям исходящих факсов для службы Fax Voip FSP (учетной записи локальной системы)

Для получения информации о количестве успешно переданных страниц факса и правильного связывания этой информации с уникальным номером, идентифицирующим задание исходящего факса, служба Fax Voip FSP (запускается под учетной записью локальной системы) должна иметь разрешение на Просмотр заданий для исходящих факсов на факс-сервере. Обычно это настраивается автоматически при установке Fax Voip FSP, см. также Регистрация провайдера службы факсов . Чтобы настроить разрешения вручную, выполните следующие действия:

1. В Windows 11, в Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса..., а затем перейдите на вкладку Безопасность. В Windows Server 2022, в Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

2. На вкладке Безопасность, нажмите Дополнительно.

3. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения SYSTEM (СИСТЕМА) и нажмите Изменить. Если запись разрешения SYSTEM (СИСТЕМА) отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите SYSTEM либо СИСТЕМА, нажмите Проверить имена, нажмите OK.

4. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажок Просмотр заданий для исходящих факсов. Нажмите OK. См. картинку ниже.

5. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.

Устранение неполадок в Windows 7 и Windows Server 2008R2 (применение исправления от Microsoft)

На компьютере с Windows 7 или Windows Server 2008R2, функционал интеллектуальной повторной передачи факса обычно не работает по умолчанию. Это связано с тем, что служба Fax Voip FSP (запускается под учетной записью локальной системы), которая использует Fax Service Extended COM API, не может получить доступ к факсам, созданным под учетными записями других пользователей. Эта проблема возникает, даже если учетная запись локальной системы имеет необходимые разрешения для доступа к факсам всех пользователей (разрешение на Просмотр заданий для исходящих факсов на факс-сервере), см. выше. Проблема описана в следующей статье на сайте Microsoft:

https://support.microsoft.com/en-us/help/2535158/an-application-that-uses-the-fax-service-extended-com-api-only-enumera

Чтобы устранить проблему, необходимо вручную установить исправление (KB2535158), предоставленное Microsoft. К сожалению, это исправление больше не доступно для загрузки с веб-сайта Microsoft. Вы можете найти необходимые установочные пакеты (как 64-битный, так и 32-битный) в папке установки Fax Voip FSP, скорее всего, путь будет следующим: C:\Program Files (x86)\FaxVoip FSP\FixJobEnum_Win7_2008R2\. Кроме того, вы можете загрузить необходимый установочный пакет с веб-сайта Fax Voip.

Чтобы устранить проблему в 64-разрядной версии Windows 7 или в Windows Server 2008R2, загрузите и установите следующий пакет:

https://www.t38faxvoip.com/downloads/Windows6.1-KB2535158-x64.zip

Чтобы устранить проблему в 32-разрядной версии Windows 7, загрузите и установите следующий пакет:

https://www.t38faxvoip.com/downloads/Windows6.1-KB2535158-x86.zip

После применения исправления необходимо перезагрузить компьютер.


Набор номера

Набор номера (телефония Microsoft)

Панель управления Fax Voip FSP ›› Факс ››

Правила набора номера, предоставляемые интерфейсом программирования приложений телефонии Windows (TAPI) используются службой факсов Windows и приложением Факсы и сканирование Windows при преобразовании номеров факсов, введенных пользователем в каноническом формате.

Канонический формат телефонного номера - это универсальный формат, который явно определяет компоненты телефонного номера, используемый TAPI для преобразования номера в соответствии с правилами набора для страны или региона. Номер в каноническом формате выглядит следующим образом:

+КодСтраны (КодГорода) НомерАбонента

+

Указывает, что номер телефона представлен в каноническом формате.

КодСтраны

Стандартный код страны/региона, определяющий страну или регион для телефонного номера. Содержит одну или несколько цифр от 0 до 9. Код страны/региона отделяется пробелом, который следует за ним.

(КодГорода)

Телефонный код города. Может содержать одну или несколько цифр от 0 до 9. Код города заключен в круглые скобки. Этот компонент опускается для стран/регионов, в которых не используются коды городов.

(НомерАбонента)

Телефонный номер абонента. Обычно содержит одну или несколько цифр от 0 до 9 и символы форматирования.

Например, вот как вы должны ввести номер абонента в России в каноническом формате телефонного номера:

+7 (812) 346-7890

При выборе определенного правила в окне Новый факс в программе Факсы и сканирование Windows, правило набора применяется во время создания задания факса. В этом случае набираемый номер также преобразуется во время создания задания факса и не может быть изменен позже. В программе Факсы и сканирование Windows номер факса будет отображаться с использованием символов форматирования (пробелы и дефисы).

При выборе (нет) в поле Правило набора в окне Новый факс в программе Факсы и сканирование Windows, или при создании факса с использованием Fax Service API, правила набора не применяются во время создания задания факса, при этом программа Факсы и сканирование Windows отображает номер факса без изменений, в том же формате, в котором он был введен. В этом случае используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) применяется в момент набора номера факса.

В случае номера факса в неканоническом формате, он набирается и отображается без изменений, в том же формате, в котором он был введен.

На этой странице вы можете настроить правила набора номера, проверить как будет набираться номер факса и как он будет отображаться в программе Факсы и сканирование Windows.

Правило набора

Выберите правило набора номера (местоположение). Аналогично выбору правила в окне Новый факс в программе Факсы и сканирование Windows.

(нет)

Правило набора номера не применяется во время создания задания факса. Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) применяется в момент набора номера факса.

<конкретное правило>

Выбранное правило набора номера применяется во время создания задания факса.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Телефонная карточка

Телефонная карточка, связанная с используемым местоположением. Информация о телефонной карточке игнорируется, если выбрано (нет) и используемое по умолчанию правило набора применяется в момент набора номера факса.

<По умолчанию>

Нажмите чтобы использовать выбранное местоположение по умолчанию (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows).

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows. Может содержать символы форматирования (пробелы и дефисы).

Набираемый номер

Номер факса, как он будет набираться после применения правил набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Набираемый номер может содержать специальные символы, такие как 'W', ',', '#' и т. д. Например в России и большинстве стран бывшего СНГ применяется префикс 8W10 для международных вызовов и префикс 8W для междугородних вызовов. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .

В таблице ниже приведены примеры правил маршрутизации исходящих VOIP вызовов , которые можно использовать при выборе 'Россия' в качестве страны в настройках местоположения и требования набирать код страны и код города перед номером. Например, номер +7 (812) 346-7890 будет преобразован в 8W8123467890 через TAPI, а затем дополнительно преобразован в 78123467890 через правила маршрутизации исходящих VOIP вызовов.

Правило # | Если номер начинается с цифр | Удалить цифры | Добавить
#1 | 8W10 | 4 |
#2 | 8W | 2 | 7
#3 | общее правило для всех остальных номеров, не преобразующее номер

В примере ниже перед кодом страны будет дополнительно добавлен префикс 00. Например, номер +49 (30) 123-45-678 будет преобразован в 8W10493012345678 через TAPI, а затем дополнительно преобразован в 00493012345678 через правила маршрутизации исходящих VOIP вызовов.

Правило # | Если номер начинается с цифр | Удалить цифры | Добавить
#1 | 8W10 | 4 | 00
#2 | 8W | 2 | 007
#3 | общее правило для всех остальных номеров, не преобразующее номер

Примечания

  • Правила набора номера не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Общие сведения о правилах набора номера

Панель управления Fax Voip FSP ›› Факс ›› Набор номера ››

Интерфейс программирования приложений телефонии (TAPI) позволяет настраивать правила набора номера для всех программ телефонии. При запуске программы до настройки правил набора номера (например, при попытке отправить факс с помощью программы Факсы и сканирование Windows), обычно запрашивается минимум сведений, необходимых для набора номера. Вам необходимо выбрать страну или регион и ввести телефонный код города. Тоновый набор номера установлен по умолчанию и должен быть выбран для большинства телефонных служб.

Для полной настройки правил набора номера на компьютере используется объект Телефон и модем в панели управления Windows, как описано ниже.

Местоположение вызова

Местоположение вызова представляет собой набор параметров, используемых для анализа телефонных номеров и определения правильной последовательности набора номера. Допускается создание любого числа местоположений вызова для различных целей.

Местоположение вызова может соответствовать фактическому географическому положению, такому как кабинет или гостиничный номер, где для выхода на внешнюю линию требуется набрать код. Если работа сопряжена с поездками в разные города или страны, можно создать местоположение вызова для каждого кода области, города или страны.

Местоположение вызова также может быть создано для правил набора номера, не обязательно связанных с географическим положением. Например, различные правила набора номера могут быть созданы для различных целей.

Сведения о местоположении вызова включают в себя следующие параметры:

  • Имя
  • Страну или регион
  • Код города (области)
  • Правила набора номера
  • Правила набора кода города
  • Сведения о телефонной карточке

Задание имен и использование местоположений вызова

Для местоположения вызова можно задать любое запоминающееся имя. По умолчанию для набора номеров используется местоположение, выбранное в диалоговом окне Телефон и модем. Многие программы телефонии, такие как Факсы и сканирование Windows, позволяют выбирать местоположение вызова перед набором номера. При выполнении междугороднего звонка программа телефонии использует сведения о наборе номера, заданные для текущего местоположения вызова.

Доступные местоположения вызова отображаются на вкладке Набор номера диалогового окна Телефон и модем, открываемого из панели управления Windows. На этой вкладке можно выбрать местоположение вызова, используемое по умолчанию, создать новое местоположение вызова, или изменить любое существующее местоположение.

Чтобы открыть диалоговое окно Телефон и модем, переключитесь на панель Поиск, наберите телефон и модем, а затем нажмите Телефон и модем. Кроме того, вы можете выбрать Факс -> Набор номера в дереве Панели управления Fax Voip FSP , а затем нажать <Настроить правила>, см. также главу Набор номера (телефония Microsoft) настоящего справочного руководства.

Чтобы создать новое местоположение вызова, нажмите Создать... . Чтобы изменить существующее местоположение, выберите его и нажмите Изменить... .

Общие правила местоположения вызова

Общие правила местоположения задают имя местоположения, страну или регион, а также код города. Тоновый тип набора номера установлен по умолчанию и должен быть выбран для большинства телефонных служб. Используемые по умолчанию правила набора номера для местных, междугородных и международных звонков определяются выбором страны или региона. Правила набора номера задают префикс выхода на междугородную линию и префикс выхода на международную линию, набираемые перед телефонными номерами других городов или стран.

Правила набора кода города

Правила набора кода города позволяют изменить порядок набора номеров внутри страны или региона. Стандартные правила набора телефонных номеров других городов часто требуют, чтобы программой набирался префикс выхода на междугородную линию, код города, а затем номер телефона. Для вызова номеров в том же городе программой набирается только номер телефона нужного абонента.

Чтобы создать новое правило набора кода города, нажмите Создать... . Для изменения существующего правила, выберите его и нажмите Изменить... .

В приведенном ниже примере мы добавляем код страны '7' и код города перед номером для вызовов в пределах кода города '495', который соответствует нашему местоположению.

Телефонные карточки

Местоположение вызова может использовать настройки телефонной карточки для указания префиксов выхода на междугородную линию или международную линию, которые не являются стандартными для страны или области. Что касается программного обеспечения службы факсов Windows (запускаемого под учетной записью сетевой службы), следует понимать, что информация о телефонной карточке привязана к учетной записи текущего пользователя и игнорируется, если используемое по умолчанию правило набора применяется в момент набора номера факса.


Таймауты факса

Панель управления Fax Voip FSP ›› Факс ››

Использование опций Таймауты факса позволяет Fax Voip FSP принудительно завершить VoIP вызов и освободить ресурсы факса (виртуальные устройства Fax Voip Line).

При обычном сценарии, Fax Voip FSP автоматически завершает вызов после успешной передачи или успешного приема факса, а также в случае получения финальной статистики о неудачной передаче или неудачном приеме факса от модуля факса. Вызов также завершается (и ресурсы факса освобождаются), когда удаленная сторона кладет трубку. Корректное завершение вызова также обеспечивается набором внутренних таймаутов в низкоуровневых кодах Fax Voip FSP. На практике, по различным причинам (удаленная сторона не повесила трубку, ошибки в SIP сигнализации), редко, но возможны ситуации, при которых вызов не завершается в течении разумного времени. Использование таймаутов гарантирует завершение вызова в любом случае и помогает избежать зависших вызовов.

Передача факса (исходящие вызовы)

Опции ниже применяются к исходящим факсам:

Ждать ответа на вызов не более ... секунд

Определяет, как долго Fax Voip FSP должен ждать ответа на вызов до истечения времени ожидания. Таймаут по умолчанию: 90 секунд. Допустимые значения: от 10 до 180 секунд. Обратите внимание, что телефонная система обычно прекращает вызов, если на него не отвечают в течение 60-90 секунд.

Время установки связи с факсом, не более ... секунд

Максимальное время ожидания начала передачи факса. Отсчет времени ведется от момента определения ответа на вызов до момента начала передачи первой страницы факса. Таймаут по умолчанию: 90 секунд. Допустимые значения: от 10 до 180 секунд.

Время передачи одной страницы факса, не более ... минут

Максимальное время передачи одной страницы факса. Таймаут по умолчанию: 15 минут. Допустимые значения: от 5 до 90 минут. Обратите внимание, что фактическое время передачи страницы факса зависит от многих факторов: содержимого страницы, скорости передачи факса, использования Коррекции ошибок (ECM) и т.д.

Максимальная продолжительность исходящего вызова ... минут

Максимальная продолжительность исходящего вызова. Таймаут по умолчанию: 60 минут. Допустимые значения: от 5 до 90 минут. Обратите внимание, что многие поставщики услуг телефонной связи принудительно прерывают любой вызов по истечении 30-90 минут.

Прием факса (входящие вызовы)

Опции ниже применяются к входящим факсам:

Время установки связи с факсом, не более ... секунд

Максимальное время ожидания начала приема факса. Отсчет времени ведется от момента ответа на входящий вызов до момента начала приема первой страницы факса. Таймаут по умолчанию: 90 секунд. Допустимые значения: от 10 до 180 секунд.

Время приема одной страницы факса, не более ... минут

Максимальное время приема одной страницы факса. Таймаут по умолчанию: 15 минут. Допустимые значения: от 5 до 90 минут. Обратите внимание, что фактическое время передачи страницы факса зависит от многих факторов: содержимого страницы, скорости передачи факса, использования Коррекции ошибок (ECM) и т.д.

Максимальная продолжительность входящего вызова ... минут

Максимальная продолжительность входящего вызова. Таймаут по умолчанию: 60 минут. Допустимые значения: от 5 до 90 минут. Обратите внимание, что многие поставщики услуг телефонной связи принудительно прерывают любой вызов по истечении 30-90 минут.


Конвертация в факс

Параметры конвертации в факс

Панель управления Fax Voip FSP ›› Факс ››

Функция Прямая конвертация в факс позволяет конвертировать некоторые из наиболее популярных графических форматов файлов в совместимый формат факса (TIFF). В настоящее время используется с функцией Почта-на-факс и при отправке факса с помощью утилиты командной строки SendFax.exe .

В случае использования Прямой конвертации в факс, установка приложения, которое ассоциируется в системе с требуемым расширением файла, не требуется. Обратите внимание, что в силу дизайна программного обеспечения службы факсов Windows, фоновая печать используется в любом случае. Однако в случае Прямой конвертации в факс, производится печать временного файла TIFF (полученного в результате прямой конвертации), а не оригинального документа (например PDF).

В настоящий момент поддерживаются следующие форматы (могут быть преобразованы в факс напрямую):

*.pdf (Файл Adobe PDF) (по умолчанию)

*.tif, *.tiff (Рисунок TIFF) (по умолчанию)

*.sff (Structured Fax File) (по умолчанию)

*.qfx (Ventafax QFX файл) (по умолчанию)

*.bmp (Точечный рисунок)

*.jpg, *.jpeg (Рисунок JPEG)

*.gif (Рисунок GIF)

*.png (Рисунок PNG)

*.ico (Файл ICO)

*.wmf, *.emf (Метафайлы Windows)

Наиболее распространенной проблемой, которая может быть решена с помощью Прямой конвертации в факс, является возможность использования PDF файлов в качестве вложений электронной почты с функцией Почта-на-факс . Установка Adobe Reader также как и Acrobat Wrapper не требуется. Нет необходимости в сложных настройках для обеспечения работоспособности функции Почта-на-факс при работе с PDF вложениями.

Выберите типы файлов к которым применяется прямая конвертация в формат факса

Эта таблица содержит список типов файлов которые могут быть преобразованы в формат факса напрямую. Если тип файла выбран, процедура Прямой конвертации в факс будет применяться ко всем файлам этого типа. Если тип файла не выбран, файл будет распечатан с использованием принтера Fax и приложения, которое ассоциируется в системе с данным типом файлов. Все остальные типы файлов, не перечисленные в таблице, всегда печатаются с использованием принтера Fax и приложения, которое ассоциируется в системе с данным типом файлов.

Параметры TIFF

Эти параметры позволяют задать формат факса (файла TIFF на выходе), созданного в результате Прямой конвертации в факс.

Автоповорот

Этот параметр определяет будет ли применяться алгоритм автоматического выбора ориентации. Если данная опция включена и оригинальный документ имеет альбомную ориентацию, то при преобразовании в факс документ будет повернут на 90 градусов по часовой стрелке. Если эта опция выключена, будет сохранена исходная ориентация. В зависимости от настроек принтера факсов этот параметр может быть проигнорирован.

Страница A4

Если данная опция включена, Fax Voip FSP устанавливает ширину страницы равной 1728 и высоту страницы в диапазоне 1100...1210 (при разрешении 204x98 dpi) либо в диапазоне 2200...2420 (при разрешении 204x196 dpi). Если эта опция выключена, Fax Voip FSP не контролирует высоту страницы. В зависимости от настроек принтера факсов этот параметр может быть проигнорирован.

Передача полутонов

Полутона (Halftone) - это репрографическая техника которая имитирует непрерывную передачу изображения путем использования точек, различающихся по размеру, форме либо интервалу между ними. Опцию Передача полутонов рекомендуется использовать при конвертации цветных документов в формат факса. Если эта опция выключена, цветное изображение преобразованное в черно-белый факс, будет очень низкого качества. Следует заметить что в случае прямой конвертации при применении Передачи полутонов используются настройки системы Windows по умолчанию. По этой причине, если факс создан из цветного документа и включена опция Передача полутонов, время передачи такого факса будет достаточно велико. Факс, созданный с использованием принтера Fax (из того же цветного документа) имеет приемлемое качество и передается значительно быстрее. Заметим также что в случае Прямой конвертации PDF файлов, содержащих цветные изображения, эта опция игнорируется, Передача полутонов всегда применяется, время передачи факса не очень велико и качество факса приемлемое.

Результаты применения различных комбинаций рассмотренных выше опций показаны на рисунке ниже:

Примечания

  • Прямая конвертация в факс не применяется если пользователь осуществляет печать документа с использованием принтера Fax.
  • Мы бы рекомендовали использовать Прямую конвертацию в факс при работе с PDF файлами, особенно при использовании функции Почта-на-факс и PDF файлов в качестве вложений электронной почты .


Параметры printto

Панель управления Fax Voip FSP ›› Факс ››

Стандартные команды printto используются операционной системой Windows чтобы связать расширение файла с приложением, которое отвечает за печать файлов с этим расширением. Например, для печати текстового документа (*.txt) обычно используется Блокнот (notepad.exe). Для печати файлов с расширениями .doc и .rtf используется Microsoft Word. Печать файлов PDF обычно ассоциируется с приложением Acrobat Reader и т.д. Для печати файлов различных графических форматов как правило используется системная библиотека shimgvw.dll либо приложение Paint.

Приложения Факсы и сканирование Windows и Fax Voip FSP используют функцию printto в следующих случаях:

  • При создании факса с использованием команды Создать факс в приложении Факсы и сканирование Windows и добавлением документа путем выбора пункта меню Вставка -> Вложение файла... .
  • При выборе команды Отправить -> Получатель факса из контекстного меню файла в проводнике Windows.
  • При создании факса с использованием команды Создать факс в Панели управления Fax Voip FSP или с помощью команды Отправить факс из контекстного меню значка Fax Voip FSP в системном трее.
  • При использовании функции Почта-на-факс (методы FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 , Fax Service API)
  • При отправке факса с помощью утилиты командной строки SendFax.exe (методы FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 , Fax Service API)

Функция printto очень удобна, однако зависит от установленных на компьютере приложений и пользовательских настроек. Отсутствие правильных ассоциаций файлов приводит к неработоспособности вышеперечисленных функционалов с отдельными расширениями файлов. Даже в случае хорошо известных расширений, ассоциации файлов могут быть повреждены после установки нового приложения. Начиная с Windows Vista отсутствует возможность настройки команд printto через пользовательский интерфейс. В Windows 11, Windows 10 и Windows 8 / 8.1 ассоциации по умолчанию не позволяют использовать printto со многими стандартными расширениями файлов. В ОС Windows Server эта проблема отсутствует, потому что новые приложения Windows Store (Магазин) по умолчанию не установлены.

Описанная здесь функция восстанавливает правильные ассоциации для стандартных типов файлов, а также устраняет другие проблемы связанные с печатью.

Обратите внимание, что на компьютере с Windows 11 и Windows 10 функция, описанная в текущей главе, не способна разрешить все проблемы и ассоциации файлов необходимо назначать вручную, см. главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.

Параметры printto

Нажмите, чтобы узнать как исправить ассоциации файлов в Windows 11 и Windows 10

Нажмите чтобы открыть главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства. Эта глава содержит важную информацию для пользователей Windows 11 или Windows 10. Приведенная информация также может быть полезна для пользователей других операционных систем, в частности Windows 8/8.1 или Windows Server 2022/2019/2016/2012/2012R2.

<Исправить команды ‘printto’>

Нажмите чтобы исправить ассоциации printto для стандартных типов файлов, а также устранить другие проблемы связанные с печатью. Для использования этой опции обычно требуются права администратора. Права администратора запрашиваются только в случае необходимости.

В зависимости от операционной системы, применяются следующие исправления:

В Windows 11 / 10 / 8 / 8.1 64-bit и Windows Server 2022 / 2019 / 2016 / 2012 / 2012R2

Исправление печати из-под служб Windows. Хорошо известная проблема. Приложение не видит установленные в системе принтеры. В случае вызова метода FaxDocument.ConnectedSubmit2 (Fax Service API) приложение зависает. В ряде других случаев возникает ошибка печати. Критично при работе функции Почта-на-факс в качестве службы Windows .

Во всех операционных системах

Исправление стандартных команд 'printto' для стандартных классов ProgID. В настоящее время поддерживаются следующие классы ProgID: txtfile, giffile, jpegfile, pjpegfile, pjpegfile, pngfile, TIFImage.Document, wdpfile, PBrush, emffile, rlefile, wmffile, Paint.Picture, icofile.

Во всех операционных системах

Исправление стандартных команд ‘printto’ для стандартных расширений файлов для учетной записи текущего пользователя. В настоящее время поддерживаются следующие расширения файлов: *.txt, *.bmp, *.dib, *.emf, *.gif, *.ico, *.jfif, *.jpe, *.jpeg, *.jpg, *.jxr, *.png, *.rle, *.tif, *.tiff, *.wdp, *.wmf. В Windows 11 и Windows 10 ассоциации файлов необходимо назначать вручную, см. главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.

Примечания

  • Функция Исправить команды ‘printto’ всегда выполняется во время установки Fax Voip FSP. Однако, во время инсталляции функция изначально выполняется с правами администратора, то есть не учитывает и не исправляет настройки текущего пользователя. Рекомендуется запустить данную функцию непосредственно после установки Fax Voip FSP, а также при обнаружении проблем с печатью.
  • Файл журнала printto_fix.txt всегда сохраняется в папке {CommonAppDataFolder}\FaxVoip FSP\log, где {CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.
  • Для пользователей Windows 11 и Windows 10, см. также главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.


Исправление ассоциаций файлов в Windows 11 и Windows 10

Панель управления Fax Voip FSP ›› Факс ›› Параметры printto ››

В Windows 11 и Windows 10, функция Исправить команды ‘printto’ к сожалению не способна разрешить все проблемы связанные с печатью (функция printto). Механизм назначения ассоциаций типов файлов вновь изменился в этой операционной системе. Вам необходимо назначать ассоциации типов файлов с конкретными приложениями вручную.

Ассоциаций типов файлов можно легко настроить для учетной записи текущего пользователя. При конфигурировании функции Почта-на-факс для запуска в качестве службы Windows, настройте службу на использование обычной учетной записи пользователя. Подробнее см. в главе Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства.

Чтобы настроить ассоциации типов файлов для учетной записи текущего пользователя

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Параметры.

2. В окне Параметры нажмите Приложения, а затем Приложения по умолчанию.

3. На вкладке Приложения по умолчанию, нажмите Выбрать значения по умолчанию по типам файлов.

4. На странице Выбрать значения по умолчанию по типам файлов убедитесь, что расширение файла (например .tif) ассоциируется с нужным приложением. Чтобы изменить приложение по умолчанию, щелкните расширение и выберите приложение, которое будет использоваться с выбранным типом файла (например Просмотр фотографий Windows).

5. Откройте Панель управления Fax Voip FSP. В дереве нажмите Факс, затем нажмите Конвертация в факс. Нажмите Исправить команды ‘printto’ (см. также главу Параметры printto ).

Рекомендованные ассоциации типов файлов

В таблице ниже вы найдете настройки, которые мы бы рекомендовали использовать для ассоциаций стандартных типов файлов. Вы можете назначить иные программы по умолчанию, но корректная работа функции printto в этом случае не гарантируется.

Расширение

Описание

Программа по умолчанию

.bmp

Точечный рисунок

Paint

.dib

Точечный рисунок

Paint

.emf

Файл EMF

Paint

.gif

Файл GIF

Просмотр фотографий Windows

.ico

Файл ICO

Просмотр фотографий Windows

.jfif

Рисунок JPEG

Просмотр фотографий Windows

.jpe

Рисунок JPEG

Просмотр фотографий Windows

.jpeg

Рисунок JPEG

Просмотр фотографий Windows

.jpg

Рисунок JPEG

Просмотр фотографий Windows

.jxr

Фото Windows Media

Просмотр фотографий Windows

.png

Рисунок PNG

Просмотр фотографий Windows

.rle

Файл RLE

Paint

.tif

Рисунок TIFF

Просмотр фотографий Windows

.tiff

Рисунок TIFF

Просмотр фотографий Windows

.wdp

Фото Windows Media

Просмотр фотографий Windows

.wmf

Файл WMF

Paint

.txt

Текстовый документ

Блокнот

Примечания

  • Метод назначения ассоциаций типов файлов, описанный в этой главе, можно использовать не только в Windows 11 и Windows 10 но также в других операционных системах, в частности Windows 8/8.1 или Windows Server 2022/2019/2016/2012/2012R2.
  • Описанный метод можно также применить к другим типам файлов, которые не упомянуты в списке рекомендованных ассоциаций типов файлов.


Параметры просмотра факсов

Панель управления Fax Voip FSP ›› Факс ››

Команда для открытия TIFF

Введите в этом поле команду для запуска исполняемого файла приложения для просмотра файлов TIFF. Можно использовать стандартные варианты: 1) explorer – для просмотра файлов TIFF в окне программы Internet Explorer в соответствии с настройками вашей операционной системы. 2) rundll32 shimgvw.dll,ImageView_Fullscreen – для просмотра файлов TIFF с использованием Средства просмотра фотографий Windows. Для выбора исполняемого файла, используйте небольшую кнопку справа от поля со списком.

По умолчанию

Используйте эту кнопку для выбора стандартной Команды для открытия TIFF.

Примечания

  • В настоящее время эта настройка задает приложение, используемое для просмотра исходящего факса при его отслеживании с помощью утилиты SendFax.exe. См. Отслеживание факса (графический интерфейс) , команда Просмотр.


Отправка факса с помощью SendFax.exe

Отправка факса с помощью утилиты SendFax.exe

Панель управления Fax Voip FSP ››

SendFax.exe является утилитой командной строки и предназначена для автоматического создания факса и его дальнейшего отслеживания.

Для получения подробных сведений о SendFax.exe и параметрах командной строки, см. Параметры командной строки SendFax.exe .

Чтобы настроить командную строку, а затем запустить SendFax.exe из Панели управления Fax Voip FSP, см. Настройка и запуск SendFax.exe из панели управления Fax Voip FSP .

Для получения подробных сведений о диалоговом окне Настройка параметров SendFax.exe, см. Параметры SendFax.exe .

Чтобы отслеживать факс при запуске SendFax.exe в режиме графического интерфейса пользователя (GUI), см. Отслеживание факса (графический интерфейс) .

Чтобы отслеживать факс при запуске SendFax.exe в режиме консоли, см. Отслеживание факса (режим консоли) .

Для просмотра журналов SendFax.exe, см. Журналы SendFax.exe .


Параметры командной строки SendFax.exe

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ››

SendFax.exe является утилитой командной строки и предназначена для автоматического создания факса и его дальнейшего отслеживания. Может быть использована в различных сценариях, например в bat-файлах или в пользовательских приложениях. Помогает автоматизировать процесс отправки факсов.

Вы можете найти SendFax.exe в папке установки Fax Voip FSP. Это приложение использует библиотеки Fax Voip FSP, и поэтому должно находиться в папке, где установлен Fax Voip FSP. Не следует перемещать SendFax.exe в другую папку.

Для конструирования командной строки и тестирования SendFax.exe, откройте Панель управления Fax Voip FSP, в дереве нажмите Факс, а затем нажмите SendFax.exe, см. главу Настройка и запуск SendFax.exe из панели управления Fax Voip FSP настоящего справочного руководства.

Пример использования в bat-файле можно найти в следующем файле: *{CommonAppDataFolder}\FaxVoip FSP\SendFax\Sample\SendFax_test.bat.

использование (графический режим): SendFax.exe [параметры]

использование (режим консоли): SendFax_c.exe [параметры]

Получатели факса:

Чтобы отправить факс одному получателю, используйте параметры /FaxNumber и /RecipientName. Для отправки факса нескольким получателям, используйте параметр /RecipientList.

/FaxNumber=value

Номер факса получателя.

/RecipientName=value

Имя получателя. Отображается на титульной странице.

/RecipientList=value

Полный путь к текстовому файлу, в котором содержится список получателей факса. Каждая строка соответствует одному получателю. Можно задать не только номер факса, но и имя получателя, например, 74957721234<Иван Петров>.

Отправляемые документы:

Для отправки единственного документа, используйте параметр /FileName. Чтобы отправить несколько документов, используйте параметр /FileList. Чтобы отправить факс, состоящий только из титульной страницы, пропустите эти параметры и укажите '/CoverPage=true'.

/FileName=value

Полный путь к документу, который будет отправлен в качестве факса.

/FileList=value

Полный путь к текстовому файлу, в котором содержится список отправляемых документов. Каждая строка соответствует одному документу. Следует указывать полные пути к файлам.

/DocumentName=value

Удобное имя, которое описывает отправляемый факс. Переопределяет значение по умолчанию, перечисляющее исходные имена отправляемых документов.

Параметры титульной страницы:

/CoverPage=value

Переопределяет параметр 'Прикреплять титульную страницу к факсу', см. главу Титульные страницы (SendFax.exe) .

/CoverPage=true

Прикрепить титульную страницу к факсу. Обязательный параметр при отправке факса, состоящего только из титульной страницы.

/CoverPage=false

Не прикреплять титульную страницу к факсу.

/CoverInfo=value

Полный путь к пользовательскому ini-файлу с информацией для титульной страницы. Переопределяет значения по умолчанию, см. главы Титульные страницы (SendFax.exe) и Сведения об отправителе (SendFax.exe) .

Структура ini-файла следующая:

[Template]

Переопределяет шаблон титульной страницы. При отсутствии раздела, используется шаблон по умолчанию.

UseServerCoverPage=

1 - стандартный шаблон; 0 - пользовательский шаблон

CoverPageName=

Имя титульной страницы (confident, fyi, generic, urgent) или путь к файлу шаблона.

[Sender]

Переопределяет сведения об отправителе. При отсутствии раздела, используются сведения об отправителе по умолчанию.

SdrName=

Имя отправителя.

SdrFaxNumber=

Номер факса отправителя.

SdrEmail=

Адрес электронной почты отправителя. Может быть переопределен с помощью параметра /SdrEmail. Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).

SdrCompany=

Название организации отправителя. Передается в верхней части каждой страницы факса. Можно переопределить с помощью параметра /FaxHeader.

SdrDepartment=

Имя отдела отправителя.

SdrTitle=

Должность отправителя.

SdrOfficeLocation=

Номер офиса (комнаты) отправителя.

SdrHomePhone=

Номер домашнего телефона отправителя.

SdrOfficePhone=

Номер рабочего телефона отправителя.

SdrAddress=

Адрес отправителя. Для переноса строк используйте символ '\n'.

SdrBillingCode=

Код биллинга, связанный с отправителем.

SdrTsid=

Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Может быть переопределен с помощью параметра /FaxStationID.

[Content]

Переопределяет тему факса и примечание к титульной странице. При отсутствии раздела, используются тема и примечание, заданные по умолчанию.

CoverPageSubject=

Тема факса.

CoverPageNote=

Примечание к титульной странице. Для переноса строк используйте символ '\n'.

Параметры факса (переопределения):

/FaxStationID=value

Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Переопределяет TSID, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows.

/FaxHeader=value

Строка заголовка факса. Передается в верхней части каждой страницы. Переопределяет имя организации, указанное в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows.

/SdrEmail=value

Адрес электронной почты отправителя. Переопределяет адрес эл. почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows. Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).

Важность и время отправки факса:

/Priority=value

Приоритет, используемый при отправке факса.

/Priority=Low

Низкий приоритет.

/Priority=Normal

Обычный приоритет (по умолчанию).

/Priority=High

Высокий приоритет.

/Discount

Отправить факс во время действия льготного тарифа.

/Schedule=value

Отправить факс не раньше указанной даты и времени. Формат даты и времени должен соответствовать настройкам вашей операционной системы, например 10.07.2019 22:15:30 Если этот параметр не используется либо дата/время не могут быть распознаны, будут использованы текущие значения даты и времени.

Параметры TIFF (применяются только при прямой конвертации в факс):

/AutoRotate=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/AutoRotate=true

Применить алгоритм автоматического выбора ориентации.

/AutoRotate=false

Не использовать автоматический выбор ориентации.

/A4Page=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/A4Page=true

Установить ширину и высоту страницы в формате A4.

/A4Page=false

Не контролировать высоту страницы.

/HALFTONE=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/HALFTONE=true

Использовать полутона при конвертации в факс.

/HALFTONE=false

Не использовать полутона при конвертации.

Параметры конвертации (принудительные режимы):

/ForceDirectConvert

Создавать факс с использованием Прямой Конвертации. Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf).

/ForcePrint

Создавать факс путем печати на принтер факсов. Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита попытается создать факс с использованием функции Прямой Конвертации.

Уведомление на e-mail (оригинал):

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server. При отправке почты SSL не поддерживается.

/EmailReceiptMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) .

/EmailReceiptMS=true

Отправить уведомление о доставке по эл. почте.

/EmailReceiptMS=false

Не отправлять уведомление о доставке по эл. почте.

/ReceiptAddressMS=value

Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Переопределяет адрес эл. почты по умолчанию, заданный в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) .

/GroupReceiptMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) .

/GroupReceiptMS=true

Отправить одно уведомление для всех получателей факса.

/GroupReceiptMS=false

Отправлять индивидуальные уведомления для каждого получателя факса.

/ReceiptAttachFaxMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) .

/ReceiptAttachFaxMS=true

Вложить копию отправленного факса.

/ReceiptAttachFaxMS=false

Не вкладывать копию отправленного факса.

Параметры отслеживания факса:

/Track

Отслеживание отправки факса . Этот параметр игнорируется при отправке факса нескольким получателям.

/JobID=value

Не создавать новый факс. Только отслеживать ранее созданный факс. Необходимо указать действительный идентификатор отслеживаемого факса (код задания). При использовании этого параметра все вышеперечисленные параметры игнорируются.

Параметры консоли:

Для работы в режиме консоли запускайте приложение SendFax_c.exe.

/DoNotCloseConsole

Не закрывать консоль после выполнения. Будет отображено сообщение 'Для продолжения нажмите любую клавишу . . .'

/Console

Используя этот параметр, можно запустить приложение SendFax.exe (версия с графическим интерфейсом) в режиме консоли. Обратите внимание, что вызывающее приложение не ожидает завершения работы консоли в этом случае. Вместо этого запускайте приложение SendFax_c.exe.

Журналы и отладка:

/DebugLog

Включить журнал отладки, содержащий подробную информацию о работе SendFax.exe. Путь к файлу журнала: *{CommonAppDataFolder}\FaxVoip FSP\log\SendFax_Debug.txt

/Log

Включить простой журнал, содержащий краткую информацию о работе SendFax.exe. Путь к файлу журнала: *{CommonAppDataFolder}\FaxVoip FSP\log\SendFax_Log.txt

Примеры:

SendFax.exe /FaxNumber=13607451257 /RecipientName=Andre Hedges /CoverPage=true /CoverInfo=C:\ProgramData\FaxVoip FSP\SendFax\Sample\coverpage_test.ini /Track /DebugLog /Log

SendFax_c.exe /FaxNumber=14251234567 /RecipientName=Bob Linkermann /CoverPage=true /FileName=C:\ProgramData\FaxVoip FSP\SendFax\Sample\testPDF.pdf /Priority=High /ForceDirectConvert /Track /DoNotCloseConsole /DebugLog /Log

SendFax_c.exe /RecipientList=C:\ProgramData\FaxVoip FSP\SendFax\Sample\Recipients_test.txt /FileList=C:\ProgramData\FaxVoip FSP\SendFax\Sample\FileList_test.txt /FaxStationID=1(425)987-6543 /FaxHeader=This is my company /DoNotCloseConsole /DebugLog /Log

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Настройка и запуск SendFax.exe

Настройка и запуск SendFax.exe из панели управления Fax Voip FSP

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ››

На этой странице вы можете легко настроить параметры командной строки, а затем запустить SendFax.exe, чтобы отправить факс или отслеживать состояние ранее созданного факса. Предлагаемый визуальный инструмент может быть полезен как для разработчиков, желающих протестировать и затем использовать SendFax.exe в своих приложениях, так и для обычных пользователей, которые просто хотят отправить факс.

В контекстной вкладке SendFax.exe, на ленте доступны следующие команды:

Запустить SendFax.exe

Запустить

Нажмите чтобы запустить утилиту SendFax.exe с выбранными параметрами.

Копировать

Нажмите чтобы скопировать командную строку в буфер обмена.

Отслеживать факс

Установите этот флажок, чтобы отслеживать активность отправляемого факса . Добавляет параметр /Track к командной строке. Этот параметр игнорируется при отправке факса нескольким получателям.

Запустить в консоли

Установите этот флажок, чтобы запустить консольную версию утилиты SendFax.exe (SendFax_c.exe). При запуске в родительской консоли новое окно консоли не создается. Вызывающий процесс ожидает завершения консольного приложения. Если флажок не установлен, SendFax.exe запускается в режиме графического интерфейса пользователя (GUI). Режим графического интерфейса полезен для отслеживания факса , а также для сокрытия консоли.

Не закрывать консоль

Если этот флажок установлен, окно консоли не закрывается после выполнения, при этом в консоли отображается сообщение 'Для продолжения нажмите любую клавишу . . .' . Добавляет параметр /DoNotCloseConsole к командной строке. Не используйте эту опцию в автоматизированных сценариях.

Настроить SendFax.exe

Настроить

Нажмите чтобы настроить параметры командной строки SendFax.exe, см. Параметры SendFax.exe . Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись в списке Параметры SendFax.exe.

Обновить

Нажмите чтобы обновить командную строку SendFax.exe, используя параметры, настроенные в списке Параметры SendFax.exe.

Очистить

Нажмите чтобы очистить параметры командной строки SendFax.exe.

Список получателей

Нажмите чтобы просмотреть / отредактировать список получателей факса, сохраненный в отдельном текстовом файле (параметр командной строки /RecipientList, обычно используется при отправке факса нескольким получателям).

Список документов

Нажмите чтобы просмотреть / отредактировать список документов, отправляемых в качестве факса, который хранится в отдельном текстовом файле (параметр командной строки /FileList, обычно используется при отправке нескольких факсимильных документов).

Титульная страница

Нажмите чтобы просмотреть / отредактировать информацию для титульной страницы, сохраненную в отдельном ini-файле (параметр командной строки /CoverInfo).

Журналы SendFax.exe

Включить журнал отладки

Установите этот флажок, чтобы включить журнал отладки, содержащий подробную информацию о работе SendFax.exe. Добавляет параметр /DebugLog к командной строке.

Включить простой журнал

Установите этот флажок, чтобы включить простой журнал, содержащий краткую информацию о работе SendFax.exe. Добавляет параметр /Log к командной строке.

Просмотр журнала отладки

Нажмите для просмотра журнала отладки SendFax.exe.

Просмотр журнала отладки

Нажмите для просмотра журнала отладки SendFax.exe.

Просмотр простого журнала

Нажмите для просмотра простого журнала SendFax.exe.

Журналы SendFax.exe

Нажмите чтобы перейти на страницу Журналы SendFax.exe .

Командная строка

Командная строка SendFax.exe, состоит из пути к приложению и аргументов командной строки. Генерируется автоматически на основе вашей конфигурации. Текстовое поле можно редактировать вручную, но эти изменения не сохраняются и не гарантируют корректный запуск утилиты SendFax.exe.

Не создавать новый факс. Только отслеживать ранее созданный факс.

Установите этот флажок, если вы хотите отслеживать ранее созданный факс. Необходимо указать действительный идентификатор отслеживаемого исходящего факса (код задания). При использовании этой опции новый факс не создается.

Код задания

Действительный код задания - уникальный идентификатор исходящего факсимильного сообщения.

Код задания факса можно получить с помощью Fax Service API, см. свойство FaxOutgoingJob.Id , также он отображается в программном обеспечении Факсы и сканирование Windows, в свойствах факса. В Факсы и сканирование Windows, в папке Исходящие, выберите факс и щелкните по нему правой кнопкой мыши. В контекстном меню выберите Свойства. Свойство Код задания можно найти на вкладке Сведения.

Список Параметры SendFax.exe позволяет легко просматривать текущие настройки SendFax.exe. Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись. См. также главу Параметры SendFax.exe настоящего справочного руководства. Можно настроить следующие параметры:

  • Запустить в консоли. Указывает, запускается ли приложение в консоли (Тип: ДА; SendFax_c.exe) или в режиме графического интерфейса (Тип: НЕТ; SendFax.exe).
  • Получатели факса. Факс может быть отправлен одному получателю (Тип: ОДИН; /FaxNumber=...[/RecipientName=...]) или нескольким получателям (Тип: СПИСОК; /RecipientList=).
  • Прикрепить титульную страницу. Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса. Вы можете использовать опцию 'Прикреплять титульную страницу к факсу' по умолчанию, см. главу Титульные страницы (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить ее (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /CoverPage=...)
  • Информация для титульной страницы. Вы можете использовать опции по умолчанию, см. главы Титульные страницы (SendFax.exe) и Сведения об отправителе (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете полностью или частично переопределить их, используя ini-файл (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /CoverInfo=...).
  • Документы для отправки. Вы можете отправить один факсимильный документ (Тип: ОДИН; /FileName=...), несколько факсимильных документов (Тип: СПИСОК; /FileList=...), либо вы можете отправить факс, состоящий только из титульной страницы (Тип: НЕ ЗАДАНО).
  • Название документа. Удобное имя, которое описывает отправляемый факс. Значение по умолчанию, перечисляющее исходные имена отправляемых документов (Тип: ПО УМОЛЧАНИЮ), может быть переопределено (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /DocumentName=...).
  • Время отправки факса. Факс может быть отправлен немедленно (Тип: СЕЙЧАС), в указанное время (Тип: ВРЕМЯ; /Schedule=...), либо отправлен во время действия льготного тарифа (Тип: ЛЬГОТНЫЙ ТАРИФ; /Discount).
  • Важность факса. Задает приоритет, используемый при отправке факса. Факс может быть отправлен с низким приоритетом (Тип: НИЗКАЯ; /Priority=Low), обычным приоритетом (Тип: ОБЫЧНАЯ) или высоким приоритетом (Тип: ВЫСОКАЯ; /Priority=High).
  • Идентификатор факса. Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить TSID, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /FaxStationID=...).
  • Заголовок факса. Строка заголовка факса. Передается в верхней части каждой страницы. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить имя организации, указанное в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /FaxHeader=...).
  • Эл. почта отправителя. Адрес электронной почты отправителя. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить адрес эл. почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /SdrEmail=...). Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).
  • Прямая конвертация (принудительно). (Тип: ДА; /ForceDirectConvert) Факс создается с использованием Прямой Конвертации. Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf). (Тип: НЕТ) Параметр /ForceDirectConvert не применяется.
  • Печать документа (принудительно). (Тип: ДА; /ForcePrint) Факс создается путем печати на принтер факсов. Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита попытается создать факс с использованием функции Прямой Конвертации. (Тип: НЕТ) Параметр /ForcePrint не применяется.
  • Автоповорот. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /AutoRotate=...).
  • Страница A4. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /A4Page=...).
  • Передача полутонов. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /HALFTONE=...).
  • Уведомление на e-mail (ориг.). Указывает, следует ли отправить уведомление о доставке по эл. почте. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /EmailReceiptMS=...). Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server. При отправке почты SSL не поддерживается.
  • Уведомить по адресу (ориг.). Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /ReceiptAddressMS=...).
  • Одно уведомление для нескольких получателей (ориг.). Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправить одно уведомление для всех получателей факса. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /GroupReceiptMS=...).
  • Вложить копию факса в уведомление (ориг.). Указывает, следует ли вкладывать копию отправленного факса при отправке уведомления о доставке. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /ReceiptAttachFaxMS=...).
  • Отслеживать факс. Вы можете отслеживать активность отправляемого факса (Тип: ДА; /Track). Этот параметр игнорируется при отправке факса нескольким получателям. Если этот параметр не указан, SendFax.exe завершает работу сразу же после создания задания факса (Тип: НЕТ).
  • Не закрывать консоль. Если указан этот параметр (Тип: ДА; /DoNotCloseConsole), окно консоли не закрывается после выполнения, при этом в консоли отображается сообщение 'Для продолжения нажмите любую клавишу . . .' . Если этот параметр не указан (Тип: НЕТ), окно консоли закрывается сразу после выполнения.
  • Включить журнал отладки. Если указан этот параметр (Тип: ДА; /DebugLog), приложение создает журнал отладки, содержащий подробную информацию о работе SendFax.exe. Если этот параметр не указан (Тип: НЕТ), журнал отладки не создается.
  • Включить простой журнал. Если указан этот параметр (Тип: ДА; /Log), приложение создает простой журнал, содержащий краткую информацию о работе SendFax.exe. Если этот параметр не указан (Тип: НЕТ), простой журнал не создается.


Титульные страницы

Титульные страницы (SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Настройка и запуск SendFax.exe ››

На этой странице вы можете задать настройки по умолчанию для титульных страниц факсов, которые будут использоваться при отправке факса с помощью утилиты командной строки SendFax.exe .

Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи. Титульные страницы можно использовать разными способами. Вы можете отправить факс, состоящий только из титульной страницы, при этом само сообщение включается в него в качестве примечания к титульной странице. Но можно также отправить титульную страницу в дополнение к другому документу. Например, можно послать по факсу документ Microsoft Word и сопроводить его титульной страницей. В этом случае титульная страница будет добавлена ​​в документ и отправлена ​​как первая страница факса.

Приведенные ниже параметры могут быть переопределены с помощью параметров командной строки /CoverPage и /CoverInfo, см. главы Параметры командной строки SendFax.exe и Титульная страница (параметры SendFax.exe) настоящего справочного руководства.

Укажите сведения об отправителе

Нажмите, чтобы перейти на страницу Сведения об отправителе (SendFax.exe) , где вы можете указать информацию об отправителе по умолчанию для использования с утилитой SendFax.exe.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании утилиты SendFax.exe.

Использовать стандартный шаблон титульной страницы

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу сохраненную в указанном файле

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip FSP.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Тема (по умолчанию)

В этом поле можно указать тему факса по умолчанию для использования с утилитой SendFax.exe. Эта информация обычно отображается на титульной странице. Заполнение этого поля не обязательно.

Примечание к титульной странице (по умолчанию)

Текст по умолчанию, который будет отображен на титульной странице факса в качестве примечания (при использовании утилиты SendFax.exe). Заполнение этого поля не обязательно.

Примечания

  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (SendFax.exe) настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Настройка и запуск SendFax.exe ››

На этой странице можно указать информацию об отправителе факса, которая будет отображаться на титульной странице факса в случае использования утилиты командной строки SendFax.exe . Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline). Адрес электронной почты, указанный в поле Эл.почта, может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).

Приведенные ниже параметры могут быть переопределены с помощью параметра командной строки /CoverInfo, см. главы Параметры командной строки SendFax.exe и Сведения об отправителе (параметры SendFax.exe) настоящего справочного руководства.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается утилита SendFax.exe.

Использовать нижеследующую информацию об отправителе

Если выбрана эта опция, утилита SendFax.exe использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Эл. почта

Адрес электронной почты отправителя. Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Может быть переопределен с помощью параметра командной строки /SdrEmail.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста. Можно переопределить с помощью параметра командной строки /FaxHeader.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. Может быть переопределен с помощью параметра командной строки /FaxStationID.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • Адрес электронной почты, указанный в поле Эл. почта, может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Чтобы использовать этот функционал, вы должны вручную включить опцию Разрешить отправку факсов через электронную почту в параметрах почта-на-факс . Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты для указанного адреса электронной почты и отключить отправку уведомлений, см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.


Уведомления на e-mail (оригинал)

Параметры уведомлений о доставке на е-mail - оригинал (SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Настройка и запуск SendFax.exe ››

На этой странице вы можете задать настройки по умолчанию для оригинальных уведомлений о доставке на e-mail, которые будут использоваться при отправке факса с помощью утилиты командной строки SendFax.exe .

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server (например Windows Server 2022). Этот функционал не поддерживает SSL при отправке электронной почты. В качестве альтернативы, вы можете указать адрес электронной почты в сведениях об отправителе , и он будет обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Также можно использовать метод маршрутизации исходящих факсов Уведомления о доставке по электронной почте - функционал из пакета Fax Voip FSP.

Приведенные ниже параметры могут быть переопределены с помощью следующих параметров командной строки: /EmailReceiptMS, /ReceiptAddressMS, /GroupReceiptMS и /ReceiptAttachFaxMS, см. главы Параметры командной строки SendFax.exe и Уведомления на е-mail - оригинал (параметры SendFax.exe) настоящего справочного руководства.

Не отправлять уведомления о доставке факса по электронной почте

Выберите этот вариант, чтобы отключить уведомления о доставке. Можно переопределить с помощью параметра командной строки /EmailReceiptMS.

Отправлять уведомления о доставке факса по электронной почте

Выберите этот вариант, чтобы отправлять уведомления о доставке по электронной почте. Можно переопределить с помощью параметра командной строки /EmailReceiptMS.

По адресу:

Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Можно переопределить с помощью параметра командной строки /ReceiptAddressMS.

<Адресная книга>

Нажмите, чтобы выбрать получателя e-mail сообщения из адресной книги (контакты Windows).

Одно уведомление для нескольких получателей

Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправлять одно уведомление для всех получателей факса. Если этот флажок не установлен, будет отправлено индивидуальное уведомление для каждого получателя факса. Можно переопределить с помощью параметра командной строки /GroupReceiptMS.

Вкладывать копию отправленного факса

Установите этот флажок, чтобы вкладывать копию отправленного факса (файл TIFF) при отправке уведомления о доставке. При отправке факса нескольким получателям и при заданной опции Одно уведомление для нескольких получателей, факс обычно не может быть прикреплен к уведомлению, потому что он отличается для каждого получателя. Можно переопределить с помощью параметра командной строки /ReceiptAttachFaxMS.

<Параметры SMTP>

Нажмите, чтобы настроить Параметры SMTP (служба факсов Windows) . Требуются права администратора.


Параметры SMTP (служба факсов Windows)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Настройка и запуск SendFax.exe ›› Уведомления на e-mail (оригинал) ››

Чтобы настроить параметры SMTP, которые будут использоваться с оригинальными е-mail уведомлениями о доставке факса , выполните следующие действия:

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Факс, затем нажмите SendFax.exe, затем нажмите Уведомления на e-mail (оригинал).

3. Нажмите кнопку <Параметры SMTP>.

4. В окне Параметры SMTP (служба факсов Windows), настройте параметры SMTP.

Параметры SMTP (служба факсов Windows)

Доставка уведомлений по электронной почте (SMTP)

Установите этот флажок, чтобы включить отправку уведомлений о доставке по эл. почте (SMTP).

Адрес отправителя

Адрес электронной почты, с которого будет отправлено уведомление о доставке.

Адрес сервера

Имя SMTP сервера, с которого будут отправляться уведомления.

Порт

Номер порта SMTP, обычно 25.

Анонимный доступ

Факс-сервер отправляет уведомление о доставке факса, используя неавторизованный доступ к SMTP серверу. Обычно не используется.

Обычная проверка подлинности

Факс-сервер отправляет уведомление о доставке факса, используя базовую аутентификацию на SMTP сервере. Требуются Имя пользователя и Пароль. Обычно следует выбирать эту опцию.

Встроенная проверка подлинности Windows

Факс-сервер отправляет уведомление о доставке факса, используя NTLM-аутентификацию на SMTP сервере. Требуются Имя пользователя и Пароль. Обычно не используется.

Имя пользователя

Имя пользователя для авторизации на сервере SMTP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Пароль для авторизации на сервере SMTP.

Подтверждение пароля

Это поле используется для подтверждения пароля.

Применять эти параметры SMTP для маршрутизации входящих факсов с использованием электронной почты (расширение маршрутизации Microsoft)

Указывает, следует ли использовать указанные выше параметры SMTP для расширения маршрутизации Microsoft, которое позволяет маршрутизировать входящие факсы получателям e-mail (оригинальный функционал).

5. Нажмите кнопку <OK>, чтобы сохранить настройки. Все изменения вступают в силу немедленно. Требуются права администратора.

Примечания

  • Этот функционал является частью программного обеспечения службы факсов Windows и доступен только в ОС Windows Server (например Windows Server 2022). SSL не поддерживается при отправке электронной почты.
  • В качестве альтернативы, вы можете настроить параметры SMTP с помощью Диспетчера службы факса (Microsoft). Для доступа к указанным настройкам, в левой панели щелкните правой кнопкой мыши по узлу Факс, нажмите Свойства, а затем откройте вкладку Уведомления.


Параметры SendFax.exe

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ››

Эта глава содержит информацию по настройке параметров командной строки SendFax.exe с помощью диалогового окна Настройка параметров SendFax.exe, см. также главу Настройка и запуск SendFax.exe из панели управления Fax Voip FSP настоящего справочного руководства.

Чтобы настроить параметры командной строки, а затем запустить SendFax.exe, выполните следующие действия:

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Факс, а затем нажмите SendFax.exe.

3. Чтобы изменить параметры командной строки, в контекстной вкладке SendFax.exe на ленте нажмите Настроить. Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись в списке Параметры SendFax.exe.

4. В окне Настройка параметров SendFax.exe, укажите одного или нескольких получателей факса, выберите документы для отправки в качестве факса и укажите другие необходимые параметры. Нажмите OK.

5. Чтобы запустить утилиту SendFax.exe с выбранными параметрами, в контекстной вкладке SendFax.exe на ленте нажмите Запустить.

В диалоговом окне Настройка параметров SendFax.exe можно настроить следующие параметры:

  • Получатели факса
  • Документы
  • Конвертация в факс
  • Титульная страница
  • Сведения об отправителе
  • Важность и время отправки факса
  • Уведомления на е-mail (оригинал)


Получатели факса

Получатели факса (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Получатели факса

На этой вкладке вы можете указать одного или нескольких получателей факса.

Номер факса

Номер факса получателя. Для отправки факса нескольким получателям, последовательно введите сведения о каждом получателе в поле Номер факса и (опционально) в поле Имя получателя, и нажимайте Добавить для добавления получателя в список получателей факса.

Имя получателя

Имя получателя. Отображается на титульной странице.

<Адресная книга>

Нажмите, чтобы выбрать одного или нескольких получателей факса из Адресной книги (Контакты Windows). Выбранный получатель будет добавлен в список получателей факса при условии непустого поля Работа, факс либо непустого поля Дом, факс.

<Список>

Нажмите, чтобы загрузить список номеров факсов из выбранного текстового файла. При подготовке текстового файла, вы должны руководствоваться следующими правилами:

      • Каждая строка может содержать единственный номер факса.
      • Номер факса должен находиться в начале строки. Пробелы и символы табуляции в начале строки игнорируются.
      • Строка может содержать любую дополнительную информацию, такую как имя компании, номер телефона и т.д. Эта информация должна быть отделена от номера факса с использованием любого из следующих разделителей: пробел, символ табуляции или точка с запятой.

Обратите внимание, что этот метод не позволяет добавлять имена получателей.

<Добавить>

Используйте эту кнопку, чтобы добавить получателя в список получателей факса. Номер факса получателя должен быть изначально введен в поле Номер факса, а имя получателя (опционально) должно быть введено в поле Имя получателя.

<Удалить>

Используйте эту кнопку для удаления получателя из списка получателей факса.

<Изменить>

Нажмите, чтобы изменить номер факса и имя получателя. Один из получателей должен быть выбран в списке.

Хранить список получателей в файле

Установите этот флажок, чтобы сохранить список получателей факса в отдельном текстовом файле (параметр командной строки /RecipientList=). Полный путь к текстовому файлу, в котором содержится список получателей факса, должен быть указан в текстовом поле ниже. Если этот флажок не установлен, единственный получатель факса задается с помощью параметров командной строки /FaxNumber= и (опционально) /RecipientName=.

<Обзор>

Нажмите, чтобы указать путь к текстовому файлу, в котором хранится список получателей факса. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip FSP\SendFax\Recipients.txt.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Документы

Документы (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Документы

На этой вкладке вы можете выбрать один или несколько документов для отправки в качестве факса.

Документ

Полный путь к документу, который будет отправлен в качестве факса. Чтобы отправить несколько документов, последовательно выберите каждый из них, и нажимайте Добавить для добавления документа в список документов.

<Обзор>

Нажмите, чтобы выбрать путь к документу, который будет отправлен в качестве факса. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

<Добавить>

Используйте эту кнопку, чтобы добавить документ в список отправляемых документов. Документ должен быть изначально выбран в текстовом поле выше.

<Удалить>

Используйте эту кнопку для удаления документа из списка отправляемых документов.

Хранить список документов в файле

Установите этот флажок, чтобы сохранить список отправляемых документов в отдельном текстовом файле (параметр командной строки /FileList=). Полный путь к текстовому файлу, в котором содержится список отправляемых документов, должен быть указан в текстовом поле ниже. Если этот флажок не установлен, полный путь к единственному отправляемому документу задается с помощью параметра командной строки /FileName=.

<Обзор>

Нажмите, чтобы указать путь к текстовому файлу, в котором хранится список отправляемых документов. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip FSP\SendFax\FileList.txt.

Название документа (переопределение)

Установите этот флажок, чтобы переопределить заданное по умолчанию удобное имя, которое описывает отправляемый факс (параметр командной строки /DocumentName=). Введите название документа в текстовом поле справа. Если этот флажок не установлен, используется значение по умолчанию (список исходных имен отправляемых документов).

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Конвертация в факс

Конвертация в факс (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Конвертация в факс

На этой вкладке вы можете указать, каким образом конвертировать ваши документы в факс (файл TIFF).

Параметры TIFF (только при прямом преобразовании)

В этой области вы можете переопределить Параметры TIFF по умолчанию, заданные в Параметрах конвертации в факс . Эти параметры применяются только при использовании прямой конвертации в факс.

Автоповорот (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы применить алгоритм автоматического выбора ориентации (параметр командной строки /AutoRotate=true). Либо выберите Нет, чтобы не использовать алгоритм автоматического выбора ориентации (параметр командной строки /AutoRotate=false).

Страница A4 (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы установить ширину и высоту страницы в формате A4 (параметр командной строки /A4Page=true). Либо выберите Нет, чтобы не контролировать высоту страницы (параметр командной строки /A4Page=false).

Передача полутонов (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы использовать полутона при конвертации в факс (параметр командной строки /HALFTONE=true). Либо выберите Нет, чтобы не использовать полутона при конвертации (параметр командной строки /HALFTONE=false).

Принудительные режимы

Параметры ниже позволяют игнорировать Параметры конвертации в факс , заданные по умолчанию.

Прямая конвертация (принудительно)

Установите этот флажок, чтобы создать факс с использованием функции Прямой конвертации (параметр командной строки /ForceDirectConvert). Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf).

Печать документа (принудительно)

Установите этот флажок, чтобы создать факс путем печати на принтер факсов (параметр командной строки /ForcePrint). Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита SendFax.exe попытается создать факс с использованием функции Прямой конвертации.


Титульная страница

Титульная страница (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Титульная страница

Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи. Титульные страницы можно использовать разными способами. Вы можете отправить факс, состоящий только из титульной страницы, при этом само сообщение включается в него в качестве примечания к титульной странице. Но можно также отправить титульную страницу в дополнение к другому документу. Например, можно послать по факсу документ Microsoft Word и сопроводить его титульной страницей. В этом случае титульная страница будет добавлена ​​в документ и отправлена ​​как первая страница факса.

На этой вкладке вы можете переопределить настройки по умолчанию для титульной страницы факса, см. главу Титульные страницы (SendFax.exe) .

Прикрепить титульную страницу (переопределение)

Установите этот флажок, чтобы переопределить параметр Прикреплять титульную страницу к факсу, заданный по умолчанию, см. главу Титульные страницы (SendFax.exe) . Справа выберите Да, чтобы прикрепить титульную страницу к факсу (параметр командной строки /CoverPage=true). Либо выберите Нет, чтобы не прикреплять титульную страницу к факсу (параметр командной строки /CoverPage=false). Чтобы отправить факс, состоящий только из титульной страницы, установите флажок, а затем справа выберите Да (/CoverPage=true в этом случае является обязательным параметром командной строки).

Шаблон титульной страницы (переопределить настройки по умолч.)

Установите этот флажок, чтобы переопределить шаблон титульной страницы, заданный по умолчанию, см. главу Титульные страницы (SendFax.exe) . Измененные настройки хранятся в разделе [Template] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Использовать стандартный шаблон

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу из указанного файла

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip FSP.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Тема факса и примечание (переопределить настройки по умолчанию)

Установите этот флажок, чтобы переопределить тему факса и примечание к титульной странице, заданные по умолчанию, см. главу Титульные страницы (SendFax.exe) . Измененные настройки хранятся в разделе [Content] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Тема

В этом поле можно указать тему факса. Эта информация обычно отображается на титульной странице. Заполнение этого поля не обязательно.

Примечание к титульной странице

Текст, который будет отображен на титульной странице факса в качестве примечания. Заполнение этого поля не обязательно.

Хранить информацию для титульной страницы в этом файле

Полный путь к пользовательскому ini-файлу с информацией для титульной страницы (параметр командной строки /CoverInfo=).

<Обзор>

Нажмите, чтобы указать путь к пользовательскому ini-файлу, в котором будет храниться информация для титульной страницы. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip FSP\SendFax\coverpage.ini.

Примечания

  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (параметры SendFax.exe) настоящего справочного руководства.
  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Сведения об отправителе

Сведения об отправителе (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Сведения об отправителе

Информация об отправителе отображается на титульных страницах. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline). Адрес электронной почты, указанный в поле Эл.почта, может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).

На этой вкладке вы можете переопределить настройки по умолчанию для информации об отправителе, см. главу Сведения об отправителе (SendFax.exe) .

Сведения об отправителе (переопределить настройки по умолчанию)

Установите этот флажок, чтобы переопределить настройки для информации об отправителе, заданные по умолчанию, см. главу Сведения об отправителе (SendFax.exe) . Измененные настройки хранятся в разделе [Sender] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Использовать информацию об отправителе, заданную по умолчанию

Указывает, что используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается утилита SendFax.exe.

Использовать нижеследующие данные

Если выбрана эта опция, утилита SendFax.exe использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Эл. почта

Адрес электронной почты отправителя. Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Может быть переопределен с помощью опции E-mail отправителя (переопр.), см. ниже (параметр командной строки /SdrEmail=).

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста. Можно переопределить с помощью опции Заголовок факса (переопр.), см. ниже (параметр командной строки /FaxHeader=).

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. Может быть переопределен с помощью опции Идент. факса (переопр.), см. ниже (параметр командной строки /FaxStationID=).

Код оплаты

Код биллинга, связанный с отправителем.

Идент. факса (переопр.)

Установите этот флажок, чтобы переопределить идентификатор передающей станции (TSID), указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /FaxStationID=). Введите TSID в текстовом поле справа. Код TSID передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса.

Заголовок факса (переопр.)

Установите этот флажок, чтобы переопределить строку заголовка факса (название организации), указанную в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /FaxHeader=). Введите заголовок факса в текстовом поле справа. Заголовок факса обычно передается в верхней части каждой страницы отправляемого факса.

E-mail отправителя (переопр.)

Установите этот флажок, чтобы переопределить адрес электронной почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /SdrEmail=). Введите адрес электронной почты в текстовом поле справа. Этот адрес может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ).

Примечания

  • Адрес электронной почты, заданный в поле Эл. почта или с использованием опции E-mail отправителя (переопр.) (параметр командной строки /SdrEmail=), может быть обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Чтобы использовать этот функционал, вы должны вручную включить опцию Разрешить отправку факсов через электронную почту в параметрах почта-на-факс . Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты для указанного адреса электронной почты и отключить отправку уведомлений, см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.


Важность и время отправки факса

Важность и время отправки факса (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Важность и время отправки факса

На этой вкладке вы можете запланировать время для отправки вашего факса и задать приоритет, который будет использоваться при отправке факса.

Важность

В этой области вы можете задать приоритет, который будет использоваться при отправке факса.

Важность факса

Укажите приоритет, который следует использовать при отправке факса. Все факсы, имеющие высокую важность (параметр командной строки /Priority=High), будут отправлены перед факсом, который имеет обычную или низкую (параметр командной строки /Priority=Low) важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Время отправки факса

В этой области вы можете запланировать время для отправки вашего факса.

Сейчас

Выберите эту опцию, чтобы отправить факс немедленно.

Во время действия льготного тарифа

Выберите эту опцию, чтобы отправить факс во время действия льготного тарифа (параметр командной строки /Discount). На компьютере с операционной системой Windows Server (например Windows Server 2022), время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 или Windows 10, время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).

В указанное время

Выберите эту опцию, чтобы указать дату и время отправки факса (параметр командной строки /Schedule=).


Уведомления на e-mail (оригинал)

Уведомления на е-mail - оригинал (параметры SendFax.exe)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Параметры SendFax.exe ››

Уведомления на е-mail (оригинал)

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server (например Windows Server 2022). Этот функционал не поддерживает SSL при отправке электронной почты. В качестве альтернативы, вы можете указать адрес электронной почты в сведениях об отправителе , и он будет обработан функцией Почта-на-факс ( уведомления о доставке на адрес электронной почты отправителя ). Также можно использовать метод маршрутизации исходящих факсов Уведомления о доставке по электронной почте - функционал из пакета Fax Voip FSP.

На этой вкладке вы можете переопределить настройки по умолчанию для оригинальных уведомлений о доставке на e-mail, заданные в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) .

Отправить уведомление на e-mail (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) . Справа выберите Да, чтобы отправить уведомление о доставке по электронной почте (параметр командной строки /EmailReceiptMS=true). Либо выберите Нет, чтобы не отправлять уведомление (параметр командной строки /EmailReceiptMS=false).

По адресу (переопр.)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) . Справа, в текстовом поле, введите адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса (параметр командной строки /ReceiptAddressMS=).

<Адресная книга>

Нажмите, чтобы выбрать получателя e-mail сообщения из адресной книги (контакты Windows).

Одно уведомл. для нескольких получателей (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) . Справа выберите Да, чтобы отправить одно уведомление для всех получателей факса (параметр командной строки /GroupReceiptMS=true). Либо выберите Нет, чтобы отправлять индивидуальные уведомления для каждого получателя факса (параметр командной строки /GroupReceiptMS=false).

Вкладывать копию отправленного факса (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFax.exe) . Справа выберите Да, чтобы вложить копию отправленного факса (файл TIFF) при отправке уведомления о доставке (параметр командной строки /ReceiptAttachFaxMS=true). Либо выберите Нет, чтобы не вкладывать копию отправленного факса (параметр командной строки /ReceiptAttachFaxMS=false).

<Параметры SMTP>

Нажмите, чтобы настроить Параметры SMTP (служба факсов Windows) . Требуются права администратора. В качестве альтернативы, вы можете настроить параметры SMTP с помощью Диспетчера службы факса (Microsoft). Для доступа к настройкам SMTP, в левой панели щелкните правой кнопкой мыши по узлу Факс, нажмите Свойства, а затем откройте вкладку Уведомления.


Отслеживание факса (графический интерфейс)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ››

При запуске утилиты SendFax.exe в режиме графического интерфейса пользователя (GUI) с параметром командной строки /Track, отображается окно отслеживания факса. Окно отслеживания факса аналогично Монитору факсов , который входит в программное обеспечение Факсы и сканирование Windows, но позволяет отслеживать конкретный, только что созданный исходящий факс. Вы можете не только просматривать состояние факса , но также управлять заданием факса и просматривать свойства факса . Параметр /Track игнорируется при отправке факса нескольким получателям. Также можно отслеживать ранее созданный факс, запустив SendFax.exe с параметром /JobID=.

Команды ленты в окне отслеживания факса

Следующие команды доступны в меню Файл:

Просмотр (F3)

Нажмите для просмотра факса в программе для просмотра TIFF файлов. См. также Параметры просмотра факсов .

Удалить (Del)

Нажмите чтобы удалить факс. Отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Пауза

Нажмите чтобы приостановить передачу факса.

Продолжить

Нажмите чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи.

Перезапустить

Нажмите чтобы повторить передачу факса после неудачной попытки.

Справка (F1)

Нажмите чтобы открыть файл справки. Для вызова справочной системы вы также можете использовать кнопку Вызов справки, расположенную в правом верхнем углу ленты.

Выход (Ctrl + X)

Нажмите, чтобы выйти из приложения.

Следующие команды доступны на вкладке Главная:

Факс

Просмотр (F3)

Нажмите для просмотра факса в программе для просмотра TIFF файлов. См. также Параметры просмотра факсов ..

Удалить (Del)

Нажмите чтобы удалить факс. Отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Действия

Пауза

Нажмите чтобы приостановить передачу факса.

Продолжить

Нажмите чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи.

Перезапустить

Нажмите чтобы повторить передачу факса после неудачной попытки.

Области

События

Нажмите чтобы отобразить или скрыть журнал событий. См. также Мониторинг факса .

Свойства

Нажмите чтобы отобразить или скрыть свойства факса. См. также Просмотр свойств факса .

Предпросмотр

Нажмите чтобы отобразить или скрыть панель предварительного просмотра.

Следующие команды доступны на вкладке Вид:

Цвета ленты

Стандартные цвета

Выберите этот вариант, чтобы применить стандартную цветовую схему (определяется операционной системой).

Настроить цвета

Выберите этот вариант, чтобы настроить цвета ленты. Обратите внимание, что эта опция не работает правильно в Windows 11, Windows 10 версии 1809 или более поздней, Windows Server 2022 и в Windows Server 2019.

Цвет фона

Выберите основной цвет фона для настраиваемой ленты.

Цвет выделения

Выберите основной цвет выделения для настраиваемой ленты (только Windows 7).

Цвет текста

Выберите основной цвет текста для настраиваемой ленты.

Текущее представление

Лента

Снимите флажок чтобы скрыть ленту (Ribbon). Переключение в классический режим произойдет при следующем запуске приложения.

Панель инструментов

Поставьте флажок чтобы отобразить классическую панель инструментов. Переключение в классический режим произойдет при следующем запуске приложения.

Строка меню

Поставьте флажок чтобы отобразить классическое меню. Переключение в классический режим произойдет при следующем запуске приложения.

Вид по умолчанию

Восстановить умолчания

Используйте эту опцию для восстановления внешнего вида по умолчанию для окна отслеживания факса.

Панель быстрого доступа представляет собой небольшую, настраиваемую панель инструментов, которая содержит набор команд, заданных приложением или выбранных пользователем.

По умолчанию, Панель быстрого доступа расположена в строке заголовка окна отслеживания факса, но также может быть настроена для отображения под лентой. В дополнение к отображенным командам, Панель быстрого доступа также включает в себя настраиваемое выпадающее меню, которое содержит полный набор команд Панели быстрого доступа по умолчанию (скрытых или отображенных), а также параметры настройки Панели быстрого доступа и ленты. Почти все элементы управления ленты могут быть добавлены на Панель быстрого доступа через контекстное меню, как показано на рисунке ниже.


Мониторинг факса

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Отслеживание факса (графический интерфейс) ››

Когда вы запускаете утилиту SendFax.exe с параметром /Track, окно с текущей информацией о вашем факсе отображается сразу же после успешного создания задания факса. В основной области отображается информация о получателе факса, текущем состоянии факса (например, какая страница в данный момент передается), а также информация о времени, прошедшем с начала передачи факса. Чтобы просмотреть полный список событий, касающихся вашего факса, на ленте нажмите События. Вы можете остановить отслеживание факса в любой момент, просто закрыв окно отслеживания факса.


Просмотр свойств факса

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Отслеживание факса (графический интерфейс) ››

Чтобы просмотреть свойства факса в окне отслеживания, на ленте нажмите Свойства. Чтобы отобразить панель предварительного просмотра, нажмите Предпросмотр.

Следующие свойства факса отображаются на вкладке Общие:

Свойства факса (Общие)

  • Номер получателя. Номер факса получателя.
  • Имя получателя. Имя получателя. Отображается на титульной странице.
  • Страниц. Общее количество страниц в отправляемом факсимильном сообщении.
  • Состояние. Текущее состояние факса (например Выполняется, Повтор, Завершено).
  • Расширенное состояние. Расширенное состояние факса (например Набор номера, Отправка страницы..., Нет ответа, Занято).
  • Код CSID. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • Код TSID. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
  • Устройство. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
  • Повторы. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • Запланированное время. Время, на которое запланирована отправка факса.
  • Время начала. Время начала передачи исходящего факса.
  • Время окончания. Время окончания передачи исходящего факса.
  • Продолжительность. Продолжительность передачи исходящего факса.

Следующие свойства факса отображаются на вкладке Сведения:

Свойства факса (Сведения)

  • Название документа. Удобное имя, которое описывает отправляемый факс.
  • Титульная страница. Указывает, содержит ли факс титульную страницу.
  • Тема. Тема факса. Отображается на титульной странице.
  • Размер. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с факсом, в килобайтах.
  • Приоритет. Важность факса; например обычная, низкая или высокая.
  • Код задания. Уникальный идентификатор, назначенный факсу в процессе формирования задания. Этот идентификатор следует указывать при запуске SendFax.exe с параметром командной строки /JobID=, чтобы отслеживать ранее созданный факс.
  • Код рассылки. Уникальный идентификатор, назначенный факсу в процессе формирования задания. При отправке факса более чем одному получателю, создаются отдельные задания факса, каждому из которых назначается свой Код задания, но в рамках одной группы заданий им будет назначен один и тот же Код рассылки.
  • Время постановки в очередь. Время формирования задания исходящего факса.
  • Исх. запланированное время. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • Время отправки факса. Указывает способ задания времени отправки факса. Это свойство может иметь одно из следующих значений: Сейчас (немедленная отправка факса), В указанное время, Во время действия льготного тарифа.
  • Уведомление о доставке. Указывает тип уведомления о доставке факса. Это свойство может иметь одно из следующих значений: Эл. почта; Не требуется. Оригинальные уведомления о доставке факса на e-mail доступны только в ОС Windows Server (например Windows Server 2022), см. также в главе Уведомления на e-mail (оригинал) настоящего справочного руководства.
  • Уведомить по адресу. Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса.
  • Общее уведомление. Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправить одно уведомление для всех получателей факса.

Следующие свойства факса отображаются на вкладке Сведения об отправителе:

Свойства факса (Сведения об отправителе)

  • Имя. Имя отправителя.
  • Номер факса. Номер факса отправителя.
  • Электронная почта. Адрес электронной почты отправителя.
  • Должность. Должность отправителя.
  • Организация. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • Отдел. Имя отдела отправителя.
  • Комната. Номер офиса (комнаты) отправителя.
  • Телефон (раб.). Номер рабочего телефона отправителя.
  • Телефон (дом.). Номер домашнего телефона отправителя.
  • Адрес. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • Код оплаты. Код биллинга, связанный с отправителем.
  • Код TSID. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), обычно совпадающий с номером факса, указанном в сведениях об отправителе . Обратите внимание, что в зависимости от настроек факс сервера, он может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Вкладка Просмотр используется для предварительного просмотра факса.

Предварительный просмотр факса


Работа с факсом

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ›› Отслеживание факса (графический интерфейс) ››

Когда вы запускаете утилиту SendFax.exe в режиме графического интерфейса пользователя (GUI) с параметром /Track, вы можете не только следить за отправкой факса, но и управлять заданием факса.

Чтобы просмотреть факс в программе для просмотра TIFF файлов, нажмите Просмотр или воспользуйтесь клавишей F3.

Чтобы удалить факс, нажмите Удалить или воспользуйтесь клавишей Del. Эта команда отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Чтобы приостановить передачу факса, нажмите Пауза.

Чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи, нажмите Продолжить.

Чтобы повторить передачу факса после неудачной попытки, нажмите Перезапустить.


Отслеживание факса (режим консоли)

Панель управления Fax Voip FSP ›› Отправка факса с помощью SendFax.exe ››

При запуске консольной версии утилиты SendFax.exe (SendFax_c.exe) с параметром командной строки /Track, информация о событиях факса (например, какая страница в данный момент передается) выводится непосредственно в консоль. Параметр /Track игнорируется при отправке факса нескольким получателям. Также можно отслеживать ранее созданный факс, запустив утилиту SendFax.exe (SendFax_c.exe) с параметром /JobID=.

По умолчанию процесс отслеживания факса прекращается после успешной отправки факса или после выполнения максимального числа попыток отправить факс, после чего утилита SendFax.exe автоматически завершает работу. Если вы не хотите, чтобы консоль автоматически закрывалась после выполнения, используйте параметр командной строки /DoNotCloseConsole. Вы можете остановить отслеживание факса в любой момент, закрыв окно консоли или нажав комбинацию клавиш Ctrl + C.

Примечания

  • Обратите внимание, что вы не можете управлять заданием факса при запуске утилиты SendFax.exe в режиме консоли.


Аудио

Панель управления Fax Voip FSP ››

  • Параметры аудио
  • Аудио кодеки


Параметры аудио

Панель управления Fax Voip FSP ›› Аудио ››

Аудио файл для проигрывания (WAV файл 8 kHz 16-бит или 8-бит Моно)

Аудио файл для проигрывания перед передачей факса, после ответа на исходящий факсовый вызов. Вы можете выбрать путь к файлу, нажав на кнопку справа от текстового поля. Для передачи через телефонную линию используются WAV (.wav) файлы формата 8 kHz 16-bit Mono либо 8 kHz 8-bit Mono. Пример аудио файла находится в папке *{CommonAppDataFolder}\FaxVoip FSP\Sounds\Fax после установки Fax Voip FSP. По умолчанию используется файл intro_fax_out.wav.

Реплика перед передачей факса

Установите этот флажок, чтобы воспроизводить выбранный аудиофайл перед отправкой факса. Подчеркнем, что использование этой опции не рекомендуется, если не предполагается, что на вызов отвечает человек.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.
  • Параметры, описанные в данном разделе, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов.


Аудио кодеки

Панель управления Fax Voip FSP ›› Аудио ››

  • Параметры аудио кодеков
  • Требования к аудио кодекам для передачи факсов


Параметры аудио кодеков

Панель управления Fax Voip FSP ›› Аудио ›› Аудио кодеки ››

Fax Voip FSP поддерживает следующие аудио кодеки:

G.711-uLaw-64k (по умолчанию)

G.711-ALaw-64k (по умолчанию)

G.723.1

G.726-32k

GSM-06.10

iLBC

SpeexNB

SpeexWB

По крайней мере один аудио кодек должен быть выбран. Доступные кодеки отображаются в левой панели. В правой панели отображаются кодеки, выбранные пользователем. Выбранные кодеки могут быть выстроены в порядке предпочтений. По умолчанию порядок предпочтений кодеков применяется только к исходящим вызовам. При входящих вызовах Fax Voip FSP использует порядок предпочтений заданный удаленной стороной.

Обратите внимание, что отправка и получение факсов налагает некоторые ограничения на использование аудио кодеков. Для получения более подробной информации обратитесь к главе Требования к аудио кодекам для передачи факсов данного справочного руководства.

Вам доступны следующие команды:

<Добавить> (или двойной щелчок мышью на выбранной записи в панели Доступные кодеки)

Используйте эту кнопку для добавления кодеков для использования с Fax Voip FSP. Вы должны предварительно выделить один из кодеков в панели Доступные кодеки.

<Удалить> (или двойной щелчок мышью на выбранной записи в панели Выбранные кодеки)

Используйте эту кнопку для удаления кодеков из панели Выбранные кодеки. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

<Вверх> и <Вниз>

Используйте эту кнопку чтобы изменить порядок предпочтения кодеков для выбранных аудио кодеков. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

Заметим, что вы также можете выполнить любое из вышеперечисленных действий, выбрав соответствующую команду из контекстного меню списка.


Требования к аудио кодекам

Требования к аудио кодекам для передачи факсов

Панель управления Fax Voip FSP ›› Аудио ›› Аудио кодеки ››

При конфигурировании режимов факса, уделите внимание выбору аудио кодеков.

При выборе аудио кодеков, вам следует руководствоваться следующими правилами:

  • T.38 факс полностью совместим с использованием любого аудио кодека. По крайней мере один аудио кодек должен быть выбран. По крайней мере один из выбранных кодеков должен поддерживаться вашей SIP или H.323 сетью.
  • Обратите внимание, что в зависимости от настроек T.38 факса, некоторые начальные операции факса могут выполняться в аудио режиме до переключения на T.38. При использовании кодеков отличных от G.711-ulaw и G.711-Alaw, CNG и CED сигналы факса могут не передаваться и не детектироваться. По этой причине рекомендуется использовать кодеки G.711 даже при работе с T.38 факсами.
  • Для обеспечения генерации CNG сигнала факса при отправке T.38 факса и использовании аудио кодеков отличных от G.711-ulaw и G.711-Alaw, воспользуйтесь опцией Перекл. в T.38 после ... секунд, задав минимальную задержку (0-2 сек).
  • Аудио факс (факс поверх кодека G.711) может работать только при условии использования кодеков G.711-ulaw или G.711-Alaw. Таким образом, по крайней мере один из этих двух кодеков должен быть выбран и поддерживаться вашей SIP или H.323 сетью.
  • Для предотвращения отправки или приема факсов в аудио режиме, вы можете убрать кодеки G.711-ulaw и G.711-Alaw из списка выбранных кодеков. Это возможно при условии, что ваш SIP или H.323 провайдер поддерживает один из других голосовых кодеков.
  • Для обеспечения совместимости с режимом аудио факса при использовании кодеков отличных от G.711-ulaw и G.711-Alaw, настоятельно рекомендуется устанавливать наивысший приоритет для G.711-ulaw и G.711-Alaw. Корректный ре-инвайт на G.711-ulaw или G.711-Alaw, при уже установленном вызове с использованием иного аудио кодека, в приложении Fax Voip FSP не гарантирован.


Электронная почта

Панель управления Fax Voip FSP ››

  • Факс-на-почту, почта-на-факс и уведомления о доставке
  • Почта-на-факс
  • Параметры SMTP
  • Параметры POP3 / IMAP
  • Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0
  • Шаблоны электронной почты


Факс-на-почту, почта-на-факс и уведомления о доставке

Панель управления Fax Voip FSP ›› Электронная почта ››

Служба почта-на-факс

Функция Почта-на-факс реализована отдельным модулем. Этот модуль можно запускать как приложение под текущей учетной записью пользователя, или он может быть настроен для запуска в качестве службы Windows.

Запускать почтовую подсистему как приложение

Выберите эту опцию чтобы запускать почтовую подсистему Fax Voip FSP как обычное приложение. Почтовая подсистема автоматически запускается после входа пользователя в систему. Как правило, этот вариант можно использовать для однопользовательской системы. При использовании этой опции в многопользовательской среде поведение может быть непредсказуемо. Для изменения данного параметра требуются права администратора.

Запускать почтовую подсистему как службу Windows

Выберите эту опцию чтобы запускать почтовую подсистему Fax Voip FSP в качестве службы Windows. Служба автоматически запускается при запуске Windows до входа пользователя в систему. Этот вариант рекомендуется для многопользовательских систем. В то же время настоятельно рекомендуется запускать эту службу от имени учетной записи пользователя, а не под учетной записью локальной системы или сетевой службы. Пользователь, от имени которого запускается служба, сможет просматривать и управлять факсами, сгенерированными службой, в приложении Факсы и сканирование Windows, а также настраивать ассоциации типов файлов (ответственные за правильную печать различных документов). Чтобы установить службу, см. главу Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства. См. также главу Почта-на-факс в качестве службы Windows настоящего справочного руководства. Для изменения данного параметра требуются права администратора.

<СТАРТ>

Используйте эту кнопку чтобы запустить почтовую подсистему (службу Fax Voip FSP Mail). Функция Почта-на-факс должна быть включена в ваших настройках.

<СТОП>

Используйте эту кнопку чтобы остановить почтовую подсистему (службу Fax Voip FSP Mail).

Тип запуска

Указывает, каким образом запускается почтовая подсистема (Приложение или Служба Windows). В случае службы также отображается имя учетной записи, под которой служба запущена.

Состояние

Указывает, работает ли почтовая подсистема (служба Fax Voip FSP Mail).

Факс-на-почту

Функция Факс-на-почту реализована в методе маршрутизации для входящих факсов Отправить по электронной почте . В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть отправлен различным e-mail адресатам. Один и тот же входящий факс может быть маршрутизирован одному или более e-mail получателям. Можно использовать поля Кому, Копия и Скрытая копия, формат доставки факса (TIFF, PDF или SFF) задается индивидуально для каждого правила.

Чтобы настроить Факс-на-почту, вам обычно необходимо создать одно или несколько правил маршрутизации по e-mail , настроить параметры SMTP и отредактировать шаблон электронной почты 'Получен новый факс' (если требуется).

Почта-на-факс и уведомления о доставке

Чтобы включить и настроить функцию Почта-на-факс, см. главу Почта-на-факс настоящего справочного руководства. Вам необходимо настроить параметры POP3 / IMAP . Чтобы включить уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя, также необходимо настроить параметры SMTP .

Уведомления о доставке реализованы в методе маршрутизации для исходящих факсов Уведомления о доставке по электронной почте . В зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса, уведомление о доставке может быть отправлено различным e-mail адресатам. Уведомление о доставке может быть отправлено одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Копия отправленного факса может быть прикреплена к сообщению электронной почты в формате TIFF, PDF или SFF. Чтобы настроить Уведомления о доставке, вам обычно необходимо создать одно или несколько правил метода “Уведомления о доставке по электронной почте” . Также необходимо настроить параметры SMTP .

Для обеих функций, вы можете настроить следующие шаблоны электронной почты (если требуется): Факс успешно отправлен , Не удалось отправить факс и Не удалось создать задание факса .


Конфигурирование почта-на-факс в качестве службы Windows

Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows

Панель управления Fax Voip FSP ›› Электронная почта ›› Факс-на-почту, почта-на-факс и уведомления о доставке ››

Почтовую подсистему Fax Voip FSP (функцию Почта-на-факс) можно настроить для запуска в качестве службы Windows. Служба автоматически запускается при запуске Windows до входа пользователя в систему. Этот вариант рекомендуется для многопользовательских систем.

Настоятельно рекомендуется запускать службу Fax Voip FSP Mail от имени учетной записи пользователя, а не под учетной записью локальной системы или сетевой службы. Пользователь, от имени которого запускается служба, сможет просматривать и управлять факсами, сгенерированными службой, в приложении Факсы и сканирование Windows, а также настраивать ассоциации типов файлов (ответственные за правильную печать различных документов).

Чтобы настроить Почта-на-факс в качестве службы Windows

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта.

2. Выберите опцию Запускать почтовую подсистему как службу Windows, а затем нажмите <Применить>. Требуются права администратора.

3. В окне Служба Fax Voip FSP Mail, укажите имя пользователя и пароль учетной записи, которая будет использоваться для запуска службы Fax Voip FSP Mail. Имя учетной записи должно иметь формат DOMAIN\Username. По умолчанию, Fax Voip FSP предлагает использовать текущую учетную запись (с правами администратора). Вы должны четко понимать, что только указанный пользователь сможет просматривать факсы, сгенерированные службой, и управлять ими в приложении Факсы и сканирование Windows. Также, ассоциации типов файлов (ответственные за правильную печать различных документов) должны быть настроены под учетной записью указанного пользователя. По причинам, указанным выше, не следует запускать эту службу от имени локальной системы или сетевой службы*. Нажмите OK.

4. Подождите, пока программа выполнит все необходимые действия и запустит службу Fax Voip FSP Mail.

5. После завершения установки и запуска службы, вы должны увидеть Тип запуска: Служба Windows и Состояние: Служба запущена, см. рисунок ниже. Имя учетной записи, под которой запущена служба, также отображается в поле Тип запуска.

Примечания

  • (* : Чтобы запускать службу под учетной записью 'Локальная система', в поле Учетная запись введите LocalSystem (пароль не требуется). Чтобы запускать службу от имени учетной записи 'Сетевая служба', в поле Учетная запись введите NT AUTHORITY\NetworkService (пароль не требуется). Обратите внимание, что запуск службы Fax Voip FSP Mail от имени локальной системы или сетевой службы не рекомендован.
  • Учетная запись пользователя, которая будет использоваться для запуска службы Fax Voip FSP Mail, должна обладать правами Входа в качестве службы. При установке службы, Fax Voip FSP принудительно добавляет право Входа в качестве службы для указанной учетной записи. В некоторых системах вы можете проверить и настроить локальную политику Вход в качестве службы используя Редактор локальной групповой политики (gpedit.msc): Политика 'Локальный компьютер' -> Конфигурация компьютера -> Конфигурация Windows -> Параметры безопасности -> Локальные политики -> Назначение прав пользователя, локальная политика Вход в качестве службы.

Чтобы изменить учетную запись пользователя, под которой запускается служба

Предполагается, что почтовая подсистема (функция Почта-на-факс) уже настроена для запуска в качестве службы Windows.

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Управление компьютером.

2. В окне Управление компьютером, в левой панели, щелкните дважды Управление компьютером (локальным), щелкните дважды Службы и приложения, щелкните Службы.

3. В правой панели щелкните правой кнопкой мыши по службе Fax Voip FSP Mail. В контекстном меню, нажмите Свойства.

4. В окне Свойства: Fax Voip FSP Mail (Локальный компьютер), на вкладке Вход в систему, выберите С учетной записью, а затем нажмите Обзор... .

5. В диалоговом окне Выбор: "Пользователь", введите имя учетной записи, а затем нажмите Проверить имена. Нажмите OK.

6. В текстовых полях Пароль и Подтверждение, введите пароль для выбранной учетной записи, а затем нажмите OK.

7. Щелкните правой кнопкой мыши по службе Fax Voip FSP Mail. В контекстном меню, нажмите Перезапустить.

Примечания

  • Кроме того, вы можете временно удалить службу, выбрав опцию Запускать почтовую подсистему как приложение в Панели управления Fax Voip FSP, а затем нажав <Применить>. Далее выполните процедуру, описанную в начале этой главы, указав желаемую учетную запись пользователя.


Почта-на-факс

Панель управления Fax Voip FSP ›› Электронная почта ››

Функция Почта-на-факс позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Чтобы использовать функцию Почта-на-факс, вы должны:

  • Настроить службу факсов Windows для отправки факсов через одну или несколько линий Fax Voip Line
  • Настроить параметры POP3 / IMAP
  • Настроить параметры SMTP
  • Настроить шаблон электронной почты 'Факс успешно отправлен' (если требуется)
  • Настроить шаблон электронной почты 'Не удалось отправить факс' (если требуется)
  • Настроить шаблон электронной почты 'Не удалось создать задание факса' (если требуется)
  • Включить функцию Почта-на-факс

Чтобы включить функцию Почта-на-факс, настроить типы вложений электронной почты, задать приоритет и время отправки факсов, обратитесь к разделу Параметры почта-на-факс .

Чтобы настроить правила набора номера, обратитесь к разделу Набор номера (почта-на-факс) .

Чтобы настроить уведомления о доставке факса на e-mail отправителя, обратитесь к разделу Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) .

Чтобы использовать титульные страницы факса, обратитесь к разделу Титульные страницы (почта-на-факс) .

Чтобы указать информацию об отправителе факса, которая будет отображаться на титульной странице, обратитесь к разделу Сведения об отправителе (почта-на-факс) .

Чтобы настроить поведение функции Почта-на-факс в зависимости от адреса электронной почты отправителя, обратитесь к разделу Правила для почты (почта-на-факс) .

Необходимые сведения по отправке факсов из приложения электронной почты можно найти в главе Отправка факсов через e-mail .

Чтобы настроить подсистему Почта-на-факс для запуска в качестве службы Windows, обратитесь к разделу Конфигурирование почта-на-факс в качестве службы Windows .

Если возникли проблемы, см. главу Устранение неполадок функции почта-на-факс .


Параметры почта-на-факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

Чтобы включить или отключить функцию Почта-на-факс

Разрешить отправку факсов через электронную почту

Эта опция позволяет включить или отключить функцию Почта-на-факс. Установите этот флажок, чтобы разрешить отправку факсов через электронную почту. Если почтовая подсистема Fax Voip FSP сконфигурирована для работы в качестве службы Windows, то для изменения данного параметра могут потребоваться права администратора.

По умолчанию, функция Почта-на-факс доступна для любого адреса электронной почты. Однако, вы можете разрешить или запретить использование этой функции для одного, нескольких или всех адресов электронной почты с помощью Правил для почты . См. также главу Общие параметры (правило для почты) настоящего справочного руководства.

Типы вложений электронной почты

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Вложения электронной почты (правило для почты) настоящего справочного руководства.

Разрешить любые типы файлов в качестве вложений электронной почты

Если выбрана эта опция, функция Почта-на-факс обрабатывает сообщения электронной почты с любыми вложениями. Обратите внимание, что это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. См. также главу Вложения электронной почты настоящего справочного руководства.

Только указанные расширения файлов

Если выбрана эта опция, функция Почта-на-факс обрабатывает лишь вложения электронной почты с указанными расширениями файлов. Введите расширения файлов в текстовое поле справа. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.

Важность и время отправки факсов

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Время отправки факса (правило для почты) настоящего справочного руководства.

Важность факсов, отправляемых через электронную почту

Укажите приоритет, который следует использовать при отправке факса, сгенерированного функцией Почта-на-факс. Все факсы, имеющие высокую важность, будут отправлены перед факсом, который имеет обычную или низкую важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Отправлять факсы во время действия льготного тарифа

Укажите, следует ли отправлять факсы, сгенерированные функцией Почта-на-факс, во время действия льготного тарифа. На компьютере с Windows Server, время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 или Windows 10, время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).


Набор номера

Набор номера (почта-на-факс)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

На этой странице можно указать способ преобразования номера факса.

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Набор номера (правило для почты) настоящего справочного руководства.

Преобразовать номер факса в неканонический формат перед отправкой

Укажите, нужно ли преобразовывать номера факсов в неканонический формат перед тем как создавать задание факса. Если этот флажок не отмечен, номер факса получателя в программе Факсы и сканирование Windows будет отображаться без изменений, в том же формате, в котором он был введен пользователем электронной почты. В этом случае, при использовании номера факса в каноническом формате, используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера.

Простое преобразование (удалить '+', скобки, тире и пробелы)

При использовании этой опции, знак '+', а также все круглые скобки, дефисы и пробелы будут удалены из набираемого номера. Обратите внимание, что эта функция на самом деле не проверяет, действительно ли исходный номер факса имеет канонический формат ("+" в начале номера, и т.д.).

Правило набора

При использовании этой опции, правило набора (TAPI), соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса.

(по умолчанию)

Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено к номеру факса получателя до создания задания факса.

<конкретное правило>

Правило набора, соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса. Обратите внимание, что использование конкретного местоположения не изменяет местоположение по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Добавить префикс

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру факса. Это может быть полезно во многих сценариях. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов . См. описание параметров Если номер начинается с цифр и Удалить цифры... в главе Общие параметры (маршрутизация исходящих VOIP вызовов) настоящего справочного руководства. При использовании этого параметра и номеров факсов в каноническом формате мы рекомендуем также использовать опцию Преобразовать номер факса в неканонический формат перед отправкой.

Использовать исходный номер при отпраке уведомления на e-mail отправителя

При использовании этой опции, исходный номер получателя факса (введенный пользователем электронной почты) будет указан в уведомлении по электронной почте. Если этот флажок не отмечен, будет указан преобразованный номер факса (например, с добавленным префиксом). Эта опция игнорируется, если пользователь электронной почты указывает нескольких получателей факса в одном сообщении электронной почты.

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows.

Набираемый номер

Номер факса, как он будет набираться. Если опция Преобразовать номер факса в неканонический формат перед отправкой не используется, а номер факса получателя имеет канонический формат, то используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Примечания

  • Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Например, набираемый номер может содержать специальные символы, такие как 'W', ',', '#' и т. д. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .
  • Правила набора номера (TAPI) не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Уведомления о доставке

Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

На этой странице можно указать, следует ли уведомлять отправителя по e-mail об успешной или неудачной доставке факса. Вы можете выбрать формат вложения и указать, как формируются имена файлов.

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.

Нажмите, чтобы настроить шаблоны электронной почты

Нажмите, чтобы перейти на страницу Шаблоны электронной почты и настроить шаблоны электронной почты по умолчанию, которые будут использоваться с функцией Почта-на-факс.

Уведомление о доставке на адрес электронной почты отправителя

Указывает, следует ли отправлять уведомление об успешной или неудачной отправке факса на адрес электронной почты отправителя.

Вкладывать копию отправленного факса в формате

Указывает, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию отправленного факса. Может быть TIFF, PDF либо SFF. Обратите внимание, что эта опция игнорируется в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.). В указанном случае уведомление о доставке всегда отправляется без вложенного факса.

Приведенные ниже опции отвечают за формирование имен файлов для прикрепленных факсов.

Использовать шаблон имени файла по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон имени файла:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с TSID, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.
      • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Титульные страницы

Титульные страницы (почта-на-факс)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Титульные страницы (правило для почты) настоящего справочного руководства.

Укажите сведения об отправителе

Нажмите, чтобы перейти на страницу Сведения об отправителе (почта-на-факс) и настроить сведения об отправителе по умолчанию, которые будут использоваться с функцией Почта-на-факс.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании функции Почта-на-факс.

Разрешить отправку факсов, состоящих только из титульной страницы

Указывает, можно ли отправлять факсы, состоящие только из титульной страницы, при использовании функции Почта-на-факс.

Использовать стандартный шаблон титульной страницы

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу сохраненную в указанном файле

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip FSP.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Примечания

  • При использовании функции Почта-на-факс, вы можете указать тему титульной страницы и примечание к титульной странице в основной части вашего сообщения электронной почты. Имя получателя, как и номер факса получателя, можно указать в теме вашего сообщения электронной почты. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (почта-на-факс) настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (почта-на-факс)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

На этой странице можно указать информацию об отправителе факса, которая будет отображаться на титульной странице факса в случае использования функции Почта-на-факс. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline).

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Сведения об отправителе (правило для почты) настоящего справочного руководства.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается почтовая подсистема Fax Voip FSP (служба Fax Voip FSP Mail).

Использовать нижеследующую информацию об отправителе

Если выбрана эта опция, функция Почта-на-факс использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • При использовании функции Почта-на-факс , адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты. Адрес e-mail, указанный в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...) игнорируется.
  • Если вы указываете адрес e-mail в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...), а затем отправляете факс обычным способом (из программного обеспечения Факсы и сканирование Windows), и при этом функция Почта-на-факс активна, то факс будет обработан системой Почта-на-факс и уведомление об успешной или неудачной доставке факса будет отправлено на указанный адрес электронной почты. Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты (почта-на-факс) для указанного адреса электронной почты и отключить отправку уведомлений для этого правила, см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.


Правила для почты

Правила для почты (почта-на-факс)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

Так называемые Правила для почты позволяют настроить поведение функции Почта-на-факс в зависимости от адреса электронной почты отправителя. Максимальное поддерживаемое количество Правил для почты не ограничено.

Fax Voip FSP всегда проверяет Правила для почты, начиная с правила # 1. Сообщения e-mail обрабатываются согласно первому правилу, для которого адрес электронной почты соответствует заданному шаблону. Все остальные правила игнорируются. Например, если правило # 1 применяется для любого адреса электронной почты ('Электронная почта' = *@*), то все остальные правила # 2, # 3, и т.д. никогда не выполнятся ни при каких условиях. Если не существует ни одного правила, которое соответствует адресу электронной почты отправителя, будут применяться параметры почта-на-факс , заданные по умолчанию.

Правило может применяться к:

  • одному адресу электронной почты
  • группе адресов электронной почты с указанной доменной частью
  • любому адресу электронной почты

Существует два типа правил:

  • Разрешить. Правила, которые позволяют использовать функционал Почта-на-факс для указанного адреса (адресов) электронной почты.
  • Запретить. Правила, которые запрещают использовать функционал Почта-на-факс для указанного адреса (адресов) электронной почты.

Следующие параметры почта-на-факс могут быть установлены или переопределены с помощью правила для почты:

  • Правила набора номера
  • Уведомление о доставке на адрес электронной почты отправителя
  • Типы файлов, которые можно использовать в качестве вложений электронной почты
  • Титульные страницы
  • Сведения об отправителе
  • Важность и время отправки факсов
  • Шаблоны электронной почты : Факс успешно отправлен , Не удалось отправить факс , Не удалось создать задание факса

Таблица Правила для почты (Почта-на-факс) содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Электронная почта

Шаблон адреса электронной почты, для которого применяется текущее правило.

Разрешить

Тип правила. Разрешает или запрещает использование функционала Почта-на-факс для указанного адреса (адресов) электронной почты.

Набор номера

Указывает, используются ли для правил набора номера пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Уведомления

Указывает, используются ли для уведомлений о доставке факса пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Вложения

Указывает, используются ли для вложений электронной почты пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Титульные страницы

Указывает, используются ли для титульных страниц пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Сведения об отправителе

Указывает, используются ли для сведений об отправителе пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Время отправки

Указывает, используются ли для важности и времени отправки факсов пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Шаблоны e-mail

Указывает, используются ли для шаблонов электронной почты пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Почта-на-факс, на ленте доступны следующие команды:

Правила для почты

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило для почты.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила для почты. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила для почты. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правила для почты. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правила для почты. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил для почты. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Почта-на-факс также доступны в контекстном меню списка.


Добавление или изменение правил

Добавление или изменение правил "Почта-на-факс"

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс, затем нажмите Правила для почты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Почта-на-факс, на вкладке Общие, укажите адрес электронной почты, для которого применяется данное правило. Чтобы выбрать адрес электронной почты из адресной книги (контакты Windows), нажмите кнопку Адресная книга. Выберите тип правила: Разрешить или Запретить. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Общие параметры .

5. Перейдите на вкладку Набор номера.

6. На вкладке Набор номера, укажите, следует ли для правил набора номера использовать пользовательские настройки или настройки по умолчанию. Укажите, нужно ли преобразовывать номер факса в неканонический формат перед тем как создавать задание факса. Укажите, следует ли добавлять префикс перед номером. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Набор номера .

7. Перейдите на вкладку Уведомления.

8. На вкладке Уведомления, укажите, следует ли для уведомлений о доставке факса использовать пользовательские настройки или настройки по умолчанию. Укажите, следует ли уведомлять отправителя об успешной или неудачной доставке факса по электронной почте. Выберите формат для прикрепленных факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Уведомления о доставке .

9. Перейдите на вкладку Вложения.

10. На вкладке Вложения, укажите, следует ли для вложений электронной почты использовать пользовательские настройки или настройки по умолчанию. Укажите, может ли пользователь использовать любые типы вложений электронной почты или только файлы с указанными расширениями. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Вложения электронной почты .

11. Перейдите на вкладку Титульные страницы.

12. На вкладке Титульные страницы, укажите, следует ли для титульных страниц факсов использовать пользовательские настройки или настройки по умолчанию. Выберите общий или личный шаблон титульной страницы, который будет использоваться. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Титульные страницы .

13. Перейдите на вкладку Отправитель.

14. На вкладке Отправитель, укажите, следует ли для сведений об отправителе использовать пользовательские настройки или настройки по умолчанию. Чтобы импортировать сведения об отправителе для заданного адреса электронной почты из адресной книги (контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Сведения об отправителе .

15. Перейдите на вкладку Время отправки.

16. На вкладке Время отправки, укажите, следует ли для важности и времени отправки факсов использовать пользовательские настройки или настройки по умолчанию. Задайте приоритет. Укажите, следует ли отправлять факсы во время действия льготного тарифа. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Время отправки факса .

17. Перейдите на вкладку Шаблоны.

18. На вкладке Шаблоны, укажите, следует ли для шаблонов электронной почты использовать пользовательские настройки или настройки по умолчанию. Настройте шаблоны электронной почты, которые будут использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Шаблоны электронной почты .

19. Нажмите кнопку <OK> чтобы зафиксировать изменения.

20. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

21. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Правил для почты. Все изменения вступают в силу немедленно.


Управление правилами

Управление правилами "Почта-на-факс"

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ››

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс, затем нажмите Правила для почты.

3. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Все изменения вступают в силу немедленно.


Параметры правил для почты

Параметры правил "Почта-на-факс"

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Почта-на-факс.

  • Общие параметры
  • Набор номера
  • Уведомления о доставке
  • Вложения электронной почты
  • Титульные страницы
  • Сведения об отправителе
  • Время отправки факса
  • Шаблоны электронной почты


Общие параметры

Общие параметры (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Общие параметры

Адрес электронной почты

В этой области необходимо задать шаблон адреса электронной почты, для которого применяется текущее правило. Правило может применяться к одному адресу электронной почты, группе адресов электронной почты с указанной доменной частью или ко всем адресам электронной почты.

E-mail адрес

Если выбрана эта опция, правило применяется к одному адресу электронной почты.

<Адресная книга>

Нажмите, чтобы выбрать адрес электронной почты из адресной книги (контакты Windows). Эта опция также позволяет импортировать из адресной книги сведения об отправителе для выбранного контакта.

Группа e-mail

Если выбрана эта опция, правило применяется к группе адресов электронной почты с указанной доменной частью.

Любой адрес электронной почты

Если выбрана эта опция, правило применяется ко всем адресам электронной почты.

Тип правила

В этой области необходимо задать тип правила. Правило может разрешать или запрещать использование функционала Почта-на-факс для указанного адреса (адресов) электронной почты.

Разрешить

Если выбрана эта опция, функция Почта-на-факс обрабатывает электронные письма с указанного адреса (адресов) электронной почты.

Запретить

Если выбрана эта опция, функция Почта-на-факс не обрабатывает электронные письма с указанного адреса (адресов) электронной почты.


Набор номера

Набор номера (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Набор номера

На этой вкладке вы можете переопределить настройки по умолчанию для правил набора номера, см. главу Набор номера (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для правил набора номера.

Преобразовать номер факса в неканонический формат

Укажите, нужно ли преобразовывать номера факсов в неканонический формат перед тем как создавать задание факса. Если этот флажок не отмечен, номер факса получателя в программе Факсы и сканирование Windows будет отображаться без изменений, в том же формате, в котором он был введен пользователем электронной почты. В этом случае, при использовании номера факса в каноническом формате, используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера.

Простое преобразование (удалить '+', скобки, тире и пробелы)

При использовании этой опции, знак '+', а также все круглые скобки, дефисы и пробелы будут удалены из набираемого номера. Обратите внимание, что эта функция на самом деле не проверяет, действительно ли исходный номер факса имеет канонический формат ("+" в начале номера, и т.д.).

Правило набора

При использовании этой опции, правило набора (TAPI), соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса.

(по умолчанию)

Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено к номеру факса получателя до создания задания факса.

<конкретное правило>

Правило набора, соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса. Обратите внимание, что использование конкретного местоположения не изменяет местоположение по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Добавить префикс

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру факса. Это может быть полезно во многих сценариях. В частности, это можно использовать для маршрутизации факсов от различных пользователей электронной почты через разные учетные записи SIP. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов . См. описание параметров Если номер начинается с цифр и Удалить цифры... в главе Общие параметры (маршрутизация исходящих VOIP вызовов) настоящего справочного руководства. При использовании этого параметра и номеров факсов в каноническом формате мы рекомендуем также использовать опцию Преобразовать номер факса в неканонический формат.

Использовать исходный номер при отпраке уведомления

При использовании этой опции, исходный номер получателя факса (введенный пользователем электронной почты) будет указан в уведомлении по электронной почте. Если этот флажок не отмечен, будет указан преобразованный номер факса (например, с добавленным префиксом). Эта опция игнорируется, если пользователь электронной почты указывает нескольких получателей факса в одном сообщении электронной почты.

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows.

Набираемый номер

Номер факса, как он будет набираться. Если опция Преобразовать номер факса в неканонический формат не используется, а номер факса получателя имеет канонический формат, то используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Примечания

  • Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Например, набираемый номер может содержать специальные символы, такие как 'W', ',', '#' и т. д. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .
  • Правила набора номера (TAPI) не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Уведомления о доставке

Уведомления о доставке (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Уведомления о доставке

На этой вкладке вы можете переопределить настройки по умолчанию для уведомлений о доставке факса, см. главу Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для уведомлений о доставке факса.

Нажмите, чтобы настроить шаблоны электронной почты

Нажмите, чтобы перейти на вкладку Шаблоны .

Уведомление о доставке

В этой области вы можете указать пользовательские настройки для уведомлений о доставке факса, которые будут применяться только к текущему правилу.

Уведомление о доставке на адрес электронной почты отправителя

Указывает, следует ли отправлять уведомление об успешной или неудачной отправке факса на адрес электронной почты отправителя.

Вкладывать копию отправленного факса в формате

Указывает, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию отправленного факса. Может быть TIFF, PDF либо SFF. Обратите внимание, что эта опция игнорируется в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.). В указанном случае уведомление о доставке всегда отправляется без вложенного факса.

Приведенные ниже опции отвечают за формирование имен файлов для прикрепленных факсов.

Использовать шаблон имени файла по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон имени файла:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с TSID, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.
      • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Вложения электронной почты

Вложения электронной почты (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Вложения электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для вложений электронной почты, заданные в параметрах почта-на-факс .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для вложений электронной почты.

Типы вложений электронной почты

В этой области вы можете указать пользовательские настройки для вложений электронной почты, которые будут применяться только к текущему правилу.

Разрешить любые типы файлов в качестве e-mail вложений

Если выбрана эта опция, функция Почта-на-факс обрабатывает сообщения электронной почты с любыми вложениями. Обратите внимание, что это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. См. также главу Вложения электронной почты настоящего справочного руководства.

Только указанные расширения файлов

Если выбрана эта опция, функция Почта-на-факс обрабатывает лишь вложения электронной почты с указанными расширениями файлов. Введите расширения файлов в текстовое поле ниже. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.


Титульные страницы

Титульные страницы (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Титульные страницы

На этой вкладке вы можете переопределить настройки по умолчанию для титульных страниц факсов, см. главу Титульные страницы (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для титульных страниц.

Нажмите, чтобы указать сведения об отправителе

Нажмите, чтобы перейти на вкладку Отправитель .

Титульные страницы

В этой области вы можете указать пользовательские настройки для титульных страниц факсов, которые будут применяться только к текущему правилу.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании функции Почта-на-факс.

Разрешить отправку факсов, состоящих только из титульной страницы

Указывает, можно ли отправлять факсы, состоящие только из титульной страницы, при использовании функции Почта-на-факс.

Использовать стандартный шаблон

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу из указанного файла

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip FSP.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Примечания

  • При использовании функции Почта-на-факс, вы можете указать тему титульной страницы и примечание к титульной странице в основной части вашего сообщения электронной почты. Имя получателя, как и номер факса получателя, можно указать в теме вашего сообщения электронной почты. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (правило для почты) настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Сведения об отправителе

Информация об отправителе отображается на титульных страницах. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline).

На этой вкладке вы можете переопределить настройки по умолчанию для информации об отправителе, см. главу Сведения об отправителе (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для информации об отправителе.

Сведения об отправителе

В этой области вы можете указать пользовательские настройки для информации об отправителе, которые будут применяться только к текущему правилу.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается почтовая подсистема Fax Voip FSP (служба Fax Voip FSP Mail).

Использовать нижеследующие данные

Если выбрана эта опция, функция Почта-на-факс использует сведения об отправителе, указанные ниже.

<Адресная книга...>

Нажмите, чтобы импортировать сведения об отправителе для заданного адреса электронной почты из адресной книги (контакты Windows).

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • При использовании функции Почта-на-факс , адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты. Адрес e-mail, указанный в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...) игнорируется.


Время отправки факса

Время отправки факса (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Время отправки факса

На этой вкладке вы можете переопределить настройки по умолчанию для важности и времени отправки факсов, заданные в параметрах почта-на-факс .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для важности и времени отправки факсов.

Важность и время отправки факсов

В этой области вы можете указать пользовательские настройки для важности и времени отправки факсов, которые будут применяться только к текущему правилу.

Важность факсов

Укажите приоритет, который следует использовать при отправке факса. Все факсы, имеющие высокую важность, будут отправлены перед факсом, который имеет обычную или низкую важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Отправлять факсы во время действия льготного тарифа

Укажите, следует ли отправлять факсы во время действия льготного тарифа. На компьютере с Windows Server, время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 или Windows 10, время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).


Шаблоны электронной почты

Шаблоны электронной почты (правило для почты)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Правила для почты ›› Параметры правил для почты ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблонов электронной почты, см. главу Шаблоны электронной почты настоящего справочного руководства.

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующие шаблоны доступны для редактирования: Факс успешно отправлен, Не удалось отправить факс, Не удалось создать задание факса.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Факс успешно отправлен, см. Шаблоны электронной почты: Факс успешно отправлен . Настройки шаблона на вкладке правила для почты делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось отправить факс, см. Шаблоны электронной почты: Не удалось отправить факс . Настройки шаблона на вкладке правила для почты делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось создать задание факса, см. Шаблоны электронной почты: Не удалось создать задание факса . Настройки шаблона на вкладке правила для почты делаются аналогично.


Отправка факсов через e-mail

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

Данный раздел содержит необходимые сведения по использованию функции Почта-на-факс .

Чтобы отправить факс из приложения электронной почты, обратитесь к разделу Создание сообщения электронной почты .

Чтобы отправить факс с титульной страницей, обратитесь к разделу Отправка титульных страниц .

Поддерживаемые форматы вложений электронной почты обсуждаются в главе Вложения электронной почты .

Чтобы использовать файлы PDF в качестве вложений электронной почты, обратитесь к разделу Использование PDF файлов в качестве вложений электронной почты .

Для настройки списка пользователей электронной почты, которые могут использовать функцию Почта-на-факс, обратитесь к разделу Блокирование нежелательных адресов электронной почты .

E-mail уведомления об успешной или неудачной доставке факса обсуждаются в главе Уведомление на e-mail о результатах отправки факса .

Необходимые сведения по использованию функции Почта-на-факс в качестве службы Windows можно найти в главе Почта-на-факс в качестве службы Windows .


Создание сообщения e-mail

Создание сообщения электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

Для отправки факса из приложения электронной почты, необходимо создать письмо, содержащее следующие обязательные элементы:

  • Кому: Адрес электронной почты, ассоциированный с Fax Voip FSP, в соответствии с Параметрами POP3 / IMAP (например, faxserver@t38faxvoip.com).
  • Тема: Используется для задания номера факса получателя (например, 74997056352). Вы можете указать не только Номер факса получателя, но также Имя получателя (например, 78126104066<Козлов Евгений Иванович>). Можно указать несколько получателей, которые должны быть разделены точкой с запятой (например, 74997056352;78126104066<Козлов Евгений Иванович>). Имя получателя обычно отображается на титульной странице факса, см. также главу Отправка титульных страниц настоящего справочного руководства.
  • Текст сообщения. Вы можете оставить это поле пустым. Опционально, в основной части вашего сообщения электронной почты можно указать тему титульной страницы и примечание к титульной странице. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Вложение. Фактическое содержимое факса берется из вложения вашего сообщения электронной почты. Вы можете присоединить один или несколько файлов, которые будут объединены в одно факсимильное сообщение. Поддерживаемые форматы файлов, которые можно преобразовать в факс, обсуждаются в главе Вложения электронной почты . В случае отправки факса, состоящего только из титульной страницы, вы не должны прикреплять файлы к сообщению e-mail.


Отправка титульных страниц

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

Функция Почта-на-факс позволяет использовать титульные страницы при отправке факса из приложения электронной почты. Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи.

Чтобы задать шаблон общей или личной титульной страницы, который будет использоваться, см. главу Титульные страницы (почта-на-факс) . Параметр Прикреплять титульную страницу к факсу отвечает за добавление титульной страницы в документ факса. Параметр Разрешить отправку факсов, состоящих только из титульной страницы позволяет отправлять одностраничные факсы, при этом само сообщение включается в качестве примечания к титульной странице. Настройки для титульных страниц могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. также Титульные страницы (правило для почты) .

Чтобы указать информацию об отправителе, которая будет отображаться на титульных страницах, см. главу Сведения об отправителе (почта-на-факс) . Информация об отправителе может быть персонализирована в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. также Сведения об отправителе (правило для почты) . Обратите внимание, что адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты.

Имя получателя, как и Номер факса получателя, должны быть указаны в теме вашего сообщения электронной почты, см. рисунок ниже.

Тема титульной страницы и примечание к титульной странице должны быть включены в основную часть вашего сообщения электронной почты. Строка, содержащая тему титульной страницы, должна быть заключена в квадратные скобки и помещена над текстом, который содержит примечание к титульной странице. Пустые строки в начале текста, а также между темой и примечанием игнорируются. На рисунке ниже показано, как создать сообщение электронной почты.

На рисунке ниже показано как выглядит отправленная титульная страница.


Вложения электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

При использовании функции Почта-на-факс , фактическое содержимое факса берется из вложения сообщения электронной почты. Вы можете присоединить один или несколько файлов, которые будут объединены в одно факсимильное сообщение. Отправка нескольких вложений электронной почты поддерживается только при установке Fax Voip FSP на компьютер с операционной системой Windows Vista или более поздней.

По умолчанию, Fax Voip FSP не налагает никаких ограничений на типы вложений, которые вы можете использовать. К сожалению, это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. Чтобы избежать нежелательных проблем, пожалуйста, протестируйте работу функции Почта-на-факс с различными типами вложений на вашем компьютере, настройте вашу операционную систему (если необходимо), а затем, в настройках Fax Voip FSP, укажите расширения файлов, которые будут использоваться с функцией Почта-на-факс. Приведенная ниже информация поможет вам настроить вашу систему.

Ваш документ (вложение электронной почты) может быть преобразован в факс двумя различными способами:

  • С помощью функции Прямой конвертации в факс .
  • Печать в фоновом режиме (функция printto) с использованием стандартного принтера Fax, включенного в программное обеспечение службы факсов Windows.

Прямая конвертация в факс

Функция Прямой конвертации в факс позволяет конвертировать некоторые из наиболее популярных графических форматов файлов в совместимый формат факса (TIFF). Установка приложения, которое ассоциируется в системе с требуемым расширением файла, не требуется. Поддерживаемые расширения файлов: *.PDF, *.TIF, *.TIFF, *.SFF, *.QFX, *.BMP, *.JPG, *.JPEG, *.GIF, *.PNG, *.ICO, *.WMF, *.EMF. Чтобы использовать функцию Прямой конвертации в факс для указанного типа вложения электронной почты, отметьте соответствующее расширение файла в Панели управления Fax Voip FSP (Факс -> Конвертация в факс), подробности см. в главе Параметры конвертации в факс настоящего справочного руководства.

Печать в фоновом режиме

Если Прямая конвертация в факс не определена или не выбрана для расширения вашего файла (вложения электронной почты), функция Почта-на-факс пытается распечатать документ в фоновом режиме с помощью принтера Fax. Приложение, которое ассоциируется в системе с требуемым расширением файла, должно быть установлено и зарегистрировано на вашем компьютере. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Например, для печати текстового документа (*.txt) обычно используется Блокнот (notepad.exe). Для печати файлов различных графических форматов как правило используется системная библиотека shimgvw.dll либо приложение Paint. Для печати файлов с расширениями .doc и .rtf требуется установка Microsoft Word.

Теоретически любой файл, который может быть напечатан, может использоваться как вложение электронной почты. Однако не все так хорошо, как хотелось бы. Например, при печати с помощью приложения Microsoft Word (*.doc, *.rtf), печать осуществляется в обычном, а не в фоновом режиме. Ассоциированное приложение может выводить различные окна при печати, что требует действий со стороны пользователя и делает автоматическую печать документа невозможной. Некоторые типы файлов, которые нормально печатаются из открытого приложения, могут не поддерживать фоновую печать. Иными словами, ситуация с использованием функции printto для различных типов файлов сильно зависит от конкретного компьютера и установленных на нем приложений.

Правильное функционирование printto может быть легко исправлено для следующих расширений файлов: *.TXT, *.BMP, *.DIB, *.EMF, *.GIF, *.ICO, *.JFIF, *.JPE, *.JPEG, *.JPG, *.JXR, *.PNG, *.RLE, *.TIF, *.TIFF, *.WDP, *.WMF с помощью опции Исправить команды ‘printto’ в Панели управления Fax Voip FSP (Факс -> Конвертация в факс), подробности см. в главе Параметры printto настоящего справочного руководства. Для пользователей Windows 11 и Windows 10, см. также Исправление ассоциаций файлов в Windows 11 и Windows 10 .

В случае неудачной печати вашего документа (вложения электронной почты), функция Почта-на-факс пытается использовать Прямую конвертацию в факс (если поддерживается для данного расширения файла).

В случае неудачной печати, вы обычно сталкиваетесь с ошибками двух типов. В первом случае, подсистема Почта-на-факс немедленно возвращает ошибку 'Указанному файлу не сопоставлено ни одно приложение для выполнения данной операции', через уведомление на e-mail. Во втором случае, подсистема Почта-на-факс возвращает ошибку 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Столь длительное время ожидания связано с внутренним таймаутом в методах FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API), это не может быть легко исправлено в нашем приложении. По указанной причине, мы рекомендуем блокировать расширение файла, используя опцию Только указанные расширения файлов (см. ниже) или использовать функцию Прямой конвертации в факс для данного типа файлов (если это возможно).

Чтобы настроить Почта-на-факс для работы только с указанными вложениями электронной почты

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Электронная почта, а затем нажмите Почта-на-факс.

3. Выберите опцию Только указанные расширения файлов. Введите расширения файлов в текстовое поле справа. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.

4. Нажмите кнопку <Применить>. Все изменения вступают в силу немедленно.

Настройки для вложений электронной почты могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. главу Вложения электронной почты (правило для почты) настоящего справочного руководства.

Примечания

  • Мы настоятельно рекомендуем использовать функцию Прямой конвертации в факс , если это возможно для типа файлов, который вы намереваетесь использовать. В случае использования Прямой конвертации в факс, дополнительные тесты и установка приложения, которое ассоциируется с выбранным типом файла, не требуется.
  • Для исправления команд printto для стандартных расширений файлов, воспользуйтесь опцией Исправить команды ‘printto’. См. главу Параметры printto настоящего справочного руководства. Для пользователей Windows 11 и Windows 10, см. также Исправление ассоциаций файлов в Windows 11 и Windows 10 .
  • Обратите внимание, что в силу дизайна программного обеспечения службы факсов Windows, фоновая печать используется в любом случае. Однако в случае Прямой конвертации в факс , производится печать временного файла TIFF (полученного в результате прямой конвертации), а не оригинального документа (например PDF).


Использование PDF в качестве вложений

Использование PDF файлов в качестве вложений электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

Adobe Portable Document Format (PDF) является одним из наиболее популярных форматов при работе с факсами. По этой причине мы вынуждены рассмотреть вопрос о PDF вложениях отдельно. При использовании функции Почта-на-факс, два различных метода могут использоваться при создании факса из оригинального PDF документа:

  • Прямая конвертация в факс вашего документа PDF (рекомендуется).
  • Печать оригинального PDF документа (функция printto) с использованием стандартного принтера Fax, включенного в программное обеспечение службы факсов Windows.

Для использования Прямой конвертации в факс (рекомендуется)

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Факс, затем нажмите Конвертация в факс.

3. В списке Выберите типы файлов к которым применяется прямая конвертация в формат факса, поставьте флажок рядом с типом файла Adobe PDF, чтобы применять прямую конвертацию для файлов PDF.

4. Нажмите кнопку <Применить>. Все изменения вступают в силу немедленно.

Для печати PDF файлов с помощью printto

Если Прямая конвертация в факс не выбрана для файлов PDF, Fax Voip FSP автоматически “печатает” файлы PDF, используя стандартную программу, зарегистрированную в вашей системе для просмотра и печати PDF файлов. Обычно таковой является Adobe Acrobat Reader. Начиная с Adobe Reader версии 8, поведение при автоматической печати PDF документов изменилось. Adobe Reader более не закрывает себя после вызова при помощи API функции ShellExecute(printto, ...). В описанной ситуации, файлы PDF не могут использоваться в качестве вложений электронной почты.

Тем не менее, существует решение этой проблемы. Более подробную информацию можно найти на веб-сайте https://www.biopdf.com/ :

https://www.biopdf.com/acrowrap/close_adobe_reader.php

Вам необходимо загрузить и установить программу Acrobat Wrapper . При использовании этой утилиты, Adobe Reader будет корректно закрываться после “печати”.

Если вы используете Adobe Reader совместно с функцией Почта-на-факс для обработки сообщений электронной почты, содержащих PDF вложения, следующая информация должна быть принята во внимание:

  • Для автоматического закрытия PDF файлов после печати, последняя версия программы Acrobat Wrapper должна быть установлена и это должно быть сделано после установки программы Adobe Reader.
  • После любых обновлений программы Adobe Reader вы должны переустановить Acrobat Wrapper. В связи с этим, желательно отключить автоматическое обновление Adobe Reader.
  • Описанный метод не работает в случае конфигурирования почта-на-факс в качестве службы Windows , независимо от версий Adobe Reader и Acrobat Wrapper.

Чтобы загрузить и установить Adobe Reader, выполните следующие шаги:

1. Перейдите на web-страницу загрузки программы Adobe Reader .

2. Выберите операционную систему и язык. В поле выбора версии, выберите Reader 11.0 ... for Windows или Reader DC 202X.X.X ... for Windows. Мы бы рекомендовали вам снять галочки с опций установки McAfee и Chrome Extension, не ясно, нужны ли вам эти дополнительные приложения.

3. Нажмите Загрузить Acrobat Reader и следуйте инструкциям установки.

Примечания

  • Все проблемы, связанные с функцией 'печати PDF файлов с помощью printto', не могут рассматриваться как ошибки в программе Fax Voip FSP. Рекомендации, содержащиеся в этой главе, даны 'КАК ЕСТЬ' и любые претензии, связанные с работой данной функции, не будут рассматриваться нашей службой поддержки.
  • Для решения проблем, иногда возникающих в результате неуспешных тестов, следуйте инструкциям в главе Устранение неполадок функции почта-на-факс настоящего справочного руководства.


Блокирование нежелательных е-mail

Блокирование нежелательных адресов электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

По умолчанию, функция Почта-на-факс обрабатывает электронные письма, полученные с любых адресов электронной почты. Это не очень хорошая практика, так как любой, кто знает адрес электронной почты, связанный с Fax Voip FSP, может несанкционированно отправить факс. Чтобы этого избежать, мы настоятельно рекомендуем настроить список пользователей электронной почты, которым разрешено использовать функцию Почта-на-факс. Эта задача может быть легко решена с помощью Правил для почты .

Чтобы заблокировать адрес электронной почты

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс, затем нажмите Правила для почты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Почта-на-факс, на вкладке Общие, укажите адрес электронной почты, для которого применяется данное правило, либо выберите адрес электронной почты из адресной книги (контакты Windows), нажав кнопку Адресная книга. Чтобы применить правило к группе адресов электронной почты, выберите опцию Группа e-mail и укажите доменную часть адреса электронной почты (например, gmail.com). Чтобы применить правило ко всем адресам электронной почты, выберите опцию Любой адрес электронной почты. В области Укажите тип правила, выберите Запретить. См. также главу Параметры правил для почты , раздел Общие параметры .

5. Вы также можете отключить уведомления о доставке факсов для заблокированного адреса (адресов) электронной почты. Для этого, на вкладке Уведомления, снимите флажок Использовать настройки Почта-на-факс по умолчанию, а затем снимите флажок Уведомление о доставке на адрес электронной почты отправителя. В противном случае, пользователь электронной почты получит уведомление с ошибкой 'Извините, ваш e-mail адрес заблокирован...', при попытке отправить сообщение электронной почты. См. также главу Параметры правил для почты , раздел Уведомления о доставке .

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

8. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Правил для почты. Все изменения вступают в силу немедленно.

В примере, см. рисунок выше, использование функции Почта-на-факс разрешено для любого e-mail адреса с доменной частью @t38faxvoip.com, за исключением адреса robby@t38faxvoip.com, для которого создано отдельное правило вида Запретить. Обратите внимание, что правило для 'robby@t38faxvoip.com' размещено перед правилом для '*@t38faxvoip.com'. Правило вида Запретить, которое применяется ко всем адресам электронной почты (*@*), должно быть размещено после всех остальных правил.


Уведомление на e-mail

Уведомление на e-mail о результатах отправки факса

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

При использовании функции Почта-на-факс, пользователь может получать уведомления о результатах отправки факса по электронной почте. Чтобы включить или отключить отправку уведомлений, cм. описание параметра Уведомление о доставке на адрес электронной почты отправителя в главе Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) настоящего справочного руководства. Настройки могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.

В случае неудачной доставки факса, уведомление по электронной почте обычно содержит код ошибки и ее описание. В приведенной ниже таблице приведены типичные ошибки, а также даны некоторые рекомендации по устранению неполадок.

Ошибка | Описание ошибки | Как исправить проблему
Факс успешно отправлен
OK |  |
Не удалось отправить факс
Код завершения операции, возвращаемый факс сервером. Например: НЕТ_ОТВЕТА. | Описание ошибки, возвращаемое факс сервером. Например: Вызов не был отвечен. | Ошибка, возвращаемая факс сервером, не всегда указывает на наличие реальной проблемы (например, телефонная линия может быть действительно занята, вызов не был отвечен, набранный номер не является номером факса и т.д.). В любом случае эти ошибки никак не связаны с функцией Почта-на-факс. Попробуйте сначала отправить факс из приложения Факсы и сканирование Windows. Если это не работает, настройте правильно Fax Voip FSP и службу факсов Windows. Пожалуйста, изучите это руководство пользователя.
Получатели факса не указаны. | Как минимум один получатель факса должен быть указан в теме сообщения электронной почты. | Укажите корректный номер факса получателя в теме вашего e-mail сообщения. Подробнее см. в разделе Создание сообщения электронной почты .
Нет вложений в вашем электронном письме. | Ваше электронное письмо не содержит вложений либо имя вложения не читается. Также для вашей учетной записи отключена опция отправки титульной страницы без документа. Нечего отсылать. | Создайте электронное письмо, содержащее одно или несколько вложений, см. Создание сообщения электронной почты . Включите опцию Разрешить отправку факсов, состоящих только из титульной страницы, см. Титульные страницы (почта-на-факс) . Если при отправке электронного письма с вложением, вложение каким-то образом "потерялось" (странно...), попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером, см. Параметры POP3 / IMAP .
Расширение файла не поддерживается. | Расширение файла... не поддерживается. Индекс файла = ... (с указанием имени вложения электронной почты). Пожалуйста свяжитесь с администратором факс сервера для получения подробной информации о поддерживаемых форматах. | Явным образом укажите расширение вашего файла рядом с параметром Только указанные расширения файлов, либо выберите опцию Разрешить любые типы файлов в качестве вложений электронной почты. Подробнее см. в разделах Параметры почта-на-факс и Вложения электронной почты .
Документ не может быть преобразован в факс. | Ошибка, возвращаемая функцией Прямая конвертация в факс ... Индекс файла = ... (с указанием имени вложения электронной почты, вызвавшего ошибку). | Скорее всего, ваш файл поврежден.
Не удалось отправить факс. Недопустимое вложение. | Ошибка, возвращаемая методами FaxDocument.ConnectedSubmit или FaxDocument.ConnectedSubmit2 (Fax Service API), обычно 'Указанному файлу не сопоставлено ни одно приложение для выполнения данной операции' ... Индекс файла = ... (с указанием имени вложения электронной почты, вызвавшего ошибку). | Установите приложение, которое ассоциируется в системе с требуемым расширением файла. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Подробнее см. в разделе Вложения электронной почты .
Не удалось отправить факс. | Ошибка, возвращаемая методами FaxDocument.ConnectedSubmit или FaxDocument.ConnectedSubmit2 (Fax Service API), не связанная с файлом вложения электронной почты. | Решение проблемы зависит от конкретной ошибки.
Ваш e-mail адрес заблокирован.
Некорректный e-mail отправителя. | Извините, ваш e-mail адрес заблокирован. Пожалуйста свяжитесь с администратором сервера. | Адрес электронной почты заблокирован Правилами для почты (почта-на-факс) . Подробнее см. в разделе Блокирование нежелательных адресов электронной почты .


Почта-на-факс в качестве службы Windows

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Отправка факсов через e-mail ››

По умолчанию, подсистема Почта-на-факс запускается как обычное приложение от имени учетной записи текущего пользователя. Чтобы настроить подсистему Почта-на-факс для запуска в качестве службы Windows, см. Конфигурирование почта-на-факс в качестве службы Windows . Служба автоматически запускается при запуске Windows до входа пользователя в систему. Этот вариант рекомендуется для многопользовательских систем.

Запуск службы от имени учетной записи пользователя

Настоятельно рекомендуется запускать службу Fax Voip FSP Mail от имени учетной записи пользователя, а не под учетной записью локальной системы или сетевой службы. Для этого есть как минимум две причины:

  • Возможность просмотра и управления факсами, сгенерированными службой, в приложении Факсы и сканирование Windows
  • Возможность настраивать ассоциации типов файлов (ответственные за правильную печать различных документов)

Просмотр факсов и управление ими в Факсы и сканирование Windows

Текущий пользователь не имеет доступа к факсам, которые созданы другим пользователем. Если служба Fax Voip FSP Mail запущена от имени учетной записи Локальная система, факсы также будут создаваться от имени учетной записи Локальная система. В этом случае вы не можете просматривать факсы и управлять ими в приложении Факсы и сканирование Windows. Нормального решения этой проблемы не существует. Вы можете осуществить некоторые манипуляции на вкладке Параметры факса -> Безопасность, но это не решает всех проблем, с которыми вы столкнетесь. Если служба Fax Voip FSP Mail запущена под определенной учетной записью пользователя, указанный пользователь сможет просматривать факсы, сгенерированные службой и управлять ими обычным способом (при входе в систему). Обратите внимание, что только один пользователь (от имени которого работает служба) может получить доступ к факсам.

Настройка ассоциаций типов файлов

При создании факса из вашего документа, функция Почта-на-факс пытается распечатать документ в фоновом режиме с помощью принтера Fax. Успех этой операции определяется присутствием приложения, связанного с требуемым расширением файла, которое должно быть установлено и правильно зарегистрировано на вашем компьютере. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Ассоциации типов файлов, ответственные за правильную печать различных документов, могут быть легко настроены для текущей учетной записи пользователя. Однако, нет простого способа настроить ассоциации типов файлов для учетной записи 'Локальная система' или учетной записи 'Сетевая служба'. Если служба Fax Voip FSP Mail запущена от имени учетной записи Локальная система, функция Почта-на-факс не видит ваших настроек и печать документа обычно заканчивается неудачей. Если служба Fax Voip FSP Mail запущена под определенной учетной записью пользователя, указанный пользователь может настроить ассоциации типов файлов обычным способом (при входе в систему).

Для получения дополнительной информации см. следующие главы настоящего справочного руководства: Вложения электронной почты , Параметры printto , Исправление ассоциаций файлов в Windows 11 и Windows 10 .

Примечания

  • При настройке Почта-на-факс для работы с различными вложениями электронной почты, всегда делайте тесты под учетной записью текущего пользователя, прежде чем перенастраивать подсистему Почта-на-факс для запуска в качестве службы Windows.
  • Повторите тесты после перенастройки подсистемы Почта-на-факс в качестве службы Windows.


Устранение неполадок почта-на-факс

Устранение неполадок функции почта-на-факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ››

  • Часто задаваемые вопросы (FAQ)
  • Просмотр журнала функции почта-на-факс
  • Общие инструкции по восстановлению функции почта-на-факс
  • Использование вложений электронной почты с именами файлов на национальных языках


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Устранение неполадок почта-на-факс ››

Я настроил email2fax (почта-на-факс), но ничего не работает. По электронной почте всегда один и тот же ответ: 'Не удалось отправить факс... Состояние: НЕТ_ОТВЕТА; Расширенное состояние: Вызов не был отвечен'. Какие-либо предложения?

Ошибка, возвращаемая факс сервером, не всегда указывает на наличие реальной проблемы (например, телефонная линия может быть действительно занята, вызов не был отвечен, набранный номер не является номером факса и т.д.). В любом случае эти ошибки никак не связаны с функцией Почта-на-факс. Попробуйте сначала отправить факс из приложения Факсы и сканирование Windows. Если это не работает, настройте правильно Fax Voip FSP и службу факсов Windows. Пожалуйста, изучите это руководство пользователя.

У меня проблема с функцией email2fax (почта-на-факс). Когда я отправляю какое-либо вложение PDF, я получаю ответ от системы: 'Комментарий: Ваше электронное письмо не содержит вложений либо имя вложения не читается... Нечего отсылать'. Эта проблема происходит не со всеми вложениями...

Попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером, см. Параметры POP3 / IMAP . В зависимости от сервера IMAP и его настроек, вы можете столкнуться с этой проблемой.

Мы использовали почтовый сервер Gmail с email2fax, но он почему-то перестал работать. В чем проблема?

Чтобы использовать Fax Voip FSP с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .

Я не могу настроить Fax Voip FSP для работы с моим сервером POP3 (IMAP, SMTP). Я использую Fax Voip FSP версии 3.3.1 (2.4.1). Не могли бы вы помочь?

Проблема может заключаться в требованиях к версии TLS на вашем почтовом сервере. Начиная с Fax Voip FSP версии 4.1.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip FSP использовали TLS версии 1.0. Установите последнюю версию программного обеспечения Fax Voip FSP.

Мой провайдер электронной почты говорит мне, что я должен использовать OAuth 2.0 при настройке POP3 (IMAP, SMTP). Я использую Fax Voip FSP версии 4.1.1 (3.3.1, 2.4.1). Не могли бы вы помочь?

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip FSP версии 4.2.1. Установите последнюю версию программного обеспечения Fax Voip FSP.

При отправке вложения с расширением DOC, я получаю следующую ошибку: 'Не удалось отправить факс. Недопустимое вложение... Указанному файлу не сопоставлено ни одно приложение для выполнения данной операции'. Как исправить?

Попробуйте установить приложение, которое ассоциируется в системе с требуемым расширением файла. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Например, для печати файлов с расширениями .doc и .rtf, необходимо установить приложение Microsoft Word на компьютере, где установлен Fax Voip FSP. Подробнее см. в разделе Вложения электронной почты .

Когда я отправляю свое вложение, email2fax (почта-на-факс) зависает. Затем я получаю следующую ошибку: 'Не удалось отправить факс. Недопустимое вложение... Время ожидания операции истекло'. Почему?

Подсистема Почта-на-факс не может напечатать ваш документ и по какой-то причине не может вернуть ошибку немедленно. Она возвращает 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Столь длительное время ожидания связано с внутренним таймаутом в методах FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API), это не может быть легко исправлено в нашем приложении. По указанной причине, мы рекомендуем блокировать расширение файла, используя опцию Только указанные расширения файлов (подробнее см. в разделе Вложения электронной почты ) или использовать функцию Прямой конвертации в факс , для данного типа файлов (если это возможно).

Могу ли я использовать вложения электронной почты с именами файлов на русском языке? Будет довольно сложно заставить 70 сотрудников в нашем офисе прекратить использовать кириллицу ...

Fax Voip FSP имеет поддержку Юникод, поэтому у вас вряд ли возникнут проблемы из-за этого. Но если вы сомневаетесь, настройте свою систему на корректную поддержку русского языка, см. главу Использование вложений электронной почты с именами файлов на национальных языках .

Мы больше не можем отправлять исходящие факсы из приложения электронной почты. Остановка и запуск службы не помогает...

Создайте журнал отладки Почта-на-факс, подробности см. в разделе Просмотр журнала функции почта-на-факс . Следуйте общим инструкциям по восстановлению функции почта-на-факс .


Просмотр журнала почта-на-факс

Просмотр журнала функции почта-на-факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Устранение неполадок почта-на-факс ››

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Общие параметры, затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол функции Почта-на-факс.

3. Чтобы автоматически удалить файл журнала отладки при запуске почтовой подсистемы (службы Fax Voip FSP Mail), поставьте флажок у параметра Очистка протокола при запуске службы Fax Voip FSP Mail.

4. Нажмите кнопку <Применить>.

Для просмотра журнала функции Почта-на-факс нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол функции Почта-на-факс.

Примечания

  • Для просмотра детализированного журнала приема сообщений e-mail, воспользуйтесь опцией Вести протокол приема электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.
  • Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.


Восстановление почта-на-факс

Общие инструкции по восстановлению функции почта-на-факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Устранение неполадок почта-на-факс ››

В результате неудачных экспериментов с различными видами вложений электронной почты, вы можете столкнуться с ситуацией, при которой Fax Voip FSP более не проверяет входящую почту и функция Почта-на-факс оказывается полностью неработоспособной (предполагается, что Параметры POP3 / IMAP настроены корректно). Когда это происходит, вы можете также наблюдать повышенную загрузку процессора.

Изучение журнала функции почта-на-факс

1. Следуйте инструкциям главы Просмотр журнала функции почта-на-факс , чтобы включить отладку.

2. В Панели управления Fax Voip FSP, в дереве нажмите Электронная почта. Нажмите <СТОП>, а затем <СТАРТ>, чтобы перезапустить почтовую подсистему (службу Fax Voip FSP Mail).

3. Подождите не менее 5 минут. Внутренний таймаут методов FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API) составляет 5 минут, и это не может быть легко исправлено в нашем приложении. Подсистема Почта-на-факс может вернуть ошибку 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Это будет отражено в файле журнала, и вы сможете устранить проблему, заблокировав расширение файла, вызвавшее ошибку, см. главу Вложения электронной почты настоящего справочного руководства.

4. В дереве нажмите Общие параметры, затем нажмите Журналы электронной почты. Для просмотра журнала отладки нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол функции Почта-на-факс.

5. Изучите файл журнала и попытайтесь устранить проблему. Вы также можете отправить файл журнала в нашу службу поддержки по электронной почте.

Попробуйте отключить опцию "Запускать почтовую подсистему как службу Windows"

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Электронная почта. Выберите опцию Запускать почтовую подсистему как приложение.

3. Нажмите кнопку <Применить>. Убедитесь в том, что почтовая подсистема запущена.

4. Посмотрите, исчезла ли проблема. Изучите файл журнала отладки.

Удаление временных файлов

1. Откройте Панель управления Fax Voip FSP.

2. В Панели управления Fax Voip FSP, в дереве нажмите Электронная почта. Нажмите <СТОП>, чтобы остановить почтовую подсистему (службу Fax Voip FSP Mail).

3. В Проводнике Windows откройте папку {CommonAppDataFolder}\FaxVoip FSP, обычно 'C:\ProgramData\FaxVoip FSP'.

4. В папке данных Fax Voip FSP найдите папку {CommonAppDataFolder}\FaxVoip FSP\attach, обычно 'C:\ProgramData\FaxVoip FSP\attach', и откройте ее. Если в этой папке присутствуют какие-либо файлы, удалите их. Чтобы исследовать проблему, вы можете скопировать обнаруженные файлы в другое место на жестком диске перед удалением, а затем отправить их в нашу службу поддержки по электронной почте.

5. В папке данных Fax Voip FSP найдите папку {CommonAppDataFolder}\FaxVoip FSP\mail, обычно 'C:\ProgramData\FaxVoip FSP\mail', и откройте ее. Если в этой папке присутствуют какие-либо файлы, удалите их. Чтобы исследовать проблему, вы можете скопировать обнаруженные файлы в другое место на жестком диске перед удалением, а затем отправить их в нашу службу поддержки по электронной почте.

6. В Панели управления Fax Voip FSP, в дереве нажмите Электронная почта. Нажмите <СТАРТ>, чтобы запустить почтовую подсистему (службу Fax Voip FSP Mail).

Примечания

  • Функция Почта-на-факс основана на возможности вашей системы использовать функцию printto с различными типами документов (вложений электронной почты). Поведение для различных типов файлов сильно зависит от конкретного компьютера и установленных на нем приложений. Для получения дополнительной информации см. следующие главы настоящего справочного руководства: Вложения электронной почты , Параметры printto , Исправление ассоциаций файлов в Windows 10 . Проблемы, связанные с использованием какого-либо конкретного типа файлов в качестве e-mail вложений, не могут рассматриваться как ошибки в программе Fax Voip FSP.
  • Функция Почта-на-факс предоставляется 'КАК ЕСТЬ'. Следует понимать, что это не основная функция приложения. Мы всегда рады помочь вам в решении различных проблем касательно функции Почта-на-факс, но при этом любые претензии, связанные с этой функцией, не рассматриваются нашей службой поддержки.


Имена вложений электронной почты

Использование вложений электронной почты с именами файлов на национальных языках

Панель управления Fax Voip FSP ›› Электронная почта ›› Почта-на-факс ›› Устранение неполадок почта-на-факс ››

Обратите внимание, что Fax Voip FSP имеет поддержку Юникод. Таким образом, вы не должны столкнуться с проблемами, описанными в этой главе и можете использовать любые имена файлов. Тем не менее, приведенная ниже информация может оказаться полезной.

При отправке факсов с использованием функции Почта-на-факс, в качестве вложений электронной почты, пользователи часто используют длинные имена файлов и имена файлов на их родном языке, например на русском или на польском. Примеры файлов с подобными именами вы можете видеть на рисунке ниже.

Мы рекомендуем использовать короткие имена файлов с использованием букв латинского алфавита. Если вы все же хотите использовать имена файлов на вашем родном языке и имеете проблемы с такими файлами, вам следует правильно настроить вашу операционную систему на поддержку нужного языка. Нижеприведенные примеры иллюстрируют, как настроить вашу систему на поддержку русского языка.

Чтобы настроить Windows для поддержки нужного языка, выполните следующие шаги:

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления. На других системах в меню Пуск выберите Панель управления.

2. В Панели управления, нажмите Региональные стандарты.

3. В окне Регион, перейдите на вкладку Дополнительно.

4. На вкладке Дополнительно, в области Язык программ, не поддерживающих Юникод, нажмите кнопку <Изменить язык системы…>.

5. В диалоговом окне Региональные стандарты (Язык и региональные стандарты), выберите требуемый язык, например Русский (Россия).

6. Нажмите OK.

7. В диалоговом окне Изменение языка системы, нажмите Перезагрузить сейчас чтобы перезагрузить компьютер.


Параметры SMTP

Панель управления Fax Voip FSP ›› Электронная почта ››

SMTP сервер отвечает за отправку сообщений электронной почты. Параметры SMTP необходимо сконфигурировать для работы следующих функций Fax Voip FSP:

  • Маршрутизация входящих факсов: отправить по электронной почте . Пересылка принятых факсов получателям e-mail.
  • Маршрутизация исходящих факсов: уведомления о доставке по электронной почте . Уведомления об успешной или неудачной доставке факса на заранее заданный адрес(а) электронной почты.
  • Почта-на-факс . Уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя.

Предполагается, что у вас есть учетная запись электронной почты, полученная от поставщика услуг Интернета или системного администратора. Внимание! Для того, чтобы избежать неожиданных проблем, эта учетная запись не должна использоваться другими почтовыми клиентами для получения и отправки обычных писем электронной почты.

Авторизация по протоколу OAuth 2.0

Поставьте галочку, чтобы использовать протокол OAuth 2.0 при отправке сообщений электронной почты. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (SMTP) . Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip FSP версии 4.2.1.

Нажмите чтобы настроить OAuth 2.0

Нажмите чтобы настроить Параметры OAuth 2.0 (SMTP) .

Метод отправки E-mail

SecureSmtpClient

Этот метод изначально реализован в Fax Voip FSP версии 4.2.1 для поддержки протокола OAuth 2.0 при отправке сообщений электронной почты через SMTP. Поддерживает как неявное безопасное соединение Implicit SSL (обычно через порт 465), так и явное безопасное соединение Explicit SSL с отправкой команды STARTTLS (обычно через порт 587 или 25). Данный метод позволяет игнорировать ошибки в случае если ваш сервер SMTP не имеет валидного SSL сертификата. При отправке сообщения электронной почты создается подробный лог, см. главу Журналы электронной почты настоящего справочного руководства.

CDO.Message

Выберите этот вариант, чтобы использовать Collaboration Data Objects (CDO) for Microsoft Windows 2000 (Cdosys.dll) при отправке сообщений e-mail из Fax Voip FSP. Используйте эту опцию, если ваш сервер SMTP требует неявное безопасное соединение Implicit SSL (обычно через порт 465). Кроме того, необходимо использовать данный метод для отправки сообщений электронной почты с цифровой подписью.

System.Net.Mail

При выборе этого варианта для отправки сообщений e-mail используется метод предлагаемый .Net Framework. Используйте эту опцию, если ваш сервер SMTP требует явное безопасное соединение Explicit SSL с отправкой команды STARTTLS (обычно через порт 587 или 25). Кроме того, данный метод позволяет игнорировать ошибки в случае если ваш сервер SMTP не имеет валидного SSL сертификата.

E-mail отправителя

Адрес электронной почты, соответствующий учетной записи на SMTP сервере, которая используется в настройках Fax Voip FSP. Этот e-mail адрес будет отображаться в качестве адреса отправителя в исходящих e-mail сообщениях.

Имя отправителя

Понятное имя, соответствующее адресу электронной почты. Когда Fax Voip FSP отправляет сообщение, это имя будет стоять в поле От исходящего сообщения. По умолчанию используется имя Fax Voip FSP, вы можете ввести любое другое имя. Если вы оставите данное поле пустым, получатель сообщения будет видеть e-mail адрес отправителя вместо имени.

Сервер SMTP

Сервер SMTP для отправки исходящих сообщений.

Порт

Номер порта, через который устанавливается подключение на сервере исходящей почты (SMTP). Обычно используется порт 25. В случае использования неявного безопасного соединения Implicit SSL, номер порта как правило 465. В случае явного безопасного соединения Explicit SSL с отправкой команды STARTTLS, номер порта как правило 587 либо 25.

Подключаться через безопасное соединение (SSL)

Указывает, следует ли использовать безопасный протокол SSL (Secure Sockets Layer) при подключении к серверу SMTP. Обратите внимание, что, начиная с Fax Voip FSP версии 4.1.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip FSP использовали TLS версии 1.0. Если серверу необходим протокол SSL, то это требование накладывается на сервер администратором сети или поставщиком услуг Интернета.

Режим SSL

Implicit

Выберите этот вариант, если ваш сервер SMTP требует неявное безопасное соединение Implicit SSL (обычно через порт 465). При использовании этого метода сеанс SSL устанавливается заранее, до отправки команд протокола. Режим Implicit SSL реализован через методы SecureSmtpClient и CDO.Message для отправки сообщений e-mail.

Explicit (STARTTLS)

Выберите этот вариант, если ваш сервер SMTP требует явное безопасное соединение Explicit SSL (обычно через порт 587 или 25). В этом режиме сеанс SMTP начинается в незашифрованном канале, затем от клиента к серверу дается команда STARTTLS, чтобы переключиться на безопасное соединение с помощью протокола SSL. Режим Explicit SSL реализован через методы SecureSmtpClient и System.Net.Mail для отправки сообщений e-mail.

Требуется проверка подлинности

Поставьте галочку, если для работы с SMTP сервером необходима проверка подлинности.

Логин

Имя пользователя для авторизации на сервере SMTP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Поле для ввода пароля, назначенного поставщиком услуг интернета. Пароль не требуется и игнорируется, если используется современная проверка подлинности OAuth 2.0.

Подписывать исходящие сообщения цифровой подписью

Добавление цифровой подписи во все сообщения, отправляемые программой Fax Voip FSP. Если сообщение подписано, можно точно установить, кто является его отправителем. Действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в Хранилище сертификатов локального компьютера в вашей системе. У учетной записи Network Service (Сетевая служба), под которой работает служба факсов Windows, должен быть доступ на чтение к закрытым ключам вашего сертификата. Заметим, что для просмотра подписанных сообщений получателю не требуется цифрового удостоверения.

Прозрачная подпись

При прозрачном подписывании сообщений цифровая подпись отделена от подписываемых данных. Почтовые программы, не поддерживающие кодировку S/MIME могут читать только прозрачно подписанные сообщения. Используйте эту опцию, если вы не знаете, какими почтовыми программами пользуются ваши получатели.

Непрозрачная подпись

Включение кодирования сообщений с цифровой подписью во избежание ее подделывания. При использовании этой опции, пользователи почтовых программ, не поддерживающих кодировку S/MIME, не смогут читать сообщения с цифровой подписью. Если вам известно, что получатель использует почтовую программу с поддержкой кодировки S/MIME, вы можете использовать как прозрачное, так и непрозрачное подписывание.

<Сертификат>

Нажмите для отображения диалогового окна, содержащего свойства сертификата X.509 и связанной цепочки сертификатов. Если действительный сертификат, соответствующий заданному E-mail отправителя не найден, то выводится сообщение с информацией. Действительный цифровой сертификат должен быть установлен в Хранилище сертификатов локального компьютера в вашей системе. У учетной записи Network Service (Сетевая служба), под которой работает служба факсов Windows, должен быть доступ на чтение к закрытым ключам вашего сертификата. Если ваш сертификат установлен в Хранилище сертификатов текущего пользователя, Fax Voip FSP предлагает установить его в Хранилище сертификатов локального компьютера. Если ваш сертификат установлен в Хранилище сертификатов локального компьютера, но у учетной записи Network Service (Сетевая служба) отсутствует доступ на чтение к закрытым ключам, Fax Voip FSP предлагает предоставить доступ к закрытым ключам для службы факсов (учетная запись Network Service). Следуйте инструкциям диалоговых окон. Обратите внимание, что для проверки разрешений доступа для учетной записи Network Service (Сетевая служба), а также для установки сертификата в Хранилище сертификатов локального компьютера, требуются права администратора. Более подробную информацию можно найти в главе Получение и установка сертификата безопасности электронной почты настоящего справочного руководства.

<Тест>

Используйте эту кнопку для запуска встроенного SMTP клиента для тестирования параметров SMTP перед использованием.

Примечания

  • Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip FSP версии 4.2.1. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (SMTP) .
  • Начиная с Fax Voip FSP версии 4.1.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip FSP использовали TLS версии 1.0.
  • Чтобы использовать Fax Voip FSP с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .
  • Неявное безопасное соединение Implicit SSL поддерживается с методами SecureSmtpClient и CDO.Message. Явное безопасное соединение Explicit SSL с отправкой команды STARTTLS поддерживается с методами SecureSmtpClient и System.Net.Mail.
  • Если ваш сервер SMTP не имеет валидного SSL сертификата, используйте метод SecureSmtpClient или System.Net.Mail.
  • Чтобы отправлять сообщения электронной почты с цифровой подписью, используйте метод CDO.Message.
  • Чтобы отправлять сообщения электронной почты с цифровой подписью, действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в Хранилище сертификатов локального компьютера. У учетной записи Network Service (Сетевая служба), под которой работает служба факсов Windows, должен быть доступ на чтение к закрытым ключам вашего сертификата. Более подробную информацию можно найти в главе Получение и установка сертификата безопасности электронной почты настоящего справочного руководства.
  • Fax Voip FSP отправляет все сообщения e-mail в кодировке UTF-8.
  • При использовании метода CDO.Message для отправки сообщений e-mail и наличии символов юникода в имени прикрепленного файла, эти символы могут заменяться подчеркиванием ' _ '. Проблема может наблюдаться при использовании пользовательских шаблонов имен файлов, обычно при использовании нестандартной локали для форматирования даты и времени. Для получения более подробной информации см. следующие главы: Параметры формата (Отправить по электронной почте) , Параметры формата (Уведомления о доставке по электронной почте) , Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) , Уведомления о доставке (правило для почты) . Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.
  • Для проверки сделанных настроек воспользуйтесь кнопкой <Тест>, см. главу Отправка пробного e-mail . Для просмотра журнала отправки сообщений, воспользуйтесь опцией Вести протокол отправки электронной почты, см. главу Журналы электронной почты настоящего справочного руководства.
  • При использовании стандартных шаблонов электронной почты, язык текста сообщений зависит от используемого в программе активного Языкового профиля (см. главу Многоязычная поддержка настоящего справочного руководства). Если выбран профиль Русский, то сообщения отправляются на русском языке. Если выбран профиль English (Default) или English, то сообщения отправляются на английском языке. Также вы можете использовать пользовательские шаблоны электронной почты .


Параметры OAuth 2.0

Параметры OAuth 2.0 (SMTP)

Панель управления Fax Voip FSP ›› Электронная почта ›› Параметры SMTP ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip FSP версии 4.2.1.

На этой странице задаются настройки OAuth 2.0, которые будут использоваться при отправке сообщений электронной почты через сервер SMTP, см. также главу Параметры SMTP настоящего справочного руководства. Используйте кнопку <Refresh Token>, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год) и предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты, установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. После настройки параметров OAuth 2.0 и получения Refresh Token, нажмите <Применить>, чтобы сохранить настройки.

Нажмите, чтобы настроить параметры SMTP

Нажмите чтобы настроить Параметры SMTP .

<Загрузить профиль>

Нажмите, чтобы загрузить предопределенные настройки, выбранные из раскрывающегося списка справа. В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird . Можно выбрать следующие варианты (тестировалось с Fax Voip FSP):

Google / Gmail.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Gmail . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию По умолчанию или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .

Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net), Internet Explorer или По умолчанию. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Yahoo.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yahoo! . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .

Yandex.com (Fax Voip)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Yandex.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Mail.ru (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Mail.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .

Адрес авторизации

Адрес сервера авторизации (Authorization URI), на который направляется запрос на авторизацию. Сервер авторизации используется для аутентификации и авторизации и возвращает разрешение на авторизацию (код авторизации) клиентскому приложению.

Адрес получения токена

Адрес получения токена (Token URI), который используется клиентским приложением для обмена кода авторизации или Refresh Token на токен доступа (access token).

Разрешения (Scope)

Разделенный пробелами список разрешений. Разрешения OAuth 2.0 (scopes) позволяют ограничить уровень доступа, предоставляемого токену доступа (access token).

Идентификатор клиента

Публичный идентификатор клиентского приложения (Client ID).

Секретный ключ

Секретный ключ (Client Secret) используется для аутентификации подлинности приложения для API сервиса, когда приложение запрашивает доступ к учетной записи пользователя. Может быть пустой строкой для "публичного" приложения.

Адрес перенаправления

Адрес (Redirect URI), на который пользователь будет перенаправлен после того, как он разрешил приложению доступ. Он должен соответствовать одному из адресов перенаправления, зарегистрированных разработчиком при создании приложения. Сервер авторизации должен отклонить запрос, если указанный адрес не совпадает с зарегистрированным для приложения.

Адрес электр. почты

Адрес электронной почты, соответствующий учетной записи пользователя.

Refresh Token

Refresh Token предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год). Для получения Refresh Token, используйте кнопку <Refresh Token>.

<Refresh Token>

Используйте эту кнопку, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем).

Открыть запрос авторизации в этом браузере

Выберите один из вариантов ниже. Мы предлагаем 3 различных метода, так как в зависимости от почтового сервера OAuth 2.0 и параметра Адрес перенаправления (Redirect URI), который задается разработчиком при создании приложения, некоторые из них могут не работать.

Internet Explorer

Если выбран этот вариант, для обработки запроса на авторизацию используется InternetExplorer object (веб-браузер Windows Internet Explorer). Этот вариант работает со всеми провайдерами электронной почты OAuth 2.0, которые были протестированы. Обратите внимание, что этот вариант также работает в Windows 11, где Microsoft заблокировала браузер Internet Explorer.

WebBrowser (.Net)

Если выбран этот вариант, для обработки запроса на авторизацию используется элемент управления WebBrowser (.NET Framework). Обратите внимание, что этот вариант не работает с Gmail (ошибка 'неподдерживаемый браузер').

По умолчанию

Если выбран этот вариант, для обработки запроса на авторизацию используется веб-браузер по умолчанию. Обратите внимание, что этот вариант работает только с приложениями, для которых разработчик явно указал Адрес перенаправления (Redirect URI) = http://127.0.0.1. Кроме того, при этом используется случайный неиспользуемый порт, что не всегда поддерживается провайдером электронной почты OAuth 2.0. Окно браузера должно быть закрыто пользователем вручную. В наших тестах это работало только с Gmail и Microsoft (профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)). Тестировалось с Microsoft Edge и Internet Explorer в качестве веб-браузеров по умолчанию.

<Очистить>

Нажмите, чтобы очистить все текстовые поля на данной странице.

Использовать эти параметры OAuth 2.0 для POP3 / IMAP

Установите этот флажок, чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты.

Примечания

  • В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте вашего провайдера электронной почты OAuth 2.0.


Получение и установка сертификата безопасности электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ›› Параметры SMTP ››

Чтобы Fax Voip FSP мог отправлять сообщения электронной почты с цифровой подписью, действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в Хранилище сертификатов локального компьютера в вашей системе. У учетной записи Network Service (Сетевая служба), под которой работает служба факсов Windows, должен быть доступ на чтение к закрытым ключам вашего сертификата.

Получение сертификата

Цифровые сертификаты выдаются независимыми центрами сертификации. При обращении на веб-узел центра сертификации для получения сертификата перед его выпуском производится предварительная проверка подлинности для клиента. Имеются различные классы сертификатов, каждый из которых подтверждает определенный уровень надежности. Для получения дополнительных сведений посетите веб-узел центра сертификации. Можно использовать Бесплатный почтовый сертификат от Actalis .

После получения сертификата, он обычно устанавливается в Хранилище сертификатов текущего пользователя. Для доступа к вашему сертификату, выполните следующие действия:

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления. В Панели управления, нажмите Сеть и интернет, а затем нажмите Свойства браузера.

2. В окне Свойства: интернет, на вкладке Содержание нажмите Сертификаты.

3. В окне Сертификаты выберите вкладку Личные и затем дважды щелкните ваш сертификат. Убедитесь, что отображается информация о наличии закрытого ключа.

Наличие действительного сертификата в Хранилище сертификатов текущего пользователя не обеспечивает автоматического подписания сообщений электронной почты, отправляемых Fax Voip FSP. Сертификат должен быть установлен в Хранилище сертификатов локального компьютера. У учетной записи Network Service (Сетевая служба), под которой работает служба факсов Windows, должен быть доступ на чтение к закрытым ключам вашего сертификата. Самый простой способ обеспечить эти условия - использовать Панель Управления Fax Voip FSP для правильной переустановки сертификата.

Переустановка сертификата в хранилище локального компьютера с помощью Панели управления Fax Voip FSP

Предполагается, что действительный цифровой сертификат, соответствующий заданному E-mail отправителя, уже установлен в Хранилище сертификатов текущего пользователя. Чтобы установить сертификат в Хранилище сертификатов локального компьютера, выполните следующие действия:

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Электронная почта, затем нажмите SMTP.

3. Нажмите кнопку <Сертификат>.

4. В появившемся диалоговом окне нажмите Да, чтобы установить ваш сертификат в Хранилище сертификатов локального компьютера и предоставить доступ на чтение к закрытым ключам сертификата для службы факсов (учетная запись Network Service). Требуются права администратора.

5. В следующем диалоговом окне нажмите OK.

В последующих четырех разделах показано, как вручную установить сертификат в Хранилище сертификатов локального компьютера. Как и ранее, предполагается, что действительный цифровой сертификат, соответствующий заданному E-mail отправителя, уже установлен в Хранилище сертификатов текущего пользователя. Прежде всего, вы должны экспортировать сертификат вместе с закрытым ключом и сохранить его в Файле обмена личной информацией – PKCS #12 (.PFX).

Экспорт сертификата вместе с закрытым ключом

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления. В Панели управления, нажмите Сеть и интернет, а затем нажмите Свойства браузера.

2. В окне Свойства: интернет, на вкладке Содержание нажмите Сертификаты.

3. В окне Сертификаты выберите вкладку Личные и затем выберите ваш сертификат. Нажмите Экспорт. Следуйте инструкциям Мастера экспорта сертификатов.

4. На странице Экспортирование закрытого ключа, выберите опцию Да, экспортировать закрытый ключ.

5. На странице Формат экспортируемого файла, выберите опцию Файл обмена личной информацией – PKCS #12 (.PFX). Выберите другие опции, кроме опции Удалить закрытый ключ после успешного экспорта как показано на рисунке ниже.

6. На следующей странице мастера введите пароль для защиты закрытого ключа.

7. На странице Имя экспортируемого файла укажите имя файла, который вы хотите экспортировать.

8. На странице Завершение работы мастера экспорта сертификатов нажмите Готово чтобы закрыть окно мастера.

После успешного завершения этой процедуры, вы можете удалить сертификат из Хранилища сертификатов, если вы планируете установить его заново. Для этого в окне Сертификаты нажмите Удалить.

Установка сертификата в Хранилище сертификатов локального компьютера

1. Дважды щелкните файл .PFX, в котором был сохранен ваш сертификат с закрытым ключом.

2. В окне Мастер импорта сертификатов, на первой странице выберите опцию Локальный компьютер. Нажмите Далее и следуйте инструкциям. Для установки сертификата в Хранилище сертификатов локального компьютера, требуются права администратора.

3. Следуйте инструкциям Мастера импорта сертификатов.

4. На странице Защита с помощью закрытого ключа, введите пароль для закрытого ключа. Вы можете отметить опции, доступные в области Параметры импорта, если хотите. Нажмите Далее.

5. На странице Хранилище сертификатов выберите опцию Автоматически выбрать хранилище на основе типа сертификата. Нажмите Далее.

6. На странице Завершение работы мастера импорта сертификатов нажмите Готово чтобы закрыть окно мастера.

Для доступа к сертификатам установленным в Хранилище сертификатов локального компьютера

1. Откройте окно командной строки.

2. Введите mmc и нажмите клавишу ВВОД. Обратите внимание, что для просмотра сертификатов в Хранилище сертификатов локального компьютера, вы должны иметь права администратора.

3. В меню Файл выберите команду Добавить или удалить оснастку.

4. В диалоговом окне Добавление и удаление оснасток, в списке Доступные оснастки выберите Сертификаты. Нажмите Добавить.

5. В диалоговом окне Оснастка диспетчера сертификатов, выберите учетной записи компьютера и нажмите Далее.

6. В диалоговом окне Выбор компьютера, нажмите Готово.

7. В диалоговом окне Добавление и удаление оснасток, нажмите OK.

8. В окне Корень консоли, щелкните Сертификаты (локальный компьютер) для просмотра хранилищ сертификатов.

9. (Опционально). В меню Файл выберите команду Сохранить или Сохранить как чтобы сохранить консоль для дальнейшего использования.

Предоставление доступа к закрытым ключам сертификата для службы факсов

1. Откройте оснастку Сертификаты в консоли mmc, как показано в предыдущем разделе.

2. Щелкните свой сертификат правой кнопкой мыши. В контекстном меню, выберите Все задачи, а затем нажмите Управление закрытыми ключами... .

3. В окне Разрешения для ... private keys нажмите Добавить... .

4. В диалоговом окне Выбор: "Пользователи" или "Группы", введите NETWORK SERVICE, а затем нажмите Проверить имена. Нажмите OK.

5. В окне Разрешения для ... private keys, в списке Группы или пользователи, выберите NETWORK SERVICE. Предоставьте разрешение на чтение для учетной записи Network Service, как показано на рисунке ниже. Нажмите Применить.

Просмотр сертификата в приложении Fax Voip FSP

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Электронная почта, затем нажмите SMTP.

3. Для просмотра сертификата нажмите кнопку <Сертификат>. Если действительный сертификат, соответствующий заданному E-mail отправителя найден, он будет отображен. Для проверки разрешений доступа для учетной записи Network Service (Сетевая служба), требуются права администратора.


Отправка пробного e-mail

Тестирование отправки e-mail с помощью встроенного SMTP клиента

Панель управления Fax Voip FSP ›› Электронная почта ›› Параметры SMTP ››

1. Откройте Панель управления Fax Voip FSP.

2. Вы можете включить опцию Вести протокол отправки электронной почты для просмотра протокола отправки e-mail сообщений. Для включения этой опции, в дереве Панели управления Fax Voip FSP нажмите Общие параметры, а затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол отправки электронной почты и нажмите кнопку <Применить>.

3. В дереве нажмите Электронная почта, затем нажмите SMTP.

4. Нажмите кнопку <Тест> для запуска встроенного SMTP клиента. При использовании современной проверки подлинности OAuth 2.0, значок защищенного электронного письма будет отображаться в верхнем левом углу окна Отправить пробное сообщение. При отправке сообщения с цифровой подписью, будет отображаться иконка с изображением сертификата. Флажок Протокол в нижнем левом углу информирует о том, что опция Вести протокол отправки электронной почты активна.

5. Укажите адрес электронной почты получателя в поле Кому. Можно указывать не только адрес электронной почты, но также имя получателя. Можно также указать несколько получателей, которые должны быть разделены точкой с запятой. Например: sales@company.com;Support<support@company.com>. В полях Копия и Скрытая копия, можно задать получателей e-mail, которые отображаются соответственно в полях Копия и Скрытая копия сообщения электронной почты. Используйте кнопки <Кому>, <Копия> и <Скрытая копия>, чтобы выбрать получателей электронной почты из адресной книги (Контакты Windows).

6. Если вы хотите изменить тему сообщения, измените текст в поле Тема.

7. Если вы хотите изменить текст сообщения, вы можете ввести собственный текст в основном текстовом поле.

8. Для выбора e-mail вложения, нажмите кнопку <Вложить> и выберите файл. Для отправки сообщения без вложения, удалите текст из текстового поля.

9. Для отправки сообщения нажмите кнопку <Отправить>.

10. При использовании метода SecureSmtpClient для отправки сообщений электронной почты, подробности сеанса связи с сервером SMTP будут отображаться в окне Тестирование сервера исходящей почты SMTP. Чтобы закрыть окно, нажмите <Закрыть>.

11. Вы увидите окно сообщения с результатами отправки e-mail. В случае ошибки, в окне сообщения будет указан номер ошибки и ее описание. Нажмите кнопку <OK>, чтобы закрыть встроенный SMTP клиент. Для просмотра протокола отправки сообщения, в дереве Панели управления Fax Voip FSP нажмите Общие параметры, затем нажмите Журналы электронной почты, а затем нажмите кнопку <Просмотр> напротив опции Вести протокол отправки электронной почты.


Параметры POP3 / IMAP

Панель управления Fax Voip FSP ›› Электронная почта ››

POP3 / IMAP сервер отвечает за прием сообщений электронной почты. Параметры POP3 / IMAP необходимо сконфигурировать для работы следующей функции Fax Voip FSP:

  • Почта-на-факс . Отправка факсов через e-mail.

Предполагается, что у вас есть учетная запись электронной почты, полученная от поставщика услуг Интернета или системного администратора. Внимание! Для того, чтобы избежать неожиданных проблем, эта учетная запись не должна использоваться другими почтовыми клиентами для получения и отправки обычных писем электронной почты.

Авторизация по протоколу OAuth 2.0

Поставьте галочку, чтобы использовать протокол OAuth 2.0 при приеме сообщений электронной почты. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (POP3 / IMAP) . Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip FSP версии 4.2.1.

Нажмите чтобы настроить OAuth 2.0

Нажмите чтобы настроить Параметры OAuth 2.0 (POP3 / IMAP) .

Тип сервера

Тип сервера, используемого для приема входящей электронной почты. Вы можете выбрать между POP3 и IMAP.

Сервер входящей почты

Имя сервера входящих сообщений POP3 / IMAP. Эти сведения можно получить у поставщика услуг Интернета или администратора локальной сети.

Порт

Номер порта, через который устанавливается подключение на сервере входящей почты. Обычно используется порт 110 (в случае серверов POP3) или порт 143 (в случае серверов IMAP). При использовании безопасного соединения (SSL), номер порта как правило 995 в случае серверов POP3 или 993 в случае серверов IMAP.

Подключаться через безопасное соединение (SSL)

Указывает, следует ли использовать безопасный протокол SSL (Secure Sockets Layer) при подключении к серверу POP3 / IMAP. Если серверу необходим протокол SSL, то это требование накладывается на сервер администратором сети или поставщиком услуг Интернета. Обратите внимание, что, начиная с Fax Voip FSP версии 4.1.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip FSP использовали TLS версии 1.0.

Логин

Имя пользователя для авторизации на сервере POP3 / IMAP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Поле для ввода пароля, назначенного поставщиком услуг интернета. Пароль не требуется и игнорируется, если используется современная проверка подлинности OAuth 2.0.

Проверять новые сообщения каждые ... сек.

Интервал для проверки входящих сообщений электронной почты, используемый функцией Почта-на-факс. Может быть установлен от 10 до 60 секунд.

<Тест>

Используйте эту кнопку для тестирования POP3 / IMAP перед использованием.

Примечания

  • Если при отправке электронных писем с вложением, вложения каким-то образом "теряются" (странно...), попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером. В зависимости от сервера IMAP и его настроек, вы можете столкнуться с этой проблемой.
  • Если ваш сервер поддерживает как POP3 так и IMAP, рекомендуется использовать POP3. В случае некоторых серверов (например в случае pop.gmail.com / imap.gmail.com), входящие e-mail сообщения, принятые и удаленные через IMAP, могут затем быть получены повторно через POP3. Это может привести к путанице.
  • Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip FSP версии 4.2.1. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (POP3 / IMAP) .
  • Начиная с Fax Voip FSP версии 4.1.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip FSP использовали TLS версии 1.0.
  • Чтобы использовать Fax Voip FSP с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .
  • При использовании безопасного соединения (SSL), недействительные SSL сертификаты сервера POP3 / IMAP игнорируются.
  • Для проверки сделанных настроек воспользуйтесь кнопкой <Тест>, см. главу Тестирование POP3 / IMAP . Для просмотра журнала приема сообщений, воспользуйтесь опцией Вести протокол приема электронной почты, см. главу Журналы электронной почты настоящего справочного руководства.


Параметры OAuth 2.0

Параметры OAuth 2.0 (POP3 / IMAP)

Панель управления Fax Voip FSP ›› Электронная почта ›› Параметры POP3/IMAP ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip FSP версии 4.2.1.

На этой странице задаются настройки OAuth 2.0, которые будут использоваться при приеме сообщений электронной почты через сервер POP3 или IMAP, см. также главу Параметры POP3 / IMAP настоящего справочного руководства. Используйте кнопку <Refresh Token>, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год) и предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). После настройки параметров OAuth 2.0 и получения Refresh Token, нажмите <Применить>, чтобы сохранить настройки.

Нажмите, чтобы настроить параметры POP3/IMAP

Нажмите чтобы настроить Параметры POP3 / IMAP .

<Загрузить профиль>

Нажмите, чтобы загрузить предопределенные настройки, выбранные из раскрывающегося списка справа. В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird . Можно выбрать следующие варианты (тестировалось с Fax Voip FSP):

Google / Gmail.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Gmail . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию По умолчанию или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .

Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net), Internet Explorer или По умолчанию. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Yahoo.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yahoo! . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .

Yandex.com (Fax Voip)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Yandex.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Mail.ru (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip FSP для использования с учетной записью Mail.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .

Адрес авторизации

Адрес сервера авторизации (Authorization URI), на который направляется запрос на авторизацию. Сервер авторизации используется для аутентификации и авторизации и возвращает разрешение на авторизацию (код авторизации) клиентскому приложению.

Адрес получения токена

Адрес получения токена (Token URI), который используется клиентским приложением для обмена кода авторизации или Refresh Token на токен доступа (access token).

Разрешения (Scope)

Разделенный пробелами список разрешений. Разрешения OAuth 2.0 (scopes) позволяют ограничить уровень доступа, предоставляемого токену доступа (access token).

Идентификатор клиента

Публичный идентификатор клиентского приложения (Client ID).

Секретный ключ

Секретный ключ (Client Secret) используется для аутентификации подлинности приложения для API сервиса, когда приложение запрашивает доступ к учетной записи пользователя. Может быть пустой строкой для "публичного" приложения.

Адрес перенаправления

Адрес (Redirect URI), на который пользователь будет перенаправлен после того, как он разрешил приложению доступ. Он должен соответствовать одному из адресов перенаправления, зарегистрированных разработчиком при создании приложения. Сервер авторизации должен отклонить запрос, если указанный адрес не совпадает с зарегистрированным для приложения.

Адрес электр. почты

Адрес электронной почты, соответствующий учетной записи пользователя.

Refresh Token

Refresh Token предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год). Для получения Refresh Token, используйте кнопку <Refresh Token>.

<Refresh Token>

Используйте эту кнопку, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем).

Открыть запрос авторизации в этом браузере

Выберите один из вариантов ниже. Мы предлагаем 3 различных метода, так как в зависимости от почтового сервера OAuth 2.0 и параметра Адрес перенаправления (Redirect URI), который задается разработчиком при создании приложения, некоторые из них могут не работать.

Internet Explorer

Если выбран этот вариант, для обработки запроса на авторизацию используется InternetExplorer object (веб-браузер Windows Internet Explorer). Этот вариант работает со всеми провайдерами электронной почты OAuth 2.0, которые были протестированы. Обратите внимание, что этот вариант также работает в Windows 11, где Microsoft заблокировала браузер Internet Explorer.

WebBrowser (.Net)

Если выбран этот вариант, для обработки запроса на авторизацию используется элемент управления WebBrowser (.NET Framework). Обратите внимание, что этот вариант не работает с Gmail (ошибка 'неподдерживаемый браузер').

По умолчанию

Если выбран этот вариант, для обработки запроса на авторизацию используется веб-браузер по умолчанию. Обратите внимание, что этот вариант работает только с приложениями, для которых разработчик явно указал Адрес перенаправления (Redirect URI) = http://127.0.0.1. Кроме того, при этом используется случайный неиспользуемый порт, что не всегда поддерживается провайдером электронной почты OAuth 2.0. Окно браузера должно быть закрыто пользователем вручную. В наших тестах это работало только с Gmail и Microsoft (профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)). Тестировалось с Microsoft Edge и Internet Explorer в качестве веб-браузеров по умолчанию.

<Очистить>

Нажмите, чтобы очистить все текстовые поля на данной странице.

Использовать параметры OAuth 2.0 (SMTP)

Установите этот флажок, чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты. Если выбрана эта опция, Параметры OAuth 2.0 (SMTP) также используются для POP3 / IMAP.

Примечания

  • В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте вашего провайдера электронной почты OAuth 2.0.


Тестирование POP3 / IMAP

Панель управления Fax Voip FSP ›› Электронная почта ›› Параметры POP3/IMAP ››

Проверка подключения к серверу POP3 / IMAP

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Нажмите кнопку <Тест>.

3. Подробности сеанса связи с сервером входящей почты будут отображаться в окне Тестирование сервера входящей почты. Чтобы закрыть окно, нажмите <Закрыть>. Обратите внимание, что Fax Voip FSP не загружает сообщения с сервера и не удаляет их в процессе тестирования.

Просмотр протокола POP3 / IMAP

1. Откройте Панель управления Fax Voip FSP.

2. В дереве нажмите Общие параметры, затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол приема электронной почты и нажмите кнопку <Применить>.

Для просмотра протокола приема сообщений POP3 / IMAP нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол приема электронной почты.


Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip FSP версии 4.2.1.

Чтобы настроить OAuth 2.0 для отправки сообщений электронной почты через сервер SMTP, см. Параметры OAuth 2.0 (SMTP) .

Чтобы настроить OAuth 2.0 для приема сообщений электронной почты через сервер POP3 или IMAP, см. Параметры OAuth 2.0 (POP3 / IMAP) .

Ниже приведены примеры настройки Fax Voip FSP с провайдерами электронной почты OAuth 2.0:

  • Настройка SMTP, POP3 и IMAP с учетной записью Google (Gmail.com) с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Microsoft (Office 365, Hotmail, Outlook.com) с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Yahoo.com с использованием OAuth 2.0
  • Настройка SMTP и IMAP с учетной записью Yandex.ru с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Mail.ru с использованием OAuth 2.0


Google (Gmail.com)

Настройка SMTP, POP3 и IMAP с учетной записью Google (Gmail.com) с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Google / Gmail.com (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Gmail . В области Открыть запрос авторизации в этом браузере, выберите По умолчанию или Internet Explorer. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войдите в аккаунт Google, выберите правильную учетную запись или убедитесь, что введен правильный адрес электронной почты, а затем нажмите Далее.

6. На следующей странице введите пароль и нажмите Далее.

7. Если для вашей учетной записи Gmail включена двухэтапная аутентификация, введите код подтверждения, полученный от Google. При необходимости установите флажок Больше не спрашивать на этом устройстве. Затем нажмите Далее.

8. На следующей странице нажмите Разрешить, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Gmail.

9. Если в области Открыть запрос авторизации в этом браузере была выбрана опция По умолчанию, закройте окно веб-браузера вручную.

10. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-10 для Параметров OAuth 2.0 (POP3 / IMAP) .

12. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Gmail

Сервер SMTP: smtp.gmail.com

Порт: 465

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Implicit

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

13. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.gmail.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

14. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.gmail.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .
  • Чтобы настроить SMTP, POP3 и IMAP с Gmail с использованием обычной проверки подлинности, после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .


Microsoft (Office 365, Hotmail, Outlook.com)

Настройка SMTP, POP3 и IMAP с учетной записью Microsoft (Office 365, Hotmail, Outlook.com) с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird) или Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Microsoft. В области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net) или Internet Explorer. Если на предыдущем шаге вы выбрали Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test), то также можно выбрать браузер По умолчанию. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера введите пароль и нажмите Вход.

6. На следующей странице нажмите Да, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Microsoft.

7. Если в области Открыть запрос авторизации в этом браузере была выбрана опция По умолчанию, закройте окно веб-браузера вручную.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Microsoft

Сервер SMTP: outlook.office365.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail . Обратите внимание, что отправка сообщений электронной почты через SMTP с использованием OAuth 2.0 может не работать, см. комментарии ниже.

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: outlook.office365.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

12. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: outlook.office365.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • Профиль Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird) использует Идентификатор клиента, импортированный из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test) использует Идентификатор клиента, который мы нашли на веб-сайте EmailArchitect . Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .
  • Обратите внимание, что отправка сообщений электронной почты через SMTP с использованием OAuth 2.0 или прием сообщений электронной почты через POP3 с использованием OAuth 2.0 может не работать. Проблема предположительно на стороне Microsoft и связана с типом учетной записи Microsoft (Office 365, Microsoft Exchange, Hotmail / Outlook.com) и ее настройками. С одной стороны, Microsoft постоянно предупреждает об отключении обычной проверки подлинности для пользователей Office 365 и Exchange Online: Прекращение поддержки обычной проверки подлинности в Exchange Online . С другой стороны, что-то может не работать и проблема сохраняется несколько дней, недель или даже месяцев. Наши последние тесты с обычной учетной записью Microsoft (Hotmail/Outlook.com) показывают, что все протоколы (подключение IMAP, POP3 и SMTP с помощью OAuth 2.0) работают должным образом (июнь 2023 г.). Однако, исходя из всего вышесказанного, для большинства учетных записей Microsoft в настоящее время представляется разумным использовать обычную проверку подлинности.


Yahoo.com

Настройка SMTP, POP3 и IMAP с учетной записью Yahoo.com с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Yahoo.com (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Yahoo! . В области Открыть запрос авторизации в этом браузере, выберите Internet Explorer или WebBrowser (.Net). Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти с использованием учетной записи Yahoo, убедитесь, что введен правильный адрес электронной почты, а затем нажмите Далее.

6. На следующей странице введите пароль и нажмите Далее.

7. На следующей странице нажмите Принять, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Yahoo!.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Сервер SMTP: smtp.mail.yahoo.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.mail.yahoo.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

12. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.mail.yahoo.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .
  • Чтобы настроить SMTP, POP3 и IMAP с Yahoo! с использованием обычной проверки подлинности, вам необходимо сгенерировать пароль приложения в разделе Настройки безопасности учетной записи. Пароль приложения следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Yahoo!. Обратите внимание, что эта функция может быть недоступна для вновь созданных учетных записей.


Yandex.ru

Настройка SMTP и IMAP с учетной записью Yandex.ru с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Yandex.com (Thunderbird) или Yandex.com (Fax Voip), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Yandex.ru . В области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net) или Internet Explorer. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти с Яндекс ID, убедитесь, что введен правильный адрес электронной почты, а затем нажмите Войти.

6. На следующей странице введите пароль и нажмите Войти.

7. На следующей странице нажмите Войти как..., чтобы подтвердить запрошенный доступ к вашему почтовому ящику Yandex.ru.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Сервер SMTP: smtp.yandex.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (IMAP):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.yandex.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • Профиль Yandex.com (Thunderbird) использует пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Профиль Yandex.com (Fax Voip) использует 'приложение OAuth 2.0' (пару Идентификатор клиента / Секретный ключ), которое было зарегистрировано нашими разработчиками. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .
  • Обратите внимание, что прием сообщений электронной почты по протоколу POP3 с использованием cовременной проверки подлинности OAuth 2.0 в настоящее время не поддерживается в Yandex.ru . В этом случае следует использовать обычную проверку подлинности (POP3 сервер входящей почты: pop.yandex.com, порт 995).
  • Чтобы настроить SMTP, POP3 и IMAP с Yandex.ru с использованием обычной проверки подлинности, в зависимости от настроек вашего аккаунта, вы можете использовать основной пароль учетной записи, либо сгенерировать пароль приложения в разделе Безопасность.


Mail.ru

Настройка SMTP, POP3 и IMAP с учетной записью Mail.ru с использованием OAuth 2.0

Панель управления Fax Voip FSP ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip FSP. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Mail.ru (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Mail.ru . В области Открыть запрос авторизации в этом браузере, выберите Internet Explorer или WebBrowser (.Net). Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти в почту, убедитесь, что введен правильный адрес электронной почты. Введите пароль, а затем нажмите Войти в почту.

6. На следующей странице нажмите Разрешить, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Mail.ru.

7. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

8. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-7 для Параметров OAuth 2.0 (POP3 / IMAP) .

9. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Сервер SMTP: smtp.mail.ru

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

10. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.mail.ru

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

11. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.mail.ru

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .
  • Чтобы настроить SMTP, POP3 и IMAP с Mail.ru с использованием обычной проверки подлинности, вам необходимо сгенерировать пароль для внешних приложений в разделе Безопасность. Пароль для внешних приложений следует использовать в настройках Fax Voip FSP вместо основного пароля для вашей учетной записи Mail.ru.


Шаблоны электронной почты

Панель управления Fax Voip FSP ›› Электронная почта ››

Шаблоны электронной почты позволяют изменять стандартный текст сообщений e-mail, используемых в программе. Как тема, так и текст сообщения электронной почты могут быть изменены в соответствии с вашими требованиями и предпочтениями. Также вы можете выбрать формат даты и времени.

Fax Voip FSP отправляет сообщения электронной почты в следующих случаях:

  • Почта-на-факс . Уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя.
  • Маршрутизация входящих факсов: отправить по электронной почте . Пересылка принятых факсов получателям e-mail.
  • Маршрутизация исходящих факсов: уведомления о доставке по электронной почте . Уведомления об успешной или неудачной доставке факса на заранее заданный адрес(а) электронной почты.

Содержание e-mail сообщений различно для различных функций, таким образом каждый шаблон должен быть сконфигурирован индивидуально. В шаблонах можно использовать так называемые %переменные%, которые заменяются фактическими данными. Примеры: %CallerID%, %PagesReceived%, %Duration% и т.д. Доступные наборы переменных различны для различных шаблонов. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку Вставить переменную справа от текстового поля, а затем выберите переменную из выпадающего меню. Чтобы восстановить Тему сообщения или Текст сообщения, предлагаемые по умолчанию (не путать с встроенным в программный код шаблоном по умолчанию, см. описание опции Использовать шаблон по умолчанию), полностью очистите текстовое поле, а затем нажмите Применить.

Следующие шаблоны доступны для редактирования:

  • Получен новый факс . Используется с методом маршрутизации: отправить по электронной почте .
  • Факс успешно отправлен . Используется с функцией Почта-на-факс и с методом маршрутизации: уведомления о доставке по электронной почте в случае успешно отправленного факса.
  • Не удалось отправить факс . Используется с функцией Почта-на-факс и с методом маршрутизации: уведомления о доставке по электронной почте в случае неудачной отправки факса.
  • Не удалось создать задание факса . Используется с функцией Почта-на-факс в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.).

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон.

Примечания

  • Для получения дополнительной информации по настройке конкретного шаблона, пожалуйста прочтите соответствующий раздел данной главы.


Получен новый факс

Шаблоны электронной почты: Получен новый факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Получен новый факс используется с методом маршрутизации: отправить по электронной почте при пересылке принятых факсов получателям e-mail. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Получен новый факс. Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (получен новый факс)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Получен новый факс можно использовать следующие переменные (заменяются фактическими данными):

  • %CallerID%. Номер телефона вызывающего устройства.
  • %CalledNumber%. Номер телефона вызываемого абонента (DID).
  • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
  • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
  • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
  • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
  • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
  • %PagesReceived%. Количество страниц в принятом факсимильном документе.
  • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip Line 2.
  • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip FSP.
  • %RemoteFaxIDOrCallerID%. Механизм замещения следующий: эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае строка неизвестный отправитель.
  • %CallerIDOrRemoteFaxID%. Механизм замещения следующий: эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае строка неизвестный отправитель.
  • %CallerIDAndRemoteFaxID%. Механизм замещения следующий: эквивалентно %CallerID% (%RemoteFaxID%) если как CallerID так и Fax ID отправителя – не пустые строки; в противном случае эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае строка неизвестный отправитель. Пример: 19012223344 ( (901) 222-3344).

Примечания

  • При использовании метода маршрутизации: отправить по электронной почте , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных правил, см. главу Шаблоны электронной почты (Отправить по электронной почте) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Факс успешно отправлен

Шаблоны электронной почты: Факс успешно отправлен

Панель управления Fax Voip FSP ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Факс успешно отправлен используется с функцией Почта-на-факс и с методом маршрутизации: уведомления о доставке по электронной почте при отправке уведомлений об успешной доставке факса на адрес электронной почты отправителя или на заранее заданный адрес(а) электронной почты соответственно. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Факс успешно отправлен. Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (факс успешно отправлен)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Факс успешно отправлен можно использовать следующие переменные (заменяются фактическими данными):

  • %RecipientFaxNumber%. Номер факса получателя.
  • %RecipientName%. Имя получателя.

  • %SenderEmail%. Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %SenderName%. Имя отправителя.
  • %SenderFaxNumber%. Номер факса отправителя.
  • %SenderFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается получателю при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание переменной %LocalFaxID%.
  • %SenderCompany%. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • %SenderDepartment%. Имя отдела отправителя.
  • %SenderTitle%. Должность отправителя.
  • %SenderOfficeLocation%. Номер офиса (комнаты) отправителя.
  • %SenderHomePhone%. Номер домашнего телефона отправителя.
  • %SenderOfficePhone%. Номер рабочего телефона отправителя.
  • %SenderAddress%. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • %SenderBillingCode%. Код биллинга, связанный с отправителем.

  • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При использовании с методом маршрутизации: уведомления о доставке по электронной почте и отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
  • %HasCoverPage%. Указывает, содержит ли факс титульную страницу.
  • %Subject%. Содержит тему факса (отображается на титульной странице).
  • %PagesTotal%. Общее количество страниц в отправленном факсимильном сообщении.
  • %TiffSize%. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с отправленным факсом, в килобайтах.

  • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с %SenderFaxID%, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
  • %Priority%. Важность отправленного факса; например обычная, низкая или высокая.
  • %SubmissionTime%. Время формирования задания исходящего факса.
  • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • %StartTime%. Время начала передачи исходящего факса.
  • %EndTime%. Время окончания передачи исходящего факса.
  • %Duration%. Продолжительность передачи исходящего факса.
  • %Retries%. Число предпринятых системой неудачных попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip Line 2.
  • %Status%. Результат отправки факса. OK в случае успешной отправки факса.
  • %FaxMessageID%. Уникальный номер, который идентифицирует отправленное факсимильное сообщение. Совпадает с идентификатором, который был присвоен заданию исходящего факса при его формировании.
  • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip FSP.

Примечания

  • При использовании функции Почта-на-факс , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты) настоящего справочного руководства.
  • При использовании метода маршрутизации: уведомления о доставке по электронной почте , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (Уведомления о доставке по электронной почте) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Не удалось отправить факс

Шаблоны электронной почты: Не удалось отправить факс

Панель управления Fax Voip FSP ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Не удалось отправить факс используется с функцией Почта-на-факс и с методом маршрутизации: уведомления о доставке по электронной почте при отправке уведомлений о неудачной доставке факса на адрес электронной почты отправителя или на заранее заданный адрес(а) электронной почты соответственно. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Не удалось отправить факс. Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (не удалось отправить факс)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Не удалось отправить факс можно использовать следующие переменные (заменяются фактическими данными):

  • %RecipientFaxNumber%. Номер факса получателя.
  • %RecipientName%. Имя получателя.

  • %SenderEmail%. Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %SenderName%. Имя отправителя.
  • %SenderFaxNumber%. Номер факса отправителя.
  • %SenderFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается получателю при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание переменной %LocalFaxID%.
  • %SenderCompany%. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • %SenderDepartment%. Имя отдела отправителя.
  • %SenderTitle%. Должность отправителя.
  • %SenderOfficeLocation%. Номер офиса (комнаты) отправителя.
  • %SenderHomePhone%. Номер домашнего телефона отправителя.
  • %SenderOfficePhone%. Номер рабочего телефона отправителя.
  • %SenderAddress%. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • %SenderBillingCode%. Код биллинга, связанный с отправителем.

  • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При использовании с методом маршрутизации: уведомления о доставке по электронной почте и отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
  • %HasCoverPage%. Указывает, содержит ли факс титульную страницу.
  • %Subject%. Содержит тему факса (отображается на титульной странице).
  • %PagesTotal%. Общее количество страниц в исходящем факсе.
  • %TiffSize%. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с исходящим факсом, в килобайтах.

  • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с %SenderFaxID%, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
  • %Priority%. Важность отправляемого факса; например обычная, низкая или высокая.
  • %SubmissionTime%. Время формирования задания исходящего факса.
  • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • %StartTime%. Время начала передачи исходящего факса.
  • %EndTime%. Время окончания передачи исходящего факса.
  • %Duration%. Продолжительность передачи исходящего факса.
  • %Retries%. Число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • %PagesTransferred%. Число успешно переданных страниц факса.
  • %DeviceName%. Имя устройства, которое использовалось при попытке отправить факс. Пример: Fax Voip Line 2.
  • %Status%. Результат отправки факса. Пример: НЕТ_ОТВЕТА.
  • %StatusText%. Описание ошибки. Пример: Вызов не был отвечен.
  • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с отправкой факсимильного документа.
  • %FaxAccount%. Имя учетной записи пользователя, который отправил факс.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip FSP.

Примечания

  • При использовании функции Почта-на-факс , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты) настоящего справочного руководства.
  • При использовании метода маршрутизации: уведомления о доставке по электронной почте , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (Уведомления о доставке по электронной почте) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Не удалось создать задание факса

Шаблоны электронной почты: Не удалось создать задание факса

Панель управления Fax Voip FSP ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Не удалось создать задание факса используется с функцией Почта-на-факс в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.). Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Не удалось создать задание факса. Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (не удалось отправить факс)

Тема сообщения e-mail в случае ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса и т.д).

Тема сообщения (E-mail адрес заблокирован)

Тема сообщения в случае если адрес электронной почты отправителя заблокирован (в соответствии с настройками программы).

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных переменной %SubmissionTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Не удалось создать задание факса можно использовать следующие переменные (заменяются фактическими данными):

  • %FaxRecipients%. В зависимости от характера ошибки, список получателей факса либо тема сообщения e-mail, полученного от отправителя сообщения.
  • %SenderEmail%. Адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %EmailSubject%. Тема сообщения e-mail, полученного от отправителя сообщения.
  • %DocumentName%. Исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
  • %SubmissionTime%. Время получения e-mail сообщения.
  • %Status%. Краткое описание ошибки создания факса.
  • %StatusText%. Полное описание ошибки создания факса.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip FSP.

Примечания

  • При использовании функции Почта-на-факс , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Общие параметры и протоколы

Панель управления Fax Voip FSP ››

  • Общие параметры
  • Журналы Fax Voip FSP
  • Журналы маршрутизации входящих факсов
  • Журналы маршрутизации исходящих факсов
  • Журналы электронной почты
  • Журналы SendFax.exe
  • Многоязычная поддержка


Общие параметры

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Автоматически проверять обновления

Установите флажок, чтобы Fax Voip FSP при запуске автоматически проверял наличие новой версии программы. Если новая версия доступна, отображается уведомление в области системного трея. Чтобы загрузить и установить новую версию, нажмите на уведомление. Fax Voip FSP проверяет обновления не чаще одного раза в сутки.

Загружать значок Fax Voip FSP в трей при загрузке Windows

Установите флажок, чтобы Windows автоматически загружал значок Fax Voip FSP в трей при старте системы (после входа пользователя в систему). Обратите внимание, что наличие значка в трее не является обязательным для работы программы.


Журналы Fax Voip FSP

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Вести протокол модуля IP-телефонии

Вести файл журнала отладки, в котором содержится необходимая информация о работе Службы Fax Voip FSP. Рекомендуется использовать эту опцию только при конфигурировании Fax Voip FSP или при возникновении проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Очистка протокола модуля IP-телефонии при запуске службы Fax Voip FSP

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске Службы Fax Voip FSP.

Вести протокол модуля провайдера службы факсов (Fax Voip FSP)

Вести файл журнала отладки, в котором содержится необходимая информация о работе Fax Voip провайдера для службы факсов Windows. Провайдер службы факсов (FSP) интегрирован в Службу факсов Windows.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки. Обратите внимание, что вы не можете удалить этот файл при запущенной службе факсов.

Очистка протокола модуля Fax Voip FSP при запуске службы факсов Windows

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске службы факсов.

Вести протокол модуля расширения маршрутизации Fax Voip FSP

Вести файл журнала отладки, в котором содержится необходимая информация о работе Расширения маршрутизации Fax Voip FSP. Расширение маршрутизации интегрировано в Службу факсов Windows. Для просмотра детализированных журналов отладки для конкретных методов маршрутизации факса, воспользуйтесь опциями, описанными в главе Журналы маршрутизации входящих факсов настоящего справочного руководства.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки. Обратите внимание, что вы не можете удалить этот файл при запущенной службе факсов.

Очистка протокола модуля расшир. маршрутизации при запуске службы факсов

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске службы факсов.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы маршрутизации входящих факсов

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Вести протокол метода маршрутизации 'Отправить по электронной почте'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов Отправить по электронной почте . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации факсов через e-mail. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол метода маршрутизации 'Сохранить в папке'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов Сохранить в папке . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол метода маршрутизации 'Печать'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов Печать . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила печати входящих факсов.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы маршрутизации исходящих факсов

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Вести протокол методов маршрутизации исходящих факсов

Эта опция помогает настроить и протестировать методы маршрутизации для исходящих факсов : Уведомления о доставке по электронной почте , Сохранить в папке , Печать , Пользовательский . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации факсов. Методы маршрутизации для исходящих факсов вызываются непосредственно из службы Fax Voip FSP и это отражается в другом журнале отладки, используйте опцию Вести протокол модуля IP-телефонии, см. в главе Журналы Fax Voip FSP . Для просмотра детализированного журнала отправки сообщений e-mail (при использовании метода маршрутизации Уведомления о доставке по электронной почте ), воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы электронной почты

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Вести протокол функции Почта-на-факс

Эта опция помогает настроить и протестировать функцию Почта-на-факс . Рекомендуется использовать эту опцию только при конфигурировании Fax Voip FSP или при возникновении проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Очистка протокола при запуске службы Fax Voip FSP Mail

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске почтовой подсистемы (службы Fax Voip FSP Mail).

Вести протокол отправки электронной почты

Используйте эту опцию для настройки и тестирования параметров SMTP . Файл журнала содержит результаты отправки каждого сообщения e-mail. Используется с методом маршрутизации для входящих факсов: отправить по электронной почте , методом маршрутизации для исходящих факсов: уведомления о доставке по электронной почте и функцией Почта-на-факс . Мы бы рекомендовали использовать данную опцию только в процессе настройки Fax Voip FSP или в случае возникновения проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол приема электронной почты

Используйте эту опцию для выявления ошибок при конфигурировании параметров POP3 / IMAP . В файле журнала протоколируется каждая сессия POP3 / IMAP (используется с функцией Почта-на-факс ). Мы бы рекомендовали использовать данную опцию только в процессе настройки Fax Voip FSP или в случае возникновения проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы SendFax.exe

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

Журнал отладки SendFax.exe

В этой области вы можете просмотреть или удалить журнал отладки, создаваемый утилитой командной строки SendFax.exe . Журнал отладки содержит подробную информацию о работе SendFax.exe. Чтобы включить журнал отладки, запустите SendFax.exe с параметром командной строки /DebugLog.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Очистка журнала отладки при каждом запуске SendFax.exe

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске SendFax.exe.

Простой журнал SendFax.exe

В этой области вы можете просмотреть или удалить простой журнал, создаваемый утилитой командной строки SendFax.exe . Простой журнал содержит краткую информацию о работе SendFax.exe. Чтобы включить простой журнал, запустите SendFax.exe с параметром командной строки /Log.

<Просмотр>

Используйте эту кнопку для просмотра журнала.

<Удалить>

Используйте эту кнопку для удаления файла журнала.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Многоязычная поддержка

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ››

В приложении Fax Voip FSP вы можете создавать и использовать так называемые Языковые профили. Таким образом, пользователь может перевести программу Fax Voip FSP (полностью или частично) на любой желаемый язык. Файлы с языковыми настройками сохраняются в папке *{CommonAppDataFolder}\FaxVoip FSP\Language. Имя подпапки, в которой сохраняются языковые файлы отдельно взятого профиля, совпадает с именем профиля. В качестве имени профиля как правило используется название языка. Языковые файлы представляют собой стандартные ini-файлы, сохраненные в кодировке Юникод (UTF-16). Имена ini файлов фиксированы и соответствуют различным модулям программы.

После установки Fax Voip FSP всегда присутствуют следующие стандартные профили:

  • English (Default). Зарезервированное имя. Профиль по умолчанию, встроенный в программный код. Языковые ini файлы не используются. Нельзя редактировать или удалить этот профиль, но можно создать новый профиль с его использованием.
  • English. Зарезервированное имя. После установки программы совпадает с профилем по умолчанию. Однако языковые данные загружаются из ini файлов. В отличие от профиля по умолчанию, вы можете редактировать или удалить его. Что вы должны понимать, при переустановке программы или обновлении версии, языковые данные всегда заменяются данными по умолчанию. По этой причине лучше создавать новый языковой профиль, если вы планируете кастомизировать его.
  • Русский. Зарезервированное имя. Обеспечивает поддержку русского языка в программе. При использовании русскоязычного инсталлятора устанавливается в качестве текущего. Языковые данные загружаются из ini файлов. Вы можете редактировать или удалить его. Что вы должны понимать, при переустановке программы или обновлении версии с использованием русскоязычного инсталлятора, языковые данные всегда заменяются данными из файлов установщика. По этой причине лучше создавать новый языковой профиль, если вы планируете кастомизировать его. Обратите внимание, этот пакет не входит в базовую комплектацию Fax Voip FSP (стандартная версия на английском языке) и устанавливается только при использовании русскоязычного инсталлятора.

Чтобы добавить новый Языковой профиль, обратитесь к разделу Добавление языкового профиля .

Чтобы редактировать языковые данные, обратитесь к разделу Редактирование языкового профиля .

Для получения дополнительной информации по структуре языковых ini-файлов, обратитесь к разделу Языковые файлы .

Для изменения языка программы, установите флажок для нужного элемента в списке доступных Языковых профилей, см. рисунок ниже. Нажмите кнопку <Применить> для сохранения языковых настроек. Изменения вступят в силу немедленно. Тем не менее, мы рекомендуем полностью перезагрузить Fax Voip FSP после изменения настроек языка.

В контекстной вкладке Язык, на ленте доступны следующие команды:

Языковые профили

Добавить (Ctrl + N)

Нажмите чтобы добавить Языковой профиль.

Править (Ctrl + E)

Нажмите чтобы редактировать выбранный Языковой профиль. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите чтобы удалить выбранный Языковой профиль.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Папка

Папка профиля

Нажмите, чтобы открыть папку с языковыми файлами выбранного Языкового профиля в проводнике Windows.

Большинство команд из контекстной вкладки Язык также доступны в контекстном меню списка.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Добавление языкового профиля

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ›› Многоязычная поддержка ››

Новый Языковой профиль может быть создан как копия одного из существующих профилей. Чтобы добавить новый профиль, следуйте инструкциям ниже:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Общие параметры, затем нажмите Язык.

3. Чтобы создать Языковой профиль, нажмите Добавить.

4. В диалоговом окне Добавление языкового профиля, в поле Введите имя языкового профиля или выберите из списка, введите или выберите имя нового профиля. Мы рекомендуем использовать название языка в качестве имени профиля, но вы можете ввести любое имя, которое вам нравится.

5. Из раскрывающегося списка Копировать данные из, выберите имя существующего профиля, из которого вы хотите скопировать языковые данные.

6. Нажмите кнопку <OK>.

Новый профиль будет создан и отображен в списке языков. Для настройки профиля (редактирования языковых данных), см. главу Редактирование языкового профиля . Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>.


Редактирование языкового профиля

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ›› Многоязычная поддержка ››

После создания нового Языкового профиля, вы на самом деле имеете копию одного из ранее существовавших профилей, как правило English (Default). Для того, чтобы перевести программу на нужный язык, вам необходимо отредактировать новый Языковой профиль, используя один из методов описанных ниже в этой главе.

Редактирование Языкового профиля с использованием Графического интерфейса пользователя (GUI):

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Общие параметры, затем нажмите Язык.

3. Выберите профиль, который вы хотите редактировать, а затем нажмите Править.

4. В диалоговом окне Редактирование языкового профиля, из раскрывающегося списка Сравнивать со следующим профилем, выберите профиль, который будет использоваться для сравнения.

5. Нажмите кнопку <OK>.

6. В окне Редактирование языкового профиля:<имя языка>, выберите Имя ini-файла и Секцию для редактирования.

Таблица, показанная на рисунке ниже, содержит следующие столбцы:

Параметр

Внутреннее имя переменной, в которой сохраняется текст, который можно перевести. Имя переменной обычно ассоциируется с соответствующим текстом на английском языке.

Столбец #2 (текст для сравнения)

Отображает текст, соответствующий профилю, который был выбран для сравнения. Этот столбец используется исключительно для подсказок, его содержимое не может быть изменено.

Столбец #3 (текст для редактирования)

Отображает текст, соответствующий профилю, который был выбран для редактирования. Вы можете редактировать текст в этом столбце, чтобы сделать свой перевод.

7. Отредактируйте текст в третьем столбце. В случае нескольких строк текста, используйте сочетание символов \n для перехода на новую строку (поддерживается не со всеми параметрами).

8. После выполнения необходимых изменений, нажмите кнопку <Закрыть>.

Все изменения автоматически сохраняются, когда вы выбираете другое Имя ini-файла либо другую Секцию, а также при закрытии окна Редактирование языкового профиля:<имя языка>.

Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>. Если профиль уже используется, перезапустите Fax Voip FSP для обновления языковых данных (или дважды измените текущий профиль).

Редактирование языковых файлов вручную:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите Общие параметры, затем нажмите Язык.

3. Выберите профиль, который вы хотите редактировать, а затем нажмите кнопку <Папка профиля>.

4. Отредактируйте ini-файлы вручную с помощью Блокнота или другого текстового редактора. Для получения дополнительной информации по структуре языковых ini-файлов, обратитесь к разделу Языковые файлы .

Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>. Если профиль уже используется, перезапустите Fax Voip FSP для обновления языковых данных (или дважды измените текущий профиль).

Примечания

  • Языковой файл sendfax.txt (справка для утилиты SendFax.exe) является исключением. Его нельзя редактировать используя Графический интерфейс пользователя (GUI). Этот файл необходимо редактировать вручную.


Языковые файлы

Панель управления Fax Voip FSP ›› Общие параметры и протоколы ›› Многоязычная поддержка ››

Файлы с языковыми настройками сохраняются в папке *{CommonAppDataFolder}\FaxVoip FSP\Language. Имя подпапки, в которой сохраняются языковые файлы отдельно взятого профиля, совпадает с именем профиля (как правило используется название языка). Языковые файлы представляют собой стандартные ini-файлы, сохраненные в кодировке Юникод (UTF-16). Имена ini файлов фиксированы и соответствуют различным модулям Fax Voip FSP. Единственным исключением является языковой файл sendfax.txt (справка для утилиты SendFax.exe), который не является стандартным ini-файлом.

Структура ini-файла выглядит следующим образом:

[section1]

parameter11=value11

parameter12=value12

...

[section2]

parameter21=value21

parameter22=value22

...

В случае нескольких строк текста, для перехода на новую строку используется сочетание символов \n (поддерживается не со всеми параметрами). В случае отсутствия ini-файлов, секций или отдельных параметров, Fax Voip FSP использует строки по умолчанию из языкового профиля English (default) (для отсутствующих параметров).

Вы можете редактировать языковые данные вручную, путем редактирования строковых параметров в ini-файлах. Ниже вы найдете краткое описание языковых файлов Fax Voip FSP.

FaxVoipFSPConfig.ini

Языковые настройки Панели управления Fax Voip FSP.

Секции:

[Form_FSPConfig] Общие элементы главной формы.

[Help] Справочная система.

[Menu] Контекстные меню.

[Ribbon_TabMain] Лента. Основная вкладка.

[Ribbon_TabView] Лента. Вкладка Вид.

[Ribbon_TabTools] Лента. Вкладка Инструменты.

[Ribbon_TabSIPAccounts] Лента. Контекстная вкладка Учетные записи SIP.

[Ribbon_TabOutgoingPlan] Лента. Контекстная вкладка Исходящие маршруты.

[Ribbon_TabIncomingPlan] Лента. Контекстная вкладка Входящие маршруты.

[Ribbon_TabRouteMain] Лента. Контекстная вкладка Методы для входящих.

[Ribbon_TabRouteEmail] Лента. Контекстная вкладка Отправить по почте (Методы для входящих).

[Ribbon_TabRouteFolder] Лента. Контекстная вкладка Сохранить в папке (Методы для входящих).

[Ribbon_TabRoutePrint] Лента. Контекстная вкладка Печать (Методы для входящих).

[Ribbon_TabRouteOutMain] Лента. Контекстная вкладка Методы для исходящих.

[Ribbon_TabRouteOutEmail] Лента. Контекстная вкладка Уведомления на e-mail (Методы для исходящих).

[Ribbon_TabRouteOutFolder] Лента. Контекстная вкладка Сохранить в папке (Методы для исходящих).

[Ribbon_TabRouteOutPrint] Лента. Контекстная вкладка Печать (Методы для исходящих).

[Ribbon_TabSendFaxExe] Лента. Контекстная вкладка SendFax.exe.

[Ribbon_TabMail2FaxRoute] Лента. Контекстная вкладка Почта-на-факс.

[Ribbon_TabLanguage] Лента. Контекстная вкладка Язык.

[Ribbon_Menu] Лента. Меню ленты.

[Ribbon_Menu_H323Phones] Лента. Список номеров телефонов H.323. Контекстное меню.

[Ribbon_Menu_AudioCodecs] Лента. Список аудио кодеков. Контекстное меню.

[TreeView] Дерево Панели управления Fax Voip FSP, отображаемое слева.

[VOIP] Страница Параметры IP-телефонии.

[VOIP_SIP] Страница Параметры SIP.

[VOIP_SIP_Registrations] Страница Список учетных записей SIP.

[VOIP_SIP_T38Fax] Страница Параметры T.38 факса (SIP).

[VOIP_SIP_AudioFax] Страница Параметры аудио факса (SIP).

[VOIP_H323] Страница Параметры H.323.

[VOIP_H323_Gatekeeper] Страница H.323 Гейткипер.

[VOIP_H323_T38Fax] Страница Параметры T.38 факса (H.323).

[VOIP_H323_AudioFax] Страница Параметры аудио факса (H.323).

[VOIP_OutgoingPlan] Страница Маршрутизация исходящих Voip вызовов.

[VOIP_IncomingPlan] Страница Маршрутизация входящих Voip вызовов.

[VOIP_UserAgent] Страница Агент пользователя.

[Fax_IncomingMethods] Страница Методы маршрутизации для входящих факсов.

[Fax_IncomingMethods_RouteThroughEmail] Страница Маршрутизация входящих факсов: отправить по электронной почте.

[Fax_IncomingMethods_StoreInFolder] Страница Маршрутизация входящих факсов: сохранить в папке.

[Fax_IncomingMethods_Print] Страница Маршрутизация входящих факсов: печать.

[Fax_IncomingMethods_Custom] Страница Пользовательская маршрутизация входящих факсов.

[Fax_OutgoingMethods] Страница Методы маршрутизации для исходящих факсов.

[Fax_OutgoingMethods_EmailReceipts] Страница Маршрутизация исходящих факсов: уведомления о доставке по электронной почте.

[Fax_OutgoingMethods_StoreInFolder] Страница Маршрутизация исходящих факсов: сохранить в папке.

[Fax_OutgoingMethods_Print] Страница Маршрутизация исходящих факсов: печать.

[Fax_OutgoingMethods_Custom] Страница Пользовательская маршрутизация исходящих факсов.

[Fax] Страница Параметры факса.

[Fax_DialingRules] Страница Набор номера (телефония Microsoft).

[Fax_FaxTimeouts] Страница Таймауты факса.

[Fax_FaxConverter] Страница Параметры конвертации в факс.

[Fax_FaxViewer] Страница Просмотр факсов.

[Fax_SendFaxExe] Страница SendFax.exe - утилита командной строки.

[Fax_SendFaxExe_Cover] Страница Титульные страницы (SendFax.exe).

[Fax_SendFaxExe_Sender] Страница Сведения об отправителе (SendFax.exe).

[Fax_SendFaxExe_Receipts] Страница Уведомления на e-mail (оригинал) - SendFax.exe.

[Audio] Страница Параметры аудио.

[Audio_Codecs] Страница Параметры аудио кодеков.

[Email] Страница Служба почта-на-факс.

[Email_Mail2Fax] Страница Почта-на-факс.

[Email_Mail2Fax_DialingRules] Страница Набор номера (Почта-на-факс).

[Email_Mail2Fax_Receipts] Страница Уведомление о доставке (Почта-на-факс).

[Email_Mail2Fax_Cover] Страница Титульные страницы (Почта-на-факс).

[Email_Mail2Fax_Sender] Страница Сведения об отправителе (Почта-на-факс).

[Email_Mail2Fax_Route] Страница Правила для почты (Почта-на-факс).

[Email_SMTP] Страница Параметры сервера исходящей почты (SMTP).

[Email_SMTP_OAuth2] Страница Параметры OAuth 2.0 (SMTP).

[Email_POP3IMAP] Страница Параметры сервера входящей почты (POP3/IMAP).

[Email_POP3IMAP_OAuth2] Страница Параметры OAuth 2.0 (POP3/IMAP).

[Email_Templates] Страница Шаблоны электронной почты.

[Options] Страницы Общие параметры, Журналы Fax Voip FSP, Журналы маршрутизации входящих факсов, Журналы маршрутизации исходящих факсов, Журналы электронной почты и Журналы SendFax.exe.

[Options_Language] Страница Языковые параметры.

[License] Страница Лицензии.

[About] Страница О программе.

[Form_SIPregister] Диалог Учетная запись SIP (добавление / изменение).

[Form_AddH323Number] Диалог Номер телефона (H.323).

[Form_VoipRouteOut] Диалог Правило Voip маршрутизации исходящих вызовов, общие элементы.

[Form_VoipRouteOut_General] Диалог Правило Voip маршрутизации исходящих вызовов, страница Общие.

[Form_VoipRouteOut_Fax] Диалог Правило Voip маршрутизации исходящих вызовов, страница Факс.

[Form_VoipRouteOut_Audio] Диалог Правило Voip маршрутизации исходящих вызовов, страница Аудио.

[Form_VoipRouteIn] Диалог Правило Voip маршрутизации входящих вызовов, общие элементы.

[Form_VoipRouteIn_General] Диалог Правило Voip маршрутизации входящих вызовов, страница Общие.

[Form_VoipRouteIn_Fax] Диалог Правило Voip маршрутизации входящих вызовов, страница Факс.

[Form_RouteEmail] Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), общие элементы.

[Form_RouteEmail_General] Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Общие.

[Form_RouteEmail_Email] Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница E-mail.

[Form_RouteEmail_Format] Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Формат.

[Form_RouteEmail_Templates] Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Шаблоны.

[Form_RouteFolder] Диалог Правило сохранения в папке (маршрутизация входящих факсов), общие элементы.

[Form_RouteFolder_General] Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Общие.

[Form_RouteFolder_StoreInFolder] Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Сохранить в папке.

[Form_RouteFolder_Format] Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Формат.

[Form_RoutePrint] Диалог Правило печати (маршрутизация входящих факсов), общие элементы.

[Form_RoutePrint_General] Диалог Правило печати (маршрутизация входящих факсов), страница Общие.

[Form_RoutePrint_Print] Диалог Правило печати (маршрутизация входящих факсов), страница Печать.

[Form_RouteOutEmail] Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutEmail_General] Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutEmail_Email] Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница E-mail.

[Form_RouteOutEmail_Format] Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Формат.

[Form_RouteOutEmail_Templates] Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Шаблоны.

[Form_RouteOutFolder] Диалог Правило сохранения в папке (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutFolder_General] Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutFolder_StoreInFolder] Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Сохранить в папке.

[Form_RouteOutFolder_Format] Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Формат.

[Form_RouteOutPrint] Диалог Правило печати (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutPrint_General] Диалог Правило печати (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutPrint_Print] Диалог Правило печати (маршрутизация исходящих факсов), страница Печать.

[Form_SendFaxExe] Диалог Настройка параметров SendFax.exe, общие элементы.

[Form_SendFaxExe_Recipients] Диалог Настройка параметров SendFax.exe, страница Получатели.

[Form_SendFaxExe_Documents] Диалог Настройка параметров SendFax.exe, страница Документы.

[Form_SendFaxExe_Converting] Диалог Настройка параметров SendFax.exe, страница Конвертация.

[Form_SendFaxExe_Cover] Диалог Настройка параметров SendFax.exe, страница Титульная страница.

[Form_SendFaxExe_Sender] Диалог Настройка параметров SendFax.exe, страница Отправитель.

[Form_SendFaxExe_Schedule] Диалог Настройка параметров SendFax.exe, страница Время отправки.

[Form_SendFaxExe_Receipts] Диалог Настройка параметров SendFax.exe, страница Уведомления.

[Form_CheckFaxNumber] Диалог Проверка номера факса.

[Form_Progress] Окно, отображающее ход импорта /удаления номеров факсов.

[Form_SmtpMSFax] Диалог Параметры SMTP (служба факсов Windows).

[Form_Mail2FaxService] Диалог Служба Fax Voip FSP Mail.

[Form_Mail2FaxRoute] Диалог Правило Почта-на-факс, общие элементы.

[Form_Mail2FaxRoute_General] Диалог Правило Почта-на-факс, страница Общие.

[Form_Mail2FaxRoute_DialingRules] Диалог Правило Почта-на-факс, страница Набор номера.

[Form_Mail2FaxRoute_Receipts] Диалог Правило Почта-на-факс, страница Уведомления.

[Form_Mail2FaxRoute_Attach] Диалог Правило Почта-на-факс, страница Вложения.

[Form_Mail2FaxRoute_Cover] Диалог Правило Почта-на-факс, страница Титульные страницы.

[Form_Mail2FaxRoute_Sender] Диалог Правило Почта-на-факс, страница Отправитель.

[Form_Mail2FaxRoute_Schedule] Диалог Правило Почта-на-факс, страница Время отправки.

[Form_Mail2FaxRoute_Templates] Диалог Правило Почта-на-факс, страница Шаблоны.

[Form_TestMail] Диалог Отправить пробное сообщение.

[Form_TestSmtp] Окно Тестирование сервера исходящей почты SMTP.

[Form_TestPop3] Окно Тестирование сервера входящей почты (POP3/IMAP).

[Form_AddLanguage] Диалог Добавление языкового профиля.

[Form_CompareLanguage] Диалог Редактирование языкового профиля (в котором пользователь указывает язык для сравнения).

[Form_EditLanguage] Окно Редактирование языкового профиля.

[Form_License] Окно Лицензия Fax Voip FSP.

[Form_VerifyID] Окно Проверочные коды.

[Form_Install] Окно, отображающее ход запуска или остановки служб.

[Form_Backup] Окно Сохранение конфигурации Fax Voip FSP.

[Form_Restore] Окно Восстановление конфигурации Fax Voip FSP.

[Form_WinFaxService] Окно Параметры службы факсов Windows.

FaxVoipFSPManager.ini

Языковые настройки Диспетчера Fax Voip FSP.

Секции:

[Help] Справочная система.

[Menu] Меню Fax Voip FSP в системном трее.

[Common] Общие элементы.

[Form_Trial] Окно, появляющееся в незарегистрированной версии.

convert.ini

Языковые настройки, касающиеся конвертации файлов в различные форматы.

Секции:

[Convert_ToFax] Тексты ошибок при преобразовании в формат факса.

Email.ini

Языковые настройки SMTP журнала, обратного вызова функций SSL, а также касающиеся подписывания сообщений e-mail.

Секции:

[SendMail] SMTP журнал.

[SSL_Callback] Обратный вызов функций SSL.

[Sign_Message] Подписывание сообщений электронной почты цифровой подписью.

[OAuth2Token] Процедура получения Refresh Token.

FaxStatusMSFax.ini

Языковые настройки описаний состояния факса (служба факсов Windows).

Секции:

[Fax_ExtStatus] Расширенное состояние факса.

FixPrintto.ini

Языковые настройки журнала функции Исправить команды ‘printto’.

Секции:

[Common] Общие тексты.

[Print_System] Действия, связанные с исправлениями при запуске в качестве службы Windows.

[Fix_Printto] Прочие параметры.

fswincom.ini

Языковые настройки вспомогательной утилиты (fswincom.exe), которая используется при установке и удалении Fax Voip FSP.

Секции:

[Common] Общие тексты.

[Form_Remove] Окно Удаление Fax Voip FSP.

mailtext.ini

Языковые настройки шаблонов электронной почты по умолчанию.

Секции:

[Fax_In] Входящие факсы, Метод маршрутизации: отправить по электронной почте.

[Fax_Out] Исходящие факсы, Почта-на-факс, Метод маршрутизации: уведомления о доставке по электронной почте.

sendfax.ini

Языковые настройки утилиты SendFax.exe.

Секции:

[Form_Track] Окно отслеживания факса, общие элементы.

[Help] Справочная система.

[Menu] Окно отслеживания факса, главное меню.

[Toolbar] Окно отслеживания факса, подписи кнопок и всплывающие подсказки в панели инструментов.

[Ribbon_TabMain] Окно отслеживания факса. Лента. Основная вкладка.

[Ribbon_TabView] Окно отслеживания факса. Лента. Вкладка Вид.

[Ribbon_Menu] Окно отслеживания факса. Лента. Меню ленты.

[Properties] Окно отслеживания факса. Область отображения свойств факса.

[FaxStatus_Short] Состояние факса. Краткое описание.

[FaxStatus_Long] Состояние факса. Длинное описание.

[FaxExtStatus_Short] Расширенное состояние факса. Краткое описание.

[FaxExtStatus_Long] Расширенное состояние факса. Длинное описание.

[FaxProperty_Value] Значения для свойств факса.

[App_Output] Описания событий и ошибок SendFax.exe.

sendfax.txt

Справочный текст, отображаемый при запуске утилиты SendFax.exe без параметров. Текстовой файл в кодировке Юникод. Его нельзя редактировать используя Графический интерфейс пользователя (GUI). Для редактирования этого файла воспользуйтесь Блокнотом или другим текстовым редактором.

TrayNotify.ini

Языковые настройки Уведомлений в трей.

Секции:

[New_Version] Уведомление Доступна новая версия... .

[License] Уведомления, касающиеся лицензий.

WinFaxService.ini

Языковые настройки утилиты установки Службы факсов Windows.

Секции:

[Form_Install] Окно, отображающее ход установки Службы факсов Windows.

[Common] Общие тексты.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Служба факсов Windows

Служба факсов Windows и приложение Факсы и сканирование Windows представляют собой интегрированное факс программное обеспечение включенное во все версии Windows. Microsoft Fax является расширяемой факс платформой, которую можно использовать для развертывания совместно используемых факс ресурсов в вашей организации. Пользователи внутри организации могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере, а также использовать локальные факс устройства, привязанные к их компьютерам. Факс администраторы могут конфигурировать, управлять и следить за этими общими ресурсами факсов. Централизованное управление общими факс-устройствами на базе сервера означает более простое управление и техническое обслуживание, а также низкую стоимость. Пользователи факса могут отправлять и получать факсы без необходимости использования ручных факс-аппаратов, экономя при этом время и силы.

Служба факсов Windows является обязательным компонентом для продукта Fax Voip FSP, используется для отправки и получения факсов и должна быть установлена на вашем компьютере. В процессе установки, Fax Voip FSP всегда пытается автоматически установить Службу факсов Windows на вашем компьютере, если она не установлена. Чтобы вручную установить Службу факсов Windows, следуйте инструкциям главы Установка службы факсов Windows настоящего справочного руководства.

Fax Voip провайдер для службы факсов Windows (FSP) и Расширение маршрутизации Fax Voip FSP (отвечает за методы маршрутизации для входящих факсов ) должны быть зарегистрированы в операционной системе для работы со Службой факсов Windows. Чтобы вручную зарегистрировать Fax Voip FSP, следуйте инструкциям главы Регистрация провайдера службы факсов настоящего справочного руководства.

В процессе установки, Fax Voip FSP всегда пытается автоматически настроить Службу факсов Windows на использование факсимильных устройств Fax Voip Line для отправки и приема факсов. Чтобы вручную настроить Службу факсов Windows, следуйте инструкциям главы Настройка службы факсов настоящего справочного руководства.

В процессе установки, Fax Voip FSP настраивает Службу факсов Windows на использование 'Fax Voip FSP' в качестве Идентификатора факса для всех устройств Fax Voip Line. Чтобы вручную настроить Идентификатор факса и Заголовок факса, следуйте инструкциям главы Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Чтобы настроить факс сервер, развернутый на базе операционной системы Windows Server, для совместного использования с клиентскими компьютерами, следуйте инструкциям главы Совместное использование ресурсов факса настоящего справочного руководства.

Чтобы просматривать факсы, созданные другим пользователем, и управлять ими, следуйте инструкциям главы Доступ к факсам другого пользователя настоящего справочного руководства.

Примечания

  • Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем.


Установка службы факсов

Установка службы факсов Windows

Служба факсов Windows ››

Служба факсов Windows (приложение Факсы и сканирование Windows) обычно уже установлена по умолчанию на компьютерах с Windows 11, Windows 10, Windows 8/8.1 и Windows 7.

Служба факсов Windows (роль Факс-сервера) обычно не установлена по умолчанию на компьютерах с Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2.

В процессе установки, Fax Voip FSP всегда пытается автоматически установить Службу факсов Windows на вашем компьютере, если она не установлена.

Чтобы вручную установить Службу факсов Windows в Windows 10 (ранние версии), Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10 настоящего справочного руководства.

Чтобы вручную установить Службу факсов Windows в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022 настоящего справочного руководства.

После ручной установки Службы факсов Windows, обычно необходимо осуществить регистрацию Fax Voip провайдера для службы факсов Windows (FSP) со службой факсов .


Windows 10

Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10

Служба факсов Windows ›› Установка службы факсов ››

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления.

2. В Панели управления нажмите Программы, а затем нажмите Включение или отключение компонентов Windows.

3. В появившемся окне Компоненты Windows поставьте флажок у компонента Факсы и сканирование Windows, а затем нажмите OK.

Примечания

  • Инструкции выше не применимы к Windows 11 и поздним версиям Windows 10, в которых компонент Факсы и сканирование Windows всегда установлен и не может быть удален или установлен таким образом.


Windows Server 2022

Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022

Служба факсов Windows ›› Установка службы факсов ››

1. Нажмите Пуск, а затем нажмите Диспетчер серверов.

2. В окне Диспетчер серверов, в левой панели выберите Добавить роли и компоненты.

3. В появившемся окне Мастер добавления ролей и компонентов, на странице Выбор ролей сервера, поставьте флажок у роли Факс-сервер.

4. В появившемся диалоговом окне нажмите Добавить компоненты чтобы добавить требуемые службы ролей.

5. В окне Мастера добавления ролей и компонентов нажмите Далее.

6. Следуйте инструкциям Мастера добавления ролей и компонентов. Для получения более подробных сведений, ищите Установка роли факс-сервера в справочной системе Windows.


Настройка службы факсов

Настройка службы факсов Windows

Служба факсов Windows ››

В процессе установки, Fax Voip FSP всегда пытается автоматически настроить Службу факсов Windows на использование факсимильных устройств Fax Voip Line для отправки и приема факсов.

Чтобы вручную настроить Службу факсов Windows в Windows 11, Windows 10, Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы настроить службу факсов в Windows 11 настоящего справочного руководства.

Чтобы вручную настроить Службу факсов Windows в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы настроить службу факсов в Windows Server 2022 настоящего справочного руководства.


Windows 11

Чтобы настроить службу факсов в Windows 11

Служба факсов Windows ›› Настройка службы факсов ››

1. Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование.

Кроме того, вы можете воспользоваться командой Факсы и сканирование Windows из меню иконки Fax Voip FSP в системном трее или командой Факсы и сканирование Windows в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

3. Нажмите Подключиться к факс-модему и следуйте инструкциям.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... .

5. В окне Параметры факса, на вкладке Общие, нажмите Выбрать устройство... .

6. В диалоговом окне Выбор устройства, выберите факсимильное устройство Fax Voip Line 0. Затем нажмите OK.

7. Вернувшись на вкладку Общие, поставьте флажок у параметра Разрешить устройству отправку факсов. Если вы хотите принимать входящие факсы, поставьте флажок у параметра Разрешить устройству получение факсов. Выберите опцию Автоматически отвечать... . Затем нажмите OK.


Windows Server 2022

Чтобы настроить службу факсов в Windows Server 2022

Служба факсов Windows ›› Настройка службы факсов ››

Чтобы получить доступ к приложению Факсы и сканирование Windows

Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование.

Кроме того, вы можете воспользоваться командой Факсы и сканирование Windows из меню иконки Fax Voip FSP в системном трее или воспользоваться командой Факсы и сканирование Windows в Панели управления Fax Voip FSP , на вкладке Главная ленты.

Чтобы получить доступ к Диспетчеру службы факсов

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Либо переключитесь на панель Поиск, наберите диспетчер службы факсов, а затем выберите команду Диспетчер службы факсов.

Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните Поставщики. Убедитесь, что поставщик Fax Voip T.38/G.711FAX Device Provider присутствует в списке. Если поставщик отсутствует, воспользуйтесь командой Переустановить компоненты Fax Voip FSP в Панели управления Fax Voip FSP , на вкладке Инструменты ленты, подробности см. в главе Регистрация провайдера службы факсов настоящего справочного руководства.

3. Щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip Line 0. В контекстном меню, нажмите Свойства.

4. В окне свойств, на вкладке Общие, поставьте флажок у параметра Отправка факсов. Чтобы иметь возможность принимать входящие факсы, поставьте флажок у параметра Получение факсов. В полях Код передающего абонента (TSID) и Код вызываемого абонента (CSID), по желанию введите ваш номер факса. Затем нажмите OK. Заметим, что эти параметры настраиваются индивидуально для каждого факсимильного устройства.

5. В левой панели, щелкните дважды на устройстве Fax Voip Line 0, нажмите Методы для входящих, а затем в правой панели, в зависимости от ваших интересов, настройте методы для входящих факсов чтобы автоматически осуществлять Печать, Отправку по электронной почте или Сохранение в папке полученных факсов. Заметим, что методы для входящих факсов настраиваются индивидуально для каждого факсимильного устройства.

Добавление учетной записи факса

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

2. Нажмите Подключиться к факс-модему и следуйте инструкциям.


Совместное использование ресурсов факса

Служба факсов Windows ››

Факс сервер, развернутый на базе операционной системы Windows Server, может совместно использоваться пользователями в локальной сети. Пользователи на своих клиентских компьютерах (Windows 11, Windows 10 и т.д.) могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере.

Чтобы настроить факс сервер в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2 для совместного использования с клиентскими компьютерами, следуйте инструкциям главы Настройка факс сервера (Windows Server 2022) настоящего справочного руководства.

Чтобы подключить клиентский компьютер к факс серверу в вашей сети, следуйте инструкциям главы Настройка факс клиента (Windows 11) настоящего справочного руководства.

Примечания

  • Вы не можете совместно использовать факсимильные ресурсы рабочей станции (Windows 11, Windows 10, Windows 8/8.1 или Windows 7).
  • В инструкциях в этой главе предполагается, что оба компьютера (сервер и клиент) являются членами рабочей группы.


Настройка факс сервера

Настройка факс сервера (Windows Server 2022)

Служба факсов Windows ›› Совместное использование ресурсов факса ››

Общий доступ к принтеру факсов

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Свойства принтера. Кроме того, вы можете воспользоваться командой Принтер факсов в Панели управления Fax Voip FSP , на ленте, на вкладке Главная.

2. В окне Свойства: Fax, перейдите на вкладку Доступ, выберите Общий доступ к данному принтеру, а затем введите имя принтера, которое должно отображаться для сетевых пользователей. Нажмите OK.

Настройка учетных записей пользователей

Чтобы получить доступ к факс серверу, работающему под управлением Windows Server 2022, пользователь должен иметь учетную запись.

Чтобы добавить локальную учетную запись пользователя, выполните следующие действия:

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Управление компьютером. В окне Управление компьютером, разверните Локальные пользователи и группы, щелкните правой кнопкой мыши Пользователи, а затем выберите Новый пользователь.

2. В окне Новый пользователь, введите имя пользователя и пароль. Ниже выберите наиболее подходящие опции, связанные с тем, как будет обрабатываться пароль, нажмите Создать, а затем закройте окно.

3. В окне Управление компьютером, убедитесь, что новый пользователь отображается в списке пользователей.

Факс сервер можно настроить таким образом, чтобы учетная запись автоматически создавалась при первом использовании Факсы и сканирование Windows для отправки факса. При использовании этой опции, как только пользователь подключается к факс-серверу, учетная запись создается автоматически.

Если вы хотите ограничить количество пользователей, подключающихся к факс-серверу, вы можете отключить эту настройку. В этом случае вы должны вручную создать учетные записи для всех пользователей, которым необходим доступ к факс серверу. При такой настройке, если пользователь пытается подключиться к серверу, не имея еще учетной записи, попытка подключения не удастся.

Для автоматического создания учетных записей пользователей факс сервера, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, поставьте флажок у параметра Автоматически создавать учетные записи при подключении чтобы администратору не нужно было явно создавать каждую учетную запись пользователя. Нажмите OK.

Чтобы вручную добавить учетную запись пользователя факс сервера, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните Учетные записи.

3. В правой панели, просмотрите существующие учетные записи, а затем определите, какие новые учетные записи вы хотите добавить.

4. Чтобы добавить новую учетную запись, щелкните правой кнопкой мыши Учетные записи, выберите Создать, а затем выберите Учетная запись.

5. В окне Создание новой учетной записи, укажите имя пользователя и домен, а затем нажмите Создать. Обратите внимание, что имя пользователя должно соответствовать локальной учетной записи пользователя, которую вы создали ранее.

6. В Диспетчере службы факса (Microsoft), убедитесь, что новая учетная запись отображается в списке учетных записей.

Настройка доступа к папке "Входящие" на факс сервере

Чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для всех учетных записей, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, в области Параметры переназначения, выберите опцию Выключить чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для всех учетных записей. Нажмите OK.

Чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для отдельных учетных записей, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, в области Параметры переназначения, выберите опцию Включить чтобы переназначить полученные факсимильные сообщения только отдельным учетным записям. Нажмите OK.

3. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

4. На вкладке Безопасность, нажмите Дополнительно.

5. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения, связанную с желаемой учетной записью пользователя, и нажмите Изменить. Если запись разрешения отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

6. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажок Управление папкой получения на сервере. Нажмите OK. См. картинку ниже.

7. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.


Настройка факс клиента

Настройка факс клиента (Windows 11)

Служба факсов Windows ›› Совместное использование ресурсов факса ››

Чтобы подключить клиентский компьютер к факс серверу, расположенному в вашей сети, выполните следующие действия:

1. В проводнике Windows, введите имя или адрес компьютера в вашей сети (операционная система Windows Server), на котором установлен общий факс сервер. Щелкните кнопку Переход к... или нажмите клавишу Enter.

2. В окне Безопасность Windows, введите имя пользователя и пароль, связанные с учетной записью пользователя, созданной на сервере для отправки факсов, см. главу Настройка факс сервера настоящего справочного руководства. Установите флажок Запомнить учетные данные, это очень важно. Нажмите OK.

3. Убедитесь, что принтер факсов отображается в папке.

4. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Учетные записи пользователей, а затем нажмите Управление учетными данными Windows.

5. В Диспетчере учетных данных, на странице Учетные данные Windows убедитесь, что присутствует запись, связанная с вашим сервером и учетной записью пользователя, созданной на сервере для отправки факсов. Если запись отсутствует, создайте ее, щелкнув по ссылке Добавить учетные данные Windows, см. рисунок ниже.

6. Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Нажмите Добавить... .

7. На странице Выберите факс-модем или сервер нажмите Подключиться к факс-серверу в сети.

8. На странице Введите размещение сервера факсов, введите имя или адрес компьютера в вашей сети (операционная система Windows Server), на котором установлен общий факс сервер. Следуйте инструкциям мастера.

9. Убедитесь, что учетная запись факса была успешно создана.


Конфигурирование идентификатора и заголовка факса

Служба факсов Windows ››

При отправке и получении факсов, обычно требуется задать Идентификатор факса и Заголовок факса. В случае Fax Voip FSP эти параметры конфигурируются в программном обеспечении Службы факсов Windows.

TSID (Код передающего абонента, Transmitting Subscriber Identification) - это Идентификатор факса передающей факсимильной станции. TSID - это текстовая строка, идентифицирующая данного пользователя как отправителя факса. Она передается получателю при отправке факса и может быть выведена на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста.

CSID (Код вызываемого абонента, Called Subscriber Identification) - это Идентификатор факса принимающей факсимильной станции. CSID - это текстовая строка, идентифицирующая данного пользователя как получателя факса. Она возвращается отправителю при получении факса и может быть выведена на дисплей факс-аппарата отправителя. Код CSID обычно состоит из номера факса получателя и названия организации. Коды CSID и TSID пользователя могут совпадать. Код CSID может содержать до 20 символов текста.

Заголовок факса - это текстовая строка, которая также передается в верхней части каждой страницы отправляемого факса. Обычно название вашей организации. Заголовок факса может содержать до 50 символов текста.

В процессе установки, Fax Voip FSP настраивает Службу факсов Windows на использование 'Fax Voip FSP' в качестве Идентификатора факса для всех устройств Fax Voip Line.

Чтобы настроить Идентификатор факса и Заголовок факса в Windows 11, Windows 10, Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы задать идентификатор факса и заголовок факса в Windows 11 настоящего справочного руководства.

Чтобы настроить Идентификатор факса и Заголовок факса в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы задать идентификатор факса и заголовок факса в Windows Server 2022 настоящего справочного руководства.


Windows 11

Чтобы задать идентификатор факса и заголовок факса в Windows 11

Служба факсов Windows ›› Конфигурирование идентификатора и заголовка факса ››

Обратите внимание, что параметр Использовать код устройства передающего абонента (TSID) можно настроить с помощью кнопки Переустановить компоненты Fax Voip FSP в Панели управления Fax Voip FSP , на вкладке Инструменты ленты, см. Регистрация провайдера службы факсов . В этом случае вам не нужно вручную редактировать реестр Windows и перезапускать службу факсов Windows.

Исходящий факс. Использовать код устройства передающего абонента (TSID).

Этот метод не позволяет переопределять Идентификатор факса (TSID).

1. Для использования этого метода следует установить значение параметра UseDeviceTsid равным 1. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Выполнить. Введите regedit; нажмите OK чтобы запустить Редактор реестра. Найдите раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax. Создайте параметр UseDeviceTsid (REG_DWORD), если он отсутствует. Установите значение параметра UseDeviceTsid равным 1 как показано на рисунке ниже.

2. Перезапустите Службу факсов Windows. Для этого в Панели управления Fax Voip FSP , из меню Файл выберите команду Перезапустить Службу факсов Windows.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... . В окне Параметры факса, на вкладке Общие, нажмите Дополнительные параметры... . В окне Дополнительные параметры, в поле ИД TSID, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите OK. В окне Параметры факса нажмите OK.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Исходящий факс. Не использовать код устройства передающего абонента (TSID).

Используя этот метод, вы можете переопределять Идентификатор факса (TSID) при создании факса.

1. Для использования этого метода следует установить значение параметра UseDeviceTsid равным 0 (нуль). Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Выполнить. Введите regedit; нажмите OK чтобы запустить Редактор реестра. Найдите раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax. Создайте параметр UseDeviceTsid (REG_DWORD), если он отсутствует. Установите значение параметра UseDeviceTsid равным 0 (нулю) как показано на рисунке ниже.

2. Перезапустите Службу факсов Windows. Для этого в Панели управления Fax Voip FSP , из меню Файл выберите команду Перезапустить Службу факсов Windows.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Входящий факс

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... . В окне Параметры факса, на вкладке Общие, нажмите Дополнительные параметры... . В окне Дополнительные параметры, в поле ИД CSID, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите OK.


Windows Server 2022

Чтобы задать идентификатор факса и заголовок факса в Windows Server 2022

Служба факсов Windows ›› Конфигурирование идентификатора и заголовка факса ››

Обратите внимание, что параметр Использовать код устройства передающего абонента (TSID) можно также настроить с помощью кнопки Переустановить компоненты Fax Voip FSP в Панели управления Fax Voip FSP , на вкладке Инструменты ленты, см. Регистрация провайдера службы факсов .

Исходящий факс. Использовать код устройства передающего абонента (TSID).

Этот метод не позволяет переопределять Идентификатор факса (TSID).

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Исходящие, поставьте флажок у параметра Использовать код устройства передающего абонента (TSID). Нажмите Применить.

3. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip Line 0. В контекстном меню, нажмите Свойства. На вкладке Общие, в поле Код передающего абонента (TSID), задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите Применить.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Исходящий факс. Не использовать код устройства передающего абонента (TSID).

Используя этот метод, вы можете переопределять Идентификатор факса (TSID) при создании факса.

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Исходящие, снимите флажок у параметра Использовать код устройства передающего абонента (TSID). Нажмите Применить.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Входящий факс

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip FSP в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip Line 0. В контекстном меню, нажмите Свойства. На вкладке Общие, в поле Код вызываемого абонента (CSID), задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите Применить.


Доступ к факсам другого пользователя

Служба факсов Windows ››

В этой главе объясняется, как под текущей учетной записью получить доступ к факсам, созданным другим пользователем. Например, администратор факс сервера хочет просматривать факсы, созданные другими пользователями, и управлять ими. Или какая-то служба, работающая под другой учетной записью, автоматически создает факсимильные задания, и вам необходимо иметь доступ к этим факсам, примером является функция Почта-на-факс из пакета Fax Voip FSP.

Запуск программы Факсы и сканирование Windows под другой учетной записью

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Командная строка.

2. В командной строке выполните следующую команду:

runas.exe /savecred /user:SERVER1\FaxUser %windir%\system32\WFS.exe

В нашем примере SERVER1\FaxUser - это локальная учетная запись пользователя (включая имя компьютера), к факсам которого мы хотим получить доступ.

3. При необходимости введите пароль для пользователя, указанного в командной строке, а затем нажмите ENTER. Параметр /savecred используется для сохранения учетных данных и позволяет избежать ввода пароля при последующих запусках.

Приложение Факсы и сканирование Windows будет запущено под указанной учетной записью, а не под учетной записью текущего пользователя.

Кроме того, вы можете создать ярлык, чтобы запускать Факсы и сканирование Windows. Параметр ярлыка Объект должен быть таким, как показано ниже:

C:\Windows\System32\runas.exe /savecred /user:SERVER1\FaxUser %windir%\system32\WFS.exe

Добавление учетной записи факса

Перед добавлением учетной записи факса, необходимо предоставить разрешение на Просмотр конфигурации службы на факс сервере для пользователя, от имени которого запущено приложение Факсы и сканирование Windows. Чтобы настроить разрешения, выполните следующие действия:

1. В Windows 11, в Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса..., а затем перейдите на вкладку Безопасность. В Windows Server 2022, в Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

2. На вкладке Безопасность, нажмите Дополнительно.

3. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения, связанную с желаемой учетной записью пользователя, и нажмите Изменить. Если запись разрешения отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

4. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажок Просмотр конфигурации службы. Нажмите OK. См. картинку ниже.

5. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.

Чтобы добавить учетную запись факса, выполните следующие действия:

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

2. Нажмите Подключиться к факс-модему и следуйте инструкциям.

Для отправки факса

Чтобы отправить факс от имени учетной записи другого пользователя, см. Отправка факса с использованием другой учетной записи .


Регистрация провайдера службы факсов

Регистрация Fax Voip провайдера для службы факсов Windows (FSP) со службой факсов

Служба факсов Windows ››

Fax Voip провайдер для службы факсов Windows (FSP) и Расширение маршрутизации Fax Voip FSP (отвечает за методы маршрутизации для входящих факсов ) должны быть зарегистрированы в операционной системе для работы со Службой факсов Windows. Чтобы вручную зарегистрировать Fax Voip FSP без переустановки программы, а также настроить Службу факсов Windows для отправки/получения факсов через устройства Fax Voip FSP, выполните следующие действия:

1. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

2. В Панели управления Fax Voip FSP, на вкладке Инструменты ленты, нажмите Переустановить компоненты Fax Voip FSP.

3. Подождите, пока программа не завершит необходимые действия. Служба факсов Windows может быть перезапущена несколько раз.

4. В окне Параметры службы факсов Windows вы можете указать необходимые параметры для настройки службы факсов с устройствами Fax Voip FSP.

На компьютере с Windows 11 следует выбрать единственное устройство Fax Voip Line, которое вы бы хотели использовать для отправки и получения факсов через службу факсов Windows.

На компьютере с Windows Server 2022, указанные вами параметры будут применены ко всем устройствам Fax Voip Line, которые в данный момент установлены в вашей системе.

Следующие параметры могут быть настроены:

Параметры отправки и получения

Разрешить отправку факсов

Укажите, следует ли использовать устройства Fax Voip FSP для отправки факсов.

Разрешить получение факсов

Укажите, следует ли использовать устройства Fax Voip FSP для приема факсов.

Автоматически отвечать после ... звонков

Число звонков на линии, после которых устройства Fax Voip FSP должны автоматически отвечать на входящий факс. Обратите внимание, что эта опция недоступна в текущей версии Fax Voip FSP.

Идентификация

Использовать код устройства передающего абонента (TSID)

Если эта опция включена, то при отправке исходящего факса получателю передается идентификатор факса (TSID, Transmitting Subscriber ID), указанный в настройках факс устройства, которое использовалось для передачи факса. Если эта опция выключена, передаваемый идентификатор факса совпадает с номером факса отправителя, который указан в Сведениях об отправителе. См. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

ИД TSID

Укажите Transmitting Subscriber Identification (Код передающего абонента, TSID). TSID - это текстовая строка, идентифицирующая данного пользователя как отправителя факса. Она передается получателю при отправке факса и может быть выведена на дисплей факс-аппарата получателя. Код TSID может содержать до 20 символов текста.

ИД CSID

Укажите Called Subscriber Identification (Код вызываемого абонента, CSID). CSID - это текстовая строка, идентифицирующая данного пользователя как получателя факса. Она возвращается отправителю при получении факса и может быть выведена на дисплей факс-аппарата отправителя. Код CSID может содержать до 20 символов текста.

5. В окне Параметры службы факсов Windows нажмите OK.

6. Подождите, пока программа не завершит все необходимые действия. Служба факсов Windows может быть перезапущена несколько раз.

7. Для просмотра лог-файла, в диалоговом окне нажмите Да.

Ниже приведен полный список действий, производимых при выполнении команды Переустановить компоненты Fax Voip FSP:

  • Остановка подсистемы почты (службы Fax Voip FSP Mail).
  • Остановка Службы факсов Windows и Службы Fax Voip FSP.
  • Переустановка Службы Fax Voip FSP.
  • Установка Службы факсов Windows, если она не установлена (все поддерживаемые операционные системы).
  • Установка компонента Возможности рабочего стола, если он не установлен (Windows Server 2012/2012R2 и Windows Server 2008R2).
  • Регистрация Fax Voip провайдера для службы факсов Windows (FSP) со службой факсов.
  • Регистрация Расширения маршрутизации Fax Voip FSP (отвечает за методы маршрутизации для входящих факсов ) со службой факсов.
  • Настройка разрешений безопасности для Службы факсов Windows.
  • Настройка автоматического запуска Службы факсов Windows при загрузке Windows.
  • Добавление Учетной записи факса с именем 'Fax Voip FSP', если учетная запись еще не создана.
  • Настройка разрешений безопасности для факс-сервера. Для работы системы интеллектуальной повторной передачи факса (при повторе после неудачи, начинать передачу факса с первой страницы, которая не была успешно передана) необходимо, чтобы служба Fax Voip FSP (запускается под учетной записью локальной системы) имела разрешение на Просмотр заданий для исходящих факсов на факс-сервере. Для обеспечения правильной работы методов маршрутизации для исходящих факсов , служба Fax Voip FSP (учетная запись локальной системы) должна иметь разрешения на Просмотр заданий для исходящих факсов и Просмотр архивов сообщений.
  • Настройка службы факсов для архивирования всех успешно отправленных факсов в папку Отправленные. Необходимо для обеспечения правильной работы методов маршрутизации для исходящих факсов .
  • Настройка доступа для чтения списка учетных записей факса (раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax\Accounts).
  • В Windows 11, Windows 10, Windows Server 2022, Windows Server 2019 и Windows Server 2016: Исправление ошибки в программе Факсы и сканирование Windows из-за которой кнопка 'Переслать по электронной почте' неактивна, в то время как e-mail клиент с поддержкой MAPI установлен в системе.
  • Создание ярлыка Факсы и сканирование на рабочем столе. В Windows 8 и более поздних версиях, создание ярлыка Факсы и сканирование в меню 'Пуск'. В ОС Windows Server, создание ярлыка Диспетчер службы факсов на рабочем столе и в меню 'Пуск'.
  • Переустановка факсимильных устройств Fax Voip Line. Настройка Кода передающего абонента (TSID) и Кода вызываемого абонента (CSID) для всех факсимильных устройств Fax Voip Line (по умолчанию 'Fax Voip FSP'). Настройка параметра Использовать код устройства передающего абонента (TSID), см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
  • В Windows 11, Windows 10, Windows 8/8.1 и Windows 7: настройка выбранного факсимильного устройства Fax Voip Line для отправки и/или приема факсов. По умолчанию разрешены как отправка, так и получение факсов.
  • В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2: настройка всех факсимильных устройств Fax Voip Line для отправки и/или приема факсов. По умолчанию разрешены как отправка, так и получение факсов.
  • В Windows 11, Windows 10, Windows 8/8.1 и Windows 7: включение монитора факсов и уведомлений о факсах для выбранного факсимильного устройства Fax Voip Line.
  • В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2: включение монитора факсов и уведомлений для первого факсимильного устройства Fax Voip Line.
  • Включение / выключение методов маршрутизации факса, определенных Расширением маршрутизации Fax Voip FSP для всех факсимильных устройств Fax Voip Line, в зависимости от текущих настроек.
  • Запуск Службы Fax Voip FSP и Службы факсов Windows.
  • Запуск подсистемы почты (службы Fax Voip FSP Mail).


Отправка и получение факсов

Fax Voip FSP использует Службу факсов Windows и приложение Факсы и сканирование Windows для отправки и получения факсов.

  • Отправка факсов
  • Получение факсов
  • Мониторинг и уведомления


Отправка факсов

Отправка и получение факсов ››

Факс можно отправить из приложения Windows, открыв или создав документ в этом приложении, а затем распечатав его на принтере факсов. Соответствующие инструкции см. в разделе Отправка факса из приложения Windows .

Чтобы отправить факс, используя команду меню иконки Fax Voip FSP в трее или из Панели управления Fax Voip FSP, обратитесь к разделу Отправка факса из Fax Voip FSP .

Чтобы задать Идентификатор факса и Заголовок факса, обратитесь к разделу Настройка сведений об отправителе .

Чтобы настроить качество изображения для отправляемых факсов, обратитесь к разделу Настройка качества изображения .

Чтобы отправить факс с помощью утилиты SendFax.exe, см. Утилита командной строки SendFax.exe . Более подробную информацию можно найти в главе Отправка факса с помощью утилиты SendFax.exe настоящего справочного руководства.

Чтобы отправить факс от имени учетной записи другого пользователя, обратитесь к разделу Отправка факса с использованием другой учетной записи .

Чтобы получить подробную информацию о том, как отслеживать ход отправки факсов, обратитесь к разделу Мониторинг и уведомления .


Отправка факса из приложения Windows

Отправка и получение факсов ›› Отправка факсов ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. Выберите в списке установленный принтер факсов и нажмите Печать.

3. В окне Новый факс, введите номер факса получателя в поле Кому.

4. В поле Титульный лист, опционально выберите титульный лист, который будет передан в качестве первой страницы факса.

5. В поле Правило набора, опционально выберите правило набора номера. Правила набора номера (TAPI) применяются при преобразовании номеров факсов, введенных в каноническом формате (например +7 (812) 346-7890). Обратите внимание, что выбор конкретного правила в этом поле может изменить местоположение вызова по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows. Дополнительные сведения об использовании правил набора см. в главах Набор номера (телефония Microsoft) и Общие сведения о правилах набора номера настоящего справочного руководства.

6. Опционально, введите соответствующую информацию в поля Тема и Примечания.

7. Опционально, настройте сведения об отправителе .

8. Для отправки факса нажмите Отправка.

Ваш компьютер автоматически наберет номер факса и будет отправлять факс.


Отправка факса из Fax Voip FSP

Отправка и получение факсов ›› Отправка факсов ››

1. Выберите команду Отправить факс из меню иконки Fax Voip FSP в системном трее. Либо нажмите Создать факс в Панели управления Fax Voip FSP , на ленте, на вкладке Главная.

2. В диалоговом окне Выбор факсимильного сообщения, выберите документ, который вы бы хотели отправить по факсу, затем нажмите Открыть. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

3. Следуйте инструкциям из предыдущего раздела .

Примечания

  • Вы также можете отправить факс, щелкнув правой кнопкой мыши по файлу в проводнике Windows и выбрав команду Получатель факса из подменю Отправить.


Настройка сведений об отправителе

Отправка и получение факсов ›› Отправка факсов ››

Приведенные ниже инструкции позволяют переопределить Идентификатор факса и Заголовок факса при отправке факса .

1. В окне Новый факс, в меню Сервис, нажмите Сведения об отправителе... .

2. Чтобы переопределить настройки по умолчанию, в окне Сведения об отправителе, поставьте флажок Сведения об отправителе.

3. В поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Обратие внимание, что вы можете переопределить Код TSID таким способом, только если опция Использовать код устройства передающего абонента (TSID) отключена, см. в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

4. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста.

5. Нажмите OK.


Настройка качества изображения

Отправка и получение факсов ›› Отправка факсов ››

Можно выбрать разрешение для отправляемых факсов. Различным уровням разрешения, выражаемым числом точек на дюйм, присваиваются обобщенные названия, например Обычное (200x200 точек/дюйм) или Черновое (200x100 точек/дюйм). Эти уровни разрешения не обязательно гарантируют ту же четкость, которую можно наблюдать при создании документа в приложении Windows. При просмотре факса перед отправкой изображение документа будет более четким.

Для установки параметров принтера факсов:

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование и звук, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Настройка печати. Кроме того, вы можете нажать Принтер факсов в Панели управления Fax Voip FSP , на ленте, на вкладке Главная, а затем нажать Настройка... .

2. В окне Настройка печати: Fax, выберите стандартное разрешение из списка Качество изображения.

Обратите внимание, что при создании и отправке факса из приложения Windows, приложение может использовать индивидуальные параметры, имеющие приоритет над глобальными параметрами настройки принтера. По этой причине мы рекомендуем вам проверить разрешение принтера непосредственно перед печатью.


Утилита командной строки SendFax.exe

Отправка и получение факсов ›› Отправка факсов ››

Вы можете отправить факс с помощью утилиты SendFax.exe, которая включена в программное обеспечение Fax Voip FSP и позволяет автоматически создавать факс, а затем отслеживать его, подробнее см. главу Отправка факса с помощью утилиты SendFax.exe настоящего справочного руководства.

Для получения подробных сведений о параметрах командной строки SendFax.exe, см. Параметры командной строки SendFax.exe .

Кроме того, в вашем распоряжении есть полезный визуальный инструмент, который позволяет легко настроить параметры командной строки, а затем запустить SendFax.exe непосредственно из Панели управления Fax Voip FSP, см. Настройка и запуск SendFax.exe из панели управления Fax Voip FSP .


Отправка факса с использованием другой учетной записи

Отправка и получение факсов ›› Отправка факсов ››

По умолчанию новый факс создается от имени текущего пользователя, который вошел в систему. В этой главе объясняется, как отправить факс, используя другую учетную запись факса. Например, это может быть полезно, когда несколько пользователей хотят совместно использовать одну учетную запись факса и иметь доступ к исходящим факсам, созданным любым из этих пользователей. В зависимости от учетной записи пользователя, который отправил факс, к исходящим факсам могут применяться различные действия, см. главу Методы маршрутизации для исходящих факсов настоящего справочного руководства.

Чтобы отправить факс из программы Факсы и сканирование Windows

1. Запустите приложение Факсы и сканирование Windows под учетной записью другого пользователя, см. Доступ к факсам другого пользователя .

2. На панели инструментов нажмите кнопку Создать факс, чтобы открыть диалоговое окно Новый факс.

3. В окне Новый факс, введите номер факса получателя в поле Кому.

4. В поле Титульный лист, опционально выберите титульный лист, который будет передан в качестве первой страницы факса.

5. Опционально, введите соответствующую информацию в поля Тема и Примечания.

6. Опционально, настройте сведения об отправителе .

7. Вы можете прикрепить документ к факсимильному сообщению с помощью кнопки Вложение файла на панели инструментов, вставить изображение в тело факса с помощью кнопки Вложить изображение, а таже вставить отсканированный документ с помощью кнопки Вложить отсканированный документ.

8. Для отправки факса нажмите Отправка.

Чтобы отправить факс из приложения Windows

Приложение Факсы и сканирование Windows должно быть заранее запущено под учетной записью другого пользователя, см. Доступ к факсам другого пользователя . Процедура аналогична описанной в главе Отправка факса из приложения Windows , однако по умолчанию при печати на принтер факсов, вы получите сообщение об ошибке, как показано на рисунке ниже.

В качестве обходного пути следует предоставить доступ на чтение к временной папке текущего пользователя для учетной записи пользователя, под которой запущено приложение Факсы и сканирование Windows. Чтобы настроить разрешения, выполните следующие действия:

1. В проводнике Windows, откройте папку, содержащую временную папку текущего пользователя. Временная папка (%temp%) для учетной записи текущего пользователя обычно C:\Users\<Account Name>\AppData\Local\Temp\.

2. Щелкните правой кнопкой мыши папку Temp. В контекстном меню, нажмите Свойства. В окне Свойства: Temp перейдите на вкладку Безопасность. Нажмите Изменить... .

3. В окне Разрешения для ... Temp, в списке Группы или пользователи, убедитесь, что присутствует запись, связанная с учетной записью пользователя, под которой запущено приложение Факсы и сканирование Windows. Если запись отсутствует, нажмите Добавить, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

4. В окне Разрешения для ... Temp, в списке Группы или пользователи, выберите запись, связанную с учетной записью пользователя, под которой запущено приложение Факсы и сканирование Windows. Предоставьте разрешение на Чтение для этой учетной записи, как показано на рисунке ниже. Нажмите Применить.

Чтобы отправить факс, выполните следующие действия:

1. Убедитесь, что приложение Факсы и сканирование Windows уже запущено под нужной учетной записью другого пользователя, см. Доступ к факсам другого пользователя . Не закрывайте главное окно приложения Факсы и сканирование Windows.

2. Следуйте инструкциям главы Отправка факса из приложения Windows .

Новый факс будет создан от имени учетной записи пользователя, под которой запущено приложение Факсы и сканирование Windows, а не под учетной записью текущего пользователя.


Получение факсов

Отправка и получение факсов ››

Если вы сконфигурировали Службу факсов Windows автоматически получать факсы, ваш компьютер будет автоматически отвечать на входящие вызовы и сохранять полученные факсы в приложении Факсы и сканирование Windows.

Для просмотра принятых факсов

1. Выберите команду Факсы и сканирование Windows из меню иконки Fax Voip FSP в системном трее или нажмите Факсы и сканирование Windows в Панели управления Fax Voip FSP , на вкладке Главная ленты.

2. В левой панели, выберите Входящие для просмотра принятых факсов.

Примечания

  • Обратите внимание, что Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации.


Мониторинг и уведомления

Отправка и получение факсов ››

В уведомлениях о факсах сообщается о различных аспектах работы службы факсов, например, о ходе передачи входящих и исходящих факсов, а также об исходе отправки или приема факса - успех или неудача. Уведомления бывают двух категорий:

  • Визуальные уведомления. Включают значок в области уведомлений, выноску с сообщением рядом со значком и монитор факсов.
  • Звуковые уведомления. Оповещения о событиях факса с помощью звукового сигнала.

Монитор факсов

Монитор факсов показывает информацию о ходе процесса отправки или приема факса через локальное факсимильное устройство.

Вы можете настроить Монитор факсов для показа следующих визуальных уведомлений:

  • Отображать ход приема или отправки факса.
  • Сообщать об успехах и сбоях при отправке и приеме факсов.

Также можно настроить звуковые уведомления о следующих событиях:

  • звонок на линии факса
  • получен новый факс
  • факс отправлен
  • в факсе обнаружена ошибка

Если Монитор факсов открыт, вы можете вручную прервать отправку или прием факса, нажав кнопку Прервать.

Монитор факсов отображает информацию о ходе процесса отправки или приема факса, включая следующие сведения:

  • Состояние. Текущее состояние исходящего или входящего факса.
  • Истекшее время. Время, прошедшее с момента инициирования приема или передачи факса.
  • Кому/От кого. Данные об отправителе или получателе.

Установка параметров уведомлений в Windows 11

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... .

2. На вкладке Отслеживание, сконфигурируйте необходимые параметры, как показано на рисунке ниже.

3. Нажмите Параметры звуковых уведомлений... . Сконфигурируйте необходимые параметры, как показано на рисунке ниже. Нажмите OK.

4. В окне Параметры факса нажмите Применить.

Установка параметров уведомлений в Windows Server 2022

Обратите внимание, что на компьютере с операционной системой Windows Server уведомления о факсах могут быть включены только для одного выбранного факсимильного устройства.

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование и звук, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Свойства принтера. Кроме того, вы можете воспользоваться командой Принтер факсов в Панели управления Fax Voip FSP , на ленте, на вкладке Главная.

2. На вкладке Отслеживание, выберите факсимильное устройство, для которого нужно настроить параметры отслеживания и уведомления. Сконфигурируйте необходимые параметры, как показано на рисунке ниже.

3. Нажмите Настройка звуковых уведомлений... . Сконфигурируйте необходимые параметры, как показано на рисунке ниже. Нажмите OK.

4. В окне Свойства: Fax нажмите Применить.


Caller ID и номер вызываемого абонента (DID)

Caller ID, известный также как Caller Identification (CID), является услугой телефонного обслуживания, она передает номер вызывающего абонента на телефонное оборудование вызываемого абонента вместе с сигналом вызова, или на этапе инициализации вызова, но перед тем как вызов отвечен. Caller ID Number позволяет получать номер телефона, а Caller ID Name позволяет видеть имя и/или фамилию абонента или название организации, где зарегистрирован телефонный номер. Информация Caller ID, передаваемая вызываемому абоненту, может отображаться на собственном дисплее телефона, или на дисплее отдельного прилагаемого оборудования. Эта информация обычно посылается один раз между первым и вторым сигналами вызова. Модем может декодировать эту информацию о вызывающем абоненте и отображать ее на мониторе компьютера. В зависимости от используемого программного обеспечения, Caller Id может использоваться с различными функциями, такими как "Черный и Белый список".

Номер вызываемого абонента - это телефонный номер человека, который (или устройства, которое) отвечает на телефонный вызов. Direct inward dialing (DID) представляет собой телекоммуникационную услугу, которая обеспечивает обслуживание нескольких телефонных номеров по одной или нескольким телефонным линиям и передает набранный телефонный номер на целевое телефонное устройство. Услуга DID широко используется факс-серверами. Маршрут входящего вызова завершается на телефонном интерфейсе компьютера (факс-модем), на котором запущено программное обеспечение факс-сервера. Последовательность цифр телефонного номера используется для идентификации получателя факса. Это позволяет каждому получателю иметь индивидуальный номер факса, хотя физически доступно только одно факсимильное устройство.


Получение Caller ID и DID

Caller ID и номер вызываемого абонента (DID) ››

Функция Caller ID поддерживается приложением Fax Voip FSP по умолчанию. Дополнительные настройки не требуются. Caller ID Number отображается в приложении Факсы и сканирование Windows, в Мониторе факсов, во время входящего вызова. См. также в главе Мониторинг и уведомления настоящего справочного руководства.

В приложении Факсы и сканирование Windows, Caller ID Number сохраняется в поле Код звонящего. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации. Это используется в методах маршрутизации для входящих факсов , а также может использоваться разработчиками программного обеспечения при доступе к входящим факсам через функции Fax Service API.

Примечания

  • Передача правильного Caller ID Number не всегда возможна через VoIP сети.
  • Приложение Факсы и сканирование Windows не поддерживает отображение Caller ID Name во время входящего вызова.


Передача Caller ID (SIP)

Caller ID и номер вызываемого абонента (DID) ››

При конфигурировании исходящих SIP вызовов, следует принять во внимание следующую информацию:

  • Если Имя пользователя SIP (SIP-ID), используемое для вызова, состоит только из цифр, оно будет передано на оборудование вызываемого абонента как Caller ID Number.
  • Отображаемое имя, используемое для вызова, передается на оборудование вызываемого абонента как Caller ID Name.

Чтобы задать Отображаемое имя и Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония.

3. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

4. В поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Все изменения вступают в силу немедленно.

Отображаемое имя и Имя пользователя по умолчанию могут быть переопределены через параметры Отображаемое имя SIP и Имя пользователя SIP.

Чтобы задать Отображаемое имя SIP и Имя пользователя SIP, иные чем Отображаемое имя и Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите SIP.

3. Выключите опцию Использовать отображаемое имя по умолчанию.

4. В поле Отображаемое имя SIP введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

5. Выключите опцию Использовать имя пользователя по умолчанию.

6. В поле Имя пользователя SIP введите ваш номер телефона, который будет передаваться как Caller ID Number.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Все изменения вступают в силу немедленно.

Имя пользователя SIP может быть переопределено при использовании Учетной записи SIP (SIP регистрация) и в настройках Маршрутизации исходящих VOIP вызовов. Отображаемое имя SIP может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Чтобы переопределить Имя пользователя SIP и Отображаемое имя SIP в параметрах правила Маршрутизации исходящих VOIP вызовов, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number. Чтобы иметь возможность изменить Имя пользователя, опция По умолчанию должна быть выключена. Заметим, что если вызов маршрутизируется на SIP сервер, используемый для осуществления SIP регистрации, то Имя пользователя не может быть задано произвольным образом и должно соответствовать Имени пользователя (или SIP-ID), заданному в одной из Учетных записей SIP в Списке учетных записей SIP.

5. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name. Чтобы иметь возможность изменить Отображаемое имя, опция По умолчанию должна быть выключена.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Все изменения вступают в силу немедленно.

Примечания

  • Передача правильного Caller ID Number не всегда возможна через VoIP сети. По этой причине, иногда удобно вводить телефонный номер в поле Отображаемое имя. Это обеспечивает возможность передачи вашего номера как Caller ID Name вместо Caller ID Number.


Передача Caller ID (H.323)

Caller ID и номер вызываемого абонента (DID) ››

При конфигурировании исходящих H.323 вызовов, следует принять во внимание следующую информацию:

  • По умолчанию, Fax Voip FSP использует верхний номер из списка Номера телефонов H.323 для передачи его на оборудование вызываемого абонента как Caller ID Number.
  • Отображаемое имя, используемое для вызова, передается на оборудование вызываемого абонента как Caller ID Name.

Чтобы задать Отображаемое имя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония.

3. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

4. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Все изменения вступают в силу немедленно.

Отображаемое имя по умолчанию может быть переопределено через параметр Отображаемое имя H.323.

Чтобы задать Отображаемое имя H.323, иное чем Отображаемое имя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите H.323.

3. Выключите опцию Использовать отображаемое имя по умолчанию.

4. В поле Отображаемое имя H.323 введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Все изменения вступают в силу немедленно.

Что касается списка Номера телефонов H.323, вы должны понимать следующее:

  • Если H.323 ID состоит только из цифр, Fax Voip FSP автоматически добавляет его в список телефонных номеров.
  • Если вы используете регистрацию с H.323 гейткипером, и при этом используется H.235 аутентификация и H.235 логин состоит только из цифр, Fax Voip FSP автоматически добавляет H.235 логин в список телефонных номеров.
  • Любой другой телефонный номер может быть добавлен в список. Телефонные номера, заданные в этом списке, используются в процессе регистрации с H.323 гейткипером, т.е. это список телефонных номеров, на которые возможны входящие вызовы.
  • По умолчанию, Fax Voip FSP использует верхний номер из списка Номера телефонов H.323 для передачи его на оборудование вызываемого абонента как Caller ID Number.

Чтобы добавить новый номер в список Номера телефонов и использовать его в качестве Caller ID Number по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите H.323.

3. Для добавления нового телефонного номера нажмите кнопку <Добавить>.

4. В окне Номер телефона введите добавляемый номер и нажмите <OK>.

5. Используйте кнопку <Вверх> чтобы передвинуть добавленный номер в верхнюю позицию списка Номера телефонов.

6. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Все изменения вступают в силу немедленно.

Caller ID Number и Caller ID Name (Отображаемое имя H.323), заданные по умолчанию, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов.

Чтобы переопределить Caller ID Number и Caller ID Name в параметрах правила Маршрутизации исходящих VOIP вызовов, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number. Чтобы иметь возможность изменить Имя пользователя, опция По умолчанию должна быть выключена.

5. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name. Чтобы иметь возможность изменить Отображаемое имя, опция По умолчанию должна быть выключена.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Все изменения вступают в силу немедленно.

Примечания

  • Передача правильного Caller ID Number не всегда возможна через VoIP сети. По этой причине, иногда удобно вводить телефонный номер в поле Отображаемое имя. Это обеспечивает возможность передачи вашего номера как Caller ID Name вместо Caller ID Number.


Примеры настройки с операторами VoIP

При отправке и приеме факсов через VoIP, настоятельно рекомендуется воспользоваться услугами тех операторов IP-телефонии, которые предоставляют поддержку T.38. Протокол T.38 - наиболее надежный протокол передачи факсов через VoIP в режиме реального времени. Компенсирует задержки и потери пакетов характерные для VoIP.

Ниже приведены примеры VoIP (SIP) операторов, которые поддерживают T.38:

  • Настройка c YouMagic (МТТ)
  • Настройка с Телфин

Fax Voip FSP также поддерживает отправку/прием факсов по аудио каналу (факс поверх кодека G.711). Это может быть полезно при работе с VoIP операторами, которые не поддерживают T.38, но при этом обеспечивают достойное качество голосового канала. См. примеры ниже:

  • Настройка с Мультифон (Мегафон)
  • Настройка с Dellmont (Betamax)


Youmagic.com (МТТ)

Настройка Fax Voip FSP c оператором YouMagic (проект МТТ)

Примеры настройки с операторами VoIP ››

Youmagic.com – SIP проект оператора связи МТТ (ОАО «Межрегиональный Транзит Телеком»). Из характерных особенностей: качественная поддержка T.38, предоставление городских телефонных номеров в Москве и некоторых других городах. Получить учетную запись можно, зарегистрировавшись на веб-сайте оператора .

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): номер телефона, предоставленный оператором

Пароль: пароль

Сервер регистрации: voip.mtt.ru

Настройка маршрутизации исходящих вызовов

На вкладке Общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: voip.mtt.ru

Имя пользователя: номер телефона, предоставленный оператором

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.


Телфин

Настройка Fax Voip FSP c оператором Телфин

Примеры настройки с операторами VoIP ››

Telphin.ru – SIP оператор, поддерживающий передачу факсов по протоколу T.38. Получить учетную запись можно, зарегистрировавшись на веб-сайте оператора . Данному оператору также принадлежит проект telMe .

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): SIP-ID, предоставленный оператором

Пароль: пароль

Сервер регистрации: sip.telphin.com:5068

Прокси-сервер: voice.telphin.com:5068

Настройка маршрутизации исходящих вызовов

На вкладке Общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: sip.telphin.com:5068

Прокси-сервер: voice.telphin.com:5068

Имя пользователя: SIP-ID, предоставленный оператором

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.


Мультифон (Мегафон)

Настройка Fax Voip FSP c оператором Мультифон (проект Мегафон)

Примеры настройки с операторами VoIP ››

Мультифон – SIP проект оператора мобильной связи Мегафон . Из характерных особенностей: передача факса поверх кодека G.711, поддержка схемы Tel URI для исходящих SIP вызовов, поддержка не только SIP через UDP, но и SIP через TCP. Для регистрации необходимо являться абонентом Мегафон , скачать приложение Мультифон и произвести регистрацию с его помощью. Полученную учетную запись можно затем использовать в программе Fax Voip FSP для передачи факсов.

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): номер вашего мобильного телефона

Пароль: пароль

Сервер регистрации: multifon.ru

Настройка маршрутизации исходящих вызовов

На вкладке Общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: multifon.ru

Имя пользователя: номер вашего мобильного телефона

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Опцию T.38 факс желательно отключить.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Опцию T.38 факс желательно отключить.

Для установки переадресации вызовов на SIP клиент (Fax Voip), можно использовать http-запрос следующего вида:

https://sm.megafon.ru/sm/client/routing/set?login=<login>&password=<password>&routing=<routing>

routing

Режим приёма входящих вызовов:
0 – только на мобильный
1 – только SIP (в программный или аппаратный SIP- телефон)
2 – параллельный вызов


DellMont (Betamax)

Настройка Fax Voip FSP c операторами DellMont (Betamax)

Примеры настройки с операторами VoIP ››

Существует огромное количество SIP провайдеров, которые ассоциируются с компанией DellMont (Betamax) , например VoipBuster . Операторы этой группы не поддерживают протокол T.38. Качество передачи факса поверх кодека G.711 сильно зависит от страны, куда посылается факс. При звонках в Европу качество очень хорошее, при звонках в Россию качество в целом удовлетворительное. Для регистрации необходимо посетить веб-сайт одного из провайдеров данной группы. Тарифы на разных сайтах могут отличаться. Список провайдеров приведен ниже.

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): имя пользователя, полученное при регистрации

Пароль: пароль, полученный при регистрации

Сервер регистрации: sip.voipbuster.com (подходит для любого из провайдеров этой группы)

Настройка маршрутизации исходящих вызовов

На вкладке Общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: sip.voipbuster.com

Имя пользователя: имя пользователя, полученное при регистрации

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Опцию T.38 факс желательно отключить.

Набираемый номер вводится в формате 00<код_страны><код_города><номер_телефона>.

Список провайдеров DellMont (Betamax)

        • Nonoh
        • 12Voip
        • Free Call
        • InternetCalls.com
        • JustVoip
        • VoipCheap.com
        • VoipCheap.co.uk
        • Low-rate Voip
        • NetAppel
        • PoivY
        • Sip Discount
        • VoipBuster
        • VoipRaider
        • VoipDiscount
        • VoipStunt
        • WebCall Direct
        • SMS Discount
        • SMSListo
        • VoipWise
        • Voice Trading
        • InterVoip.com
        • DialNow
        • VoipBusterPro
        • CallEasy.com
        • VoipZoom
        • ActionVoip
        • VoipBlast.com
        • Jumblo
        • VoipGain
        • Telbo
        • Rynga.com
        • PowerVoip.com
        • CheapVoip
        • BestVOIPReselling
        • CallingCredit.Com


Лицензии

  • Виды лицензий
  • Просмотр текущей лицензии
  • Покупка лицензии
  • Добавление/изменение лицензии
  • Обновление Fax Voip FSP до версии 4
  • Политика лицензионной поддержки
  • Часто задаваемые вопросы (FAQ)


Виды лицензий

Лицензии ››

В настоящее время для Fax Voip FSP предлагаются следующие лицензии:

Лицензия Fax Voip провайдер службы факсов Windows: T.38 / G.711 линии факса (версия 4)

В зависимости от приобретенной лицензии, вы можете одновременно использовать одно или более* факсимильных устройств Fax Voip Line. Данный тип лицензии позволяет:

  • Отправлять T.38 и аудио (поверх кодека G.711) факсы через SIP и H.323 сети IP-телефонии с использованием Службы факсов Windows и приложения Факсы и сканирование Windows.
  • Принимать T.38 и аудио (поверх кодека G.711) факсы через SIP и H.323 сети IP-телефонии с использованием Службы факсов Windows и приложения Факсы и сканирование Windows.
  • Использовать функцию Почта-на-факс . Титульные страницы , правила для почты , шаблоны электронной почты .
  • Использовать базовую маршрутизацию для входящих факсов (Расширение маршрутизации Fax Voip FSP): Отправить по электронной почте , Сохранить в папке , Печать с ограниченным количеством правил.
  • Использовать пользовательскую маршрутизацию входящих факсов (Расширение маршрутизации Fax Voip FSP).
  • Использовать базовую маршрутизацию для исходящих факсов : Уведомления о доставке по электронной почте , Сохранить в папке , Печать с ограниченным количеством правил.
  • Использовать пользовательскую маршрутизацию исходящих факсов .
  • Использовать утилиту командной строки SendFax.exe для отправки факсов.

Лицензия Fax Voip FSP расширенная маршрутизация факсов: E-mail, Сохранить в папке, Печать (версия 4)

Чтобы использовать данную лицензию, вам необходимо также приобрести и установить лицензию Fax Voip провайдер службы факсов Windows: линии факса. Эта лицензия позволяет существенно увеличить максимальное количество правил, которые разрешено использовать со следующими методами маршрутизации для входящих факсов и методами маршрутизации для исходящих факсов :

  • Отправить по электронной почте (Маршрутизация входящих факсов, Расширение маршрутизации Fax Voip FSP)
  • Сохранить в папке (Маршрутизация входящих факсов, Расширение маршрутизации Fax Voip FSP)
  • Печать (Маршрутизация входящих факсов, Расширение маршрутизации Fax Voip FSP)
  • Уведомления о доставке по электронной почте (Маршрутизация исходящих факсов)
  • Сохранить в папке (Маршрутизация исходящих факсов)
  • Печать (Маршрутизация исходящих факсов)

Примечания

  • (* : Будьте внимательны при покупке многолинейных лицензий. Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем.


Просмотр текущей лицензии

Лицензии ››

1. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

2. Для просмотра текущего состояния лицензии, в дереве Панели управления Fax Voip FSP нажмите О программе.

3. Для просмотра подробной информации о текущих лицензиях, в дереве Панели управления Fax Voip FSP нажмите Лицензия. Вкладка Лицензии содержит информацию о числе факсимильных устройств Fax Voip Line, лицензированных на вашем компьютере. Также отображается информация о максимальном количестве доступных правил для методов маршрутизации факсов.


Покупка лицензии

Лицензии ››

1. Чтобы купить лицензию Fax Voip FSP, следует посетить веб-сайт программы:

https://www.t38faxvoip.ru/fsp/buy.htm

2. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

3. В дереве Панели управления Fax Voip FSP нажмите Лицензия, затем нажмите кнопку Купить.

4. Если вы не смогли найти требуемой лицензии среди предлагаемых вариантов, например, желаете приобрести не стандартное количество линий Fax Voip FSP или правил расширенной маршрутизации факсов, пожалуйста свяжитесь с нашим отделом продаж ( sales@t38faxvoip.ru ) и обсудите детали вашей будущей лицензии. Заметим, что лицензия Расширенная маршрутизация факсов должна приобретаться отдельно.

5. После осуществления платежа, в дереве Панели управления Fax Voip FSP нажмите Лицензия, затем нажмите Регистрация.

6. В окне Лицензия Fax Voip FSP, в области Для получения лицензионного ключа, отображается уникальный для вашего компьютера идентификатор системы, так называемый System ID. Эта информация необходима для того, чтобы сгенерировать ваш лицензионный ключ. Вам следует выделить ваш SystemID, копировать и вставить ваш SystemID в ваш документ (e-mail). Следует также предоставить информацию, подтверждающую оплату программы. Письмо следует отправить на наш адрес электронной почты sales@t38faxvoip.ru .

7. Как правило, по зачислению оплаты за лицензию, мы сами отправляем вам письмо с предложением прислать ваш System ID. При оплате продукта следует указывать действительный адрес электронной почты, чтобы было возможно связаться с вами.

Примечания

  • Ваш SystemID зависит от оборудования вашего компьютера. Если Вы планируете делать какие-либо изменения с оборудованием, пожалуйста сделайте это перед получением Лицензионного Ключа.
  • Если у вас уже имеются ранее купленные лицензии и вы бы хотели увеличить число линий Fax Voip FSP или правил расширенной маршрутизации факсов на вашем компьютере, пожалуйста обеспечьте нас необходимой информацией о вашей действующей лицензии. Изменение типа Лицензии потребует замены Лицензионного Ключа.
  • В случае одновременной покупки лицензии Fax Voip провайдер службы факсов Windows: линии факса и лицензии Расширенная маршрутизация факсов, в вашем e-mail содержащем SystemID, пожалуйста укажите, что обе лицензии предназначаются для одного и того же компьютера.
  • Если у вас уже имеется ранее купленная лицензия Fax Voip провайдер службы факсов Windows: линии факса и вы желаете добавить лицензию Расширенная маршрутизация факсов, чтобы увеличить число правил маршрутизации факсов на вашем компьютере, пожалуйста обеспечьте нас необходимой информацией о вашей действующей лицензии Fax Voip провайдер службы факсов Windows: линии факса. Добавление лицензии Расширенная маршрутизация факсов потребует замены Лицензионного Ключа.


Добавление/изменение лицензии

Лицензии ››

1. Чтобы Добавить новую лицензию или заменить ваш Лицензионный ключ, в дереве Панели управления Fax Voip FSP нажмите Лицензия, затем нажмите кнопку Регистрация.

2. Скопируйте Лицензионную информацию из сообщения e-mail и вставьте ее в текстовое поле Лицензионная информация в области Для активации лицензионного ключа в окне Лицензия Fax Voip FSP. Первое число указывает на количество лицензируемых факсимильных устройств Fax Voip Line, третье – на количество правил Расширенной маршрутизации факсов, второе является нулем и зарезервировано для будущего использования.

3. Скопируйте Лицензионный ключ из сообщения e-mail и вставьте его в текстовое поле Лицензионный ключ в области Для активации лицензионного ключа в окне Лицензия Fax Voip FSP.

4. Нажмите кнопку Обновить. Для активации Лицензионного ключа требуются права администратора.

5. Подождите, пока Fax Voip FSP настроит устройства Fax Voip Line и перезапустит службы.

6. В области системного трея нажмите на сообщение Лицензия активирована. Перезапустите Диспетчер Fax Voip FSP, нажав на ярлык Fax Voip FSP на рабочем столе или любым другим способом.

7. Откройте Панель управления Fax Voip FSP, дважды щелкнув иконку Fax Voip FSP в системном трее. В дереве Панели управления Fax Voip FSP нажмите О программе для проверки состояния лицензии.

8. Для просмотра подробной информации о лицензии, в дереве Панели управления Fax Voip FSP нажмите Лицензия.

Примечания

  • Пожалуйста сохраните ваш SystemID и сообщение электронной почты, содержащее Лицензионный ключ.
  • Лицензионный ключ проверяется, перед тем как он будет сохранен в реестре Windows. Таким образом, возможность случайного ввода недействительного лицензионного ключа исключена.
  • Чтобы удалить лицензионный ключ, нажмите кнопку Удалить. Требуются права администратора.


Обновление Fax Voip FSP до версии 4

Лицензии ››

Если вы используете старую версию Fax Voip FSP (версия 3 или более ранняя), вы можете обновить Fax Voip FSP до версии 4 со скидкой. Опция Обновить Fax Voip FSP до версии 4 доступна только для компьютера, на котором Fax Voip FSP был лицензирован ранее.

Для обновления вашей текущей лицензии, выполните следующие шаги:

1. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

2. В дереве Панели управления Fax Voip FSP нажмите Лицензия.

3. В списке Лицензии должны отображаться все лицензии, действительные для предыдущих версий Fax Voip FSP. Кнопка <Апгрейд> должна быть видима и доступна. Если по каким-либо причинам вы не видите ваших старых лицензий, пожалуйста свяжитесь с нашим отделом продаж .

4. Нажмите кнопку <Апгрейд>. Вы будете перенаправлены на страницу оплаты, где вы сможете заплатить за обновление вашей текущей лицензии до лицензии 4-й версии.

5. После осуществления платежа, в дереве Панели управления Fax Voip FSP нажмите Лицензия, затем нажмите Регистрация.

6. В окне Лицензия Fax Voip FSP, в области Для обновления лицензии, нажмите на ссылку Нажмите, чтобы показать проверочные коды. Для выполнения этого действия требуются права администратора.

7. Скопируйте и вставьте следующую информацию в ваш документ (e-mail):

        • SystemID (заканчивается -FP4)
        • Проверочный код #1 (заканчивается -FP41)
        • Проверочный код #2 (заканчивается -FP42, только если отображен)

SystemID требуется для генерации лицензионного ключа. Проверочные коды необходимы для проверки того, что Fax Voip FSP действительно установлен на компьютере, для которого вам выдавалась действительная лицензия для предыдущих версий Fax Voip FSP.

8. E-mail, содержащий SystemID и Проверочные коды, следует отправить на наш адрес электронной почты sales@t38faxvoip.ru .

9. После получения нового лицензионного ключа, следуйте инструкциям главы Добавление/изменение лицензии настоящего справочного руководства.

Примечания

  • При обновлении Fax Voip FSP до версии 4, ваш жесткий диск проверяется, чтобы убедиться, что вы являетесь лицензированным пользователем программного продукта Fax Voip FSP. Наличие пробных версий Fax Voip FSP не является подтверждением на право использования продукта. Вы не сможете установить обновление Fax Voip FSP до версии 4, если на вашем компьютере отсутствует установленная ранее действительная лицензия Fax Voip FSP.
  • Вы можете обновить только существующую лицензию (такое же количество факсимильных устройств Fax Voip Line и правил для методов маршрутизации факсов). Если вы хотите приобрести дополнительные факсимильные устройства Fax Voip Line или правила для методов маршрутизации факсов, вы должны приобрести соответствующие лицензии отдельно.
  • Обновление лицензии не предполагает перенос лицензии на другой компьютер и осуществляется на компьютере, для которого Fax Voip FSP был лицензирован ранее.
  • Размер скидки, предоставляемый в случае обновления лицензии, зависит от текущей политики Fax Voip Software и может изменяться.
  • По любым вопросам касательно права обновления или требований к обновлению, пожалуйста отправьте сообщение e-mail в наш отдел продаж .


Политика лицензионной поддержки

Лицензии ››

Срок лицензионной поддержки устанавливается один календарный год со дня приобретения лицензии.

  • Лицензионный ключ привязан к единственному компьютеру и генерируется на основе уникального для вашего компьютера идентификатора системы System ID. По умолчанию генерируется постоянный лицензионный ключ, не ограниченный во времени.
  • Бесплатная замена лицензионного ключа (генерация нового ключа для другого System ID) при замене или изменении аппаратной части компьютера, переустановке операционной системы и т.п. возможна в течении срока лицензионной поддержки (1 год). По умолчанию, интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. В любом случае, бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз.
  • При бесплатной замене лицензионного ключа, предыдущий лицензионный ключ (System ID) блокируется и добавляется в черный список. Таким образом, вы не сможете когда-либо использовать Fax Voip FSP на вашем старом компьютере после такой замены лицензионного ключа.
  • Пользователь лицензионной версии программы имеет право на платное продление срока лицензионной поддержки. Стоимость продления срока лицензионной поддержки на один год устанавливается в размере 30% от текущей стоимости вашей лицензии на момент продления.
  • По любым вопросам, касающихся лицензионной поддержки, пожалуйста свяжитесь с нашим отделом продаж по электронной почте.


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Лицензии ››

Я хочу купить Fax Voip FSP. Как я могу сделать это?

Пожалуйста посетите страницу оплаты программы на нашем веб-сайте . Выберите лицензию которую вы бы хотели приобрести и нажмите Купить. Следуйте инструкциям платежной системы. Если вы российская организация, и для бухгалтерского учета вам требуются документы установленного образца (счет-фактура, торг-12), рекомендуем осуществлять покупку через одного из наших представителей в РФ, например allsoft.ru .

Я собираюсь приобрести Fax Voip FSP. Fax Voip FSP установлен на компьютере с Windows 11 (Windows 10, Windows 8/8.1, Windows 7). Какую лицензию мне купить?

Подробное описание лицензий можно найти в главе Виды лицензий настоящего справочного руководства, а также на странице оплаты программы на нашем веб-сайте . Для вашей операционной системы вам определенно нужна следующая лицензия: Лицензия Fax Voip провайдер службы факсов Windows 1 линия (T.38 и аудио факс, SIP, H.323). Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 и Windows 7, вы можете использовать одно факсимильное устройство.

Я собираюсь приобрести Fax Voip FSP. Я хочу использовать несколько линий факса одновременно. Каковы требования к системе?

Чтобы использовать несколько линий Fax Voip FSP, вам необходимо установить Fax Voip FSP на компьютер с операционной системой Windows Server. Максимально возможное количество факсимильных устройств, которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, Enterprise или Datacenter Edition, ограничение на количество факсимильных устройств отсутствует. В других версиях Windows 2008R2, максимально допустимое число факсимильных устройств обычно равно четырем.

Какую лицензию предоставляет пробная версия?

Fax Voip FSP ТРИАЛ работает следующим образом:

Лицензия Fax Voip провайдер службы факсов Windows

2 линии

(T.38 и аудио факс, SIP, H.323)

но в течении ограниченного пробного периода времени 15 дней.

Обратите внимание, что в Windows 11, Windows 10, Windows 8/8.1 и Windows 7 вы можете использовать только одну линию факса.

Я бы хотел купить лицензию "Fax Voip провайдер службы факсов Windows 9 линий (T.38 и аудио факс, SIP, H.323)", но не вижу такой лицензии на странице оплаты... Как мне купить ее?

Мы можем продать любое количество линий Fax Voip FSP. Если вы не видите требуемой лицензии на странице оплаты программы на нашем веб-сайте , пожалуйста свяжитесь с нашим отделом продаж и мы вышлем вам необходимую ссылку на оплату требуемой лицензии.

Я оплатил лицензию. Где мой лицензионный ключ?...

Как упомянуто в главе Покупка лицензии настоящего справочного руководства, после осуществления платежа вам следует отправить ваш SystemID в наш отдел продаж . Ваш SystemID необходим для того, чтобы сгенерировать ваш лицензионный ключ. Как правило, по зачислению оплаты за лицензию, мы сами отправляем вам письмо с предложением прислать ваш System ID. При оплате продукта следует указывать действительный адрес электронной почты, чтобы было возможно связаться с вами. Обычно мы пытаемся связаться с вами в течении нескольких часов после получения денег от вас (но не позднее 48 часов, согласно требованиям платежной системы).

Я уже приобрел лицензию “Fax Voip провайдер службы факсов Windows 2 линии (T.38 и аудио факс, SIP, H.323)”. Мы бы хотели добавить 2 линии к нашей лицензии, чтобы иметь “Fax Voip провайдер службы факсов 4 линии (T.38 и аудио факс, SIP, H.323)”. Что я должен делать?

Пожалуйста посетите наш веб-сайт . Чтобы добавить 2 линии, вы должны оплатить лицензию Fax Voip провайдер службы факсов Windows 2 линии (T.38 и аудио факс, SIP, H.323), а затем связаться с нашим отделом продаж . Мы заменим ваш текущий лицензионный ключ новым ключом (предполагается тот же компьютер) “Fax Voip провайдер службы факсов 4 линии (T.38 и аудио факс, SIP, H.323)”. Если вы не видите на странице оплаты требуемой лицензии, которую вы хотели бы добавить, свяжитесь с нашим отделом продаж и мы вышлем вам необходимую ссылку на оплату требуемой лицензии. Обратите внимание, что в этом случае вы оплачиваете полную стоимость добавляемой лицензии, а не разницу в стоимости между двумя лицензиями.

Я оплатил лицензию, пожалуйста вышлите мне мой лицензионный ключ. Я установил Fax Voip FSP на временный сервер, на следующей неделе я установлю Fax Voip FSP на новый сервер. (В следующем месяце, году, я собираюсь покупать новый компьютер или буду менять мой жесткий диск...) Могу ли я просить другой лицензионный ключ позже?

Чтобы было возможно попросить другой лицензионный ключ позже, вы можете попросить временный лицензионный ключ (с датой окончания лицензии). В этом случае вы сможете попросить другой лицензионный ключ (даже для другого компьютера) ближе к концу срока действия текущего ключа. Если вы хотите получить временный лицензионный ключ вместо постоянного, следует попросить нас об этом до получения лицензионного ключа. По умолчанию, мы высылаем вам постоянный лицензионный ключ, привязанный к единственному SystemID.

Что произойдет с моей лицензией, если я переустановлю Fax Voip FSP? Что произойдет с моей лицензией, если я переустановлю Windows? Могу ли я просить новый лицензионный ключ?

При удалении и переустановке Fax Voip FSP, ваш лицензионный ключ сохраняется в системном реестре Windows. Не нужно вводить его повторно.

Лицензия привязана к единственному компьютеру (SystemID). При использовании нормального аппаратного компьютера, SystemID зависит только от вашего оборудования и не зависит от версии операционной системы Windows или от конкретной установки. После переустановки Windows, вы обычно можете использовать ваш лицензионный ключ без каких-либо проблем. В этом случае, вы должны повторно ввести лицензионный ключ согласно стандартным инструкциям. При использовании Виртуальной машины, SystemID не сохраняется ввиду отсутствия оборудования как такового. Вам следует устанавливать Fax Voip FSP на нормальный аппаратный компьютер чтобы избежать подобных проблем. Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз.

Где я могу загрузить пробную версию “16 линий” (или “8 линий”)?

2 линии, доступные во время пробного периода, более чем достаточно для тестирования. Другие линии будут работать точно также. Если вам необходимо большее количество линий, вы должны купить лицензию .

Я использую стационарный компьютер дома, но также имею ноутбук, который обычно беру с собой в путешествие. Также, я иногда работаю на компьютере в офисе... Я никогда не использую оба компьютера одновременно. Не могли бы вы прислать лицензионный ключ, который будет работать на обеих машинах?

Лицензия привязана к единственному компьютеру. Если вы хотите использовать Fax Voip FSP на нескольких компьютерах, вам следует приобрести отдельную лицензию для каждого из них.

Наш пробный период закончился. Могу ли я продлить пробный период? (Как сбросить пробный период?)

Мы не знаем как сбросить пробный период на вашем компьютере. Мы также не знаем, как взломать нашу защиту. 15 дней это более чем достаточно для тестирования. Если вы собираетесь использовать Fax Voip FSP по истечении 15 дней, вы должны купить лицензию .

Мы хорошо известная компания, наша продукция известна во всем мире... Не могли бы вы прислать нам лицензионный ключ, в идеале не привязанный к конкретному компьютеру, т.к. у нас много компьютеров, используемых для тестирования..?

15 дней это более чем достаточно для тестирования. Если вы собираетесь использовать Fax Voip FSP по истечении 15 дней, вы должны купить лицензию . Лицензия привязана к единственному компьютеру, поэтому вам необходимо приобрести отдельную лицензию для каждого компьютера, на котором вы намерены использовать Fax Voip FSP. Известные успешные компании обычно не задают таких вопросов. Кроме того, наши цены являются относительно низкими.

Мой жесткий диск (материнская плата) умер, что было так неожиданно... Не могли бы вы выслать мне другую лицензию?

Мы не рекомендуем устанавливать наше программное обеспечение на старые компьютеры с плохими жесткими дисками. Следует также отметить, что срок службы жесткого диска, обычно составляет не менее 2-3-х лет (это при очень грубом обращении). Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я клонировал мой жесткий диск с использованием специальной утилиты, отключил старый диск (из-за аппаратных проблем) и начал работу с использованием нового диска. Но Fax Voip FSP теперь не лицензирован. Затем я удалил Fax Voip FSP с моего компьютера, перезагрузил компьютер и установил Fax Voip FSP заново. Но опять та же проблема...

Лицензия привязана к единственному компьютеру (SystemID). Ваш SystemID не может быть “клонирован”, т.к. определяется вашим физическим оборудованием (в частности зависит от жесткого диска). Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я переустановил Windows и мой SystemID изменился. Я использую Виртуальную машину (VMWare и т.п.) и мой виртуальный сервер рухнул в прошлую пятницу. Не могли бы вы прислать мне другую лицензию?

Мы категорически не рекомендуем устанавливать Fax Voip FSP на Виртуальную машину. Виртуальные машины чрезвычайно неустойчивы и требуют частых переустановок, при которых SystemID не сохраняется ввиду отсутствия оборудования как такового. Пожалуйста установите Fax Voip FSP на нормальный аппаратный компьютер. В любом случае вы можете попросить новый лицензионный ключ в течении срока лицензионной поддержки (1 год). Интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. Бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я решил использовать Fax Voip FSP на другом компьютере. Не могли бы вы прислать мне новую лицензию? (Как я могу перенести лицензию?)

Лицензия привязана к единственному компьютеру. Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. При бесплатной замене лицензионного ключа, предыдущий лицензионный ключ (System ID) блокируется и добавляется в черный список. Таким образом, вы не сможете когда-либо использовать Fax Voip FSP на вашем старом компьютере после такой замены лицензионного ключа.

Я хочу перепродавать вашу программу. Что я должен делать? Могу ли я получать специальные скидки?

Пожалуйста свяжитесь с нашим отделом продаж .

Я установил новую версию Fax Voip FSP 4.x.x. Я имею действительный лицензионный ключ, установленный на моем компьютере, но Fax Voip FSP показывает, что я работаю с пробной версией. В чем может быть проблема?...

Скорее всего ваша лицензия позволяет работать с Fax Voip FSP версии 3.3.1 или более ранней. Вы можете обновить Fax Voip FSP до версии 4 , воспользовавшись специальной скидкой.

Мы использовали пиратскую копию Windows и были вынуждены уничтожить наши компьютеры (с установленной лицензией Fax Voip FSP).... Не могли бы вы прислать мне другую лицензию Fax Voip FSP?

Извините, но в этом случае, вы определенно должны купить новую лицензию Fax Voip FSP .


Архивация и восстановление

Функции архивации и восстановления позволяют выполнять следующие задачи:

  • Сохранение текущей конфигурации Fax Voip FSP и файлов, созданных в процессе работы программы.
  • Восстановление конфигурации Fax Voip FSP и файлов пользователя из резервной копии.
  • Перемещение текущей конфигурации Fax Voip FSP и файлов пользователя на другой компьютер.

Чтобы сохранить вашу текущую конфигурацию, обратитесь к разделу Сохранение параметров и файлов .

Чтобы восстановить конфигурацию из резервной копии, обратитесь к разделу Восстановление параметров и файлов .


Сохранение параметров и файлов

Сохранение текущих параметров и файлов Fax Voip FSP

Архивация и восстановление ››

1. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

2. В Панели управления Fax Voip FSP, на вкладке Инструменты ленты, нажмите Экспорт настроек.

3. В окне Сохранение конфигурации Fax Voip FSP, выберите папку для сохранения резервной копии. Введите имя новой папки, в которую будут скопированы резервные файлы. По умолчанию предлагается создать папку на рабочем столе. Нажмите Сохранить. Требуются права администратора.

4. Чтобы открыть папку с сохраненными файлами в проводнике Windows, в диалоговом окне нажмите Да, см. рисунок ниже.


Восстановление параметров и файлов

Восстановление параметров и файлов Fax Voip FSP

Архивация и восстановление ››

1. Откройте Панель управления Fax Voip FSP. Для этого нажмите Пуск, выберите Fax Voip FSP; нажмите Панель управления Fax Voip FSP. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip FSP из меню иконки Fax Voip FSP в системном трее.

2. В Панели управления Fax Voip FSP, на вкладке Инструменты ленты, нажмите Импорт настроек.

3. В окне Восстановление конфигурации Fax Voip FSP, укажите папку, в которой сохранены параметры и файлы Fax Voip FSP. Нажмите Восстановить. Требуются права администратора.

4. Подождите, пока программа не завершит все необходимые действия. Служба Fax Voip FSP будет перезапущена.

5. В диалоговом окне нажмите OK, см. рисунок ниже.

6. Перезапустите Диспетчер Fax Voip FSP, нажав на ярлык Fax Voip FSP на рабочем столе или любым другим способом.


Удаление Fax Voip FSP

  • Чтобы удалить Fax Voip FSP


Чтобы удалить Fax Voip FSP

Удаление программного обеспечения Fax Voip FSP

Удаление Fax Voip FSP ››

Чтобы удалить Fax Voip FSP с локального компьютера

1. Закройте все компоненты Fax Voip FSP, чтобы избежать возможных проблем.

2. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Приложения и возможности.

3. В списке установленных программ выделите запись Fax Voip Windows Fax Service Provider. Нажмите кнопку Удалить.

4. В окне мастера Удаление Fax Voip Windows Fax Service Provider нажмите Удалить.

5. Отметьте опции удаления и затем нажмите Далее. Для сохранения настроек и файлов созданных в процессе работы программы, оставьте опции по умолчанию как показано на рисунке ниже.

Доступны следующие варианты удаления Fax Voip FSP:

Все файлы

Выберите эту опцию, чтобы полностью удалить программу с вашего компьютера. Все настройки, а также файлы созданные в процессе работы программы (Fax Voip FSP журналы отладки и т.д.) будут удалены. Будьте внимательны! Удаленные документы не могут быть восстановлены.

Указанные файлы

Выберите эту опцию чтобы сохранить настройки и файлы созданные в процессе работы программы. Отметьте объекты подлежащие удалению.

Файлы программы

Эта опция всегда выбрана и не может быть изменена.

Провайдер службы факсов Windows

Эта опция всегда выбрана и не может быть изменена.

Расширение маршрутизации факсов (Fax Voip FSP)

Эта опция всегда выбрана и не может быть изменена.

Параметры (SIP, H.323, Маршруты, Факс, Email, Языки...)

Отметьте эту опцию чтобы удалить текущую конфигурацию. Эта опция также удаляет пользовательские Шаблоны электронной почты и Языковые профили (включая профили, созданные пользователем).

Методы для входящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы удалить настройки для Методов маршрутизации для входящих факсов .

Методы для исходящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы удалить настройки для Методов маршрутизации для исходящих факсов .

Правила для почты (Почта-на-факс)

Отметьте эту опцию чтобы удалить Правила для почты (почта-на-факс) .

Файлы созданные в процессе работы программы

Отметьте эту опцию чтобы удалить файлы созданные в процессе работы программы (Fax Voip FSP журналы отладки и т.д.). Будьте внимательны! Удаленные документы не могут быть восстановлены.

6. На завершающей странице мастера Удаление Fax Voip Windows Fax Service Provider нажмите Готово.


Запуск Fax Voip FSP через подключение к удаленному рабочему столу

Запуск Fax Voip FSP через подключение к удаленному рабочему столу (RDP)

При помощи Подключения к удаленному рабочему столу (RDP), вы можете удаленно настраивать параметры приложений и запускать приложения на вашем компьютере. RDP является стандартным компонентом операционной системы Windows, нет необходимости загружать и устанавливать громоздское, часто некачественное программное обеспечение сторонних производителей. Вы можете использовать RDP для удаленной установки и настройки приложения Fax Voip FSP. При этом следует использовать учетную запись администратора.

Для осуществления необходимых настроек на компьютере, на котором установлен Fax Voip FSP, следуйте инструкциям раздела Настройка RDP на компьютере, к которому требуется подключиться настоящей главы.

Чтобы подключиться к компьютеру, на котором установлен Fax Voip FSP, с другого компьютера, следуйте инструкциям раздела Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP) настоящей главы.

Заметим, что если вы нуждаетесь в удаленной поддержке , вы должны предоставить доступ к вашему компьютеру через стандартное RDP подключение, как описано в этой главе. Следует особо отметить, что наши эксперты не используют никакого другого программного обеспечения для осуществления удаленной поддержки .


Настройка RDP на компьютере, к которому требуется подключиться

Запуск Fax Voip FSP через подключение к удаленному рабочему столу ››

Чтобы разрешить удаленные подключения на компьютере, к которому требуется подключиться:

1. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Система. В окне О системе нажмите Дополнительные параметры системы.

2. В окне Свойства системы, на вкладке Удаленный доступ, в группе Удаленный рабочий стол, выберите опцию Разрешить удаленные подключения к этому компьютеру. Снимите галку Разрешить подключения только с компьютеров, на которых работает удаленный рабочий стол с проверкой подлинности на уровне сети чтобы иметь возможность доступа к вашему компьютеру с компьютеров, на которых установлены старые операционные системы.

3. Если вы являетесь администратором компьютера, ваша текущая учетная запись будет автоматически добавлена в список удаленных пользователей и вы можете пропустить оставшиеся действия.

4. Нажмите OK или Применить, чтобы сохранить параметры.

Примечания

  • Функция Подключение к удаленному рабочему столу включена не во все версии Windows. См. также документацию к вашей версии операционной системы Windows.


Подключение к удаленному компьютеру с помощью RDP

Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP)

Запуск Fax Voip FSP через подключение к удаленному рабочему столу ››

Для запуска удаленного рабочего стола на компьютере, с которого происходит подключение:

1. В меню Пуск выберите Стандартные - Windows и нажмите Подключение к удаленному рабочему столу.

2. В окне Подключение к удаленному рабочему столу, в поле Компьютер, введите имя компьютера, к которому требуется подключиться, а затем щелкните Подключить. (Вместо имени компьютера можно также ввести его IP-адрес).

3. После подключения к удаленному компьютеру, вам будет предложено ввести учетные данные.

Примечания

  • Версия клиента подключения к удаленному рабочему столу зависит от типа и версии операционной системы Windows, версии Service Pack и т.п. См. также документацию по вашей операционной системе Windows.


Проблемы Виртуальных Машин

В настоящее время, установка операционной системы Windows на Виртуальную машину весьма популярна. Десятки и сотни разработчиков утверждают, что их Виртуальные машины обеспечивают точно такие же условия, как обеспечивает обычный аппаратный компьютер. Согласно их утверждениям, нет никакой разницы между операционной системой, установленной на Виртуальную машину и операционной системой, установленной обычным способом.

К сожалению, на практике, картина может быть гораздо более печальной. Ваша система нестабильна, вы вынуждены часто переустанавливать ее. У вас часто возникают проблемы при использовании стандартных функций, драйверов и т.д. Ваши любимые программы не работают правильно или дают сбой в самый неподходящий момент. Вы начинаете винить разработчиков программного обеспечения и говорить, что они пишут некачественные программы.

Итак, возможно ли установить Fax Voip FSP на Виртуальную машину? Будет ли он работать на ней?

Да, вы можете. Но... Компания FaxVoip Software не дает никаких гарантий и не несет никакой ответственности, если программа Fax Voip FSP не будет работать правильно, будучи установленной на Виртуальную машину. Fax Voip FSP является достаточно сложным приложением с технической точки зрения. Не удивительно, что любой из тщательно скрываемых недостатков вашей Виртуальной машины может всплыть и вызвать ошибку. В случае возникновения ошибки, которая не подтверждается путем воспроизведения такой же проблемы на аппаратном компьютере, с установленной на нем такой же операционной системы, наши эксперты наврядли смогут помочь вам. Мы тестируем нашу программу на нормальных аппаратных компьютерах и никогда не используем Виртуальные машины. Может быть ваша Виртуальная машина и самая лучшая в мире, но пожалуйста, попытайтесь решить проблему с ее разработчиками, ведь именно они, а не мы, и не разработчики Windows настаивают на том, что "Виртуальная машина работает так же хорошо".

Иными словами, мы настоятельно рекомендуем, чтобы вы устанавливали Fax Voip FSP на нормальный аппаратный компьютер.

Ответы на вопросы, часто задаваемые пользователями Виртуальных машин можно найти в разделе Часто задаваемые вопросы (FAQ) текущей главы.


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Проблемы Виртуальных Машин ››

Я переустановил Windows и мой SystemID изменился. Я использую Виртуальную машину (VMWare и т.п.) и мой виртуальный сервер рухнул в прошлую пятницу. Не могли бы вы прислать мне другую лицензию?

Мы категорически не рекомендуем устанавливать Fax Voip FSP на Виртуальную машину. Виртуальные машины чрезвычайно неустойчивы и требуют частых переустановок, при которых SystemID не сохраняется ввиду отсутствия оборудования как такового. Пожалуйста установите Fax Voip FSP на нормальный аппаратный компьютер. Если вы все-таки решили игнорировать наши рекомендации и установить Fax Voip FSP на Виртуальной машине, имейте ввиду следующее. В любом случае вы можете попросить новый лицензионный ключ в течении срока лицензионной поддержки (1 год). Интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. Бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз.

У меня есть одна проблема с вашим программным обеспечением. На моей VMWare, Windows 11 (Windows 10, Windows 8.1), когда я отправляю (принимаю) факс, нет никаких проблем. Но затем Fax Voip FSP рушится. Есть ли у вас какие-либо предложения, что я могу сделать?

Вы можете установить Fax Voip FSP на такую же операционную систему, но установленную на нормальный аппаратный компьютер.

Наши специалисты не очень хорошие эксперты по части Виртуальных машин и мы готовы признать это. Пожалуйста, адресуйте ваш вопрос в техническую поддержку VMware. Они безусловно являются высококлассными специалистами в области Windows и обязаны обеспечить правильную работу Windows-совместимого программного обеспечения на своей виртуальной системе.

Привет, я только что обновил Fax Voip FSP с версии 3 до версии 4 и теперь не могу запустить программу. В системном журнале я вижу: Faulting application FaxVoipFSPConfig.exe, version 4.1.0.1, faulting module kernel32.dll... У меня никогда никогда не было такой ошибки при использовании предыдущей версии. Я использую VMWare... Вы можете решить эту проблему?

Мы не даем никаких гарантий нормальной работы Fax Voip FSP, если программа установлена на Виртуальную машину. Может быть мы добавили какую-нибудь новую функцию, которая использует например WIN API, которая не использовалась в предыдущей версии Fax Voip FSP. Вероятно поддержка этой функции не доработана в вашей Виртуальной машине. Пожалуйста свяжитесь со службой поддержки вашей VM и попросите их исправить проблему.

Собираетесь ли вы осуществлять поддержку Виртуальных Машин в будущем?

Мы занимаемся поддержкой правильного функционирования нашей программы на операционных системах Microsoft Windows . Обеспечение правильного функционирования самой операционной системы, определенно является задачей тех, кто разрабатывает оборудование, на котором эта система функционирует. В случае Виртуальной машины, это задача разработчиков вашей Виртуальной машины.


Техническая поддержка

Вы можете связаться с нашей службой технической поддержки, отправив сообщение e-mail по адресу support@t38faxvoip.ru

Для получения самой свежей информации о нашей программе, пожалуйста, посетите наш веб-сайт https://www.t38faxvoip.ru/fsp

По вопросам покупки и лицензирования Fax Voip FSP, обращайтесь по адресу: sales@t38faxvoip.ru

Примечания

  • Наши эксперты всегда рады помочь вам с помощью Удаленной поддержки .


Удаленная поддержка

Техническая поддержка ››

В случае нестандартных проблем, а также для ускорения решения возникших проблем, наши эксперты могут помочь вам с помощью Удаленной поддержки и решить проблему непосредственно на вашем компьютере. Чтобы использовать данную возможность, вы должны предоставить доступ к вашему компьютеру через Подключение к удаленному рабочему столу (RDP) . Для получения Удаленной поддержки, пожалуйста свяжитесь с нашей службой поддержки .

Часто задаваемые вопросы (FAQ)

Как настроить мой компьютер, чтобы ваши специалисты смогли получить к нему доступ и оказать удаленную помощь?

Вам следует настроить доступ через Подключение к удаленному рабочему столу на вашем компьютере, где установлен Fax Voip FSP. Для этого воспользуйтесь инструкциями в главе Настройка RDP на компьютере, к которому требуется подключиться настоящего справочного руководства.

Какую программу вы используете для удаленного доступа к моему компьютеру?

Наши специалисты используют стандартный клиент для Подключения к удаленному рабочему столу от фирмы Microsoft, который входит в комплектацию операционной системы Windows. Мы используем стандартную процедуру, описанную в главе Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP) настоящего справочного руководства.

Какие необходимые данные я должен сообщить вам?

Вы должны сообщить нам IP-адрес вашего компьютера, Имя пользователя (должен являться администратором) и Пароль. Естественно, вы должны объяснить суть возникшей проблемы нашему эксперту. Необходимость Удаленной поддержки должна быть согласована с нашей службой поддержки . Если вы используете Виртуальную машину , мы просим проинформировать нас об этом заранее. Напомним, что наши эксперты не занимаются решением специфических проблем виртуальных машин.

На моем компьютере установлена программа TeamView (GoTo Meeting), мой Session ID 666-666-666 и действителен в течении ближайших 10 минут (3-х часов). TeamView это очень хорошая программа. Я буду в офисе еще 40 минут (до 8 часов вечера по моему местному времени). Не могли бы вы взглянуть на мою проблему?

Наши специалисты не используют программное обеспечение сторонних производителей для удаленного доступа к вашему компьютеру. Упомянутые вами программы не установлены на наших компьютерах и не могут быть использованы по соображениям безопасности.

Обратите внимание, что Удаленная поддержка обычно предлагается в случае непонятных проблем, которые не могут быть решены в обычном порядке в течении 5 минут. Нашим экспертам обычно требуется какое-то время, чтобы понять проблему на компьютере клиента и попытаться найти решение. После предварительного согласования и предоставления доступа к вашему компьютеру, наш специалист изучит проблему в течение последующих 24 часов (обычно раньше) и свяжется с вами.

Почему я должен давать вам доступ к своему компьютеру? Я не могу дать вам пароль администратора. Что вы собираетесь делать на моем компьютере?

Странный вопрос... Вы попросили решить вашу проблему и просите об Удаленной поддержке. Естественно, наши специалисты будут заниматься исключительно проблемами программы Fax Voip FSP на вашем компьютере.

Без доступа с правами администратора мы, скорее всего, не сможет понять и решить проблему, так что это необходимо.

Конечно, только вы сами принимаете окончательное решение о предоставлении или не предоставлении доступа к вашему компьютеру.

В настоящее время у меня нет лицензии на вашу программу. (Fax Voip FSP установлен в качестве пробной версии). Могу я просить вас о предоставлении удаленной помощи?

Да, конечно. Пожалуйста свяжитесь с нашей службой поддержки . Заметим только, что клиенты, оплатившие лицензию, имеют преимущественное право на получение любого вида технической поддержки.


Другие продукты

  • Fax Voip T.38 Модем
  • Fax Voip T.38 Консоль
  • Fax Voip Softphone
  • Windows Mail Restore Tool for Windows 10, 8.1 and 7


Fax Voip T.38 Модем

Другие продукты ››

Fax Voip T.38 Модем
Виртуальный голосовой факс-модем
SIP, H.323, ISDN CAPI 2.0

https://www.t38faxvoip.ru

Факс и автоответчик для SIP/H.323/ISDN CAPI 2.0. Голосовой факс-модем для работы со стандартным факс софтом. Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Цветные факсы через VoIP и ISDN. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip T.38 Модем

Итак, вам необходимо отправлять и принимать факсы, вам нужен автоответчик. Вы привыкли работать с вашим программным обеспечением для факса и автоответчика.

Вы хотите отправлять факсы через VoIP или ISDN и даже слышали о протоколе T.38. Вы хотите использовать автоответчик на вашей SIP, H.323 или ISDN линии. При этом вы хотите продолжать пользоваться вашей любимой программой для факса и автоответчика.

Никаких проблем! Fax Voip T.38 Модем - это решение для вас и вашего бизнеса.

Что такое Fax Voip T.38 Модем? С точки зрения вашей факсовой и голосовой программы, это голосовой факс-модем. Fax Voip T.38 Модем устанавливает Виртуальные COM порты и виртуальные модемы Fax Voip 14.4K TAPI Voice-Fax Modems в вашей системе, с которыми вы легко можете настроить вашу факсовую программу. С точки зрения VoIP сети, это SIP/H.323 клиент с поддержкой T.38 и G.711 факса. С точки зрения вашей ISDN линии, это CAPI 2.0 приложение с поддержкой аудио факса. С помощью Fax Voip T.38 Модем вы можете отправлять и принимать T.38 и аудио (цветные и черно-белые) факсы и голосовые сообщения без какого-либо оборудования, используя только вашу любимую программу для факса и голоса. Fax Voip T.38 Модем – идеальное решение для организации факсимильной и голосовой почты в SIP, H.323 или ISDN сети. Fax Voip T.38 Модем работает с VoIP или ISDN PBX или с вашим SIP/H.323/ISDN оператором. Fax Voip T.38 Модем поддерживает до 100 виртуальных линий.

На рисунке ниже показано как работает приложение Fax Voip T.38 Модем.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Fax Voip T.38 Модем поддерживает функции Caller ID и Набор добавочного номера.

Fax Voip T.38 Модем – полнофункциональная система для отправки факсов через e-mail (Почта-на-факс) и получения факсов на e-mail (Факс-на-почту).

Функция Почта-на-факс - Microsoft Fax позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Методы маршрутизации для входящих факсов (Microsoft Fax): отправить по электронной почте, сохранить в папке, печать позволяют маршрутизировать входящие факсы получателям в сети. Пользовательская маршрутизация входящих факсов (Microsoft Fax) позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов (Microsoft Fax): уведомления о доставке по электронной почте, сохранить в папке, печать позволяют маршрутизировать исходящие факсы в зависимости от номера факса получателя, а также успешной или неудачной доставки факса. Пользовательская маршрутизация исходящих факсов (Microsoft Fax) позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса.

Fax Voip T.38 Модем был успешно протестирован с Microsoft Fax, BVRP Classic Phone Tools 9, FaxTalk Messenger Pro 7.5, CallStation, WinFax Pro и многими другими хорошо известными программами.

Fax Voip T.38 Модем хорошо работает с такими операторами IP-телефонии, как YouMagic (МТТ) , Телфин , Мультифон (Мегафон) , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими.


OtherProducts_FaxVoipConsole

Другие продукты ››

Fax Voip T.38 Консоль
T.38 и аудио факс. SIP, H.323, ISDN CAPI 2.0

https://www.t38faxvoip.ru/console

T.38 и аудио факс для SIP/H.323/ISDN CAPI 2.0. Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Отправка аудио сообщений. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация, факс-по-запросу. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip T.38 Консоль

Fax Voip T.38 Консоль позволяет отправлять и получать T.38 и аудио (поверх кодека G.711) факсы и отправлять аудио сообщения с использованием любого провайдера IP-телефонии (SIP или H.323). Решение не требует установки какого-либо стороннего факс-голосового программного обеспечения.

На рисунке ниже показано как работает приложение Fax Voip T.38 Консоль.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Вы можете отправлять T.38, аудио и CAPI факсы через Виртуальный принтер Fax Voip и принимать факсы напрямую в TIFF, PDF или SFF файлы. Управлять факсами можно через приложение Fax Voip T.38 Консоль.

Можно отправлять не только факсы, но также аудио сообщения.

Fax Voip T.38 Консоль – полнофункциональная система для отправки факсов и аудио сообщений через e-mail (Почта-на-факс и Аудио через почту) и получения факсов на e-mail (Факс-на-почту).

Функция Почта-на-факс (аудио через почту) позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Методы маршрутизации для входящих факсов: отправить по электронной почте, сохранить в папке, печать позволяют маршрутизировать входящие факсы получателям в сети. Пользовательская маршрутизация входящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов и аудио сообщений: уведомления о доставке по электронной почте, сохранить в папке, печать позволяют маршрутизировать исходящие факсы и аудио сообщения в зависимости от номера получателя, а также успешной или неудачной доставки факса или аудио сообщения. Пользовательская маршрутизация исходящих факсов и аудио сообщений позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса или аудио сообщения.

Функция Факс по запросу позволяет вызывающим абонентам получать необходимую информацию по факсу в процессе текущего вызова.

Fax Voip T.38 Консоль хорошо работает с такими операторами IP-телефонии, как YouMagic (МТТ) , Телфин , Мультифон (Мегафон) , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими.


Fax Voip Softphone

Другие продукты ››

Fax Voip Softphone
Phone, Fax, Call Recording, Random Calls

https://www.t38faxvoip.com/phone

https://www.t38modem.com/phone

SIP/H.323 софтфон. Запись телефонных разговоров. Проигрывание аудио сообщений в телефонную линию. Отправка и прием T.38 и аудио факсов. Мелодия на удержании. Перевод и переадресация вызовов. Телефонная книга. Журнал. Функция случайных телефонных вызовов.

О программе Fax Voip Softphone

Fax Voip Softphone является мощным и уникальным SIP / H.323 программным телефоном при помощи которого можно осуществлять телефонные вызовы, записывать разговор по телефону, воспроизводить аудио файлы в телефонную линию, а также отправлять и принимать T.38 и аудио факсы. Весь функционал доступен в рамках единственного приложения с использованием любого провайдера IP телефонии (VoIP). Fax Voip Softphone поддерживает такие функции как Мелодия на удержании, Перевод Вызова и Переадресация вызова.

Audio - Fax панель позволяет отправлять заранее подготовленные факсы и аудио сообщения в один клик.

Используя Log Book (журнал), вы можете легко просматривать историю вызовов, просматривать полученные и отправленные факсы, а также прослушивать записи разговоров и отправленные аудио сообщения.

Phone Book (телефонная книга) является удобным местом хранения информации о ваших контактах.

Функция Random Phone Calls (случайные телефонные вызовы) может быть полезна для вашего бизнеса, а также для различных тестовых целей. Эта функция позволяет автоматически осуществлять повторяющиеся телефонные вызовы на один или несколько заданных номеров. Также эта функция позволяет проигрывать в линию аудио сообщения и вести запись разговоров.

Используя Fax Voip Softphone Control Panel (панель управления), вы легко можете настроить софтфон в соответствии с вашими требованиями.

Fax Voip Softphone был успешно протестирован с YouMagic , Телфин , Мультифон , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими операторами IP-телефонии.


Windows Mail Restore Tool for Windows 10, 8.1 and 7

Другие продукты ››

Windows Mail Restore Tool
for Windows 10, 8.1 and 7

https://www.winmail10.com

Позволяет использовать классическое программное обеспечение Почта Windows (ранее Outlook Express) на компьютере под управлением Windows 10, Windows 8.1 или Windows 7. Автоматическое восстановление после обновлений. Резервное копирование и восстановление хранилища сообщений и настроек. Многоязычная поддержка.

О программе WM Restore Tool

Windows Mail Restore Tool (WM Restore Tool) позволяет использовать классическое программное обеспечение Почта Windows (ранее Outlook Express) на компьютере под управлением Windows 10, Windows 8.1 или Windows 7. Windows Mail (ранее Outlook Express), один из наиболее популярных клиентов электронной почты по всему миру, теперь доступен снова для всех новых версий Windows.

В Windows Mail есть все инструменты, необходимые для работы с электронной почтой и новостями. Доступные языки интерфейса Windows Mail: английский, немецкий, французский, испанский, итальянский, японский, китайский (упрощенный), китайский (традиционный), арабский, болгарский, хорватский, чешский, датский, голландский, эстонский, финский, греческий, иврит, корейский, латышский, литовский, норвежский, польский, португальский (Бразилия), португальский (Португалия), румынский, русский, сербский, словацкий, словенский, шведский, тайский, турецкий, украинский.

Windows Mail поддерживает следующие почтовые и новостные протоколы: POP3 (Post Office Protocol 3), SMTP (Simple Mail Transfer Protocol), IMAP (Internet Message Access Protocol), NNTP (Network News Transfer Protocol). Благодаря поддержке SSL, вы можете легко настроить Windows Mail для использования с Gmail , Hotmail (Live, Outlook.com) и многими другими службами электронной почты. Windows Mail полностью совместима с функциями обмена сообщениями Simple MAPI . Кроме того, Windows Mail имеет документированный интерфейс прикладного программирования (API) основанный на Component Object Model (COM).

Инструмент WM Restore Tool предоставляет вам дополнительный набор полезных инструментов при работе с приложением Windows Mail. Вы можете легко создать резервную копию, восстановить или переместить на другой компьютер свои настройки и хранилище сообщений Windows Mail.