Содержание
Fax Voip T.38 Модем
Виртуальный голосовой факс-модем
SIP, H.323, ISDN CAPI 2.0

https://www.t38faxvoip.ru

Факс и автоответчик для SIP/H.323/ISDN CAPI 2.0. Голосовой факс-модем для работы со стандартным факс софтом. Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Цветные факсы через VoIP и ISDN. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

Содержание

Введение

Новое в версии 9.4.1

История предыдущих версий (Fax Voip T38 Fax & Voice)

Установка Fax Voip T.38 Модем

Установка пробной версии

Функции

Системные требования

Удаление предыдущей версии

Microsoft .NET Framework 4.5

Запуск программы установки

Настройка Fax Voip T.38 Модем

Настройка линии SIP

Настройка линии H.323

Настройка линии ISDN CAPI 2.0

Настройка линий факсов

Установка Средства просмотра фотографий в Windows Server

Диспетчер Fax Voip T.38 Модем

Запуск диспетчера Fax Voip T.38 Модем

Запуск и остановка Fax Voip T.38 Модем

Опции меню в системном трее

Панель управления Fax Voip T.38 Модем

IP-телефония

SIP

Параметры SIP

Параметры прокси-сервера

Агент пользователя SIP

Учетные записи SIP

Параметры учетных записей SIP

Добавление или изменение учетной записи SIP

Управление учетными записями SIP

Тестирование учетной записи SIP

Параметры восстановления SIP регистрации

Параметры T.38 UDPTL Redundancy (SIP)

Параметры голосовых кодеков SIP

H.323

Параметры H.323

H.323 гейткипер

Параметры T.38 UDPTL Redundancy (H.323)

Параметры голосовых кодеков H.323

ISDN CAPI 2.0

Параметры ISDN CAPI 2.0

Маршрутизация исходящих VOIP вызовов

Добавление или изменение правил для исходящих вызовов

Управление правилами для исходящих вызовов

Параметры маршрутизации исходящих VOIP вызовов

Общие параметры

Параметры факса

Параметры кодеков

Маршрутизация входящих VOIP вызовов

Добавление или изменение правил для входящих VOIP вызовов

Управление правилами для входящих VOIP вызовов

Параметры маршрутизации входящих VOIP вызовов

Общие параметры

Параметры факса

Параметры кодеков

Виртуальные COM порты и модемы

COM порты и модемы

Добавление/удаление Виртуальных COM портов Fax Voip

Добавление/удаление модемов Fax Voip

Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами

Использование Fax Voip T.38 Модем с драйвером Eltima Virtual Serial Port

Создание виртуальных пар COM портов Eltima

Использование Fax Voip T.38 Модем с Eterlogic.com Virtual Serial Ports Emulator

Создание виртуальных пар COM портов Eterlogic.com

Автозапуск: запуск Eterlogic.com VSPE с использованием ярлыка и командной строки

Автозапуск: запуск Eterlogic.com VSPE в качестве службы Windows

Настройка Fax Voip T.38 Модем с виртуальными парами COM портов

Проверка доступности COM портов при запуске Fax Voip T.38 Модем

Привязка модема к виртуальной паре COM портов

Настройка факс программы

Маршрутизация исходящих вызовов с модемов

Маршрутизация входящих вызовов на модемы

Изменение правил для входящих вызовов на модемы

Голосовые функции модема и распознавание DTMF

Форматы голосовых данных модема

Системы голосовых команд модема

Голосовая поддержка через TAPI драйвер модема

Проблемы с голосовым модемом в Windows 10: устранение неполадок

Поддерживаемое программное обеспечение (голос/факс/модем)

Параметры Caller ID (Входящие вызовы на модемы)

Методы маршрутизации для входящих факсов (Microsoft Fax)

Отправить по электронной почте

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры E-mail

Параметры формата

Шаблоны электронной почты

Сохранить в папке

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры сохранения

Параметры формата

Печать

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры печати

Пользовательская маршрутизация входящих факсов

Требования к пользовательскому приложению (информация для разработчика)

Пример пользовательского приложения

Методы маршрутизации для исходящих факсов (Microsoft Fax)

Уведомления о доставке по электронной почте

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры E-mail

Параметры формата

Шаблоны электронной почты

Сохранить в папке

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры сохранения

Параметры формата

Печать

Добавление или изменение правил

Управление правилами

Параметры

Общие параметры

Параметры печати

Пользовательская маршрутизация исходящих факсов

Требования к пользовательскому приложению (информация для разработчика)

Пример пользовательского приложения

Факс

Параметры факса

Набор номера (Microsoft Fax)

Общие сведения о правилах набора номера

Параметры конвертации в факс

Параметры Printto

Исправление ассоциаций файлов в Windows 11 и Windows 10

Параметры просмотра факсов

Отправка факса с помощью утилиты SendFaxMS.exe - Microsoft Fax

Параметры командной строки SendFaxMS.exe

Настройка и запуск SendFaxMS.exe

Титульные страницы (SendFaxMS.exe)

Сведения об отправителе (SendFaxMS.exe)

Уведомления о доставке на е-mail (оригинал)

Параметры SMTP (служба факсов Windows)

Параметры SendFaxMS.exe

Получатели факса

Документы

Конвертация в факс

Титульная страница

Сведения об отправителе

Важность и время отправки факса

Уведомления на е-mail (оригинал)

Отслеживание факса (графический интерфейс)

Мониторинг факса

Просмотр свойств факса

Работа с факсом

Отслеживание факса (режим консоли)

Электронная почта

Факс-на-почту, почта-на-факс и уведомления о доставке

Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows

Почта-на-факс - Microsoft Fax

Параметры почта-на-факс

Набор номера (почта-на-факс)

Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс)

Титульные страницы (почта-на-факс)

Сведения об отправителе (почта-на-факс)

Правила для почты (почта-на-факс)

Добавление или изменение правил

Управление правилами

Параметры правил для почты

Общие параметры

Набор номера

Уведомления о доставке

Вложения электронной почты

Титульные страницы

Сведения об отправителе

Время отправки факса

Шаблоны электронной почты

Отправка факсов через e-mail (Microsoft Fax)

Создание сообщения электронной почты

Отправка титульных страниц

Вложения электронной почты

Использование PDF файлов в качестве вложений электронной почты

Блокирование нежелательных адресов электронной почты

Уведомление на e-mail о результатах отправки факса

Почта-на-факс в качестве службы Windows

Устранение неполадок функции почта-на-факс

Часто задаваемые вопросы (FAQ)

Просмотр журнала функции почта-на-факс

Общие инструкции по восстановлению функции почта-на-факс

Использование вложений электронной почты с именами файлов на национальных языках

Параметры SMTP

Параметры OAuth 2.0

Получение и установка сертификата безопасности электронной почты

Отправка пробного e-mail

Параметры POP3 / IMAP

Параметры OAuth 2.0

Тестирование POP3 / IMAP

Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0

Google (Gmail.com)

Microsoft (Office 365, Hotmail, Outlook.com)

Yahoo.com

Yandex.ru

Mail.ru

Шаблоны электронной почты

Получен новый факс (служба Microsoft Fax)

Факс успешно отправлен (служба Microsoft Fax)

Не удалось отправить факс (служба Microsoft Fax)

Не удалось создать задание факса

Общие параметры

Общие параметры и протоколы

Журналы маршрутизации входящих факсов (Microsoft Fax)

Журналы маршрутизации исходящих факсов (Microsoft Fax)

Журналы электронной почты

Журналы SendFaxMS.exe (Microsoft Fax)

Многоязычная поддержка

Добавление языкового профиля

Редактирование языкового профиля

Языковые файлы

Параметры системы

Fax Voip T.38 Модем в качестве службы Windows

Настройка Fax Voip T.38 Модем в качестве службы Windows

Описание служб Fax Voip T.38 Модем

T38 и G711 (аудио) режимы факса

Настройка режима факса

Настройка режима исходящих факсов

Настройка режима входящих факсов

Режимы исходящих факсов

Режим G711 факс (G711)

Режим T38 факс (T38)

Режим G711 факс + T38 факс (G711,T38)

Режим T38 факс с отправкой ре-инвайта + G711 факс (T38+R,G711)

Режимы входящих факсов

Режим G711 факс (G711)

Режим T38 факс + G711 факс (T38,G711)

Режим G711 факс + T38 факс с ожиданием ре-инвайта (T38R,G711)

Требования к голосовым кодекам

Параметры голосовых кодеков SIP (по умолчанию)

Параметры голосовых кодеков H.323 (по умолчанию)

Настройка исходящих кодеков

Настройка входящих кодеков

Цветные факсы через VoIP и ISDN

Требования к VoIP сети

Настройка Fax Voip T.38 Модем

Требования к факс программному обеспечению

Требования к противоположной стороне

Caller ID

Получение Caller ID

Передача Caller ID (SIP)

Передача Caller ID (H.323)

Передача Caller ID (ISDN CAPI 2.0)

Набор добавочного номера

Отправка факса на добавочный номер

Факс по запросу

Пример с Venta Fax

T.38 и G.711 режимы факса

Использование Fax Voip T.38 Модем cо службой факсов Windows

Настройка службы факсов из панели управления Fax Voip T.38 Модем

Установка Службы факсов

Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10

Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022

Настройка службы факсов

Windows 11

Windows Server 2022

Совместное использование ресурсов факса

Настройка факс сервера (Windows Server 2022)

Настройка факс клиента (Windows 11)

Конфигурирование идентификатора и заголовка факса

Windows 11

Windows Server 2022

Отправка и получение факсов

Отправка факсов

Отправка факса из приложения Windows

Отправка факса из Fax Voip T.38 Модем

Настройка сведений об отправителе

Настройка качества изображения

Утилита командной строки SendFaxMS.exe

Отправка факса с использованием другой учетной записи

Получение факсов

Мониторинг и уведомления

Доступ к факсам другого пользователя

Устранение неполадок службы факсов Windows

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами

Использование Fax Voip T.38 Модем с CallStation

Конфигурирование модема в CallStation

Автоответчик

Прием факсов

Пересылка голосовых сообщений

Пересылка факсов

Удаленный доступ

Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro 7.5

Конфигурирование модема в FaxTalk Messenger Pro

Отправка факса

Настройка голосовой и факсимильной почты

Удаленный доступ к голосовой и факсимильной почте

Получение входящих факсов и голосовых сообщений

Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools 9

Конфигурирование модема в BVRP Classic Phone Tools

Удаленное управление сообщениями

Отправка факса

Получение входящих факсов и голосовых сообщений

Использование Fax Voip T.38 Модем с Venta Fax & Voice

Конфигурирование модема и системы голосовых команд

Формат голосовых данных модема

Реплика перед передачей факса

Голосовое приветствие автоответчика

Удаленное управление автоответчиком

Прослушивание телефонной линии через динамики компьютера

Отправка факса

Отправка голосового сообщения

Получение входящих факсов и голосовых сообщений

Факс по запросу

Venta Fax & Voice драйвер (VentaEngine)

Цветные факсы

Требования к VOIP сети

Настройка Fax Voip T.38 Модем

Настройка Venta Fax для отправки цветных факсов

Настройка Venta Fax для приема цветных факсов

Требования к противоположной стороне

Отправка цветных факсов

Прием цветных факсов

Использование Fax Voip T.38 Модем с FaxAmatic

Конфигурирование FaxAmatic для работы с Fax Voip T.38 Модем

Отправка факса

Примеры настройки с операторами VoIP

YouMagic (МТТ)

Телфин

Мультифон (Мегафон)

DellMont (Betamax)

Лицензии

Виды лицензий

Просмотр текущей лицензии

Покупка лицензии

Добавление/изменение лицензии

Обновление до версии 9

Политика лицензионной поддержки

Часто задаваемые вопросы

Мастер архивации и восстановления Fax Voip T.38 Модем

Сохранение текущих параметров и файлов

Восстановление параметров и файлов

Использование мастера архивации и восстановления с предыдущими версиями

Удаление Fax Voip T.38 Модем

Чтобы удалить Fax Voip T.38 Модем

Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу (RDP)

Настройка RDP на компьютере, к которому требуется подключиться

Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP)

Устранение неполадок при использовании RDP

Проблемы Виртуальных Машин

Часто задаваемые вопросы

Техническая поддержка

Удаленная поддержка

Другие продукты

Fax Voip Windows Fax Service Provider

Fax Voip T.38 Консоль

Fax Voip Softphone

Windows Mail Restore Tool for Windows 10, 8.1 and 7

Copyright © FaxVoip Software, LLC, 2008-2024. Все права защищены.


Введение
Fax Voip T.38 Модем
Виртуальный голосовой факс-модем
SIP, H.323, ISDN CAPI 2.0

https://www.t38faxvoip.ru

Факс и автоответчик для SIP/H.323/ISDN CAPI 2.0. Голосовой факс-модем для работы со стандартным факс софтом. Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Цветные факсы через VoIP и ISDN. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip T.38 Модем

Итак, вам необходимо отправлять и принимать факсы, вам нужен автоответчик. Вы привыкли работать с вашим программным обеспечением для факса и автоответчика.

Вы хотите отправлять факсы через VoIP или ISDN и даже слышали о протоколе T.38. Вы хотите использовать автоответчик на вашей SIP, H.323 или ISDN линии. При этом вы хотите продолжать пользоваться вашей любимой программой для факса и автоответчика.

Никаких проблем! Fax Voip T.38 Модем - это решение для вас и вашего бизнеса.

Что такое Fax Voip T.38 Модем? С точки зрения вашей факсовой и голосовой программы, это голосовой факс-модем. Fax Voip T.38 Модем устанавливает Виртуальные COM порты и виртуальные модемы Fax Voip 14.4K TAPI Voice-Fax Modems в вашей системе, с которыми вы легко можете настроить вашу факсовую программу. С точки зрения VoIP сети, это SIP/H.323 клиент с поддержкой T.38 и G.711 факса. С точки зрения вашей ISDN линии, это CAPI 2.0 приложение с поддержкой аудио факса. С помощью Fax Voip T.38 Модем вы можете отправлять и принимать T.38 и аудио (цветные и черно-белые) факсы и голосовые сообщения без какого-либо оборудования, используя только вашу любимую программу для факса и голоса. Fax Voip T.38 Модем – идеальное решение для организации факсимильной и голосовой почты в SIP, H.323 или ISDN сети. Fax Voip T.38 Модем работает с VoIP или ISDN PBX или с вашим SIP/H.323/ISDN оператором. Fax Voip T.38 Модем поддерживает до 100 виртуальных линий.

На рисунке ниже показано как работает приложение Fax Voip T.38 Модем.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Fax Voip T.38 Модем поддерживает функции Caller ID и Набор добавочного номера.

Fax Voip T.38 Модем – полнофункциональная система для отправки факсов через e-mail (Почта-на-факс) и получения факсов на e-mail (Факс-на-почту).

Функция Почта-на-факс - Microsoft Fax позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Методы маршрутизации для входящих факсов (Microsoft Fax) : отправить по электронной почте , сохранить в папке , печать позволяют маршрутизировать входящие факсы получателям в сети. Пользовательская маршрутизация входящих факсов (Microsoft Fax) позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов (Microsoft Fax) : уведомления о доставке по электронной почте , сохранить в папке , печать позволяют маршрутизировать исходящие факсы в зависимости от номера факса получателя, а также успешной или неудачной доставки факса. Пользовательская маршрутизация исходящих факсов (Microsoft Fax) позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса.

Fax Voip T.38 Модем был успешно протестирован с Microsoft Fax, BVRP Classic Phone Tools 9 , FaxTalk Messenger Pro 7.5 , CallStation , WinFax Pro и многими другими хорошо известными программами.

Fax Voip T.38 Модем хорошо работает с такими операторами IP-телефонии, как YouMagic (МТТ) , Телфин , Мультифон (Мегафон) , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими.


Новое в версии 9.4.1

Новое в версии 9.4.1 (Февраль 2024)

  • Исправлены HTTPS и некоторые другие ссылки в приложении.
  • Исправлены ссылки HTTPS в руководстве пользователя.

Новое в версии 9.3.1 (Июль 2023)

  • Добавлена поддержка OAuth 2.0 (современная проверка подлинности) при отправке сообщений электронной почты через сервер SMTP.
  • Добавлена поддержка OAuth 2.0 (современная проверка подлинности) при приеме сообщений электронной почты через сервер POP3 / IMAP.
  • Метод SecureSmtpClient для отправки сообщений электронной почты через SMTP. Поддержка OAuth 2.0 (современная проверка подлинности). Implicit SSL, Explicit SSL (STARTTLS). Кодировка UTF-8. Подробный лог при отправке сообщения электронной почты через SMTP.
  • В панели управления Fax Voip T.38 Модем реализована процедура получения Refresh Token (OAuth 2.0) с использованием Internet Explorer, WebBrowser (.Net) или веб-браузера по умолчанию.
  • Fax Voip T.38 Модем был успешно протестирован с Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и некоторыми другими провайдерами электронной почты OAuth 2.0.
  • Корректное отображение номера и описания ошибки при использовании метода CDO.Message для отправки сообщений электронной почты через SMTP. Исправлено.
  • Некоторые другие улучшения.

Новое в Fax Voip T.38 Модем версии 9.2.1 (Ноябрь 2022)

  • Добавлена поддержка TLS версии 1.2 при использовании SMTP и защищенного соединения (SSL). Может быть критично при использовании метода маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , метода маршрутизации для исходящих факсов 'Уведомления о доставке по электронной почте' (Microsoft Fax) и функции Почта-на-факс - Microsoft Fax .
  • Добавлена поддержка TLS версии 1.2 при использовании POP3 / IMAP и защищенного соединения (SSL). Может быть критично при использовании функции Почта-на-факс - Microsoft Fax .
  • Добавлены некоторые комментарии о том, как использовать Fax Voip T.38 Модем с аккаунтом Gmail после 30 Мая 2022 года ( Параметры SMTP , Параметры POP3 / IMAP ).
  • В панели управления Fax Voip T.38 Модем добавлена страница Набор номера (телефония Microsoft) - Microsoft Fax . На этой странице вы можете настроить правила набора номера (TAPI) и проверить, как будет преобразован номер факса, введенный в каноническом формате, и как он будет отображаться в программе Факсы и сканирование Windows. В руководстве пользователя добавлены инструкции по настройке правил набора номера (глава Общие сведения о правилах набора номера ).
  • При использовании функции Почта-на-факс - Microsoft Fax и Правил для почты - Microsoft Fax , добавлена возможность преобразования номера факса в неканонический формат перед созданием задания факса, в том числе с использованием правил набора номера (TAPI), настроенных в параметрах Телефон и модем в панели управления Windows.
  • При использовании функции Почта-на-факс - Microsoft Fax и Правил для почты - Microsoft Fax , появилась возможность добавления префикса перед номером факса. В частности, это можно использовать для маршрутизации факсов от различных пользователей электронной почты через разные учетные записи SIP. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов (параметры Если номер начинается с цифр и Удалить цифры...).
  • Исправлена проблема с отображением файлов PDF в программе Adobe Acrobat Reader - при использовании метода маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) и метода маршрутизации для входящих факсов 'Сохранить в папке' (Microsoft Fax) .
  • Некоторые другие улучшения.

Новое в Fax Voip T.38 Модем версии 9.1.1 (Апрель 2022)

  • Функционал 'Виртуальные COM порты (модемы) Fax Voip' был перенесен в отдельное приложение, которое теперь называется Fax Voip T.38 Модем. Функционал 'Внутренние VOIP/ISDN факс/аудио линии Fax Voip' (Консоль Fax Voip и Принтер Fax Voip) был перенесен в другое приложение под названием Fax Voip T.38 Консоль . Большое количество разных, но похожих функций в одном приложении часто сбивает с толку наших пользователей в процессе настройки, тестирования и покупке лицензий. Мы хотим сделать наши продукты более понятными и удобными.
  • Добавлена поддержка Windows 11 и Windows Server 2022.
  • Наконец удалена поддержка Windows XP, Windows Server 2003 и Windows Vista.
  • В панели управления Fax Voip T.38 Модем добавлены команды, позволяющие копировать правила маршрутизации или учетные записи SIP. Применимо к учетным записям SIP , маршрутизации исходящих VOIP вызовов , маршрутизации входящих VOIP вызовов , методам маршрутизации для входящих факсов - Microsoft Fax ( отправить по электронной почте , сохранить в папке , печать ), методам маршрутизации для исходящих факсов - Microsoft Fax ( уведомления о доставке по электронной почте , сохранить в папке , печать ) и правилам для почты - Microsoft Fax . Может быть полезно при создании большого количества схожих правил или учетных записей SIP.
  • В панели управления Fax Voip T.38 Модем добавлены команды, позволяющие разрешить или запретить использование выбранных правил. Применимо к методам маршрутизации для входящих факсов - Microsoft Fax ( отправить по электронной почте , сохранить в папке , печать ) и методам маршрутизации для исходящих факсов - Microsoft Fax ( уведомления о доставке по электронной почте , сохранить в папке , печать ).
  • При использовании параметра Удалить цифры в правиле маршрутизации исходящих VOIP вызовов, теперь можно удалять не только цифры, но и любые другие символы в начале номера.
  • Новые стили и иконки для лучшей совместимости с Windows 11.
  • Обновленная справочная система.
  • Некоторые другие улучшения.


История предыдущих версий

История предыдущих версий (Fax Voip T38 Fax & Voice)

Новое в версии 9.4.1 ››

Версия 8.3.1 (Июнь 2021)

  • Метод маршрутизации Уведомления о доставке по электронной почте (внутренние линии) для исходящих факсов и аудио сообщений. Отправка уведомлений на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса или аудио сообщения. В зависимости от номера получателя, типа вызова (факс или аудио), а также успешной или неудачной доставки факса или аудио сообщения, уведомление о доставке может быть отправлено различным e-mail адресатам. Отправка уведомлений нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата прикрепляемого факса: TIFF, PDF или SFF. Копия аудио сообщения может быть прикреплена к сообщению электронной почты в формате WAV. Настраиваемые шаблоны электронной почты. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени. Этот метод дублирует функцию Уведомления о доставке на e-mail (внутренние линии). Для совместимости с некоторыми другими функциями, старый функционал не был удален и вы можете использовать обе функции независимо друг от друга.
  • Метод маршрутизации сохранить в папке (внутренние линии) для исходящих факсов и аудио сообщений. Копирование исходящих факсов и аудио сообщений в заданные папки в зависимости от номера получателя, типа вызова (факс или аудио), а также успешной или неудачной доставки факса или аудио сообщения. Сохранение исходящего факса или аудио сообщения в одной или нескольких папках. Возможность выбора формата сохранения факса: TIFF, PDF или SFF. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени.
  • Метод маршрутизации печать (внутренние линии) для исходящих факсов. Печать исходящих факсов в зависимости от номера факса получателя, а также успешной или неудачной доставки факса. Печать исходящих факсов на один или несколько принтеров.
  • Пользовательская маршрутизация исходящих факсов и аудио сообщений (внутренние линии). Позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса или аудио сообщения. Прилагается пример кода.
  • Метод маршрутизации Уведомления о доставке по электронной почте (Microsoft Fax) для исходящих факсов. Отправка уведомлений на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса. В зависимости от номера факса получателя, а также успешной или неудачной доставки факса, уведомление о доставке может быть отправлено различным e-mail адресатам. Отправка уведомлений нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата прикрепляемого факса: TIFF, PDF или SFF. Настраиваемые шаблоны электронной почты. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени. Этот метод является заменой для функции Уведомления о доставке на e-mail (Microsoft Fax). Старый функционал полностью удален из приложения.
  • Метод маршрутизации сохранить в папке (Microsoft Fax) для исходящих факсов. Копирование исходящих факсов в заданные папки в зависимости от номера факса получателя, а также успешной или неудачной доставки факса. Сохранение исходящих факсов в одной или нескольких папках. Возможность выбора формата сохранения факса: TIFF, PDF или SFF. Настраиваемые шаблоны имен файлов. Настраиваемые форматы даты и времени.
  • Метод маршрутизации печать (Microsoft Fax) для исходящих факсов. Печать исходящих факсов в зависимости от номера факса получателя, а также успешной или неудачной доставки факса. Печать исходящих факсов на один или несколько принтеров.
  • Пользовательская маршрутизация исходящих факсов (Microsoft Fax) . Позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Прилагается пример кода.
  • Лицензия 'Fax Voip расширенная маршрутизация факсов: E-mail, сохранить в папке, печать, факс-по-запросу' теперь применяется как к методам маршрутизации для входящих факсов, так и к методам маршрутизации для исходящих факсов и аудио сообщений.
  • В предыдущих версиях пользователь мог указать двузначное число в параметре Удалить цифры в правиле маршрутизации исходящих VOIP вызовов, что приводило к ошибке при исходящем вызове. Исправлено. Имеющийся код позволяет удалить не более 9 первых цифр набираемого номера.
  • Настройка службы факсов Windows для архивирования всех успешно отправленных факсов в папку Отправленные. Необходимо для обеспечения правильной работы методов маршрутизации для исходящих факсов - Microsoft Fax .
  • Возможность настройки параметра Использовать код устройства передающего абонента (TSID) (служба факсов Windows) с помощью команды 'Настройка факс службы' в панели управления Fax Voip .
  • В руководстве пользователя добавлены инструкции по настройке факс-сервера (операционная система Windows Server, служба факсов Windows) для совместного использования с клиентскими компьютерами (глава Совместное использование ресурсов факса ).
  • В руководстве пользователя добавлены инструкции о том, как просматривать факсы (служба факсов Windows), созданные другим пользователем, и управлять ими (глава Доступ к факсам другого пользователя ). Добавлены инструкции о том, как отправить факс от имени учетной записи другого пользователя (глава Отправка факса с использованием другой учетной записи ).
  • Некоторые другие улучшения.

Версия 8.2.1 (Апрель 2020)

  • Обновленная утилита командной строки SendFax.exe - внутренние линии. Улучшения: отправка факса нескольким получателям, поддержка отправки нескольких документов, настройка и запуск SendFax.exe из панели управления Fax Voip, Журналы отладки SendFax.exe (внутренние линии). Исправлена ​​ошибка с распознаванием даты и времени при использовании параметров /Schedule= и /Submission=.
  • Обновленная утилита командной строки SendAudio.exe - внутренние линии. Улучшения: отправка аудио сообщения нескольким получателям, настройка и запуск SendAudio.exe из панели управления Fax Voip, Журналы отладки SendAudio.exe (внутренние линии). Исправлена ​​ошибка с распознаванием даты и времени при использовании параметров /Schedule= и /Submission=.
  • Утилита командной строки SendFaxMS.exe - Microsoft Fax . Отправка факса одному или нескольким получателям. Поддержка отправки нескольких документов, титульных страниц, оригинальных уведомлений о доставке на e-mail. Отслеживание факса . Настройка и запуск SendFaxMS.exe из панели управления Fax Voip . Журналы отладки SendFaxMS.exe (Microsoft Fax) .
  • Изменения в реализации методов маршрутизации для входящих факсов (внутренние линии): отправить по электронной почте, сохранить в папке, печать. Теперь они реализованы с использованием независимых исполняемых файлов и запускаются в отдельных потоках, что повышает стабильность системы. Кроме того, теперь вы можете включить ведение журналов отладки для этих функций.
  • Пользовательская маршрутизация входящих факсов - внутренние линии. Позволяет легко добавить любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Прилагается пример кода.
  • В шаблонах электронной почты , возможность выбрать региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени.
  • Индивидуальные шаблоны электронной почты при использовании метода маршрутизации отправить по электронной почте - внутренние линии для входящих факсов.
  • Индивидуальные шаблоны электронной почты при использовании метода маршрутизации отправить по электронной почте - Microsoft Fax для входящих факсов (расширение маршрутизации Fax Voip).
  • Настраиваемые шаблоны имен файлов при использовании метода маршрутизации сохранить в папке - внутренние линии для входящих факсов. Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов при использовании метода маршрутизации отправить по электронной почте - внутренние линии для входящих факсов. Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов при использовании метода маршрутизации сохранить в папке - Microsoft Fax для входящих факсов (расширение маршрутизации Fax Voip). Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов при использовании метода маршрутизации отправить по электронной почте - Microsoft Fax для входящих факсов (расширение маршрутизации Fax Voip). Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов и аудио сообщений при использовании функций Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс/аудио) - внутренние линии и Уведомления о доставке на e-mail (внутренние линии). Настраиваемые форматы даты и времени.
  • Настраиваемые шаблоны имен файлов для прикрепляемых факсов при использовании функций Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax и Уведомления о доставке на e-mail (Microsoft Fax). Настраиваемые форматы даты и времени.
  • В Windows 10 версии 1903 и 1909, исправлена проблема с голосовыми модемами при использовании TAPI.
  • Обновленная справочная система.
  • Некоторые другие улучшения.

Версия 8.1.1 (Март 2019)

  • Добавлена поддержка Windows Server 2019.
  • Реализован интерфейс ленты (Ribbon) на базе Windows Ribbon Framework в Панели управления Fax Voip. Классический интерфейс сохранен для обеспечения обратной совместимости.
  • Поддержка титульных страниц при отправке факсов через внутренние линии и Консоль Fax Voip. Вы можете отправить факс, состоящий только из титульной страницы, или же отправить титульную страницу в дополнение к другому документу. Можно использовать стандартные шаблоны (Секретно, К сведению, Универсальный, Срочно) или создавать личные титульные страницы в приложении 'Редактор титульных страниц факсов'. Эта новая функциональность использует Fax Service API и требует установки службы факсов Windows.
  • Отправка титульных страниц с помощью утилиты командной строки SendFax.exe (с кастомизацией).
  • Значительно улучшенные функции Почта-на-факс (аудио через почту) - внутренние линии и Почта-на-факс - Microsoft Fax . Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений. Кроме того, теперь вы можете включить ведение журнала отладки для этих функций. Улучшенные шаблоны электронной почты .
  • Правила для почты (почта-на-факс/аудио) - внутренние линии и Правила для почты (почта-на-факс) - Microsoft Fax . В зависимости от адреса электронной почты, позволяют переопределить следующие параметры: уведомления о доставке, вложения электронной почты, титульные страницы, сведения об отправителе, шаблоны электронной почты, режим факса (с внутренними линиями), важность и время отправки факса (с Microsoft Fax). Блокирование нежелательных адресов электронной почты.
  • Настройка служб почта-на-факс (аудио через почту) для запуска под учетной записью обычного пользователя вместо учетной записи локальной системы, при запуске Fax Voip в качестве службы Windows. Это минимизирует вероятность непредвиденных проблем при работе в качестве службы.
  • Изменения в реализации методов маршрутизации для входящих факсов (Microsoft Fax) : отправить по электронной почте , сохранить в папке , печать . Теперь они реализованы с использованием расширения маршрутизации Fax Voip, которое интегрировано в службу факсов Windows. Кроме того, теперь вы можете включить ведение журнала отладки для этих функций.
  • Пользовательская маршрутизация входящих факсов - Microsoft Fax (расширение маршрутизации Fax Voip). Позволяет легко добавить любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Прилагается пример кода.
  • Исправлена ​​двойная отправка первого RING при получении входящего вызова на виртуальный COM порт (модем). В частности, это неизбежно вызывало сбой службы факсов Windows, если она была настроена на автоматический ответ после 1 звонка (во всех версиях Fax Voip до 8.1.1).
  • Во всех поддерживаемых системах, автоматическая установка приложения Факсы и сканирование Windows (роли Факс-сервера) во время установки Fax Voip, если не установлено. Создание ярлыков на рабочем столе и в меню 'Пуск'. В Windows Server 2012/2012R2 и Windows Server 2008R2, установка компонента Возможности рабочего стола, если не установлен.
  • Настройка службы факсов Windows для отправки/получения факсов через виртуальные COM порты (модемы) Fax Voip в одно действие, используя Панель управления Fax Voip.
  • В Windows 10 версии 1709 или более поздней, а также в Windows Server 2019, исправление ошибки в Microsoft Modem Device Provider, из-за которой CallerID и TSID не сохраняются в базе данных службы факсов после получения факса.
  • В Windows 10, Windows Server 2019 и Windows Server 2016, исправление ошибки в программе Факсы и сканирование Windows, из-за которой кнопка 'Переслать по электронной почте' неактивна, в то время как e-mail клиент с поддержкой MAPI установлен в системе.
  • В Панели управления Fax Voip, отображение текущего состояния служб почта-на-факс в строке состояния. Отображение текущего состояния службы факсов Windows в строке состояния.
  • Отправка факсов из Панели управления Fax Voip (с помощью Консоли Fax Voip / внутренних линий или службы факсов Windows / приложения Факсы и сканирование).
  • Обновленная справочная система.
  • Некоторые другие улучшения.

Версия 7.6.1 (Январь 2018)

  • Добавлена поддержка Windows Server 2016.
  • При прямом преобразовании из PDF в TIFF, исправлена ошибка с зависанием процесса и 100% загрузкой ЦП, с некоторыми PDF файлами (обнаружено в версиях 7.1.1 - 7.5.1).
  • При прямом преобразовании из PDF в TIFF, исправлена ошибка с неспособностью конвертировать файлы PDF с именами в Юникод (не на английском языке).
  • Исправлены различные проблемы с лицензиями на компьютерах с включенной политикой FIPS для криптографических алгоритмов (обнаружено в версиях 7.1.1 - 7.5.1).
  • В Windows 10 Fall Creators Update (версия 1709), исправлено корректное отображение Диспетчера устройств при установке или удалении Виртуальных COM портов.
  • В справочной системе, изменен шрифт с Arial 9 на Segoe UI Light 10. Предыдущий не выглядит хорошо на новых системах, напр. на Windows 10.
  • Изменен стиль по умолчанию в Консоли Fax Voip и справочной системе.
  • Некоторые другие улучшения.

Версия 7.5.1 (Ноябрь 2016)

  • Отправка аудио сообщений через внутренние линии Fax Voip и Консоль Fax Voip. Мастер отправки аудио сообщений.
  • Утилита командной строки SendAudio.exe. Предназначена для автоматического создания аудио сообщения и может быть использована в различных сценариях, например при создании большого количества аудио сообщений, а также разработчиками программного обеспечения в их приложениях.
  • Функция Аудио через почту (через внутренние линии), аналогична функции Почта-на-факс. Уведомления о доставке на e-mail, настраиваемые шаблоны электронной почты.
  • Исправлены возможные сбои в приложении Консоль Fax Voip в режиме интерфейса Ленты (Ribbon).
  • Добавлены инструкции по исправлению проблемы установки Unimodem аудиоустройств в Windows 10 (голосовые функции модема через TAPI). Инструмент FixModemOnWin10.exe .
  • Некоторые другие улучшения.

Версия 7.4.1 (Сентябрь 2016)

  • Реализован интерфейс Ленты (Ribbon) на базе Windows Ribbon Framework в Консоли Fax Voip. Классический интерфейс сохранен для обеспечения обратной совместимости.
  • Вспомогательный механизм принудительного восстановления SIP регистрации. Может быть полезен в случае нестабильной регистрации.
  • Возможность ручного запуска или отмены SIP регистрации из Панели управления Fax Voip. Можно использовать для тестирования, а также для ручного восстановления регистрации в случае ее потери.
  • Применены новые стили для лучшей совместимости с Windows 10. Новый набор иконок. Всплывающие подсказки в TreeView с иконкой и текстом.
  • Некоторые другие улучшения.

Версия 7.3.1 (Июнь 2016)

  • Реализован обходной путь, позволяющий передавать Номер вызываемого абонента (DID) в стандартное факс приложение (например Microsoft Fax) через строку Caller ID.
  • Внедрен Метод маршрутизации: отправить по электронной почте (с использованием Microsoft Fax) . Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Отправка e-mail нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата доставки факса: TIFF, PDF или SFF.
  • Внедрен Метод маршрутизации: сохранить в папке (с использованием Microsoft Fax) . Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Сохранение входящих факсов в одной или нескольких папках. Возможность выбора формата сохранения факса: TIFF, PDF или SFF.
  • Внедрен Метод маршрутизации: печать (с использованием Microsoft Fax) . Маршрутизация входящих факсов в зависимости от Номера вызываемого абонента (DID) и Caller ID. Печать входящих факсов на один или несколько принтеров.
  • Лицензия Fax Voip расширенная маршрутизация факсов (E-mail, Сохранить в папке, Печать, Факс-по-запросу) теперь может использоваться с лицензией Виртуальные COM порты (модемы) и позволяет существенно увеличить максимальное количество правил, которые разрешено использовать с Методами маршрутизации для входящих факсов (Microsoft Fax) .
  • Утилита CertMgr.exe удалена из установочного пакета. Все процедуры, которые использовали этот инструмент, теперь используют функции .Net Framework.
  • Некоторые другие улучшения.

Версия 7.2.1 (Март 2016)

  • Добавлена многоязычная поддержка. Простой механизм для перевода программы на любой язык. Обратите внимание, файлы поддержки русского языка устанавливаются только при использовании русскоязычного инсталлятора (не поставляются со стандартной версией на английском языке).
  • Настраиваемые шаблоны электронной почты (используются с функциями Почта-на-факс, Факс-на-почту, а также с новой функцией Уведомления о доставке).
  • Реализована функция Уведомления о доставке на e-mail (как с внутренними линиями, так и с Microsoft Fax). Эта новая функция независима от аналогичного функционала, используемого в Почта-на-факс. Копия отправленного факса может быть прикреплена в формате TIFF, PDF или SFF. Несколько получателей e-mail могут быть заданы с использованием полей Кому, Копия и Скрытая копия. В случае внутренних линий факса настройки по умолчанию могут быть переопределены при отправке факса с использованием Fax Voip – мастер отправки факсов либо утилиты sendfax.exe.
  • Возможность отключения уведомлений о доставке на e-mail адрес отправителя при использовании функции Почта-на-факс. Копия отправленного факса теперь может быть прикреплена в формате TIFF, PDF или SFF.
  • Добавлена возможность не прикреплять принятый факс при использовании метода Отправить по электронной почте с внутренними линиями факса.
  • Возможность указать несколько адресов электронной почты с функцией Факс-на-почту на основе службы Microsoft Fax.
  • Реализована поддержка Адресной книги (Контакты Windows). Возможность выбора из Адресной книги номеров факсов и адресов электронной почты получателей.
  • Исправлена ошибка в конструкторе правила Маршрутизации исходящих VOIP вызовов.
  • Некоторые другие улучшения.

Версия 7.1.1 (Сентябрь 2015)

  • Добавлена поддержка Windows 10.
  • Миграция на .NET Framework.
  • Реализована поддержка Юникод.
  • Новый TAPI-совместимый драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. Поддержка Голосовых функций модема через стандартный драйвер Unimodem аудиоустройство. Исправлена ошибка воспроизведения в Unimodem Transform Module в Windows 10, Windows 8/8.1, Windows 7, Windows Vista, Windows Server 2012/2012R2 и Windows Server 2008/2008R2.
  • Добавлен формат голосовых данных модема 16-bit linear PCM at 8000 Hz.
  • Реализована функция Аппаратного разрыва соединения путем детектирования потери сигнала CD с помощью понижения сигнала DTR.
  • Fax Voip был успешно протестирован с TAPI-совместимым приложением CallStation (факс / голос).
  • Исправлены незначительные ошибки при отображении факс статистики в Консоли Fax Voip.
  • System.Net.Mail метод отправки e-mail сообщений через SMTP. Поддержка явного безопасного соединение Explicit SSL (STARTTLS) через порт 587.
  • Отправка e-mail сообщений подписанных цифровой подписью. Прозрачная подпись. Непрозрачная подпись.
  • Отправка e-mail сообщений в кодировке UTF-8.
  • Поддержка POP3 SSL.
  • Реализована поддержка IMAP. Поддержка IMAP SSL.
  • Игнорирование недействительного SSL сертификата сервера при отправке и получении e-mail сообщений с использованием SSL.
  • Добавлена возможность тестирования подключения к серверу POP3/IMAP. Добавлена функция Вести протокол приема электронной почты.
  • Добавлена возможность задавать группу e-mail адресов на базе имени домена в файле mail.ini, при использовании функции Почта-на-факс.
  • Исправлены различные проблемы печати из-под системной учетной записи в Windows Server 2012/2012R2. Исправлены проблемы печати стандартных файлов Текстовый документ (*.txt) из-под системной учетной записи в Windows 8/8.1 и Windows Server 2012/2012R2 с использованием функции Исправить команды printto . На всех системах, эта функция восстанавливает правильные ассоциации файлов для текущего пользователя.
  • Добавлены инструкции по исправлению ассоциаций файлов в Windows 10 .
  • Улучшенная система защиты. Короткие лицензионные ключи.
  • Новая лицензионная политика.
  • Повторяющиеся главы удалены в руководстве пользователя.
  • В окне Справки HTML добавлена кнопка Стиль (при вызове справочной системы из приложения Fax Voip).
  • Некоторые другие улучшения.

Примечания

  • Версия Fax Voip 7.1.1 была выпущена на только на английском языке.

Версия 6.5.1 (Август 2014)

  • В русской версии, исправлено отображение русского текста при отправке сообщений электронной почты на русском языке из Windows 8 /8.1, Windows 7 и Windows Vista. Применяется кодировка UTF-8.
  • Права администратора более не требуются для работы программы.
  • Общие настройки программы для всех пользователей.
  • Все пользовательские файлы, настройки и логи перенесены в стандартную папку Application Data, как положено.
  • Основные параметры программы перемещены в единый конфигурационный файл settings.ini.
  • Улучшенный механизм загрузки конфигурации.
  • Изменения в механизме межпроцессорного взаимодействия (IPC), который используется при создании заданий факса и получении статистики. В версии 6.4.1 был применен IPC на базе оконных сообщений. В версии 6.5.1 применена однонаправленная MailSlot технология.
  • Удалена бессмысленная задержка 2-3 секунды при наборе номеров длиннее 10 цифр. Существенно при большом количестве одновременных вызовов.
  • Поменялась процедура установки модемов. При добавлении нового модема установщик более не обновляет драйвера для ранее установленных модемов. Исправлены некоторые специфические проблемы при установке модемов на некоторых системах.
  • Используется более быстрый способ получения списка COM портов и модемов установленных в системе. WMI более не используется для этой цели.
  • Добавлена возможность выборочного сохранения настроек и данных пользователя при переустановке программы. При обновлении с версии 6.4.1 или более ранней, установщик автоматически импортирует настройки и данные если это возможно.
  • Добавлен Мастер архивации и восстановления Fax Voip . Может быть использован для сохранения, восстановления или перемещения конфигурации и файлов на другой компьютер. С некоторыми ограничениями может быть использован с предыдущими версиями Fax Voip.
  • Исправлены различные проблемы связанные с печатью и использованием функции printto. Новая функция Исправить команды printto исправляет проблемы печати и восстанавливает стандартные ассоциации файлов под системным аккаунтом в Windows 8. На всех системах эта функция корректирует стандартные ассоциации файлов для текущего пользователя. Также теперь используется прямой вызов функций библиотеки shimgvw.dll вместо использования printto где это возможно.
  • Иконки на кнопках СТАРТ и СТОП. Иконки запуска с правами администратора. Другие стандартные системные иконки применяются там, где это возможно.
  • Исправлен сбой в Панели управления Fax Voip при попытке использовать драйвера виртуальных COM портов сторонних производителей на Windows 8.
  • Исправлены возможные сбои на некоторых компьютерах, в частности на компьютерах с сенсорным экраном.
  • Исправлено слегка некорректное поведение функции Сообщение... (отправка факса по электронной почте) в Консоли Fax Voip.
  • Исправлен баг с правами доступа к папкам на Window XP/2003 при использовании файловой системы NTFS.
  • Исправлены некоторые проблемы с лицензиями. Исправлен сбой приложения при изменении System ID. Исправлена зависимость SystemID (редко но возможно на некоторых компьютерах) от наличия или отсутствия прав администратора. В предыдущих версиях этот досадный баг мог приводить к проблемам с появлением окна отправки факса. Исправление критично для нормальной работы новой версии. Исправлены некоторые проблемы с временными ключами.
  • Улучшенная справочная система. Добавлена вкладка поиска. Добавлены элементы навигации вверху каждой страницы.
  • Реализовано он-лайн руководство пользователя.
  • Некоторые другие улучшения.

Версия 6.4.1 (Февраль 2014)

  • Добавлена поддержка Windows 8.1, Windows 8.1 64-бит и Windows Server 2012 R2.
  • Существенные изменения движка внутренних VOIP/ISDN линий факса что сильно увеличивает стабильность приложения при одновременной работе с большим количеством факсов. Более эффективные механизмы межпроцессорного взаимодействия (IPC) при создании заданий факса и получении статистики. Временные файлы более не используются. Исправлены некоторые серьезные недочеты, могущие привести к аварийному завершению или зависанию программы.
  • Новый механизм добавления / обновления записей в папках Консоли Fax Voip исключающий зависание. Исправлена неприятная проблема с авто-прокруткой записей при их обновлении.
  • Поменялась иконка приложения. Добавлены иконки в меню. Добавлены некоторые новые меню.
  • В Консоли Fax Voip: подписи к кнопкам панели инструментов. Добавлен стиль Explorer (Vista и выше). Контекстное меню панели инструментов. Панель папок с возможностью менять ее стиль (Vista и выше). Автосохранение вида папки (эскизы страниц, таблица…) в диалогах отправки и сохранения факсов (XP и Windows Server 2003).
  • Уведомления в трей о принятых и отправленных факсах.
  • Улучшенная справочная система. При нажатии F1 или кнопки Справка открывается раздел соответствующий текущему окну. Тематический стиль применен к панели инструментов (Vista и выше) и другим элементам окна справки.
  • Исправлены различные проблемы при запуске Fax Voip в качестве Службы Windows . В предыдущих версиях процессы иногда могли не завершаться при остановке службы.
  • Если лицензия временная, отображается дата ее окончания.
  • Некоторые другие улучшения.

Версия 6.3.1 (Март 2013)

  • Добавлена поддержка Windows 8 , Windows 8 64-бит и Windows Server 2012.
  • Некоторые улучшения в дизайне Консоли Fax Voip. Крупные значки в панели инструментов. Исправлено некорректное отображение русскоязычных примечаний к кнопкам на некоторых системах. Исправлены другие незначительные ошибки.
  • Исправлены некоторые специфические проблемы передачи факса как аудио (факс поверх кодека G.711), обнаруженные в версии 6.
  • Исправлено использование ‘ + ‘ в опциях маршрутизации вызовов, таких как Отображаемое имя или Идентификатор факса.
  • Исправлены некоторые проблемы при использовании функции Почта-на-факс.
  • Устранена проблема с отображением напоминания об использовании пробной версии в случае если пользователь активировал лицензионный ключ, но забыл перезагрузить Fax Voip.
  • Исправлены другие недочеты, в частности в SIP сообщениях.

Версия 6.2.1 (Август 2012)

  • Отправка и прием факсов по стандартам CAPI 2.0 через внутренние линии факса. Поддержка B3 Protocol 4: T.30 for Group 3 fax и B3 Protocol 5: T.30 for Group 3 fax extended. Поддержка формата SFF (Structured Fax File).
  • Возможность задания параметров CAPI 2.0 факса через маршрутизацию вызовов. B3 Protocol, Максимальная скорость, Отключить ECM, Разрешить передачу факсов в высоком разрешении. Возможность выбора между режимами аудио факс и CAPI факс при отправке и приеме факсов через ISDN CAPI 2.0 с использованием внутренних линий факса.
  • Выбор номера ISDN контроллера и B-канала для исходящих вызовов через ISDN CAPI 2.0.
  • Возможность использования SFF формата в папке Входящие в Консоли Fax Voip. Сохранение факсов в формате SFF командой Сохранить как... Добавлена возможность использовать формат SFF с методами маршрутизации для входящих факсов Отправить по электронной почте и Сохранить в папке, а также с функцией Факс-на-почту на основе службы Microsoft Fax.
  • Возможность использовать Прямую конвертацию с файлами SFF.
  • Добавлена возможность использовать Виртуальный принтер Fax Voip для отправки факсов через Службу Microsoft Fax. Это особенно полезно при создании большого количества факсов которые вы бы хотели отправить через программу Microsoft Fax.

Версия 6.1.1 (Май 2012)

  • Драйвер Виртуальных COM портов, подписанный цифровой подписью Microsoft Code Signing, полностью совместимый с 64-битными версиями Windows 7, Vista и Windows Server 2008 (включая R2).
  • Добавлена поддержка ISDN CAPI 2.0. Аудио факс через линию ISDN CAPI 2.0. Возможность использовать стандартное факс программное обеспечение (например Microsoft Fax), сконфигурированное для работы с Виртуальными COM портами (модемами) Fax Voip с телефонной линией ISDN через интерфейс CAPI 2.0. Отправка и прием факсов через внутренние линии по технологии ISDN CAPI 2.0 также поддерживается.
  • Решена проблема с загрузкой иконки Fax Voip в трей при старте операционной системы для всех версий Windows 7 и Windows Vista. Отключено сообщение UAC во время автозагрузки.
  • Файл setup.exe и некоторые другие исполняемые файлы подписаны цифровой подписью.

Версия 5.6.1 Russian Edition (Март 2012)

  • Отправка сообщений электронной почты на русском или английском языках.
  • Русскоязычный интерфейс программы.
  • Руководство пользователя на русском языке.
  • Исправлено: корректное добавление исходящего факс задания в Консоль Fax Voip при некоторых региональных настройках даты и времени, использующих формат времени 'hh.mm.ss' вместо обычного 'hh:mm:ss', например Итальянский (Италия).*
  • Исправлена проблема запуска Fax Voip на операционной системе Windows 2008 R2 x64.**
  • Исправлена проблема регистрации с некоторыми H.323 гейткиперами с использованием H.235 MD5 аутентификации, например с sipgate.ru.**

Примечания

  • *Проблема изначально присутствовала в выпуске Fax Voip 5.6.1 (язык - английский). В настоящий момент исправлена в том числе в дистрибутиве английской версии Fax Voip 5.6.1.
  • **Проблема отсутствовала в Fax Voip 5.5.1 (язык - английский), но изначально присутствовала в выпуске Fax Voip 5.6.1 (язык - английский). В настоящий момент исправлена в том числе в дистрибутиве английской версии Fax Voip 5.6.1.

Версия 5.6.1 (Январь 2012)

  • Добавлена поддержка SIP через TCP. SIP регистрация, прокси-сервер, исходящие и входящие вызовы с использованием TCP транспорта.
  • Добавлена поддержка SIP через TLS. SIP регистрация, прокси-сервер, исходящие и входящие вызовы с использованием TLS. Возможность осуществления исходящих и приема входящих вызовов с префиксом sips:.
  • Возможность приема входящих SIP вызовов с префиксом tel: (схема Tel URI).
  • Исправлено: наличие исходящего прокси-сервера делает ненужной DNS проверку целевого URI, которая может оказаться неудачной, помешав осуществлению SIP вызова, в то время как проверка исходящего прокси-сервера через DNS успешна.
  • Возможность задавать диапазон локальных RTP портов, используемый Fax Voip.
  • Отправка факса нескольким получателям при использовании принтера Fax Voip или команды Отправить факс в Консоли Fax Voip.
  • Возможность загрузки списка номеров факсов из текстового файла.
  • Добавлена утилита командной строки Sendfax.exe. Позволяет автоматически создать задание факса и может быть использована в различных сценариях, например при создании большого количества исходящих факсов, а также разработчиками программного обеспечения в их приложениях.

Версия 5.5.1 (Октябрь 2011)

  • Добавлена функция Факс по запросу . Возможность отправки заранее подготовленного факсимильного документа во время входящего вызова который маршрутизируется на внутренние VOIP линии факса. В Консоли Fax Voip добавлена панель Факс-по-запросу.
  • Добавлен скрипт для программы Venta Fax, позволяющий создать систему Факс по запросу при работе с Venta Fax и Виртуальными COM портами (модемами) Fax Voip.
  • Возможность сохранения факсимильного документа в файле TIFF правильного формата при печати на Виртуальный принтер Fax Voip.
  • Лицензия Fax Voip Extended Incoming Routing (E-mail, Store in Folder, Print) license преобразована в лицензию Fax Voip Extended Incoming Routing (E-mail, Store in Folder, Print, Fax-on-Demand) license.
  • Исправлена проблема SIP регистрации с некоторыми SIP серверами (провайдерами). Проблема состояла в том, что Fax Voip не осуществлял повторную регистрацию по истечению таймаута регистрации.
  • Исправлена проблема корректного извлечения вызывающего и вызываемого номеров и отображения их в Консоли Fax Voip для входящих вызовов с некоторых SIP систем. Это особенно важно при использовании Методов маршрутизации для входящих факсов.
  • Исправлены некоторые мелкие проблемы, которые могли привести к аварийному закрытию Консоли Fax Voip.

Версия 5.4.1 (Август 2011)

  • Внедрен Метод маршрутизации: отправить по электронной почте для входящих факсов. Отправка e-mail нескольким получателям с возможностью использования полей Копия и Скрытая копия. Возможность выбора формата доставки факса, TIFF или PDF, который не зависит от формата входящих факсов в Консоли Fax Voip.
  • Внедрен Метод маршрутизации: сохранить в папке для входящих факсов. Сохранение входящих факсов в одной или нескольких папках. Возможность выбора формата сохранения факса, TIFF или PDF, который не зависит от формата входящих факсов в Консоли Fax Voip.
  • Внедрен Метод маршрутизации: печать для входящих факсов. Печать входящих факсов на один или несколько принтеров.
  • Отображение информации о маршрутизации входящих факсов в Консоли Fax Voip, в папке Входящие и в окне свойств принятого факса.
  • Добавлен новый тип лицензии, Fax Voip Extended Incoming Routing (E-mail, Store in Folder, Print) license.
  • Исправлен возможный сбой при использовании апострофа в Идентификаторе факса и некоторых других полях базы данных.
  • Исправлена некорректная перерисовка Консоли Fax Voip при использовании кнопки По умолчанию.

Версия 5.3.1 (Июнь 2011)

  • Прямая конвертация документа в факс без использования Виртуального принтера Fax Voip. Поддерживаемые форматы: PDF, TIFF, QFX, BMP, JPEG, GIF, PNG, ICO, WMF (EMF). Опции: Разрешение, Компрессия, Автоповорот, Страница A4, Передача полутонов. Прямую конвертацию в факс можно использовать со следующими функциями: Отправка факсов из Консоли Fax Voip, Отправка факсов через e-mail (с использованием Внутренних VOIP линий факса, а также с использованием Microsoft Fax). Эта новая функция полностью решает проблему использования PDF вложений с функцией Почта-на-факс. Также решает проблему отправки факсов через Удаленный рабочий стол (терминальное окно серверной операционной системы, RDP подключение к компьютеру с Vista, Windows 7 или Windows 2008).
  • Просмотр факсов, полученных в формате PDF, в Панели просмотра факсов, а также в аналогичных панелях диалоговых окон Сохранить как... и Свойства.
  • Возможность конвертации факсов, полученных в формате PDF, в различные графические форматы. Доступные форматы: TIFF (CCITTFAX4, CCITTFAX3, LZW, PACKBITS), PDF, BMP, JPEG, GIF, PNG, PCX. Возможность разбиения на отдельные страницы и сохранения только выбранных страниц.
  • Возможность конвертации факсов, полученных в формате TIFF, в формат PCX.
  • Добавлена возможность использовать команду Переслать с факсами, полученными в формате PDF.
  • Старый диалог печати заменен стандартным диалогом Печать (печать факсов с использованием Консоли Fax Voip).
  • Установщик Fax Voip более не устанавливает в систему библиотеку wiaaut.dll. Все процедуры, которые использовали эту библиотеку, теперь используют GDI / GDI +.
  • Улучшенные процедуры перерисовки Панели управления Fax Voip и Консоли Fax Voip (при изменении размеров окна или его элементов).
  • Улучшен внешний вид некоторых элементов. Например, кнопки выбора номеров страниц в диалоге Сохранить как... в Консоли Fax Voip.
  • Уменьшение времени запуска Панели управления Fax Voip и времени сохранения настроек в результате изменения механизма обмена данными между Fax Voip и реестром Windows.

Версия 5.2.1 (Апрель 2011)

  • Заменен движок Консоли Fax Voip. Внедрена база данных MS Access (Microsoft Jet 4.0).
  • Опции Отправка факса по расписанию и Уведомление о доставке (по e-mail) добавлены в Мастер отправки факсов Fax Voip.
  • Возможность задавать Число повторов при неуспешной передаче факса и интервал времени между повторами.
  • Остановка и возобновление передачи исходящих факсов.
  • Следующие столбцы добавлены в папку Исходящие: Время постановки в очередь, Исходное запланированное время, Запланированное время, Повторы. Столбец Состояние разделен на два столбца: Состояние и Расширенное состояние.
  • Схема Tel URI внедрена и теперь может использоваться с исходящими вызовами SIP.
  • Добавлена возможность использования символа ' + ' в номере телефона, а также возможность использования не-цифровых алиасов при исходящих вызовах. Однако, это не всегда поддерживается в стандартном факс программном обеспечении.
  • Исправлены некоторые проблемы с Панелью управления Fax Voip, которые иногда могли вызвать ее аварийное завершение в версии 5.1.1.
  • Следующие важные главы были добавлены в справочное руководство: Лицензии - Часто задаваемые вопросы , Проблемы Виртуальных Машин , Запуск Fax Voip через подключение к удаленному рабочему столу (RDP) , Удаленная поддержка .

Версия 5.1.1 (Январь 2011)

  • Добавлена поддержка H.323.
  • Список телефонных номеров H.323, Fast Start, Slow Start, H.245 Tunneling.
  • Регистрация на H.323 гейткипере, Поиск гейткипера, Время жизни.
  • H.235 MD5 аутентификация при регистрации на гейткипере.
  • Прямая маршрутизация H.323 вызовов.
  • Голосовая индикация вызова добавлена для случаев, в которых она не работала ранее (при наборе номера через виртуальные модемы в голосовом режиме).
  • Дополнительные исправления неправильных кодов ошибок, возникающих в случае внезапного разъединения телефонной линии во время передачи факса (с виртуальными модемами).
  • Исправлены некоторые проблемы с Виртуальными COM портами, которые могли приводить к блокировке портов при определенных обстоятельствах. Например в ситуации, когда на момент запуска Fax Voip факс программное обеспечение уже запущено и находится в режиме автоматического ответа на вызов.
  • Игнорирование правил Маршрутизации исходящих и входящих VOIP вызовов определенных типов (правила для SIP вызовов; правила для H.323 вызовов; правила, относящиеся к Виртуальным COM портам; правила, относящиеся к внутренним VOIP линиям факса) для случаев, когда эти типы правил не могут быть использованы в текущей конфигурации программы. Подсветка правил различных типов различными цветами в Панели управления Fax Voip.
  • Исправлена проблема запуска Fax Voip через системный трей на Windows 7 64-бит в режимах TESTSIGNING=ON или DISABLE_INTEGRITY_CHECKS (команды меню "Запустить Fax Voip T38 Fax & Voice" и "Запустить службу Fax Voip T38 Fax & Voice").
  • Добавлена возможность использования телефонных номеров, содержащих символ ‘ * ‘ в случае использования функции Почта-на-факс на основе внутренних VOIP линий факса.
  • Панель управления Fax Voip теперь запоминает текущее состояние (текущая вкладка, состояние элементов дерева), в котором вы закрываете ее.
  • Все процедуры отправки сообщений e-mail перенесены в отдельный поток во избежание проблем при большом количестве исходящих e-mail сообщений.
  • Добавлены некоторые комментарии по поводу версии Adobe Reader (9.4 или более ранней), которая совместима с Acrobat Wrapper и которую следует использовать с функцией Почта-на-факс.
  • Добавлены некоторые комментарии по поводу использования вложений e-mail с именами файлов на национальных языках, при использовании функции Почта-на-факс.
  • Добавлены инструкции по восстановлению работоспособности функции Почта-на-факс после неудачных экспериментов с различными типами вложений email.
  • Добавлена возможность автоматической проверки наличия новой версии программы.
  • Проверка, установлен ли Microsoft.NET Framework и какая версия установлена, во время установки Fax Voip.
  • Проверка, установлен ли уже Fax Voip и какая версия установлена, во время установки Fax Voip. Автоматическое удаление Fax Voip перед началом новой установки.

Версия 4.7.1 (Сентябрь 2010)

  • Изменение процедур при установке программы, существенно улучшены процедуры добавления и удаления Виртуальных COM портов и модемов.
  • Драйвер модема Standard 14400 bps modem заменен новым драйвером FaxVoip Modem 14400 bps Voice-Fax.
  • Добавлена функция Caller ID Name.
  • Добавлена функция T.38 UDPTL Redundancy.
  • В Консоли Fax Voip добавлен столбец Заголовок факса.
  • Удален параметр Использовать заголовок и идентификатор факса по умолчанию для всех исходящих факсов. Как Заголовок факса, так и Идентификатор факса теперь могут быть переопределены в настройках Маршрутизации вызовов, а также в диалоге Виртуального принтера Fax Voip и через функцию Почта-на-факс.
  • Возможность переопределения параметров по умолчанию через Маршрутизацию вызовов: Имя пользователя, Отображаемое имя, Максимальная скорость передачи факса, ECM, T.38 Redundancy, Идентификатор факса, Заголовок факса, Кодеки.
  • Исправлены некоторые проблемы, связанные с неправильными кодами ошибок, возникающих в случае внезапного разъединения телефонной линии во время передачи факса (с виртуальными модемами).
  • Автоматическое распознавание и управление опциями загрузки операционной системы на 64-битных версиях Windows 7, Windows Vista и Windows Server 2008.
  • Добавлена возможность отправки T.38 ре-инвайта для случая исходящих вызовов через внутренние линии.
  • Исправлена проблема получения G711 факса на скорости 14400 бит/сек (v.17) через Виртуальные COM порты (модемы).
  • Исправлен дефект с корректным сохранением Списка учетных записей SIP при удалении отдельных записей.
  • Добавлена защита от случайной вставки специальных символов (например символ переноса каретки) при использовании метода копировать-вставить при заполнении текстовых полей в Панели управления Fax Voip.

Версия 4.6.1 (Июнь 2010)

  • Добавлена поддержка Windows 7 и Windows 7 x64 Edition.
  • Добавлена возможность настройки дополнительных параметров SIP регистрации: Имя пользователя для авторизации, Домен/Realm, SIP контакт URL.
  • Исправлены некоторые проблемы с использованием глобального прокси-сервера.
  • Добавлен ложный кодек G.729 для решения проблем совместимости с SIP сетями, в которых поддерживается T.38, но не поддерживаются никакие другие голосовые кодеки кроме G.729.
  • Исправлена проблема аварийного завершения Fax Voip в ситуации, когда пользователь пытается отправить факс через "внутренние линии", но при этом не задал ни одного правила для исходящих SIP вызовов, осуществляемых через “внутренние линии”.
  • Исправлено отображение состояния SIP регистрации, если имя пользователя содержит символ ' * '.
  • Полная совместимость с Визуальными стилями XP/Vista (для Консоли Fax Voip и Панели управления Fax Voip).
  • Возможность изменять размер Панели управления Fax Voip.
  • Возможность выбирать стиль Панели инструментов в Консоли Fax Voip на Vista и Windows 7.
  • Внедрены 32-битные иконки в Консоли Fax Voip и Панели управления Fax Voip.
  • В Консоли Fax Voip и Панели управления Fax Voip добавлены кнопки восстановления внешнего вида по умолчанию.

Версия 4.5.1 (Апрель 2010)

  • Исправлена проблема набора номера в голосовом режиме (время ожидания перед ответом на вызов). Добавлена голосовая индикация вызова (с виртуальными модемами).
  • Корректное переключение в режим T.38 после набора номера в голосовом режиме (с виртуальными модемами).
  • Исправлена проблема ответа на входящий вызов при работе с некоторыми PBX, которая присутствовала из-за досадной ошибки в нашем SIP коде.
  • Добавлено подробное описание процедуры отправки и приема Цветных факсов через VOIP с использованием программ Venta Fax и Fax Voip. Данная технология полностью совместима с Fax Voip.
  • В Консоли Fax Voip добавлена Панель просмотра факсов.
  • Добавлена возможность просмотра текущего состояния входящих факсов в Консоли Fax Voip. Теперь вы знаете о входящем факсе и о номере страницы, принимаемой в настоящий момент, не дожидаясь окончания приема факса.
  • Добавлена возможность конвертации факсов в различные графические форматы. Доступные форматы: TIFF (CCITTFAX4, CCITTFAX3, LZW, PACKBITS), PDF, BMP, JPEG, GIF, PNG. Возможность разбиения на отдельные страницы и сохранения только выбранных страниц.
  • Внедрены новые диалоги Выбор сообщения... и Сохранить как... с Панелью просмотра факсов и возможностью настройки различных параметров.
  • Исправлена проблема корректного появления окна "Мастера отправки факсов" (появляется после печати) "поверх всех окон" на Vista и Windows 2008.
  • Добавлена поддержка визуальных стилей XP/Vista для некоторых базовых элементов пользовательского интерфейса.

Версия 4.4.1 (Январь 2010)

  • Добавлена возможность отправки факсов в Аудио G711 факс режиме через Виртуальные COM порты (модемы). Это означает, что теперь вы можете использовать стандартное факс программное обеспечение для отправки факсов через SIP провайдеров, которые не поддерживают T.38, например через Betamax.
  • Добавлена функция автоматического возврата к режиму G711 факс. Эта функция может быть полезна с теми SIP провайдерами, которые поддерживают T.38, но при этом поддержка T.38 не всегда гарантирована.
  • Добавлена возможность просмотра текущего состояния исходящих факсов в Консоли Fax Voip. Теперь вы знаете номер страницы факса, передаваемой в настоящий момент и прочую статистику, не дожидаясь окончания отправки факса.
  • Раздельные настройки ECM и Максимальной скорости передачи факса для исходящих/входящих и T.38/аудио факсов. Настройки этих параметров для Виртуальных COM портов (модемов) и Внутренних SIP линий факса также разделены.

Версия 4.3.1 (Декабрь 2009)

  • Добавлена возможность отправки факсов без использования Виртуальных COM портов и факс программного обеспечения сторонних производителей (как T.38, так и G711 факсы), с использованием внутренних SIP линий факса Fax Voip.
  • Добавлен Виртуальный принтер Fax Voip.
  • Приложение Журнал заменено приложением Консоль Fax Voip с расширенной функциональностью.
  • Добавлен встроенный функционал Почта-на-факс (на основе внутренних SIP линий факса).
  • Теперь вы можете добавлять не-цифровые префиксы (например '+') и использовать не-цифровые номера (имена пользователей) в правилах Маршрутизации исходящих SIP вызовов.
  • Исправлена проблема с нулевым “штампом времени” при использовании аудио (G711) режима факса. Исправление этой ошибки позволяет корректно работать не только с Betamax, но также с многими другими SIP провайдерами и оборудованием, которые не имеют поддержки T.38.

Версия 4.2.1 (Сентябрь 2009)

  • Добавлена возможность запускать Fax Voip в качестве Службы Windows.
  • Добавлена возможность отправки сообщений e-mail через CDO. Это делает использование функций Факс-на-почту (как на основе внутренних SIP линий факса, так и на основе службы Microsoft Fax) и Почта-на-факс более удобным и надежным. Вы можете работать с SMTP сервером с поддержкой SSL (например gmail.com), и задавать имя отправителя на вашем национальном языке. Добавлен встроенный SMTP-клиент для предварительного тестирования отправки e-mail. Новая функция Вести протокол отправки электронной почты (CDO) поможет выявить ошибки при конфигурировании SMTP.
  • В функции Факс-в-файл добавлена возможность принимать G711-факсы на скоростях 14400/12000 бит/сек (v.17).
  • В функции Факс-в-файл время ожидания начала передачи факса после ответа на входящий вызов увеличено до 1 минуты.
  • Теперь можно задать локальный Идентификатор факса (функция Факс-в-файл). В приложении Журнал мы также добавили отображение Продолжительности вызова.
  • В функции Почта-на-факс (на основе службы Microsoft Fax) добавлена возможность задать Идентификатор факса (SenderFaxID =) и Заголовок факса (SenderCompany =) в тексте сообщения.
  • В функциях Факс-на-почту (как на основе внутренних SIP линий факса, так и на основе службы Microsoft Fax) и Почта-на-факс существенно изменен формат сообщений e-mail.
  • Исправлено несколько ошибок в функции Факс-в-файл. Эти дефекты могли приводить к сбоям и даже к аварийному завершению приложения при определенных условиях (в версии 4.1.1).
  • Программа установки Fax Voip более не устанавливает Службу Microsoft Fax без согласия пользователя, или если она уже установлена (Windows XP/2003).
  • Fax Voip блокирует запуск функции Почта-на-факс, если Служба Microsoft Fax не установлена. Это позволяет избежать сообщения об ошибке, что смотрится не очень красиво.

Версия 4.1.1 (Август 2009)

  • Внедрены Голосовые функции модема. Теперь можно использовать Fax Voip не только в качестве "T.38 факса", но также в качестве Голосового почтового ящика (Автоответчика). Вы можете использовать голосовое приветствие перед отправкой или приемом факса. Возможна отправка не только факсов, но также и голосовых сообщений.
  • Добавлена поддержка DTMF. Это делает возможным управление вашим Голосовым и факсовым почтовым ящиком, используя DTMF тона.
  • Новые голосовые функции были успешно протестированы с программой Venta Fax & Voice. Venta Fax позволяет использовать все новые голосовые и DTMF функции Fax Voip. Вы даже можете прослушивать SIP линию через динамики компьютера.
  • Голосовые возможности также были успешно протестированы с программами BVRP Classic Phone Tools и FaxTalk Messenger Pro .
  • Добавлена поддержка одновременных SIP регистраций. Вы можете работать одновременно с несколькими SIP серверами, и (или) регистрировать несколько Учетных записей SIP на одном и том же сервере.
  • Добавлена поддержка Маршрутизации исходящих вызовов и Маршрутизации входящих вызовов. Маршрут вызова выбирается в зависимости от выполнения тех или иных начальных условий. Для разных портов могут использоваться разные наборы правил.
  • Добавлены новые Аудио кодеки для SIP. Текущая версия Fax Voip поддерживает следующие аудио форматы для SIP: G.711-uLaw-64k, G.711-ALaw-64k, G.723.1, G.726-32k, GSM-06.10, iLBC, SpeexNB, SpeexWB.
  • Добавлена функция Caller ID. Caller ID теперь поддерживается как через прямое подключение к COM порту, так и при работе через драйвер модема Standard 14400 bps modem, через TAPI.
  • Добавлена возможность Набора добавочного номера с использованием DTMF тонов.
  • Функция отправки факсов поверх G711 была удалена из-за несовместимости с новыми функциями. Эта функция была добавлена ранее в экспериментальных целях и ее реализация обладала рядом существенных недостатков. Однако, вы можете принимать факсы как G711-аудио, используя функцию Принимать факсы как файлы.
  • SIP и T.38 модули программы были существенно переработаны. Исправлены ошибки, касающиеся некорректного использования параметра Прокси-сервер. Эти ошибки иногда приводили к отсутствию слышимости или неудаче при переключении в режим T.38.
  • Исправлены некоторые ошибки в модуле mfaxmail.exe (mfaxmail.exe отвечает за работу функций Почта-на-факс и Факс-на-почту и использует Microsoft Fax API).
  • Руководство пользователя в формате PDF было удалено из основного дистрибутива программы. PDF файл фактически дублирует файл справки Fax Voip.

Версия 3.5.1

  • Добавлена поддержка Windows Vista x64 Edition и Windows Server 2008 x64 Edition.
  • Добавлена возможность работы с драйверами Виртуальных COM портов сторонних производителей ( Eltima Virtual Serial Port Driver , Eterlogic.com Virtual Serial Ports Emulator и т.д.), что особенно важно для пользователей 64-битных версий операционных систем Vista и Windows 2008, но также может быть использовано на всех остальных системах.
  • В справочную систему добавлены рекомендации касательно корректной работы с pdf вложениями при использовании функции Почта-на-факс. Вам необходимо установить программу Acrobat Wrapper , чтобы обеспечить корректное закрытие приложения Adobe Reader после автоматической печати.

Версия 3.4.1

  • Добавлена поддержка Windows XP x64 Edition and Windows Server 2003 x64 Edition.
  • Исправлены некоторые мелкие проблемы, связанные с применением значка в системном трее. Компонент STrayIco.ocx более не используется. Функционал реализован через API.
  • Программа установки Fax Voip более не пытается установить cdosys.dll. Предполагается, что CDO (Collaboration Data Objects) теперь является частью Windows, и правильная версия библиотеки присутствует во всех поддерживаемых системах по умолчанию.
  • Добавлены новые значки для некоторых файлов. Это обеспечивает более удобный просмотр файлов в папке на Vista/2008, особенно если используется режим просмотра Крупные значки или Огромные значки.

Версия 3.3.1

  • Добавлена поддержка Windows Vista и Windows Server 2008.

Версия 3.2.1

  • Добавлена возможность изменять параметры Отображаемое Имя и Агент пользователя SIP.

Версия 3.1.1

  • Применен новый дизайн Панели управления Fax Voip. Теперь мы можем быстрее внедрять новые функции, которые предлагают добавить наши пользователи.
  • Fax Voip теперь может отправлять аудио-факсы (поверх кодека G.711). Это стало возможным благодаря применению внутреннего шлюза T38 в G711. Вы можете отправлять аудио-факсы в режиме ECM. Получение аудио-факсов внедрено в виде функции Факс-в-Tiff.
  • Добавлена возможность изменять интервал для проверки входящих сообщений электронной почты.

Версия 2.4.1

  • Теперь можно проверять Состояние SIP регистрации в Панели управления Fax Voip (с описанием ошибки).

Версия 2.3.1

  • Новая функция: Fax Voip теперь является полнофункциональной системой для отправки факсов через e-mail (Почта-на-факс) и для получения факсов на e-mail (Факс-на-почту). Новая система основана на Microsoft Fax API, таким образом Служба Microsoft Fax должна быть установлена и настроена для работы с Fax Voip на вашем компьютере.
  • Программа установки Fax Voip автоматически запускает Мастер компонентов Windows, который проверяет установлена ли Служба Microsoft Fax, и при необходимости устанавливает ее.
  • При установке COM порта, драйвер модема Standard 14400 bps Modem устанавливается и привязывается к этому порту автоматически. При удалении COM порта, модем также удаляется из вашей системы.

Версия 2.2.1

  • Новая функция: Fax Voip поддерживает перенаправление входящих факсов на e-mail. Для использования этой функции, вам следует выбрать опцию Принимать факсы как файлы. Fax Voip использует учетную запись на сервере SMTP и направляет входящие факсы на заранее заданный адрес электронной почты.

Версия 2.1.1

  • SIP модуль программы был существенно переработан. Теперь поддерживается корректная и стабильная SIP регистрация. Fax Voip был успешно протестирован на предмет стабильной работы с большим количеством SIP операторов, поддерживающих T.38. Теперь программа Fax Voip без проблем принимает входящие вызовы факсов. Вы также можете использовать Fax Voip, создав Учетную запись SIP, и зарегистрировавшись на вашей SIP PBX. Нет необходимости обеспечивать статическую маршрутизацию для входящих вызовов. Также не возникает проблем при использовании SIP прокси-сервера.
  • Появилась возможность принимать входящие факсы напрямую в файлы TIFF или PDF. Fax Voip может перенаправлять все входящие T.38 факс вызовы в TIFF или PDF файлы, не используя при этом стандартное факс программное обеспечение, и без ограничения количества одновременных входящих факс вызовов. В этом режиме, виртуальные модемы не используются и, таким образом, могут быть использованы для исходящих T.38 факс вызовов. Для удобства обработки входящих факсов было разработано и внедрено специальное приложение: Журнал Fax Voip.

Версия 1.1.3

  • Добавлена поддержка кодеков G723.1 и GSM 06.10. T.38 является специальным протоколом для передачи факсов поверх VOIP. Однако невозможно начать вызов, не используя голосовые кодеки. Если ваш SIP провайдер не поддерживает кодек G.711, вы можете использовать кодеки G.723 или GSM. Теперь можно выбрать кодеки в Панели управления Fax Voip.
  • Добавлена поддержка STUN сервера. Это очень важная функция при работе со многими SIP провайдерами. Теперь можно ввести имя STUN сервера в Панели управления Fax Voip.
  • Исправлены некоторые ошибки при использовании параметра Прокси-сервер.
  • Добавлены некоторые комментарии по поводу использования Fax Voip с AXON PBX, касательно входящих факс вызовов на Fax Voip из внешней SIP сети. При наличии проблем с приемом входящих факсов, важно включить опцию Use static IP address and static mapped ports в AXON PBX, в панели Network Settings, и ввести значения External SIP port и External RTP port starting from... . При этом нет необходимости вводить ваш Public IP address.


Установка Fax Voip T.38 Модем

  • Установка пробной версии
  • Функции
  • Системные требования
  • Удаление предыдущей версии
  • Microsoft .NET Framework 4.5
  • Запуск программы установки
  • Настройка Fax Voip T.38 Модем
  • Установка Средства просмотра фотографий в Windows Server


Установка пробной версии

Установка Fax Voip T.38 Модем ››

Программное обеспечение Fax Voip T.38 Модем может быть установлено в качестве временной пробной версии.

Fax Voip T.38 Модем позволяет вам:

  • Отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы через SIP, H.323 сети IP-телефонии и через линию ISDN CAPI 2.0 с использованием стандартных факс программ ( Служба факсов Windows / Факсы и сканирование , WinFax Pro, а также любые другие программы, умеющие работать с факс модемами или COM портами напрямую).
  • Отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы, а также голосовые сообщения через SIP, H.323 сети IP-телефонии и через линию ISDN CAPI 2.0 с использованием программ для работы с голосовыми факс-модемами ( BVRP Classic Phone Tools 9 , FaxTalk Messenger Pro 7.5 , CallStation , Venta Fax & Voice и другие).
  • Использовать функцию Почта-на-факс - Microsoft Fax . Поддержка нескольких e-mail вложений, титульные страницы , правила для почты , шаблоны электронной почты .
  • Использовать методы маршрутизации для входящих факсов - Microsoft Fax (Расширение маршрутизации Fax Voip T.38 Модем): отправить по электронной почте , сохранить в папке , печать , пользовательская маршрутизация .
  • Использовать методы маршрутизации для исходящих факсов - Microsoft Fax : уведомления о доставке по электронной почте , сохранить в папке , печать , пользовательская маршрутизация .
  • Использовать утилиту командной строки SendFaxMS.exe - Microsoft Fax для отправки факсов.

Ограничения пробной версии:

  • Пробная лицензия может быть использована один раз на данном компьютере.
  • Пробный период времени составляет 15 дней и начинает действовать с момента установки программного обеспечения.
  • Допускается использование 2-х Виртуальных COM портов (модемов).
  • Допускается использование 2-х правил для каждого метода маршрутизации для входящих факсов (Microsoft Fax) : отправить по электронной почте , сохранить в папке , печать .
  • Допускается использование 2-х правил для каждого метода маршрутизации для исходящих факсов (Microsoft Fax) : уведомления о доставке по электронной почте , сохранить в папке , печать .
  • Окно с напоминанием об использовании незарегистрированной версии появляется каждые 30 минут и останавливает программу при отсутствии действий со стороны пользователя.

Примечания

  • При покупке лицензии, используйте вкладку Лицензия в Панели управления Fax Voip T.38 Модем для активации приобретенного лицензионного ключа. Переустановка программного обеспечения не требуется. Индивидуальные настройки, сделанные для Виртуальных COM портов (модемов), параметры SIP, H.323, ISDN CAPI 2.0, настройки факса и прочие будут сохранены.
  • Лицензия Fax Voip T.38 Модем Виртуальные COM порты позволяет работать с одним или несколькими Виртуальными COM портами (модемами), отправлять и принимать факсы (T.38 и аудио), а также голосовые сообщения через SIP, H.323 или ISDN CAPI 2.0 сеть при помощи вашего факс программного обеспечения, например через Microsoft Fax.
  • Лицензия Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, Сохранить в папке, Печать) является дополнением к лицензии Fax Voip T.38 Модем Виртуальные COM порты (модемы) и не может использоваться независимо. Эта лицензия позволяет существенно увеличить максимальное количество правил, которые разрешено использовать со следующими методами маршрутизации для входящих факсов (Microsoft Fax) : отправить по электронной почте , сохранить в папке , печать и методами маршрутизации для исходящих факсов (Microsoft Fax) : уведомления о доставке по электронной почте , сохранить в папке , печать .


Функции

Установка Fax Voip T.38 Модем ››

Виртуальные COM порты (модемы)

  • До 100 Виртуальных COM портов (модемов) для подключения к стандартной факс программе напрямую или через TAPI
  • Драйвер Виртуальных COM портов, подписанный цифровой подписью Microsoft Code Signing, полностью совместимый с 64-битными версиями Windows
  • Fax Voip 14.4K TAPI Voice-Fax Modem драйвер для модемов (TAPI совместимый)
  • Поддержка драйверов Виртуальных COM портов сторонних производителей
  • Упрощенная процедура установки Виртуальных COM портов и модемов
  • Fax Class 1, UTI-T V.27ter/V.29/V.17, T.30 Fax Group 3 до 14.400 бит/с
  • Коррекция ошибок (ECM)
  • T.38 Fax через IP в режиме реального времени, T.38 UDPTL Redundancy, Force T.38 режим
  • Аудио факс поверх G.711 через IP в режиме реального времени
  • Автоматическое переключение в режим G.711 факс если T.38 не доступен
  • Аудио факс через ISDN CAPI 2.0 в режиме реального времени
  • Цветные факсы через VoIP и ISDN
  • Факс-по-запросу
  • Поддержка голосовых функций модема (UTI-T V.253 Conexant/Rockwell, аудио форматы: 16-BIT LINEAR, PCM, ALAW, ULAW)
  • Поддержка голосовых функций модема через драйвер Unimodem аудиоустройство (TAPI). Автоматическое исправление ошибок, созданных Microsoft в различных версиях Windows
  • Поддержка функций автоответчика
  • Голосовое приветствие перед отправкой или приемом факса
  • Удаленный доступ к голосовой и факс почте (DTMF)
  • Прослушивание телефонной линии через динамики компьютера
  • Набор добавочного номера (DTMF)
  • Caller ID Number, Caller ID Name (через прямое подключение к COM порту и через TAPI)
  • Номер вызываемого абонента (DID). Передача номера вызываемого абонента (DID) через строку Caller ID (обходной путь)
  • Простая интеграция со службой факсов Windows. Настройка службы факсов Windows для отправки/получения факсов через виртуальные COM порты (модемы) Fax Voip в одно действие. Автоматическая установка приложения Факсы и сканирование Windows (роли Факс-сервера) во время установки Fax Voip T.38 Модем. Создание ярлыков на рабочем столе и в меню 'Пуск'. В Windows 11 и Windows 10, автоматическое исправление ошибок в службе факсов Windows и приложении Факсы и сканирование (CallerID и TSID не сохраняются после получения факса, кнопка 'Переслать по электронной почте' неактивна)
  • Утилита командной строки SendFaxMS.exe - Microsoft Fax. Отправка факса одному или нескольким получателям. Поддержка отправки нескольких документов, титульных страниц, оригинальных уведомлений о доставке на e-mail. Отслеживание факса. Настройка и запуск SendFaxMS.exe из панели управления Fax Voip T.38 Модем

Методы маршрутизации для входящих факсов - Microsoft Fax (Расширение маршрутизации Fax Voip T.38 Модем)

  • Расширение маршрутизации Fax Voip T.38 Модем, интегрированное в Службу факсов Windows
  • Маршрутизация для входящих факсов: метод Отправить по электронной почте (Microsoft Fax). Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Маршрутизация для входящих факсов: метод Сохранить в папке (Microsoft Fax). Настраиваемые шаблоны имен файлов
  • Маршрутизация для входящих факсов: метод Печать (Microsoft Fax)
  • Пользовательская маршрутизация входящих факсов (Microsoft Fax)

Методы маршрутизации для исходящих факсов - Microsoft Fax

  • Маршрутизация для исходящих факсов: метод Уведомления о доставке по электронной почте (Microsoft Fax). Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Маршрутизация для исходящих факсов: метод Сохранить в папке (Microsoft Fax). Настраиваемые шаблоны имен файлов
  • Маршрутизация для исходящих факсов: метод Печать (Microsoft Fax)
  • Пользовательская маршрутизация исходящих факсов (Microsoft Fax)

SIP / H.323 / ISDN CAPI 2.0

  • Поддержка SIP через UDP, SIP через TCP и SIP через TLS
  • SIP прокси-сервер
  • Поддержка нескольких учетных записей SIP (Одновременные SIP регистрации), Имя пользователя для авторизации, Домен/Realm, SIP контакт URL, Таймаут регистрации, принудительная регистрация
  • Прямая маршрутизация SIP вызовов
  • Возможность изменять Агента пользователя SIP
  • Поддержка H.323, Fast Start, H.245 Tunneling, Список телефонных номеров
  • Регистрация на H.323 гейткипере, Поиск гейткипера, Время жизни
  • H.235 MD5 аутентификация при регистрации на гейткипере
  • Прямая маршрутизация H.323 вызовов
  • Поддержка ISDN CAPI 2.0
  • Прямая маршрутизация вызовов ISDN CAPI 2.0
  • Выбор номера ISDN контроллера и B-канала для исходящих вызовов через ISDN CAPI 2.0
  • Поддержка схемы Tel URI (только с SIP)
  • VOIP аудио форматы: G.711-uLaw-64k, G.711-ALaw-64k, G.723.1, G.726-32k, GSM-06.10, iLBC, SpeexNB, SpeexWB
  • CAPI 2.0 аудио форматы: CCITT G.711 A-law, CCITT G.711 u-law
  • Ложный G.729 кодек для совместимости с T.38
  • Поддержка STUN сервера
  • Маршрутизация исходящих и входящих VOIP вызовов
  • Переопределение параметров через маршрутизацию вызовов: Имя пользователя (Caller ID Number), Отображаемое имя (Caller ID Name), Максимальная скорость передачи факса, ECM, T38 UDPTL Redundancy, Кодеки

Поддержка E-mail: почта-на-факс, факс-на-почту, уведомления о доставке

  • Почта-на-факс - Microsoft Fax. Поддержка нескольких вложений e-mail. Титульные страницы, сведения об отправителе
  • Правила для почты (почта-на-факс) - Microsoft Fax. Переопределение параметров в зависимости от адреса e-mail: правила набора номера, уведомления о доставке, вложения электронной почты, титульные страницы, сведения об отправителе, шаблоны электронной почты, важность и время отправки факса. Блокирование нежелательных адресов электронной почты
  • Настройка почтовой службы Fax Voip T.38 Модем для запуска под учетной записью обычного пользователя вместо учетной записи локальной системы
  • Факс-на-почту (метод маршрутизации 'Отправить по электронной почте') - с использованием Службы Microsoft Fax. Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Уведомления о доставке на e-mail - Microsoft Fax (Маршрутизация исходящих факсов: метод Уведомления о доставке по электронной почте). Шаблоны электронной почты. Настраиваемые шаблоны имен файлов для прикрепляемых факсов
  • Настраиваемые шаблоны электронной почты. Настраиваемые форматы даты и времени
  • Поддержка SMTP. Поддержка OAuth 2.0 (современная проверка подлинности). SecureSmtpClient, CDO.Message, System.Net.Mail. Implicit SSL, Explicit SSL (STARTTLS). Поддержка TLS версии 1.2. Кодировка UTF-8
  • Отправка сообщений электронной почты подписанных цифровой подписью. Прозрачная подпись. Непрозрачная подпись
  • Поддержка POP3/IMAP. Поддержка OAuth 2.0 (современная проверка подлинности). Поддержка SSL. Поддержка TLS версии 1.2
  • Игнорирование недействительного SSL сертификата сервера электронной почты

Прочее

  • Панель управления Fax Voip T.38 Модем. Интерфейс ленты (Ribbon)
  • Диспетчер Fax Voip T.38 Модем
  • Возможность работы в качестве Службы Windows
  • Прямая конвертация документа в формат факса. Поддерживаемые форматы: PDF, TIFF, SFF, QFX, BMP, JPEG, GIF, PNG, ICO, WMF (EMF)
  • Функция 'Исправить команды printto'. Поддерживаемые форматы: TXT, BMP, DIB, EMF, GIF, ICO, JFIF, JPE, JPEG, JPG, JXR, PNG, RLE, TIF, TIFF, WDP, WMF
  • Многоязычная поддержка. Простой механизм для перевода программы на любой язык
  • Поддержка Адресной книги (Контакты Windows)
  • Проверка на наличие новых версий программы
  • Мастер архивации и восстановления Fax Voip T.38 Модем
  • Выборочное сохранение настроек и данных пользователя при переустановке программы
  • Поддержка Юникод
  • Полная совместимость с визуальными стилями операционной системы
  • Русскоязычный интерфейс*
  • Руководство пользователя на русском языке*

Примечания

  • (* : Файлы поддержки русского языка устанавливаются только при использовании русскоязычного инсталлятора (не поставляются со стандартной версией на английском языке).


Системные требования

Установка Fax Voip T.38 Модем ››

Поддерживаемые платформы*

  • Windows 11
  • Windows 10, Windows 10 64-бит
  • Windows Server 2022, Windows Server 2019, Windows Server 2016
  • Windows 8.1, Windows 8.1 64-бит, Windows Server 2012 R2 **
  • Windows 8, Windows 8 64-бит, Windows Server 2012 **
  • Windows 7, Windows 7 64-бит, Windows Server 2008 R2 **

  • Intel-совместимый компьютер с 32-битным или 64-битным (x64) процессором.
  • Microsoft.NET Framework 4.5 или более поздний

Дополнительные системные требования

  • Служба факсов Windows (Факсы и сканирование Windows)
  • Средство просмотра фотографий Windows
  • Adobe Acrobat Reader 11, Reader DC 2023 или более ранние версии
  • Acrobat Wrapper v.11.2.0.51 или более поздние версии (чтобы использовать PDF в качестве e-mail вложений с функцией Почта-на-факс)
  • IrfanView Software (для просмотра факсов в формате SFF)

Виртуальные COM порты – совместимое программное обеспечение

  • Eltima Virtual Serial Port Driver
  • Eterlogic.com Virtual Serial Ports Emulator

Fax & Voice – совместимое программное обеспечение

  • CallStation (поддержка голосовых функций через TAPI)
  • BVRP Classic Phone Tools 9
  • FaxTalk Messenger Pro 7.5
  • Venta Fax & Voice
  • VK Easy Fax

Fax – совместимое программное обеспечение

  • Microsoft Fax (Факсы и сканирование Windows)
  • WinFax PRO
  • GFI FAXmaker
  • RelayFax
  • FaxAmatic

Рекомендуемые операторы VOIP

  • YouMagic (МТТ) (поддержка T.38)
  • Телфин (поддержка T.38)
  • Мультифон (Мегафон) (только факс поверх кодека G.711)
  • T38FAX (США, поддержка T.38)
  • CALLCentric (США, поддержка T.38)
  • babyTEL (США/Канада, поддержка T.38)
  • MondoTalk (Австралия, поддержка T.38)
  • DellMont (Betamax) : VoipBuster , Nonoh и другие (только факс поверх кодека G.711, качество сильно зависит от страны)

SIP PBX – совместимое программное обеспечение

  • Axon PBX
  • 3CX VOIP Phone System (Enterprise Edition)

H.323 – совместимое программное обеспечение

  • GNU Gatekeeper
  • SoLink Control Server

Требования к сети

  • Сетевое подключение локального компьютера к SIP или H.323 серверу

Примечания

  • (* : Компания FaxVoip Software не дает никаких гарантий и не несет никакой ответственности, если программа Fax Voip T.38 Модем не будет работать правильно, будучи установленной на Виртуальную машину любого типа. В случае возникновения специфических проблем при подобных установках, техническая поддержка не предоставляется.
  • (** : Ограниченная поддержка. Некоторые функции могут не работать или работать неправильно. Операционные системы Windows 7 и Windows 8/8.1 больше не поддерживаются корпорацией Майкрософт.


Удаление предыдущей версии

Установка Fax Voip T.38 Модем ››

Установщик Fax Voip T.38 Модем автоматически проверяет, не установлен ли Fax Voip T.38 Модем или старая версия Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней) и какая версия установлена, и предлагает удалить Fax Voip T.38 Модем (Fax Voip T38 Fax & Voice) перед началом новой установки. Таким образом, нет необходимости отдельно запускать стандартную процедуру деинсталляции.

Чтобы сохранить предыдущие настройки Fax Voip T.38 Модем, а также файлы, созданные в процессе работы программы, следуйте инструкциям главы Удаление программного обеспечения Fax Voip T.38 Модем настоящего справочного руководства. Если вы подозреваете, что ваша конфигурация повреждена по какой-то причине, вы должны удалить предыдущие настройки. Кроме того, до удаления или переустановки программы, вы можете запустить Мастер архивации и восстановления Fax Voip T.38 Модем , что позволит сохранить, а в дальнейшем восстановить ваши параметры и файлы.

При обновлении с Fax Voip T38 Fax & Voice версии 8.3.1 или более ранней, предыдущие параметры и файлы импортируются автоматически и без дополнительных подтверждений, если вы устанавливаете Fax Voip T.38 Модем в первый раз. Если по какой-то причине вам необходимо повторить процедуру, вы можете удалить параметр Upgrade9 (REG_DWORD) из раздела HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\FaxVoip\T38Modem в реестре Windows, а затем повторно запустить программу установки Fax Voip T.38 Модем.

Чтобы сохранить вашу старую конфигурацию (Fax Voip T38 Fax & Voice версии 8 или более ранней), запустите Мастер архивации и восстановления Fax Voip (включен в Fax Voip T38 Fax & Voice версии 8 или более ранней) до того как удалить предыдущую версию. См. также в главе Использование мастера архивации и восстановления Fax Voip T.38 Модем с предыдущими версиями настоящего справочного руководства.


Microsoft .NET Framework 4.5

Microsoft .NET Framework 4.5 или более поздней версии

Установка Fax Voip T.38 Модем ››

Основные модули Fax Voip T.38 Модем написаны на языке C/C ++ и на самом деле не используют Microsoft .Net Framework. Все необходимые компоненты среды выполнения библиотек C++, установлены во всех поддерживаемых операционных системах по умолчанию.

Для работы графического интерфейса пользователя (GUI) и некоторых других модулей требуется установка Microsoft .Net Framework 4.5 или более поздней версии.

Microsoft .Net Framework 4.8 (совместимый с .Net Framework 4.5) включен в Windows 11 и Windows Server 2022. Установка .NET Framework для этих операционных систем не требуется.

Microsoft .Net Framework 4.6-4.8 (совместимый с .Net Framework 4.5) включен в Windows 10, Windows Server 2019 и Windows Server 2016. Установка .NET Framework для этих операционных систем не требуется. Установленная версия .Net Framework зависит от версии Windows 10, подробнее см. Версии и зависимости платформы .NET Framework .

Microsoft .Net Framework 4.5.1 (совместимый с .Net Framework 4.5) включен в Windows 8.1 и Windows Server 2012R2. Установка .NET Framework для этих операционных систем не требуется.

Microsoft .Net Framework 4.5 включен в Windows 8 и Windows Server 2012. Установка .NET Framework для этих операционных систем не требуется.

При установке на компьютер с Windows 7 или Windows Server 2008R2, для нормальной работы Fax Voip T.38 Модем требуется, чтобы Microsoft .NET Framework 4.5 или более поздней версии был установлен на вашем компьютере. Вам следует убедиться, что Microsoft .NET Framework 4.5 уже установлен и установить его при необходимости. Это может быть сделано перед установкой программы Fax Voip T.38 Модем или в процессе установки.

Для проверки необходимости установки .NET Framework 4.5

1. Из меню Пуск выберите Панель управления. В Панели управления выберите Программы, а затем нажмите Удаление программы.

2. В окне Удаление или изменение программы пролистайте список приложений, чтобы увидеть, есть ли в нем Microsoft .NET Framework 4.5 или более поздней версии.

3. Закройте окно.

Установка .NET Framework 4.5 в ручном режиме

Вы можете скачать веб-установщик Microsoft .NET Framework 4.5 с web-сайта Fax Voip T.38 Модем.

1. Перейдите на веб-сайт Fax Voip T.38 Модем на страницу загрузки .

2. Найдите и воспользуйтесь следующей ссылкой:

Microsoft .Net Framework 4.5 dotNetFx45_Full_setup.exe 982КБ

3. После того как вы скачаете установочный файл, запустите его и установите .NET Framework 4.5 на ваш компьютер. Заметим, что установку следует осуществлять от имени Администратора.

Установка .NET Framework через Центр обновления Windows

Microsoft рекомендует производить установку или обновление .NET Framework через Центр обновления Windows. Чтобы установить или обновить .NET Framework 4.5 на вашем компьютере с Windows 7 или Windows Server 2008R2, выполните следующие шаги:

1. Из меню Пуск выберите Все программы, а затем нажмите Центр обновления Windows.

2. На странице Центр обновления Windows нажмите Поиск обновлений чтобы найти все доступные обновления.

3. После завершения поиска, нажмите на ссылку Важных обновлений:... доступны в панели Загрузка и установка обновлений для компьютера.

4. Выберите обновление Microsoft .NET Framework 4.5 (4.5.1, 4.5.2...) как показано на рисунке ниже, а затем нажмите OK.

5. На следующей странице нажмите кнопку Установить обновления.

6. Программа Центр обновления Windows автоматически загрузит и установит выбранные обновления.

7. После установки .NET Framework 4.5, рекомендуется повторить процедуру обновления для получения последней версии .NET Framework со всеми исправлениями и дополнениями. На странице Центр обновления Windows нажмите Поиск обновлений.

8. По окончании поиска, отметьте обновления, касающиеся пакета Microsoft .NET Framework 4.5 а затем нажмите кнопку OK.

9. На следующей странице нажмите кнопку Установить обновления.

10. Программа Центр обновления Windows автоматически загрузит и установит выбранные обновления.

Установка .NET Framework при запуске программы установки

При установке на компьютер с Windows 7 или Windows Server 2008R2, установщик Fax Voip T.38 Модем автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена. Если Microsoft .NET Framework 4.5 не установлен, программа установки предложит установить Microsoft .NET Framework.

Выберите один из предлагаемых вариантов и нажмите Далее:

Установить .NET Framework 4.5 и продолжить установку (рекомендовано)

При выборе этой опции, запускается программа установки Microsoft .NET Framework 4.5, включенная в установочный пакет Fax Voip T.38 Модем. Примите условие лицензионного соглашения и нажмите кнопку Установить. Следует учесть, что все необходимые компоненты загружаются с веб-сайта Microsoft в процессе установки и это может занять значительное время.

По завершению установки .NET Framework 4.5, вы сможете продолжить установку Fax Voip T.38 Модем.

Открыть Windows Update для загрузки и установки последней версии .NET Framework

При выборе этой опции, открывается окно Windows Update. Установите последнюю версию Microsoft .NET Framework через Windows Update как описано выше. По завершению установки .NET Framework 4.5, вам следует запустить установщик Fax Voip T.38 Модем повторно.

Примечания

  • Требуемая версия Microsoft .NET Framework уже включена в Windows 11, Windows 10, Windows 8/8.1, Windows Server 2022, Windows Server 2019, Windows Server 2016 и Windows Server 2012/2012R2. Установка .NET Framework для этих операционных систем не требуется.
  • В Windows 7 или Windows Server 2008R2, установщик Fax Voip T.38 Модем автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена, и предлагает утановить правильную версию, если она не установлена.


Запуск программы установки

Установка Fax Voip T.38 Модем ››

Чтобы установить Fax Voip T.38 Модем, следуйте инструкциям ниже:

1. Запустите файл setup.exe с установочного диска Fax Voip T.38 Модем или ZIP архива.

2. При установке на компьютер с Windows 7 или Windows Server 2008R2, установщик Fax Voip T.38 Модем автоматически проверяет, установлен ли Microsoft .NET Framework на вашем компьютере и какая версия установлена. Если Microsoft .NET Framework 4.5 не установлен, программа установки предложит установить Microsoft .NET Framework, подробнее см. главу Microsoft .NET Framework 4.5 настоящего справочного руководства.

3. Программа установки Fax Voip T.38 Модем автоматически проверяет, не установлен ли уже Fax Voip T.38 Модем или старая версия Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней) и какая версия установлена, и предлагает удалить Fax Voip T.38 Модем (Fax Voip T38 Fax & Voice) перед началом новой установки. Для продолжения установки нажмите Далее. При переустановке или обновлении программы, вы можете выбрать, какие предыдущие настройки и файлы, созданные в процессе работы программы должны быть сохранены, подробнее см. в главе Удаление программного обеспечения Fax Voip T.38 Модем настоящего справочного руководства. При обновлении с Fax Voip T38 Fax & Voice версии 8.3.1 или более ранней, предыдущие параметры и файлы импортируются автоматически и без дополнительных подтверждений, если вы устанавливаете Fax Voip T.38 Модем в первый раз, подробнее см. в главе Удаление предыдущей версии настоящего справочного руководства.

Дождитесь окончания удаления предыдущей версии.

4. В окне, сообщающем о готовности начать установку Fax Voip T.38 Модем, нажмите Далее.

5. Далее запускается основной Мастер установки Fax Voip T.38 Модем.

6. Нажмите Далее. Следуйте инструкциям мастера. На странице Все готово для начала установки нажмите Установить.

7. По окончании копирования файлов, мастер установит Драйвера Fax Voip для Виртуальных COM портов.

8. Далее программа установки запускает процедуру Установки модемов.

9. Мастер автоматически установит драйвера Fax Voip 14.4K TAPI Voice-Fax Modem для виртуальных модемов. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема.

10. Мастер автоматически установит Виртуальные COM порты.

11. По умолчанию Fax Voip T.38 Модем устанавливает два порта с номерами COM20 и COM21.

12. Программа установки проверяет, установлена ли Служба факсов Windows на вашем компьютере и выводит соответствующее диалоговое окно, если не установлена. Чтобы установить Службу факсов Windows, нажмите OK. Чтобы установить Службу факсов Windows вручную, см. главу Установка службы факсов настоящего справочного руководства.

13. В Windows 11 и поздних версиях Windows 10, компонент Факсы и сканирование Windows всегда установлен и не может быть удален в Компонентах Windows. В Windows 10 (ранние версии), Windows 8/8.1 и Windows 7, программа установки Fax Voip T.38 Модем автоматически установит компонент Факсы и сканирование Windows.

14. В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2, программа установки Fax Voip T.38 Модем автоматически установит роль Факс-сервера.

15. В Windows 2012/2012R2 и Windows 2008R2, программа установки Fax Voip T.38 Модем дополнительно устанавливает компонент Возможности рабочего стола, если он не установлен.

16. Программа установки Fax Voip T.38 Модем автоматически настраивает Службу факсов Windows, а затем запускает службы. В процессе настройки, Служба факсов Windows может быть перезапущена несколько раз. Подробности см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

17. В заключительном окне Мастера установки Fax Voip T.38 Модем выберите Да, перезагрузить компьютер сейчас, а затем нажмите Готово.

Примечания

  • Перезагрузка операционной системы после установки Виртуальных COM портов и модемов не всегда необходима. Тем не менее, не рекомендуется игнорировать этот шаг, поскольку некоторые программы могут не правильно взаимодействовать с драйверами модемов непосредственно после установки.


Настройка Fax Voip T.38 Модем

Установка Fax Voip T.38 Модем ››

При первом запуске Fax Voip T.38 Модем, Панель управления Fax Voip T.38 Модем должна появиться на экране. После установки программы и перезагрузки компьютера, Fax Voip T.38 Модем обычно запускается автоматически. Если по каким-либо причинам этого не произошло, вы можете запустить Fax Voip T.38 Модем вручную. Для этого в меню Пуск последовательно выберите Fax Voip T.38 Modem и выполните команду Fax Voip T.38 Modem, либо воспользуйтесь ярлыком Fax Voip T.38 Modem на рабочем столе.

В большинстве случаев, открывается вкладка Виртуальные COM порты и модемы. Здесь отображается список установленных Виртуальных COM портов Fax Voip (обычно COM20 и COM21) и модемов, привязанных к этим портам.

Чтобы настроить Fax Voip T.38 Модем для работы по протоколу SIP, следуйте инструкциям в разделе Настройка линии SIP .

Чтобы настроить Fax Voip T.38 Модем для работы по протоколу H.323, следуйте инструкциям в разделе Настройка линии H.323 .

Чтобы настроить Fax Voip T.38 Модем для работы с линией ISDN CAPI 2.0, следуйте инструкциям в разделе Настройка линии ISDN CAPI 2.0 .


Настройка линии SIP

Установка Fax Voip T.38 Модем ›› Настройка Fax Voip T.38 Модем ››

В данной главе показано, как быстро настроить Fax Voip T.38 Модем для работы с SIP провайдером на примере Российского провайдера IP-телефонии YouMagic (проект оператора МТТ ), который качественно поддерживает передачу факсов по T.38, а также предоставляет прямые телефонные номера в Москве и некоторых других городах, что удобно с точки зрения организации входящей факсимильной связи с использованием Fax Voip T.38 Модем. Другим примером SIP провайдера с поддержкой T.38 является Телфин . Аудио факс (факс поверх кодека G.711) поддерживается в таких сетях как Мультифон (проект оператора сотовой связи Мегафон ) и VoipBuster (либо его аналоги). С примерами подключения к конкретным SIP операторам вы можете ознакомиться в главе Примеры настройки с операторами VoIP настоящего справочного руководства.

Для быстрой настройки работы Fax Voip T.38 Модем по протоколу SIP, выполните следующие шаги:

1. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония.

2. Поставьте флажок у параметра Включить SIP.

3. (Опционально). В поле Сервер STUN введите имя STUN сервера, если это необходимо в силу особенностей вашей сети или рекомендовано вашим SIP провайдером. (Примеры: 'stun.voipbuster.com', 'stun.sipnet.ru', 'sip.mtt.ru',...).

4. Нажмите кнопку <Применить>.

5. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите SIP.

6. В полях Интерфейс SIP/UDP, Интерфейс SIP/TCP и Интерфейс SIP/TLS выберите из списка или введите адреса сетевых интерфейсов для прослушивания SIP запросов через UDP, TCP и TLS. В полях для указания порта, введите номера портов. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Во избежание конфликтов, при выборе номера порта, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP. По умолчанию, Fax Voip T.38 Модем использует порты 5070 для UDP и TCP, и порт 5061 для TLS. Если вы не планируете использовать SIP через TCP или SIP через TLS, вы можете снять галочки у параметров Включить SIP через TCP и Включить SIP через TLS.

7. Нажмите кнопку <Применить>.

8. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

9. Чтобы добавить Учетную запись SIP, нажмите Добавить.

10. В окне Учетная запись SIP, введите ваше имя пользователя (SIP-ID) и пароль, соответственно в поля Имя пользователя и Пароль.

11. В поле Сервер регистрации, введите имя или IP-адрес SIP сервера регистрации. Может также содержать номер порта. Если сервер регистрации использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.voipbuster.com', 'voip.mtt.ru', 'sip.telphin.com:5068', '192.168.0.5:5065', ...).

12. (Опционально). В поле Прокси-сервер введите имя или IP-адрес SIP прокси-сервера, используемого для регистрации. Может также содержать номер порта. Если используется порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.myproxy.com', 'voice.telphin.com:5068', '192.168.1.3:5065', ...).

13. (Опционально). Нажмите кнопку <Подробно>.

14. (Опционально). При необходимости заполните поля Имя пользователя для авторизации, Домен/Realm и SIP контакт URL. Заметим, что обычно следует оставлять эти поля пустыми. Неправильные данные в этих полях могут привести к проблемам при осуществлении SIP регистрации и при входящих вызовах.

15. В поле Таймаут регистрации измените значение таймаута (если это необходимо). По умолчанию используется таймаут 180 секунд.

16. При необходимости выберите Транспорт. По умолчанию используется SIP через UDP. Заметим, что SIP через TCP и SIP через TLS могут не поддерживаться на стороне вашего SIP провайдера.

17. Нажмите кнопку <OK> чтобы зафиксировать изменения.

18. Ваша Учетная запись SIP будет отображена в Списке учетных записей SIP. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP.

19. Вам будет предложено создать правила Маршрутизации исходящих VOIP вызовов. Нажмите кнопку <Да>, чтобы создать правила по умолчанию.

20. Будет отображена вкладка Маршрутизация исходящих VOIP вызовов. Правило по умолчанию означает, что все исходящие вызовы с любого Виртуального COM порта (модема) маршрутизируются с использованием первой Учетной записи SIP без преобразования набираемого номера с поддержкой как T.38, так и аудио (факс поверх кодека G.711) режимов факса.

21. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите Входящие маршруты. Будет отображена вкладка Маршрутизация входящих VOIP вызовов. Убедитесь, что в настройках присутствует правило, обрабатывающее входящие вызовы SIP (правило по умолчанию создается в процессе установки Fax Voip T.38 Модем). Правило по умолчанию для входящих SIP вызовов означает, что все входящие вызовы из любой SIP сети будут маршрутизированы на Виртуальные COM порты (модемы) и без преобразования телефонного номера.

22. В Панели управления Fax Voip T.38 Модем нажмите кнопку <СТАРТ> чтобы протестировать SIP регистрацию с вашим SIP провайдером.

23. Состояние регистрации вашей Учетной записи SIP будет отображено в столбце Статус регистрации в Списке учетных записей SIP. Если настройки выполнены правильно, вы увидите сообщение 'Зарегистрирован'.


Настройка линии H.323

Установка Fax Voip T.38 Модем ›› Настройка Fax Voip T.38 Модем ››

В данной главе показано, как быстро настроить Fax Voip T.38 Модем для работы по H.323. Большинство провайдеров, предоставляющих услуги IP-телефонии по протоколу H.323, используют аутентификацию пользователя по его IP-адресу. Для настройки Fax Voip T.38 Модем в этом случае обычно достаточно выбрать вариант работы Не использовать гейткипер и указать имя или IP-адрес узла H.323 вашего поставщика услуг в поле Шлюз H.323 при создании правила Маршрутизации исходящих VOIP вызовов.

В некоторых случаях может потребоваться регистрация на H.323 гейткипере. Для настройки Fax Voip T.38 Модем в этом случае необходимо выбрать вариант работы Использовать гейткипер, указать IP-адрес гейткипера и выбрать опцию Набор номера через гейткипер при создании правила Маршрутизации исходящих VOIP вызовов. При регистрации на гейткипере может потребоваться H.235 аутентификация с логином и паролем. На рисунках ниже используется пример такого подключения по H.323 c авторизацией по логину и паролю. Использование H.235 аутентификации удобно для случая динамического IP-адреса компьютера.

Для быстрой настройки работы Fax Voip T.38 Модем по протоколу H.323, выполните следующие шаги:

1. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония.

2. Поставьте флажок у параметра Включить H.323.

3. (Опционально). В поле Сервер STUN введите имя STUN сервера, если это необходимо в силу особенностей вашей сети или рекомендовано вашим H.323 провайдером. (Примеры: 'stun.voipbuster.com', 'stun.sipnet.ru', 'sip.mtt.ru',...).

4. Нажмите кнопку <Применить>.

5. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите H.323.

6. В поле Интерфейс H.323, выберите из списка или введите адрес сетевого интерфейса для прослушивания H.323 запросов. В поле для указания порта, введите номер порта. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Во избежание конфликтов, при выборе номера порта, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по H.323. По умолчанию, Fax Voip T.38 Модем использует порт 1720.

7. Сделайте необходимые настройки параметров Включить Fast Start и Включить H.245 Tunneling, согласно требованиям вашей H.323 сети.

8. Добавьте ваш H.323 телефонный номер в список Номера телефонов. Для добавления номера нажмите кнопку <Добавить>. Телефонные номера, заданные в этом списке, используются в процессе регистрации с H.323 гейткипером (список телефонных номеров на которые возможны входящие звонки). Во время исходящего вызова H.323, верхний номер из этого списка будет передан удаленной стороне как Caller ID Number.

9. Нажмите кнопку <Применить>.

10. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите H.323, затем нажмите Гейткипер.

11. Сделайте необходимые настройки нижеперечисленных параметров:

Режим гейткипера

Не использовать гейткипер (по умолчанию)

В этом режиме Fax Voip T.38 Модем функционирует как независимый H.323 узел и не регистрируется на H.323 гейткипере. Все входящие H.323 вызовы должны быть маршрутизированы непосредственно на IP-адрес и порт на котором работает Fax Voip T.38 Модем. Этот режим предпочтителен в случае когда H.323 провайдер использует ваш IP-адрес для идентификации (наиболее распространенный метод привязки используемый для аутентификации).

Использовать если доступен

Fax Voip T.38 Модем пытается зарегистрироваться на H.323 гейткипере. Если это невозможно, Fax Voip T.38 Модем функционирует как независимый H.323 узел без регистрации на H.323 гейткипере.

Использовать гейткипер

В этом режиме Fax Voip T.38 Модем должен быть зарегистрирован на H.323 гейткипере.

Поиск гейткипера

В этом режиме Fax Voip T.38 Модем способен найти H.323 гейткипер автоматически. Опция полезна при регистрации на гейткипере расположенном в вашей локальной сети.

Адрес

IP-адрес или имя сервера где находится H.323 гейткипер.

Время жизни

Продолжительность времени (в секундах) в течении которого действительна регистрация на H.323 гейткипере. Заметим, что этот параметр может быть переопределен самим гейткипером в процессе регистрации.

H.235 аутентификация

Поставьте галочку если для регистрации на гейткипере необходима аутентификация. Аутентификация осуществляется согласно стандарта H.235 и MD5 алгоритма хэширования.

Логин

H.235 логин для авторизации.

Пароль

H.235 пароль для авторизации.

12. Чтобы иметь возможность совершать исходящие H.323 вызовы, необходимо создать правила Маршрутизации исходящих VOIP вызовов. Заметим, что Fax Voip T.38 Модем не создает правила для исходящих H.323 вызовов автоматически. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите Исходящие маршруты.

13. Для добавления нового правила Маршрутизации исходящих VOIP вызовов нажмите Добавить.

14. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в области Маршрутизировать вызов, в группе VOIP протокол, выберите опцию H.323. Выберите вариант Шлюз H.323 и задайте имя или IP-адрес H.323 узла, на который следует маршрутизировать H.323 вызовы. Либо выберите вариант Набор номера через гейткипер, чтобы маршрутизировать вызовы через H.323 гейткипер. Нажмите кнопку <OK>.

15. На рисунке ниже все исходящие вызовы будут маршрутизированы через H.323 гейткипер. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов.

16. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите Входящие маршруты. Будет отображена вкладка Маршрутизация входящих VOIP вызовов. Убедитесь, что в настройках присутствует правило, обрабатывающее входящие вызовы H.323 (правило по умолчанию создается в процессе установки Fax Voip T.38 Модем). Правило по умолчанию для входящих H.323 вызовов означает, что все входящие вызовы из любой H.323 сети будут маршрутизированы на Виртуальные COM порты (модемы) и без преобразования телефонного номера.

17. Для тестирования регистрации на H.323 гейткипере (если сделаны соответствующие настройки), в Панели управления Fax Voip T.38 Модем нажмите кнопку <СТАРТ>.

18. Если используется регистрация на H.323 гейткипере, состояние H.323 регистрации будет отображаться на вкладке Гейткипер. Если настройки выполнены правильно, вы увидите сообщение 'RegistrationConfirm' в области Статус гейткипера.


Настройка линии ISDN CAPI 2.0

Установка Fax Voip T.38 Модем ›› Настройка Fax Voip T.38 Модем ››

Для работы с телефонной линией ISDN через интерфейс CAPI 2.0, вам необходимо приобрести ISDN карту для вашего компьютера и установить CAPI 2.0 драйвер (capi2032.dll), который поставляется производителем вашей ISDN карты. Следует также понимать, что некоторые драйвера CAPI 2.0 не позволяют одновременное использование интерфейса CAPI 2.0 более чем одним приложением CAPI 2.0.

Для быстрой настройки работы Fax Voip T.38 Модем для работы с линией ISDN CAPI 2.0, выполните следующие шаги:

1. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония.

2. Поставьте флажок у параметра Включить ISDN CAPI.

3. Нажмите кнопку <Применить>.

4. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите ISDN CAPI 2.0.

5. В поле Кодек, выберите G.711 кодек который должен использоваться в вашей системе. CAPI 2.0 приложения работают с голосовыми данными в формате G.711 A-law или G.711 u-law. Вам следует предварительно выяснить, который из этих двух кодеков используется в настройках вашей ISDN карты.

6. Нажмите кнопку <Применить>.

7. Чтобы иметь возможность совершать исходящие ISDN CAPI 2.0 вызовы, необходимо создать правила Маршрутизации исходящих VOIP вызовов. Заметим, что Fax Voip T.38 Модем не создает правила для исходящих ISDN вызовов автоматически. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите Исходящие маршруты.

8. Для добавления нового правила Маршрутизации исходящих VOIP вызовов нажмите Добавить.

9. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в области Маршрутизировать вызов, в группе VOIP протокол, выберите опцию ISDN CAPI 2.0. Нажмите кнопку <OK>.

10. На рисунке ниже мы создали правило для исходящих ISDN CAPI 2.0 вызовов: все исходящие вызовы с любого Виртуального COM порта (модема) маршрутизируются через линию ISDN CAPI 2.0 без преобразования набираемого номера с поддержкой аудио факса (факс поверх кодека G.711). Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов.

11. В дереве Панели управления Fax Voip T.38 Модем нажмите IP-телефония, затем нажмите Входящие маршруты. Будет отображена вкладка Маршрутизация входящих VOIP вызовов. Убедитесь, что в настройках присутствует правило, обрабатывающее входящие ISDN CAPI 2.0 вызовы (правило по умолчанию создается в процессе установки Fax Voip T.38 Модем). Правило по умолчанию для входящих ISDN CAPI 2.0 вызовов означает, что все входящие вызовы с ISDN линии будут маршрутизированы на Виртуальные COM порты (модемы) и без преобразования телефонного номера.

12. Для проверки подключения к вашей ISDN карте, в Панели управления Fax Voip T.38 Модем нажмите кнопку <СТАРТ>.

13. Если настройки выполнены правильно, в области Профиль CAPI вы должны увидеть сообщение 'Состояние: Подключено'. В панели Профиль CAPI также отображается информация о производителе CAPI драйвера, версии CAPI (включая версию производителя), число ISDN контроллеров и число доступных B-каналов для каждого контроллера.


Настройка линий факсов

Установка Fax Voip T.38 Модем ›› Настройка Fax Voip T.38 Модем ››

Для отправки и приема факсов и голосовых сообщений через Виртуальные COM порты (модемы), необходимо чтобы внешнее факс программное обеспечение было установлено на вашем компьютере и настроено для работы с Fax Voip T.38 Модем. Fax Voip T.38 Модем поддерживает работу с любой стандартной факс программой, которая может работать с COM портами напрямую или через драйвер модема. Примеры настроек и использования с различными факс программами подробно рассмотрены в главе Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами настоящего справочного руководства. Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .

При настройке Fax Voip T.38 Модем, обратите внимание на параметр Перезапускать службу Microsoft Fax при запуске Fax Voip T.38 Модем (в дереве Панели управления Fax Voip T.38 Модем нажмите Факс). Эту опцию рекомендуется включать в случае если Fax Voip T.38 Модем работает совместно со Службой факсов Windows. Если опция включена, то всякий раз при запуске Fax Voip T.38 Модем Служба факсов Windows перезапускается. Если вы используете Fax Voip T.38 Модем с другой факс программой, например с FaxTalk Messenger Pro 7.5, не используйте эту опцию и снимите галочку.

Более подробную информацию об отправке и получении факсов с использованием электронной почты, можно найти в главах Почта-на-факс - Microsoft Fax , Маршрутизация входящих факсов: отправить по электронной почте (Microsoft Fax) и Маршрутизация исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax) настоящего справочного руководства. Мы рекомендуем настраивать эти функции только после того, как вы успешно настроите Fax Voip T.38 Модем для отправки и получения факсов.

Для настройки различных дополнительных функций Fax Voip T.38 Модем, следует руководствоваться информацией в соответствующих главах настоящего справочного руководства.


Установка Средства просмотра фотографий в Windows Server

Установка Средства просмотра фотографий в Windows Server 2012R2

Установка Fax Voip T.38 Модем ››

Для просмотра факсов (файлы формата TIFF), обычно используется приложение Средство просмотра фотографий Windows. Обратите внимание, что это приложение обычно не устанавлено по умолчанию в Windows Server 2012/2012R2 и Windows Server 2008R2.

Чтобы установить Средство просмотра фотографий Windows в Windows Server 2012/2012R2 или Windows Server 2008R2, вам необходимо установить компонент Возможности рабочего стола.

1. Переключитесь на панель Поиск, наберите диспетчер серверов, а затем нажмите Диспетчер серверов.

2. В Диспетчере серверов, выберите Добавить роли и компоненты.

3. В окне Мастера добавления ролей и компонентов, на странице Выбор компонентов, поставьте флажок около компонента Возможности рабочего стола.

4. Нажмите Далее, а затем нажмите Установить.

5. По завершении установки, Windows уведомит вас о необходимости перезагрузки сервера для завершения процесса установки.

6. После перезагрузки убедитесь, что Средство просмотра фотографий Windows установлено. На компьютере с Windows Server 2012R2, щелкните правой кнопкой мыши кнопку Пуск, а затем нажмите Выполнить. В окне Выполнить, введите следующую команду: rundll32 shimgvw.dll,ImageView_Fullscreen. Нажмите OK. Приложение Средство просмотра фотографий Windows должно запуститься.


Диспетчер Fax Voip T.38 Модем

  • Запуск диспетчера Fax Voip T.38 Модем
  • Запуск и остановка Fax Voip T.38 Модем
  • Опции меню в системном трее


Запуск диспетчера Fax Voip T.38 Модем

Диспетчер Fax Voip T.38 Модем ››

Чтобы запустить Диспетчер Fax Voip T.38 Модем, в меню Пуск выберите Fax Voip T.38 Modem, а затем нажмите Fax Voip T.38 Modem.

Кроме того, вы можете воспользоваться ярлыком Fax Voip T.38 Modem на рабочем столе.


Запуск и остановка Fax Voip T.38 Модем

Диспетчер Fax Voip T.38 Модем ››

Чтобы запустить Fax Voip T.38 Модем

Для запуска Fax Voip T.38 Модем, выберите команду Запустить Fax Voip T.38 Модем в меню Fax Voip T.38 Модем в системном трее.

Fax Voip T.38 Модем может быть сконфигурирован для работы в качестве Службы Windows . Для запуска Fax Voip T.38 Модем в качестве Службы Windows, выберите команду Запустить службу Fax Voip T.38 Модем в меню Fax Voip T.38 Модем в системном трее.

Чтобы остановить Fax Voip T.38 Модем

Чтобы остановить Fax Voip T.38 Модем, выберите команду Остановить Fax Voip T.38 Модем в меню Fax Voip T.38 Модем в системном трее.

Если Fax Voip T.38 Модем сконфигурирован для работы в качестве Службы Windows , то для остановки службы выберите команду Остановить службу Fax Voip T.38 Модем в меню Fax Voip T.38 Модем в системном трее.


Опции меню в системном трее

Диспетчер Fax Voip T.38 Модем ››

Когда Fax Voip T.38 Модем запущен, его значок отображается в системном трее.

Для доступа к меню Fax Voip T.38 Модем, щелкните значок Fax Voip T.38 Модем в системном трее правой кнопкой мыши и появится всплывающее меню, изображенное на рисунке ниже:

В меню доступны следующие команды:

Запустить Fax Voip T.38 Модем (Запустить службу Fax Voip T.38 Модем)

Нажмите чтобы запустить Fax Voip T.38 Модем.

Остановить Fax Voip T.38 Модем (Остановить службу Fax Voip T.38 Модем)

Нажмите чтобы остановить Fax Voip T.38 Модем.

Панель управления Fax Voip T.38 Модем

Нажмите чтобы открыть Панель управления Fax Voip T.38 Модем . Вы также можете сделать двойной щелчок по значку в системном трее.

Факсы и сканирование Windows

Нажмите чтобы запустить Факсы и сканирование Windows.

Диспетчер службы факсов

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Адресная книга (Контакты Windows)

Нажмите чтобы открыть Адресную книгу (Контакты Windows).

Мастер архивации и восстановления

Нажмите чтобы запустить Мастер архивации и восстановления Fax Voip T.38 Модем. Мастер архивации и восстановления Fax Voip T.38 Модем предназначен для сохранения, восстановления или перемещения конфигурации и файлов на другой компьютер. Чтобы использовать эту опцию, требуются права администратора.

Справка

Нажмите чтобы открыть файл справки.

О программе

Вывод сведений о программе, ее версии и авторских правах.

Выход

Нажмите чтобы закрыть приложение.


Панель управления Fax Voip T.38 Модем

Чтобы открыть Панель управления Fax Voip T.38 Модем, нажмите Пуск, выберите Fax Voip T.38 Modem; нажмите Панель управления Fax Voip T.38 Modem. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip T.38 Модем из меню иконки Fax Voip T.38 Модем в системном трее.

<СТАРТ>

Используйте эту кнопку чтобы запустить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

<СТОП>

Используйте эту кнопку чтобы остановить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

<Применить>

Используйте эту кнопку чтобы сохранить изменения ваших настроек.

<OK>

Используйте эту кнопку чтобы сохранить изменения ваших настроек и закрыть Панель управления Fax Voip T.38 Модем. Если Служба Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем) остановлена, она будет запущена с использованием новых настроек. Если Служба Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем) уже запущена, перезапуск не произойдет и работа продолжится с использованием предыдущих настроек. В этом случае, чтобы запустить приложение с новыми параметрами, необходимо остановить и затем запустить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

<Отмена>

Используйте эту кнопку чтобы закрыть Панель управления Fax Voip T.38 Модем без сохранения изменений в настройках.

В строке состояния отображается следующая информация:

Служба факсов Windows

Текущее состояние Службы факсов Windows. Следует понимать, что служба факсов может автоматически останавливаться, если она не используется приложениями и ни одно факсимильное устройство не настроено на прием факсов.

T.38 Модем / Служба T.38 Модем

Текущее состояние Службы Fax Voip T.38 Модем (приложения Fax Voip T.38 Модем).

SIP регистрация

Текущее состояние SIP регистраций (Зарегистрирован или Не зарегистрирован). Этот индикатор работает при запущенной Службе Fax Voip T.38 Модем (приложении Fax Voip T.38 Модем) и включенной опции Включить SIP (более детально см. в главе Параметры IP-телефонии ). Этот индикатор также показывает текущее число успешных SIP регистраций (первая цифра) и полное количество записей в списке учетных записей SIP (вторая цифра).

Команды ленты в Панели управления Fax Voip T.38 Модем

Следующие команды доступны в меню Файл:

Служба факсов Windows

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям (используя службу факсов Windows). Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям (используя службу факсов Windows). Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Отправить пробный факс (Ctrl + T)

Нажмите чтобы создать и отправить пробную страницу факса с использованием принтера факсов.

Факсы и сканирование Windows (Ctrl + W)

Нажмите чтобы запустить Факсы и сканирование Windows.

Диспетчер службы факсов (Ctrl + M)

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Перезапустить службу факсов Windows

Нажмите чтобы перезапустить службу факсов.

Перезапустить

Нажмите чтобы перезапустить службу факсов.

Запустить

Нажмите чтобы запустить службу факсов.

Остановить

Нажмите чтобы остановить службу факсов.

Настройка факс службы

Нажмите, чтобы восстановить компоненты службы факсов Windows, зарегистрировать Расширение маршрутизации Fax Voip T.38 Модем для работы со службой факсов и настроить службу факсов для отправки/получения факсов через Виртуальные COM порты (модемы) Fax Voip. Подробности см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Служба Fax Voip T.38 Модем

СТАРТ

Нажмите чтобы запустить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

СТОП

Нажмите чтобы остановить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

Справка (F1)

Нажмите чтобы открыть файл справки. Для вызова справочной системы вы также можете использовать кнопку Вызов справки, расположенную в правом верхнем углу ленты.

Выход (Ctrl + X)

Нажмите чтобы закрыть Панель управления Fax Voip T.38 Модем.

Быстрый доступ к настройкам Fax Voip T.38 Модем

Учетные записи SIP

Нажмите чтобы сконфигурировать учетные записи SIP для регистрации на сервере поставщика услуг IP-телефонии.

Маршрутизация исходящих VOIP вызовов

Нажмите чтобы сконфигурировать маршрутизацию исходящих вызовов . Должно присутствовать хотя бы одно правило.

Маршрутизация входящих VOIP вызовов

Нажмите чтобы сконфигурировать маршрутизацию входящих вызовов . Должно присутствовать хотя бы одно правило.

Виртуальные COM порты и модемы

Нажмите, чтобы настроить Виртуальные COM порты и модемы Fax Voip.

Маршрутизация входящих факсов через e-mail (Microsoft Fax)

Нажмите, чтобы настроить метод маршрутизации 'Отправить по электронной почте' для входящих факсов (Microsoft Fax) .

Сохранение входящих факсов в папке (Microsoft Fax)

Нажмите, чтобы настроить метод маршрутизации 'Сохранить в папке' для входящих факсов (Microsoft Fax) .

Уведомления о доставке по электронной почте (Microsoft Fax)

Нажмите, чтобы настроить метод маршрутизации 'Уведомления о доставке по электронной почте' для исходящих факсов (Microsoft Fax) .

Почта-на-факс - Microsoft Fax

Нажмите, чтобы настроить функцию 'Почта-на-факс - Microsoft Fax' .

Лицензии

Просмотр и управление вашими лицензиями .

Следующие команды доступны на вкладке Главная:

Факсы и сканирование Windows

Создать факс (Ctrl + F)

Нажмите чтобы создать новый факс для отправки одному или нескольким получателям (используя службу факсов Windows). Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

Факсы и сканирование (Ctrl + W)

Нажмите чтобы запустить Факсы и сканирование Windows.

Служба факсов Windows

Диспетчер службы факсов (Ctrl + M)

Нажмите чтобы открыть Диспетчер службы факса (Microsoft). Эта опция доступна только в серверных операционных системах, таких как Windows Server 2022.

Запустить

Нажмите чтобы запустить службу факсов Windows.

Остановить

Нажмите чтобы остановить службу факсов Windows.

Перезапустить

Нажмите чтобы перезапустить службу факсов Windows.

Настройка факс службы

Нажмите, чтобы восстановить компоненты службы факсов Windows, зарегистрировать Расширение маршрутизации Fax Voip T.38 Модем для работы со службой факсов и настроить службу факсов для отправки/получения факсов через Виртуальные COM порты (модемы) Fax Voip. Подробности см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Принтер факсов (Ctrl + P)

Принтер факсов

Отображение свойств принтера факсов.

Отправить пробный факс (Ctrl + T)

Нажмите чтобы создать и отправить пробную страницу факса с использованием принтера факсов.

Служба T.38 Модем

СТАРТ

Нажмите чтобы запустить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

СТОП

Нажмите чтобы остановить Службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

Большинство команд вкладки Главная также доступны в меню Файл.

Следующие команды доступны на вкладке Вид:

Области

Панель навигации

Нажмите чтобы отобразить или скрыть Панель навигации.

Строка состояния

Нажмите чтобы отобразить или скрыть строку состояния.

Лента

Снимите флажок чтобы скрыть ленту (Ribbon). Подтвердите переключение в классический режим. Требуется перезапуск Панели управления Fax Voip T.38 Модем.

Строка меню

Поставьте флажок чтобы отобразить классическое меню. Подтвердите переключение в классический режим. Требуется перезапуск Панели управления Fax Voip T.38 Модем.

Текущее представление

Стиль панели навигации

Эта опция позволяет вам выбрать тематический стиль Панели навигации в соответствии с темами предоставляемыми операционной системой. Просто выберите желаемый стиль из выпадающего списка.

Стиль HTML справки

Эта опция позволяет вам выбрать тематический стиль панели инструментов окна справки в соответствии с темами предоставляемыми операционной системой. Просто выберите желаемый стиль из выпадающего списка.

Цвета ленты

Стандартные цвета

Выберите этот вариант, чтобы применить стандартную цветовую схему (определяется операционной системой).

Настроить цвета

Выберите этот вариант, чтобы настроить цвета ленты. Обратите внимание, что эта опция не работает правильно в Windows 11, Windows 10 версии 1809 или более поздней, Windows Server 2022 и в Windows Server 2019.

Цвет фона

Выберите основной цвет фона для настраиваемой ленты.

Цвет выделения

Выберите основной цвет выделения для настраиваемой ленты (только Windows 7).

Цвет текста

Выберите основной цвет текста для настраиваемой ленты.

Вид по умолчанию

Восстановить умолчания

Используйте эту опцию для восстановления внешнего вида по умолчанию для Панели управления Fax Voip T.38 Модем и ее отдельных компонентов. Эта функция не изменяет ваши SIP, H.323, ISDN CAPI 2.0 и прочие параметры.

Большинство команд вкладки Вид также доступны в контекстном меню Панели навигации.

Следующие команды доступны на вкладке Инструменты:

Виртуальные COM порты

Порты и Модемы

Нажмите, чтобы настроить Виртуальные COM порты и модемы Fax Voip.

Исправить проблему TAPI с голосовыми модемами

Нажмите чтобы исправить проблему TAPI с голосовыми модемами в Windows 10 версии 1903 или 1909 (Microsoft исправила эту проблему в Windows 10 версии 2004). Подробности см. в главе Проблемы с голосовым модемом в Windows 10 настоящего справочного руководства. Требуются права администратора.

Контакты Windows

Контакты Windows

Нажмите, чтобы открыть папку Контакты.

Создать контакт

Добавление нового контакта.

Найти людей

Поиск людей в контактах пользователя.

Адресная книга

Нажмите, чтобы открыть Адресную книгу (Контакты Windows).

Архивация и восстановление

Мастер архивации и восстановления

Нажмите чтобы запустить Мастер архивации и восстановления Fax Voip T.38 Модем. Мастер архивации и восстановления Fax Voip T.38 Модем предназначен для сохранения, восстановления или перемещения конфигурации и файлов на другой компьютер. Чтобы использовать эту опцию, требуются права администратора.

Некоторые команды ленты содержатся в так называемых контекстных вкладках, которые доступны в зависимости от контекста. Эти команды описаны отдельно в соответствующих главах.

Панель быстрого доступа представляет собой небольшую, настраиваемую панель инструментов, которая содержит набор команд, заданных приложением или выбранных пользователем.

По умолчанию, Панель быстрого доступа расположена в строке заголовка окна Панели управления Fax Voip T.38 Модем, но также может быть настроена для отображения под лентой. В дополнение к отображенным командам, Панель быстрого доступа также включает в себя настраиваемое выпадающее меню, которое содержит полный набор команд Панели быстрого доступа по умолчанию (скрытых или отображенных), а также параметры настройки Панели быстрого доступа и ленты. Почти все элементы управления ленты могут быть добавлены на Панель быстрого доступа через контекстное меню, как показано на рисунке ниже.


IP-телефония

Параметры IP-телефонии

Панель управления Fax Voip T.38 Модем ››

Отображаемое имя

Введенный здесь текст отображается на дисплее удаленного телефона или факс-аппарата когда Fax Voip T.38 Модем совершает исходящий вызов (Caller ID NAME). По умолчанию используется имя 'FaxVoip Modem'. Отображаемое Имя может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Имя пользователя

По умолчанию, Fax Voip T.38 Модем использует Имя пользователя заданное в этом поле. По умолчанию используется имя 'FaxVoip'. Значение из этого поля используется как значение по умолчанию для параметров Имя пользователя SIP, H.323 ID и Имя пользователя ISDN (номер), но может быть переопределено в настройках SIP, H.323 и ISDN CAPI 2.0. Имя пользователя также может быть переопределено через SIP регистрацию и в настройках Маршрутизации исходящих VOIP вызовов. Если Имя пользователя состоит только из цифр и не переопределено использованием прочих настроек, то на удаленной стороне оно будет определяться как Caller ID NUMBER.

Voip протоколы

По крайней мере одна из нижеследующих опций должна быть выбрана:

Включить SIP

Выберите эту опцию если Вы планируете использовать Fax Voip T.38 Модем для работы в SIP сетях.

Включить H.323

Выберите эту опцию если Вы планируете использовать Fax Voip T.38 Модем для работы в сетях H.323.

Включить ISDN CAPI

Выберите эту опцию если Вы планируете использовать Fax Voip T.38 Модем для работы через линию ISDN CAPI 2.0.

Параметры сети

Диапазон портов RTP

Диапазон RTP портов используемый Fax Voip T.38 Модем. По умолчанию используются порты от 5000 до 5998.

Сервер STUN (и порт)

Адрес и порт используемого STUN сервера. Может быть полезен при использовании NAT для определения вашего IP-адреса. Эта опция может быть полезна как при работе через SIP так и при работе по H.323. Заметим, что STUN порт по умолчанию 3478. Если STUN сервер использует порт 3478, вы можете не вводить ':3478' в этом поле.

Примеры:

stun.sipnet.ru

stun.voipbuster.com

stun.yourstunserver.com:3478


SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ››

  • Параметры SIP
  • Параметры прокси-сервера
  • Агент пользователя SIP
  • Учетные записи SIP
  • Параметры T.38 UDPTL Redundancy (SIP)
  • Параметры голосовых кодеков SIP


Параметры SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

Имя пользователя SIP

По умолчанию в качестве Имени пользователя SIP используется Имя пользователя заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить. Имя пользователя SIP используется только при работе по протоколу SIP. Если Имя пользователя SIP состоит из одних цифр, при прямом исходящем SIP вызове без использования SIP регистрации и аутентификации, Имя пользователя SIP будет передано удаленной стороне как Caller ID NUMBER. Имя пользователя SIP может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Использовать имя пользователя по умолчанию

Чтобы иметь возможность изменить Имя пользователя SIP, снимите галочку. Если эта опция включена, то в качестве Имени пользователя SIP будет использовано Имя пользователя заданное в Параметрах IP-телефонии.

Интерфейс SIP/UDP (и порт)

Интерфейс/порт для прослушивания SIP/UDP запросов. Все входящие вызовы SIP через UDP должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для SIP через UDP используется порт 5060. Если вы используете порт 5060, можно не вводить '5060' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP.

Примеры:

192.168.0.2

* : 5070

Включить SIP через UDP

Включите эту опцию если предполагается использование SIP через UDP.

Интерфейс SIP/TCP (и порт)

Интерфейс/порт для прослушивания SIP/TCP запросов. Все входящие вызовы SIP через TCP должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для SIP через TCP используется порт 5060. Если вы используете порт 5060, можно не вводить '5060' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP/TCP.

Включить SIP через TCP

Включите эту опцию если предполагается использование SIP через TCP.

Интерфейс SIP/TLS (и порт)

Интерфейс/порт для прослушивания SIP/TLS запросов. Все входящие вызовы SIP через TLS должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для SIP через TLS используется порт 5061. Если вы используете порт 5061, можно не вводить '5061' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по SIP/TLS.

Включить SIP через TLS

Включите эту опцию если предполагается использование SIP через TLS.


Параметры прокси-сервера

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

Заметим что при использовании нижеописанного функционала, глобальные параметры прокси-сервера будут автоматически использоваться со всеми SIP регистрациями и всеми исходящими SIP вызовами, за исключением случаев когда заданы индивидуальные параметры прокси-сервера для отдельно взятой SIP регистрации или правила Маршрутизации исходящих VOIP вызовов, которое применяется к исходящему вызову. Неаккуратное использование глобальных параметров прокси-сервера может привести к проблемам с набором номера (для исходящих вызовов) и к проблемам прохождения голоса или факса (для входящих вызовов). Таким образом, для неопытных пользователей мы не рекомендуем включать опцию Использовать прокси-сервер. Если ваш SIP провайдер требует (или поддерживает) использование Прокси-сервера, мы рекомендуем задавать параметры прокси-сервера непосредственно для SIP регистрации (Учетная запись SIP) и в правилах Маршрутизации исходящих VOIP вызовов ассоциированных с этим провайдером. Однако, эта опция может быть полезна для продвинутых пользователей. Например, если вы не хотите использовать функцию SIP регистрация, вы можете ввести данные авторизации на сервере вашего SIP провайдера в Параметрах прокси-сервера (Имя пользователя, Пароль, Адрес SIP сервера) и использовать эти настройки для осуществления исходящих вызовов через сеть вашего провайдера.

Использовать прокси-сервер

Поставьте галочку если вы хотите задать и использовать глобальные настройки прокси-сервера.

Адрес прокси (и порт)

IP-адрес или имя прокси-сервера. Заметим, что по умолчанию используется порт 5060 если используется UDP или TCP транспорт или порт 5061 если используется TLS транспорт. Номер порта можно не вводить если используется порт по умолчанию. Заметим что в случае использования глобального прокси-сервера, этот прокси-сервер будет использоваться со всеми SIP регистрациями и всеми правилами Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Примеры:

sip.outboundserver.com

myoutbound.com : 5080

192.168.0.5 : 5075

Sip через UDP

Выберите чтобы использовать SIP через UDP. Эта опция используется по умолчанию. Заметим что в случае использования глобальных Параметров прокси-сервера, выбранный транспорт будет применяться ко всем SIP регистрациям и всем правилам Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Sip через TCP

Выберите чтобы использовать SIP через TCP. Если вы планируете использовать TCP, пожалуйста спросите у вашего SIP провайдера поддерживает ли он SIP через TCP. Заметим что в случае использования глобальных Параметров прокси-сервера, выбранный транспорт будет применяться ко всем SIP регистрациям и всем правилам Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Sip через TLS

Выберите чтобы использовать SIP через TLS. Если вы планируете использовать TLS, пожалуйста спросите у вашего SIP провайдера поддерживает ли он SIP через TLS. Заметим что в случае использования глобальных Параметров прокси-сервера, выбранный транспорт будет применяться ко всем SIP регистрациям и всем правилам Маршрутизации исходящих VOIP вызовов, за исключением регистраций и правил для которых индивидуально задан другой прокси-сервер.

Имя пользователя (не обязательно)

Имя пользователя для авторизации с прокси.

Пароль (не обязательно)

Пароль для авторизации с прокси.


Агент пользователя SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

Рассматриваемые здесь параметры используются для идентификации Fax Voip T.38 Модем в процессе взаимодействия с другими элементами SIP сети. Позволяют информировать противоположную сторону о программе или оборудовании, которое использует пользователь.

Агент пользователя SIP

Информация об оборудовании или программном обеспечении которое использует SIP пользователь. По умолчанию FaxVoip Modem.

Производитель софта

Информация о производителе программного обеспечения или оборудования SIP. По умолчанию FaxVoip Software.


Учетные записи SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

  • Параметры учетных записей SIP
  • Добавление или изменение учетной записи SIP
  • Управление учетными записями SIP
  • Тестирование учетной записи SIP
  • Параметры восстановления SIP регистрации


Параметры учетных записей SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

Fax Voip T.38 Модем поддерживает работу с несколькими Учетными записями SIP и позволяет осуществлять Одновременные SIP регистрации. Вы можете работать одновременно с несколькими SIP серверами, и (или) регистрировать несколько Учетных записей SIP на одном и том же сервере. Функция Одновременных SIP регистраций позволяет принимать входящие вызовы из различных SIP сетей. Для осуществления исходящих вызовов с использованием различных Учетных записей SIP, следует сделать соответствующие настройки правил Маршрутизации исходящих VOIP вызовов. Fax Voip T.38 Модем поддерживает SIP регистрацию через UDP, через TCP и через TLS. Максимальное поддерживаемое количество Учетных записей SIP не ограничено.

Список учетных записей SIP содержит следующую информацию:

имя@сервер

Учетная запись пользователя на сервере SIP провайдера. Состоит из двух частей: имя пользователя (SIP-ID) и имя (IP-адрес) сервера. Вторая часть также может содержать номер порта. Если сервер использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде.

Прокси-сервер (опционально)

Отображает адрес SIP прокси-сервера, который используется с текущей учетной записью (если задан). Имя (IP-адрес) прокси-сервера также может содержать номер порта. Если прокси-сервер использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. Значок => перед именем прокси-сервера сообщает о том, что при текущей регистрации используются глобальные параметры прокси, заданные в Параметрах прокси-сервера . Если для данной регистрации задан индивидуальный прокси-сервер, то всегда будет использоваться UDP транспорт. Чтобы работать с прокси-сервером по TCP или TLS, необходимо использовать глобальные Параметры прокси-сервера .

Транспорт

Отображает транспорт (UDP, TCP или TLS) используемый для текущей учетной записи при регистрации. По умолчанию, этот же транспорт используется при входящих вызовах через текущую регистрацию.

Статус регистрации

Это поле отображает состояние SIP регистрации для текущей учетной записи (OK либо описание ошибки). Этот индикатор работает когда Fax Voip T.38 Модем запущен.

Имя для авторизации (опционально)

Имя пользователя для авторизации.

Домен (опционально)

Домен учетной записи.

Контакт (опционально)

Позволяет переопределить поле Contact в SIP сообщении REGISTER. В зависимости от настроек SIP сервера позволяет перенаправить входящий вызов на другой номер или даже на другой SIP узел.

Таймаут

Таймаут SIP регистрации. По умолчанию 180 секунд.

Параметры восстановления

Дополнительные опции для принудительного восстановления SIP регистрации, в случае если она нестабильна по каким-либо причинам. См. также главу Параметры восстановления SIP регистрации настоящего справочного руководства.

Force=да

Fax Voip T.38 Модем принудительно отправляет запрос REGISTER с заданной периодичностью.

Force=нет

Функция принудительного восстановления отключена.

Timeout=...мин

Интервал между отправкой REGISTER, в минутах. Может быть установлен от 1 до 999 минут.

Check= да

Fax Voip T.38 Модем не отправляет REGISTER если аккаунт зарегистрирован.

Check = нет

Принудительный запрос отправляется независимо от текущего статуса регистрации.

UnReg= да

Fax Voip T.38 Модем пытается отменить текущую регистрацию перед отправкой принудительного запроса.

UnReg= нет

Fax Voip T.38 Модем отправляет REGISTER без отправки предварительной команды на отмену регистрации.

Delay=...сек

Интервал между отправкой команд отмены регистрации и REGISTER, в секундах. Может быть установлен от 1 до 10 секунд.

Если SIP регистрация не может быть осуществлена согласно текущей конфигурации программы, Fax Voip T.38 Модем не загружает и игнорирует учетную запись при запуске приложения.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует все учетные записи SIP.
  • Если опция Включить SIP через UDP отключена (SIP через UDP не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует учетные записи которые используют SIP через UDP.
  • Если опция Включить SIP через TCP отключена (SIP через TCP не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует учетные записи которые используют SIP через TCP.
  • Если опция Включить SIP через TLS отключена (SIP через TLS не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует учетные записи которые используют SIP через TLS.

Учетные записи SIP, которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом.

В контекстной вкладке Учетные записи SIP, на ленте доступны следующие команды:

Учетные записи SIP

Добавить (Ctrl + N)

Нажмите чтобы добавить Учетную запись SIP.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранной Учетной записи SIP. Может быть полезно при создании большого количества схожих записей. Чтобы отредактировать вновь созданную запись, выберите ее и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения Учетной записи SIP. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одной или более Учетной записи SIP. Удаляемая запись должна быть выделена.

Удалить (Del)

Нажмите для удаления одной или более Учетной записи SIP. Удаляемая запись должна быть выделена.

Удалить все записи

Нажмите чтобы удалить все записи в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений Учетных записей SIP. Одна из записей должна быть выделена.

Вверх (Ctrl + U)

Переместить выбранный элемент вверх.

Вниз (Ctrl + D)

Переместить выбранный элемент вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Регистрация

Используйте эти команды, чтобы вручную зарегистрироваться на SIP сервере или отменить регистрацию. Одна или несколько записей должны быть выделены. См. также главу Тестирование учетной записи SIP настоящего справочного руководства.

Зарегистрировать

Нажмите чтобы зарегистрировать учетную запись на SIP сервере.

Зарегистрировать

Нажмите чтобы зарегистрировать учетную запись на SIP сервере.

Отменить регистрацию

Нажмите чтобы отменить регистрацию на SIP сервере.

Большинство команд из контекстной вкладки Учетные записи SIP также доступны в контекстном меню списка.


Добавление/изменение учетной записи SIP

Добавление (или изменение) учетной записи SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Чтобы добавить Учетную запись SIP, нажмите Добавить. Для редактирования существующей Учетной записи SIP, выделите ее и нажмите Править (или сделайте двойной щелчок мышью на выбранной записи).

4. В окне Учетная запись SIP, нажмите кнопку <Подробно>, чтобы просматривать и редактировать дополнительные параметры.

5. Сделайте необходимые настройки для выбранной (или новой) Учетной записи SIP.

Параметры учетной записи SIP

Имя пользователя (или SIP-ID)

Идентификатор SIP аккаунта. Обычно это ваше Имя пользователя или телефонный номер.

Пароль

Пароль для авторизации.

Сервер регистрации

IP-адрес или имя SIP сервера регистрации. Может также содержать номер порта. Если сервер регистрации использует порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.voipbuster.com', 'sip.telphin.com:5068', 'voip.mtt.ru', '192.168.0.2:5065', ...) При использовании TLS в качестве транспорта, по умолчанию используется порт 5061.

Прокси-сервер (опционально)

IP-адрес или имя SIP прокси-сервера, используемого для регистрации. Может также содержать номер порта. Если используется порт отличный от 5060 (по умолчанию), то номер порта должен быть задан в явном виде. (Примеры: 'sip.myproxy.com', 'voice.telphin.com:5068', '192.168.0.5:5065', ...). Если Прокси-сервер задан в этом поле, Fax Voip T.38 Модем всегда осуществляет процедуру регистрации используя SIP через UDP. Чтобы работать с прокси-сервером с использованием TCP или TLS транспорта, следует использовать глобальные Параметры прокси-сервера .

Имя пользователя для авторизации (опционально)

Имя пользователя для авторизации. Обычно не требуется.

Домен/Realm (опционально)

Домен учетной записи. Обычно не требуется.

SIP контакт URL (опционально)

Позволяет переопределить поле Contact в SIP сообщении REGISTER. Обычно не требуется. В зависимости от настроек SIP сервера позволяет перенаправить входящий вызов на другой номер или даже на другой SIP узел. Если вы не понимаете назначение этого параметра, оставьте поле пустым. Неправильные данные в этом поле могут привести к проблемам при осуществлении SIP регистрации и при входящих вызовах.

Таймаут регистрации

Таймаут SIP регистрации. По умолчанию 180 секунд.

Транспорт

При использовании Параметров прокси-сервера по умолчанию, будет использован транспорт, заданный в параметрах прокси-сервера. Если в поле Прокси-сервер задан индивидуальный (для текущей регистрации) прокси-сервер, будет использоваться SIP через UDP. Заметим, что TCP и TLS могут не поддерживаться на стороне вашего сервера или SIP провайдера.

SIP через UDP (по умолчанию)

Используйте эту опцию для осуществления регистрации и приема входящих SIP вызовов через UDP.

SIP через TCP

Используйте эту опцию для осуществления регистрации и приема входящих SIP вызовов через TCP.

SIP через TLS

Используйте эту опцию для осуществления регистрации и приема входящих SIP вызовов через TLS.

Восстановление SIP регистрации

Используйте только если регистрация не является стабильной по каким-либо причинам. Подробнее см. в главе Параметры восстановления SIP регистрации настоящего справочного руководства.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Используйте команды Вверх и Вниз чтобы изменить порядок предпочтений Учетных записей SIP.

8. Заметим, что непосредственно после добавления или редактирования Учетной записи SIP, Статус регистрации для этой учетной записи не будет отображаться или может быть отображен неправильно.

9. Вы можете протестировать учетную запись перед тем как сохранять ее. См. главу Тестирование учетной записи SIP настоящего справочного руководства.

10. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Статус SIP регистрации для каждой Учетной записи SIP отображается в столбце Статус регистрации. Суммарная информация отображается в строке состояния.


Управление учетными записями SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Чтобы изменить порядок предпочтений Учетных записей SIP, используйте команды Вверх и Вниз. Одна из Учетных записей SIP должна быть выделена.

4. Для удаления одной или более Учетной записи SIP, выберите запись и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Тестирование учетной записи SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

Fax Voip T.38 Модем регистрирует учетные записи SIP при старте приложения. Также вы можете вручную зарегистрироваться на SIP сервере или отменить регистрацию. Этот функционал можно использовать в следующих случаях:

  • Временно приостановить, а затем возобновить регистрацию для одной или более учетных записей SIP.
  • Вручную восстановить регистрацию в случае потери регистрации, если по какой-либо причине она не может быть восстановлена автоматически.
  • Для тестирования регистрации непосредственно после добавления или редактирования учетной записи SIP (перед сохранением настроек).
  • Для исследования поведения SIP сервера при конфигурировании опции Принудительная регистрация. См. также главу Параметры восстановления SIP регистрации настоящего справочного руководства.

Рассматриваемые функции не могут быть использованы при остановленном приложении Fax Voip T.38 Модем. Обратите внимание, что эти функции используют данные, отображаемые в данный момент в списке учетных записей SIP, а не уже сохраненные настройки. Именно поэтому вы можете использовать их для тестирования вновь созданных или только что отредактированных учетных записей без нажатия кнопки <Применить> и перезапуска Fax Voip T.38 Модем.

Чтобы зарегистрировать учетную запись SIP

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Убедитесь в том, что Fax Voip T.38 Модем запущен. Для запуска Fax Voip T.38 Модем нажмите кнопку <СТАРТ>.

4. Выберите одну или более записей в списке учетных записей.

5. Нажмите Зарегистрировать либо выберите команду Зарегистрировать из выпадающего меню кнопки Зарегистрировать.

Чтобы отменить регистрацию

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Убедитесь в том, что Fax Voip T.38 Модем запущен. Для запуска Fax Voip T.38 Модем нажмите кнопку <СТАРТ>.

4. Выберите одну или более записей в списке учетных записей.

5. Выберите команду Отменить регистрацию из выпадающего меню кнопки Зарегистрировать.

Примечания

  • Если SIP регистрация отменена командой Отменить регистрацию, она может быть автоматически восстановлена через некоторое время если включена опция Принудительная регистрация. См. также главу Параметры восстановления SIP регистрации настоящего справочного руководства. Это не относится к случаю проверки только что созданной учетной записи SIP до ее сохранения и перезапуска Fax Voip T.38 Модем.


Параметры восстановления SIP регистрации

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ›› Учетные записи SIP ››

При нормальной эксплуатации Fax Voip T.38 Модем регистрирует учетные записи SIP при старте приложения, а затем регистрация поддерживается штатными методами путем отправки запроса REGISTER в соответствии с Таймаутом регистрации.

В некоторых случаях регистрация может быть нестабильной. В этой ситуации программа периодически не может принимать входящие вызовы. Типичные причины: слишком большой интервал обновления (см. Таймаут регистрации), нестабильное подключение к сети интернет, какие-либо временные проблемы на стороне поставщика SIP услуг и т.п. Даже в случае потери регистрации, как правило, Fax Voip T.38 Модем должен автоматически восстановить регистрацию через некоторое время. Однако, в отдельных случаях и по различным причинам этого не происходит, и программа остается незарегистрированной. Обычно вы можете устранить проблемы путем изменения Таймаута регистрации, указав в настройках Прокси-сервер и/или Сервер STUN и т.д.

К сожалению, в некоторых случаях несовместимости, все эти усилия могут не привести к желаемым результатам.

Описанные ниже опции позволяют решить проблему нестабильной SIP регистрации, независимо от причин ее возникновения. Fax Voip T.38 Модем периодически отправляет принудительный запрос REGISTER и восстанавливает SIP Регистрацию без необходимости перезапуска всего приложения. Рассматриваемые параметры настраиваются независимо друг от друга для различных учетных записей SIP. Обратите внимание, что это вспомогательный механизм. Нет необходимости использовать его, если проблемы со стабильностью регистрации отсутствуют.

Настройка параметров восстановления SIP регистрации

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Учетные записи SIP.

3. Выделите учетную запись и нажмите Править (или сделайте двойной щелчок мышью на выбранной записи).

4. В окне Учетная запись SIP, нажмите кнопку <Подробно>.

5. Сделайте необходимые настройки в области Восстановление SIP регистрации.

Восстановление SIP регистрации

Принудительная регистрация каждые ... мин.

Если эта опция включена, Fax Voip T.38 Модем принудительно отправляет запрос REGISTER с заданной периодичностью. Интервал между запросами задается в минутах и может быть установлен от 1 до 999 минут. Не следует задавать слишком малый интервал, если в этом нет необходимости.

Регистрировать только если не зарегистрирован

Если опция включена, Fax Voip T.38 Модем не отправляет REGISTER если аккаунт зарегистрирован. Если опция выключена, запрос всегда передается независимо от текущего статуса регистрации.

Отменять текущую регистрацию

Поставьте флажок, чтобы отменить текущую регистрацию перед отправкой принудительного запроса. Реальная необходимость этой команды зависит от конкретного сервера, как правило не требуется.

Задержка между командами ... сек.

Интервал между отправкой команд отмены регистрации и REGISTER, в секундах. Может быть установлен от 1 до 10 секунд. Интервал в 1 секунду обычно достаточен. За исключением случая, когда сервер отвечает с большой задержкой.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Учетных записей SIP. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Примечания

  • Чтобы восстановить регистрацию вручную, см. главу Тестирование учетной записи SIP настоящего справочного руководства.


SIP T.38 Redundancy

Параметры T.38 UDPTL Redundancy (SIP)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

T.38 предоставляет возможности для устранения последствий потери пакетов за счет избыточности данных (T.38 redundancy). При отправке пакета к нему прикрепляются ноль, один, два, три или даже большее число ранее отправленных пакетов. (Спецификация не накладывает ограничений.) Это требует увеличенной пропускной способности сети (что все еще намного меньше чем если не использовать T.38) но при этом позволяет принимающему шлюзу реконструировать полную последовательность пакетов, даже при достаточно высоком уровне потери пакетов. Величина избыточности (T.38 redundancy) соответствует тому, сколько предыдущих пакетов повторяется с каждым пакетом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

Примечания

  • Параметры T.38 redundancy для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры T.38 redundancy заданные в этой панели применяются только к факсовым вызовам SIP. Для настройки аналогичных параметров для H.323, вы должны использовать соответствующую панель.


Параметры кодеков SIP

Параметры голосовых кодеков SIP

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› SIP ››

Fax Voip T.38 Модем поддерживает различные Аудио кодеки при работе по SIP. Это особенно важно с точки зрения некоторых функций, таких как Голосовые функции модема . Желательно спросить у вашего SIP провайдера о поддерживаемых аудио кодеках. По крайней мере один аудио кодек должен быть выбран. Следует понимать, что режим факса G711fax (факс поверх кодека G.711) работает только при использовании кодеков G.711-ulaw или G.711-Alaw. С другой стороны, режим факса T.38 позволяет использовать любой аудио кодек допустимый для использования в вашей SIP сети. Для получения более подробной информации обратитесь к главе T38 и G711 (аудио) режимы факса , раздел Требования к голосовым кодекам данного справочного руководства чтобы узнать больше о режимах факса и об использовании аудио кодеков.

В левой панели перечислены кодеки доступные для использования. В правой панели перечислены кодеки, выбранные пользователем. Кодеки заданные в правой панели могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов. Выбранные кодеки могут быть выстроены в порядке предпочтений. По умолчанию порядок предпочтений кодеков применяется только к исходящим вызовам. При входящих вызовах Fax Voip T.38 Модем использует порядок предпочтений заданный удаленной стороной.

Fax Voip T.38 Модем поддерживает следующие аудио форматы для SIP:

G.711-uLaw-64k (по умолчанию)

G.711-ALaw-64k (по умолчанию)

G.729* (только для совместимости с T.38)

G.723.1

G.726-32k

GSM-06.10

iLBC

SpeexNB

SpeexWB

Вам доступны следующие команды:

<Добавить> (или двойной щелчок мышью на выбранной записи в панели Доступные кодеки)

Используйте эту кнопку для добавления кодеков для использования с Fax Voip T.38 Модем. Вы должны предварительно выделить один из кодеков в панели Доступные кодеки.

<Удалить> (или двойной щелчок мышью на выбранной записи в панели Выбранные кодеки)

Используйте эту кнопку для удаления кодеков из панели Выбранные кодеки. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтения кодеков для выбранных аудио кодеков. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

Заметим, что вы также можете выполнить любое из вышеперечисленных действий, выбрав соответствующую команду из контекстного меню списка.

Применять предпочтения к входящим вызовам

Поставьте галочку чтобы игнорировать порядок предпочтения кодеков предлагаемый другой стороной и использовать порядок предпочтения кодеков заданный в Fax Voip T.38 Модем во время входящих вызовов. Заметим что использование этой опции не соответствует RFC3264. Тем не менее, мы сочли полезным добавить такую возможность. Эта опция может быть использована с наборами кодеков, которые содержат следующие выбранные кодеки: G.711-uLaw-64k, G.711-ALaw-64k, G.723.1, GSM-06.10. Заметим, что корректная работа этой опции с другими кодеками не гарантирована.

Примечания

  • Ложный G.729* кодек позволяет сообщать поддержку кодека G.729 тем T.38 факс шлюзам, которые не поддерживают G.711 и другие поддерживаемые аудио форматы; используйте этот кодек только для решения проблем совместимости. Вы не сможете использовать G.729* с Голосовыми функциями модема .
  • Обычно, если используется ложный G.729* кодек, для исходящих вызовов также следует использовать режим Отправлять T.38 ре-инвайт чтобы обеспечить генерацию CNG сигнала. См. также в главе T38 и G711 (аудио) режимы факса , раздел Режим T38 факс с отправкой ре-инвайта .
  • Параметры голосовых кодеков заданные в этой панели применяются только к вызовам SIP. Для настройки аналогичных параметров для H.323, вы должны использовать соответствующую панель.


H.323

Панель управления Fax Voip T.38 Модем ›› IP-телефония ››

  • Параметры H.323
  • H.323 гейткипер
  • Параметры T.38 UDPTL Redundancy (H.323)
  • Параметры голосовых кодеков H.323


Параметры H.323

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› H.323 ››

H.323 ID

H.323 ID используется для идентификации Fax Voip T.38 Модем в качестве узла H.323 в процессе взаимодействия с другими элементами H.323 сети, в частности с H.323 гейткипером. По умолчанию в качестве H.323 ID Fax Voip T.38 Модем использует Имя пользователя заданное в Параметрах IP-телефонии, но в данном поле его можно переопределить.

Использовать имя пользователя по умолчанию как H.323 ID

Чтобы иметь возможность изменить H.323 ID, снимите галочку. Если эта опция включена, то в качестве H.323 ID будет использовано Имя пользователя заданное в Параметрах IP-телефонии.

Интерфейс H.323 (и порт)

Интерфейс/порт для прослушивания H.323 запросов. Все входящие H.323 вызовы должны быть направлены на этот интерфейс/порт. ' * ' означает все сетевые интерфейсы и может быть рекомендовано для использования по крайней мере на первое время. Заметим, что по умолчанию для H.323 используется порт 1720. Если вы используете порт 1720, можно не вводить '1720' в поле для порта. Во избежание конфликтов, пожалуйста проверьте что выбранный порт не используется другим программным обеспечением работающим по H.323.

Примеры:

192.168.0.2

* : 1722

Номера телефонов

Список Номера телефонов содержит цифровые телефонные номера ассоциированные с Fax Voip T.38 Модем с точки зрения H.323. Если H.323 ID состоит только из цифр, Fax Voip T.38 Модем автоматически добавляет его в список телефонных номеров. Если используется регистрация на H.323 гейткипере, используется H.235 аутентификация и H.235 логин состоит только из цифр, Fax Voip T.38 Модем автоматически добавляет H.235 логин в список телефонных номеров. Телефонные номера заданные в этом списке используются в процессе регистрации с H.323 гейткипером (список телефонных номеров на которые возможны входящие звонки). Во время исходящего вызова H.323, верхний номер из этого списка будет передан удаленной стороне как Caller ID NUMBER. Caller ID NUMBER может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов. (поле Имя пользователя).

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтений телефонных номеров. Перед тем как использовать эти кнопки, вы должны выделить один из номеров.

<Добавить>

Используйте эту кнопку для добавления в список нового номера телефона.

<Удалить>

Используйте эту кнопку для удаления из списка одного или более номера телефона. Перед тем как удалять номера, вы должны выделить один или более номеров, которые вы хотите удалить.

Заметим, что вы также можете выполнить любое из вышеперечисленных действий, выбрав соответствующую команду из контекстного меню списка.

Включить Fast Start

Для включения режима Fast Start поставьте галочку. Для выключения режима снимите галочку.

Включить H.245 Tunneling

Для включения режима H.245 tunneling поставьте галочку. Для выключения режима снимите галочку.


H.323 гейткипер

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› H.323 ››

Режим гейткипера

Не использовать гейткипер (по умолчанию)

В этом режиме Fax Voip T.38 Модем функционирует как независимый H.323 узел и не регистрируется на H.323 гейткипере. Все входящие H.323 вызовы должны быть маршрутизированы непосредственно на IP-адрес и порт на котором работает Fax Voip T.38 Модем. Этот режим предпочтителен в случае когда H.323 провайдер использует ваш IP-адрес для идентификации (наиболее распространенный метод привязки используемый для аутентификации).

Использовать если доступен

Fax Voip T.38 Модем пытается зарегистрироваться на H.323 гейткипере. Если это невозможно, Fax Voip T.38 Модем функционирует как независимый H.323 узел без регистрации на H.323 гейткипере.

Использовать гейткипер

В этом режиме Fax Voip T.38 Модем должен быть зарегистрирован на H.323 гейткипере.

Поиск гейткипера

В этом режиме Fax Voip T.38 Модем способен найти H.323 гейткипер автоматически. Опция полезна при регистрации на гейткипере расположенном в вашей локальной сети.

Адрес

IP-адрес или имя сервера где находится H.323 гейткипер.

Время жизни

Продолжительность времени (в секундах) в течении которого действительна регистрация на H.323 гейткипере. Заметим, что этот параметр может быть переопределен самим гейткипером в процессе регистрации.

H.235 аутентификация

Поставьте галочку если для регистрации на гейткипере необходима аутентификация. Аутентификация осуществляется согласно стандарта H.235 и MD5 алгоритма хэширования.

Логин

H.235 логин для авторизации.

Пароль

H.235 пароль для авторизации.

Статус гейткипера

В этой области показывается состояние регистрации на H.323 гейткипере. Этот индикатор работает когда Служба Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем) запущена, опция Включить H.323 включена (см. в Параметрах IP-телефонии ), выбран режим Использовать гейткипер или Использовать если доступен и гейткипер действительно найден. Следующая информация может быть отображена:

      • Имя гейткипера
      • GatekeeperConfirm/ GatekeeperReject (состояние гейткипера)
      • RegistrationConfirm/ RegistrationReject (состояние регистрации на гейткипере)


H.323 T.38 Redundancy

Параметры T.38 UDPTL Redundancy (H.323)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› H.323 ››

T.38 предоставляет возможности для устранения последствий потери пакетов за счет избыточности данных (T.38 redundancy). При отправке пакета к нему прикрепляются ноль, один, два, три или даже большее число ранее отправленных пакетов. (Спецификация не накладывает ограничений.) Это требует увеличенной пропускной способности сети (что все еще намного меньше чем если не использовать T.38) но при этом позволяет принимающему шлюзу реконструировать полную последовательность пакетов, даже при достаточно высоком уровне потери пакетов. Величина избыточности (T.38 redundancy) соответствует тому, сколько предыдущих пакетов повторяется с каждым пакетом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

Примечания

  • Параметры T.38 redundancy для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.
  • Параметры T.38 redundancy заданные в этой панели применяются только к факсовым вызовам H.323. Для настройки аналогичных параметров для SIP, вы должны использовать соответствующую панель.


Параметры кодеков H.323

Параметры голосовых кодеков H.323

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› H.323 ››

Fax Voip T.38 Модем поддерживает различные Аудио кодеки при работе по H.323. Это особенно важно с точки зрения некоторых функций, таких как Голосовые функции модема . Желательно спросить у вашего H.323 провайдера о поддерживаемых аудио кодеках. По крайней мере один аудио кодек должен быть выбран. Следует понимать, что режим факса G711fax (факс поверх кодека G.711) работает только при использовании кодеков G.711-ulaw или G.711-Alaw. С другой стороны, режим факса T.38 позволяет использовать любой аудио кодек допустимый для использования в вашей H.323 сети. Для получения более подробной информации обратитесь к главе T38 и G711 (аудио) режимы факса , раздел Требования к голосовым кодекам данного справочного руководства чтобы узнать больше о режимах факса и об использовании аудио кодеков.

В левой панели перечислены кодеки доступные для использования. В правой панели перечислены кодеки, выбранные пользователем. Кодеки заданные в правой панели могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов. Выбранные кодеки могут быть выстроены в порядке предпочтений. По умолчанию порядок предпочтений кодеков применяется только к исходящим вызовам. При входящих вызовах Fax Voip T.38 Модем использует порядок предпочтений заданный удаленной стороной.

Fax Voip T.38 Модем поддерживает следующие аудио форматы для H.323:

G.711-uLaw-64k (по умолчанию)

G.711-ALaw-64k (по умолчанию)

G.729* (только для совместимости с T.38)

G.723.1

G.726-32k

GSM-06.10

iLBC

SpeexNB

SpeexWB

<Добавить> (или двойной щелчок мышью на выбранной записи в панели Доступные кодеки)

Используйте эту кнопку для добавления кодеков для использования с Fax Voip T.38 Модем. Вы должны предварительно выделить один из кодеков в панели Доступные кодеки.

<Удалить> (или двойной щелчок мышью на выбранной записи в панели Выбранные кодеки)

Используйте эту кнопку для удаления кодеков из панели Выбранные кодеки. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтения кодеков для выбранных аудио кодеков. Вы должны предварительно выделить один из кодеков в панели Выбранные кодеки.

Заметим, что вы также можете выполнить любое из вышеперечисленных действий, выбрав соответствующую команду из контекстного меню списка.

Примечания

  • Ложный G.729* кодек позволяет сообщать поддержку кодека G.729 тем T.38 факс шлюзам, которые не поддерживают G.711 и другие поддерживаемые аудио форматы; используйте этот кодек только для решения проблем совместимости. Вы не сможете использовать G.729* с Голосовыми функциями модема .
  • Обычно, если используется ложный G.729* кодек, для исходящих вызовов также следует использовать режим Отправлять T.38 ре-инвайт чтобы обеспечить генерацию CNG сигнала. См. также в главе T38 и G711 (аудио) режимы факса , раздел Режим T38 факс с отправкой ре-инвайта .
  • Параметры голосовых кодеков заданные в этой панели применяются только к вызовам H.323. Для настройки аналогичных параметров для SIP, вы должны использовать соответствующую панель.


ISDN CAPI 2.0

Панель управления Fax Voip T.38 Модем ›› IP-телефония ››

  • Параметры ISDN CAPI 2.0


Параметры ISDN CAPI 2.0

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› ISDN CAPI 2.0 ››

При отправке/приеме факсов через линию ISDN CAPI 2.0, Fax Voip T.38 Модем не использует факс функции вашей ISDN карты, как это обычно делают факс приложения, работающие с CAPI 2.0, факс передается как стандартный аудио поток данных. Работу Fax Voip T.38 Модем можно сравнить с работой аналогового факсимильного аппарата, который подключен к телефонной линии ISDN через адаптер. Fax Voip T.38 Модем использует такую же технологию как и при передаче аудио факса через SIP или H.323 (факс поверх кодека G.711). Возможность использования CAPI 2.0 с Виртуальными COM портами (модемами) позволяет вам отправлять и принимать факсы через линию ISDN с использованием вашего стандартного факс программного обеспечения, которое не предназначено для работы с CAPI 2.0, например с Microsoft Fax.

Имя пользователя ISDN (номер)

Эта опция позволяет включить вызывающий номер (CallerID) в сообщение CAPI 2.0 при совершении исходящего вызова. По умолчанию Fax Voip T.38 Модем использует Имя пользователя по умолчанию, заданное в параметрах IP-телефонии в качестве ISDN номера, но вы можете переопределить его в рассматриваемом поле. С другой стороны, этот параметр может быть переопределен через Маршрутизацию исходящих VOIP вызовов. Имя пользователя, состоящее из букв, игнорируется, поэтому для включения CallerID в сообщение CAPI 2.0 следует использовать цифры. В зависимости от свойств вашей ISDN карты, CallerID может быть проигнорирован или переопределен. В случае если вы вводите неправильный ISDN номер, не удовлетворяющий ISDN настройкам вашего оборудования, исходящий вызов может быть отклонен. Заметим, что в случае использования Имени пользователя ISDN (номера), который состоит из букв, такая ошибка невозможна.

Использовать имя пользователя по умолчанию

Чтобы иметь возможность изменить Имя пользователя ISDN, снимите галочку. Если эта опция включена, то в качестве Имени пользователя ISDN (номера) будет использовано Имя пользователя заданное в Параметрах IP-телефонии.

Кодек

CAPI 2.0 приложения работают с голосовыми данными в формате G.711 A-law или G.711 u-law. Выберите G.711 кодек который должен использоваться в вашей системе. Вам следует предварительно выяснить, который из этих двух кодеков используется в настройках вашей ISDN карты

Профиль CAPI

В этой области отображается детальная информация о подсистеме ISDN CAPI 2.0, которая используется на вашем компьютере. Этот индикатор работает когда Служба Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем) запущена и опция Включить ISDN CAPI включена (см. в Параметрах IP-телефонии ). Следующая информация может быть отображена:

      • Состояние: Подключено / Не удалось подключиться...
      • Производитель CAPI 2.0 драйвера
      • Версия CAPI (включая версию производителя)
      • ISDN контроллеры – число ISDN контроллеров
      • Число B-каналов для каждого контроллера

Примечания

  • Для работы с телефонной линией ISDN через интерфейс CAPI 2.0, вам необходимо приобрести ISDN карту для вашего компьютера и установить CAPI 2.0 драйвер (capi2032.dll), который поставляется производителем вашей ISDN карты.
  • Следует понимать, что некоторые драйвера CAPI 2.0 не позволяют одновременное использование интерфейса CAPI 2.0 более чем одним приложением CAPI 2.0.


Исходящие маршруты

Маршрутизация исходящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ››

В зависимости от набираемого номера исходящие вызовы могут быть маршрутизированы через различные SIP или H.323 сервера, направлены на H.323 гейткипер, осуществлены с использованием различных Учетных записей SIP (SIP регистраций) или маршрутизированы через ISDN CAPI 2.0 линию. Максимальное поддерживаемое количество правил Маршрутизации исходящих VOIP вызовов не ограничено.

Правила могут применяться к одному, нескольким или всем Виртуальным COM портам (модемам) одновременно.

Fax Voip T.38 Модем всегда проверяет правила Маршрутизации исходящих VOIP вызовов, начиная с правила # 1. Вызов маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется ко всем Виртуальным COM портам (COM: *), и для любых набираемых номеров (.*), то другие правила # 2, # 3, и т.д. применяемые к Виртуальным COM портам никогда не выполнятся ни при каких условиях. Таким образом, следует всегда уделять внимание порядку предпочтений для правил Маршрутизации исходящих VOIP вызовов.

Если не существует ни одного правила, которому удовлетворяет вызов, вызов не может быть осуществлен. Чтобы осуществить исходящий вызов определенного типа, вы должны иметь хотя бы одно правило для этого типа вызовов в таблице Маршрутизации исходящих VOIP вызовов.

В зависимости от набираемого номера исходящие вызовы могут быть маршрутизированы через

  • SIP сеть
  • H.323 сеть
  • ISDN CAPI 2.0 линию

Исходящие вызовы SIP могут быть маршрутизированы

  • на SIP сервер с которым Fax Voip T.38 Модем зарегистрирован, вызов будет осуществлен с использованием выбранной Учетной записи SIP (с учетом Имени пользователя SIP)
  • на IP-адрес (имя SIP сервера) не ассоциированный ни с одной Учетной записью SIP

Исходящие вызовы H.323 могут быть маршрутизированы

  • на H.323 гейткипер с которым Fax Voip T.38 Модем зарегистрирован
  • на IP-адрес (имя H.323 сервера) не ассоциированный с H.323 гейткипером

Следующие правила преобразования могут применяться к набираемому номеру:

  • заданный префикс может быть добавлен к телефонному номеру
  • заданное количество первых цифр номера может быть удалено

Следующие параметры вызова и настройки факса могут быть установлены или переопределены в отдельно взятом правиле Маршрутизации исходящих VOIP вызовов:

  • UDP, TCP или TLS транспорт может быть выбран
  • Схема Tel URI может быть использована (только с исходящими SIP вызовами)
  • sips: префикс может быть использован (только с исходящими вызовами SIP через TLS)
  • Имя пользователя (Caller ID Number)
  • Отображаемое имя (Caller ID Name)
  • Режим факса (T.38, факс поверх G.711, опция отправлять T.38 ре-инвайт)
  • Максимальная скорость передачи факса
  • ECM (коррекция ошибок)
  • T.38 Redundancy
  • Голосовые кодеки

Если в таблице Маршрутизации исходящих VOIP вызовов нет ни одного правила и существует хотя бы одна Учетная запись SIP в Списке учетных записей SIP, Fax Voip T.38 Модем автоматически предлагает создать правила по умолчанию для исходящих вызовов когда вы нажимаете кнопку <Применить>.

Правила по умолчанию следующие:

  • Все вызовы, исходящие с Виртуальных COM портов (модемов) маршрутизируются с использованием первой Учетной записи SIP без преобразования номера с поддержкой как T.38 так и факс поверх G.711 режимов.

Для просмотра правил для отдельно взятого Виртуального COM порта (модема), например COM20, перейдите в Порты и модемы=>Исходящие маршруты (Маршрутизация исходящих вызовов с модемов) в Панели управления Fax Voip T.38 Модем, затем выберите требуемый порт из поля со списком.

При возникновении проблем с Маршрутизацией исходящих VOIP вызовов, вы можете включить опцию Вести протокол маршрутизации вызовов. Для этого в Панели управления Fax Voip T.38 Модем перейдите в Общие параметры, затем включите Вести протокол маршрутизации вызовов (необходимо сохранить настройки и перезапустить Fax Voip T.38 Модем). Анализ протокола поможет выявить ошибки и задать корректные правила для исходящих вызовов.

Если правила какого-либо типа не могут быть использованы в текущей конфигурации программы, Fax Voip T.38 Модем не загружает эти правила при запуске приложения и игнорирует их.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы в SIP сеть.
  • Если опция Включить SIP через UDP отключена (SIP через UDP не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы по SIP с использованием UDP транспорта.
  • Если опция Включить SIP через TCP отключена (SIP через TCP не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы по SIP с использованием TCP транспорта.
  • Если опция Включить SIP через TLS отключена (SIP через TLS не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы по SIP с использованием TLS транспорта.
  • Если опция Включить H.323 отключена (H.323 не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы в H.323 сеть.
  • Если опция Включить ISDN CAPI отключена (ISDN CAPI 2.0 не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила которые маршрутизируют вызовы через линию ISDN CAPI 2.0.

Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом в таблице Маршрутизация исходящих VOIP вызовов.

Таблица Маршрутизация исходящих VOIP вызовов содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Линия

Это поле описывает к каким линиям применяется данное правило.

' COM:.* ' означает "все виртуальные COM порты (модемы)". 'COM:20,21' означает что правило применяется только к линиям ассоциированным с портами COM20 и COM21 и не применяется к другим портам (COM22, COM23, и т.д.). Заметим что если для Виртуальных COM портов используется драйвер, поставляемый вместе с Fax Voip T.38 Модем, указываются COM-порты используемые в настройках вашей факс программы. В случае использования стороннего драйвера для Виртуальных пар COM портов, указываются COM порты на стороне Fax Voip T.38 Модем. (В этом случае ваша факс программа работает с COM портами, находящимися на другом конце виртуальной пары COM портов и эти COM порты имеют другие номера).

Если номер =

Задает формат набираемых телефонных номеров, для которых применяется данное правило. Например ' .* ' означает “любой номер”.

SIP/H.323

Указывает будет ли исходящий вызов направлен в SIP, H.323 или ISDN сеть. В случае SIP, в этом поле указывается используемый транспорт (UDP, TCP или TLS) а также будет ли использоваться схема Tel URI или префикс sips: в сообщении SIP INVITE.

Набирать номер

Задает правило преобразования набираемого телефонного номера. Например '<NUM>' означает что правило преобразования номера не применяется. '9<NUM>' означает что к номеру будет добавлен префикс – цифра 9. '<NUM-2>' означает что первые 2 цифры номера будут удалены.

Сервер

Отображает имя (IP-адрес) SIP или H.323 сервера на который маршрутизируется вызов.

В случае ISDN используется следующий формат: CAPI:[контроллер]:[B-канал], где [контроллер] – номер используемого для вызова ISDN контроллера ( ‘ * ‘ означает первый доступный контроллер) и [B-канал] – номер используемого для вызова B-канала (‘ * ‘ означает первый доступный B-канал).

<GK> означает что вызов будет направлен на H.323 гейткипер. В случае H.323, при использовании регистрации на H.323 гейткипере, следует понимать что исходящие H.323 вызовы на произвольные IP-адреса могут быть запрещены политикой гейткипера.

В случае SIP, в зависимости от того какое Имя Пользователя используется (см. ниже) и некоторых других параметров Fax Voip T.38 Модем, поведение может быть различным:

Вариант 1:

1. Сервер = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP существует по крайней мере 1 учетная запись

имя@сервер = '<name>@ sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован с использованием первой Учетной записи SIP, ассоциированной с заданным сервером.

Вариант 2:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP существует учетная запись

имя@сервер = 'NAME@sip.server.com'.

Исходящий вызов будет маршрутизирован с использованием этой Учетной записи SIP 'NAME@sip.server.com'.

Вариант 3:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. Имя сервера совпадает с именем прокси-сервера по умолчанию. (См. Параметры прокси-сервера ). Имя пользователя совпадает с именем пользователя для прокси-сервера. Опция Использовать прокси-сервер включена.

Исходящий вызов будет маршрутизирован на прокси-сервер. Имя пользователя и пароль заданные в настройках прокси-сервера могут быть использованы для аутентификации.

Вариант 4:

1. Сервер = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP нет ни одной учетной записи

имя@сервер = '<name>@sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием Имя пользователя SIP, которое задано в Параметрах SIP (по умолчанию FaxVoip). Этот метод может быть использован если авторизации не требуется.

Вариант 5:

1. Сервер = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP отсутствует учетная запись

имя@сервер = 'NAME@sip.server.com'.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием имени пользователя NAME. Этот метод может быть использован если авторизации не требуется. Если NAME состоит из одних цифр, то это имя обычно передается удаленной стороне как Caller ID NUMBER.

Имя пользователя

В случае SIP, это Имя пользователя SIP (SIP-ID) которое используется с текущим правилом. Обычно совпадает с Именем пользователя одной из Учетных записей SIP. При использовании значения *<по умолчанию>, следует понимать что в этом случае Fax Voip T.38 Модем может использовать Имя пользователя заданное в одной из Учетных записей SIP, а может использовать Имя пользователя SIP, заданное в Параметрах SIP (по умолчанию FaxVoip). Различные варианты поведения рассмотрены выше в описании поля Сервер. Имя пользователя, состоящее из одних цифр, обычно передается удаленной стороне как Caller ID NUMBER.

В случае H.323, этот параметр позволяет переопределить используемый по умолчанию Caller ID Number. При использовании *<по умолчанию>, следует понимать что верхний номер из списка Номеров телефонов (см. Параметры H.323 ) будет определен на удаленной стороне как Caller ID Number.

В случае ISDN, этот параметр позволяет переопределить используемый по умолчанию Caller ID Number. При использовании *<по умолчанию>, следует понимать что будет использоваться Имя пользователя ISDN (номер), заданное в Параметрах ISDN CAPI 2.0 . Имя пользователя, состоящее из букв, игнорируется, поэтому для включения CallerID в сообщение CAPI 2.0 при исходящем вызове следует использовать цифры.

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. Эта опция переопределяет Отображаемое имя по умолчанию, заданное в Параметрах IP-телефонии . *<> означает, что используется Отображаемое имя по умолчанию.

Прокси-сервер

Отображает адрес прокси-сервера, который используется при исходящих SIP вызовах (если задан). Не рекомендуется использовать различные прокси-сервера при осуществлении SIP регистрации и для исходящих вызовов, осуществляемых с использованием этой регистрации. Значок '=>' перед именем прокси-сервера указывает на использование прокси-сервера по умолчанию, заданного в Параметрах прокси-сервера .

Режим факса

Отображает Режим факса применяемый к данному правилу. G711 означает факс поверх G.711. T38 означает поддержку T.38 при исходящем вызове с использованием данного правила. T38+R указывает на то, что Fax Voip T.38 Модем будет отсылать T.38 ре-инвайт не дожидаясь ре-инвайта с противоположной стороны. Во избежание возможных проблем при отправке факсов, мы настоятельно рекомендуем заранее ознакомиться с подробным описанием возможных режимов факса для исходящих вызовов (см. главу T38 и G711 (аудио) режимы факса настоящего справочного руководства).

G.711 MaxRate

Максимальная скорость передачи факса для аудио факсов (факс поверх G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в Параметрах факса . ‘ * ’ указывает на то, что используется максимальная скорость передачи факса по умолчанию.

G.711 ECM

Возможность использовать Коррекцию ошибок для аудио факсов (факс поверх G.711). Эта опция переопределяет настройки по умолчанию, заданные в Параметрах факса . ‘ * ’ указывает на то, что используется значение ECM по умолчанию.

T.38 MaxRate

Максимальная скорость передачи факса по T.38. Максимальная скорость передачи факса по T.38 всегда установлена равной 14400.

T.38 ECM

Возможность использовать Коррекцию ошибок для факсов, передаваемых по T.38. Коррекция ошибок при передаче факса по T.38 всегда разрешена.

T.38 Redundancy

T.38 Redundancy в формате I/LS/HS, используемая с текущим правилом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно. Эта опция переопределяет настройки по умолчанию, заданные в полях “SIP=>T.38=>T.38 Redundancy” (для случая SIP) или в полях “H.323=>T.38=>T.38 Redundancy” (для случая H.323). ‘ * ’ указывает на то, что используются значения T.38 Redundancy по умолчанию.

Кодеки

Опция Кодеки переопределяет кодеки по умолчанию, заданные в панели “SIP=>Кодеки=>Выбранные кодеки” (в случае SIP) или в панели “H.323=>Кодеки=>Выбранные кодеки” (в случае H.323). *<> указывает на то, что используются кодеки по умолчанию. В случае ISDN используемый по умолчанию G.711 A-law или G.711 u-law кодек не может быть переопределен в отдельно взятом правиле

В контекстной вкладке Исходящие маршруты, на ленте доступны следующие команды:

Исходящие правила

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило Маршрутизации исходящих VOIP вызовов.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила Маршрутизации исходящих VOIP вызовов. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения правила Маршрутизации исходящих VOIP вызовов. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации исходящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации исходящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил Маршрутизации исходящих VOIP вызовов. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Исходящие маршруты также доступны в контекстном меню списка.


Добавление/изменение правила исходящего вызова

Добавление (или изменение) правил для исходящих вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, задайте условия, при которых применяется данное правило (номера COM портов, формат набираемого номера). Выберите VOIP протокол, SIP или H.323. Либо выберите опцию ISDN CAPI 2.0. В случае SIP, в поле Сервер SIP, не забудьте указать имя или IP-адрес SIP сервера (узла SIP), на который следует направить вызов. Вы также можете выбрать транспорт (UDP, TCP или TLS) для использования с исходящими SIP вызовами. В случае H.323, в поле Шлюз H.323, не забудьте указать IP-адрес узла H.323, на который следует направить вызов, или выберите опцию Набор номера через гейткипер, чтобы направлять вызовы на H.323 гейткипер. Более подробную информацию можно найти в главе Параметры маршрутизации исходящих VOIP вызовов , в разделе Общие параметры .

5. Перейдите на вкладку Факс.

6. На вкладке Факс, в области Режимы факса, задайте требуемый режим. При необходимости измените другие параметры. Более подробную информацию можно найти в главе Параметры маршрутизации исходящих VOIP вызовов , в разделе Параметры факса .

7. Перейдите на вкладку Кодеки.

8. На вкладке Кодеки, измените настройки кодеков если это необходимо. Более подробную информацию можно найти в главе Параметры маршрутизации исходящих VOIP вызовов , в разделе Параметры кодеков .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы изменить порядок предпочтений для правил Маршрутизации исходящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

11. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами исходящих вызовов

Управление правилами для исходящих вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Чтобы изменить порядок предпочтений для правил Маршрутизации исходящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры маршрутизации исходящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Маршрутизации исходящих VOIP вызовов.

  • Общие параметры
  • Параметры факса
  • Параметры кодеков


Общие параметры

Общие параметры (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Общие параметры

Вызовы с Fax Voip T.38 Модем

Вы можете указать, применяется ли правило ко всем, к одному или к нескольким Виртуальным COM портам (модемам).

С любого модема

Правило применяется к вызовам, исходящим с любого Виртуального COM порта (модема).

С выбранных модемов

Правило применяется к вызовам, исходящим с заданных Виртуальных COM портов (модемов). Виртуальные COM порты, для которых применяется правило, должны быть выбраны из списка. Заметим, что в случае использования Fax Voip Драйвера Виртуальных COM портов, в правой панели перечислены “внешние” порты (которые используются в настройках факс программы). В случае использования Драйвера Виртуальных COM портов от стороннего производителя, в правой панели перечислены “внутренние” порты (т.е. порты из виртуальных пар портов, которые используются в настройках Fax Voip T.38 Модем).

Исходный формат набираемого номера

Этот набор опций позволяет применять правило ко всем, единственному или группе набираемых номеров.

Если номер =

Выберите эту опцию чтобы применять правило ко всем набираемым номерам или к единственному набираемому номеру.

Выберите <любой> чтобы правило применялось ко всем набираемым номерам.

Введите телефонный номер чтобы правило применялось только для этого номера.

Если номер начинается с цифр ... и количество цифр =

Правило применяется к номерам с заданным префиксом и (или) к номерам заданной длины.

Правило набора

Этот набор опций позволяет при необходимости преобразовать набираемый номер к требуемому формату.

Набирать номер =

Используйте эту опцию чтобы маршрутизировать вызовы без изменения исходного набираемого номера, либо если вы хотите маршрутизировать все вызовы на заданный номер.

Выберите <NUM> чтобы маршрутизировать вызовы без изменения исходного набираемого номера.

Введите телефонный номер чтобы маршрутизировать все вызовы на этот номер.

Удалить цифры ... Добавить...

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру и (или) удалить из набираемого номера первые несколько цифр или других символов (1-9). При применении опции Удалить цифры к исходному набранному номеру, который содержит символы, отличные от цифр, поведение может быть непредсказуемым (с некоторыми специальными символами). Рекомендуется протестировать перед тем как использовать.

Прямой вызов на IP

Используйте эту опцию чтобы иметь возможность осуществлять прямые вызовы на разные IP-адреса. Например, вызов на номер '12345*192*168*0*2*5065' будет направлен на узел 192.168.0.2:5065 на номер 12345. При выборе этой опции, нет необходимости вводить IP-адрес или имя SIP (или H.323) сервера в поле Сервер SIP (Шлюз H.323).

Маршрутизировать вызов

Параметры, заданные в этой области, позволяют маршрутизировать вызов на заданный SIP или H.323 узел. Эти параметры также позволяют вам использовать определенную Учетную запись SIP (SIP регистрацию) для осуществления вызова или маршрутизировать вызов через H.323 гейткипер. В случае ISDN CAPI 2.0, вы можете привязать вызовы к определенному ISDN контроллеру и (или) B-каналу.

VOIP протокол

SIP

Выберите эту опцию чтобы осуществлять исходящие вызовы с использованием протокола SIP.

Транспорт

В этом поле вы можете выбрать транспорт, который будет использоваться для исходящих SIP вызовов. Выберите SIP через UDP чтобы использовать UDP. Выберите SIP через TCP чтобы использовать TCP. Выберите SIP через TLS чтобы использовать TLS. По умолчанию используется UDP. При использовании Параметров прокси-сервера по умолчанию, будет использован транспорт, заданный в параметрах прокси-сервера. Если в поле Прокси-сервер задан индивидуальный (для текущего правила) прокси-сервер, будет использоваться SIP через UDP. Заметим, что TCP и TLS могут не поддерживаться на стороне вашего сервера или SIP провайдера.

Схема Tel URI

Если эта опция выбрана, Fax Voip T.38 Модем будет использовать Tel URI схему при совершении исходящих SIP вызовов. Tel URI схема может быть использована с SIP через UDP и с SIP через TCP. Сообщение SIP INVITE будет отсылаться в следующем формате:

SIP/SDP Request: INVITE tel:74957226655;phone-context=multifon.ru, with session description

Если эта опция отключена, сообщение SIP INVITE будет отсылаться в стандартном формате:

SIP/SDP Request: INVITE sip: 74957226655@sipnet.ru, with session description

Заметим, что в случае использования Tel URI схемы, вы не можете задавать номер порта в поле Сервер SIP. Также следует понимать что далеко не каждый SIP сервер способен принимать SIP запросы с использованием Tel URI схемы, поэтому не следует включать данную опцию без необходимости. С другой стороны, насколько нам известно, некоторые сервера требуют использование Tel URI схемы. Именно поэтому мы и добавили такую возможность.

Префикс sips:

Эта опция может использоваться только если используется SIP через TLS. Если опция включена, Fax Voip T.38 Модем будет использовать префикс sips: вместо стандартного префикса sip:.

Сервер SIP

Имя или IP-адрес SIP узла или SIP сервера, на который будет маршрутизироваться вызов. Обычно совпадает с Сервером регистрации SIP одной из Учетных записей SIP (SIP регистрацией). Если заданы Учетные записи SIP, имя сервера может быть выбрано из раскрывающегося списка. Заметим, что в случае использования Tel URI схемы, вы не можете задавать номер порта в этом поле.

Прокси-сервер

Адрес прокси-сервера, который используется при исходящих SIP вызовах. Не рекомендуется использовать различные прокси-сервера при осуществлении SIP регистрации и для исходящих вызовов, осуществляемых с использованием этой регистрации. Эта опция переопределяет прокси-сервер по умолчанию, заданный в Параметрах прокси-сервера . Если вы задаете индивидуальный (для текущего правила) прокси-сервер в данном поле, то при осуществлении исходящих вызовов будет использоваться SIP через UDP. Чтобы работать с прокси-сервером по TCP или TLS, необходимо использовать глобальные Параметры прокси-сервера .

Имя пользователя

Имя пользователя SIP (SIP-ID) которое используется с текущим правилом. Обычно совпадает с Именем пользователя одной из Учетных записей SIP. Имя пользователя, состоящее из одних цифр, обычно передается удаленной стороне как Caller ID Number. Если в таблице Учетные записи SIP есть записи, в которых Сервер регистрации совпадает с именем сервера заданным в поле Сервер SIP, то Имя пользователя может быть выбрано из раскрывающегося списка.

По умолчанию

Чтобы иметь возможность изменить Имя пользователя, снимите галочку. Если эта опция включена, Fax Voip T.38 Модем будет использовать либо Имя пользователя (или SIP-ID) из первой записи в таблице Учетные записи SIP, в которой Сервер регистрации совпадает с именем сервера заданным в поле Сервер SIP, либо Имя пользователя SIP по умолчанию, заданное в Параметрах SIP .

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. Эта опция переопределяет Отображаемое имя по умолчанию, заданное в Параметрах IP-телефонии .

По умолчанию

Чтобы задать Отображаемое имя, снимите галочку. Если эта опция включена, используется Отображаемое имя по умолчанию.

В зависимости от параметров Сервер SIP, Имя пользователя и некоторых других, поведение при исходящих вызовах может быть различным:

Вариант 1:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP существует по крайней мере 1 учетная запись

имя@сервер = '<name>@ sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован с использованием первой Учетной записи SIP, ассоциированной с заданным сервером.

Вариант 2:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP существует учетная запись

имя@сервер = 'NAME@sip.server.com'

Исходящий вызов будет маршрутизирован с использованием этой Учетной записи SIP 'NAME@sip.server.com'.

Вариант 3:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. Имя сервера совпадает с именем прокси-сервера по умолчанию. (См. Параметры прокси-сервера ). Имя пользователя совпадает с именем пользователя для прокси-сервера. Опция Использовать прокси-сервер включена.

Исходящий вызов будет маршрутизирован на прокси-сервер. Имя пользователя и пароль заданные в настройках прокси-сервера могут быть использованы для аутентификации.

Вариант 4:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = '*<по умолчанию>'

3. В Списке учетных записей SIP нет ни одной учетной записи

имя@сервер = '<name>@sip.server.com', где <name> - любое имя пользователя.

Исходящий вызов будет маршрутизирован на sip.server.com с использованием Имя пользователя SIP, которое задано в Параметрах SIP (по умолчанию FaxVoip). Этот метод может быть использован если авторизации не требуется.

Вариант 5:

1. Сервер SIP = 'sip.server.com'

2. Имя пользователя = 'NAME'

3. В Списке учетных записей SIP отсутствует учетная запись

имя@сервер = 'NAME@sip.server.com'

Исходящий вызов будет маршрутизирован на sip.server.com с использованием имени пользователя NAME. Этот метод может быть использован если авторизации не требуется. Если NAME состоит из одних цифр, то это имя обычно передается удаленной стороне как Caller ID NUMBER.

H.323

Выберите эту опцию чтобы осуществлять исходящие вызовы с использованием протокола H.323.

Шлюз H.323

Имя или IP-адрес H.323 узла, на который будет маршрутизироваться вызов. При использовании регистрации на H.323 гейткипере, следует понимать что исходящие H.323 вызовы на произвольные IP-адреса могут быть запрещены политикой гейткипера.

Набор номера через гейткипер

Используйте эту опцию чтобы маршрутизировать вызовы через H.323 гейткипер.

Имя пользователя

Имя пользователя которое используется с текущим правилом. Этот параметр позволяет переопределить используемый по умолчанию Caller ID Number.

По умолчанию

Чтобы иметь возможность изменить Имя пользователя, снимите галочку. Если эта опция включена, верхний номер из списка Номеров телефонов (см. Параметры H.323 ) будет определен на удаленной стороне как Caller ID Number.

Отображаемое имя

Имя которое вы бы хотели сообщать другим пользователям. Отображаемое имя обычно отображается на удаленной стороне как Caller ID Name. Эта опция переопределяет Отображаемое имя по умолчанию, заданное в Параметрах IP-телефонии .

По умолчанию

Чтобы задать Отображаемое имя, снимите галочку. Если эта опция включена, используется Отображаемое имя по умолчанию.

ISDN CAPI 2.0

Выберите эту опцию чтобы осуществлять исходящие вызовы с использованием линии ISDN CAPI 2.0.

Имя пользователя

Имя пользователя ISDN (номер) которое используется с текущим правилом. Этот параметр позволяет переопределить используемый по умолчанию Caller ID Number. Имя пользователя, состоящее из букв, игнорируется, поэтому для включения CallerID в сообщение CAPI 2.0 следует использовать цифры. В зависимости от свойств вашей ISDN карты, CallerID может быть проигнорирован или переопределен. В случае если вы вводите неправильный ISDN номер, не удовлетворяющий ISDN настройкам вашего оборудования, исходящий вызов может быть отклонен. Заметим, что в случае использования Имени пользователя ISDN (номера), который состоит из букв, такая ошибка невозможна.

По умолчанию

Чтобы иметь возможность изменить Имя пользователя, снимите галочку. Если эта опция включена, Fax Voip T.38 Модем будет использовать Имя пользователя ISDN (номер) по умолчанию, заданное в Параметрах ISDN CAPI 2.0 .

ISDN контроллер

Параметры в этой области позволяют задать номер контроллера для осуществления исходящих вызовов через ISDN CAPI 2.0.

Первый свободный

Первый доступный ISDN контроллер будет использован для осуществления исходящих вызовов с использованием текущего правила.

Контроллер #

Задайте номер ISDN контроллера для осуществления исходящих вызовов с использованием текущего правила. Заметим, что Fax Voip T.38 Модем не проверяет существование контроллера с указанным номером во время конфигурирования. Вы должны задать реальный номер ISDN контроллера присутствующий в вашей системе.

B-канал

Параметры в этой области позволяют задать номер B-канала для осуществления исходящих вызовов через ISDN CAPI 2.0.

Первый свободный

Первый доступный B-канал будет использован для осуществления исходящих вызовов с использованием текущего правила.

B-канал #

Задайте номер B-канала для осуществления исходящих вызовов с использованием текущего правила. Заметим, что Fax Voip T.38 Модем не проверяет существование B-канала с указанным номером во время конфигурирования. Вы должны задать реальный номер B-канала присутствующий в вашей системе.


Параметры факса

Параметры факса (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Параметры факса

Режимы факса

Режимы факса применяемые к текущему правилу.

Факс поверх G.711

Включите эту опцию чтобы отправлять аудио факсы.

T.38 факс

Включите эту опцию чтобы отправлять факсы по протоколу T.38. Эту опцию можно использовать только при маршрутизации вызовов через SIP или H.323 линию.

Отправлять T.38 ре-инвайт

Если эта опция включена, Fax Voip T.38 Модем отсылает T.38 ре-инвайт немедленно после установки соединения. Если эта опция выключена, Fax Voip T.38 Модем ждет получения T.38 ре-инвайта от вызываемой стороны. Эту опцию можно использовать только при маршрутизации вызовов через SIP или H.323 линию.

Параметры аудио факса поверх G.711

Параметры, задаваемые в этой области, позволяют переопределить установки по умолчанию для Коррекции ошибок (ECM) и максимальной скорости передачи факса для аудио факсов (факс поверх G.711).

Максимальная скорость

Используйте эту опцию чтобы изменить максимальную скорость передачи факса. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в Параметрах факса .

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок. Эта опция переопределяет настройки по умолчанию, заданные в Параметрах факса .

По умолчанию

Снимите галочку, чтобы изменить Коррекцию ошибок. Если данная опция включена, используются настройки по умолчанию.

Параметры T.38

Параметры, задаваемые в этой области, позволяют переопределить установки по умолчанию для Коррекции ошибок (ECM), максимальной скорости передачи факса и T.38 Redundancy для факсов, передаваемых по T.38.

Максимальная скорость

Максимальная скорость передачи факса по T.38 всегда установлена равной 14400.

По умолчанию

Эта галочка всегда отмечена и всегда используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок. Коррекция ошибок при передаче факса по T.38 всегда разрешена.

По умолчанию

Эта галочка всегда отмечена и используются настройки по умолчанию.

T.38 Redundancy

Параметры, задаваемые в этой области, позволяют переопределить параметры по умолчанию для SIP T.38 Redundancy или H.323 T.38 Redundancy.

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

По умолчанию

Снимите галочку, чтобы изменить параметры по умолчанию для SIP (или H.323) T.38 Redundancy. Если данная опция включена, используются параметры по умолчанию для SIP (или H.323) T.38 Redundancy.

Примечания

  • При отправке факса через ISDN CAPI 2.0 линию, всегда используется режим G.711 аудио факс.


Параметры кодеков

Параметры кодеков (маршрутизация исходящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Исходящие маршруты ›› Параметры маршрутизации исходящих VOIP вызовов ››

Параметры кодеков

По умолчанию

Снимите галочку, чтобы переопределить параметры Голосовых кодеков, заданные по умолчанию. Если данная опция включена, используются параметры Голосовых кодеков по умолчанию, заданные в списке “VOIP=>SIP=>Кодеки=>Выбранные кодеки” либо в списке “VOIP=>H.323=>Кодеки=>Выбранные кодеки”.

Голосовые кодеки

Эта панель отображает конфигурацию аудио кодеков, применяемую к текущему правилу. Голосовые кодеки применяемые к текущему правилу, отмечены и выстроены в порядке предпочтений.

Чтобы добавить кодек, отметьте его в списке Голосовые кодеки. Для удаления кодека, снимите галочку с кодека в списке Голосовые кодеки.

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтений для выбранных аудио кодеков. Вы должны предварительно выделить один из кодеков в списке Голосовые кодеки.

Примечания

  • Ложный G.729* кодек позволяет сообщать поддержку кодека G.729 тем T.38 факс шлюзам, которые не поддерживают G.711 и другие поддерживаемые аудио форматы; используйте этот кодек только для решения проблем совместимости. Обычно, если используется ложный G.729* кодек, для исходящих вызовов также следует использовать режим Отправлять T.38 ре-инвайт чтобы обеспечить генерацию CNG сигнала.
  • При маршрутизации вызовов через ISDN CAPI 2.0 линию всегда используется G.711 кодек принятый по умолчанию.


Входящие маршруты

Маршрутизация входящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ››

Функция Маршрутизации входящих VOIP вызовов позволяет устанавливать различные маршруты для входящих вызовов, в зависимости от выполнения тех или иных начальных условий. В зависимости от вызывающего номера (Caller ID), вызываемого номера и прочих условий, эта функция позволяет маршрутизировать входящие вызовы на Виртуальные COM порты (линии модемов) в режиме приема факса по протоколу T.38 или в режиме приема аудио факса (факс поверх кодека G.711). Также возможно преобразование вызываемого телефонного номера путем добавления заданного префикса в начало номера. Это может быть использовано совместно с функцией Маршрутизации входящих вызовов на модемы для маршрутизации различных входящих вызовов на разные Виртуальные COM порты (модемы). Максимальное поддерживаемое количество правил Маршрутизации входящих VOIP вызовов не ограничено.

Существует три типа правил:

  • Правила применяемые к входящим SIP вызовам
  • Правила применяемые к входящим H.323 вызовам
  • Правила применяемые к входящим ISDN CAPI 2.0 вызовам

Правила различных типов выделяются различными цветами в таблице Маршрутизации входящих VOIP вызовов.

Входящий вызов может быть маршрутизирован на:

  • Виртуальные COM порты (линии модемов) с поддержкой T.38
  • Виртуальные COM порты (линии модемов) как G.711 аудио факс

К вызываемому телефонному номеру могут применяться правила преобразования номера. Например, к номеру можно добавить заранее заданный префикс. Добавление префикса может быть использовано совместно с другой функцией - Маршрутизация входящих вызовов на модемы которая позволяет вам настраивать отдельные линии модемов (Виртуальные COM порты) на прием вызовов лишь на номера с заданным префиксом. Таким образом, одновременное использование Маршрутизации входящих VOIP вызовов и Маршрутизации входящих вызовов на модемы позволяет сделать очень гибкие настройки для входящих вызовов.

Следующие параметры вызова и настройки факса могут быть установлены или переопределены в отдельно взятом правиле Маршрутизации входящих VOIP вызовов:

  • Режим факса (T.38, факс поверх G.711, детектировать/отправлять T.38 ре-инвайт опции)
  • Максимальная скорость передачи факса
  • ECM (коррекция ошибок)
  • T.38 Redundancy
  • Голосовые кодеки

Fax Voip T.38 Модем всегда проверяет правила Маршрутизации входящих VOIP вызовов, начиная с правила # 1. Вызов маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется ко всем входящим SIP вызовам ('VOIP вызов откуда' = sip:.*; 'VOIP вызов куда' = sip:.*), то все остальные правила # 2, # 3, и т.д. для входящих SIP вызовов никогда не выполнятся ни при каких условиях.

Если не существует ни одного правила, которому удовлетворяет вызов, вызов не может быть осуществлен. Чтобы принимать входящие вызовы заданного типа (SIP, H.323 или ISDN), вы должны иметь хотя бы одно правило для этого типа вызовов в таблице Маршрутизации входящих VOIP вызовов.

Если в таблице Маршрутизации входящих VOIP вызовов нет ни одного правила, Fax Voip T.38 Модем автоматически предлагает создать правила для входящих вызовов по умолчанию когда вы нажимаете кнопку <Применить>.

Правила по умолчанию следующие:

  • Все входящие SIP вызовы с префиксом sip: маршрутизируются на Виртуальные COM порты (модемы) без применения правил преобразования номера
  • Все входящие H.323 вызовы маршрутизируются на Виртуальные COM порты (модемы) без применения правил преобразования номера
  • Все входящие ISDN CAPI 2.0 вызовы маршрутизируются на Виртуальные COM порты (модемы) без применения правил преобразования номера

При возникновении проблем с Маршрутизацией входящих VOIP вызовов, вы можете включить опцию Вести протокол маршрутизации вызовов. Для этого в Панели управления Fax Voip T.38 Модем перейдите в Общие параметры, затем включите Вести протокол маршрутизации вызовов (необходимо сохранить настройки и перезапустить Fax Voip T.38 Модем). Анализ протокола поможет выявить ошибки и задать корректные правила для входящих вызовов.

Если правила какого-либо типа не могут быть использованы в текущей конфигурации программы, Fax Voip T.38 Модем не загружает эти правила при запуске приложения и игнорирует их.

  • Если опция Включить SIP отключена (SIP не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила применяемые к входящим SIP вызовам.
  • Если опция Включить SIP через TLS отключена (SIP через TLS не используется, см. Параметры SIP ), Fax Voip T.38 Модем не загружает и игнорирует правила которые содержат только префикс sips: в полях VOIP вызов откуда или VOIP вызов куда.
  • Если опция Включить H.323 отключена (H.323 не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила применяемые к входящим H.323 вызовам.
  • Если опция Включить ISDN CAPI отключена (CAPI 2.0 не используется, см. Параметры IP-телефонии ), Fax Voip T.38 Модем не загружает и игнорирует правила применяемые к входящим ISDN CAPI 2.0 вызовам.

Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом в таблице Маршрутизация входящих VOIP вызовов.

Таблица Маршрутизация входящих VOIP вызовов содержит следующую информацию:

Правило

Уникальный номер текущего правила.

VOIP вызов откуда

Задает формат SIP/H.323-URL адреса (ISDN номера) вызывающей стороны для которого применяется текущее правило. SIP/H.323-URL адрес вызывающей стороны обычно имеет формат следующего вида: 'префикс:CallerID@имя_сервера'. В случае SIP поддерживаются следующие префиксы: sip:, sips: и tel:. В случае H.323 поддерживается префикс h323:. В случае ISDN поддерживается префикс isdn:. Далее, первая часть это номер вызывающего абонента, вторая часть это имя SIP/H.323 сервера. Например, 'h323:.*' означает “H.323 вызов с любого номера и с любого H.323 сервера”, '(sip|sips|tel):.*' означает “SIP вызов с любого номера, из любой sip сети и с любым из допустимых префиксов”, 'sip:.*@sip.mynetwork.com' означает “SIP вызов с любого номера, только с сервера sip.mynetwork.com”. Наибольшие проблемы могут возникнуть при попытке задать имя_сервера. Типичной является ситуация, когда вы вводите имя сервера в виде 'sip.myserver.com', и это работает с точки зрения SIP регистрации, но при входящем вызове имя того же сервера выглядит как '@sip.myserver.com:5060'. В приведенном примере конструкция 'sip:.*@sip.myserver.com' некорректна и работать не будет, правильная конструкция для поля VOIP вызов откуда должна быть записана как: 'sip:.*@sip.myserver.com:5060'. Во избежание подобных проблем используйте опцию Вести протокол маршрутизации вызовов чтобы понять структуру SIP-URL присылаемого удаленной стороной.

VOIP вызов куда

Задает формат вызываемого номера для которого применяется текущее правило. В случае SIP поддерживаются префиксы sip:, sips: и tel:. В случае H.323 добавляется стандартный h323: префикс. В случае ISDN добавляется стандартный isdn: префикс. Например, '(sip|tel):.*' означает “вызов на любой номер с префиксом sip: или tel:”, 'sip:100@.*' означает “вызов на номер 100”.

Маршрут

Задает маршрут для входящего вызова. Здесь может применяться правило преобразования входящего номера. Например, 'line:2<NUM>' означает “маршрутизировать вызовы на линии модемов и при этом добавлять к номеру префикс 2”.

Режим факса

Отображает Режим факса применяемый к данному правилу. G711 означает факс поверх G.711. T38 означает поддержку T.38 при входящем вызове с использованием данного правила. T38R означает, что Fax Voip T.38 Модем не отправляет T.38 ре-инвайт но способен обнаружить T.38 ре-инвайт посылаемый другой стороной. Во избежание возможных проблем при приеме факсов, мы настоятельно рекомендуем заранее ознакомиться с подробным описанием возможных режимов факса для входящих вызовов (см. главу T38 и G711 (аудио) режимы факса настоящего справочного руководства).

G.711 MaxRate

Максимальная скорость передачи факса для аудио факсов (факс поверх G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в Параметрах факса . ‘ * ’ указывает на то, что используется максимальная скорость передачи факса по умолчанию.

G.711 ECM

Возможность использовать Коррекцию ошибок для аудио факсов (факс поверх G.711). Эта опция переопределяет настройки по умолчанию, заданные в Параметрах факса . ‘ * ’ указывает на то, что используется значение ECM по умолчанию.

T.38 MaxRate

Максимальная скорость передачи факса по T.38. Максимальная скорость передачи факса по T.38 всегда установлена равной 14400.

T.38 ECM

Возможность использовать Коррекцию ошибок для факсов, принимаемых или передаваемых по T.38. Коррекция ошибок при приеме/передаче факса по T.38 всегда разрешена.

T.38 Redundancy

T.38 Redundancy в формате I/LS/HS, используемая с текущим правилом. Избыточность для (I)ndication, (L)ow (S)peed и (H)igh (S)peed IFP пакетов указывается раздельно. Эта опция переопределяет настройки по умолчанию, заданные в полях “SIP=>T.38=>T.38 Redundancy” (для случая SIP) или в полях “H.323=>T.38=>T.38 Redundancy” (для случая H.323). ‘ * ’ указывает на то, что используются значения T.38 Redundancy по умолчанию. Заметим, что HS-redundancy не играет роли в случае входящих вызовов при приеме факса.

Кодеки

Опция Кодеки переопределяет кодеки по умолчанию, заданные в панели “SIP=>Кодеки=>Выбранные кодеки” (в случае SIP) или в панели “H.323=>Кодеки=>Выбранные кодеки” (в случае H.323). *<> указывает на то, что используются кодеки по умолчанию. В случае ISDN используемый по умолчанию G.711 A-law или G.711 u-law кодек не может быть переопределен в отдельно взятом правиле.

В контекстной вкладке Входящие маршруты, на ленте доступны следующие команды:

Входящие правила

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило Маршрутизации входящих VOIP вызовов.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила Маршрутизации входящих VOIP вызовов. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения правила Маршрутизации входящих VOIP вызовов. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации входящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил Маршрутизации входящих VOIP вызовов. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил Маршрутизации входящих VOIP вызовов. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Входящие маршруты также доступны в контекстном меню списка.


Добавление/изменение правила входящего VOIP вызова

Добавление (или изменение) правил для входящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация входящих вызовов, на вкладке Общие, в области VOIP протокол, выберите тип входящих вызовов, могут быть SIP или H.323. Либо выберите опцию ISDN CAPI 2.0 чтобы применять правило к входящим ISDN вызовам. В областях VOIP вызов откуда и VOIP вызов куда задайте условия, при которых применяется данное правило. В области Маршрутизировать вызов, укажите, следует ли добавлять префикс к номеру при маршрутизации входящего вызова на Виртуальные COM порты (модемы). Более подробную информацию можно найти в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры .

5. Перейдите на вкладку Факс.

6. На вкладке Факс, в области Режимы факса, задайте требуемый режим. При необходимости измените другие параметры. Более подробную информацию можно найти в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Параметры факса .

7. Перейдите на вкладку Кодеки.

8. На вкладке Кодеки, измените настройки кодеков если это необходимо. Более подробную информацию можно найти в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Параметры кодеков .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы изменить порядок предпочтений для правил Маршрутизации входящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

11. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации входящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами входящих VOIP вызовов

Управление правилами для входящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Чтобы изменить порядок предпочтений для правил Маршрутизации входящих VOIP вызовов, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации входящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры маршрутизации входящих VOIP вызовов

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Маршрутизации входящих VOIP вызовов.

  • Общие параметры
  • Параметры факса
  • Параметры кодеков


Общие параметры

Общие параметры (маршрутизация входящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ›› Параметры маршрутизации входящих VOIP вызовов ››

Общие параметры

VOIP протокол

В этой области вы можете выбрать тип входящих вызовов для которых применяется текущее правило. Правило может применяться к SIP, H.323 или ISDN CAPI 2.0 входящим вызовам.

SIP

Если выбрана эта опция, правило применяется к входящим SIP вызовам.

H.323

Если выбрана эта опция, правило применяется к входящим H.323 вызовам.

ISDN CAPI 2.0

Если выбрана эта опция, правило применяется к входящим ISDN CAPI 2.0 вызовам.

VOIP вызов откуда

Параметры этой области позволяют задать первую часть шаблона маршрута, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера (или имени пользователя), или к вызовам с определенной группы номеров. В то же время, SIP/H.323 правило может применяться к входящим вызовам с любого SIP (или H.323) узла или только к входящим вызовам с определенного SIP/H.323 узла (сервера).

Префиксы

sip:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sip: в первой части шаблона маршрута.

sips:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sips: в первой части шаблона маршрута. Вызовы с префиксом sips: возможны лишь при условии использования TLS транспорта.

tel:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом tel: в первой части шаблона маршрута (TEL URI схема).

Вызывающий номер (имя) =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера (или имени пользователя).

Выберите <любой> чтобы принимать вызовы с любого номера.

Введите номер телефона (или имя пользователя) чтобы принимать вызовы только с этого телефонного номера (или имени пользователя).

Вызывающий номер (имя) начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Из VOIP сети

Опция Из VOIP сети может использоваться только с входящими SIP или H.323 вызовами. Введите имя или IP-адрес SIP или H.323 узла (SIP/H.323 сервера), чтобы применять правило к вызовам только с этого узла (сервера). <любой> означает, что правило применяется к вызовам с любого SIP или H.323 узла. Будьте осторожны при использовании этого параметра. Типичной является ситуация, когда вы вводите имя сервера в виде 'sip.myserver.com', и это работает с точки зрения SIP регистрации, но при входящем вызове имя того же сервера выглядит как 'sip.myserver.com:5060', или даже содержит совершенно другое имя или IP-адрес. В приведенном примере конструкция 'sip.myserver.com' некорректна и работать не будет, правильная конструкция для поля Из VOIP сети должна быть записана как: 'sip.myserver.com:5060'. Во избежание подобных проблем используйте опцию Вести протокол маршрутизации вызовов чтобы понять структуру URL присылаемого удаленной стороной. Чтобы включить опцию Вести протокол маршрутизации вызовов, в Панели управления Fax Voip T.38 Модем перейдите в Общие параметры, затем включите Вести протокол маршрутизации вызовов (необходимо сохранить настройки и перезапустить Fax Voip T.38 Модем).

VOIP вызов куда

Параметры этой области позволяют задать вторую часть шаблона маршрута, для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер (или имя пользователя), или на группу телефонных номеров.

Префиксы

sip:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sip: во второй части шаблона маршрута.

sips:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом sips: во второй части шаблона маршрута. Вызовы с префиксом sips: возможны лишь при условии использования TLS транспорта.

tel:

Если эта опция выбрана, правило применяется к входящим SIP вызовам с префиксом tel: во второй части шаблона маршрута (TEL URI схема).

Вызываемый номер (имя) =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер (или имя пользователя).

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона (или имя пользователя) чтобы принимать вызовы, адресованные только на этот номер (или имя пользователя). Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона (или имя пользователя) может быть выбран из раскрывающегося списка.

Вызываемый номер (имя) начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс '2', как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 200, 201, 2000, 2001 ,...,, но не будет применяться к входящим вызовам на номера 100,301,4002 ...

Маршрутизировать вызов

Параметры, заданные в этой области, позволяют маршрутизировать входящие вызовы на Виртуальные COM порты (модемы), заданный префикс может быть добавлен к телефонному номеру назначения.

На модем на номер =

Используйте эту опцию чтобы маршрутизировать вызовы на Виртуальные COM порты (модемы) без изменения телефонного номера назначения, либо с изменением номера на фиксированный заранее заданный номер.

Выберите <NUM> для маршрутизации вызовов без изменения телефонного номера назначения.

Введите номер телефона чтобы маршрутизировать все вызовы на этот номер. Обратите внимание, этот параметр переопределяет Номер вызываемого абонента (DID). См. также в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.

На модем с префиксом

Используйте эту опцию чтобы добавить заданный префикс к телефонному номеру назначения. Это может быть полезно для совместного использования с функцией Маршрутизации входящих вызовов на модемы для маршрутизации различных групп входящих вызовов (в зависимости от добавляемого префикса) на разные Виртуальные COM порты (модемы). Обратите внимание, этот параметр переопределяет Номер вызываемого абонента (DID). См. также в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.


Параметры факса

Параметры факса (маршрутизация входящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ›› Параметры маршрутизации входящих VOIP вызовов ››

Параметры факса

Режимы факса

Режимы факса применяемые к текущему правилу.

Факс поверх G.711

Включите эту опцию чтобы принимать аудио факсы.

T.38 факс

Включите эту опцию чтобы принимать факсы по протоколу T.38. Эту опцию можно использовать только применительно к входящим вызовам SIP или H.323.

Ждать T.38 ре-инвайт

Если эта опция включена, Fax Voip T.38 Модем ждет получения T.38 ре-инвайта от вызывающей стороны. Если эта опция выключена, Fax Voip T.38 Модем отсылает T.38 ре-инвайт немедленно после установки соединения. Эту опцию можно использовать только применительно к входящим вызовам SIP или H.323.

Параметры аудио факса поверх G.711

Параметры, задаваемые в этой области, позволяют переопределить установки по умолчанию для Коррекции ошибок (ECM) и максимальной скорости передачи факса для аудио факсов (факс поверх G.711).

Максимальная скорость

Используйте эту опцию чтобы изменить максимальную скорость передачи факса. Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Эта опция переопределяет максимальную скорость передачи факса по умолчанию, заданную в Параметрах факса .

По умолчанию

Снимите галочку, чтобы изменить максимальную скорость передачи факса. Если данная опция включена, используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок. Эта опция переопределяет настройки по умолчанию, заданные в Параметрах факса .

По умолчанию

Снимите галочку, чтобы изменить Коррекцию ошибок. Если данная опция включена, используются настройки по умолчанию.

Параметры T.38

Параметры, задаваемые в этой области, позволяют переопределить установки по умолчанию для Коррекции ошибок (ECM), максимальной скорости передачи факса и T.38 Redundancy для факсов, передаваемых по T.38.

Максимальная скорость

Максимальная скорость передачи факса по T.38 всегда установлена равной 14400.

По умолчанию

Эта галочка всегда отмечена и всегда используется максимальная скорость передачи факса по умолчанию.

Коррекция ошибок (ECM)

Возможность использовать Коррекцию ошибок. Коррекция ошибок при передаче факса по T.38 всегда разрешена.

По умолчанию

Эта галочка всегда отмечена и используются настройки по умолчанию.

T.38 Redundancy

Параметры, задаваемые в этой области, позволяют переопределить параметры по умолчанию для SIP T.38 Redundancy или H.323 T.38 Redundancy .

Indication

Определяет количество избыточных T.38 факс пакетов отсылаемых для индикации CNG, CED тонов, no signal. Допустимый диапазон от 0 (нет избыточности) до 5.

LS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для низко-скоростного основанного на V.21 T.30 протокола передачи факсов. Низкая скорость используется на этапе переговоров между факс машинами что происходит на скорости 300 Bps и при плохом качестве обслуживания QoS. Допустимый диапазон от 0 (нет избыточности) до 5.

HS-Redundancy

Определяет количество избыточных T.38 факс пакетов отсылаемых для высоко-скоростных протоколов V.17, V.27, и V.29 T.4 или T.6 при передаче данных изображения. Высокая скорость используется на этапе передачи что происходит на скоростях между 2400 Kbps и 14400 Kbps. Хотя плохое качество обслуживания QoS и будет ухудшать качество изображения, несколько отсутствующих строк изображения в конечном счете не влияют на восприятие человеком полученного изображения. Допустимый диапазон от 0 (нет избыточности) до 5.

По умолчанию

Снимите галочку, чтобы изменить параметры по умолчанию для SIP (или H.323) T.38 Redundancy. Если данная опция включена, используются параметры по умолчанию для SIP (или H.323) T.38 Redundancy.

Примечания

  • При приеме факса через ISDN CAPI 2.0 линию, всегда используется режим G.711 аудио факс.


Параметры кодеков

Параметры кодеков (маршрутизация входящих VOIP вызовов)

Панель управления Fax Voip T.38 Модем ›› IP-телефония ›› Входящие маршруты ›› Параметры маршрутизации входящих VOIP вызовов ››

Параметры кодеков

По умолчанию

Снимите галочку, чтобы переопределить параметры Голосовых кодеков, заданные по умолчанию. Если данная опция включена, используются параметры Голосовых кодеков по умолчанию, заданные в списке “VOIP=>SIP=>Кодеки=>Выбранные кодеки” либо в списке “VOIP=>H.323=>Кодеки=>Выбранные кодеки”.

Голосовые кодеки

Эта панель отображает конфигурацию аудио кодеков, применяемую к текущему правилу. Голосовые кодеки применяемые к текущему правилу, отмечены и выстроены в порядке предпочтений. Заметим, что порядок предпочтения кодеков при входящих вызовах используется только если включена опция Применять порядок предпочтения кодеков.

Применять порядок предпочтения кодеков

Данная опция может использоваться только применительно к входящим SIP вызовам. Будучи включенной, эта опция означает, что порядок предпочтения кодеков применяется к входящим вызовам. В настоящий момент отсутствует возможность переопределить данную опцию в отдельно взятом правиле Маршрутизации входящих VOIP вызовов. Иными словами, всегда используется соответствующая опция по умолчанию, заданная в “SIP=>Кодеки=>Выбранные кодеки=>Применять предпочтения к входящим вызовам”.

По умолчанию

Эта опция всегда включена и информирует о том, что всегда используются параметры по умолчанию.

Чтобы добавить кодек, отметьте его в списке Голосовые кодеки. Для удаления кодека, снимите галочку с кодека в списке Голосовые кодеки.

<Вверх> и <Вниз>

Используйте эти кнопки чтобы изменить порядок предпочтений для выбранных аудио кодеков. Вы должны предварительно выделить один из кодеков в списке Голосовые кодеки.

Примечания

  • Ложный G.729* кодек позволяет сообщать поддержку кодека G.729 тем T.38 факс шлюзам, которые не поддерживают G.711 и другие поддерживаемые аудио форматы; используйте этот кодек только для решения проблем совместимости.
  • При приеме входящих вызовов через ISDN CAPI 2.0 линию всегда используется G.711 кодек принятый по умолчанию.


Виртуальные COM порты и модемы

Панель управления Fax Voip T.38 Модем ››

  • Виртуальные COM порты и модемы
  • Маршрутизация исходящих вызовов с модемов
  • Маршрутизация входящих вызовов на модемы
  • Голосовые функции модема и распознавание DTMF
  • Параметры Caller ID (Входящие вызовы на модемы)


COM порты и модемы

Виртуальные COM порты и модемы

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ››

В зависимости от вашего выбора Драйвера Виртуальных COM портов для работы с линиями модемов, отображаемая информация и настраиваемые параметры будут различными.

Fax Voip драйвер Виртуальных COM портов

Fax Voip драйвер COM портов

Если эта опция выбрана, Fax Voip T.38 Модем работает с использованием Fax Voip Драйвера Виртуальных COM портов.

Сторонний драйвер COM портов

Если эта опция выбрана, Fax Voip T.38 Модем работает с использованием Стороннего Драйвера Виртуальных COM портов. Например, вы можете использовать Eltima драйвер виртуального серийного порта или Eterlogic.com эмулятор виртуальных серийных портов .

<Добавить/Удалить>

Используйте эту кнопку чтобы добавить или удалить линии Fax Voip T.38 Модем работающие на основе Fax Voip Драйвера Виртуальных COM портов. Для изменения конфигурации Виртуальных COM портов требуются права администратора.

<Модемы>

Используйте эту кнопку для просмотра, добавления или удаления модемов, привязанных к Виртуальным COM портам Fax Voip. Fax Voip T.38 Модем устанавливает Fax Voip 14.4K TAPI Voice-Fax Modem драйвер для каждого модема. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку функций Caller ID Number и Caller ID Name. Голосовые функции модема поддерживаются драйвером модема Fax Voip через TAPI, а не только в сквозном режиме. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Для изменения конфигурации модемов требуются права администратора.

Количество линий

Это поле отображает количество Виртуальных COM портов Fax Voip, установленных в вашей системе.

Сторонние драйвера Виртуальных COM портов

В качестве альтернативы, допускается использовать драйвера Виртуальных COM портов от сторонних производителей. В панели Из каждой виртуальной пары выберите COM порт на стороне модемов Fax Voip отображаются все COM порты доступные в вашей системе (как физические так и виртуальные). Fax Voip T.38 Модем не накладывает никаких ограничений на использование сторонних драйверов Виртуальных COM портов. Таким образом, невозможно программно определить, является ли порт виртуальным или физическим и относится ли порт к виртуальной паре портов. Исключения составляют Виртуальные COM порты Fax Voip созданные драйвером Fax Voip. Виртуальные COM порты Fax Voip не отображаются в этой панели, т.е. в режиме Сторонний драйвер COM портов. Вы должны быть очень внимательны при выборе портов.

Fax Voip драйвер COM портов

Если эта опция выбрана, Fax Voip T.38 Модем работает с использованием Fax Voip Драйвера Виртуальных COM портов.

Сторонний драйвер COM портов

Если эта опция выбрана, Fax Voip T.38 Модем работает с использованием Стороннего Драйвера Виртуальных COM портов. Например, вы можете использовать Eltima драйвер виртуального серийного порта или Eterlogic.com эмулятор виртуальных серийных портов .

<Модемы>

Используйте эту кнопку для просмотра, добавления или удаления модемов. Fax Voip T.38 Модем устанавливает Fax Voip 14.4K TAPI Voice-Fax Modem драйвер для каждого модема. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку функций Caller ID Number и Caller ID Name. Голосовые функции модема поддерживаются драйвером модема Fax Voip через TAPI, а не только в сквозном режиме. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Для изменения конфигурации модемов требуются права администратора.

Количество линий

Это поле отображает количество выбранных Виртуальных COM портов используемых для работы с Fax Voip T.38 Модем.

Примечания

  • Реальное количество Виртуальных COM портов (модемов), которое вы можете использовать, зависит от вашей текущей лицензии. В пробной версии вы можете использовать только первые два порта.
  • Fax Voip T.38 Модем поставляется с собственным драйвером Виртуальных COM портов, который подписан цифровой подписью Microsoft Code Signing и полностью совместим с 64-битными версиями Windows. Возможность использования драйверов сторонних производителей сохранена но реальная необходимость использования данной функции обычно отсутствует.
  • Возможность работы со сторонними драйверами виртуальных COM портов зависит от совместимости стороннего программного обеспечения с вашей операционной системой. Примеры использования подробно обсуждаются в главе Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами данного справочного руководства.


Добавление/удаление COM портов Fax Voip

Добавление/удаление Виртуальных COM портов Fax Voip

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Порты и Модемы, затем нажмите кнопку <Добавить/Удалить>.

3. В диалоговом окне предупреждения нажмите <Да> чтобы остановить службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

4. В диалоге Выбор портов поставьте галочку напротив портов которые вы хотите добавить или (и) снимите галочку напротив портов которые вы хотите удалить.

5. Нажмите <OK>. Для изменения конфигурации Виртуальных COM портов требуются права администратора.

6. Мастер автоматически установит драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem для каждого нового COM порта. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема. При удалении COM порта модем, привязанный к этому порту, автоматически удаляется.

7. При увеличении общего количества Виртуальных COM портов, мастер добавляет новые виртуальные устройства, и инициализирует процедуру обновления драйверов.

8. На завершающем шаге, Fax Voip T.38 Модем отображает обновленный список Виртуальных COM портов и модемов, и выводит окно с предложением перезагрузить компьютер.

9. Нажмите кнопку <Перезагрузить сейчас> чтобы перезагрузить компьютер.

Примечания

  • При добавлении нового Виртуального COM порта (и модема), Windows обновляет драйвера для всех ранее установленных портов. Если общее количество Виртуальных COM портов достаточно велико, обновление драйверов может занять значительное время, даже если вы добавляете один или два порта. Обратите внимание, что Fax Voip T.38 Модем не обновляет драйвера для ранее установленных модемов.
  • Реальное количество Виртуальных COM портов (модемов), которое вы можете использовать, зависит от вашей текущей лицензии. В пробной версии вы можете использовать только первые два порта.
  • Вы можете установить любое количество Виртуальных COM портов (вплоть до 100), независимо от вашей текущей лицензии. Тем не менее, установка большого количества неиспользуемых портов не рекомендована.
  • Перезагрузка операционной системы после изменения конфигурации Виртуальных COM портов не всегда необходима. Тем не менее, не рекомендуется игнорировать этот шаг, поскольку некоторые программы могут не правильно взаимодействовать с драйверами модемов непосредственно после установки.
  • Для пользователей службы факсов Windows / Факсы и сканирование Windows, при добавлении виртуальных COM портов (модемов) необходимо вручную настроить службу факсов для использования с недавно установленными модемами. Кроме того, вы можете воспользоваться командой Настройка факс службы на ленте, подробнее см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.


Добавление/удаление модемов

Добавление/удаление модемов Fax Voip

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ››

Вы можете устанавливать, удалять и переустанавливать драйвера модемов без изменения текущей конфигурации Виртуальных COM портов.

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Порты и Модемы, затем нажмите кнопку <Модемы>.

3. В диалоговом окне предупреждения нажмите <Да> чтобы остановить службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

4. Чтобы установить новые модемы или переустановить драйвера модемов, в окне Модемы выберите COM порты для которых вы бы хотели установить или переустановить модемы, затем нажмите кнопку <Установить>. Для удаления модемов, выберите COM порты для которых вы бы хотели удалить модемы, затем нажмите кнопку <Удалить>. Для изменения конфигурации модемов требуются права администратора.

5. В диалоговом окне Установка модемов нажмите <OK> чтобы подтвердить установку/удаление модемов.

6. Мастер автоматически установит драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem для каждого выбранного COM порта. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема. Системное окно Телефон и модем появляется только для информационных целей.

7. По окончании установки, Fax Voip T.38 Модем отображает обновленный список модемов. Нажмите кнопку <OK> для того чтобы закрыть окно Модемы.

8. На завершающем шаге, Fax Voip T.38 Модем отображает обновленный список Виртуальных COM портов и модемов, и выводит окно с предложением перезагрузить компьютер.

9. Нажмите кнопку <Перезагрузить сейчас> чтобы перезагрузить компьютер.

Примечания

  • Fax Voip T.38 Модем устанавливает Fax Voip 14.4K TAPI Voice-Fax Modem драйвер для каждого модема. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку функций Caller ID Number и Caller ID Name. Голосовые функции модема поддерживаются драйвером модема Fax Voip через TAPI, а не только в сквозном режиме. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется.
  • Обратите внимание, что Fax Voip T.38 Модем не обновляет драйвера для ранее установленных модемов.
  • Перезагрузка операционной системы после изменения конфигурации модемов не всегда необходима. Тем не менее, не рекомендуется игнорировать этот шаг, поскольку некоторые программы могут не правильно взаимодействовать с драйверами модемов непосредственно после установки.
  • Для пользователей службы факсов Windows / Факсы и сканирование Windows, при добавлении виртуальных COM портов (модемов) необходимо вручную настроить службу факсов для использования с недавно установленными модемами. Кроме того, вы можете воспользоваться командой Настройка факс службы на ленте, подробнее см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.


Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ››

Для подключения Fax Voip T.38 Модем к вашему факс программному обеспечению, можно использовать драйвера Виртуальных COM портов от сторонних производителей. Связь осуществляется с помощью Виртуальной пары COM портов которая эмулирует нуль-модемный кабель. Все что вам необходимо выполнить, это создать Виртуальную пару COM портов в вашей системе (например COM10<>COM11). После этого, вы должны указать первый порт (COM10) в параметрах Fax Voip T.38 Модем, и указать второй порт (COM11) в настройках используемой факс программы. В качестве альтернативы можно привязать модем Fax Voip 14.4K TAPI Voice-Fax Modem ко второму порту и сконфигурировать факс программу для работы с этим модемом.

Что касается драйверов сторонних производителей, мы могли бы рекомендовать Eltima Virtual Serial Port Driver и Eterlogic.com Virtual Serial Ports Emulator . Вы также можете использовать другие драйвера. Однако следует принять во внимание, что далеко не все производители обеспечивают возможность передачи факса через их эмуляцию виртуальных портов. Ниже приведена сравнительная таблица для рассматриваемых драйверов.

Производитель драйвера Виртуальных COM портов | Поддержка Windows 10 Windows 8.1/8 Windows 7 32-бит | Поддержка Windows 11 / 10 / 8.1 / 8 / 7 / 2022 / 2019 / 2016 / 2012 / 2008R2 64-бит | Интерфейс Виртуального COM порта для факс программы | Возможность работы через драйвер модема | Особенности лицензирования
FaxVoip Software | ДА | ДА | ДА | ДА | Входит в поставку Fax Voip T.38 Модем
Eltima Software | ДА | ДА | ДА | ДА | НЕ БЕСПЛАТНО 14-дней ТРИАЛ
ETERLOGIC.COM | ДА | ДА | ДА | НЕТ | БЕСПЛАТНО для 32-битных систем НЕ БЕСПЛАТНО для 64-битных систем, возможно бесплатное тестирование

Примечания

  • Fax Voip T.38 Модем поставляется с собственным драйвером Виртуальных COM портов, который подписан цифровой подписью Microsoft Code Signing и полностью совместим с 64-битными версиями Windows. Возможность использования драйверов сторонних производителей сохранена но реальная необходимость использования данной функции обычно отсутствует.


Использование Fax Voip T.38 Модем с драйвером Eltima

Использование Fax Voip T.38 Модем с драйвером Eltima Virtual Serial Port

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

Чтобы подключить Fax Voip T.38 Модем к вашему факс программному обеспечению, вы можете использовать драйвер Eltima Virtual Serial Port вместо стандартного драйвера Fax Voip. Возможно прямое подключение “через COM порт", или подключение с использованием драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem.

Программное обеспечение Eltima Virtual Serial Port можно загрузить с веб-сайта Fax Voip T.38 Модем , либо с веб-сайта компании Eltima Software .

Чтобы настроить, следуйте инструкциям ниже:

  • Создание виртуальных пар COM портов Eltima
  • Настройка Fax Voip T.38 Модем для работы с виртуальными парами COM портов
  • Привязка модема к виртуальной паре COM портов
  • Настройка факс программы


Создание виртуальных пар COM портов Eltima

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ›› Использование Fax Voip T.38 Модем с драйвером Eltima ››

В примере ниже показано как создать Виртуальную пару COM портов (COM10<>COM11) с использованием драйвера Eltima Virtual Serial Port .

1. Загрузите и установите программное обеспечение Eltima Virtual Serial Port .

2. Запустите конфигуратор портов, используя ярлык Launch Virtual Serial Port Driver на рабочем столе.

3. В левой панели выберите Pair, а затем нажмите кнопку <Add a new pair>.

4. Для первого порта выберите имя порта COM10. Для второго порта выберите имя порта COM11. Нажмите кнопку <Create>.

5. Убедитесь, что виртуальная пара, состоящая из портов COM10 и COM11 была успешно установлена в вашей системе.

Виртуальные порты COM10 и COM11 соединены между собой при помощи виртуального Нуль-модемного кабеля. После установки вы можете использовать виртуальную пару портов с линией Fax Voip T.38 Модем.


Использование Fax Voip T.38 Модем с Eterlogic.com

Использование Fax Voip T.38 Модем с Eterlogic.com Virtual Serial Ports Emulator

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

Чтобы подключить Fax Voip T.38 Модем к вашему факс программному обеспечению, вы можете использовать драйвер Eterlogic.com Virtual Serial Ports Emulator вместо стандартного драйвера Fax Voip. Этот драйвер позволяет использовать прямое подключение “через COM порт".

Программное обеспечение Virtual Serial Ports Emulator можно загрузить с веб-сайта Fax Voip T.38 Модем , либо с веб-сайта разработчика ETERLOGIC.COM .

Чтобы настроить, следуйте инструкциям ниже:

  • Создание виртуальных пар COM портов Eterlogic.com
  • Автозапуск: запуск Eterlogic.com VSPE с использованием ярлыка и командной строки
  • Автозапуск: запуск Eterlogic.com VSPE в качестве службы Windows
  • Настройка Fax Voip T.38 Модем для работы с виртуальными парами COM портов
  • Проверка доступности COM портов при запуске Fax Voip T.38 Модем
  • Настройка факс программы

Примечания

  • Работа эмулятора Eterlogic.com через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem не возможна. Попытка такого использования будет приводить к зависанию факс программного обеспечения. Если для работы вашего факс приложения необходима установка драйвера модема, используйте Eltima Virtual Serial Port (см. также главу Использование Fax Voip T.38 Модем с драйвером Eltima Virtual Serial Port данного справочного руководства).


Создание виртуальных пар COM портов Eterlogic.com

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ›› Использование Fax Voip T.38 Модем с Eterlogic.com ››

В примере ниже показано как создать Виртуальную пару COM портов (COM10<>COM11) с использованием Eterlogic.com Virtual Serial Ports Emulator .

1. Загрузите и установите программное обеспечение Eterlogic.com Virtual Serial Ports Emulator (VSPE).

2. Запустите VSPE. Для перехода на русский язык, в меню Language (Язык) выберите Russian.

3. В меню Устройство выберите Создать... .

4. В окне мастера, в поле Тип устройства, выберите Pair. Затем нажмите кнопку <Далее>.

5. В поле Виртуальный порт 1 выберите имя порта COM10, а в поле Виртуальный порт 2 выберите имя порта COM11. Нажмите кнопку <Готово>.

6. Убедитесь, что виртуальная пара, состоящая из портов COM10 и COM11 появилась в вашей системе.

7. Для сохранения конфигурации в меню Файл выберите Сохранить как... . Запомните месторасположение сохраненного файла (например c:\config.vspe).

Виртуальные порты COM10 и COM11 соединены между собой при помощи виртуального Нуль-модемного кабеля. После установки вы можете использовать виртуальную пару портов с линией Fax Voip T.38 Модем.

Вы можете запускать эмулятор вручную, для этого просто кликните на файле c:\config.vspe в проводнике Windows.

Примечания

  • Eterlogic.com Virtual Serial Ports Emulator по умолчанию не запускается автоматически при старте операционной системы. Таким образом, вы должны уделить особое внимание обеспечению автоматического запуска эмулятора при старте системы. Вы можете добавить ярлык в системную папку Автозагрузка , либо создать службу VSPE_Service .


Автозапуск: запуск Eterlogic.com VSPE с использованием ярлыка

Автозапуск: запуск Eterlogic.com VSPE с использованием ярлыка и командной строки

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ›› Использование Fax Voip T.38 Модем с Eterlogic.com ››

Для обеспечения автоматической загрузки Виртуальных COM портов VSPE при старте Windows, выполните следующие действия:

1. Сконфигурируйте VSPE и сохраните файл конфигурации в файле config.vspe, как описано в предыдущем разделе. Запомните месторасположение сохраненного файла (например c:\config.vspe).

2. Создайте ярлык к исполняемому файлу VSPE. Если VSPE устанавливался с параметрами по умолчанию, т.е. в папку C:\Program Files\Eterlogic.com\Virtual Serial Ports Emulator, параметры ярлыка должны быть такими, как показано ниже:

      • Объект: "C:\Program Files\Eterlogic.com\Virtual Serial Ports Emulator\VSPEmulator.exe" -minimize -hide_splash c:/config.vspe
      • Рабочая папка: "C:\Program Files\Eterlogic.com\Virtual Serial Ports Emulator"

3. Переместите созданный ярлык в папку Пуск\Программы\Автозагрузка.


Автозапуск: запуск Eterlogic.com VSPE в качестве службы

Автозапуск: запуск Eterlogic.com VSPE в качестве службы Windows

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ›› Использование Fax Voip T.38 Модем с Eterlogic.com ››

VSPE может запускаться в качестве службы Windows при использовании специального программного обеспечения. Вы можете использовать NSSM Service Manager . Вы можете загрузить его с веб-сайта Fax Voip T.38 Модем , либо с веб-сайта разработчика .

1. Загрузите и установите программное обеспечение NSSM.

2. Сконфигурируйте VSPE и сохраните файл конфигурации в файле config.vspe, как описано выше. Запомните месторасположение сохраненного файла (например c:\config.vspe).

3. Запустите cmd.exe с опцией Запуск от имени администратора. Перейдите в папку NSSM и выполните команду nssm install VSPE_Service.

4. Задайте путь к файлу VSPEmulator.exe и путь к файлу конфигурации. Нажмите кнопку <Install service>.

5. В случае успешной установки службы, вы увидите сообщение Service successfully installed!.

6. Запустите службу командой net start VSPE_Service (с опцией Запуск от имени администратора) либо перезагрузите компьютер.


Настройка Fax Voip T.38 Модем с виртуальными парами COM портов

Настройка Fax Voip T.38 Модем для работы с виртуальными парами COM портов

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

В примере ниже показано как настроить Fax Voip T.38 Модем для работы с Виртуальными COM портами от сторонних разработчиков. Предполагается, что две Виртуальные пары COM портов уже созданы в вашей системе, как показано на рисунке ниже. Первая пара: COM10<>COM11. Вторая пара: COM12<>COM13.

Для настройки Fax Voip T.38 Модем выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Порты и Модемы, проверьте что выбрана опция Сторонний драйвер COM портов.

3. В панели Из каждой виртуальной пары выберите COM порт на стороне модемов Fax Voip, поставьте галочку напротив порта COM10, который является первым портом из пары COM10<>COM11. Поставьте галочку напротив порта COM12, который является первым портом из пары COM12<>COM13.

4. Нажмите кнопку <Применить> чтобы сохранить настройки. Не забудьте перезапустить Fax Voip T.38 Модем. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Теперь линии Fax Voip T.38 Модем доступны на стороне вашего факс программного обеспечения через Второй порт COM11 из виртуальной пары COM10<>COM11 и через Второй порт COM13 из виртуальной пары COM12<>COM13.

Если для работы с вашим факс программным обеспечением необходим драйвер модема, вам необходимо привязать Fax Voip 14.4K TAPI Voice-Fax Modem ко Второму порту COM11 из виртуальной пары COM10<>COM11 и ко Второму порту COM13 из виртуальной пары COM12<>COM13. См. в главе Привязка модема к виртуальной паре COM портов настоящего справочного руководства.


Проверка доступности COM портов при запуске

Проверка доступности COM портов при запуске Fax Voip T.38 Модем

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

В некоторых реализациях драйверов Виртуальных COM портов, например в случае Eterlogic.com Virtual Serial Ports Emulator , Виртуальные COM порты не присутствуют в системе постоянно. Для запуска эмуляции в этом случае необходимо запустить поставляемое приложение. Обычно эмуляция запускается при старте операционной системы. См. примеры в главах Автозапуск: запуск Eterlogic.com VSPE с использованием ярлыка и командной строки и Автозапуск: запуск Eterlogic.com VSPE в качестве службы Windows настоящего справочного руководства. При использовании подобных сценариев может случиться, что Fax Voip T.38 Модем не обнаруживает порт при запуске. Предлагаемая опция позволяет ждать загрузки эмуляции порта до 10 секунд.

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Общие параметры.

3. Включите опцию При запуске проверять доступность COM портов. Если эта опция включена, Fax Voip T.38 Модем при запуске ждет окончания запуска эмулятора VSPE в течении максимум 10-ти секунд. Используется в сочетании с режимом автозапуска VSPE при старте операционной системы. Дело в том, что если вы запускаете Fax Voip T.38 Модем, а эмуляция портов VSPE еще не запущена, то Fax Voip T.38 Модем будет впоследствии недоступен через эти порты. Заметим, что данная опция не может использоваться при включенной опции Запускать Fax Voip T.38 Модем как службу Windows.

4. Нажмите кнопку <Применить> чтобы сохранить настройки.

Примечания

  • Нет необходимости использовать эту опцию при работе с драйвером Eltima Virtual Serial Port .


Привязка модема к виртуальной паре COM портов

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

В примере ниже показано как установить драйвер модема в случае если Fax Voip T.38 Модем настроен для работы с Виртуальными COM портами от сторонних разработчиков. Предполагается, что две Виртуальные пары COM портов уже созданы в вашей системе. Первая пара: COM10<>COM11. Вторая пара: COM12<>COM13. Также предполагается, что Первый порт COM10 из виртуальной пары COM10<>COM11 и Первый порт COM12 из виртуальной пары COM12<>COM13 подключены к Fax Voip T.38 Модем, см. в главе Настройка Fax Voip T.38 Модем для работы с виртуальными парами COM портов настоящего справочного руководства. Модемы Fax Voip 14.4K TAPI Voice-Fax Modem должны быть привязаны ко Второму порту COM11 из виртуальной пары COM10<>COM11 и ко Второму порту COM13 из виртуальной пары COM12<>COM13.

Чтобы установить модемы выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Порты и Модемы, проверьте что выбрана опция Сторонний драйвер COM портов.

3. Нажмите кнопку <Модемы>.

4. В диалоговом окне предупреждения нажмите <Да> чтобы остановить службу Fax Voip T.38 Модем (приложение Fax Voip T.38 Модем).

5. В окне Модемы выберите COM порты для которых вы бы хотели установить модемы. В приводимом примере следует привязать первый модем ко Второму порту COM11 из первой виртуальной пары COM10<>COM11 и второй модем ко Второму порту COM13 из второй виртуальной пары COM12<>COM13. Будьте внимательны при выборе портов В случае использования Стороннего драйвера Виртуальных COM портов, Fax Voip T.38 Модем отображает все существующие в вашей системе порты, за исключением портов выбранных в панели Из каждой виртуальной пары выберите COM порт на стороне модемов Fax Voip и портов созданных драйвером Fax Voip (если таковые установлены в вашей системе). В нашем примере COM10 и COM12 не будут отображаться.

6. Нажмите кнопку <Установить>. Для изменения конфигурации модемов требуются права администратора.

7. В диалоговом окне Установка модемов нажмите <OK> чтобы подтвердить установку модемов.

8. Мастер автоматически установит драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem для каждого выбранного COM порта. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема. Системное окно Телефон и модем появляется только для информационных целей.

9. По окончании установки, Fax Voip T.38 Модем отображает обновленный список модемов. Нажмите кнопку <OK> для того чтобы закрыть окно Модемы.

10. На завершающем шаге, Fax Voip T.38 Модем выводит окно с предложением перезагрузить компьютер.

11. Нажмите кнопку <Перезагрузить сейчас> чтобы перезагрузить компьютер.

Примечания

  • Fax Voip T.38 Модем устанавливает Fax Voip 14.4K TAPI Voice-Fax Modem драйвер для каждого модема. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку функций Caller ID Number и Caller ID Name. Голосовые команды поддерживаются драйвером модема Fax Voip через TAPI а не только в сквозном режиме. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется.
  • Обратите внимание, что Fax Voip T.38 Модем более не обновляет драйвера для ранее установленных модемов.
  • Перезагрузка операционной системы после изменения конфигурации модемов не всегда необходима. Тем не менее, не рекомендуется игнорировать этот шаг, поскольку некоторые программы могут не правильно взаимодействовать с драйверами модемов непосредственно после установки.
  • Для пользователей службы факсов Windows / Факсы и сканирование Windows, при добавлении виртуальных COM портов (модемов) необходимо вручную настроить службу факсов для использования с недавно установленными модемами. Кроме того, вы можете воспользоваться командой Настройка факс службы на ленте, подробнее см. в главе Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.


Настройка факс программы

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› COM порты и модемы ›› Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами ››

В примере ниже показано как настроить стандартную факс программу для работы с Fax Voip T.38 Модем при использовании Виртуальных COM портов от сторонних разработчиков.

Предполагается, что Виртуальная пара COM портов COM10<>COM11 уже создана в вашей системе.

Также предполагается, что Первый порт COM10 из виртуальной пары COM10<>COM11 подключен к Fax Voip T.38 Модем, см. в главе Настройка Fax Voip T.38 Модем для работы с виртуальными парами COM портов настоящего справочного руководства.

Также предполагается, что модем Fax Voip 14.4K TAPI Voice-Fax Modem привязан ко Второму порту COM11 из виртуальной пары COM10<>COM11, см. в главе Привязка модема к виртуальной паре COM портов настоящего справочного руководства.

Прямое подключение через COM порт

Выберите Второй порт COM11 из виртуальной пары COM10<>COM11 в настройках факс программы.

Подключение с использованием драйвера модема

Выберите модем Fax Voip 14.4K TAPI Voice-Fax Modem привязанный ко Второму порту COM11 из виртуальной пары COM10<>COM11 в настройках факс программы.

Примечания

  • Работа эмулятора Eterlogic.com через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem не возможна. Попытка такого использования будет приводить к зависанию факс программного обеспечения. Если для работы вашего факс приложения необходима установка драйвера модема, используйте Eltima Virtual Serial Port (см. также главу Использование Fax Voip T.38 Модем с драйвером Eltima Virtual Serial Port данного справочного руководства).


Исходящие маршруты

Маршрутизация исходящих вызовов с модемов

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ››

Fax Voip T.38 Модем позволяет устанавливать различные наборы правил для исходящих вызовов, осуществляемых с различных Виртуальных COM портов (модемов). Панель Маршрутизация исходящих вызовов с модемов отображает правила Маршрутизации исходящих VOIP вызовов применительно к отдельно взятому Виртуальному COM порту (модему).

Для просмотра набора правил для отдельно взятой линии модема, вам следует выбрать COM порт, ассоциированный с этой линией в поле со списком Линия. Например, на рисунке выше, вы можете видеть набор правил применяемых к виртуальной линии модема, ассоциированной с портом COM21. Заметим, что в случае использования Fax Voip Драйвера Виртуальных COM портов, линия модема ассоциируется с “внешним” портом (который используется в настройках факс программы). В случае использования Драйвера Виртуальных COM портов от стороннего производителя, линия модема ассоциируется с “внутренним” портом (тот порт виртуальной пары COM портов, который используется в настройках Fax Voip T.38 Модем).

Для настройки правил Маршрутизации исходящих вызовов с модемов для отдельно взятой линии модема, необходимо настраивать правила Маршрутизации исходящих VOIP вызовов . При этом следует уделять внимание полю Линия.


Входящие маршруты

Маршрутизация входящих вызовов на модемы

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ››

Функция Маршрутизации входящих вызовов на модемы позволяет задать индивидуальные параметры для каждого Виртуального COM порта (линии модема), с точки зрения приема входящих вызовов. Допускается: принимать входящие вызовы адресованные на любой телефонный номер, принимать входящие вызовы адресованные только на номера с заданным префиксом или запретить любые входящие вызовы. Одновременное использование Маршрутизации входящих VOIP вызовов и Маршрутизации входящих вызовов на модемы позволяет сделать очень гибкие настройки для входящих вызовов. Заметим, что в случае использования Fax Voip Драйвера Виртуальных COM портов, линия модема ассоциируется с “внешним” портом (который используется в настройках факс программы). В случае использования Драйвера Виртуальных COM портов от стороннего производителя, линия модема ассоциируется с “внутренним” портом (тот порт виртуальной пары портов, который используется в настройках Fax Voip T.38 Модем).

Панель Маршрутизация входящих вызовов на модемы отображает следующую информацию:

COM порт

Номер COM порта ассоциированный с виртуальной линией модема

Правило для входящих вызовов

Допустимые опции:

      • Принимать любые входящие вызовы.
      • Принимать входящие вызовы адресованные только на номера с заданным префиксом.
      • Не принимать входящие вызовы.

Доступны следующие команды:

<Править> (или двойной щелчок мышью на выбранной записи)

Нажмите для изменения правила Маршрутизации входящих вызовов на модемы. Одна из записей должна быть выделена.

Примечания

  • Заметим, что вы также можете выполнить вышеуказанное действие, выбрав соответствующую команду из контекстного меню списка.


Изменение правил для входящих вызовов на модемы

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Входящие маршруты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Порты и Модемы, затем нажмите Входящие маршруты.

3. Для изменения правила Маршрутизации входящих вызовов на модемы, выберите COM порт и нажмите кнопку <Править> (или двойной щелчок мышью на выбранном COM порте). Заметим, что в случае использования Fax Voip Драйвера Виртуальных COM портов, линия модема ассоциируется с “внешним” портом (который используется в настройках факс программы). В случае использования Драйвера Виртуальных COM портов от стороннего производителя, линия модема ассоциируется с “внутренним” портом (тот порт виртуальной пары портов, который используется в настройках Fax Voip T.38 Модем).

4. В диалоговом окне правила Маршрутизации входящих вызовов на модем, выберите опцию Принимать любые входящие вызовы, если для выбранного порта вы хотите иметь возможность принимать входящие вызовы на любые номера.

5. Если для выбранного порта вы хотите принимать входящие вызовы только на номера с заданным префиксом, выберите опцию Только вызовы на номера с префиксом и введите префикс в поле справа.

6. Если вы не хотите использовать выбранный порт для приема входящих вызовов, выберите опцию Не принимать входящие вызовы.

7. Нажмите кнопку <OK> чтобы зафиксировать изменения.

8. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации входящих вызовов на модемы. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Голосовые функции модема и распознавание DTMF

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ››

Голосовые функции модема поддерживаются Виртуальными COM портами (модемами) Fax Voip. Fax Voip T.38 Модем может работать не только с факсами, но также и с голосовыми сообщениями.

Голосовые функции модема – возможность работать в качестве Голосового модема. Иными словами, доступны следующие возможности:

  • Воспроизведение голосовых сообщений в телефонную линию.
  • Запись голоса из телефонной линии.

В процессе записи, модем преобразует голосовые сигналы в цифровой Формат голосовых данных . При воспроизведении голосового сообщения, модем преобразует цифровые сигналы в голосовые сигналы.

Система факсимильных команд используется для работы с функциями факса. Fax Voip T.38 Модем работает по системе Fax Class 1.

Система голосовых команд используется для работы с Голосовыми функциями.

Распознавание DTMF позволяет детектировать DTMF сигналы в голосовом режиме. Это может быть использовано при работе с системами голосовой и факсимильной почты.

Форматы голосовых данных и Системы голосовых команд поддерживаемые Fax Voip T.38 Модем обсуждаются ниже.

Голосовые функции модема поддерживаются драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem через TAPI а не только в сквозном режиме.

В зависимости от возможностей вашего программного обеспечения для работы с голосовыми факс-модемами, Голосовые функции модема и Распознавание DTMF позволяют реализовать следующие функции:

  • Автоответчик
  • Голосовое приветствие перед отправкой факса или перед приемом факса
  • Отправка голосовых сообщений
  • Работа с различными системами для голоса и факса (голосовая и факсимильная почта)
  • Удаленное управление автоответчиком
  • Прослушивание телефонной линии через динамики компьютера

В связи с отсутствием единых стандартов для голосовых модемов, поведение различных программ для работы с голосовыми факс-модемами (с факсом и голосом) может различаться. Иными словами, голосовые функции могут поддерживаться частично. Полный набор описанных голосовых функций поддерживается в случае использования Fax Voip T.38 Модем с программой Venta Fax & Voice. Подробное описание о том как настроить Venta Fax & Voice для работы с Fax Voip T.38 Модем может быть найдено в главе Использование Fax Voip T.38 Модем с Venta Fax and Voice данного справочного руководства.


Форматы голосовых данных

Форматы голосовых данных модема

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Голосовые функции модема и распознавание DTMF ››

В процессе записи, модем преобразует голосовые сигналы в цифровой Формат голосовых данных. При воспроизведении голосового сообщения, модем преобразует цифровые сигналы в голосовые сигналы. Существуют различные Форматы голосовых данных. Каждый формат состоит из трех частей: метод аудио компрессии, разрядность и частота дискретизации.

Fax Voip T.38 Модем поддерживают следующие Форматы голосовых данных:

0, "16-BIT LINEAR", 16bits, 8000Hz

1, "UNSIGNED PCM", 8bits, 8000Hz

4, "ULAW ", 8bits, 8000Hz

5, "ALAW ", 8bits, 8000Hz

128, "8-BIT LINEAR", 8bits, 8000Hz

130, "UNSIGNED PCM", 8bits, 8000Hz

131, " ULAW ", 8bits, 8000Hz

132, " ALAW ", 8bits, 8000Hz

133, "16-BIT LINEAR", 16bits, 8000Hz

Поддерживаемые Форматы голосовых данных перечислены в списке Поддерживаемые аудио форматы, как показано на рисунке ниже.

Тем не менее, не все программы для работы с голосовыми факс-модемами предоставляют возможность выбрать определенный формат. Более того, различные программы могут по разному воспринимать один и тот же формат, например использовать обратный порядок бит. Все это вносит некоторые трудности при настройке параметров голосовых функций в вашей программе. Обычно, программа для работы с голосовыми факс-модемами принимает решение об использовании определенного Формата голосовых данных на основании результатов Авто-определения модема. При возникновении проблем с голосом, вы должны попытаться выбрать другую Систему голосовых команд (или выбрать другой совместимый тип модема) в вашей программе вручную. Для вашего удобства, мы разместили список поддерживаемых Форматов голосовых данных в Панели управления Fax Voip T.38 Модем.

Примечания

  • Для выбора определенного формата, вам следует использовать настройки, предлагаемые вашим программным обеспечением для работы с голосовыми факс-модемами, следуя инструкциям прилагаемым к соответствующей программе.
  • При работе с использованием драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem через TAPI и выключенным сквозным режимом, всегда используется 8-bit unsigned linear PCM at 8000 Hz format.


Системы голосовых команд

Системы голосовых команд модема

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Голосовые функции модема и распознавание DTMF ››

Если системы факсимильных команд стандартизованы, то с голосовыми командами дело обстоит совсем иначе. Как правило, каждый производитель модемов использует свою собственную Систему голосовых команд, существенно отличающуюся от тех, которые используются производителями других модемов. Попытки стандартизации в этой сфере предпринимались (стандарты IS-101 и v.253), однако лишь некоторые производители голосовых модемов поддерживают эти стандарты. Программы, разработанные для работы с Голосовыми модемами, как правило выполняют ряд операций позволяющих определить Систему голосовых команд поддерживаемую вашим модемом. Набор этих операций называется Авто-определение системы голосовых команд модема.

Разрабатывая голосовые команды, мы приняли во внимание стандарт v.253. Мы также проанализировали работу аппаратных модемов на чипсете фирмы Conexant. Нам удалось добиться практически идеальной работы Fax Voip T.38 Модем с голосовыми функциями программы Venta Fax & Voice. Venta Fax авто-детектирует Систему голосовых команд Fax Voip T.38 Модем как Conexant/Rockwell (v.253). Тем не менее, другие факс/голосовые программы могут детектировать другие Системы голосовых команд.

При возникновении проблем с голосом, вы должны попытаться выбрать другую Систему голосовых команд (или выбрать другой совместимый тип модема) в вашей программе вручную. В списке Системы голосовых команд перечислены некоторые экспериментальные результаты, которые могут быть использованы при настройке с определенными программами.

Поддерживаемые Системы голосовых команд перечислены в списке Системы голосовых команд, как показано на рисунке ниже.

Примечания

  • Для выбора определенной Системы голосовых команд, вам следует использовать настройки, предлагаемые вашим программным обеспечением для работы с голосовыми факс-модемами, следуя инструкциям прилагаемым к соответствующей программе.
  • Голосовые функции модема поддерживаются драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem через TAPI а не только в сквозном режиме.


Голосовая поддержка через TAPI драйвер модема

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Голосовые функции модема и распознавание DTMF ››

Большинство программ предназначенных для работы с голосовыми факс-модемами, в действительности не используют TAPI при работе с голосовыми функциями. Даже при работе через драйвер модема, обычно используется так называемый сквозной режим. В сквозном режиме программа взаимодействует с модемом напрямую, реализация голосовых команд в драйвере модема не требуется. Тем не менее, некоторые программы работают с голосовыми модемами через функции TAPI, что требует полной поддержки голосовых функций модема в соответствии со спецификацией TAPI. Примерами таких программ являются CallStation и IVM Answering Attendant Software .

Fax Voip T.38 Модем поставляется с TAPI-совместимым драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem. С этим драйвером голосовые функции модема поддерживаются не только в сквозном режиме как это было реализовано в предыдущих версиях, но и через стандартные TAPI функции. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема.

При работе с использованием драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem через TAPI и выключенным сквозным режимом, всегда используется 8-bit unsigned linear PCM at 8000 Hz format.

Процедура установки драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem также исправляет хорошо известную ошибку воспроизведения в Unimodem Transform Module в Windows Vista и выше (включая Windows 11 и Windows 10, как 64-битную так и 32-битную версии), которая выражается в отсутствии воспроизведения аудио в телефонную линию через модем. Любое приложение телефонии, использующее стандартный аудио драйвер модема для проигрывания аудио сталкивается с указанной проблемой. Эта проблема обсуждалась в течение многих лет на форумах Microsoft , но по каким-то причинам не была решена Microsoft до сих пор.

Кроме того, в Fax Voip T.38 Модем реализована функция Аппаратного разрыва соединения путем детектирования потери сигнала CD с помощью понижения сигнала DTR. Этот механизм часто используется в TAPI приложениях для сброса модема.


Проблемы с голосовым модемом в Windows 10

Проблемы с голосовым модемом в Windows 10: устранение неполадок

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Голосовые функции модема и распознавание DTMF ››

Проблема TAPI с голосовыми модемами в Windows 10 версии 1903 и 1909

Обратите внимание, что описанная ниже проблема в настоящее время исправлена Microsoft в Windows 10 версии 2004 и отсутствует в Windows 11 и последних версиях Windows 10, таких как Майское обновление 2020 (версия 2004, сборка 19041) и Октябрьское обновление 2020 (версия 20H2, сборка 19042). Если вы столкнулись с этой проблемой на компьютере с Windows 10, в настоящий момент мы бы рекомендовали обновить вашу систему до последней версии.

Проблема: Начиная с Windows 10 версии 1903, не работают голосовые функции модема (через TAPI). Приложение TAPI сообщает об ошибке 'Не удалось получить идентификатор модема wave out ID', при этом перезагрузка компьютера не решает проблему. Проблема присутствует как в 32-битной так и в 64-битной версии Windows 10, касается всех голосовых модемов независимо от производителя, и не имеет никакого отношения к драйверам поставляемым производителем модема.

Наиболее полные обсуждения этой проблемы можно найти в следующих ветках на форумах Microsoft:

Windows 10 1903 Voice Modem stops working

Voice Modems and Windows 10 version 1903 & 1909 TAPI problem missing "serwvdrv.dll" in registry

Решение: вам следует восстановить отсутствующие параметры 'wave*' = 'serwvdrv.dll', которые должны находиться в следующих разделах реестра Windows:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32 (64-bit OS only)

Чтобы устранить проблему, сделайте следующее:

1. Откройте Панель управления Fax Voip T.38 Модем. Для этого нажмите Пуск, выберите Fax Voip T.38 Modem; нажмите Панель управления Fax Voip T.38 Modem. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip T.38 Модем из меню иконки Fax Voip T.38 Модем в системном трее.

2. В Панели управления Fax Voip T.38 Модем, на вкладке Инструменты ленты, нажмите Исправить проблему TAPI с голосовыми модемами. Требуются права администратора.

3. Подождите, пока исправление не будет применено. Для просмотра лог-файла, в диалоговом окне нажмите <Да>.

4. Нажмите кнопку <Перезагрузить сейчас> чтобы перезагрузить компьютер.

Кроме того, вы можете использовать инструмент FixVoiceModemsTapi1903.exe, который можно загрузить с веб-сайта Fax Voip:

https://www.t38faxvoip.com/downloads/8_2_1/FixVoiceModemsTapi1903.zip

Примечания

  • Обратите внимание, что эта проблема в настоящее время исправлена Microsoft в Windows 10 версии 2004 и отсутствует в Windows 11 и в последних версиях Windows 10, таких как Майское обновление 2020 (версия 2004, сборка 19041) и Октябрьское обновление 2020 (версия 20H2, сборка 19042). Если вы столкнулись с этой проблемой на компьютере с Windows 10, в настоящий момент мы бы рекомендовали обновить вашу систему до последней версии.
  • Это исправление автоматически применяется при установке Fax Voip T.38 Модем на компьютер с Windows 10 версии 1903, 1909 или более поздней. Вы обычно должны использовать кнопку Исправить проблему TAPI с голосовыми модемами на вкладке Инструменты при обновлении системы с более ранней версии Windows.
  • Обновления Windows, включая обновление с Windows 10 версии 1903 до версии 1909, не требуют повторного применения исправления, если оно уже применено. Кроме того, вам не нужно повторно применять исправление при установке нового модема.
  • Это исправление не применяется в Windows 10 версии 1809 или более ранней, а также в других операционных системах.

Отсутствует Unimodem аудиоустройство в Диспетчере устройств (исправлено Microsoft)

Обратите внимание, что описанная ниже проблема в настоящее время исправлена Microsoft в накопительном пакете обновлений для Windows 10 версии 1607 (13 декабря 2016 г. — KB3206632) и отсутствует в Windows 11 и в последних версиях Windows 10, таких как Creators Update (версия 1703, сборка 15063) и Fall Creators Update (версия 1709, сборка 16299). Если вы столкнулись с этой проблемой на компьютере с Windows 10 или Windows Server 2016, в настоящий момент мы бы рекомендовали обновить вашу систему до последней версии.

Проблема: Начиная с Windows 10 сборка 10586, не работают голосовые функции модема (через TAPI) и Unimodem аудиоустройство не устанавливается в разделе Звуковые, игровые и видеоустройства в Диспетчере устройств. Проблема присутствует как в 32-битной так и в 64-битной версии Windows 10, касается всех голосовых модемов независимо от производителя, и не имеет никакого отношения к драйверам поставляемым производителем модема.

Наиболее полное обсуждение этой проблемы можно найти в следующей ветке на форуме Microsoft:

56K Modem missing Unimodem Audio Device after update to Windows 10 Build 10586

Решение: следует заменить системный файл modem.sys на аналогичный файл из Windows 10 сборка 10240. Для исправления используйте инструмент FixModemOnWin10.exe, который можно найти в папке FixModemOnWin10 (в папке установки Fax Voip T.38 Модем, обычно Program Files (x86)\FaxVoip Modem). Кроме того, можно загрузить инструмент с веб-сайта Fax Voip T.38 Модем:

https://www.t38faxvoip.com/downloads/7_4_1/FixModemOnWin10.zip

Примечания

  • Обратите внимание, что эта проблема в настоящее время исправлена Microsoft в накопительном пакете обновлений для Windows 10 версии 1607 (13 декабря 2016 г. — KB3206632) и отсутствует в Windows 11 и в последних версиях Windows 10, таких как Creators Update (версия 1703, сборка 15063) и Fall Creators Update (версия 1709, сборка 16299). Если вы столкнулись с этой проблемой на компьютере с Windows 10 или Windows Server 2016, мы бы рекомендовали обновить вашу систему до последней версии. По этой причине в настоящее время мы не рекомендуем использовать наше исправление.
  • Обратите внимание, что modem.sys является системным файлом и может быть заменен во время любого обновления Windows. Если это произойдет, вы можете использовать инструмент исправления повторно.


Поддерживаемые программы (голос/факс/модем)

Поддерживаемое программное обеспечение (голос/факс/модем)

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ›› Голосовые функции модема и распознавание DTMF ››

В настоящий момент, голосовые функции были успешно протестированы со следующими программами:

  • BVRP Classic Phone Tools 9
  • FaxTalk Messenger Pro 7.5
  • CallStation (поддержка голосовых функций через TAPI)
  • Venta Fax & Voice
  • VK Easy Fax

Примечания

  • Подробные инструкции по настройке Fax Voip T.38 Модем для работы с различными факсовыми и голосовыми программами можно найти в главе Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами данного справочного руководства.


Caller ID (Входящие вызовы на модемы)

Параметры Caller ID (Входящие вызовы на модемы)

Панель управления Fax Voip T.38 Модем ›› Виртуальные COM порты и модемы ››

Параметры, настраиваемые на этой вкладке, позволяют передать Номер вызываемого абонента (DID) в стандартное факс приложение (например Microsoft Fax*).

В случае модема Fax Voip, Номер вызываемого абонента (команда NDID=) передается вместе с входящим вызовом, также как и Caller ID (команда NMBR=). Однако это не поддерживается драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem из-за отсутствия каких-либо стандартов. Кроме того, стандартное факс программное обеспечение (включая Microsoft Fax*) как правило, не в состоянии распознать Номер вызываемого абонента (DID), даже если функция поддерживается модемом. В то же время, выполнение различных действий (например, маршрутизация входящих факсов через e-mail) в зависимости именно от Номера вызываемого абонента (DID) представляет наибольший практический интерес. Предлагаемый обходной путь заключается в следующем: Номер вызываемого абонента (DID) добавляется в строку Caller ID и отделяется от реального Caller ID посредством заданного разделителя. Приложение, которое работает с API функциями факс приложения (например с Microsoft Fax API) извлекает строку Caller ID и восстанавливает оригинальный Caller ID и Номер вызываемого абонента (DID). Этот обходной путь необходим для правильной работы следующих функций: Методы маршрутизации для входящих факсов (Microsoft Fax): e-mail, сохранить в папке, печать, пользовательский *.

Только номер вызывающего абонента (стандартное поведение)

Выберите этот вариант для передачи только Caller ID. На рисунке ниже показано поведение по умолчанию.

Включать номер вызываемого абонента (DID) в строку Caller ID

Выберите этот вариант для передачи как Caller ID так и Номера вызываемого абонента (DID). Этот обходной путь необходим для правильной работы следующих функций: Методы маршрутизации для входящих факсов (Microsoft Fax): e-mail, сохранить в папке, печать, пользовательский *.

Разделитель

Разделитель между Caller ID и Номером вызываемого абонента (DID). Может состоять из одного или нескольких символов. Введите или выберите из выпадающего списка. Не используйте разделители, которые могут являться частью телефонного номера. На рисунке ниже показан результат применения разделителя ;DID= .

Примечания

  • Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Методы для входящих (Microsoft Fax)

Методы маршрутизации для входящих факсов (Microsoft Fax): e-mail, сохранить в папке, печать, пользовательский

Панель управления Fax Voip T.38 Модем ››

В Fax Voip T.38 Модем реализовано Расширение маршрутизации Fax Voip T.38 Модем, которое интегрируется в службу факсов Windows. Когда служба факсов принимает факс, она маршрутизирует принятый документ через каждый из методов маршрутизации факса, определяемых расширением маршрутизации факса.

При получении факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить Методы маршрутизации для входящих факсов чтобы маршрутизировать входящие факсы получателям в сети. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), к входящим факсам могут применяться различные действия. Эти действия определяются так называемыми правилами. Для каждого метода используются независимые наборы правил.

Методы маршрутизации факса, определенные в Расширении маршрутизации Fax Voip T.38 Модем, аналогичны методам маршрутизации, которые включены в Расширение маршрутизации Майкрософт (можно использовать на любом компьютере с Windows Server, например на Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012R2 и т.д.). Существенным отличием является возможность осуществлять маршрутизацию на основе Номера вызываемого абонента (DID) и без привязки к конкретному факсимильному устройству (модему). Это стало возможным благодаря реализации обходного пути, который описан в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства. Кроме того, методы маршрутизации факса, поставляемые с Fax Voip T.38 Модем, работают не только на компьютерах под управлением Windows Server, но и на любой рабочей станции, например Windows 11, Windows 10, Windows 8.1 и т.д.

Расширение маршрутизации Fax Voip T.38 Модем включает следующие методы маршрутизации для входящих факсов, которые могут быть настроены в Панели управления Fax Voip T.38 Модем:

Отправить по электронной почте

Входящие факсы могут быть доставлены по e-mail одному или более e-mail получателям.

Сохранить в папке

Входящие факсы могут быть скопированы в одну или более локальных или сетевых папок.

Печать

Этот метод позволяет автоматически печатать входящие факсы.

Пользовательский

Этот метод позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Использование этого метода не ограничено какими-либо лицензиями.

Страница Методы маршрутизации для входящих факсов (Microsoft Fax) содержит следующую информацию:

Метод для входящих

Название Метода маршрутизации для входящих факсов

Максимальное число правил

Общее количество правил, которые могут быть использованы. Это обычно сумма базовых и дополнительных правил.

Базовое

Количество базовых правил, которые могут быть использованы. Определяется как число Виртуальных COM портов (модемов) + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.

Расширенное

Количество дополнительных правил, определяемое лицензией Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, сохранить в папке, печать).

В контекстной вкладке Методы для входящих, на ленте доступны следующие команды:

Методы для входящих (Microsoft Fax)

Отправить по электронной почте

Нажмите чтобы настроить правила метода Отправить по электронной почте (Microsoft Fax) для входящих факсов.

Сохранить в папке

Нажмите чтобы настроить правила метода Сохранить в папке (Microsoft Fax) для входящих факсов.

Печать

Нажмите чтобы настроить правила печати входящих факсов (Microsoft Fax).

Пользовательская маршрутизация

Нажмите чтобы настроить пользовательскую маршрутизацию входящих факсов (Microsoft Fax).

Кроме того, вы можете дважды щелкнуть метод в списке Методы маршрутизации для входящих факсов (Microsoft Fax) или выбрать команду Править из контекстного меню.

На следующей диаграмме представлен обзор процесса маршрутизации входящего факса:

На компьютере с Windows Server, вы можете видеть методы маршрутизации факса, определенные Расширением маршрутизации Fax Voip T.38 Модем, в Диспетчере службы факса (Microsoft), см. на рисунке ниже.

При настройке методов маршрутизации факса (Расширение маршрутизации Fax Voip T.38 Модем), обратите внимание на следующее:

  • Методы маршрутизации для входящих факсов (Microsoft Fax) должны быть настроены в Панели управления Fax Voip T.38 Модем.
  • Не следует включать или выключать методы маршрутизации факса для отдельно взятых факсимильных устройств Fax Voip 14.4K TAPI Voice-Fax Modem в Диспетчере службы факса (Microsoft) или любым другим способом. Программное обеспечение Fax Voip T.38 Модем автоматически включает или выключает метод маршрутизации факса для всех устройств Fax Voip 14.4K TAPI Voice-Fax Modem, в зависимости от наличия или отсутствия правил для этого метода.
  • При наличии лицензии Fax Voip T.38 Модем Виртуальные COM порты (модемы), вы можете использовать методы маршрутизации факса (Расширение маршрутизации Fax Voip T.38 Модем) не только с устройствами Fax Voip 14.4K TAPI Voice-Fax Modem, но также с другими факсимильными устройствами, установленными в вашей системе (аппаратные модемы и т.д.). В указанном случае вам необходимо вручную включить методы маршрутизации факса для ваших факсимильных устройств при помощи Диспетчера службы факса (Microsoft) или любым другим способом. Кроме того, скорее всего, вы не сможете маршрутизировать факсимильные сообщения на основе номера вызываемого абонента (DID), поскольку обычно он не передается в программное обеспечение Факсы и сканирование Windows.
  • На компьютере с Windows Server, вы можете задать порядок приоритетов для методов маршрутизации входящих факсов. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Маршрутизация входящих, щелкните Глобальные методы (см. рисунок выше). В области сведений щелкните правой кнопкой мыши требуемый метод, а затем выберите Вверх или Вниз. Следует понимать, что этот параметр практически не имеет эффекта, поскольку каждый метод, определяемый Расширением маршрутизации Fax Voip T.38 Модем, всегда выполняется в отдельном потоке. Такая архитектура значительно повышает надежность всего приложения, если сравнивать с нашими предыдущими реализациями (Fax Voip T38 Fax and Voice, версия 7).

Для просмотра журнала отладки для Расширения маршрутизации Fax Voip T.38 Модем, воспользуйтесь опцией Вести протокол модуля расширения маршрутизации Fax Voip T.38 Модем, более подробную информацию см. в главе Журналы маршрутизации входящих факсов (Microsoft Fax) настоящего справочного руководства. Для просмотра детализированных журналов отладки для конкретных методов маршрутизации факса, воспользуйтесь соответствующими опциями, описанными в той же главе.

Примечания

  • Для того чтобы использовать Методы маршрутизации для входящих факсов (Microsoft Fax), у вас должна быть установлена лицензия Fax Voip T.38 Модем Виртуальные COM порты (модемы).
  • Разрешенное базовое количество правил для каждого метода определяется как количество Виртуальных COM портов (модемов) плюс 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.
  • Для значительного увеличения максимального количества правил, вы можете приобрести отдельную лицензию Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, сохранить в папке, печать). Заметим что эта лицензия не может быть использована если отсутствует лицензия Fax Voip T.38 Модем Виртуальные COM порты (модемы).
  • Использование Пользовательского метода маршрутизации не ограничено какими-либо лицензиями.
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Отправить по электронной почте

Маршрутизация входящих факсов: отправить по электронной почте (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ››

При получении факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить метод маршрутизации Отправить по электронной почте чтобы маршрутизировать входящие факсы получателям по e-mail. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть отправлен различным e-mail адресатам.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Отправить по электронной почте, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; 'Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Чтобы маршрутизировать входящие факсы посредством e-mail, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации входящих VOIP вызовов чтобы принимать факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для получения факсов через модем(ы) Fax Voip
  • Настроить параметры Caller ID (Входящие вызовы на модемы)
  • Настроить параметры SMTP
  • Настроить шаблон электронной почты 'Получен новый факс (служба Microsoft Fax)' (если требуется)
  • Создать одно или более правил, в которых следует задать e-mail получателей и формат доставки факсов

Входящий факс может быть маршрутизирован одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Факсы могут доставляться по e-mail в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Отправить по электронной почте определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Отправить по электронной почте, воспользуйтесь опцией Вести протокол метода маршрутизации 'Отправить по электронной почте (MS Fax)', более подробную информацию см. в главе Журналы маршрутизации входящих факсов (Microsoft Fax) настоящего справочного руководства. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: отправить по электронной почте содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы ) данного справочного руководства.

Включено

Указывает, будет ли Fax Voip T.38 Модем отправлять сообщения e-mail. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Электронная почта

Список e-mail адресатов.

Копия

Список e-mail адресов которые будут использоваться в поле Копия сообщения электронной почты.

Скрытая копия

Список e-mail адресов которые будут использоваться в поле Скрытая копия сообщения электронной почты.

Вкладывать факс

Указывает, будет ли копия принятого факса прикреплена к сообщению электронной почты.

Формат

Задает формат доставки факса. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла для прикрепленного факса. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff.

Шаблоны e-mail

Указывает, используются ли для шаблона электронной почты 'Получен новый факс (служба Microsoft Fax)' пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Отправить по почте, на ленте доступны следующие команды:

Правила отправки по почте

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Отправить по электронной почте.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Отправить по электронной почте. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Отправить по электронной почте. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Отправить по электронной почте. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Отправить по электронной почте. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Отправить по электронной почте. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Отправить по почте также доступны в контекстном меню списка.

Примечания

  • Для маршрутизации факсов на основе Номера вызываемого абонента (DID), выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. В противном случае все правила за исключением правил с Вызываемый номер = <любой> (.*) будут игнорироваться. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.
  • При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Отправить по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Отправить по электронной почте.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Отправка по электронной почте, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Общие параметры .

5. Перейдите на вкладку E-mail.

6. На вкладке E-mail, поставьте флажок у параметра После приема переслать факс по электронной почте чтобы включить правило. В области Выбрать получателей, задайте получателей сообщения email. Адрес электронной почты и имя получателя сначала вводятся в поля Введите e-mail получателя и Введите имя получателя (не обязательно), после чего получатель добавляется в один из списков Получатели сообщения с помощью кнопок <Кому>, <Копия> и <Скрытая копия>. Для выбора получателей из адресной книги (Контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Параметры E-mail .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат доставки факса, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Если вы не хотите вкладывать факс в сообщение электронной почты, поставьте флажок Не вкладывать копию принятого факса. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Параметры формата .

9. Перейдите на вкладку Шаблоны.

10. На вкладке Шаблоны, укажите, следует ли для шаблона электронной почты 'Получен новый факс (служба Microsoft Fax)' использовать пользовательские настройки или настройки по умолчанию. Настройте шаблон электронной почты, который будет использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры метода “Отправить по электронной почте” , в разделе Шаблоны электронной почты .

11. Нажмите кнопку <OK> чтобы зафиксировать изменения.

12. Чтобы изменить порядок предпочтений для правил метода Отправить по электронной почте (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

13. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Отправить по электронной почте (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Отправить по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Отправить по электронной почте.

3. Чтобы изменить порядок предпочтений для правил метода Отправить по электронной почте (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Отправить по электронной почте

Параметры метода “Отправить по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Отправки по электронной почте (Microsoft Fax).

  • Общие параметры
  • Параметры E-mail
  • Параметры формата
  • Шаблоны электронной почты


Общие параметры

Общие параметры (Отправить по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой> чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства. При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс '1631', как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры E-mail

Параметры E-mail (Отправить по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Параметры E-mail

После приема переслать факс по электронной почте

Данная опция позволяет разрешить или запретить отправку e-mail сообщений. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить отправку e-mail сообщений, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не отсылает электронную почту по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку факсов на e-mail для определенного вызывающего (или вызываемого) номера.

Выбрать получателей

В этой области, вы можете задать получателей e-mail сообщения.

Введите e-mail получателя

Адрес электронной почты добавляемого получателя изначально должен быть введен в это поле.

Введите имя получателя (не обязательно)

Имя добавляемого получателя изначально должно быть введено в это поле.

<Адресная книга>

Позволяет выбрать получателей e-mail сообщений из адресной книги (Контакты Windows).

Получатели сообщения

<Кому>

Используйте эту кнопку для добавления адресата в основной список получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из основного списка получателей e-mail сообщений.

<Копия>

Используйте эту кнопку для добавления адресата в список “Копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Копия” получателей e-mail сообщений.

<Скрытая копия>

Используйте эту кнопку для добавления адресата в список “Скрытая копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Скрытая копия” получателей e-mail сообщений.


Параметры формата

Параметры формата (Отправить по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Параметры формата

Формат доставки факса

В этой области можно выбрать формат доставки факса для текущего правила, а также указать, следует ли вкладывать копию принятого факса в сообщение электронной почты.

Доставлять входящие факсы в формате

Выберите формат доставки факса для текущего правила. Входящий факс может быть доставлен по e-mail как TIFF, PDF или SFF вложение.

Не вкладывать копию принятого факса

Поставьте флажок у этого параметра, если вы не хотите вкладывать факс в сообщение электронной почты.

Шаблон имени файла

В этой области можно указать шаблон имени файла для прикрепляемых факсов.

Использовать шаблон по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата доставки факса).

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %CallerID%, %StartTime%, %PagesReceived% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %CallerID%. Номер телефона вызывающего устройства.
      • %CalledNumber%. Номер телефона вызываемого абонента (DID).
      • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
      • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
      • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
      • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
      • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
      • %PagesReceived%. Количество страниц в принятом факсимильном документе.
      • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата доставки факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Шаблоны электронной почты

Шаблоны электронной почты (Отправить по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Отправить по электронной почте ›› Параметры метода Отправить по электронной почте ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблона электронной почты 'Получен новый факс (служба Microsoft Fax)' .

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующий шаблон доступен для редактирования: Получен новый факс (служба Microsoft Fax).

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Получен новый факс (служба Microsoft Fax), см. Шаблоны электронной почты: Получен новый факс (служба Microsoft Fax) . Настройки шаблона на вкладке правила отправки по электронной почте делаются аналогично.


Сохранить в папке

Маршрутизация входящих факсов: сохранить в папке (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ››

При получении факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить метод маршрутизации Сохранить в папке чтобы копировать входящие факсы в заданные локальные или сетевые папки. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть скопирован в различные папки.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Сохранить в папке, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; 'Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Чтобы сохранять входящие факсы в заданных папках, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации входящих VOIP вызовов чтобы принимать факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для получения факсов через модем(ы) Fax Voip
  • Настроить параметры Caller ID (Входящие вызовы на модемы)
  • Создать одно или более правил, в которых следует задать имена папок и формат сохранения входящих факсов

Входящий факс может быть маршрутизирован в одну или более локальных или сетевых папок. Входящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Сохранить в папке определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Сохранить в папке, воспользуйтесь опцией Вести протокол метода маршрутизации 'Сохранить в папке (MS Fax)', более подробную информацию см. в главе Журналы маршрутизации входящих факсов (Microsoft Fax) настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: сохранить в папке содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.

Включено

Указывает, будет ли Fax Voip T.38 Модем сохранять факсы в заданных папках. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Сохранить в папке

Отображает пути к папкам для хранения копий входящих факсов.

Формат

Задает формат сохранения входящих факсов. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла, используемый при копировании принятых факсов в заданные папки. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

В контекстной вкладке Сохранить в папке, на ленте доступны следующие команды:

Правила сохранения в папке

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Сохранить в папке.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Сохранить в папке. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Сохранить в папке. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Сохранить в папке. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Сохранить в папке также доступны в контекстном меню списка.

Примечания

  • Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке.
  • Для маршрутизации факсов на основе Номера вызываемого абонента (DID), выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. В противном случае все правила за исключением правил с Вызываемый номер = <любой> (.*) будут игнорироваться. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.
  • При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Сохранить в папке.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Сохранение в папке, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Общие параметры .

5. Перейдите на вкладку Сохранить в папке.

6. На вкладке Сохранить в папке, поставьте флажок у параметра После приема скопировать факс в указанные папки чтобы включить правило. В области Сохранить в папке, задайте папки для сохранения входящих факсов. Путь к папке должен быть сначала выбран или введен в текстовое поле, после чего добавлен в список Сохранить в папках с помощью кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры сохранения .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат для сохранения входящих факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры формата .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке. В диалоговом окне, показанном на рисунке ниже, нажмите Да чтобы предоставить доступ к указанным папкам для учетной записи Network Service.

11. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

12. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Сохранить в папке (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Сохранить в папке.

3. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Сохранить в папке

Параметры метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Сохранение в папке (Microsoft Fax).

  • Общие параметры
  • Параметры сохранения
  • Параметры формата


Общие параметры

Общие параметры (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой> чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства. При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс '1631', как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры сохранения

Параметры сохранения (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры сохранения

После приема скопировать факс в указанные папки

Данная опция позволяет разрешить или запретить процедуру сохранения в папках. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить копирование факсов в указанные папки, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного вызывающего (или вызываемого) номера.

Сохранить в папке

В этой области, вы можете задать локальные или сетевые папки, в которых следует сохранять входящие факсы.

<Обзор>

Нажмите эту кнопку для выбора желаемой папки с использованием системного диалогового окна Обзор папок. Можно выбрать локальную или сетевую папку.

Вы также можете вручную ввести путь к папке в текстовое поле.

Сохранить в папках

<Добавить>

Используйте эту кнопку для добавления папки в список папок. Папка должна быть изначально выбрана или введена в текстовое поле.

<Удалить>

Используйте эту кнопку для удаления папки из списка папок.

Примечания

  • Чтобы использовать метод Сохранить в папке, у учетной записи Network Service (Сетевая служба) должен быть доступ к используемой папке.


Параметры формата

Параметры формата (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры формата

Формат сохранения входящих факсов

В этой области можно выбрать формат сохранения факса для текущего правила.

Сохранять входящие факсы в формате

Выберите формат сохранения для текущего правила. Входящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла, используемый при копировании принятых факсов в заданные папки.

Использовать шаблон по умолчанию

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %CallerID%, %StartTime%, %PagesReceived% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %CallerID%. Номер телефона вызывающего устройства.
      • %CalledNumber%. Номер телефона вызываемого абонента (DID).
      • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
      • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
      • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
      • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
      • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
      • %PagesReceived%. Количество страниц в принятом факсимильном документе.
      • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата сохранения факса).

Примечания

  • При создании файлов с одинаковыми именами (например, если задан пользовательский шаблон имени файла без использования %переменных%), к имени файла добавляется порядковый номер. Например, если шаблон имени файла - 'FAX', а формат факса - 'PDF', факсы будут копироваться в заданную папку (папки) со следующими именами: FAX.pdf, FAX (2).pdf, FAX (3).pdf ....


Печать

Маршрутизация входящих факсов: печать (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ››

При получении факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить выборочную печать входящих факсов, используя метод маршрутизации Печать. В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть напечатан с использованием различных принтеров.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Печать, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех входящих вызовов ('Caller ID' = .*; 'Вызываемый номер' = .*), то другие правила # 2, # 3, и т.д. применяемые к входящим вызовам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Чтобы осуществлять печать входящих факсов на заданный принтер, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации входящих VOIP вызовов чтобы принимать факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для получения факсов через модем(ы) Fax Voip
  • Настроить параметры Caller ID (Входящие вызовы на модемы)
  • Создать одно или более правил, в которых следует задать имена принтеров

Входящий факс может быть маршрутизирован на один или несколько принтеров.

Максимально допустимое количество правил метода Печать определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Печать, воспользуйтесь опцией Вести протокол метода маршрутизации 'Печать (MS Fax)', более подробную информацию см. в главе Журналы маршрутизации входящих факсов (Microsoft Fax) настоящего справочного руководства.

Таблица Маршрутизация входящих факсов: печать содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Caller ID

Задает шаблон Caller ID, для которого применяется текущее правило.

Вызываемый номер

Задает шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.

Включено

Указывает, будет ли осуществляться печать входящих факсов. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Принтер

Отображает принтеры для печати входящих факсов.

В контекстной вкладке Печать, на ленте доступны следующие команды:

Правила печати

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Печать.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Печать. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Печать. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Печать. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Печать также доступны в контекстном меню списка.

Примечания

  • При использовании метода Печать, печать выполняется от имени учетной записи Network Service (Сетевая служба). По этой причине, выбранный принтер не должен выводить никаких дополнительных диалоговых окон перед печатью.
  • Для маршрутизации факсов на основе Номера вызываемого абонента (DID), выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. В противном случае все правила за исключением правил с Вызываемый номер = <любой> (.*) будут игнорироваться. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.
  • При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Печать ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Печать.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Печать, на вкладке Общие, задайте условия, при которых применяется данное правило (в областях Caller ID и Номер вызываемого абонента (DID)). Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Общие параметры .

5. Перейдите на вкладку Печать.

6. На вкладке Печать, поставьте флажок у параметра Напечатать факс после приема чтобы включить правило. В области Выбор принтеров, задайте имена принтеров. Вам следует выбрать принтер в поле со списком, а затем добавить его в список Имена принтеров при помощи кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Параметры печати .

7. Нажмите кнопку <OK> чтобы зафиксировать изменения.

8. Чтобы изменить порядок предпочтений для правил метода Печать (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

9. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Печать (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Печать ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для входящих (MS Fax), затем нажмите Печать.

3. Чтобы изменить порядок предпочтений для правил метода Печать (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Печать

Параметры метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Печать ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Печать (Microsoft Fax).

  • Общие параметры
  • Параметры печати


Общие параметры

Общие параметры (Печать, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Печать ›› Параметры метода Печать ››

Общие параметры

Caller ID

Параметры этой области позволяют задать шаблон Caller ID, для которого применяется текущее правило. Правило может применяться к входящим вызовам с любого телефонного номера, с жестко заданного номера, или к вызовам с определенной группы номеров.

Caller ID =

Если выбрана эта опция, правило применяется к входящим вызовам с любого номера или к входящим вызовам с заданного номера.

Выберите <любой> чтобы принимать вызовы с любого номера.

Введите номер телефона чтобы принимать вызовы только с этого телефонного номера.

Caller ID начинается с

Если выбрана эта опция, правило применяется к входящим вызовам с группы телефонных номеров с заданным префиксом.

Номер вызываемого абонента (DID)

Параметры этой области позволяют задать шаблон Номера вызываемого абонента (DID), для которого применяется текущее правило. Правило может применяться к входящим вызовам на любой номер, на заданный номер, или на группу телефонных номеров. Для распознавания DID на стороне программы Microsoft Fax, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства. При маршрутизации факсов на основе Номера вызываемого абонента (DID), обратите внимание, что Вызываемый номер (DID) может быть переопределен в настройках правил Маршрутизации входящих VOIP вызовов . Подробнее см. в главе Параметры маршрутизации входящих VOIP вызовов , в разделе Общие параметры . Чтобы избежать подмены номера вызываемого абонента, в вашем правиле, в области Маршрутизировать вызов, выберите вариант На модем на номер = а затем выберите <NUM> из выпадающего списка (опция по умолчанию).

Вызываемый номер =

Если выбрана эта опция, правило применяется к входящим вызовам на любой номер или на заданный номер.

Выберите <любой>, чтобы принимать вызовы, адресованные на любой номер телефона.

Введите номер телефона чтобы принимать вызовы, адресованные только на этот номер. Если есть записи в таблице Учетные записи SIP (или в списке Номеров телефонов H.323), то номер телефона может быть выбран из раскрывающегося списка.

Вызываемый номер начинается с

Если выбрана эта опция, правило применяется к входящим вызовам на группу телефонных номеров с заданным префиксом. Например, если задан префикс '1631', как показано на рисунке ниже, правило будет применяться к входящим вызовам на номера 16317008090, 16314901610,...,, но не будет применяться к входящим вызовам на номера 14259876543, 13601234567 ...


Параметры печати

Параметры печати (Печать, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Печать ›› Параметры метода Печать ››

Параметры печати

Напечатать факс после приема

Данная опция позволяет включить или отключить печать входящих факсов. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить печать, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного вызывающего (или вызываемого) номера.

Выбор принтеров

В этой области, вы можете задать принтеры для печати входящих факсов.

Перед добавлением принтера, следует выбрать его в поле со списком.

Имена принтеров

<Добавить>

Используйте эту кнопку для добавления принтера в список принтеров. Принтер должен быть предварительно выбран в поле со списком.

<Удалить>

Используйте эту кнопку для удаления принтера из списка принтеров.


Пользовательская маршрутизация

Пользовательская маршрутизация входящих факсов (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ››

Пользовательский метод маршрутизации (Microsoft Fax), определенный Расширением маршрутизации Fax Voip T.38 Модем, позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса. Использование этого метода не ограничено какими-либо лицензиями.

Этот метод предоставляет поставщикам программного обеспечения гибкий способ подключения приложений, которые маршрутизируют полученные факсимильные сообщения, используя различные методы маршрутизации. Эти методы маршрутизации могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д. Поставщик программного обеспечения отвечает за разработку функций своего метода, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации.

При выполнении Пользовательского метода маршрутизации (Расширение маршрутизации Fax Voip T.38 Модем), служба факсов Windows запускает указанное пользователем приложение после получения факса. Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу (файл TIFF) и другие важные параметры, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т. д., а затем выполнить любые требуемые действия. Пользовательское приложение должно автоматически завершать работу после выполнения. Приложение отвечает за удаление копии факса (файл TIFF) и папки, в которой она находится. Пользовательское приложение запускается с использованием учетной записи Network Service (Сетевая служба). Таким образом, учетная запись Network Service должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение. Подробнее см. в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

Пользовательское приложение, запускаемое после получения факса

Здесь вы можете выбрать приложение, которое будет запущено после получения факса. Вы можете выбрать приложение, нажав на кнопку справа от текстового поля, либо ввести путь к исполняемому файлу. Пример пользовательского приложения (RouteCustomMS.exe) можно найти в папке установки Fax Voip T.38 Модем, обычно C:\Program Files (x86)\FaxVoip Modem\RouteCustomMS.exe. См. также в главе Пример пользовательского приложения настоящего справочного руководства.

Создавать временную копию принятого факса (файл TIFF)

При выборе этой опции метод создает временную папку (в папке %temp% для учетной записи Network Service) и копирует принятый факс (файл TIFF) в эту папку. Временная папка (%temp%) для учетной записи Network Service обычно C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\. Путь к временному файлу TIFF передается в пользовательское приложение через аргумент командной строки TiffFileName. Пользовательское приложение отвечает за удаление временного TIFF файла и временной папки, в которой этот файл находится. Если флажок не установлен, метод не создает копию полученного факса, однако пользовательское приложение все равно может получить доступ к принятому факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Включить пользовательский метод маршрутизации

Программное обеспечение Fax Voip T.38 Модем автоматически включает или выключает Пользовательский метод маршрутизации факса (Расширение маршрутизации Fax Voip T.38 Модем) для всех устройств Fax Voip 14.4K TAPI Voice-Fax Modem, в зависимости от того, установлен ли этот флажок или нет.


Требования к пользовательскому приложению

Требования к пользовательскому приложению (информация для разработчика)

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Пользовательская маршрутизация ››

Пользовательское приложение маршрутизации, указанное пользователем, запускается службой факсов Windows при выполнении Пользовательского метода маршрутизации (Расширение маршрутизации Fax Voip T.38 Модем), после получения факса. Индивидуальный разработчик отвечает за разработку этого приложения, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации. Функции приложения могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д.

Ниже приведены общие требования, которые должны быть приняты во внимание разработчиками программного обеспечения при написании пользовательских приложений.

Аргументы командной строки

Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу (файл TIFF) и другие важные параметры, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т. д.

Ниже приведен пример аргументов командной строки, переданных вашему приложению:

/@@@TiffFileName=C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\42008_cc\FAX.tif

/@@@JobId=42008 /@@@ElapsedTime=00:00:51

/@@@ReceiveTime=11.18.2021@04:21:08 /@@@PageCount=1

/@@@Csid=Fax Voip T.38 Modem /@@@Tsid=(901) 222-3344

/@@@CallerId=19012223344 /@@@RoutingInfo=16314901610

/@@@ReceiverName=Fax Voip 14.4K TAPI Voice-Fax Modem /@@@ReceiverNumber=Fax Voip T.38 Modem

/@@@DeviceName=Fax Voip 14.4K TAPI Voice-Fax Modem /@@@DeviceId=65592

Аргументы командной строки приблизительно соответствуют элементам структуры FAX_ROUTE , см. ниже:

/@@@TiffFileName=

Временная копия файла TIFF, связанная с принятым факсимильным документом. Этот файл и временная папка, в которой он находится (в папке %temp% для учетной записи Network Service), должны быть удалены в пользовательском приложении маршрутизации после выполнения необходимых действий. Если флажок Создавать временную копию принятого факса (файл TIFF) не установлен, этот аргумент отсутствует в командной строке. См. также в главе Пользовательская маршрутизация входящих факсов (Microsoft Fax) настоящего справочного руководства.

/@@@JobId=

Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.

/@@@ElapsedTime=

Представляет общее время, прошедшее между началом и окончанием приема факса в формате 'hh:mm:ss'.

/@@@ReceiveTime=

Время начала выполнения задания факса, связанного с приемом факсимильного документа, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@PageCount=

Количество страниц в принятом факсимильном документе.

/@@@Csid=

Идентификатор факса локального факсимильного устройства (Local Fax ID), принявшего факс. Обычно состоит из номера факса получателя и названия организации.

/@@@Tsid=

Идентификатор факса удаленного передающего факсимильного устройства, отправившего факс. Как правило, представляет собой комбинацию из номера факса отправителя и названия организации.

/@@@CallerId=

Идентифицирует вызывающее устройство, которое отправило факсимильный документ. Эта строка обычно содержит номер телефона вызывающего устройства. Библиотека Расширения маршрутизации Fax Voip T.38 Модем (FaxVoipModemRouteExtWin64.dll / FaxVoipModemRouteExtWin32.dll) анализирует строку Caller ID, предоставленную службой факса, а затем сохраняет реальный Caller ID в аргументе командной строки /@@@CallerId=. См. также в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.

/@@@RoutingInfo=

Cтрока маршрутизации для принятого факсимильного документа. Библиотека Расширения маршрутизации Fax Voip T.38 Модем (FaxVoipModemRouteExtWin64.dll / FaxVoipModemRouteExtWin32.dll) анализирует строку Caller ID, предоставленную службой факса, а затем сохраняет номер вызываемого абонента (DID) в аргументе командной строки /@@@RoutingInfo=. Для распознавания DID на стороне службы факсов Windows, выберите опцию Включать номер вызываемого абонента (DID) в строку Caller ID и задайте разделитель между Caller ID и DID. Подробнее см. в главе Параметры Caller ID (Входящие вызовы на модемы) данного справочного руководства.

/@@@ReceiverName=

Согласно MSDN, имя получателя факсимильного документа (обычно совпадает с DeviceName и не используется).

/@@@ReceiverNumber=

Согласно MSDN, телефонный номер факсимильного устройства принявшего факс (обычно совпадает с Csid - идентификатором факса локального устройства, как правило не используется).

/@@@DeviceName=

Имя устройства, которое приняло факсимильный документ.

/@@@DeviceId=

Постоянный идентификатор линии принимающего факсимильного устройства.

Временная копия полученного факса (файл TIFF)

Если установлен флажок Создавать временную копию принятого факса (файл TIFF) (см. в главе Пользовательская маршрутизация входящих факсов (Microsoft Fax) настоящего справочного руководства), Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip T.38 Модем) создает временную папку и копирует принятый факс (файл TIFF) в эту папку. Временная папка создается в папке %temp% для учетной записи Network Service (Сетевая служба). Путь к временному файлу TIFF передается в пользовательское приложение через аргумент командной строки TiffFileName, см. выше.

Например,

/@@@TiffFileName=C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\42008_cc\FAX.tif

Путь к файлу TIFF:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\42008_cc\FAX.tif

Путь к временной папке:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\42008_cc\

Временная папка, в которой находится файл TIFF (FAX.tif), может использоваться вашим пользовательским приложением для хранения временных файлов, создаваемых вашим приложением.

Пользовательское приложение отвечает за удаление временного TIFF файла и временной папки, в которой этот файл находится. Вы должны навсегда удалить временную папку в своем приложении после выполнения всех необходимых действий.

Если флажок Создавать временную копию принятого факса (файл TIFF) не установлен, Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip T.38 Модем) не создает копию полученного факса, однако пользовательское приложение все равно может получить доступ к принятому факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Запуск под учетной записью Network Service (Сетевая служба)

Пользовательское приложение запускается в контексте службы факсов Windows от имени учетной записи Network Service (Сетевая служба). Таким образом, учетная запись Network Service должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение.

Завершение приложения

Пользовательский метод маршрутизации (Расширение маршрутизации Fax Voip T.38 Модем) запускает пользовательское приложение маршрутизации в отдельном потоке путем вызова функции CreateProcess . Служба факсов Windows не отслеживает приложение после его запуска и не гарантирует его корректное завершение. Разработчик пользовательского приложения отвечает за правильное автоматическое завершение работы приложения после его выполнения.


Пример пользовательского приложения

Панель управления Fax Voip T.38 Модем ›› Методы для входящих (Microsoft Fax) ›› Пользовательская маршрутизация ››

Пример пользовательского приложения маршрутизации (RouteCustomMS.exe) можно найти в папке установки Fax Voip T.38 Модем, обычно C:\Program Files (x86)\FaxVoip Modem\RouteCustomMS.exe.

Исходные коды (архив RouteCustomMS.zip) можно найти в папке данных Fax Voip T.38 Модем, обычно C:\ProgramData\FaxVoip Modem\Samples\RouteCustomMS.zip. Чтобы распаковать архив, щелкните его правой кнопкой мыши и выберите Извлечь все... из контекстного меню.

Пример кода - консольное приложение, написанное на языке Visual Basic .Net, которое может быть скомпилировано с использованием Microsoft Visual Studio 2013 или более поздней версии.

В этом примере демонстрируется использование пользовательского метода маршрутизации (Microsoft Fax) для входящих факсов, с учетом требований, предъявляемых к написанию такого приложения, см. также в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

  • Приложение анализирует предопределенную командную строку и заполняет внутреннюю структуру, где оно сохраняет путь к временному файлу TIFF и другие параметры маршрутизации, такие как CallerID, номер вызываемого абонента (DID), TSID, CSID и т.д.
  • Записывает информацию о маршрутизации в стандартный ini-файл.
  • Копирует временный TIFF файл в указанную папку с уникальным именем, которое содержит дату и время получения факса.
  • Перед тем как завершить работу, приложение удаляет временную папку и временный файл TIFF, находящийся в этой папке.
  • Приложение автоматически завершается после выполнения всех необходимых действий.
  • Приложение использует папки и файлы, для которых учетная запись Network Service (Сетевая служба) заведомо имеет доступ на запись.

Чтобы использовать пример

1. Скопируйте файл RouteCustomMS.exe в папку установки Fax Voip T.38 Модем. Вы можете использовать другую папку, но убедитесь, что учетная запись Network Service (Сетевая служба) имеет доступ к используемой папке.

2. Откройте Панель управления Fax Voip T.38 Модем. Нажмите Методы для входящих (MS Fax), затем нажмите Пользовательский.

3. На странице Пользовательская маршрутизация входящих факсов (Microsoft Fax), установите флажок Включить пользовательский метод маршрутизации.

4. В поле Пользовательское приложение, запускаемое после получения факса, введите путь к файлу RouteCustomMS.exe, либо выберите файл, нажав на кнопку справа от текстового поля.

5. Установите флажок Создавать временную копию принятого факса (файл TIFF).

6. Нажмите кнопку <Применить>, чтобы сохранить изменения.

После получения факса,

1. Откройте папку данных Fax Voip T.38 Модем в проводнике Windows, обычно C:\ProgramData\FaxVoip Modem\.

2. В подпапке RouteCustomMS найдите файл RouteCustomMS.ini.

3. В подпапке RouteCustomMS\Incoming Faxes найдите копию принятого факса.

4. Файл журнала маршрутизации RouteCustomMS.txt сохраняется в подпапке log.


Методы для исходящих (Microsoft Fax)

Методы маршрутизации для исходящих факсов (Microsoft Fax): e-mail, сохранить в папке, печать, пользовательский

Панель управления Fax Voip T.38 Модем ››

При отправке факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить Методы маршрутизации для исходящих факсов чтобы маршрутизировать исходящие факсы. В зависимости от номера факса получателя, а также успешной или неудачной доставки факса, к исходящим факсам могут применяться различные действия. Эти действия определяются так называемыми правилами. Для каждого метода используются независимые наборы правил.

Следующие методы маршрутизации для исходящих факсов могут быть настроены:

Уведомления о доставке по электронной почте

Уведомление о доставке может быть отправлено на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса.

Сохранить в папке

Исходящие факсы могут быть скопированы в одну или более локальных или сетевых папок.

Печать

Этот метод позволяет автоматически печатать исходящие факсы.

Пользовательский

Этот метод позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Использование этого метода не ограничено какими-либо лицензиями.

Страница Методы маршрутизации для исходящих факсов (Microsoft Fax) содержит следующую информацию:

Метод для исходящих

Название Метода маршрутизации для исходящих факсов

Приоритет

Приоритетный порядок выполнения методов маршрутизации для исходящих факсов. Следует понимать, что методы маршрутизации для данного факса выполняются последовательно в одном потоке. Выполнение некоторых операций (отправка электронной почты, преобразование в другой графический формат, печать и т.д.) может занять определенное время, часто до нескольких секунд. Чтобы изменить порядок выполнения методов, используйте команды Вверх и Вниз, см. ниже.

Максимальное число правил

Общее количество правил, которые могут быть использованы. Это обычно сумма базовых и дополнительных правил.

Базовое

Количество базовых правил, которые могут быть использованы. Определяется как число Виртуальных COM портов (модемов) + 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.

Расширенное

Количество дополнительных правил, определяемое лицензией Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, сохранить в папке, печать).

В контекстной вкладке Методы для исходящих, на ленте доступны следующие команды:

Методы для исходящих (Microsoft Fax)

Уведомления на e-mail

Нажмите чтобы настроить правила метода Уведомления о доставке по электронной почте (Microsoft Fax) для исходящих факсов.

Сохранить в папке

Нажмите чтобы настроить правила метода Сохранить в папке (Microsoft Fax) для исходящих факсов.

Печать

Нажмите чтобы настроить правила печати исходящих факсов (Microsoft Fax).

Пользовательская маршрутизация

Нажмите чтобы настроить пользовательскую маршрутизацию исходящих факсов (Microsoft Fax).

Приоритет

Используйте команды ниже чтобы изменить порядок выполнения методов маршрутизации для исходящих факсов (Microsoft Fax). Один из методов должен быть выделен.

Вверх (Ctrl + U)

Переместить выбранный метод вверх.

Вниз (Ctrl + D)

Переместить выбранный метод вниз.

Кроме того, вы можете дважды щелкнуть метод в списке Методы маршрутизации для исходящих факсов (Microsoft Fax) или выбрать команду Править из контекстного меню.

На следующей диаграмме представлен обзор процесса маршрутизации исходящего факса:

При использовании методов маршрутизации для исходящих факсов (Microsoft Fax), обратите внимание на следующее:

  • При наличии лицензии Fax Voip T.38 Модем Виртуальные COM порты (модемы), вы можете использовать методы маршрутизации для исходящих факсов (Microsoft Fax) не только с устройствами Fax Voip 14.4K TAPI Voice-Fax Modem, но также с другими факсимильными устройствами, установленными в вашей системе (аппаратные модемы и т.д.).
  • На компьютере с операционной системой Windows Server, для доступа к успешно отправленным факсам, необходимо настроить службу факсов для архивирования всех успешно отправленных факсов в папку Отправленные, см. ниже.
  • Методы маршрутизации для исходящих факсов (Microsoft Fax) вызываются из модуля Почта-на-факс - Microsoft Fax (служба Fax Voip T.38 Modem MsFax Mail). По этой причине, подсистема Почта-на-факс - Microsoft Fax (служба Fax Voip T.38 Modem MsFax Mail) запускается, если хотя бы один из методов настроен для использования.
  • Методы маршрутизации для исходящих факсов (Microsoft Fax) обрабатывают только исходящие факсы, созданные под учетной записью текущего пользователя или учетной записью пользователя, под которой запущена служба Fax Voip T.38 Modem MsFax Mail (если Fax Voip T.38 Модем запущен в качестве службы Windows), см. также в главе Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства. Это связано с тем, что функции Fax Service Extended COM API не могут отслеживать события для факсов, созданных под другими учетными записями пользователей (по дизайну). Проблема не может быть исправлена в приложении Fax Voip T.38 Модем. Если это критично, используйте другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP), в котором указанная проблема устранена и Методы маршрутизации для исходящих факсов работают независимо от учетной записи пользователя, под которой было создано задание факса, см. также примечания ниже.

Для просмотра журнала отладки маршрутизации исходящих факсов, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов (Microsoft Fax), более подробную информацию см. в главе Журналы маршрутизации исходящих факсов (Microsoft Fax) настоящего справочного руководства. Методы маршрутизации для исходящих факсов (Microsoft Fax) вызываются из модуля Почта-на-факс - Microsoft Fax (служба Fax Voip T.38 Modem MsFax Mail) и это отражается в соответствующем журнале отладки, используйте опцию Вести протокол функции Почта-на-факс - служба факсов Windows, см. в главе Журналы электронной почты .

Примечания

  • Для того чтобы использовать Методы маршрутизации для исходящих факсов (Microsoft Fax), у вас должна быть установлена лицензия Fax Voip T.38 Модем Виртуальные COM порты (модемы).
  • Разрешенное базовое количество правил для каждого метода определяется как количество Виртуальных COM портов (модемов) плюс 1. Пробная версия позволяет использовать не более 2-х правил каждого типа.
  • Для значительного увеличения максимального количества правил, вы можете приобрести отдельную лицензию Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, сохранить в папке, печать). Заметим что эта лицензия не может быть использована если отсутствует лицензия Fax Voip T.38 Модем Виртуальные COM порты (модемы).
  • Использование Пользовательского метода маршрутизации не ограничено какими-либо лицензиями.
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.

Настройка службы факсов для архивирования всех успешно отправленных факсов

На компьютере с операционной системой Windows Server, для доступа к успешно отправленным факсам, необходимо настроить службу факсов для архивирования всех успешно отправленных факсов в папку Отправленные. Обычно это настраивается автоматически при установке Fax Voip T.38 Модем, см. также Настройка службы факсов из панели управления Fax Voip T.38 Модем .

Чтобы вручную настроить службу факсов для архивации всех входящих и отправленных факсов на компьютере с Windows Server, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Архивы, установите флажок Архивировать все факсы в папку. По умолчанию, входящие и отправленные факсы сохраняются в папке C:\ProgramData\Microsoft\Windows NT\MSFax. Нажмите Применить.


Уведомления на e-mail

Маршрутизация исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ››

При отправке факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить метод маршрутизации Уведомления о доставке по электронной почте для отправки уведомлений на один или несколько адресов электронной почты, чтобы подтвердить успешную доставку факса. Уведомления о доставке позволяют сообщать пользователям, был ли доставлен факс или нет. Обратите внимание, что этот функционал является полностью независимым от аналогичной функции, используемой совместно с функцией Почта-на-факс - Microsoft Fax , см. описание параметра Уведомление о доставке на адрес электронной почты отправителя в главе Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax настоящего справочного руководства. Уведомление по электронной почте отправляется независимо от способа создания факса. В зависимости от номера факса получателя, а также успешной или неудачной доставки факса, уведомление о доставке может быть отправлено различным e-mail адресатам.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Уведомления о доставке по электронной почте, начиная с правила # 1. Уведомление о доставке факса будет отправлено согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя.

Чтобы использовать функционал Уведомления о доставке по электронной почте, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации исходящих VOIP вызовов чтобы отправлять факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для отправки факсов через модем(ы) Fax Voip
  • Настроить параметры SMTP
  • Настроить шаблон электронной почты 'Факс успешно отправлен (служба Microsoft Fax)' (если требуется)
  • Настроить шаблон электронной почты 'Не удалось отправить факс (служба Microsoft Fax)' (если требуется)
  • Создать одно или более правил, в которых следует задать e-mail получателей и формат доставки факсов

Уведомление о доставке может быть отправлено одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Копия отправленного факса может быть прикреплена к сообщению электронной почты в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Уведомления о доставке по электронной почте определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации исходящего факса Уведомления о доставке по электронной почте, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов (Microsoft Fax), более подробную информацию см. в главе Журналы маршрутизации исходящих факсов (Microsoft Fax) настоящего справочного руководства. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: уведомления о доставке по e-mail (Microsoft Fax) содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли Fax Voip T.38 Модем отправлять сообщения e-mail. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя.

Электронная почта

Список e-mail адресатов.

Копия

Список e-mail адресов которые будут использоваться в поле Копия сообщения электронной почты.

Скрытая копия

Список e-mail адресов которые будут использоваться в поле Скрытая копия сообщения электронной почты.

Вкладывать факс

Указывает, будет ли копия отправленного факса прикреплена к сообщению электронной почты.

Формат

Задает формат файла для прикрепленного факса. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла для прикрепленного факса. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff.

Шаблоны e-mail

Указывает, используются ли для шаблонов электронной почты пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Уведомления на e-mail, на ленте доступны следующие команды:

Правила отправки по почте

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Уведомления о доставке по электронной почте.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Уведомления о доставке по электронной почте. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Уведомления о доставке по электронной почте. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Уведомления о доставке по электронной почте. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Уведомления о доставке по электронной почте. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Уведомления о доставке по электронной почте. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Уведомления на e-mail также доступны в контекстном меню списка.

Примечания

  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Уведомления о доставке по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Уведомления на e-mail.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Уведомления о доставке по электронной почте, на вкладке Общие, укажите номера факсов получателей, для которых применяется данное правило (в области Номер факса получателя). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Общие параметры .

5. Перейдите на вкладку E-mail.

6. На вкладке E-mail, поставьте флажок у параметра После отправки факса отправить уведомление по электронной почте чтобы включить правило. В области Выбрать получателей, задайте получателей сообщения email. Адрес электронной почты и имя получателя сначала вводятся в поля Введите e-mail получателя и Введите имя получателя (не обязательно), после чего получатель добавляется в один из списков Получатели сообщения с помощью кнопок <Кому>, <Копия> и <Скрытая копия>. Для выбора получателей из адресной книги (Контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Параметры E-mail .

7. Перейдите на вкладку Формат.

8. На вкладке Формат укажите, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла для прикрепляемого факса, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Параметры формата .

9. Перейдите на вкладку Шаблоны.

10. На вкладке Шаблоны, укажите, следует ли для шаблонов электронной почты использовать пользовательские настройки или настройки по умолчанию. Настройте шаблоны электронной почты, которые будут использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры метода “Уведомления о доставке по электронной почте” , в разделе Шаблоны электронной почты .

11. Нажмите кнопку <OK> чтобы зафиксировать изменения.

12. Чтобы изменить порядок предпочтений для правил метода Уведомления о доставке по электронной почте (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

13. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Уведомления о доставке по электронной почте (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Уведомления о доставке по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Уведомления на e-mail.

3. Чтобы изменить порядок предпочтений для правил метода Уведомления о доставке по электронной почте (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Уведомления на e-mail

Параметры метода “Уведомления о доставке по электронной почте” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Уведомления о доставке по электронной почте (Microsoft Fax).

  • Общие параметры
  • Параметры E-mail
  • Параметры формата
  • Шаблоны электронной почты


Общие параметры

Общие параметры (Уведомления о доставке по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры E-mail

Параметры E-mail (Уведомления о доставке по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Параметры E-mail

После отправки факса отправить уведомление по электронной почте

Данная опция позволяет разрешить или запретить отправку e-mail сообщений. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить отправку e-mail сообщений, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не отсылает уведомление о доставке факса по заданным e-mail адресам. Это может быть использовано чтобы временно приостановить отправку уведомлений для определенного номера факса получателя.

Выбрать получателей

В этой области, вы можете задать получателей e-mail сообщения.

Введите e-mail получателя

Адрес электронной почты добавляемого получателя изначально должен быть введен в это поле.

Введите имя получателя (не обязательно)

Имя добавляемого получателя изначально должно быть введено в это поле.

<Адресная книга>

Позволяет выбрать получателей e-mail сообщений из адресной книги (Контакты Windows).

Получатели сообщения

<Кому>

Используйте эту кнопку для добавления адресата в основной список получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из основного списка получателей e-mail сообщений.

<Копия>

Используйте эту кнопку для добавления адресата в список “Копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Копия” получателей e-mail сообщений.

<Скрытая копия>

Используйте эту кнопку для добавления адресата в список “Скрытая копия” получателей e-mail сообщений. Адрес электронной почты и имя получателя должны быть изначально введены в поля Введите e-mail получателя и Введите имя получателя (не обязательно).

<Удалить>

Используйте эту кнопку для удаления адресата из списка “Скрытая копия” получателей e-mail сообщений.


Параметры формата

Параметры формата (Уведомления о доставке по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Параметры формата

Формат доставки факса

В этой области можно указать, следует ли вкладывать копию факса в сообщение электронной почты и выбрать формат файла, в котором вы хотите получить копию отправленного факса (для текущего правила).

Вкладывать копию отправленного факса в формате:

Установите этот флажок, чтобы прикрепить копию факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию факса. Может быть TIFF, PDF либо SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла для прикрепляемых факсов.

Использовать шаблон по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Шаблоны электронной почты

Шаблоны электронной почты (Уведомления о доставке по электронной почте, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Уведомления на e-mail ›› Параметры метода Уведомления на e-mail ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблонов электронной почты, см. главу Шаблоны электронной почты настоящего справочного руководства.

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующие шаблоны доступны для редактирования: Факс успешно отправлен (служба Microsoft Fax), Не удалось отправить факс (служба Microsoft Fax).

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Факс успешно отправлен (служба Microsoft Fax), см. Шаблоны электронной почты: Факс успешно отправлен (служба Microsoft Fax) . Настройки шаблона для правила Уведомления о доставке по электронной почте делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось отправить факс (служба Microsoft Fax), см. Шаблоны электронной почты: Не удалось отправить факс (служба Microsoft Fax) . Настройки шаблона для правила Уведомления о доставке по электронной почте делаются аналогично.


Сохранить в папке

Маршрутизация исходящих факсов: сохранить в папке (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ››

При отправке факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить метод маршрутизации Сохранить в папке чтобы копировать исходящие факсы в заданные локальные или сетевые папки. В зависимости от номера факса получателя, а также успешной или неудачной доставки факса, исходящий факс может быть скопирован в различные папки.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Сохранить в папке, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя.

Чтобы сохранять исходящие факсы в заданных папках, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации исходящих VOIP вызовов чтобы отправлять факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для отправки факсов через модем(ы) Fax Voip
  • Создать одно или более правил, в которых следует задать имена папок и формат сохранения исходящих факсов

Исходящий факс может быть маршрутизирован в одну или более локальных или сетевых папок. Исходящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Максимально допустимое количество правил метода Сохранить в папке определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации исходящего факса Сохранить в папке, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов (Microsoft Fax), более подробную информацию см. в главе Журналы маршрутизации исходящих факсов (Microsoft Fax) настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: сохранить в папке (Microsoft Fax) содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли Fax Voip T.38 Модем сохранять факсы в заданных папках. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя.

Сохранить в папке

Отображает пути к папкам для хранения копий исходящих факсов.

Формат

Задает формат сохранения исходящих факсов. Может быть TIFF, PDF или SFF.

Шаблон имени файла

Пользовательский шаблон имени файла, используемый при копировании исходящих факсов в заданные папки. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

В контекстной вкладке Сохранить в папке, на ленте доступны следующие команды:

Правила сохранения в папке

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Сохранить в папке.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Сохранить в папке. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Сохранить в папке. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Сохранить в папке. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Сохранить в папке. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Сохранить в папке также доступны в контекстном меню списка.

Примечания

  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Сохранить в папке.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Сохранение в папке, на вкладке Общие, укажите номера факсов получателей, для которых применяется данное правило (в области Номер факса получателя). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Общие параметры .

5. Перейдите на вкладку Сохранить в папке.

6. На вкладке Сохранить в папке, поставьте флажок у параметра После отправки скопировать факс в указанные папки чтобы включить правило. В области Сохранить в папке, задайте папки для сохранения исходящих факсов. Путь к папке должен быть сначала выбран или введен в текстовое поле, после чего добавлен в список Сохранить в папках с помощью кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры сохранения .

7. Перейдите на вкладку Формат.

8. На вкладке Формат, выберите формат для сохранения исходящих факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры метода “Сохранить в папке” , в разделе Параметры формата .

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

11. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Сохранить в папке (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Сохранить в папке.

3. Чтобы изменить порядок предпочтений для правил метода Сохранить в папке (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Сохранить в папке

Параметры метода “Сохранить в папке” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Сохранение в папке (Microsoft Fax).

  • Общие параметры
  • Параметры сохранения
  • Параметры формата


Общие параметры

Общие параметры (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры сохранения

Параметры сохранения (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры сохранения

После отправки скопировать факс в указанные папки

Данная опция позволяет разрешить или запретить процедуру сохранения в папках. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить копирование факсов в указанные папки, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не сохраняет факсы в заданных папках. Это может быть использовано чтобы временно отключить копирование факсов в заданные папки для определенного номера факса получателя.

Сохранить в папке

В этой области, вы можете задать локальные или сетевые папки, в которых следует сохранять исходящие факсы.

<Обзор>

Нажмите эту кнопку для выбора желаемой папки с использованием системного диалогового окна Обзор папок. Можно выбрать локальную или сетевую папку.

Вы также можете вручную ввести путь к папке в текстовое поле.

Сохранить в папках

<Добавить>

Используйте эту кнопку для добавления папки в список папок. Папка должна быть изначально выбрана или введена в текстовое поле.

<Удалить>

Используйте эту кнопку для удаления папки из списка папок.


Параметры формата

Параметры формата (Сохранить в папке, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Сохранить в папке ›› Параметры метода Сохранить в папке ››

Параметры формата

Формат сохранения исходящих факсов

В этой области можно выбрать формат сохранения факса для текущего правила.

Сохранять исходящие факсы в формате

Выберите формат сохранения для текущего правила. Исходящие факсы могут сохраняться в формате TIFF, PDF или SFF.

Шаблон имени файла

В этой области можно указать шаблон имени файла, используемый при копировании исходящих факсов в заданные папки.

Использовать шаблон по умолчанию

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имена файлов формируются на основе текущей даты и времени, а также случайного значения.

Использовать пользовательский шаблон:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата сохранения факса).

Примечания

  • При создании файлов с одинаковыми именами (например, если задан пользовательский шаблон имени файла без использования %переменных%), к имени файла добавляется порядковый номер. Например, если шаблон имени файла - 'FAX', а формат факса - 'PDF', факсы будут копироваться в заданную папку (папки) со следующими именами: FAX.pdf, FAX (2).pdf, FAX (3).pdf ....


Печать

Маршрутизация исходящих факсов: печать (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ››

При отправке факсов с использованием приложения Microsoft Fax * (через Виртуальные COM порты Fax Voip), вы можете настроить выборочную печать исходящих факсов, используя метод маршрутизации Печать. В зависимости от номера факса получателя, а также успешной или неудачной доставки факса, исходящий факс может быть напечатан с использованием различных принтеров.

Поведение определяется так называемыми правилами. Fax Voip T.38 Модем всегда проверяет правила метода Печать, начиная с правила # 1. Факс маршрутизируется согласно первому правилу, для которого выполняются заданные условия. Все остальные правила игнорируются. Например, если правило # 1 применяется для всех исходящих факсов ('Номер факса' = .*; 'OK' = да; 'Неудачно' = да), то другие правила # 2, # 3, и т.д. применяемые к исходящим факсам никогда не будут работать ни при каких условиях.

Каждое правило может быть включено или выключено. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено) но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя.

Чтобы осуществлять печать исходящих факсов на заданный принтер, вы должны:

  • Сделать необходимые настройки в правилах Маршрутизации исходящих VOIP вызовов чтобы отправлять факсы через Виртуальные COM порты (модемы Fax Voip)
  • Настроить службу факсов Windows для отправки факсов через модем(ы) Fax Voip
  • Создать одно или более правил, в которых следует задать имена принтеров

Исходящий факс может быть маршрутизирован на один или несколько принтеров.

Максимально допустимое количество правил метода Печать определяется текущей лицензией. Правила которые не могут быть использованы в текущей конфигурации программы всегда выделены красным цветом и игнорируются.

Для просмотра журнала отладки для метода маршрутизации факса Печать, воспользуйтесь опцией Вести протокол методов маршрутизации исходящих факсов (Microsoft Fax), более подробную информацию см. в главе Журналы маршрутизации исходящих факсов (Microsoft Fax) настоящего справочного руководства.

Таблица Маршрутизация исходящих факсов: печать (Microsoft Fax) содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Номер факса

Задает шаблон номера факса получателя, для которого применяется текущее правило.

OK

Указывает, применяется ли правило для успешно отправленных факсов.

Неудачно

Указывает, применяется ли правило в случае неудачной отправки факса.

Включено

Указывает, будет ли осуществляться печать исходящих факсов. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя.

Принтер

Отображает принтеры для печати исходящих факсов.

В контекстной вкладке Печать, на ленте доступны следующие команды:

Правила печати

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило метода Печать.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила метода Печать. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила метода Печать. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правил метода Печать. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Действие

Разрешить (Ctrl + B)

Нажмите чтобы разрешить использование выбранного правила.

Запретить (Ctrl + L)

Нажмите чтобы запретить использование выбранного правила. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя или учетной записи факса.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил метода Печать. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Печать также доступны в контекстном меню списка.

Примечания

  • Выбранный принтер не должен выводить никаких дополнительных диалоговых окон перед печатью. Также следует понимать, что если Fax Voip T.38 Модем запущен в режиме "Служба Windows", печать будет выполняться от имени учетной записи пользователя, под которой запущена служба Fax Voip T.38 Modem MsFax Mail (без возможности вывода на экран каких-либо диалоговых окон). По этой причине, мы настоятельно рекомендуем тестировать данный метод когда Fax Voip T.38 Модем запущен в режиме "Приложение", а не в режиме "Служба Windows".
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Добавление или изменение правил

Добавление или изменение правил метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Печать ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Печать.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Печать, на вкладке Общие, укажите номера факсов получателей, для которых применяется данное правило (в области Номер факса получателя). Укажите, применяется ли правило для успешно отправленных факсов и / или в случае неудачной отправки факса. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Общие параметры .

5. Перейдите на вкладку Печать.

6. На вкладке Печать, поставьте флажок у параметра Напечатать факс после отправки чтобы включить правило. В области Выбор принтеров, задайте имена принтеров. Вам следует выбрать принтер в поле со списком, а затем добавить его в список Имена принтеров при помощи кнопки <Добавить>. Более подробную информацию можно найти в главе Параметры метода “Печать” , в разделе Параметры печати .

7. Нажмите кнопку <OK> чтобы зафиксировать изменения.

8. Чтобы изменить порядок предпочтений для правил метода Печать (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

9. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил метода Печать (Microsoft Fax). Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Печать ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Методы для исходящих (MS Fax), затем нажмите Печать.

3. Чтобы изменить порядок предпочтений для правил метода Печать (Microsoft Fax), используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры метода Печать

Параметры метода “Печать” (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Печать ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Печать (Microsoft Fax).

  • Общие параметры
  • Параметры печати


Общие параметры

Общие параметры (Печать, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Печать ›› Параметры метода Печать ››

Общие параметры

Номер факса получателя

Параметры этой области позволяют задать шаблон номера факса получателя, для которого применяется текущее правило. Правило может применяться к исходящим вызовам на любой номер факса, на жестко заданный номер факса, или на группу номеров.

Номер факса =

Если выбрана эта опция, правило применяется к исходящим вызовам на любой номер факса или к исходящим вызовам на заданный номер.

Выберите <любой>, чтобы применить правило к исходящим вызовам на любой номер факса.

Введите номер факса чтобы применить правило к исходящим вызовам только на этот номер.

Номер факса начинается с

Если выбрана эта опция, правило применяется к исходящим вызовам на группу номеров факсов с заданным префиксом.

Успешная или неудачная доставка

Параметры этой области позволяют указать, применять ли правило для успешно отправленных факсов и/или в случае неудачной отправки факса. Должен быть выбран хотя бы один из вариантов.

Применять правило для успешно отправленных факсов

Если выбрана эта опция, правило применяется в случае успешной отправки факса.

Применять правило в случае неудачной отправки факса

Если выбрана эта опция, правило применяется в случае неудачной отправки факса.


Параметры печати

Параметры печати (Печать, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Печать ›› Параметры метода Печать ››

Параметры печати

Напечатать факс после отправки

Данная опция позволяет включить или отключить печать исходящих факсов. Поставьте флажок у этого параметра, чтобы включить правило. Чтобы запретить печать, снимите флажок. Если правило выключено, Fax Voip T.38 Модем принимает это правило во внимание (как и в случае когда оно включено), но не осуществляет печать факсов. Это может быть использовано чтобы временно отключить печать факсов для определенного номера факса получателя.

Выбор принтеров

В этой области, вы можете задать принтеры для печати исходящих факсов.

Перед добавлением принтера, следует выбрать его в поле со списком.

Имена принтеров

<Добавить>

Используйте эту кнопку для добавления принтера в список принтеров. Принтер должен быть предварительно выбран в поле со списком.

<Удалить>

Используйте эту кнопку для удаления принтера из списка принтеров.


Пользовательская маршрутизация

Пользовательская маршрутизация исходящих факсов (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ››

Пользовательский метод маршрутизации (Microsoft Fax) позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса. Использование этого метода не ограничено какими-либо лицензиями.

Этот метод предоставляет поставщикам программного обеспечения гибкий способ подключения приложений, которые маршрутизируют исходящие факсимильные сообщения, используя различные методы маршрутизации. Эти методы маршрутизации могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д. Поставщик программного обеспечения отвечает за разработку функций своего метода, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации.

При выполнении Пользовательского метода маршрутизации (Microsoft Fax), Fax Voip T.38 Модем запускает указанное пользователем приложение после отправки факса. Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу и другие важные параметры, такие как номер факса получателя, TSID, CSID и т. д., а затем выполнить любые требуемые действия. Пользовательское приложение должно автоматически завершать работу после выполнения. Приложение отвечает за удаление копии факса (файл TIFF, PDF или SFF) и папки, в которой она находится. Пользовательское приложение запускается с использованием учетной записи текущего пользователя или учетной записи, под которой запущена служба Почта-на-факс (MS Fax) (если Fax Voip T.38 Модем запущен в качестве службы Windows). Таким образом, соответствующая учетная запись должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение. Подробнее см. в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

Пользовательское приложение, запускаемое после отправки факса

Здесь вы можете выбрать приложение, которое будет запущено после отправки факса. Вы можете выбрать приложение, нажав на кнопку справа от текстового поля, либо ввести путь к исполняемому файлу. Пример пользовательского приложения (RouteOutCustomMS.exe) можно найти в папке установки Fax Voip T.38 Модем, обычно C:\Program Files (x86)\FaxVoip Modem\RouteOutCustomMS.exe. См. также в главе Пример пользовательского приложения настоящего справочного руководства.

Создавать временную копию отправленного факса в формате

При выборе этой опции метод создает временную папку (в папке %temp% для учетной записи текущего пользователя или учетной записи, под которой запущена служба Почта-на-факс (MS Fax)) и копирует исходящий факс (файл TIFF, PDF или SFF в зависимости от вашего выбора) в эту папку. Путь к временной папке (%temp%) обычно C:\Users\<Account Name>\AppData\Local\Temp\. Путь к временному файлу (копия исходящего факса) передается в пользовательское приложение через аргумент командной строки FaxFileName. Пользовательское приложение отвечает за удаление копии факса и временной папки, в которой этот файл находится. Если флажок не установлен, метод не создает копию исходящего факса, однако пользовательское приложение все равно может получить доступ к исходящему факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Включить пользовательский метод маршрутизации

При выборе этой опции, программное обеспечение Fax Voip T.38 Модем применяет Пользовательский метод маршрутизации (Microsoft Fax) для всех исходящих факсов, отправляемых с помощью приложения Microsoft Fax (через Виртуальные COM порты Fax Voip).


Требования к пользовательскому приложению

Требования к пользовательскому приложению (информация для разработчика)

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Пользовательская маршрутизация ››

Пользовательское приложение маршрутизации, указанное пользователем, запускается программным обеспечением Fax Voip T.38 Модем при выполнении Пользовательского метода маршрутизации (Microsoft Fax), после отправки факса. Индивидуальный разработчик отвечает за разработку этого приложения, создание графического интерфейса пользователя (GUI) для настройки правил и других параметров и за сохранение конфигурации. Функции приложения могут включать, но не ограничены печатью факсов, сохранением факсов, преобразованием графических изображений факса в текстовые файлы, доставкой факсов в приложениях электронной почты и т.д.

Ниже приведены общие требования, которые должны быть приняты во внимание разработчиками программного обеспечения при написании пользовательских приложений.

Аргументы командной строки

Командная строка, передаваемая в приложение, предопределена и содержит всю необходимую информацию. Разработчик может проанализировать командную строку в своем приложении, чтобы получить путь к факсу и другие важные параметры, такие как номер факса получателя, TSID, CSID и т. д.

Ниже приведен пример аргументов командной строки, переданных вашему приложению:

/@@@FaxFileName=C:\Users\UserAccountName\AppData\Local\Temp\201d656bff5f86f_occ\FAX.pdf

/@@@RecipientFaxNumber=19012223344 /@@@RecipientName=John Smith

/@@@SenderName=Dan Black /@@@SenderFaxNumber=(631) 490-2023

/@@@SenderTSID=(631) 490-2023 FAX /@@@SenderEmail=Dan@t38faxvoip.com

/@@@SenderCompany=FaxVoip Software, LLC /@@@SenderDepartment=Sales

/@@@SenderTitle=Sales Manager /@@@SenderOfficeLocation=14

/@@@SenderHomePhone=(425) 686-1097 /@@@SenderOfficePhone=(631) 490-1288

/@@@SenderAddress=324 6th Avenue\n10014 New York\nUSA /@@@SenderBillingCode=015

/@@@DocumentName=invoice07_10_20_003.pdf;Information.txt /@@@HasCoverPage=1

/@@@Subject=This is the subject line on the cover page of the fax.

/@@@PagesTotal=4 /@@@TiffSize=132386

/@@@CSID=(901) 222-3344 /@@@TSID=Fax Voip T.38 Modem /@@@Priority=1

/@@@SubmissionTime=07.10.2020@01:28:18 /@@@OriginalScheduledTime=07.10.2020@01:28:18

/@@@StartTime=07.10.2020@01:32:49 /@@@EndTime=07.10.2020@01:36:14 /@@@Duration=00:03:25

/@@@Retries=0 /@@@PagesTransferred=4 /@@@DeviceName=Fax Voip 14.4K TAPI Voice-Fax Modem

/@@@Status=OK /@@@JobId=201d656bff5f86f /@@@BroadcastId=2001d656bff5f75e

Аргументы командной строки приблизительно соответствуют элементам следующих объектов: FaxOutgoingJob , FaxOutgoingMessage , FaxRecipient , FaxSender , см. документацию Fax Service Extended COM Reference .

/@@@FaxFileName=

Временная копия факса (файл TIFF, PDF или SFF в зависимости от вашего выбора), связанная с отправляемым факсимильным документом. Этот файл и временная папка, в которой он находится (в папке %temp% для учетной записи текущего пользователя или учетной записи, под которой запущена служба Почта-на-факс (MS Fax)), должны быть удалены в пользовательском приложении маршрутизации после выполнения необходимых действий. Если флажок Создавать временную копию отправленного факса... не установлен, этот аргумент отсутствует в командной строке. См. также в главе Пользовательская маршрутизация исходящих факсов (Microsoft Fax) настоящего справочного руководства.

/@@@RecipientFaxNumber=

Номер факса получателя.

/@@@RecipientName=

Имя получателя. Отображается на титульной странице.

/@@@SenderName=

Имя отправителя.

/@@@SenderFaxNumber=

Номер факса отправителя.

/@@@SenderTSID=

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается в верхней части каждой страницы отправляемого факса. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание аргумента командной строки TSID.

/@@@SenderEmail=

Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.

/@@@SenderCompany=

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).

/@@@SenderDepartment=

Имя отдела отправителя.

/@@@SenderTitle=

Должность отправителя.

/@@@SenderOfficeLocation=

Номер офиса (комнаты) отправителя.

/@@@SenderHomePhone=

Номер домашнего телефона отправителя.

/@@@SenderOfficePhone=

Номер рабочего телефона отправителя.

/@@@SenderAddress=

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну. Для индикации переноса строк используется символ '\n'.

/@@@SenderBillingCode=

Код биллинга, связанный с отправителем.

/@@@DocumentName=

Удобное имя, которое описывает отправляемый факс. В случае создания факса функцией Почта-на-факс , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.

/@@@HasCoverPage=

Указывает, содержит ли факс титульную страницу. Допустимые значения: 1 - с титульной страницей, 0 - без титульной страницы.

/@@@Subject=

Содержит тему факса (отображается на титульной странице).

/@@@PagesTotal=

Общее количество страниц в исходящем факсе.

/@@@TiffSize=

Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с исходящим факсом, в байтах.

/@@@CSID=

Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.

/@@@TSID=

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с SenderTSID, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.

/@@@Priority=

Важность факса. Допустимые значения: 0 - низкая, 1 - обычная, 2 - высокая.

/@@@SubmissionTime=

Время формирования задания исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@OriginalScheduledTime=

Время, на которое первоначально была запланирована отправка факсимильного сообщения, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@StartTime=

Время начала передачи исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@EndTime=

Время окончания передачи исходящего факса, в формате 'mm.dd.yyyy@hh:mm:ss'.

/@@@Duration=

Представляет общее время, прошедшее между началом и окончанием передачи факса в формате 'hh:mm:ss'.

/@@@Retries=

В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.

/@@@PagesTransferred=

Число успешно переданных страниц факса.

/@@@DeviceName=

Имя устройства, которое использовалось при отправке факса.

/@@@Status=

Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.

/@@@JobId=

Уникальный номер, который идентифицирует задание факса, связанное с отправкой факсимильного документа.

/@@@BroadcastId=

Уникальный номер, присвоенный заданию факса в процессе отправки. При отправке факса более чем одному получателю, будут созданы отдельные задания факса, но как часть одной и той же рассылки, они будут иметь один и тот же идентификатор рассылки (Broadcast ID).

Временная копия отправленного факса

Если установлен флажок Создавать временную копию отправленного факса... (см. в главе Пользовательская маршрутизация исходящих факсов (Microsoft Fax) настоящего справочного руководства), Пользовательский метод маршрутизации создает временную папку и копирует исходящий факс (файл TIFF, PDF или SFF в зависимости от вашего выбора) в эту папку. Временная папка создается в папке %temp% для учетной записи текущего пользователя или учетной записи, под которой запущена служба Почта-на-факс (MS Fax) (если Fax Voip T.38 Модем запущен в качестве службы Windows). Путь к временному файлу (копия исходящего факса) передается в пользовательское приложение через аргумент командной строки FaxFileName, см. выше.

Например,

/@@@FaxFileName=C:\Users\UserAccountName\AppData\Local\Temp\201d656bff5f86f_occ\FAX.pdf

Путь к факсу (PDF формат):

C:\Users\UserAccountName\AppData\Local\Temp\201d656bff5f86f_occ\FAX.pdf

Путь к временной папке:

C:\Users\UserAccountName\AppData\Local\Temp\201d656bff5f86f_occ\

Временная папка, в которой находится факс (FAX.tif, FAX.pdf или FAX.sff), может использоваться вашим пользовательским приложением для хранения временных файлов, создаваемых вашим приложением.

Пользовательское приложение отвечает за удаление временной копии факса и временной папки, в которой она находится. Вы должны навсегда удалить временную папку в своем приложении после выполнения всех необходимых действий.

Если флажок Создавать временную копию отправленного факса... не установлен, Пользовательский метод маршрутизации не создает копию исходящего факса, однако пользовательское приложение все равно может получить доступ к факсу используя Fax Service API функции (на основе параметра Job ID, который также передается через командную строку).

Запуск под учетной записью текущего пользователя или учетной записью, под которой запущена служба Почта-на-факс (MS Fax)

Пользовательское приложение запускается с использованием учетной записи текущего пользователя или учетной записи, под которой запущена служба Почта-на-факс (MS Fax). Таким образом, соответствующая учетная запись должна иметь необходимый доступ к файлам, папкам и другим объектам, с которыми работает ваше приложение.

Завершение приложения

Пользовательский метод маршрутизации (Microsoft Fax) запускает пользовательское приложение маршрутизации в отдельном потоке путем вызова функции CreateProcess . Fax Voip T.38 Модем не отслеживает приложение после его запуска и не гарантирует его корректное завершение. Разработчик пользовательского приложения отвечает за правильное автоматическое завершение работы приложения после его выполнения.


Пример пользовательского приложения

Панель управления Fax Voip T.38 Модем ›› Методы для исходящих (Microsoft Fax) ›› Пользовательская маршрутизация ››

Пример пользовательского приложения маршрутизации (RouteOutCustomMS.exe) можно найти в папке установки Fax Voip T.38 Модем, обычно C:\Program Files (x86)\FaxVoip Modem\RouteOutCustomMS.exe.

Исходные коды (архив RouteOutCustomMS.zip) можно найти в папке данных Fax Voip T.38 Модем, обычно C:\ProgramData\FaxVoip Modem\Samples\RouteOutCustomMS.zip. Чтобы распаковать архив, щелкните его правой кнопкой мыши и выберите Извлечь все... из контекстного меню.

Пример кода - консольное приложение, написанное на языке Visual Basic .Net, которое может быть скомпилировано с использованием Microsoft Visual Studio 2013 или более поздней версии.

В этом примере демонстрируется использование пользовательского метода маршрутизации (Microsoft Fax) для исходящих факсов, с учетом требований, предъявляемых к написанию такого приложения, см. также в главе Требования к пользовательскому приложению (информация для разработчика) настоящего справочного руководства.

  • Приложение анализирует предопределенную командную строку и заполняет внутреннюю структуру, где оно сохраняет путь к временной копии факса (файл TIFF, PDF или SFF в зависимости от вашего выбора) и другие параметры маршрутизации, такие как номер факса получателя, TSID, CSID и т.д.
  • Записывает информацию о маршрутизации в стандартный ini-файл.
  • Копирует временный TIFF, PDF или SFF файл в указанную папку с уникальным именем, которое содержит дату и время отправки факса.
  • Перед тем как завершить работу, приложение удаляет временную папку и временную копию факса, которая находится в этой папке.
  • Приложение автоматически завершается после выполнения всех необходимых действий.
  • Приложение использует папки и файлы, для которых учетная запись любого пользователя заведомо имеет доступ на запись.

Чтобы использовать пример

1. Скопируйте файл RouteOutCustomMS.exe в папку установки Fax Voip T.38 Модем. Вы можете использовать другую папку, но убедитесь, что учетная запись текущего пользователя (учетная запись, под которой запущена служба Почта-на-факс (MS Fax)) имеет доступ к используемой папке.

2. Откройте Панель управления Fax Voip T.38 Модем. Нажмите Методы для исходящих (MS Fax), затем нажмите Пользовательский.

3. На странице Пользовательская маршрутизация исходящих факсов (Microsoft Fax), установите флажок Включить пользовательский метод маршрутизации.

4. В поле Пользовательское приложение, запускаемое после отправки факса, введите путь к файлу RouteOutCustomMS.exe, либо выберите файл, нажав на кнопку справа от текстового поля.

5. Установите флажок Создавать временную копию отправленного факса... . Выберите формат файла, в котором должна быть создана временная копия исходящего факса. Может быть TIFF, PDF или SFF.

6. Нажмите кнопку <Применить>, чтобы сохранить изменения.

После отправки факса,

1. Откройте папку данных Fax Voip T.38 Модем в проводнике Windows, обычно C:\ProgramData\FaxVoip Modem\.

2. В подпапке RouteOutCustomMS найдите файл RouteOutCustomMS.ini.

3. В подпапке RouteOutCustomMS\Outgoing Faxes найдите копию исходящего факса.

4. Файл журнала маршрутизации RouteOutCustomMS.txt сохраняется в подпапке log.


Факс

Панель управления Fax Voip T.38 Модем ››

  • Параметры факса
  • Набор номера (Microsoft Fax)
  • Параметры конвертации в факс
  • Параметры Printto
  • Параметры просмотра факсов


Параметры факса

Панель управления Fax Voip T.38 Модем ›› Факс ››

Перезапускать службу Microsoft Fax при запуске Fax Voip T.38 Модем

Эту опцию рекомендуется включать в случае если Fax Voip T.38 Модем работает совместно со службой Microsoft Fax*. Если опция включена, то всякий раз при запуске Fax Voip T.38 Модем служба Microsoft Fax перезапускается. Если Fax Voip T.38 Модем используется с другой факс программой, не используйте данную опцию. Для изменения данного параметра требуются права администратора.

Коррекция ошибок (ECM) и ограничение скорости

T.38 факс

Максимальная скорость

(Не реализовано пока). Максимальная скорость передачи факса по T.38 всегда установлена равной 14400. Тем не менее, это значение может быть уменьшено в параметрах вашей факс программы, если программа позволяет задавать максимальную скорость.

ECM

(Не реализовано пока). Коррекция ошибок при передаче факса по T.38 всегда разрешена. Возможность использовать ECM в этом случае зависит только от настроек и возможностей вашей факс программы.

Аудио факс поверх G.711

Максимальная скорость

Максимальная скорость передачи факса для аудио факсов (факс поверх G.711). Значение максимальной скорости может быть установлено 14400/9600/4800 что соответствует пределам скоростей в стандартных протоколах используемых для факсимильной связи. Это значение может быть уменьшено в параметрах вашей факс программы, если программа позволяет задавать максимальную скорость. Максимальная скорость передачи факса может быть переопределена в настройках Маршрутизации исходящих VOIP вызовов и Маршрутизации входящих VOIP вызовов.

ECM

Возможность использовать Коррекцию ошибок для аудио факсов (факс поверх G.711). Возможность использовать ECM также зависит от настроек и возможностей вашей факс программы. Данный параметр может быть переопределен в настройках Маршрутизации исходящих VOIP вызовов и Маршрутизации входящих VOIP вызовов.

Примечания

  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Набор номера (Microsoft Fax)

Набор номера (телефония Microsoft) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Факс ››

Правила набора номера, предоставляемые интерфейсом программирования приложений телефонии Windows (TAPI) используются службой факсов Windows и приложением Факсы и сканирование Windows при преобразовании номеров факсов, введенных пользователем в каноническом формате.

Канонический формат телефонного номера - это универсальный формат, который явно определяет компоненты телефонного номера, используемый TAPI для преобразования номера в соответствии с правилами набора для страны или региона. Номер в каноническом формате выглядит следующим образом:

+КодСтраны (КодГорода) НомерАбонента

+

Указывает, что номер телефона представлен в каноническом формате.

КодСтраны

Стандартный код страны/региона, определяющий страну или регион для телефонного номера. Содержит одну или несколько цифр от 0 до 9. Код страны/региона отделяется пробелом, который следует за ним.

(КодГорода)

Телефонный код города. Может содержать одну или несколько цифр от 0 до 9. Код города заключен в круглые скобки. Этот компонент опускается для стран/регионов, в которых не используются коды городов.

(НомерАбонента)

Телефонный номер абонента. Обычно содержит одну или несколько цифр от 0 до 9 и символы форматирования.

Например, вот как вы должны ввести номер абонента в США в каноническом формате телефонного номера:

+1 (425) 123-4567

При выборе определенного правила в окне Новый факс в программе Факсы и сканирование Windows, правило набора применяется во время создания задания факса. В этом случае набираемый номер также преобразуется во время создания задания факса и не может быть изменен позже. В программе Факсы и сканирование Windows номер факса будет отображаться с использованием символов форматирования (пробелы и дефисы).

При выборе (нет) в поле Правило набора в окне Новый факс в программе Факсы и сканирование Windows, или при создании факса с использованием Fax Service API, правила набора не применяются во время создания задания факса, при этом программа Факсы и сканирование Windows отображает номер факса без изменений, в том же формате, в котором он был введен. В этом случае используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) применяется в момент набора номера факса.

В случае номера факса в неканоническом формате, он набирается и отображается без изменений, в том же формате, в котором он был введен.

На этой странице вы можете настроить правила набора номера, проверить как будет набираться номер факса и как он будет отображаться в программе Факсы и сканирование Windows.

Правило набора

Выберите правило набора номера (местоположение). Аналогично выбору правила в окне Новый факс в программе Факсы и сканирование Windows.

(нет)

Правило набора номера не применяется во время создания задания факса. Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) применяется в момент набора номера факса.

<конкретное правило>

Выбранное правило набора номера применяется во время создания задания факса.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Телефонная карточка

Телефонная карточка, связанная с используемым местоположением. Информация о телефонной карточке игнорируется, если выбрано (нет) и используемое по умолчанию правило набора применяется в момент набора номера факса.

<По умолчанию>

Нажмите чтобы использовать выбранное местоположение по умолчанию (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows).

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows. Может содержать символы форматирования (пробелы и дефисы).

Набираемый номер

Номер факса, как он будет набираться после применения правил набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .

Набираемый номер может содержать специальные символы, такие как 'W', ',', '#' и т. д. Это может приводить к обрезанию набираемого номера (символ 'W'), см. также главу Набор добавочного номера данного руководства пользователя. Например в России и большинстве стран бывшего СНГ применяется префикс 8W10 для международных вызовов и префикс 8W для междугородних вызовов. В этой ситуации мы бы рекомендовали отказаться от использования канонического формата номера, либо указывать другую страну в настройках правил набора.

Примечания

  • Правила набора номера не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Общие сведения о правилах набора номера

Панель управления Fax Voip T.38 Модем ›› Факс ›› Набор номера (Microsoft Fax) ››

Интерфейс программирования приложений телефонии (TAPI) позволяет настраивать правила набора номера для всех программ телефонии. При запуске программы до настройки правил набора номера (например, при попытке отправить факс с помощью программы Факсы и сканирование Windows), обычно запрашивается минимум сведений, необходимых для набора номера. Вам необходимо выбрать страну или регион и ввести телефонный код города. Тоновый набор номера установлен по умолчанию и должен быть выбран для большинства телефонных служб.

Для полной настройки правил набора номера на компьютере используется объект Телефон и модем в панели управления Windows, как описано ниже.

Местоположение вызова

Местоположение вызова представляет собой набор параметров, используемых для анализа телефонных номеров и определения правильной последовательности набора номера. Допускается создание любого числа местоположений вызова для различных целей.

Местоположение вызова может соответствовать фактическому географическому положению, такому как кабинет или гостиничный номер, где для выхода на внешнюю линию требуется набрать код. Если работа сопряжена с поездками в разные города или страны, можно создать местоположение вызова для каждого кода области, города или страны.

Местоположение вызова также может быть создано для правил набора номера, не обязательно связанных с географическим положением. Например, различные правила набора номера могут быть созданы для различных целей.

Сведения о местоположении вызова включают в себя следующие параметры:

  • Имя
  • Страну или регион
  • Код города (области)
  • Правила набора номера
  • Правила набора кода города
  • Сведения о телефонной карточке

Задание имен и использование местоположений вызова

Для местоположения вызова можно задать любое запоминающееся имя. По умолчанию для набора номеров используется местоположение, выбранное в диалоговом окне Телефон и модем. Многие программы телефонии, такие как Факсы и сканирование Windows, позволяют выбирать местоположение вызова перед набором номера. При выполнении междугороднего звонка программа телефонии использует сведения о наборе номера, заданные для текущего местоположения вызова.

Доступные местоположения вызова отображаются на вкладке Набор номера диалогового окна Телефон и модем, открываемого из панели управления Windows. На этой вкладке можно выбрать местоположение вызова, используемое по умолчанию, создать новое местоположение вызова, или изменить любое существующее местоположение.

Чтобы открыть диалоговое окно Телефон и модем, переключитесь на панель Поиск, наберите телефон и модем, а затем нажмите Телефон и модем. Кроме того, вы можете выбрать Факс -> Набор номера (MS Fax) в дереве Панели управления Fax Voip T.38 Модем , а затем нажать <Настроить правила>, см. также главу Набор номера (телефония Microsoft) - Microsoft Fax настоящего справочного руководства.

Чтобы создать новое местоположение вызова, нажмите Создать... . Чтобы изменить существующее местоположение, выберите его и нажмите Изменить... .

Общие правила местоположения вызова

Общие правила местоположения задают имя местоположения, страну или регион, а также код города. Тоновый тип набора номера установлен по умолчанию и должен быть выбран для большинства телефонных служб. Используемые по умолчанию правила набора номера для местных, междугородных и международных звонков определяются выбором страны или региона. Правила набора номера задают префикс выхода на междугородную линию и префикс выхода на международную линию, набираемые перед телефонными номерами других городов или стран.

Правила набора кода города

Правила набора кода города позволяют изменить порядок набора номеров внутри страны или региона. Стандартные правила набора телефонных номеров других городов часто требуют, чтобы программой набирался префикс выхода на междугородную линию, код города, а затем номер телефона. Для вызова номеров в том же городе программой набирается только номер телефона нужного абонента.

Чтобы создать новое правило набора кода города, нажмите Создать... . Для изменения существующего правила, выберите его и нажмите Изменить... .

В приведенном ниже примере мы добавляем код страны '1' и код города перед номером для вызовов в пределах кода города '631', который соответствует нашему местоположению.

Телефонные карточки

Местоположение вызова может использовать настройки телефонной карточки для указания префиксов выхода на междугородную линию или международную линию, которые не являются стандартными для страны или области. Что касается программного обеспечения службы факсов Windows (запускаемого под учетной записью сетевой службы), следует понимать, что информация о телефонной карточке привязана к учетной записи текущего пользователя и игнорируется, если используемое по умолчанию правило набора применяется в момент набора номера факса.


Конвертация в факс

Параметры конвертации в факс

Панель управления Fax Voip T.38 Модем ›› Факс ››

Функция Прямая конвертация в факс позволяет конвертировать некоторые из наиболее популярных графических форматов файлов в совместимый формат факса (TIFF). В приложении Fax Voip T.38 Модем этот функционал используется с функцией Почта-на-факс - Microsoft Fax и при отправке факса с использованием утилиты командной строки SendFaxMS.exe (Microsoft Fax) .

В случае использования Прямой конвертации в факс, установка приложения, которое ассоциируется в системе с требуемым расширением файла, не требуется. Обратите внимание, что в силу дизайна программного обеспечения службы факсов Windows, фоновая печать используется в любом случае. Однако в случае Прямой конвертации в факс, производится печать временного файла TIFF (полученного в результате прямой конвертации), а не оригинального документа (например PDF).

В настоящий момент поддерживаются следующие форматы (могут быть конвертированы в факс напрямую):

*.pdf (Файл Adobe PDF) (по умолчанию)

*.tif, *.tiff (Рисунок TIFF) (по умолчанию)

*.sff (Structured Fax File) (по умолчанию)

*.qfx (Ventafax QFX файл) (по умолчанию)

*.bmp (Точечный рисунок)

*.jpg, *.jpeg (Рисунок JPEG)

*.gif (Рисунок GIF)

*.png (Рисунок PNG)

*.ico (Файл ICO)

*.wmf, *.emf (Метафайлы Windows)

Наиболее распространенной проблемой, которая может быть решена с помощью Прямой конвертации в факс, является возможность использования PDF файлов в качестве вложений электронной почты с функцией Почта-на-факс - Microsoft Fax . Установка Adobe Reader также как и Acrobat Wrapper не требуется. Нет необходимости в сложных настройках для обеспечения работоспособности функции Почта-на-факс при работе с PDF вложениями.

Выберите типы файлов к которым применяется прямая конвертация в формат факса

Эта таблица содержит список типов файлов которые могут быть конвертированы в формат факса напрямую. Если тип файла выбран, процедура Прямой конвертации в факс будет применяться ко всем файлам этого типа. Если тип файла не выбран, файл будет распечатан с использованием принтера Fax (служба факсов Windows) и приложения, которое ассоциируется в системе с данным типом файлов. Все остальные типы файлов, не перечисленные в таблице, всегда печатаются с использованием принтера Fax и приложения, которое ассоциируется в системе с данным типом файлов.

Параметры TIFF:

Эти параметры позволяют задать формат факса (файла TIFF на выходе), созданного в результате Прямой конвертации в факс.

Автоповорот

Этот параметр определяет будет ли применяться алгоритм автоматического выбора ориентации. Если данная опция включена и оригинальный документ имеет альбомную ориентацию, то при преобразовании в факс документ будет повернут на 90 градусов по часовой стрелке. Если эта опция выключена, будет сохранена исходная ориентация. В зависимости от настроек принтера факсов этот параметр может быть проигнорирован.

Страница A4

Если данная опция включена, Fax Voip T.38 Модем устанавливает ширину страницы равной 1728 и высоту страницы в диапазоне 1100...1210 (при разрешении 204x98 dpi) либо в диапазоне 2200...2420 (при разрешении 204x196 dpi). Если эта опция выключена, Fax Voip T.38 Модем не контролирует высоту страницы. В зависимости от настроек принтера факсов этот параметр может быть проигнорирован.

Передача полутонов

Полутона (Halftone) - это репрографическая техника которая имитирует непрерывную передачу изображения путем использования точек, различающихся по размеру, форме либо интервалу между ними. Опцию Передача полутонов рекомендуется использовать при конвертации цветных документов в формат факса. Если эта опция выключена, цветное изображение преобразованное в черно-белый факс, будет очень низкого качества. Следует заметить что в случае прямой конвертации при применении Передачи полутонов используются настройки системы Windows по умолчанию. По этой причине, если факс создан из цветного документа и включена опция Передача полутонов, время передачи такого факса будет достаточно велико. Факс, созданный с использованием принтера Fax (из того же цветного документа) имеет приемлемое качество и передается значительно быстрее. Заметим также что в случае Прямой конвертации файла PDF содержащего цветные изображения, эта опция игнорируется, Передача полутонов всегда применяется, размер файла TIFF и время передачи факса не очень велики и качество факса приемлемое.

Результаты применения различных комбинаций рассмотренных выше опций показаны на рисунке ниже:

Примечания

  • Прямая конвертация в факс не применяется если пользователь осуществляет печать документа с использованием принтера Fax.
  • Мы бы рекомендовали использовать Прямую конвертацию в факс при работе с PDF файлами, особенно при использовании функции Почта-на-факс - Microsoft Fax и PDF файлов в качестве вложений в сообщениях электронной почты.


Параметры Printto

Панель управления Fax Voip T.38 Модем ›› Факс ››

Стандартные команды printto используются операционной системой Windows чтобы связать расширение файла с приложением, которое отвечает за печать файлов с этим расширением. Например, для печати текстового документа (*.txt) обычно используется Блокнот (notepad.exe). Для печати файлов с расширениями .doc и .rtf используется Microsoft Word. Печать PDF обычно ассоциируется с приложением Acrobat Reader и т.д. Для печати файлов различных графических форматов как правило используется системная библиотека shimgvw.dll либо приложение Paint.

Fax Voip T.38 Модем использует функцию printto в следующих случаях (кроме случаев когда используется Прямая конвертация ):

  • При отправке факса с использованием команды Создать факс в Панели управления Fax Voip T.38 Модем.
  • При отправке факса с помощью утилиты командной строки SendFaxMS.exe - Microsoft Fax (методы FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 , Fax Service API).
  • При использовании функции Почта-на-факс - Microsoft Fax (методы FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 , Fax Service API).

Эта функциональность также используется приложением Факсы и сканирование Windows в следующих случаях:

  • При создании факса с использованием команды Создать факс в приложении Факсы и сканирование Windows и добавлением документа путем выбора пункта меню Вставка -> Вложение файла... .
  • При выборе команды Отправить -> Получатель факса из контекстного меню файла в проводнике Windows.

Функция printto очень удобна, однако зависит от установленных на компьютере приложений и пользовательских настроек. Отсутствие правильных ассоциаций файлов приводит к неработоспособности вышеперечисленных функционалов с отдельными расширениями файлов. Даже в случае хорошо известных расширений, ассоциации файлов могут быть повреждены после установки нового приложения. Начиная с Windows Vista отсутствует возможность настройки команд printto через пользовательский интерфейс. В Windows 11, Windows 10 и Windows 8 / 8.1 ассоциации по умолчанию не позволяют использовать printto со многими стандартными расширениями файлов. В операционных системах Windows Server эта проблема отсутствует, потому что новые приложения Windows Store (Магазин) по умолчанию не установлены.

Описанная здесь функция восстанавливает правильные ассоциации для стандартных типов файлов, а также устраняет другие проблемы связанные с печатью.

Обратите внимание, что на компьютере с Windows 11 или Windows 10 функция, описанная в текущей главе, не способна разрешить все проблемы и ассоциации файлов необходимо назначать вручную, см. главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.

Параметры Printto:

Нажмите, чтобы узнать как исправить ассоциации файлов в Windows 11 и Windows 10

Нажмите чтобы открыть главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства. Эта глава содержит важную информацию для пользователей Windows 11 и Windows 10. Приведенная информация также может быть полезна для пользователей других операционных систем, в частности Windows 8/8.1 или Windows Server 2022/2019/2016/2012/2012R2. См. также комментарии ниже.

<Исправить команды ‘printto’>

Нажмите чтобы исправить ассоциации printto для стандартных типов файлов, а также устранить другие проблемы связанные с печатью. Для использования этой опции обычно требуются права администратора. Права администратора запрашиваются только в случае необходимости.

В зависимости от операционной системы, применяются следующие исправления:

В Windows 11 / 10 / 8 / 8.1 64-бит и Windows Server 2022 / 2019 / 2016 / 2012 / 2012R2

Исправление печати из-под служб Windows. Хорошо известная проблема. Приложение не видит установленные в системе принтеры. В случае вызова метода FaxDocument.ConnectedSubmit2 (Fax Service API) приложение зависает. В ряде других случаев возникает ошибка печати. Критично при работе Fax Voip T.38 Модем в качестве Службы Windows.

В Windows 8 / 8.1 32-бит и 64-бит

Исправление стандартных ассоциаций файлов для учетной записи SYSTEM. На указанных операционных системах ассоциации файлов по умолчанию не определены для системной учетной записи. Следующие расширения файлов могут быть исправлены: *.txt, *.bmp, *. dib, *. emf, *. gif, *. ico, *. jfif, *. jpe, *. jpeg, *.jpg, *.jxr, *.png, *. rle, *.tif, *.tiff, *.wdp, *.wmf. Обратите внимание, что это исправление более не требуется. Служба Почта-на-факс обычно настраивается для запуска под учетной записью обычного пользователя, см. главу Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства.

Во всех операционных системах

Исправление стандартных команд 'printto' для стандартных классов ProgID. В настоящее время поддерживаются следующие классы ProgID: txtfile, giffile, jpegfile, pjpegfile, pjpegfile, pngfile, TIFImage.Document, wdpfile, PBrush, emffile, rlefile, wmffile, Paint.Picture, icofile.

Во всех операционных системах

Исправление стандартных команд 'printto' для стандартных расширений файлов для учетной записи текущего пользователя. В настоящее время поддерживаются следующие расширения файлов: *.txt, *.bmp, *. dib, *. emf, *. gif, *. ico, *. jfif, *. jpe, *. jpeg, *.jpg, *.jxr, *.png, *. rle, *.tif, *.tiff, *.wdp, *.wmf. В Windows 11 и Windows 10 ассоциации файлов необходимо назначать вручную, см. главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.

Примечания

  • Функция Исправить команды ‘printto’ всегда выполняется во время установки Fax Voip T.38 Модем. Однако, во время инсталляции функция изначально выполняется с правами администратора, то есть не учитывает и не исправляет настройки текущего пользователя. Рекомендуется запустить данную функцию непосредственно после установки Fax Voip T.38 Модем, а также при обнаружении проблем с печатью.
  • Файл журнала printto_fix.txt всегда сохраняется в папке {CommonAppDataFolder}\FaxVoip Modem\log, где {CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.
  • Обратите внимание, что там где это возможно, используется прямой вызов функций системной библиотеки shimgvw.dll вместо использования printto.
  • Для пользователей Windows 11 и Windows 10, см. также главу Исправление ассоциаций файлов в Windows 11 и Windows 10 настоящего справочного руководства.


Исправление ассоциаций файлов в Windows 11 и Windows 10

Панель управления Fax Voip T.38 Модем ›› Факс ›› Параметры Printto ››

В Windows 11 и Windows 10, функция Исправить команды ‘printto’ к сожалению не способна разрешить все проблемы связанные с печатью (функция printto). Механизм назначения ассоциаций типов файлов вновь изменился в этих операционных системах. Вам необходимо назначать ассоциации типов файлов с конкретными приложениями вручную.

Ассоциаций типов файлов можно легко настроить для учетной записи текущего пользователя. При работе Fax Voip T.38 Модем в качестве службы Windows , настройте службу Почта-на-факс (Microsoft Fax) на использование обычной учетной записи пользователя. Подробнее см. в главе Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства.

Чтобы настроить ассоциации типов файлов для учетной записи текущего пользователя:

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Параметры.

2. В окне Параметры нажмите Приложения, а затем Приложения по умолчанию.

3. На вкладке Приложения по умолчанию, нажмите Выбрать значения по умолчанию по типам файлов.

4. На странице Выбрать значения по умолчанию по типам файлов убедитесь, что расширение файла (например .tif) ассоциируется с нужным приложением. Чтобы изменить приложение по умолчанию, щелкните расширение и выберите приложение, которое будет использоваться с выбранным типом файла (например Просмотр фотографий Windows).

5. Откройте Панель управления Fax Voip T.38 Модем. В дереве Панели управления Fax Voip T.38 Модем нажмите Факс, затем нажмите Конвертация в факс. Нажмите кнопку Исправить команды ‘printto’ (см. также главу Параметры Printto ).

Рекомендованные ассоциации типов файлов

В таблице ниже вы найдете настройки, которые мы бы рекомендовали использовать для ассоциаций стандартных типов файлов. Вы можете назначить иные программы по умолчанию, но корректная работа функции printto в этом случае не гарантируется.

Расширение

Описание

Программа по умолчанию

.bmp

Точечный рисунок

Paint

.dib

Точечный рисунок

Paint

.emf

Файл EMF

Paint

.gif

Файл GIF

Просмотр фотографий Windows

.ico

Файл ICO

Просмотр фотографий Windows

.jfif

Рисунок JPEG

Просмотр фотографий Windows

.jpe

Рисунок JPEG

Просмотр фотографий Windows

.jpeg

Рисунок JPEG

Просмотр фотографий Windows

.jpg

Рисунок JPEG

Просмотр фотографий Windows

.jxr

Фото Windows Media

Просмотр фотографий Windows

.png

Рисунок PNG

Просмотр фотографий Windows

.rle

Файл RLE

Paint

.tif

Рисунок TIFF

Просмотр фотографий Windows

.tiff

Рисунок TIFF

Просмотр фотографий Windows

.wdp

Фото Windows Media

Просмотр фотографий Windows

.wmf

Файл WMF

Paint

.txt

Текстовый документ

Блокнот

Примечания

  • Метод назначения ассоциаций типов файлов, описанный в этой главе, можно использовать не только в Windows 11 и Windows 10, но также в других операционных системах, в частности Windows 8/8.1 или Windows Server 2022/2019/2016/2012/2012R2.
  • Описанный метод можно также применить к другим типам файлов, которые не упомянуты в списке рекомендованных ассоциаций типов файлов.


Параметры просмотра факсов

Панель управления Fax Voip T.38 Модем ›› Факс ››

Команда для открытия TIFF

Введите в этом поле команду для запуска исполняемого файла приложения для просмотра файлов TIFF. Можно использовать стандартные варианты: 1) explorer – для просмотра файлов TIFF в окне программы Microsoft Edge или Internet Explorer в соответствии с настройками вашей операционной системы. 2) rundll32 shimgvw.dll,ImageView_Fullscreen – для просмотра файлов TIFF с использованием Средства просмотра фотографий Windows. Для выбора исполняемого файла, используйте небольшую кнопку справа от поля со списком.

По умолчанию

Используйте эту кнопку для выбора стандартной Команды для открытия TIFF.

Примечания

  • В Fax Voip T.38 Модем эта настройка задает приложение, используемое для просмотра исходящего факса при его отслеживании с помощью утилиты SendFaxMS.exe. См. Отслеживание факса (графический интерфейс) , команда Просмотр.


Отправка факса с помощью SendFaxMS.exe - Microsoft Fax

Отправка факса с помощью утилиты SendFaxMS.exe - Microsoft Fax

Панель управления Fax Voip T.38 Модем ››

SendFaxMS.exe является утилитой командной строки и предназначена для автоматического создания факса и его дальнейшего отслеживания, при использовании службы факсов Windows и приложения Факсы и сканирование Windows.

Для получения подробных сведений о SendFaxMS.exe и параметрах командной строки, см. Параметры командной строки SendFaxMS.exe - Microsoft Fax .

Чтобы настроить командную строку, а затем запустить SendFaxMS.exe из Панели управления Fax Voip T.38 Модем, см. Настройка и запуск SendFaxMS.exe (Microsoft Fax) из панели управления Fax Voip T.38 Модем .

Для получения подробных сведений о диалоговом окне Настройка параметров SendFaxMS.exe, см. Параметры SendFaxMS.exe - Microsoft Fax .

Чтобы отслеживать факс при запуске SendFaxMS.exe в режиме графического интерфейса пользователя (GUI), см. Отслеживание факса (графический интерфейс) - Microsoft Fax .

Чтобы отслеживать факс при запуске SendFaxMS.exe в режиме консоли, см. Отслеживание факса (режим консоли) - Microsoft Fax .

Для просмотра журналов SendFaxMS.exe, см. Журналы SendFaxMS.exe (Microsoft Fax) .


Параметры командной строки SendFaxMS.exe

Параметры командной строки SendFaxMS.exe - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ››

SendFaxMS.exe является утилитой командной строки и предназначена для автоматического создания факса и его дальнейшего отслеживания, при использовании службы факсов Windows и приложения Факсы и сканирование Windows. Может быть использована в различных сценариях, например в bat-файлах или в пользовательских приложениях. Помогает автоматизировать процесс отправки факсов.

Вы можете найти SendFaxMS.exe в папке установки Fax Voip T.38 Модем. Это приложение использует библиотеки Fax Voip T.38 Модем, и поэтому должно находиться в папке, где установлен Fax Voip T.38 Модем. Не следует перемещать SendFaxMS.exe в другую папку.

Для конструирования командной строки и тестирования SendFaxMS.exe, откройте Панель управления Fax Voip T.38 Модем, в дереве нажмите Факс, а затем нажмите SendFaxMS.exe (MS Fax), см. главу Настройка и запуск SendFaxMS.exe (Microsoft Fax) из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Пример использования в bat-файле можно найти в следующем файле:

*{CommonAppDataFolder}\FaxVoip Modem\SendFaxMS\Sample\SendFaxMS_test.bat

использование (графический режим): SendFaxMS.exe [параметры]

использование (режим консоли): SendFaxMS_c.exe [параметры]

Получатели факса:

Чтобы отправить факс одному получателю, используйте параметры /FaxNumber и /RecipientName. Для отправки факса нескольким получателям, используйте параметр /RecipientList.

/FaxNumber=value

Номер факса получателя.

/RecipientName=value

Имя получателя. Отображается на титульной странице.

/RecipientList=value

Полный путь к текстовому файлу, в котором содержится список получателей факса. Каждая строка соответствует одному получателю. Можно задать не только номер факса, но и имя получателя, например, 74957721234<Иван Петров>.

Отправляемые документы:

Для отправки единственного документа, используйте параметр /FileName. Чтобы отправить несколько документов, используйте параметр /FileList. Чтобы отправить факс, состоящий только из титульной страницы, пропустите эти параметры и укажите '/CoverPage=true'.

/FileName=value

Полный путь к документу, который будет отправлен в качестве факса.

/FileList=value

Полный путь к текстовому файлу, в котором содержится список отправляемых документов. Каждая строка соответствует одному документу. Следует указывать полные пути к файлам.

/DocumentName=value

Удобное имя, которое описывает отправляемый факс. Переопределяет значение по умолчанию, перечисляющее исходные имена отправляемых документов.

Параметры титульной страницы:

/CoverPage=value

Переопределяет параметр 'Прикреплять титульную страницу к факсу', см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax .

/CoverPage=true

Прикрепить титульную страницу к факсу. Обязательный параметр при отправке факса, состоящего только из титульной страницы.

/CoverPage=false

Не прикреплять титульную страницу к факсу.

/CoverInfo=value

Полный путь к пользовательскому ini-файлу с информацией для титульной страницы. Переопределяет значения по умолчанию, см. главы Титульные страницы (SendFaxMS.exe) - Microsoft Fax и Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax .

Структура ini-файла следующая:

[Template]

Переопределяет шаблон титульной страницы. При отсутствии раздела, используется шаблон по умолчанию.

UseServerCoverPage=

1 - стандартный шаблон; 0 - пользовательский шаблон

CoverPageName=

Имя титульной страницы (confident, fyi, generic, urgent) или путь к файлу шаблона.

[Sender]

Переопределяет сведения об отправителе. При отсутствии раздела, используются сведения об отправителе по умолчанию.

SdrName=

Имя отправителя.

SdrFaxNumber=

Номер факса отправителя.

SdrEmail=

Адрес электронной почты отправителя. Может быть переопределен с помощью параметра /SdrEmail. Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).

SdrCompany=

Название организации отправителя. Передается в верхней части каждой страницы факса. Можно переопределить с помощью параметра /FaxHeader.

SdrDepartment=

Имя отдела отправителя.

SdrTitle=

Должность отправителя.

SdrOfficeLocation=

Номер офиса (комнаты) отправителя.

SdrHomePhone=

Номер домашнего телефона отправителя.

SdrOfficePhone=

Номер рабочего телефона отправителя.

SdrAddress=

Адрес отправителя. Для переноса строк используйте символ '\n'.

SdrBillingCode=

Код биллинга, связанный с отправителем.

SdrTsid=

Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Может быть переопределен с помощью параметра /FaxStationID.

[Content]

Переопределяет тему факса и примечание к титульной странице. При отсутствии раздела, используются тема и примечание, заданные по умолчанию.

CoverPageSubject=

Тема факса.

CoverPageNote=

Примечание к титульной странице. Для переноса строк используйте символ '\n'.

Параметры факса (переопределения):

/FaxStationID=value

Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Переопределяет TSID, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows.

/FaxHeader=value

Строка заголовка факса. Передается в верхней части каждой страницы. Переопределяет имя организации, указанное в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows.

/SdrEmail=value

Адрес электронной почты отправителя. Переопределяет адрес эл. почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows. Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).

Важность и время отправки факса:

/Priority=value

Приоритет, используемый при отправке факса.

/Priority=Low

Низкий приоритет.

/Priority=Normal

Обычный приоритет (по умолчанию).

/Priority=High

Высокий приоритет.

/Discount

Отправить факс во время действия льготного тарифа.

/Schedule=value

Отправить факс не раньше указанной даты и времени. Формат даты и времени должен соответствовать настройкам вашей операционной системы, например 25.04.2022 22:15:30 Если этот параметр не используется либо дата/время не могут быть распознаны, будут использованы текущие значения даты и времени.

Параметры TIFF (применяются только при прямой конвертации в факс):

/AutoRotate=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/AutoRotate=true

Применить алгоритм автоматического выбора ориентации.

/AutoRotate=false

Не использовать автоматический выбор ориентации.

/A4Page=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/A4Page=true

Установить ширину и высоту страницы в формате A4.

/A4Page=false

Не контролировать высоту страницы.

/HALFTONE=value

Переопределяет значение по умолчанию заданное в Параметрах конвертации в факс .

/HALFTONE=true

Использовать полутона при конвертации в факс.

/HALFTONE=false

Не использовать полутона при конвертации.

Параметры конвертации (принудительные режимы):

/ForceDirectConvert

Создавать факс с использованием Прямой Конвертации. Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf).

/ForcePrint

Создавать факс путем печати на принтер факсов. Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита попытается создать факс с использованием функции Прямой Конвертации.

Уведомление на e-mail (оригинал):

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server. При отправке почты SSL не поддерживается.

/EmailReceiptMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax .

/EmailReceiptMS=true

Отправить уведомление о доставке по эл. почте.

/EmailReceiptMS=false

Не отправлять уведомление о доставке по эл. почте.

/ReceiptAddressMS=value

Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Переопределяет адрес эл. почты по умолчанию, заданный в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax .

/GroupReceiptMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax .

/GroupReceiptMS=true

Отправить одно уведомление для всех получателей факса.

/GroupReceiptMS=false

Отправлять индивидуальные уведомления для каждого получателя факса.

/ReceiptAttachFaxMS=value

Переопределяет значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax .

/ReceiptAttachFaxMS=true

Вложить копию отправленного факса.

/ReceiptAttachFaxMS=false

Не вкладывать копию отправленного факса.

Параметры отслеживания факса:

/Track

Отслеживание отправки факса . Этот параметр игнорируется при отправке факса нескольким получателям.

/JobID=value

Не создавать новый факс. Только отслеживать ранее созданный факс. Необходимо указать действительный идентификатор отслеживаемого факса (код задания). При использовании этого параметра все вышеперечисленные параметры игнорируются.

Параметры консоли:

Для работы в режиме консоли запускайте приложение SendFaxMS_c.exe.

/DoNotCloseConsole

Не закрывать консоль после выполнения. Будет отображено сообщение 'Для продолжения нажмите любую клавишу . . .'

/Console

Используя этот параметр, можно запустить приложение SendFaxMS.exe (версия с графическим интерфейсом) в режиме консоли. Обратите внимание, что вызывающее приложение не ожидает завершения работы консоли в этом случае. Вместо этого запускайте приложение SendFaxMS_c.exe.

Журналы и отладка:

/DebugLog

Включить журнал отладки, содержащий подробную информацию о работе SendFaxMS.exe.

Путь к файлу журнала: *{CommonAppDataFolder}\FaxVoip Modem\log\SendFaxMS_Debug.txt

/Log

Включить простой журнал, содержащий краткую информацию о работе SendFaxMS.exe.

Путь к файлу журнала: *{CommonAppDataFolder}\FaxVoip Modem\log\SendFaxMS_Log.txt

Примеры:

SendFaxMS.exe /FaxNumber=13607451257 /RecipientName=Andre Hedges /CoverPage=true

/CoverInfo=C:\ProgramData\FaxVoip Modem\SendFaxMS\Sample\coverpage_test.ini /Track /DebugLog /Log

SendFaxMS_c.exe /FaxNumber=14251234567 /RecipientName=Bob Linkermann /CoverPage=true

/FileName=C:\ProgramData\FaxVoip Modem\SendFaxMS\Sample\testPDF.pdf

/Priority=High /ForceDirectConvert /Track /DoNotCloseConsole /DebugLog /Log

SendFaxMS_c.exe /RecipientList=C:\ProgramData\FaxVoip Modem\SendFaxMS\Sample\Recipients_test.txt

/FileList=C:\ProgramData\FaxVoip Modem\SendFaxMS\Sample\FileList_test.txt

/FaxStationID=1(425)987-6543 /FaxHeader=This is my company /DoNotCloseConsole /DebugLog /Log

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Настройка и запуск SendFaxMS.exe

Настройка и запуск SendFaxMS.exe (Microsoft Fax) из панели управления Fax Voip T.38 Модем

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ››

На этой странице вы можете легко настроить параметры командной строки, а затем запустить SendFaxMS.exe, чтобы отправить факс или отслеживать состояние ранее созданного факса. Предлагаемый визуальный инструмент может быть полезен как для разработчиков, желающих протестировать и затем использовать SendFaxMS.exe в своих приложениях, так и для обычных пользователей, которые просто хотят отправить факс.

В контекстной вкладке SendFaxMS.exe, на ленте доступны следующие команды:

Запустить SendFaxMS.exe

Запустить

Нажмите чтобы запустить утилиту SendFaxMS.exe с выбранными параметрами.

Копировать

Нажмите чтобы скопировать командную строку в буфер обмена.

Отслеживать факс

Установите этот флажок, чтобы отслеживать активность отправляемого факса . Добавляет параметр /Track к командной строке. Этот параметр игнорируется при отправке факса нескольким получателям.

Запустить в консоли

Установите этот флажок, чтобы запустить консольную версию утилиты SendFaxMS.exe (SendFaxMS_c.exe). При запуске в родительской консоли новое окно консоли не создается. Вызывающий процесс ожидает завершения консольного приложения. Если флажок не установлен, SendFaxMS.exe запускается в режиме графического интерфейса пользователя (GUI). Режим графического интерфейса полезен для отслеживания факса , а также для сокрытия консоли.

Не закрывать консоль

Если этот флажок установлен, окно консоли не закрывается после выполнения, при этом в консоли отображается сообщение 'Для продолжения нажмите любую клавишу . . .' . Добавляет параметр /DoNotCloseConsole к командной строке. Не используйте эту опцию в автоматизированных сценариях.

Настроить SendFaxMS.exe

Настроить

Нажмите чтобы настроить параметры командной строки SendFaxMS.exe, см. Параметры SendFaxMS.exe . Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись в списке Параметры SendFaxMS.exe.

Обновить

Нажмите чтобы обновить командную строку SendFaxMS.exe, используя параметры, настроенные в списке Параметры SendFaxMS.exe.

Очистить

Нажмите чтобы очистить параметры командной строки SendFaxMS.exe.

Список получателей

Нажмите чтобы просмотреть / отредактировать список получателей факса, сохраненный в отдельном текстовом файле (параметр командной строки /RecipientList, обычно используется при отправке факса нескольким получателям).

Список документов

Нажмите чтобы просмотреть / отредактировать список документов, отправляемых в качестве факса, который хранится в отдельном текстовом файле (параметр командной строки /FileList, обычно используется при отправке нескольких факсимильных документов).

Титульная страница

Нажмите чтобы просмотреть / отредактировать информацию для титульной страницы, сохраненную в отдельном ini-файле (параметр командной строки /CoverInfo).

Журналы SendFaxMS.exe

Включить журнал отладки

Установите этот флажок, чтобы включить журнал отладки, содержащий подробную информацию о работе SendFaxMS.exe. Добавляет параметр /DebugLog к командной строке.

Включить простой журнал

Установите этот флажок, чтобы включить простой журнал, содержащий краткую информацию о работе SendFaxMS.exe. Добавляет параметр /Log к командной строке.

Просмотр журнала отладки

Нажмите для просмотра журнала отладки SendFaxMS.exe.

Просмотр журнала отладки

Нажмите для просмотра журнала отладки SendFaxMS.exe.

Просмотр простого журнала

Нажмите для просмотра простого журнала SendFaxMS.exe.

Журналы SendFaxMS.exe

Нажмите чтобы перейти на страницу Журналы SendFaxMS.exe (Microsoft Fax) .

Командная строка

Командная строка SendFaxMS.exe, состоит из пути к приложению и аргументов командной строки. Генерируется автоматически на основе вашей конфигурации. Текстовое поле можно редактировать вручную, но эти изменения не сохраняются и не гарантируют корректный запуск утилиты SendFaxMS.exe.

Не создавать новый факс. Только отслеживать ранее созданный факс.

Установите этот флажок, если вы хотите отслеживать ранее созданный факс. Необходимо указать действительный идентификатор отслеживаемого исходящего факса (код задания). При использовании этой опции новый факс не создается.

Код задания

Действительный код задания - уникальный идентификатор исходящего факсимильного сообщения.

Код задания факса можно получить с помощью Fax Service API, см. свойство FaxOutgoingJob.Id , также он отображается в программном обеспечении Факсы и сканирование Windows, в свойствах факса. В Факсы и сканирование Windows, в папке Исходящие, выберите факс и щелкните по нему правой кнопкой мыши. В контекстном меню выберите Свойства. Свойство Код задания можно найти на вкладке Сведения.

Список Параметры SendFaxMS.exe позволяет легко просматривать текущие настройки SendFaxMS.exe. Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись. См. также главу Параметры SendFaxMS.exe настоящего справочного руководства. Можно настроить следующие параметры:

  • Запустить в консоли. Указывает, запускается ли приложение в консоли (Тип: ДА; SendFaxMS_c.exe) или в режиме графического интерфейса (Тип: НЕТ; SendFaxMS.exe).
  • Получатели факса. Факс может быть отправлен одному получателю (Тип: ОДИН; /FaxNumber=...[/RecipientName=...]) или нескольким получателям (Тип: СПИСОК; /RecipientList=).
  • Прикрепить титульную страницу. Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса. Вы можете использовать опцию 'Прикреплять титульную страницу к факсу' по умолчанию, см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить ее (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /CoverPage=...)
  • Информация для титульной страницы. Вы можете использовать опции по умолчанию, см. главы Титульные страницы (SendFaxMS.exe) - Microsoft Fax и Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете полностью или частично переопределить их, используя ini-файл (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /CoverInfo=...).
  • Документы для отправки. Вы можете отправить один факсимильный документ (Тип: ОДИН; /FileName=...), несколько факсимильных документов (Тип: СПИСОК; /FileList=...), либо вы можете отправить факс, состоящий только из титульной страницы (Тип: НЕ ЗАДАНО).
  • Название документа. Удобное имя, которое описывает отправляемый факс. Значение по умолчанию, перечисляющее исходные имена отправляемых документов (Тип: ПО УМОЛЧАНИЮ), может быть переопределено (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /DocumentName=...).
  • Время отправки факса. Факс может быть отправлен немедленно (Тип: СЕЙЧАС), в указанное время (Тип: ВРЕМЯ; /Schedule=...), либо отправлен во время действия льготного тарифа (Тип: ЛЬГОТНЫЙ ТАРИФ; /Discount).
  • Важность факса. Задает приоритет, используемый при отправке факса. Факс может быть отправлен с низким приоритетом (Тип: НИЗКАЯ; /Priority=Low), обычным приоритетом (Тип: ОБЫЧНАЯ) или высоким приоритетом (Тип: ВЫСОКАЯ; /Priority=High).
  • Идентификатор факса. Идентификатор передающей станции (TSID) для устройства отправителя. Передается в верхней части каждой страницы факса. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить TSID, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /FaxStationID=...).
  • Заголовок факса. Строка заголовка факса. Передается в верхней части каждой страницы. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить имя организации, указанное в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /FaxHeader=...).
  • Эл. почта отправителя. Адрес электронной почты отправителя. Можно использовать значение по умолчанию (Тип: ПО УМОЛЧАНИЮ). Либо можно переопределить адрес эл. почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /SdrEmail=...). Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).
  • Прямая конвертация (принудительно). (Тип: ДА; /ForceDirectConvert) Факс создается с использованием Прямой Конвертации. Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf). (Тип: НЕТ) Параметр /ForceDirectConvert не применяется.
  • Печать документа (принудительно). (Тип: ДА; /ForcePrint) Факс создается путем печати на принтер факсов. Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита попытается создать факс с использованием функции Прямой Конвертации. (Тип: НЕТ) Параметр /ForcePrint не применяется.
  • Автоповорот. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /AutoRotate=...).
  • Страница A4. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /A4Page=...).
  • Передача полутонов. Вы можете использовать значение по умолчанию заданное в Параметрах конвертации в факс (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /HALFTONE=...).
  • Уведомление на e-mail (ориг.). Указывает, следует ли отправить уведомление о доставке по эл. почте. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /EmailReceiptMS=...). Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server. При отправке почты SSL не поддерживается.
  • Уведомить по адресу (ориг.). Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /ReceiptAddressMS=...).
  • Одно уведомление для нескольких получателей (ориг.). Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправить одно уведомление для всех получателей факса. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /GroupReceiptMS=...).
  • Вложить копию факса в уведомление (ориг.). Указывает, следует ли вкладывать копию отправленного факса при отправке уведомления о доставке. Вы можете использовать значение по умолчанию заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax (Тип: ПО УМОЛЧАНИЮ), либо вы можете переопределить его (Тип: ПЕРЕОПРЕДЕЛЕНИЕ; /ReceiptAttachFaxMS=...).
  • Отслеживать факс. Вы можете отслеживать активность отправляемого факса (Тип: ДА; /Track). Этот параметр игнорируется при отправке факса нескольким получателям. Если этот параметр не указан, SendFaxMS.exe завершает работу сразу же после создания задания факса (Тип: НЕТ).
  • Не закрывать консоль. Если указан этот параметр (Тип: ДА; /DoNotCloseConsole), окно консоли не закрывается после выполнения, при этом в консоли отображается сообщение 'Для продолжения нажмите любую клавишу . . .' . Если этот параметр не указан (Тип: НЕТ), окно консоли закрывается сразу после выполнения.
  • Включить журнал отладки. Если указан этот параметр (Тип: ДА; /DebugLog), приложение создает журнал отладки, содержащий подробную информацию о работе SendFaxMS.exe. Если этот параметр не указан (Тип: НЕТ), журнал отладки не создается.
  • Включить простой журнал. Если указан этот параметр (Тип: ДА; /Log), приложение создает простой журнал, содержащий краткую информацию о работе SendFaxMS.exe. Если этот параметр не указан (Тип: НЕТ), простой журнал не создается.


Титульные страницы

Титульные страницы (SendFaxMS.exe) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Настройка и запуск SendFaxMS.exe ››

На этой странице вы можете задать настройки по умолчанию для титульных страниц факсов, которые будут использоваться при отправке факса с помощью утилиты командной строки SendFaxMS.exe .

Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи. Титульные страницы можно использовать разными способами. Вы можете отправить факс, состоящий только из титульной страницы, при этом само сообщение включается в него в качестве примечания к титульной странице. Но можно также отправить титульную страницу в дополнение к другому документу. Например, можно послать по факсу документ Microsoft Word и сопроводить его титульной страницей. В этом случае титульная страница будет добавлена ​​в документ и отправлена ​​как первая страница факса.

Приведенные ниже параметры могут быть переопределены с помощью параметров командной строки /CoverPage и /CoverInfo, см. главы Параметры командной строки SendFaxMS.exe - Microsoft Fax и Титульная страница (параметры SendFaxMS.exe, Microsoft Fax) настоящего справочного руководства.

Укажите сведения об отправителе

Нажмите, чтобы перейти на страницу Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax , где вы можете указать информацию об отправителе по умолчанию для использования с утилитой SendFaxMS.exe.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании утилиты SendFaxMS.exe.

Использовать стандартный шаблон титульной страницы

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу сохраненную в указанном файле

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip T.38 Модем.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Тема (по умолчанию)

В этом поле можно указать тему факса по умолчанию для использования с утилитой SendFaxMS.exe. Эта информация обычно отображается на титульной странице. Заполнение этого поля не обязательно.

Примечание к титульной странице (по умолчанию)

Текст по умолчанию, который будет отображен на титульной странице факса в качестве примечания (при использовании утилиты SendFaxMS.exe). Заполнение этого поля не обязательно.

Примечания

  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Настройка и запуск SendFaxMS.exe ››

На этой странице можно указать информацию об отправителе факса, которая будет отображаться на титульной странице факса в случае использования утилиты командной строки SendFaxMS.exe . Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline). Адрес электронной почты, указанный в поле Эл.почта, может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).

Приведенные ниже параметры могут быть переопределены с помощью параметра командной строки /CoverInfo, см. главы Параметры командной строки SendFaxMS.exe - Microsoft Fax и Сведения об отправителе (параметры SendFaxMS.exe, Microsoft Fax) настоящего справочного руководства.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается утилита SendFaxMS.exe.

Использовать нижеследующую информацию об отправителе

Если выбрана эта опция, утилита SendFaxMS.exe использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Эл. почта

Адрес электронной почты отправителя. Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Может быть переопределен с помощью параметра командной строки /SdrEmail.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста. Можно переопределить с помощью параметра командной строки /FaxHeader.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. Может быть переопределен с помощью параметра командной строки /FaxStationID.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • Адрес электронной почты, указанный в поле Эл. почта, может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Чтобы использовать этот функционал, вы должны вручную включить опцию Разрешить отправку факсов через электронную почту (служба факсов Windows) в параметрах почта-на-факс - Microsoft Fax . Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты для указанного адреса электронной почты и отключить отправку уведомлений, см. главу Уведомления о доставке (правило для почты, Microsoft Fax) настоящего справочного руководства.


Уведомления на е-mail (оригинал)

Параметры уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Настройка и запуск SendFaxMS.exe ››

На этой странице вы можете задать настройки по умолчанию для оригинальных уведомлений о доставке на e-mail, которые будут использоваться при отправке факса с помощью утилиты командной строки SendFaxMS.exe .

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server (например Windows Server 2022). Этот функционал не поддерживает SSL при отправке электронной почты. В качестве альтернативы, вы можете указать адрес электронной почты в сведениях об отправителе , и он будет обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Также можно использовать метод маршрутизации исходящих факсов Уведомления о доставке по электронной почте (Microsoft Fax) - функционал из пакета Fax Voip T.38 Модем.

Приведенные ниже параметры могут быть переопределены с помощью следующих параметров командной строки: /EmailReceiptMS, /ReceiptAddressMS, /GroupReceiptMS и /ReceiptAttachFaxMS, см. главы Параметры командной строки SendFaxMS.exe - Microsoft Fax и Уведомления на е-mail - оригинал (параметры SendFaxMS.exe, Microsoft Fax) настоящего справочного руководства.

Не отправлять уведомления о доставке факса по электронной почте

Выберите этот вариант, чтобы отключить уведомления о доставке. Можно переопределить с помощью параметра командной строки /EmailReceiptMS.

Отправлять уведомления о доставке факса по электронной почте

Выберите этот вариант, чтобы отправлять уведомления о доставке по электронной почте. Можно переопределить с помощью параметра командной строки /EmailReceiptMS.

По адресу:

Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса. Можно переопределить с помощью параметра командной строки /ReceiptAddressMS.

<Адресная книга>

Нажмите, чтобы выбрать получателя e-mail сообщения из адресной книги (контакты Windows).

Одно уведомление для нескольких получателей

Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправлять одно уведомление для всех получателей факса. Если этот флажок не установлен, будет отправлено индивидуальное уведомление для каждого получателя факса. Можно переопределить с помощью параметра командной строки /GroupReceiptMS.

Вкладывать копию отправленного факса

Установите этот флажок, чтобы вкладывать копию отправленного факса (файл TIFF) при отправке уведомления о доставке. При отправке факса нескольким получателям и при заданной опции Одно уведомление для нескольких получателей, факс обычно не может быть прикреплен к уведомлению, потому что он отличается для каждого получателя. Можно переопределить с помощью параметра командной строки /ReceiptAttachFaxMS.

<Параметры SMTP>

Нажмите, чтобы настроить Параметры SMTP (служба факсов Windows) . Требуются права администратора.


Параметры SMTP (служба факсов Windows)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Настройка и запуск SendFaxMS.exe ›› Уведомления на е-mail (оригинал) ››

Чтобы настроить параметры SMTP, которые будут использоваться с оригинальными е-mail уведомлениями о доставке факса , выполните следующие действия:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Факс, затем нажмите SendFaxMS.exe (MS Fax), затем нажмите Уведомления на e-mail (оригинал).

3. Нажмите кнопку <Параметры SMTP>.

4. В окне Параметры SMTP (служба факсов Windows), настройте параметры SMTP.

Параметры SMTP (служба факсов Windows)

Доставка уведомлений по электронной почте (SMTP)

Установите этот флажок, чтобы включить отправку уведомлений о доставке по эл. почте (SMTP).

Адрес отправителя

Адрес электронной почты, с которого будет отправлено уведомление о доставке.

Адрес сервера

Имя SMTP сервера, с которого будут отправляться уведомления.

Порт

Номер порта SMTP, обычно 25.

Анонимный доступ

Факс-сервер отправляет уведомление о доставке факса, используя неавторизованный доступ к SMTP серверу. Обычно не используется.

Обычная проверка подлинности

Факс-сервер отправляет уведомление о доставке факса, используя базовую аутентификацию на SMTP сервере. Требуются Имя пользователя и Пароль. Обычно следует выбирать эту опцию.

Встроенная проверка подлинности Windows

Факс-сервер отправляет уведомление о доставке факса, используя NTLM-аутентификацию на SMTP сервере. Требуются Имя пользователя и Пароль. Обычно не используется.

Имя пользователя

Имя пользователя для авторизации на сервере SMTP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Пароль для авторизации на сервере SMTP.

Подтверждение пароля

Это поле используется для подтверждения пароля.

Применять эти параметры SMTP для маршрутизации входящих факсов с использованием электронной почты (расширение маршрутизации Microsoft)

Указывает, следует ли использовать указанные выше параметры SMTP для расширения маршрутизации Microsoft, которое позволяет маршрутизировать входящие факсы получателям e-mail (оригинальный функционал).

5. Нажмите кнопку <OK>, чтобы сохранить настройки. Все изменения вступают в силу немедленно. Требуются права администратора.

Примечания

  • Этот функционал является частью программного обеспечения службы факсов Windows и доступен только в ОС Windows Server (например Windows Server 2022). SSL не поддерживается при отправке электронной почты.
  • В качестве альтернативы, вы можете настроить параметры SMTP с помощью Диспетчера службы факса (Microsoft). Для доступа к указанным настройкам, в левой панели щелкните правой кнопкой мыши по узлу Факс, нажмите Свойства, а затем откройте вкладку Уведомления.


Параметры SendFaxMS.exe

Параметры SendFaxMS.exe - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ››

Эта глава содержит информацию по настройке параметров командной строки SendFaxMS.exe с помощью диалогового окна Настройка параметров SendFaxMS.exe, см. также главу Настройка и запуск SendFaxMS.exe (Microsoft Fax) из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Чтобы настроить параметры командной строки, а затем запустить SendFaxMS.exe, выполните следующие действия:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Факс, а затем нажмите SendFaxMS.exe (MS Fax).

3. Чтобы изменить параметры командной строки, в контекстной вкладке SendFaxMS.exe на ленте нажмите Настроить. Чтобы быстро изменить параметры командной строки определенного типа, дважды щелкните выбранную запись в списке Параметры SendFaxMS.exe.

4. В окне Настройка параметров SendFaxMS.exe, укажите одного или нескольких получателей факса, выберите документы для отправки в качестве факса и укажите другие необходимые параметры. Нажмите OK.

5. Чтобы запустить утилиту SendFaxMS.exe с выбранными параметрами, в контекстной вкладке SendFaxMS.exe на ленте нажмите Запустить.

В диалоговом окне Настройка параметров SendFaxMS.exe можно настроить следующие параметры:

  • Получатели факса
  • Документы
  • Конвертация в факс
  • Титульная страница
  • Сведения об отправителе
  • Важность и время отправки факса
  • Уведомления на е-mail (оригинал)


Получатели факса

Получатели факса (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Получатели факса

На этой вкладке вы можете указать одного или нескольких получателей факса.

Номер факса

Номер факса получателя. Для отправки факса нескольким получателям, последовательно введите сведения о каждом получателе в поле Номер факса и (опционально) в поле Имя получателя, и нажимайте Добавить для добавления получателя в список получателей факса.

Имя получателя

Имя получателя. Отображается на титульной странице.

<Адресная книга>

Нажмите, чтобы выбрать одного или нескольких получателей факса из Адресной книги (Контакты Windows). Выбранный получатель будет добавлен в список получателей факса при условии непустого поля Работа, факс либо непустого поля Дом, факс.

<Список>

Нажмите, чтобы загрузить список номеров факсов из выбранного текстового файла. При подготовке текстового файла, вы должны руководствоваться следующими правилами:

      • Каждая строка может содержать единственный номер факса.
      • Номер факса должен находиться в начале строки. Пробелы и символы табуляции в начале строки игнорируются.
      • Строка может содержать любую дополнительную информацию, такую как имя компании, номер телефона и т.д. Эта информация должна быть отделена от номера факса с использованием любого из следующих разделителей: пробел, символ табуляции или точка с запятой.

Обратите внимание, что этот метод не позволяет добавлять имена получателей.

<Добавить>

Используйте эту кнопку, чтобы добавить получателя в список получателей факса. Номер факса получателя должен быть изначально введен в поле Номер факса, а имя получателя (опционально) должно быть введено в поле Имя получателя.

<Удалить>

Используйте эту кнопку для удаления получателя из списка получателей факса.

<Изменить>

Нажмите, чтобы изменить номер факса и имя получателя. Один из получателей должен быть выбран в списке.

Хранить список получателей в файле

Установите этот флажок, чтобы сохранить список получателей факса в отдельном текстовом файле (параметр командной строки /RecipientList=). Полный путь к текстовому файлу, в котором содержится список получателей факса, должен быть указан в текстовом поле ниже. Если этот флажок не установлен, единственный получатель факса задается с помощью параметров командной строки /FaxNumber= и (опционально) /RecipientName=.

<Обзор>

Нажмите, чтобы указать путь к текстовому файлу, в котором хранится список получателей факса. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip Modem\SendFaxMS\Recipients.txt.

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Документы

Документы (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Документы

На этой вкладке вы можете выбрать один или несколько документов для отправки в качестве факса.

Документ

Полный путь к документу, который будет отправлен в качестве факса. Чтобы отправить несколько документов, последовательно выберите каждый из них, и нажимайте Добавить для добавления документа в список документов.

<Обзор>

Нажмите, чтобы выбрать путь к документу, который будет отправлен в качестве факса. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

<Добавить>

Используйте эту кнопку, чтобы добавить документ в список отправляемых документов. Документ должен быть изначально выбран в текстовом поле выше.

<Удалить>

Используйте эту кнопку для удаления документа из списка отправляемых документов.

Хранить список документов в файле

Установите этот флажок, чтобы сохранить список отправляемых документов в отдельном текстовом файле (параметр командной строки /FileList=). Полный путь к текстовому файлу, в котором содержится список отправляемых документов, должен быть указан в текстовом поле ниже. Если этот флажок не установлен, полный путь к единственному отправляемому документу задается с помощью параметра командной строки /FileName=.

<Обзор>

Нажмите, чтобы указать путь к текстовому файлу, в котором хранится список отправляемых документов. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip Modem\SendFaxMS\FileList.txt.

Название документа (переопределение)

Установите этот флажок, чтобы переопределить заданное по умолчанию удобное имя, которое описывает отправляемый факс (параметр командной строки /DocumentName=). Введите название документа в текстовом поле справа. Если этот флажок не установлен, используется значение по умолчанию (список исходных имен отправляемых документов).

Примечания

  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Конвертация в факс

Конвертация в факс (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Конвертация в факс

На этой вкладке вы можете указать, каким образом конвертировать ваши документы в факс (файл TIFF).

Параметры TIFF (только при прямом преобразовании)

В этой области вы можете переопределить Параметры TIFF по умолчанию, заданные в Параметрах конвертации в факс . Эти параметры применяются только при использовании прямой конвертации в факс.

Автоповорот (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы применить алгоритм автоматического выбора ориентации (параметр командной строки /AutoRotate=true). Либо выберите Нет, чтобы не использовать алгоритм автоматического выбора ориентации (параметр командной строки /AutoRotate=false).

Страница A4 (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы установить ширину и высоту страницы в формате A4 (параметр командной строки /A4Page=true). Либо выберите Нет, чтобы не контролировать высоту страницы (параметр командной строки /A4Page=false).

Передача полутонов (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах конвертации в факс . Справа выберите Да, чтобы использовать полутона при конвертации в факс (параметр командной строки /HALFTONE=true). Либо выберите Нет, чтобы не использовать полутона при конвертации (параметр командной строки /HALFTONE=false).

Принудительные режимы

Параметры ниже позволяют игнорировать Параметры конвертации в факс , заданные по умолчанию.

Прямая конвертация (принудительно)

Установите этот флажок, чтобы создать факс с использованием функции Прямой конвертации (параметр командной строки /ForceDirectConvert). Настройки заданные в Параметрах конвертации в факс игнорируются. Может применяться только со следующими типами файлов: pdf, tif(tiff), sff, qfx, bmp, jpg(jpeg), gif, png, ico, wmf(emf).

Печать документа (принудительно)

Установите этот флажок, чтобы создать факс путем печати на принтер факсов (параметр командной строки /ForcePrint). Настройки заданные в Параметрах конвертации в факс игнорируются. При неудаче, утилита SendFaxMS.exe попытается создать факс с использованием функции Прямой конвертации.


Титульная страница

Титульная страница (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Титульная страница

Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи. Титульные страницы можно использовать разными способами. Вы можете отправить факс, состоящий только из титульной страницы, при этом само сообщение включается в него в качестве примечания к титульной странице. Но можно также отправить титульную страницу в дополнение к другому документу. Например, можно послать по факсу документ Microsoft Word и сопроводить его титульной страницей. В этом случае титульная страница будет добавлена ​​в документ и отправлена ​​как первая страница факса.

На этой вкладке вы можете переопределить настройки по умолчанию для титульной страницы факса, см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax .

Прикрепить титульную страницу (переопределение)

Установите этот флажок, чтобы переопределить параметр Прикреплять титульную страницу к факсу, заданный по умолчанию, см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax . Справа выберите Да, чтобы прикрепить титульную страницу к факсу (параметр командной строки /CoverPage=true). Либо выберите Нет, чтобы не прикреплять титульную страницу к факсу (параметр командной строки /CoverPage=false). Чтобы отправить факс, состоящий только из титульной страницы, установите флажок, а затем справа выберите Да (/CoverPage=true в этом случае является обязательным параметром командной строки).

Шаблон титульной страницы (переопределить настройки по умолч.)

Установите этот флажок, чтобы переопределить шаблон титульной страницы, заданный по умолчанию, см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax . Измененные настройки хранятся в разделе [Template] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Использовать стандартный шаблон

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу из указанного файла

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip T.38 Модем.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Тема факса и примечание (переопределить настройки по умолчанию)

Установите этот флажок, чтобы переопределить тему факса и примечание к титульной странице, заданные по умолчанию, см. главу Титульные страницы (SendFaxMS.exe) - Microsoft Fax . Измененные настройки хранятся в разделе [Content] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Тема

В этом поле можно указать тему факса. Эта информация обычно отображается на титульной странице. Заполнение этого поля не обязательно.

Примечание к титульной странице

Текст, который будет отображен на титульной странице факса в качестве примечания. Заполнение этого поля не обязательно.

Хранить информацию для титульной страницы в этом файле

Полный путь к пользовательскому ini-файлу с информацией для титульной страницы (параметр командной строки /CoverInfo=).

<Обзор>

Нажмите, чтобы указать путь к пользовательскому ini-файлу, в котором будет храниться информация для титульной страницы. По умолчанию предлагается путь *{CommonAppDataFolder}\FaxVoip Modem\SendFaxMS\coverpage.ini.

Примечания

  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (параметры SendFaxMS.exe, Microsoft Fax) настоящего справочного руководства.
  • *{CommonAppDataFolder} - системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Сведения об отправителе

Сведения об отправителе (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Сведения об отправителе

Информация об отправителе отображается на титульных страницах. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline). Адрес электронной почты, указанный в поле Эл.почта, может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).

На этой вкладке вы можете переопределить настройки по умолчанию для информации об отправителе, см. главу Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax .

Сведения об отправителе (переопределить настройки по умолчанию)

Установите этот флажок, чтобы переопределить настройки для информации об отправителе, заданные по умолчанию, см. главу Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax . Измененные настройки хранятся в разделе [Sender] в пользовательском ini-файле (параметр командной строки /CoverInfo=).

Использовать информацию об отправителе, заданную по умолчанию

Указывает, что используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается утилита SendFaxMS.exe.

Использовать нижеследующие данные

Если выбрана эта опция, утилита SendFaxMS.exe использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Эл. почта

Адрес электронной почты отправителя. Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Может быть переопределен с помощью опции E-mail отправителя (переопр.), см. ниже (параметр командной строки /SdrEmail=).

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста. Можно переопределить с помощью опции Заголовок факса (переопр.), см. ниже (параметр командной строки /FaxHeader=).

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. Может быть переопределен с помощью опции Идент. факса (переопр.), см. ниже (параметр командной строки /FaxStationID=).

Код оплаты

Код биллинга, связанный с отправителем.

Идент. факса (переопр.)

Установите этот флажок, чтобы переопределить идентификатор передающей станции (TSID), указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /FaxStationID=). Введите TSID в текстовом поле справа. Код TSID передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса.

Заголовок факса (переопр.)

Установите этот флажок, чтобы переопределить строку заголовка факса (название организации), указанную в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /FaxHeader=). Введите заголовок факса в текстовом поле справа. Заголовок факса обычно передается в верхней части каждой страницы отправляемого факса.

E-mail отправителя (переопр.)

Установите этот флажок, чтобы переопределить адрес электронной почты, указанный в 'Сведениях об отправителе', включая штатные настройки службы факсов Windows (параметр командной строки /SdrEmail=). Введите адрес электронной почты в текстовом поле справа. Этот адрес может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ).

Примечания

  • Адрес электронной почты, заданный в поле Эл. почта или с использованием опции E-mail отправителя (переопр.) (параметр командной строки /SdrEmail=), может быть обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Чтобы использовать этот функционал, вы должны вручную включить опцию Разрешить отправку факсов через электронную почту (служба факсов Windows) в параметрах почта-на-факс - Microsoft Fax . Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты для указанного адреса электронной почты и отключить отправку уведомлений, см. главу Уведомления о доставке (правило для почты, Microsoft Fax) настоящего справочного руководства.


Важность и время отправки факса

Важность и время отправки факса (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Важность и время отправки факса

На этой вкладке вы можете запланировать время для отправки вашего факса и задать приоритет, который будет использоваться при отправке факса.

Важность

В этой области вы можете задать приоритет, который будет использоваться при отправке факса.

Важность факса

Укажите приоритет, который следует использовать при отправке факса. Все факсы, имеющие высокую важность (параметр командной строки /Priority=High), будут отправлены перед факсом, который имеет обычную или низкую (параметр командной строки /Priority=Low) важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Время отправки факса

В этой области вы можете запланировать время для отправки вашего факса.

Сейчас

Выберите эту опцию, чтобы отправить факс немедленно.

Во время действия льготного тарифа

Выберите эту опцию, чтобы отправить факс во время действия льготного тарифа (параметр командной строки /Discount). На компьютере с операционной системой Windows Server (например Windows Server 2022), время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 или Windows 10, время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).

В указанное время

Выберите эту опцию, чтобы указать дату и время отправки факса (параметр командной строки /Schedule=).


Уведомления на е-mail (оригинал)

Уведомления на е-mail - оригинал (параметры SendFaxMS.exe, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Параметры SendFaxMS.exe ››

Уведомления на е-mail (оригинал)

Оригинальные уведомления о доставке - функционал службы факсов Windows, доступный только в ОС Windows Server (например Windows Server 2022). Этот функционал не поддерживает SSL при отправке электронной почты. В качестве альтернативы, вы можете указать адрес электронной почты в сведениях об отправителе , и он будет обработан функцией Почта-на-факс - Microsoft Fax ( уведомления о доставке на адрес электронной почты отправителя ). Также можно использовать метод маршрутизации исходящих факсов Уведомления о доставке по электронной почте (Microsoft Fax) - функционал из пакета Fax Voip T.38 Модем.

На этой вкладке вы можете переопределить настройки по умолчанию для оригинальных уведомлений о доставке на e-mail, заданные в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax .

Отправить уведомление на e-mail (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax . Справа выберите Да, чтобы отправить уведомление о доставке по электронной почте (параметр командной строки /EmailReceiptMS=true). Либо выберите Нет, чтобы не отправлять уведомление (параметр командной строки /EmailReceiptMS=false).

По адресу (переопр.)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax . Справа, в текстовом поле, введите адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса (параметр командной строки /ReceiptAddressMS=).

<Адресная книга>

Нажмите, чтобы выбрать получателя e-mail сообщения из адресной книги (контакты Windows).

Одно уведомл. для нескольких получателей (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax . Справа выберите Да, чтобы отправить одно уведомление для всех получателей факса (параметр командной строки /GroupReceiptMS=true). Либо выберите Нет, чтобы отправлять индивидуальные уведомления для каждого получателя факса (параметр командной строки /GroupReceiptMS=false).

Вкладывать копию отправленного факса (переопределение)

Установите этот флажок, чтобы переопределить значение по умолчанию, заданное в Параметрах уведомлений о доставке на е-mail - оригинал (SendFaxMS.exe) - Microsoft Fax . Справа выберите Да, чтобы вложить копию отправленного факса (файл TIFF) при отправке уведомления о доставке (параметр командной строки /ReceiptAttachFaxMS=true). Либо выберите Нет, чтобы не вкладывать копию отправленного факса (параметр командной строки /ReceiptAttachFaxMS=false).

<Параметры SMTP>

Нажмите, чтобы настроить Параметры SMTP (служба факсов Windows) . Требуются права администратора. В качестве альтернативы, вы можете настроить параметры SMTP с помощью Диспетчера службы факса (Microsoft). Для доступа к настройкам SMTP, в левой панели щелкните правой кнопкой мыши по узлу Факс, нажмите Свойства, а затем откройте вкладку Уведомления.


Отслеживание факса (графический интерфейс)

Отслеживание факса (графический интерфейс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ››

При запуске утилиты SendFaxMS.exe в режиме графического интерфейса пользователя (GUI) с параметром командной строки /Track, отображается окно отслеживания факса. Окно отслеживания факса аналогично Монитору факсов , который входит в программное обеспечение Факсы и сканирование Windows, но позволяет отслеживать конкретный, только что созданный исходящий факс. Вы можете не только просматривать состояние факса , но также управлять заданием факса и просматривать свойства факса . Параметр /Track игнорируется при отправке факса нескольким получателям. Также можно отслеживать ранее созданный факс, запустив SendFaxMS.exe с параметром /JobID=.

Команды ленты в окне отслеживания факса

Следующие команды доступны в меню Файл:

Просмотр (F3)

Нажмите для просмотра факса в программе для просмотра TIFF файлов. См. также Параметры просмотра факсов .

Удалить (Del)

Нажмите чтобы удалить факс. Отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Пауза

Нажмите чтобы приостановить передачу факса.

Продолжить

Нажмите чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи.

Перезапустить

Нажмите чтобы повторить передачу факса после неудачной попытки.

Справка (F1)

Нажмите чтобы открыть файл справки. Для вызова справочной системы вы также можете использовать кнопку Вызов справки, расположенную в правом верхнем углу ленты.

Выход (Ctrl + X)

Нажмите, чтобы выйти из приложения.

Следующие команды доступны на вкладке Главная:

Факс

Просмотр (F3)

Нажмите для просмотра факса в программе для просмотра TIFF файлов. См. также Параметры просмотра факсов .

Удалить (Del)

Нажмите чтобы удалить факс. Отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Действия

Пауза

Нажмите чтобы приостановить передачу факса.

Продолжить

Нажмите чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи.

Перезапустить

Нажмите чтобы повторить передачу факса после неудачной попытки.

Области

События

Нажмите чтобы отобразить или скрыть журнал событий. См. также Мониторинг факса .

Свойства

Нажмите чтобы отобразить или скрыть свойства факса. См. также Просмотр свойств факса .

Предпросмотр

Нажмите чтобы отобразить или скрыть панель предварительного просмотра.

Следующие команды доступны на вкладке Вид:

Цвета ленты

Стандартные цвета

Выберите этот вариант, чтобы применить стандартную цветовую схему (определяется операционной системой).

Настроить цвета

Выберите этот вариант, чтобы настроить цвета ленты. Обратите внимание, что эта опция не работает правильно в Windows 11, Windows 10 версии 1809 или более поздней, Windows Server 2022 и в Windows Server 2019.

Цвет фона

Выберите основной цвет фона для настраиваемой ленты.

Цвет выделения

Выберите основной цвет выделения для настраиваемой ленты (только Windows 7).

Цвет текста

Выберите основной цвет текста для настраиваемой ленты.

Текущее представление

Лента

Снимите флажок чтобы скрыть ленту (Ribbon). Переключение в классический режим произойдет при следующем запуске приложения.

Панель инструментов

Поставьте флажок чтобы отобразить классическую панель инструментов. Переключение в классический режим произойдет при следующем запуске приложения.

Строка меню

Поставьте флажок чтобы отобразить классическое меню. Переключение в классический режим произойдет при следующем запуске приложения.

Вид по умолчанию

Восстановить умолчания

Используйте эту опцию для восстановления внешнего вида по умолчанию для окна отслеживания факса.

Панель быстрого доступа представляет собой небольшую, настраиваемую панель инструментов, которая содержит набор команд, заданных приложением или выбранных пользователем.

По умолчанию, Панель быстрого доступа расположена в строке заголовка окна отслеживания факса, но также может быть настроена для отображения под лентой. В дополнение к отображенным командам, Панель быстрого доступа также включает в себя настраиваемое выпадающее меню, которое содержит полный набор команд Панели быстрого доступа по умолчанию (скрытых или отображенных), а также параметры настройки Панели быстрого доступа и ленты. Почти все элементы управления ленты могут быть добавлены на Панель быстрого доступа через контекстное меню, как показано на рисунке ниже.


Мониторинг факса

Мониторинг факса (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Отслеживание факса (графический интерфейс) ››

Когда вы запускаете утилиту SendFaxMS.exe с параметром /Track, окно с текущей информацией о вашем факсе отображается сразу же после успешного создания задания факса. В основной области отображается информация о получателе факса, текущем состоянии факса (например, какая страница в данный момент передается), а также информация о времени, прошедшем с начала передачи факса. Чтобы просмотреть полный список событий, касающихся вашего факса, на ленте нажмите События. Вы можете остановить отслеживание факса в любой момент, просто закрыв окно отслеживания факса.


Просмотр свойств факса

Просмотр свойств факса (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Отслеживание факса (графический интерфейс) ››

Чтобы просмотреть свойства факса в окне отслеживания, на ленте нажмите Свойства. Чтобы отобразить панель предварительного просмотра, нажмите Предпросмотр.

Следующие свойства факса отображаются на вкладке Общие:

Свойства факса (Общие)

  • Номер получателя. Номер факса получателя.
  • Имя получателя. Имя получателя. Отображается на титульной странице.
  • Страниц. Общее количество страниц в отправляемом факсимильном сообщении.
  • Состояние. Текущее состояние факса (например Выполняется, Повтор, Завершено).
  • Расширенное состояние. Расширенное состояние факса (например Набор номера, Отправка страницы..., Нет ответа, Занято).
  • Код CSID. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • Код TSID. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с номером факса, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
  • Устройство. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
  • Повторы. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • Запланированное время. Время, на которое запланирована отправка факса.
  • Время начала. Время начала передачи исходящего факса.
  • Время окончания. Время окончания передачи исходящего факса.
  • Продолжительность. Продолжительность передачи исходящего факса.

Следующие свойства факса отображаются на вкладке Сведения:

Свойства факса (Сведения)

  • Название документа. Удобное имя, которое описывает отправляемый факс.
  • Титульная страница. Указывает, содержит ли факс титульную страницу.
  • Тема. Тема факса. Отображается на титульной странице.
  • Размер. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с факсом, в килобайтах.
  • Приоритет. Важность факса; например обычная, низкая или высокая.
  • Код задания. Уникальный идентификатор, назначенный факсу в процессе формирования задания. Этот идентификатор следует указывать при запуске SendFaxMS.exe с параметром командной строки /JobID=, чтобы отслеживать ранее созданный факс.
  • Код рассылки. Уникальный идентификатор, назначенный факсу в процессе формирования задания. При отправке факса более чем одному получателю, создаются отдельные задания факса, каждому из которых назначается свой Код задания, но в рамках одной группы заданий им будет назначен один и тот же Код рассылки.
  • Время постановки в очередь. Время формирования задания исходящего факса.
  • Исх. запланированное время. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • Время отправки факса. Указывает способ задания времени отправки факса. Это свойство может иметь одно из следующих значений: Сейчас (немедленная отправка факса), В указанное время, Во время действия льготного тарифа.
  • Уведомление о доставке. Указывает тип уведомления о доставке факса. Это свойство может иметь одно из следующих значений: Эл. почта; Не требуется. Оригинальные уведомления о доставке факса на e-mail доступны только в ОС Windows Server (например Windows Server 2022), см. также в главе Уведомления на e-mail (оригинал) настоящего справочного руководства.
  • Уведомить по адресу. Адрес электронной почты, на который служба факсов должна отправить уведомление о доставке факса.
  • Общее уведомление. Указывает, следует ли отправлять индивидуальные уведомления для каждого получателя факса или отправить одно уведомление для всех получателей факса.

Следующие свойства факса отображаются на вкладке Сведения об отправителе:

Свойства факса (Сведения об отправителе)

  • Имя. Имя отправителя.
  • Номер факса. Номер факса отправителя.
  • Электронная почта. Адрес электронной почты отправителя.
  • Должность. Должность отправителя.
  • Организация. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • Отдел. Имя отдела отправителя.
  • Комната. Номер офиса (комнаты) отправителя.
  • Телефон (раб.). Номер рабочего телефона отправителя.
  • Телефон (дом.). Номер домашнего телефона отправителя.
  • Адрес. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • Код оплаты. Код биллинга, связанный с отправителем.
  • Код TSID. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), обычно совпадающий с номером факса, указанном в сведениях об отправителе . Обратите внимание, что в зависимости от настроек факс сервера, он может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Вкладка Просмотр используется для предварительного просмотра факса.

Предварительный просмотр факса


Работа с факсом

Работа с факсом (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ›› Отслеживание факса (графический интерфейс) ››

Когда вы запускаете утилиту SendFaxMS.exe в режиме графического интерфейса пользователя (GUI) с параметром /Track, вы можете не только следить за отправкой факса, но и управлять заданием факса.

Чтобы просмотреть факс в программе для просмотра TIFF файлов, нажмите Просмотр или воспользуйтесь клавишей F3.

Чтобы удалить факс, нажмите Удалить или воспользуйтесь клавишей Del. Эта команда отменяет текущий процесс отправки факса и прерывает вызов. Факс навсегда удаляется из папки Исходящие или Отправленные.

Чтобы приостановить передачу факса, нажмите Пауза.

Чтобы вывести факс из приостановленного состояния и сделать его вновь доступным для передачи, нажмите Продолжить.

Чтобы повторить передачу факса после неудачной попытки, нажмите Перезапустить.


Отслеживание факса (режим консоли)

Отслеживание факса (режим консоли) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Отправка факса с помощью SendFaxMS.exe - Microsoft Fax ››

При запуске консольной версии утилиты SendFaxMS.exe (SendFaxMS_c.exe) с параметром командной строки /Track, информация о событиях факса (например, какая страница в данный момент передается) выводится непосредственно в консоль. Параметр /Track игнорируется при отправке факса нескольким получателям. Также можно отслеживать ранее созданный факс, запустив утилиту SendFaxMS.exe (SendFaxMS_c.exe) с параметром /JobID=.

По умолчанию процесс отслеживания факса прекращается после успешной отправки факса или после выполнения максимального числа попыток отправить факс, после чего утилита SendFaxMS.exe автоматически завершает работу. Если вы не хотите, чтобы консоль автоматически закрывалась после выполнения, используйте параметр командной строки /DoNotCloseConsole. Вы можете остановить отслеживание факса в любой момент, закрыв окно консоли или нажав комбинацию клавиш Ctrl + C.

Примечания

  • Обратите внимание, что вы не можете управлять заданием факса при запуске утилиты SendFaxMS.exe в режиме консоли.


Электронная почта

Панель управления Fax Voip T.38 Модем ››

  • Факс-на-почту, почта-на-факс и уведомления о доставке
  • Почта-на-факс - Microsoft Fax
  • Параметры SMTP
  • Параметры POP3 / IMAP
  • Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0
  • Шаблоны электронной почты


Факс-на-почту, почта-на-факс и уведомления о доставке

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

Факс-на-почту

Функция Факс-на-почту реализована в Методе маршрутизации: отправить по электронной почте (Microsoft Fax) . В зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), входящий факс может быть отправлен различным e-mail адресатам. Один и тот же входящий факс может быть маршрутизирован одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Формат доставки факса (TIFF, PDF или SFF) может быть выбран индивидуально для каждого правила.

Служба факсов Windows должна быть установлена на вашем компьютере и настроена для приема факсов через модемы Fax Voip. Fax Voip T.38 Модем должен быть настроен для приема факсов с использованием Виртуальных COM портов (модемов). Для использования этого функционала необходимо приобрести лицензию Fax Voip T.38 Модем Виртуальные COM порты (модемы) и (опционально) лицензию Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, сохранить в папке, печать). Подробнее см. Метод маршрутизации: отправить по электронной почте (Microsoft Fax) .

Чтобы настроить Факс-на-почту, вам обычно необходимо создать одно или несколько правил маршрутизации по e-mail , настроить параметры SMTP и отредактировать шаблон электронной почты 'Получен новый факс (служба Microsoft Fax)' (если требуется).

Почта-на-факс

Функция Почта-на-факс - Microsoft Fax позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Служба факсов Windows должна быть установлена на вашем компьютере и настроена для отправки факсов через модемы Fax Voip. Fax Voip T.38 Модем должен быть настроен для отправки факсов с использованием Виртуальных COM портов (модемов). Для использования этой функции необходимо приобрести лицензию Fax Voip T.38 Модем Виртуальные COM порты (модемы).

Чтобы включить и настроить функцию Почта-на-факс - Microsoft Fax, см. главу Почта-на-факс - Microsoft Fax настоящего справочного руководства. Вам необходимо настроить параметры POP3 / IMAP . Чтобы включить уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя, также необходимо настроить параметры SMTP . Вы можете настроить следующие шаблоны электронной почты (если требуется): Факс успешно отправлен (служба Microsoft Fax) , Не удалось отправить факс (служба Microsoft Fax) и Не удалось создать задание факса .

Уведомления о доставке по электронной почте

Уведомления о доставке позволяют сообщать пользователям, был ли доставлен факс или нет. Уведомление по электронной почте направляется на заранее заданный адрес(а) электронной почты и независимо от способа создания факса. Уведомление о доставке может быть отправлено одному или более e-mail получателям. Вы можете использовать поля Кому, Копия и Скрытая копия. Копия отправленного факса может быть прикреплена к сообщению электронной почты в формате TIFF, PDF или SFF. Функционал Уведомления о доставке на e-mail реализован с использованием метода маршрутизации Уведомления о доставке по электронной почте (Microsoft Fax) .

Служба факсов Windows должна быть установлена на вашем компьютере и настроена для отправки факсов через модемы Fax Voip. Fax Voip T.38 Модем должен быть настроен для отправки факсов с использованием Виртуальных COM портов (модемов). Для использования этой функции необходимо приобрести лицензию Fax Voip T.38 Модем Виртуальные COM порты (модемы).

Чтобы включить и настроить Уведомления о доставке, вам обычно необходимо создать одно или несколько правил метода “Уведомления о доставке по электронной почте” . Также необходимо настроить параметры SMTP . Вы можете настроить следующие шаблоны электронной почты (если требуется): Факс успешно отправлен (служба Microsoft Fax) и Не удалось отправить факс (служба Microsoft Fax) .

Используя ссылки на странице, показанной ниже, вы можете быстро перейти к настройке функций, описанных в этой главе.


Конфигурирование почта-на-факс в качестве службы Windows

Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Факс-на-почту, почта-на-факс и уведомления о доставке ››

Приложение Fax Voip T.38 Модем, а также подсистема Почта-на-факс - Microsoft Fax могут быть настроены в качестве службы Windows. Службы могут автоматически запускаться при запуске Windows до входа пользователя в систему. Этот вариант удобен для многопользовательских систем.

Настоятельно рекомендуется запускать почтовую службу Fax Voip T.38 Модем от имени учетной записи пользователя, а не под учетной записью локальной системы или сетевой службы. Пользователь, от имени которого запускается служба, сможет настраивать ассоциации типов файлов (ответственные за правильную печать различных документов), а также просматривать факсы, сгенерированные службой, и управлять ими в приложении Факсы и сканирование Windows (при использовании функции Почта-на-факс - Microsoft Fax ).

Чтобы настроить Почта-на-факс в качестве службы Windows

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Общие параметры.

2. В случае, если Fax Voip T.38 Модем еще не настроен в качестве службы, поставьте флажок Запускать Fax Voip T.38 Модем как службу Windows, а затем нажмите <Применить>. В случае, если Fax Voip T.38 Модем уже настроен в качестве службы, нажмите кнопку Выбрать пользователя. Требуются права администратора.

3. В окне Служба Почта-на-факс, укажите имя пользователя и пароль учетной записи, которая будет использоваться для запуска почтовой службы Fax Voip T.38 Модем. Имя учетной записи должно иметь формат DOMAIN\Username. По умолчанию, Fax Voip T.38 Модем предлагает использовать текущую учетную запись (с правами администратора). Вы должны четко понимать, что ассоциации типов файлов (ответственные за правильную печать различных документов) должны быть настроены под учетной записью указанного пользователя. Также, только указанный пользователь сможет просматривать факсы, сгенерированные службой, и управлять ими в приложении Факсы и сканирование Windows (при использовании функции Почта-на-факс - Microsoft Fax ). По причинам, указанным выше, не следует запускать эту службу от имени локальной системы или сетевой службы*. Нажмите OK.

4. После завершения установки убедитесь, что имя выбранной учетной записи отображается в поле Служба Почта-на-факс (через Microsoft Fax) запускается от имени учетной записи, см. рисунок ниже.

Примечания

  • (* : Чтобы запускать службу под учетной записью 'Локальная система', в поле Учетная запись введите LocalSystem (пароль не требуется). Чтобы запускать службу от имени учетной записи 'Сетевая служба', в поле Учетная запись введите NT AUTHORITY\NetworkService (пароль не требуется). Обратите внимание, что запуск почтовой службы Fax Voip T.38 Модем от имени локальной системы или сетевой службы не рекомендован.
  • Учетная запись пользователя, которая будет использоваться для запуска почтовой службы Fax Voip T.38 Модем, должна обладать правами Входа в качестве службы. При установке службы, Fax Voip T.38 Модем принудительно добавляет право Входа в качестве службы для указанной учетной записи. В некоторых системах вы можете проверить и настроить локальную политику Вход в качестве службы используя Редактор локальной групповой политики (gpedit.msc): Политика 'Локальный компьютер' -> Конфигурация компьютера -> Конфигурация Windows -> Параметры безопасности -> Локальные политики -> Назначение прав пользователя, локальная политика Вход в качестве службы.

Чтобы изменить учетную запись пользователя, под которой запускается служба

Предполагается, что Fax Voip T.38 Модем уже настроен для запуска в качестве службы Windows.

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Управление компьютером.

2. В окне Управление компьютером, в левой панели, щелкните дважды Управление компьютером (локальным), щелкните дважды Службы и приложения, щелкните Службы.

3. В правой панели щелкните правой кнопкой мыши по службе Fax Voip T.38 Modem MsFax Mail. В контекстном меню, нажмите Свойства.

4. В окне Свойства: Fax Voip T.38 Modem MsFax Mail (Локальный компьютер), на вкладке Вход в систему, выберите С учетной записью, а затем нажмите Обзор... .

5. В диалоговом окне Выбор: "Пользователь", введите имя учетной записи, а затем нажмите Проверить имена. Нажмите OK.

6. В текстовых полях Пароль и Подтверждение, введите пароль для выбранной учетной записи, а затем нажмите OK.

7. Щелкните правой кнопкой мыши по службе Fax Voip T.38 Modem MsFax Mail. В контекстном меню, нажмите Перезапустить.

Примечания

  • В качестве альтернативы, вы можете воспользоваться кнопкой Выбрать пользователя на странице Общие параметры, в Панели управления Fax Voip T.38 Модем. Затем следуйте процедуре, описанной в начале этой главы, указав желаемую учетную запись пользователя.


Почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

Функция Почта-на-факс позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Функция Почта-на-факс - Microsoft Fax базируется на использовании Fax Service API и отправке факсов через Службу факсов Windows и приложение Факсы и сканирование Windows. Служба факсов Windows должна быть установлена на вашем компьютере. Для использования этого функционала необходимо приобрести лицензию Fax Voip T.38 Модем Виртуальные COM порты (модемы).

Чтобы использовать функцию Почта-на-факс - Microsoft Fax, вы должны:

  • Настроить службу факсов Windows для отправки факсов через модем(ы) Fax Voip. Вы можете использовать команду Настройка факс службы на ленте, см. главу Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства. Выполните настройки правил Маршрутизации исходящих VOIP вызовов , необходимые для отправки факсов через Виртуальные COM порты (модемы). Убедитесь в том, что вы можете вручную отправлять факсы из приложения Факсы и сканирование Windows. Поставьте флажок у параметра Перезапускать службу Microsoft Fax при запуске Fax Voip T.38 Модем (рекомендуется включать в случае если Fax Voip T.38 Модем работает совместно со Службой факсов Windows), см. главу Параметры факса настоящего справочного руководства.
  • Настроить параметры POP3 / IMAP. Убедитесь в корректности сделанных настроек. Воспользуйтесь кнопкой <Тест>. Сохраните ваши настройки.
  • Настроить параметры SMTP. Убедитесь в корректности сделанных настроек. Воспользуйтесь кнопкой <Тест>. Сохраните ваши настройки.
  • Настроить шаблон электронной почты 'Факс успешно отправлен (служба Microsoft Fax)' (если требуется).
  • Настроить шаблон электронной почты 'Не удалось отправить факс (служба Microsoft Fax)' (если требуется).
  • Настроить шаблон электронной почты 'Не удалось создать задание факса' (если требуется).
  • Включить функцию 'Почта-на-факс - Microsoft Fax'.

Чтобы включить функцию Почта-на-факс - Microsoft Fax, настроить типы вложений электронной почты, задать приоритет и время отправки факсов, обратитесь к разделу Параметры почта-на-факс - Microsoft Fax .

Чтобы настроить правила набора номера, обратитесь к разделу Набор номера (почта-на-факс) - Microsoft Fax .

Чтобы настроить уведомления о доставке факса на e-mail отправителя, обратитесь к разделу Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax .

Чтобы использовать титульные страницы факса, обратитесь к разделу Титульные страницы (почта-на-факс) - Microsoft Fax .

Чтобы указать информацию об отправителе факса, которая будет отображаться на титульной странице, обратитесь к разделу Сведения об отправителе (почта-на-факс) - Microsoft Fax .

Чтобы настроить поведение функции Почта-на-факс - Microsoft Fax, в зависимости от адреса электронной почты отправителя, обратитесь к разделу Правила для почты (почта-на-факс) - Microsoft Fax .

Необходимые сведения по отправке факсов из приложения электронной почты можно найти в главе Отправка факсов через e-mail (Microsoft Fax) .

Чтобы настроить подсистему Почта-на-факс для запуска в качестве службы Windows, обратитесь к разделу Конфигурирование почта-на-факс в качестве службы Windows .

Если возникли проблемы, см. главу Устранение неполадок функции почта-на-факс .


Параметры почта-на-факс

Параметры почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

Чтобы включить или отключить функцию Почта-на-факс

Разрешить отправку факсов через электронную почту (служба факсов Windows)

Эта опция позволяет включить или отключить функцию Почта-на-факс - Microsoft Fax. Установите этот флажок, чтобы разрешить отправку факсов через электронную почту. Если Fax Voip T.38 Модем сконфигурирован для работы в качестве Службы Windows, то для изменения данного параметра требуются права администратора.

По умолчанию, функция Почта-на-факс доступна для любого адреса электронной почты. Однако, вы можете разрешить или запретить использование этой функции для одного, нескольких или всех адресов электронной почты с помощью Правил для почты . См. также главу Общие параметры (правило для почты) настоящего справочного руководства.

Типы вложений электронной почты

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Вложения электронной почты (правило для почты) настоящего справочного руководства.

Разрешить любые типы файлов в качестве вложений электронной почты

Если выбрана эта опция, функция Почта-на-факс обрабатывает сообщения электронной почты с любыми вложениями. Обратите внимание, что это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. См. также главу Вложения электронной почты настоящего справочного руководства.

Только указанные расширения файлов

Если выбрана эта опция, функция Почта-на-факс обрабатывает лишь вложения электронной почты с указанными расширениями файлов. Введите расширения файлов в текстовое поле справа. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.

Важность и время отправки факсов

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Время отправки факса (правило для почты) настоящего справочного руководства.

Важность факсов, отправляемых через электронную почту

Укажите приоритет, который следует использовать при отправке факса, сгенерированного функцией Почта-на-факс. Все факсы, имеющие высокую важность, будут отправлены перед факсом, который имеет обычную или низкую важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Отправлять факсы во время действия льготного тарифа

Укажите, следует ли отправлять факсы, сгенерированные функцией Почта-на-факс, во время действия льготного тарифа. На компьютере с Windows Server, время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 (Windows 10, Windows 8.1, Windows 7), время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).

Служба почта-на-факс - Microsoft Fax

Тип запуска

Указывает, каким образом запускается почтовая подсистема (Почта-на-факс) - Приложение или Служба Windows. В случае запуска в качестве службы, также отображается имя учетной записи, под которой запущена служба Fax Voip T.38 Modem MsFax Mail.

Состояние

Указывает, работает ли почтовая подсистема (служба Fax Voip T.38 Modem MsFax Mail).

Настройка служб

Нажмите, чтобы перейти на страницу Общие параметры и протоколы , где вы можете указать, следует ли запускать Fax Voip T.38 Модем в качестве службы Windows или нет, а также указать учетную запись пользователя, под которой следует запускать почтовые службы. См. также главу Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows настоящего справочного руководства.


Набор номера

Набор номера (почта-на-факс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

На этой странице можно указать способ преобразования номера факса.

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Набор номера (правило для почты) настоящего справочного руководства.

Преобразовать номер факса в неканонический формат перед отправкой

Укажите, нужно ли преобразовывать номера факсов в неканонический формат перед тем как создавать задание факса. Если этот флажок не отмечен, номер факса получателя в программе Факсы и сканирование Windows будет отображаться без изменений, в том же формате, в котором он был введен пользователем электронной почты. В этом случае, при использовании номера факса в каноническом формате, используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера.

Простое преобразование (удалить '+', скобки, тире и пробелы)

При использовании этой опции, знак '+', а также все круглые скобки, дефисы и пробелы будут удалены из набираемого номера. Обратите внимание, что эта функция на самом деле не проверяет, действительно ли исходный номер факса имеет канонический формат ("+" в начале номера, и т.д.).

Правило набора

При использовании этой опции, правило набора (TAPI), соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса.

(по умолчанию)

Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено к номеру факса получателя до создания задания факса.

<конкретное правило>

Правило набора, соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса. Обратите внимание, что использование конкретного местоположения не изменяет местоположение по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Добавить префикс

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру факса. Это может быть полезно во многих сценариях. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов . См. описание параметров Если номер начинается с цифр и Удалить цифры... в главе Общие параметры (маршрутизация исходящих VOIP вызовов) настоящего справочного руководства. При использовании этого параметра и номеров факсов в каноническом формате мы рекомендуем также использовать опцию Преобразовать номер факса в неканонический формат перед отправкой.

Использовать исходный номер при отпраке уведомления на e-mail отправителя

При использовании этой опции, исходный номер получателя факса (введенный пользователем электронной почты) будет указан в уведомлении по электронной почте. Если этот флажок не отмечен, будет указан преобразованный номер факса (например, с добавленным префиксом). Эта опция игнорируется, если пользователь электронной почты указывает нескольких получателей факса в одном сообщении электронной почты.

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows.

Набираемый номер

Номер факса, как он будет набираться. Если опция Преобразовать номер факса в неканонический формат перед отправкой не используется, а номер факса получателя имеет канонический формат, то используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Примечания

  • Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .
  • Правила набора номера (TAPI) не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Уведомления о доставке

Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

На этой странице можно указать, следует ли уведомлять отправителя по e-mail об успешной или неудачной доставке факса. Вы можете выбрать формат вложения и указать, как формируются имена файлов.

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.

Нажмите, чтобы настроить шаблоны электронной почты

Нажмите, чтобы перейти на страницу Шаблоны электронной почты и настроить шаблоны электронной почты по умолчанию, которые будут использоваться с функцией Почта-на-факс.

Уведомление о доставке на адрес электронной почты отправителя

Указывает, следует ли отправлять уведомление об успешной или неудачной отправке факса на адрес электронной почты отправителя.

Вкладывать копию отправленного факса в формате

Указывает, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию отправленного факса. Может быть TIFF, PDF либо SFF. Обратите внимание, что эта опция игнорируется в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.). В указанном случае уведомление о доставке всегда отправляется без вложенного факса.

Приведенные ниже опции отвечают за формирование имен файлов для прикрепленных факсов.

Использовать шаблон имени файла по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон имени файла:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с TSID, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Титульные страницы

Титульные страницы (почта-на-факс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Титульные страницы (правило для почты) настоящего справочного руководства.

Укажите сведения об отправителе

Нажмите, чтобы перейти на страницу Сведения об отправителе (почта-на-факс) - Microsoft Fax , где вы можете указать информацию об отправителе по умолчанию для использования с функцией Почта-на-факс.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании функции Почта-на-факс.

Разрешить отправку факсов, состоящих только из титульной страницы

Указывает, можно ли отправлять факсы, состоящие только из титульной страницы, при использовании функции Почта-на-факс.

Использовать стандартный шаблон титульной страницы

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу сохраненную в указанном файле

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip T.38 Модем.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Примечания

  • При использовании функции Почта-на-факс, вы можете указать тему титульной страницы и примечание к титульной странице в основной части вашего сообщения электронной почты. Имя получателя, как и номер факса получателя, можно указать в теме вашего сообщения электронной почты. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (почта-на-факс) настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (почта-на-факс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

На этой странице можно указать информацию об отправителе факса, которая будет отображаться на титульной странице факса в случае использования функции Почта-на-факс. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline).

Приведенные ниже параметры могут быть переопределены в настройках Правил для почты , см. главу Сведения об отправителе (правило для почты) настоящего справочного руководства.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается Fax Voip T.38 Модем (служба Fax Voip T.38 Modem MsFax Mail).

Использовать нижеследующую информацию об отправителе

Если выбрана эта опция, функция Почта-на-факс использует сведения об отправителе, указанные ниже.

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • При использовании функции Почта-на-факс - Microsoft Fax , адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты. Адрес e-mail, указанный в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...) игнорируется.
  • Если вы указываете адрес e-mail в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...), а затем отправляете факс обычным способом (из программного обеспечения Факсы и сканирование Windows), и при этом функция Почта-на-факс - Microsoft Fax активна, то факс будет обработан системой Почта-на-факс и уведомление об успешной или неудачной доставке факса будет отправлено на указанный адрес электронной почты. Чтобы избежать отправки сообщения e-mail в этом случае, вам следует создать правило для почты для указанного адреса электронной почты и отключить отправку уведомлений для этого правила, см. главу Уведомления о доставке (правило для почты) настоящего справочного руководства.


Правила для почты

Правила для почты (почта-на-факс) - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

Так называемые Правила для почты позволяют настроить поведение функции Почта-на-факс - Microsoft Fax в зависимости от адреса электронной почты отправителя. Максимальное поддерживаемое количество Правил для почты не ограничено.

Fax Voip T.38 Модем всегда проверяет Правила для почты, начиная с правила # 1. Сообщения e-mail обрабатываются согласно первому правилу, для которого адрес электронной почты соответствует заданному шаблону. Все остальные правила игнорируются. Например, если правило # 1 применяется для любого адреса электронной почты ('Электронная почта' = *@*), то все остальные правила # 2, # 3, и т.д. никогда не выполнятся ни при каких условиях. Если не существует ни одного правила, которое соответствует адресу электронной почты отправителя, будут применяться параметры почта-на-факс , заданные по умолчанию.

Правило может применяться к:

  • одному адресу электронной почты
  • группе адресов электронной почты с указанной доменной частью
  • любому адресу электронной почты

Существует два типа правил:

  • Разрешить. Правила, которые позволяют использовать функционал Почта-на-факс для указанного адреса (адресов) электронной почты.
  • Запретить. Правила, которые запрещают использовать функционал Почта-на-факс для указанного адреса (адресов) электронной почты.

Следующие параметры почта-на-факс могут быть установлены или переопределены с помощью правила для почты:

  • Правила набора номера
  • Уведомление о доставке на адрес электронной почты отправителя
  • Типы файлов, которые можно использовать в качестве вложений электронной почты
  • Титульные страницы
  • Сведения об отправителе
  • Важность и время отправки факсов
  • Шаблоны электронной почты : Факс успешно отправлен (служба Microsoft Fax) , Не удалось отправить факс (служба Microsoft Fax) , Не удалось создать задание факса

Таблица Правила для почты (Почта-на-факс) - Microsoft Fax содержит следующую информацию:

Правило

Уникальный номер текущего правила.

Электронная почта

Шаблон адреса электронной почты, для которого применяется текущее правило.

Разрешить

Тип правила. Разрешает или запрещает использование функционала Почта-на-факс для указанного адреса (адресов) электронной почты.

Набор номера

Указывает, используются ли для правил набора номера пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Уведомления

Указывает, используются ли для уведомлений о доставке факса пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Вложения

Указывает, используются ли для вложений электронной почты пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Титульные страницы

Указывает, используются ли для титульных страниц пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Сведения об отправителе

Указывает, используются ли для сведений об отправителе пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Время отправки

Указывает, используются ли для важности и времени отправки факсов пользовательские настройки, или же настройки функции Почта-на-факс по умолчанию.

Шаблоны e-mail

Указывает, используются ли для шаблонов электронной почты пользовательские настройки, или же настройки по умолчанию.

В контекстной вкладке Почта-на-факс, на ленте доступны следующие команды:

Правила для почты

Добавить (Ctrl + N)

Нажмите чтобы добавить новое правило для почты.

Копировать (Ctrl + C)

Нажмите чтобы создать копию выбранного правила для почты. Может быть полезно при создании большого количества схожих правил. Чтобы отредактировать вновь созданное правило, выберите его и воспользуйтесь командой Править.

Править (Ctrl + E)

Нажмите для изменения существующего правила для почты. Одна из записей должна быть выделена. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите для удаления одного или более правила для почты. Удаляемые записи должны быть выделены.

Удалить (Del)

Нажмите для удаления одного или более правила для почты. Удаляемые записи должны быть выделены.

Удалить все правила

Нажмите чтобы удалить все правила в списке.

Переместить

Используйте команды ниже чтобы изменить порядок предпочтений различных правил для почты. Одно из правил должно быть выделено.

Вверх (Ctrl + U)

Переместить выбранное правило вверх.

Вниз (Ctrl + D)

Переместить выбранное правило вниз.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Большинство команд из контекстной вкладки Почта-на-факс также доступны в контекстном меню списка.


Добавление или изменение правил

Добавление или изменение правил почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс (MS Fax), затем нажмите Правила для почты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Почта-на-факс, на вкладке Общие, укажите адрес электронной почты, для которого применяется данное правило. Чтобы выбрать адрес электронной почты из адресной книги (контакты Windows), нажмите кнопку Адресная книга. Выберите тип правила: Разрешить или Запретить. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Общие параметры .

5. Перейдите на вкладку Набор номера.

6. На вкладке Набор номера, укажите, следует ли для правил набора номера использовать пользовательские настройки или настройки по умолчанию. Укажите, нужно ли преобразовывать номер факса в неканонический формат перед тем как создавать задание факса. Укажите, следует ли добавлять префикс перед номером. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Набор номера .

7. Перейдите на вкладку Уведомления.

8. На вкладке Уведомления, укажите, следует ли для уведомлений о доставке факса использовать пользовательские настройки или настройки по умолчанию. Укажите, следует ли уведомлять отправителя об успешной или неудачной доставке факса по электронной почте. Выберите формат для прикрепленных факсов, TIFF, PDF или SFF. Укажите, как формируются имена файлов. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Уведомления о доставке .

9. Перейдите на вкладку Вложения.

10. На вкладке Вложения, укажите, следует ли для вложений электронной почты использовать пользовательские настройки или настройки по умолчанию. Укажите, может ли пользователь использовать любые типы вложений электронной почты или только файлы с указанными расширениями. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Вложения электронной почты .

11. Перейдите на вкладку Титульные страницы.

12. На вкладке Титульные страницы, укажите, следует ли для титульных страниц факсов использовать пользовательские настройки или настройки по умолчанию. Выберите общий или личный шаблон титульной страницы, который будет использоваться. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Титульные страницы .

13. Перейдите на вкладку Отправитель.

14. На вкладке Отправитель, укажите, следует ли для сведений об отправителе использовать пользовательские настройки или настройки по умолчанию. Чтобы импортировать сведения об отправителе для заданного адреса электронной почты из адресной книги (контакты Windows), нажмите кнопку Адресная книга. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Сведения об отправителе .

15. Перейдите на вкладку Время отправки.

16. На вкладке Время отправки, укажите, следует ли для важности и времени отправки факсов использовать пользовательские настройки или настройки по умолчанию. Задайте приоритет. Укажите, следует ли отправлять факсы во время действия льготного тарифа. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Время отправки факса .

17. Перейдите на вкладку Шаблоны.

18. На вкладке Шаблоны, укажите, следует ли для шаблонов электронной почты использовать пользовательские настройки или настройки по умолчанию. Настройте шаблоны электронной почты, которые будут использоваться с этим правилом. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Шаблоны электронной почты .

19. Нажмите кнопку <OK> чтобы зафиксировать изменения.

20. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

21. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Правил для почты. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Управление правилами

Управление правилами почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс (MS Fax), затем нажмите Правила для почты.

3. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

4. Для удаления одного или более правил, выделите правило и затем нажмите Удалить.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.


Параметры правил для почты

Параметры правил почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ››

Этот раздел содержит информацию о параметрах, которые настраиваются в окне правила Почта-на-факс.

  • Общие параметры
  • Набор номера
  • Уведомления о доставке
  • Вложения электронной почты
  • Титульные страницы
  • Сведения об отправителе
  • Время отправки факса
  • Шаблоны электронной почты


Общие параметры

Общие параметры (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Общие параметры

Адрес электронной почты

В этой области необходимо задать шаблон адреса электронной почты, для которого применяется текущее правило. Правило может применяться к одному адресу электронной почты, группе адресов электронной почты с указанной доменной частью или ко всем адресам электронной почты.

E-mail адрес

Если выбрана эта опция, правило применяется к одному адресу электронной почты.

<Адресная книга>

Нажмите, чтобы выбрать адрес электронной почты из адресной книги (контакты Windows). Эта опция также позволяет импортировать из адресной книги сведения об отправителе для выбранного контакта.

Группа e-mail

Если выбрана эта опция, правило применяется к группе адресов электронной почты с указанной доменной частью.

Любой адрес электронной почты

Если выбрана эта опция, правило применяется ко всем адресам электронной почты.

Тип правила

В этой области необходимо задать тип правила. Правило может разрешать или запрещать использование функционала Почта-на-факс для указанного адреса (адресов) электронной почты.

Разрешить

Если выбрана эта опция, функция Почта-на-факс обрабатывает электронные письма с указанного адреса (адресов) электронной почты.

Запретить

Если выбрана эта опция, функция Почта-на-факс не обрабатывает электронные письма с указанного адреса (адресов) электронной почты.


Набор номера

Набор номера (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Набор номера

На этой вкладке вы можете переопределить настройки по умолчанию для правил набора номера, см. главу Набор номера (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для правил набора номера.

Преобразовать номер факса в неканонический формат

Укажите, нужно ли преобразовывать номера факсов в неканонический формат перед тем как создавать задание факса. Если этот флажок не отмечен, номер факса получателя в программе Факсы и сканирование Windows будет отображаться без изменений, в том же формате, в котором он был введен пользователем электронной почты. В этом случае, при использовании номера факса в каноническом формате, используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера.

Простое преобразование (удалить '+', скобки, тире и пробелы)

При использовании этой опции, знак '+', а также все круглые скобки, дефисы и пробелы будут удалены из набираемого номера. Обратите внимание, что эта функция на самом деле не проверяет, действительно ли исходный номер факса имеет канонический формат ("+" в начале номера, и т.д.).

Правило набора

При использовании этой опции, правило набора (TAPI), соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса.

(по умолчанию)

Используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено к номеру факса получателя до создания задания факса.

<конкретное правило>

Правило набора, соответствующее местоположению, выбранному в поле со списком, будет применено к номеру факса получателя до создания задания факса. Обратите внимание, что использование конкретного местоположения не изменяет местоположение по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows.

Новое правило...

Выберите эту опцию, чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

<Настроить правила>

Нажмите чтобы настроить правила набора номера (диалоговое окно Телефон и модем в панели управления Windows). Подробнее см. Общие сведения о правилах набора номера .

Имя расположения

Имя местоположения, которое используется для преобразования номера.

Страна или регион

Страна или регион, связанный с используемым местоположением.

Код города

Код города, связанный с используемым местоположением.

Добавить префикс

Используйте эту опцию чтобы добавить заданный префикс к набираемому номеру факса. Это может быть полезно во многих сценариях. В частности, это можно использовать для маршрутизации факсов от различных пользователей электронной почты через разные учетные записи SIP. Указанный префикс можно затем удалить, применив правила маршрутизации исходящих VOIP вызовов . См. описание параметров Если номер начинается с цифр и Удалить цифры... в главе Общие параметры (маршрутизация исходящих VOIP вызовов) настоящего справочного руководства. При использовании этого параметра и номеров факсов в каноническом формате мы рекомендуем также использовать опцию Преобразовать номер факса в неканонический формат.

Использовать исходный номер при отпраке уведомления

При использовании этой опции, исходный номер получателя факса (введенный пользователем электронной почты) будет указан в уведомлении по электронной почте. Если этот флажок не отмечен, будет указан преобразованный номер факса (например, с добавленным префиксом). Эта опция игнорируется, если пользователь электронной почты указывает нескольких получателей факса в одном сообщении электронной почты.

Номер факса

В этом поле можно ввести номер факса, чтобы увидеть, как он будет набираться и как он будет отображаться в программе Факсы и сканирование Windows.

Отображаемый номер

Номер факса получателя, отображаемый в программе Факсы и сканирование Windows.

Набираемый номер

Номер факса, как он будет набираться. Если опция Преобразовать номер факса в неканонический формат не используется, а номер факса получателя имеет канонический формат, то используемое по умолчанию правило набора (соответствует местоположению, выбранному в диалоговом окне Телефон и модем в панели управления Windows) будет применено в момент набора номера. Сообщение об ошибке обычно указывает, что исходный номер факса имеет неправильный формат.

Страна

Страна или регион назначения, связанный с преобразуемым номером факса.

Примечания

  • Правила набора номера, предоставляемые TAPI, не всегда соответствуют правилам набора номера, которые требуются в сети вашего провайдера IP-телефонии. Для дополнительного преобразования номера факса используйте правила маршрутизации исходящих VOIP вызовов .
  • Правила набора номера (TAPI) не применяются при использовании номеров факсов в неканоническом формате.
  • Дополнительные сведения об использовании правил набора см. в главе Общие сведения о правилах набора номера настоящего справочного руководства.


Уведомления о доставке

Уведомления о доставке (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Уведомления о доставке

На этой вкладке вы можете переопределить настройки по умолчанию для уведомлений о доставке факса, см. главу Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для уведомлений о доставке факса.

Нажмите, чтобы настроить шаблоны электронной почты

Нажмите, чтобы перейти на вкладку Шаблоны .

Уведомление о доставке

В этой области вы можете указать пользовательские настройки для уведомлений о доставке факса, которые будут применяться только к текущему правилу.

Уведомление о доставке на адрес электронной почты отправителя

Указывает, следует ли отправлять уведомление об успешной или неудачной отправке факса на адрес электронной почты отправителя.

Вкладывать копию отправленного факса в формате

Указывает, следует ли прикреплять копию отправленного факса к сообщению электронной почты. Выберите формат файла, в котором вы хотите получить копию отправленного факса. Может быть TIFF, PDF либо SFF. Обратите внимание, что эта опция игнорируется в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный документ в факс, указан некорректный номер факса, адрес электронной почты заблокирован и т.д.). В указанном случае уведомление о доставке всегда отправляется без вложенного факса.

Приведенные ниже опции отвечают за формирование имен файлов для прикрепленных факсов.

Использовать шаблон имени файла по умолчанию (FAX...)

Выберите эту опцию, чтобы использовать шаблон имени файла по умолчанию для текущего правила. Если указан шаблон имени файла по умолчанию, имя вложения факса - FAX.tif, FAX.pdf или FAX.sff (в зависимости от выбранного формата).

Использовать пользовательский шаблон имени файла:

Выберите эту опцию, чтобы указать пользовательский шаблон имени файла в текстовом поле ниже. Шаблон имени файла может содержать произвольный текст и так называемые %переменные%, которые заменяются фактическими данными (например, %RecipientFaxNumber%, %StartTime%, %PagesTransferred% и т.д.). Шаблон имени файла не может содержать следующие знаки: \ / : * ? " < > | ; Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени) отображается ниже в поле Пример.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее, в котором задается пользовательский шаблон имени файла. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню.

В пользовательском шаблоне имени файла можно использовать следующие переменные (заменяются фактическими данными):

      • %RecipientFaxNumber%. Номер факса получателя.
      • %RecipientName%. Имя получателя.
      • %DocumentName%. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются запятыми. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
      • %Subject%. Содержит тему факса (отображается на титульной странице).
      • %PagesTotal%. Общее количество страниц в факсимильном сообщении.
      • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
      • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с TSID, указанном в сведениях об отправителе , либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
      • %SubmissionTime%. Время формирования задания факса.
      • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
      • %StartTime%. Время начала передачи факса.
      • %EndTime%. Время окончания передачи факса.
      • %Duration%. Продолжительность передачи факса.
      • %Retries%. В случае успешно отправленного факса, число предпринятых системой неудачных попыток отправить факс. В случае неудачной отправки факса, число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
      • %PagesTransferred%. Число успешно переданных страниц факса.
      • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
      • %Status%. Результат отправки факса. Примеры: OK (в случае успешной отправки факса), NO_ANSWER, BUSY.
      • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса.

Формат

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона имени файла. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

Дата

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует дате. Выберите формат даты из раскрывающегося списка. Доступные форматы даты определяются выбранным региональным стандартом (регион и язык). Символы косой черты ' / ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования даты для текущего выбора отображается справа в поле Пример.

Время

Установите этот флажок, чтобы использовать часть значения DateTime, которая соответствует времени. Выберите формат времени из раскрывающегося списка. Доступные форматы времени определяются выбранным региональным стандартом (регион и язык). Символы двоеточия ' : ', которые нельзя использовать в именах файлов, заменяются черточками ' - '. Пример форматирования времени для текущего выбора отображается справа в поле Пример.

Пример

Пример имени файла для текущего шаблона (с учетом выбранных форматов даты и времени, а также выбранного формата факса).

Примечания

  • При использовании метода CDO.Message для отправки сообщений e-mail (подробнее см. в главе Параметры SMTP ) и наличии символов юникода в имени прикрепленного файла (обычно при использовании нестандартной локали для форматирования даты и времени), эти символы могут заменяться подчеркиванием ' _ '. Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.


Вложения электронной почты

Вложения электронной почты (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Вложения электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для вложений электронной почты, заданные в параметрах почта-на-факс .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для вложений электронной почты.

Типы вложений электронной почты

В этой области вы можете указать пользовательские настройки для вложений электронной почты, которые будут применяться только к текущему правилу.

Разрешить любые типы файлов в качестве вложений электронной почты

Если выбрана эта опция, функция Почта-на-факс обрабатывает сообщения электронной почты с любыми вложениями. Обратите внимание, что это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. См. также главу Вложения электронной почты настоящего справочного руководства.

Только указанные расширения файлов

Если выбрана эта опция, функция Почта-на-факс обрабатывает лишь вложения электронной почты с указанными расширениями файлов. Введите расширения файлов в текстовое поле ниже. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.


Титульные страницы

Титульные страницы (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Титульные страницы

На этой вкладке вы можете переопределить настройки по умолчанию для титульных страниц факсов, см. главу Титульные страницы (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для титульных страниц.

Нажмите, чтобы указать сведения об отправителе

Нажмите, чтобы перейти на вкладку Отправитель .

Титульные страницы

В этой области вы можете указать пользовательские настройки для титульных страниц факсов, которые будут применяться только к текущему правилу.

Прикреплять титульную страницу к факсу

Указывает, будет ли титульная страница добавлена к документу и отправлена в качестве первой страницы факса, при использовании функции Почта-на-факс.

Разрешить отправку факсов, состоящих только из титульной страницы

Указывает, можно ли отправлять факсы, состоящие только из титульной страницы, при использовании функции Почта-на-факс.

Использовать стандартный шаблон

Если выбрана эта опция, будет использоваться один из общих шаблонов титульных страниц, предоставляемых факс сервером. Вы можете выбрать один из следующих стандартных шаблонов: Секретно, К сведению, Универсальный и Срочно. Файлы с шаблонами общих титульных страниц обычно хранятся в следующей папке: C:\ProgramData\Microsoft\Windows NT\MSFax\Common Coverpages.

Использовать личную титульную страницу из указанного файла

Если выбрана эта опция, будет использоваться указанный шаблон личной титульной страницы, хранящийся в файле на локальном компьютере. Чтобы выбрать нужный шаблон титульной страницы, нажмите на кнопку справа от текстового поля. Файлы личных титульных страниц обычно хранятся в папке Личные титульные страницы: C:\Users\<Account Name>\Documents\Fax\Personal CoverPages, однако вы можете сохранить свой шаблон титульной страницы в любой другой папке на своем жестком диске, а затем указать путь к нему в настройках Fax Voip T.38 Модем.

<Создать...>

Нажмите, чтобы создать новый шаблон личной титульной страницы, используя приложение Редактор титульных страниц факсов. По умолчанию новый шаблон сохраняется в папке Личные титульные страницы (Personal CoverPages). Кроме того, вы можете создавать ваши личные титульные страницы и управлять ими из программного обеспечения Факсы и сканирование Windows (Сервис -> Титульные страницы... ).

<Открыть...>

Нажмите, чтобы открыть выбранный шаблон титульной страницы в приложении Редактор титульных страниц факсов.

Примечания

  • При использовании функции Почта-на-факс, вы можете указать тему титульной страницы и примечание к титульной странице в основной части вашего сообщения электронной почты. Имя получателя, как и номер факса получателя, можно указать в теме вашего сообщения электронной почты. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Чтобы указать сведения об отправителе, которые обычно отображаются на титульных страницах, см. главу Сведения об отправителе (правило для почты) настоящего справочного руководства.


Сведения об отправителе

Сведения об отправителе (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Сведения об отправителе

Информация об отправителе отображается на титульных страницах. Идентификатор факса (TSID) передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Имя Организации и Идентификатор факса (TSID) также отображаются в верхней части каждой страницы отправляемого факса (Fax Headline).

На этой вкладке вы можете переопределить настройки по умолчанию для информации об отправителе, см. главу Сведения об отправителе (почта-на-факс) .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для информации об отправителе.

Сведения об отправителе

В этой области вы можете указать пользовательские настройки для информации об отправителе, которые будут применяться только к текущему правилу.

Использовать информацию об отправителе, заданную по умолчанию

Если выбрана эта опция, используются сведения об отправителе по умолчанию, заданные в программе Факсы и сканирование Windows (Сервис -> Сведения об отправителе...). Вы должны понимать, что сведения об отправителе по умолчанию зависят от учетной записи пользователя, под которой запускается Fax Voip T.38 Модем (служба Fax Voip T.38 Modem MsFax Mail).

Использовать нижеследующие данные

Если выбрана эта опция, функция Почта-на-факс использует сведения об отправителе, указанные ниже.

<Адресная книга...>

Нажмите, чтобы импортировать сведения об отправителе для заданного адреса электронной почты из адресной книги (контакты Windows).

Полное имя

Имя отправителя.

Номер факса

Номер факса отправителя.

Должность

Должность отправителя.

Организация

Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline). Заголовок факса может содержать до 50 символов текста.

Комната

Номер офиса (комнаты) отправителя.

Отдел

Имя отдела отправителя.

Телефон (дом.)

Номер домашнего телефона отправителя.

Телефон (раб.)

Номер рабочего телефона отправителя.

Адрес

Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.

Идентификатор факса (TSID)

Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя. Передается на оборудование получателя при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста. Обратите внимание, что в зависимости от настроек факс сервера, этот параметр может не учитываться; при этом передается TSID указанный в настройках факс устройства, которое используется для передачи факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Код оплаты

Код биллинга, связанный с отправителем.

Примечания

  • При использовании функции Почта-на-факс - Microsoft Fax , адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты. Адрес e-mail, указанный в настройках программы Факсы и сканирование Windows (Сервис -> Сведения об отправителе...) игнорируется.


Время отправки факса

Время отправки факса (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Время отправки факса

На этой вкладке вы можете переопределить настройки по умолчанию для важности и времени отправки факсов, заданные в параметрах почта-на-факс .

Использовать настройки Почта-на-факс по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для важности и времени отправки факсов.

Важность и время отправки факсов

В этой области вы можете указать пользовательские настройки для важности и времени отправки факсов, которые будут применяться только к текущему правилу.

Важность факсов

Укажите приоритет, который следует использовать при отправке факса. Все факсы, имеющие высокую важность, будут отправлены перед факсом, который имеет обычную или низкую важность. Все факсы, имеющие обычную важность, будут отправлены перед факсом, который имеет низкую важность. По умолчанию факсы имеют обычную важность.

Отправлять факсы во время действия льготного тарифа

Укажите, следует ли отправлять факсы во время действия льготного тарифа. На компьютере с Windows Server, время действия льготного тарифа можно настроить в Диспетчере службы факса Microsoft (Факс (Локальный) -> Свойства -> Исходящие). На компьютере с Windows 11 (Windows 10, Windows 8.1, Windows 7), время действия льготного тарифа настраивается в приложении Факсы и сканирование Windows (Сервис -> Параметры факса -> Дополнительно).


Шаблоны электронной почты

Шаблоны электронной почты (правило для почты, Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Правила для почты ›› Параметры правил для почты ››

Шаблоны электронной почты

На этой вкладке вы можете переопределить настройки по умолчанию для шаблонов электронной почты, см. главу Шаблоны электронной почты настоящего справочного руководства.

Использовать настройки шаблонов электронной почты по умолчанию

Если выбрана эта опция, используются настройки по умолчанию для шаблонов электронной почты.

Шаблоны электронной почты

В этой области вы можете указать пользовательские настройки для шаблонов электронной почты, которые будут применяться только к текущему правилу.

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить. Следующие шаблоны доступны для редактирования: Факс успешно отправлен (служба Microsoft Fax), Не удалось отправить факс (служба Microsoft Fax), Не удалось создать задание факса.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон. В этом случае будет использован шаблон электронной почты, встроенный в программный код.

Чтобы настроить выбранный шаблон, см. примечания ниже.

Примечания

  • Для получения дополнительной информации по настройке шаблона Факс успешно отправлен (служба Microsoft Fax), см. Шаблоны электронной почты: Факс успешно отправлен (служба Microsoft Fax) . Настройки шаблона на вкладке правила для почты делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось отправить факс (служба Microsoft Fax), см. Шаблоны электронной почты: Не удалось отправить факс (служба Microsoft Fax) . Настройки шаблона на вкладке правила для почты делаются аналогично.
  • Для получения дополнительной информации по настройке шаблона Не удалось создать задание факса, см. Шаблоны электронной почты: Не удалось создать задание факса . Настройки шаблона на вкладке правила для почты делаются аналогично.


Отправка факсов через e-mail

Отправка факсов через e-mail (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

Данный раздел содержит необходимые сведения по использованию функции Почта-на-факс - Microsoft Fax .

Чтобы отправить факс из приложения электронной почты, обратитесь к разделу Создание сообщения электронной почты .

Чтобы отправить факс с титульной страницей, обратитесь к разделу Отправка титульных страниц .

Поддерживаемые форматы вложений электронной почты обсуждаются в главе Вложения электронной почты .

Чтобы использовать файлы PDF в качестве вложений электронной почты, обратитесь к разделу Использование PDF файлов в качестве вложений электронной почты .

Для настройки списка пользователей электронной почты, которые могут использовать функцию Почта-на-факс, обратитесь к разделу Блокирование нежелательных адресов электронной почты .

E-mail уведомления об успешной или неудачной доставке факса обсуждаются в главе Уведомление на e-mail о результатах отправки факса .

Необходимые сведения по использованию функции Почта-на-факс в качестве службы Windows можно найти в главе Почта-на-факс в качестве службы Windows .


Создание сообщения e-mail

Создание сообщения электронной почты (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

Для отправки факса из приложения электронной почты, необходимо создать письмо, содержащее следующие обязательные элементы:

  • Кому: Адрес электронной почты, ассоциированный с Fax Voip T.38 Модем, в соответствии с Параметрами POP3 / IMAP (например, faxserver@t38faxvoip.com).
  • Тема: Используется для задания номера факса получателя (например, 74997056352). Вы можете указать не только Номер факса получателя, но также Имя получателя (например, 78126104066<Козлов Евгений Иванович>). Можно указать несколько получателей, которые должны быть разделены точкой с запятой (например, 74997056352;78126104066<Козлов Евгений Иванович>). Имя получателя обычно отображается на титульной странице факса, см. также главу Отправка титульных страниц настоящего справочного руководства.
  • Текст сообщения. Вы можете оставить это поле пустым. Опционально, в основной части вашего сообщения электронной почты можно указать тему титульной страницы и примечание к титульной странице. Подробнее см. в главе Отправка титульных страниц настоящего справочного руководства.
  • Вложение. Фактическое содержимое факса берется из вложения вашего сообщения электронной почты. Вы можете присоединить один или несколько файлов, которые будут объединены в одно факсимильное сообщение. Поддерживаемые форматы файлов, которые можно преобразовать в факс, обсуждаются в главе Вложения электронной почты . В случае отправки факса, состоящего только из титульной страницы, вы не должны прикреплять файлы к сообщению e-mail.


Отправка титульных страниц

Отправка титульных страниц (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

Функция Почта-на-факс - Microsoft Fax позволяет использовать титульные страницы при отправке факса из приложения электронной почты. Титульная страница содержит введенные пользователем данные об отправителе и получателе факса, часто сопровождаемые коротким сообщением, а также системные сведения, такие как дата и время передачи.

Чтобы задать шаблон общей или личной титульной страницы, который будет использоваться, см. главу Титульные страницы (почта-на-факс) . Параметр Прикреплять титульную страницу к факсу отвечает за добавление титульной страницы в документ факса. Параметр Разрешить отправку факсов, состоящих только из титульной страницы позволяет отправлять одностраничные факсы, при этом само сообщение включается в качестве примечания к титульной странице. Настройки для титульных страниц могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. также Титульные страницы (правило для почты) .

Чтобы указать информацию об отправителе, которая будет отображаться на титульных страницах, см. главу Сведения об отправителе (почта-на-факс) . Информация об отправителе может быть персонализирована в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. также Сведения об отправителе (правило для почты) . Обратите внимание, что адрес электронной почты, связанный с отправителем, который также может отображаться на титульной странице факса, принудительно извлекается из сообщения электронной почты.

Имя получателя, как и Номер факса получателя, должны быть указаны в теме вашего сообщения электронной почты, см. рисунок ниже.

Тема титульной страницы и примечание к титульной странице должны быть включены в основную часть вашего сообщения электронной почты. Строка, содержащая тему титульной страницы, должна быть заключена в квадратные скобки и помещена над текстом, который содержит примечание к титульной странице. Пустые строки в начале текста, а также между темой и примечанием игнорируются. На рисунке ниже показано, как создать сообщение электронной почты.

На рисунке ниже показано как выглядит отправленная титульная страница.


Вложения электронной почты

Вложения электронной почты (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

При использовании функции Почта-на-факс - Microsoft Fax , фактическое содержимое факса берется из вложения вашего сообщения электронной почты. Вы можете присоединить один или несколько файлов, которые будут объединены в одно факсимильное сообщение.

По умолчанию, Fax Voip T.38 Модем не налагает никаких ограничений на типы вложений, которые вы можете использовать. К сожалению, это никоим образом не гарантирует, что ваш документ будет правильно преобразован и отправлен по факсу. Чтобы избежать нежелательных проблем, пожалуйста, протестируйте работу функции Почта-на-факс с различными типами вложений на вашем компьютере, настройте вашу операционную систему (если необходимо), а затем, в настройках Fax Voip T.38 Модем, укажите расширения файлов, которые будут использоваться с функцией Почта-на-факс. Приведенная ниже информация поможет вам настроить вашу систему.

Ваш документ (вложение электронной почты) может быть преобразован в факс двумя различными способами:

  • С помощью функции Прямой конвертации в факс .
  • Печать в фоновом режиме (функция printto) с использованием стандартного принтера Fax, включенного в программное обеспечение службы факсов Windows.

Прямая конвертация в факс

Функция Прямой конвертации в факс позволяет конвертировать некоторые из наиболее популярных графических форматов файлов в совместимый формат факса (TIFF). Установка приложения, которое ассоциируется в системе с требуемым расширением файла, не требуется. Поддерживаемые расширения файлов: *.PDF, *.TIF, *.TIFF, *.SFF, *.QFX, *.BMP, *.JPG, *.JPEG, *.GIF, *.PNG, *.ICO, *.WMF, *.EMF. Чтобы использовать функцию Прямой конвертации в факс для указанного типа вложения электронной почты, отметьте соответствующее расширение файла в Панели управления Fax Voip T.38 Модем (Факс -> Конвертация в факс), подробности см. в главе Параметры конвертации в факс настоящего справочного руководства.

Печать в фоновом режиме

Если Прямая конвертация в факс не определена или не выбрана для расширения вашего файла (вложения электронной почты), функция Почта-на-факс пытается распечатать документ в фоновом режиме с помощью принтера Fax. Приложение, которое ассоциируется в системе с требуемым расширением файла, должно быть установлено и зарегистрировано на вашем компьютере. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Например, для печати текстового документа (*.txt) обычно используется Блокнот (notepad.exe). Для печати файлов различных графических форматов как правило используется системная библиотека shimgvw.dll либо приложение Paint. Для печати файлов с расширениями .doc и .rtf требуется установка Microsoft Word.

Теоретически любой файл, который может быть напечатан, может использоваться как вложение электронной почты. Однако не все так хорошо, как хотелось бы. Например, при печати с помощью приложения Microsoft Word (*.doc, *.rtf), печать осуществляется в обычном, а не в фоновом режиме. Ассоциированное приложение может выводить различные окна при печати, что требует действий со стороны пользователя и делает автоматическую печать документа невозможной. Некоторые типы файлов, которые нормально печатаются из открытого приложения, могут не поддерживать фоновую печать. Иными словами, ситуация с использованием функции printto для различных типов файлов сильно зависит от конкретного компьютера и установленных на нем приложений.

Правильное функционирование printto может быть легко исправлено для следующих расширений файлов: *.TXT, *.BMP, *.DIB, *.EMF, *.GIF, *.ICO, *.JFIF, *.JPE, *.JPEG, *.JPG, *.JXR, *.PNG, *.RLE, *.TIF, *.TIFF, *.WDP, *.WMF с помощью опции Исправить команды ‘printto’ в Панели управления Fax Voip T.38 Модем (Факс -> Конвертация в факс), подробности см. в главе Параметры printto настоящего справочного руководства. Для пользователей Windows 11 и Windows 10, см. также Исправление ассоциаций файлов в Windows 11 и Windows 10 .

В случае неудачной печати вашего документа (вложения электронной почты), функция Почта-на-факс пытается использовать Прямую конвертацию в факс (если поддерживается для данного расширения файла).

В случае неудачной печати, вы обычно сталкиваетесь с ошибками двух типов. В первом случае, подсистема Почта-на-факс немедленно возвращает ошибку 'Указанному файлу не сопоставлено ни одно приложение для выполнения данной операции', через уведомление на e-mail. Во втором случае, подсистема Почта-на-факс возвращает ошибку 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Столь длительное время ожидания связано с внутренним таймаутом в методах FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API), это не может быть легко исправлено в нашем приложении. По указанной причине, мы рекомендуем блокировать расширение файла, используя опцию Только указанные расширения файлов (см. ниже) или использовать функцию Прямой конвертации в факс для данного типа файлов (если это возможно).

Чтобы настроить Почта-на-факс для работы только с указанными вложениями электронной почты

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Электронная почта, а затем нажмите Почта-на-факс (MS Fax).

3. Выберите опцию Только указанные расширения файлов. Введите расширения файлов в текстовое поле справа. Расширения файлов должны быть разделены точкой с запятой. Например: .TIF;.PDF;.TXT.

4. Нажмите кнопку <Применить> чтобы сохранить настройки. Не забудьте перезапустить Fax Voip T.38 Модем. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Настройки для вложений электронной почты могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. главу Вложения электронной почты (правило для почты) .

Примечания

  • Мы настоятельно рекомендуем использовать функцию Прямой конвертации в факс , если это возможно для типа файлов, который вы намереваетесь использовать. В случае использования Прямой конвертации в факс, дополнительные тесты и установка приложения, ассоциированного с выбранным типом файла, не требуются.
  • Для исправления команд printto для файлов стандартных графических форматов, используйте функцию Исправить команды ‘printto’. См. главу Параметры Printto настоящего справочного руководства. Для пользователей Windows 11 и Windows 10, см. также главу Исправление ассоциаций файлов в Windows 11 и Windows 10 .
  • Обратите внимание, что в силу дизайна программного обеспечения службы факсов Windows, фоновая печать используется в любом случае. Однако в случае Прямой конвертации в факс , производится печать временного файла TIFF (полученного в результате прямой конвертации), а не оригинального документа (например PDF).


Использование PDF в качестве вложений

Использование PDF файлов в качестве вложений электронной почты (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

Adobe Portable Document Format (PDF) является одним из наиболее популярных форматов при работе с факсами. По этой причине мы вынуждены рассмотреть вопрос о PDF вложениях отдельно. При использовании функции Почта-на-факс, два различных метода могут использоваться при создании факса из оригинального PDF документа:

  • Прямая конвертация в факс вашего документа PDF (рекомендуется).
  • Печать оригинального PDF документа (функция printto) с использованием стандартного принтера Fax, включенного в программное обеспечение службы факсов Windows.

Для использования Прямой конвертации в факс (рекомендуется)

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Факс, затем нажмите Конвертация в факс.

3. В списке Выберите типы файлов к которым применяется прямая конвертация в формат факса, поставьте флажок у типа файла Файл Adobe PDF чтобы применять прямую конвертацию для файлов PDF.

4. Нажмите кнопку <Применить> чтобы сохранить настройки. Не забудьте перезапустить Fax Voip T.38 Модем. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Для печати PDF файлов с помощью printto

Если Прямая конвертация в факс не выбрана для файлов PDF, Fax Voip T.38 Модем автоматически “печатает” файлы PDF, используя стандартную программу, зарегистрированную в вашей системе для просмотра и печати PDF файлов. Обычно таковой является Adobe Acrobat Reader. Начиная с Adobe Reader версии 8, поведение при автоматической печати PDF документов изменилось. Adobe Reader более не закрывает себя после вызова при помощи API функции ShellExecute(printto, ...). В описанной ситуации, файлы PDF не могут использоваться в качестве вложений электронной почты.

Тем не менее, существует решение этой проблемы. Более подробную информацию можно найти на веб-сайте https://www.biopdf.com/ :

https://www.biopdf.com/acrowrap/close_adobe_reader.php

Вам необходимо загрузить и установить программу Acrobat Wrapper . При использовании этой утилиты, Adobe Reader будет корректно закрываться после “печати”.

Если вы используете Adobe Reader совместно с функцией Почта-на-факс для обработки сообщений электронной почты, содержащих PDF вложения, следующая информация должна быть принята во внимание:

  • Для автоматического закрытия PDF файлов после печати, последняя версия программы Acrobat Wrapper должна быть установлена и это должно быть сделано после установки программы Adobe Reader.
  • После любых обновлений программы Adobe Reader вы должны переустановить Acrobat Wrapper. В связи с этим, желательно отключить автоматическое обновление Adobe Reader.
  • Описанный метод обычно не работает в случае конфигурирования почта-на-факс в качестве службы Windows , независимо от версий Adobe Reader и Acrobat Wrapper.

Чтобы загрузить и установить Adobe Reader, выполните следующие шаги:

1. Перейдите на web-страницу загрузки программы Adobe Reader .

2. Выберите операционную систему и язык. В поле выбора версии, выберите Reader 11.0 ... for Windows или Reader DC 202X.X.X ... for Windows. Мы бы рекомендовали вам снять галочки с опций установки McAfee и Chrome Extension, не ясно, нужны ли вам эти дополнительные приложения.

3. Нажмите Загрузить сейчас и следуйте инструкциям установки.

Примечания

  • Все проблемы, ассоциированные с функцией 'печати PDF файлов с помощью printto', не могут рассматриваться как ошибки в программе Fax Voip T.38 Модем. Рекомендации, содержащиеся в этой главе, даны 'КАК ЕСТЬ' и любые претензии, связанные с работой данной функции, не будут рассматриваться нашей службой поддержки.
  • Для решения проблем, иногда возникающих в результате неуспешных тестов, следуйте инструкциям в главе Устранение неполадок функции почта-на-факс настоящего справочного руководства.


Блокирование нежелательных e-mail

Блокирование нежелательных адресов электронной почты (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

По умолчанию, функция Почта-на-факс - Microsoft Fax обрабатывает электронные письма, полученные с любых адресов электронной почты. Это не очень хорошая практика, так как любой, кто знает адрес электронной почты, связанный с Fax Voip T.38 Модем, может несанкционированно отправить факс. Чтобы этого избежать, мы настоятельно рекомендуем настроить список пользователей электронной почты, которым разрешено использовать функцию Почта-на-факс. Эта задача может быть легко решена с помощью Правил для почты .

Чтобы заблокировать адрес электронной почты

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Электронная почта, затем нажмите Почта-на-факс (MS Fax), затем нажмите Правила для почты.

3. Для добавления нового правила, нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила Почта-на-факс, на вкладке Общие, укажите адрес электронной почты, для которого применяется данное правило, либо выберите адрес электронной почты из адресной книги (контакты Windows), нажав кнопку Адресная книга. Чтобы применить правило к группе адресов электронной почты, выберите опцию Группа e-mail и укажите доменную часть адреса электронной почты (например, gmail.com). Чтобы применить правило ко всем адресам электронной почты, выберите опцию Любой адрес электронной почты. В области Укажите тип правила, выберите Запретить. Более подробную информацию можно найти в главе Параметры правил для почты , в разделе Общие параметры .

5. Вы также можете отключить уведомления о доставке факсов для заблокированного адреса (адресов) электронной почты. Для этого, на вкладке Уведомления, снимите флажок Использовать настройки Почта-на-факс по умолчанию, а затем снимите флажок Уведомление о доставке на адрес электронной почты отправителя. В противном случае, пользователь электронной почты получит уведомление с ошибкой 'Извините, ваш e-mail адрес заблокирован...', при попытке отправить сообщение электронной почты. См. также главу Параметры правил для почты , раздел Уведомления о доставке .

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Чтобы изменить порядок предпочтений для Правил для почты, используйте команды Вверх и Вниз. Одно из правил должно быть выделено.

8. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры Правил для почты. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

В примере, см. рисунок выше, использование функции Почта-на-факс разрешено для любого e-mail адреса с доменной частью @t38faxvoip.com, за исключением адреса robby@t38faxvoip.com, для которого создано отдельное правило вида Запретить. Обратите внимание, что правило для 'robby@t38faxvoip.com' размещено перед правилом для '*@t38faxvoip.com'. Правило вида Запретить, которое применяется ко всем адресам электронной почты (*@*), должно быть размещено после всех остальных правил.


Уведомление на e-mail

Уведомление на e-mail о результатах отправки факса (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

При использовании функции Почта-на-факс - Microsoft Fax , пользователь может получать уведомления о результатах отправки факса по электронной почте. Чтобы включить или отключить отправку уведомлений, cм. описание параметра Уведомление о доставке на адрес электронной почты отправителя в главе Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax настоящего справочного руководства. Настройки могут быть персонализированы в зависимости от адреса электронной почты отправителя с помощью Правил для почты , см. главу Уведомления о доставке (правило для почты) .

В случае неудачной доставки факса, уведомление по электронной почте обычно содержит код ошибки и ее описание. В таблице ниже приведены типичные ошибки, а также даны некоторые рекомендации по устранению неполадок.

Ошибка | Описание ошибки | Как исправить проблему
Факс успешно дослан
OK |  |
Не удалось отправить факс
Код завершения операции, возвращаемый факс сервером. Например: НЕТ_ОТВЕТА. | Описание ошибки, возвращаемое факс сервером. Например: Вызов не был отвечен. | Ошибка, возвращаемая факс сервером, не всегда указывает на наличие реальной проблемы (например, телефонная линия может быть действительно занята, вызов не был отвечен, набранный номер не является номером факса и т.д.). В любом случае эти ошибки никак не связаны с функцией Почта-на-факс. Попробуйте сначала отправить факс из приложения Факсы и сканирование Windows. Если это не работает, настройте правильно Fax Voip T.38 Модем и службу факсов Windows. Пожалуйста, изучите это руководство пользователя.
Получатели факса не указаны. | Как минимум один получатель факса должен быть указан в теме сообщения электронной почты. | Укажите корректный номер факса получателя в теме вашего e-mail сообщения. Подробнее см. в разделе Создание сообщения электронной почты .
Нет вложений в вашем электронном письме. | Ваше электронное письмо не содержит вложений либо имя вложения не читается. Также для вашей учетной записи отключена опция отправки титульной страницы без документа. Нечего отсылать. | Создайте электронное письмо, содержащее одно или несколько вложений, см. Создание сообщения электронной почты . Включите опцию Разрешить отправку факсов, состоящих только из титульной страницы, см. Титульные страницы (почта-на-факс) . Если при отправке электронного письма с вложением, вложение каким-то образом "потерялось" (странно...), попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером, см. Параметры POP3 / IMAP .
Расширение файла не поддерживается. | Расширение файла... не поддерживается. Индекс файла = ... (с указанием имени вложения электронной почты). Пожалуйста свяжитесь с администратором факс сервера для получения подробной информации о поддерживаемых форматах. | Явным образом укажите расширение вашего файла рядом с параметром Только указанные расширения файлов, либо выберите опцию Разрешить любые типы файлов в качестве вложений электронной почты. Подробнее см. в разделах Параметры почта-на-факс и Вложения электронной почты .
Документ не может быть преобразован в факс. | Ошибка, возвращаемая функцией Прямая конвертация в факс ... Индекс файла = ... (с указанием имени вложения электронной почты, вызвавшего ошибку). | Скорее всего, ваш файл поврежден.
Не удалось отправить факс. Недопустимое вложение. | Ошибка, возвращаемая методами FaxDocument.ConnectedSubmit или FaxDocument.ConnectedSubmit2 (Fax Service API), обычно 'Указанному файлу не сопоставлено ни одно приложение для выполнения данной операции' ... Индекс файла = ... (с указанием имени вложения электронной почты, вызвавшего ошибку). | Установите приложение, которое ассоциируется в системе с требуемым расширением файла. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Подробнее см. в разделе Вложения электронной почты .
Не удалось отправить факс. | Ошибка, возвращаемая методами FaxDocument.ConnectedSubmit или FaxDocument.ConnectedSubmit2 (Fax Service API), не связанная с файлом вложения электронной почты. | Решение проблемы зависит от конкретной ошибки.
Ваш e-mail адрес заблокирован.
Некорректный e-mail отправителя. | Извините, ваш e-mail адрес заблокирован. Пожалуйста свяжитесь с администратором сервера. | Адрес электронной почты заблокирован Правилами для почты . Подробнее см. в разделе Блокирование нежелательных адресов электронной почты .


Почта-на-факс в качестве службы Windows

Почта-на-факс в качестве службы Windows (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Отправка факсов через e-mail ››

Приложение Fax Voip T.38 Модем, а также подсистема Почта-на-факс - Microsoft Fax могут быть настроены в качестве службы Windows. Служба может автоматически запускаться при запуске Windows до входа пользователя в систему. Этот вариант рекомендуется для многопользовательских систем. Чтобы правильно настроить подсистему Почта-на-факс для запуска в качестве службы Windows, см. Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows .

Запуск службы от имени учетной записи пользователя

Настоятельно рекомендуется запускать службу Fax Voip T.38 Modem MsFax Mail от имени учетной записи пользователя, а не под учетной записью локальной системы или сетевой службы. Для этого есть как минимум две причины:

  • Возможность просмотра и управления факсами, сгенерированными службой, в приложении Факсы и сканирование Windows
  • Возможность настраивать ассоциации типов файлов (ответственные за правильную печать различных документов)

Просмотр факсов и управление ими в Факсы и сканирование Windows

Текущий пользователь не имеет доступа к факсам, которые созданы другим пользователем. Если служба Fax Voip T.38 Modem MsFax Mail запущена от имени учетной записи Локальная система, факсы также будут создаваться от имени учетной записи Локальная система. В этом случае вы не можете просматривать факсы и управлять ими в приложении Факсы и сканирование Windows. Нормального решения этой проблемы не существует. Вы можете осуществить некоторые манипуляции на вкладке Параметры факса -> Безопасность, но это не решает всех проблем, с которыми вы столкнетесь. Если служба Fax Voip T.38 Modem MsFax Mail запущена под определенной учетной записью пользователя, указанный пользователь сможет просматривать факсы, сгенерированные службой и управлять ими обычным способом (при входе в систему). Обратите внимание, что только один пользователь (от имени которого работает служба) может получить доступ к факсам.

Настройка ассоциаций типов файлов

При создании факса из вашего документа, функция Почта-на-факс пытается распечатать документ в фоновом режиме с помощью принтера Fax. Успех этой операции определяется присутствием приложения, связанного с требуемым расширением файла, которое должно быть установлено и правильно зарегистрировано на вашем компьютере. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Ассоциации типов файлов, ответственные за правильную печать различных документов, могут быть легко настроены для текущей учетной записи пользователя. Однако, нет простого способа настроить ассоциации типов файлов для учетной записи 'Локальная система' или учетной записи 'Сетевая служба'. Если служба Fax Voip T.38 Modem MsFax Mail запущена от имени учетной записи Локальная система, функция Почта-на-факс не видит ваших настроек и печать документа обычно заканчивается неудачей. Если служба Fax Voip T.38 Modem MsFax Mail запущена под определенной учетной записью пользователя, указанный пользователь может настроить ассоциации типов файлов обычным способом (при входе в систему).

Для получения дополнительной информации см. следующие главы настоящего справочного руководства: Вложения электронной почты , Параметры Printto , Исправление ассоциаций файлов в Windows 11 и Windows 10 .

Примечания

  • При настройке Почта-на-факс для работы с различными вложениями электронной почты, всегда делайте тесты под учетной записью текущего пользователя, прежде чем перенастраивать подсистему Почта-на-факс для запуска в качестве службы Windows.
  • Повторите тесты после перенастройки подсистемы Почта-на-факс в качестве службы Windows.


Устранение неполадок почта-на-факс

Устранение неполадок функции почта-на-факс

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ››

  • Часто задаваемые вопросы (FAQ)
  • Просмотр журнала функции почта-на-факс - Microsoft Fax
  • Общие инструкции по восстановлению функции почта-на-факс
  • Использование вложений электронной почты с именами файлов на национальных языках


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Устранение неполадок почта-на-факс ››

Я настроил email2fax (почта-на-факс), но ничего не работает. Я вижу факс в папке Исходящие в Факсы и сканирование Windows, но передача факса всегда заканчивается с ошибкой. Какие-либо предложения?

Ошибка не всегда указывает на наличие реальной проблемы (например, телефонная линия может быть действительно занята, вызов не был отвечен, набранный номер не является номером факса и т.д.). В любом случае, проблема определенно никак не связана с функцией Почта-на-факс. Попробуйте сначала отправить факс из приложения Факсы и сканирование Windows. Если это не работает, правильно настройте Fax Voip T.38 Модем согласно инструкциям. Пожалуйста, изучите это руководство пользователя.

У меня проблема с функцией email2fax (почта-на-факс). Когда я отправляю какое-либо вложение PDF, я получаю ответ от системы: 'Комментарий: Ваше электронное письмо не содержит вложений либо имя вложения не читается... Нечего отсылать'. Эта проблема происходит не со всеми вложениями...

Попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером, см. Параметры POP3 / IMAP . В зависимости от сервера IMAP и его настроек, вы можете столкнуться с этой проблемой.

Мы использовали почтовый сервер Gmail с email2fax, но он почему-то перестал работать. В чем проблема?

Чтобы использовать Fax Voip T.38 Модем с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .

Я не могу настроить Fax Voip T.38 Модем для работы с моим сервером POP3 (IMAP, SMTP). Я использую Fax Voip T.38 Модем версии 9.1.1. Не могли бы вы помочь?

Проблема может заключаться в требованиях к версии TLS на вашем почтовом сервере. Начиная с Fax Voip T.38 Модем версии 9.2.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. В Fax Voip T.38 Модем версии 9.1.1 использовался TLS версии 1.0. Установите последнюю версию программного обеспечения Fax Voip T.38 Модем.

Мой провайдер электронной почты говорит мне, что я должен использовать OAuth 2.0 при настройке POP3 (IMAP, SMTP). Я использую Fax Voip T.38 Модем версии 9.2.1 (9.1.1). Не могли бы вы помочь?

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1. Установите последнюю версию программного обеспечения Fax Voip T.38 Модем.

При отправке вложения с расширением DOC, я получаю следующую ошибку: 'Не удалось отправить факс. Недопустимое вложение...'. Как исправить?

Попробуйте установить приложение, которое ассоциируется в системе с требуемым расширением файла. Соответствующее приложение должно поддерживать стандартную команду printto, которая используется Windows при печати файла. Например, для печати файлов с расширениями .doc и .rtf, необходимо установить приложение Microsoft Word на компьютере, где установлен Fax Voip T.38 Модем. Подробнее см. в разделе Вложения электронной почты (Microsoft Fax) .

Когда я отправляю свое вложение, email2fax (Microsoft Fax) зависает. Затем я получаю следующую ошибку: 'Не удалось отправить факс. Недопустимое вложение... Время ожидания операции истекло'. Почему?

Подсистема Почта-на-факс не может напечатать ваш документ и по какой-то причине не может вернуть ошибку немедленно. Она возвращает 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Столь длительное время ожидания связано с внутренним таймаутом в методах FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API), это не может быть легко исправлено в нашем приложении. По указанной причине, мы рекомендуем блокировать расширение файла, используя опцию Только указанные расширения файлов (подробнее см. в разделе Вложения электронной почты ) или использовать функцию Прямой конвертации в факс , для данного типа файлов (если это возможно).

Могу ли я использовать вложения электронной почты с именами файлов на русском языке? Будет довольно сложно заставить 70 сотрудников в нашем офисе прекратить использовать кириллицу ...

Fax Voip T.38 Модем имеет поддержку Юникод, поэтому у вас вряд ли возникнут проблемы из-за этого. Но если вы сомневаетесь, настройте свою систему на корректную поддержку русского языка, см. главу Использование вложений электронной почты с именами файлов на национальных языках .

Возможно ли отправлять титульные страницы с помощью функции email2fax (почта-на-факс)?

Да.

Могу ли я использовать несколько вложений электронной почты для объединения в одно факсимильное сообщение при использовании email2fax (почта-на-факс)?

Да.

Можно ли настроить поведение email2fax, в зависимости от адреса электронной почты отправителя?

Да. Подробнее см. Правила для почты (почта-на-факс) - Microsoft Fax .

Мы больше не можем отправлять исходящие факсы из приложения электронной почты. Остановка и запуск службы не помогает...

Создайте журнал отладки Почта-на-факс, подробности см. в разделе Просмотр журнала функции почта-на-факс - Microsoft Fax . Следуйте общим инструкциям по восстановлению функции почта-на-факс .


Просмотр журнала почта-на-факс

Просмотр журнала функции почта-на-факс - Microsoft Fax

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Устранение неполадок почта-на-факс ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Общие параметры, затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол функции Почта-на-факс - служба факсов Windows.

3. Чтобы автоматически удалить файл журнала отладки при запуске почтовой подсистемы (службы Fax Voip T.38 Modem MsFax Mail), поставьте флажок у параметра Очистка протокола при запуске службы Почта-на-факс.

4. Нажмите кнопку <Применить>.

Для просмотра журнала функции Почта-на-факс нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол функции Почта-на-факс - служба факсов Windows.

Примечания

  • Для просмотра детализированного журнала приема сообщений e-mail, воспользуйтесь опцией Вести протокол приема электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.
  • Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.


Восстановление почта-на-факс

Общие инструкции по восстановлению функции почта-на-факс

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Устранение неполадок почта-на-факс ››

В результате неудачных экспериментов с различными видами вложений электронной почты, вы можете столкнуться с ситуацией, при которой Fax Voip T.38 Модем более не проверяет входящую почту и функция Почта-на-факс оказывается полностью неработоспособной (предполагается, что Параметры POP3 / IMAP настроены корректно). Когда это происходит, вы можете также наблюдать повышенную загрузку процессора.

Изучение журнала функции почта-на-факс - Microsoft Fax

1. Следуйте инструкциям главы Просмотр журнала функции почта-на-факс - Microsoft Fax , чтобы включить отладку.

2. В Панели управления Fax Voip T.38 Модем, нажмите <СТОП>, а затем <СТАРТ>, чтобы перезапустить подсистему Почта-на-факс (службу Fax Voip T.38 Modem MsFax Mail).

3. Подождите не менее 5 минут. Внутренний таймаут методов FaxDocument.ConnectedSubmit и FaxDocument.ConnectedSubmit2 (Fax Service API) составляет 5 минут, и это не может быть легко исправлено в нашем приложении. Подсистема Почта-на-факс может вернуть ошибку 'Время ожидания операции истекло' после 5-минутного ожидания, в течение которого подсистема Почта-на-факс намертво зависает. Это будет отражено в файле журнала, и вы сможете устранить проблему, заблокировав расширение файла, вызвавшее ошибку, см. главу Вложения электронной почты (Microsoft Fax) настоящего справочного руководства.

4. В дереве нажмите Общие параметры, затем нажмите Журналы электронной почты. Для просмотра журнала отладки нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол функции Почта-на-факс - служба факсов Windows.

5. Изучите файл журнала и попытайтесь устранить проблему. Вы также можете отправить файл журнала в нашу службу поддержки по электронной почте.

Попробуйте отключить опцию "Запускать Fax Voip T.38 Модем как службу Windows"

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Общие параметры.

3. Снимите флажок Запускать Fax Voip T.38 Модем как службу Windows, и затем нажмите <Применить>.

4. Нажмите кнопку <СТАРТ>.

5. Посмотрите, исчезла ли проблема. Изучите файл журнала.

Удаление временных файлов

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите кнопку <СТОП> чтобы остановить Fax Voip T.38 Модем.

3. В Проводнике Windows откройте папку *{CommonAppDataFolder}\FaxVoip Modem, обычно 'C:\ProgramData\FaxVoip Modem'.

4. В папке данных Fax Voip T.38 Модем найдите папку *{CommonAppDataFolder}\FaxVoip Modem\attach, обычно 'C:\ProgramData\FaxVoip Modem\attach', и откройте ее. Если в этой папке присутствуют какие-либо файлы, удалите их. Чтобы исследовать проблему, вы можете скопировать обнаруженные файлы в другое место на жестком диске перед удалением, а затем отправить их в нашу службу поддержки по электронной почте.

5. В папке данных Fax Voip T.38 Модем найдите папку *{CommonAppDataFolder}\FaxVoip Modem\mail, обычно 'C:\ProgramData\FaxVoip Modem\mail', и откройте ее. Если в этой папке присутствуют какие-либо файлы, удалите их. Чтобы исследовать проблему, вы можете скопировать обнаруженные файлы в другое место на жестком диске перед удалением, а затем отправить их в нашу службу поддержки по электронной почте.

6. В Панели управления Fax Voip T.38 Модем, нажмите кнопку <СТАРТ>.

Примечания

  • *{CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.
  • Функция Почта-на-факс основана на возможности вашей системы использовать функцию printto с различными типами документов (вложений электронной почты). Поведение для различных типов файлов сильно зависит от конкретного компьютера и установленных на нем приложений. Для получения дополнительной информации см. следующие главы настоящего справочного руководства: Вложения электронной почты (Microsoft Fax) , Параметры printto , Исправление ассоциаций файлов в Windows 11 и Windows 10 . Проблемы, связанные с использованием какого-либо конкретного типа файлов в качестве e-mail вложений, не могут рассматриваться как ошибки в программе Fax Voip T.38 Модем.
  • Функция Почта-на-факс в настоящее время предоставляется 'КАК ЕСТЬ'. Следует понимать, что это не основная функция приложения Fax Voip T.38 Модем. Мы всегда рады помочь вам в решении различных проблем касательно функции Почта-на-факс, но при этом любые претензии, связанные с этой функцией, не рассматриваются нашей службой поддержки.


Имена вложений электронной почты

Использование вложений электронной почты с именами файлов на национальных языках

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Почта-на-факс - Microsoft Fax ›› Устранение неполадок почта-на-факс ››

Обратите внимание, что Fax Voip T.38 Модем поддерживает Юникод. Таким образом, вы не должны столкнуться с проблемами, описанными в этой главе и можете использовать любые имена файлов. Тем не менее, приведенная ниже информация может оказаться полезной.

При отправке факсов с использованием функции Почта-на-факс, в качестве вложений электронной почты, пользователи часто используют длинные имена файлов и имена файлов на их родном языке, например на русском или на польском. Примеры файлов с подобными именами вы можете видеть на рисунке ниже.

Мы рекомендуем использовать короткие имена файлов с использованием букв латинского алфавита. Если вы все же хотите использовать имена файлов на вашем родном языке и имеете проблемы с такими файлами, вам следует правильно настроить вашу операционную систему на поддержку нужного языка. Нижеприведенный пример иллюстрирует, как настроить вашу систему на поддержку русского языка.

Чтобы настроить Windows для поддержки нужного языка, выполните следующие шаги:

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления.

2. В Панели управления, нажмите Региональные стандарты.

3. В окне Регион, перейдите на вкладку Дополнительно.

4. На вкладке Дополнительно, в области Язык программ, не поддерживающих Юникод, нажмите кнопку <Изменить язык системы…>.

5. В диалоговом окне Региональные стандарты, выберите требуемый язык, например Русский (Россия).

6. Нажмите OK.

7. В диалоговом окне Изменение языка системы, нажмите Перезагрузить сейчас чтобы перезагрузить компьютер.


Параметры SMTP

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

SMTP сервер отвечает за отправку сообщений электронной почты. Параметры SMTP необходимо сконфигурировать для работы следующих функций Fax Voip T.38 Модем:

  • Маршрутизация входящих факсов: отправить по электронной почте (Microsoft Fax)
  • Маршрутизация исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax) . Уведомления об успешной или неудачной доставке факса на заранее заданный адрес(а) электронной почты.
  • Почта-на-факс - Microsoft Fax . Уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя.

Предполагается, что у вас есть учетная запись электронной почты, полученная от поставщика услуг Интернета или системного администратора. Внимание! Для того, чтобы избежать неожиданных проблем, эта учетная запись не должна использоваться другими почтовыми клиентами для получения и отправки обычных писем электронной почты.

Авторизация по протоколу OAuth 2.0

Поставьте галочку, чтобы использовать протокол OAuth 2.0 при отправке сообщений электронной почты. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (SMTP) . Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1.

Нажмите чтобы настроить OAuth 2.0

Нажмите чтобы настроить Параметры OAuth 2.0 (SMTP) .

Метод отправки E-mail

SecureSmtpClient

Этот метод изначально реализован в Fax Voip T.38 Модем версии 9.3.1 для поддержки протокола OAuth 2.0 при отправке сообщений электронной почты через SMTP. Поддерживает как неявное безопасное соединение Implicit SSL (обычно через порт 465), так и явное безопасное соединение Explicit SSL с отправкой команды STARTTLS (обычно через порт 587 или 25). Данный метод позволяет игнорировать ошибки в случае если ваш сервер SMTP не имеет валидного SSL сертификата. При отправке сообщения электронной почты создается подробный лог, см. главу Журналы электронной почты настоящего справочного руководства.

CDO.Message

Выберите этот вариант, чтобы использовать Collaboration Data Objects (CDO) for Microsoft Windows 2000 (Cdosys.dll) при отправке сообщений e-mail из Fax Voip T.38 Модем. Используйте эту опцию, если ваш сервер SMTP требует неявное безопасное соединение Implicit SSL (обычно через порт 465). Кроме того, необходимо использовать данный метод для отправки сообщений электронной почты с цифровой подписью.

System.Net.Mail

При выборе этого варианта для отправки сообщений e-mail используется метод предлагаемый .Net Framework. Используйте эту опцию, если ваш сервер SMTP требует явное безопасное соединение Explicit SSL с отправкой команды STARTTLS (обычно через порт 587 или 25). Кроме того, данный метод позволяет игнорировать ошибки в случае если ваш сервер SMTP не имеет валидного SSL сертификата.

E-mail отправителя

Адрес электронной почты, соответствующий учетной записи на SMTP сервере, которая используется в настройках Fax Voip T.38 Модем. Этот e-mail будет отображаться в качестве адреса отправителя в сообщениях e-mail, посылаемых Fax Voip T.38 Модем.

Имя отправителя

Понятное имя, соответствующее адресу электронной почты. Когда Fax Voip T.38 Модем отправляет сообщение, это имя будет стоять в поле От исходящего сообщения. По умолчанию используется имя Fax Voip T.38 Modem, вы можете ввести любое другое имя. Если вы оставите данное поле пустым, получатель сообщения будет видеть e-mail адрес отправителя вместо имени.

Сервер SMTP

Сервер SMTP для отправки исходящих сообщений.

Порт

Номер порта, через который устанавливается подключение на сервере исходящей почты (SMTP). Обычно используется порт 25. В случае использования неявного безопасного соединения Implicit SSL, номер порта как правило 465. В случае явного безопасного соединения Explicit SSL с отправкой команды STARTTLS, номер порта как правило 587 либо 25.

Подключаться через безопасное соединение (SSL)

Указывает, следует ли использовать безопасный протокол SSL (Secure Sockets Layer) при подключении к серверу SMTP. Обратите внимание, что, начиная с Fax Voip T.38 Модем версии 9.2.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip T.38 Модем использовали TLS версии 1.0. Если серверу необходим протокол SSL, то это требование накладывается на сервер администратором сети или поставщиком услуг Интернета.

Режим SSL

Implicit

Выберите этот вариант, если ваш сервер SMTP требует неявное безопасное соединение Implicit SSL (обычно через порт 465). При использовании этого метода сеанс SSL устанавливается заранее, до отправки команд протокола. Режим Implicit SSL реализован через методы SecureSmtpClient и CDO.Message для отправки сообщений e-mail.

Explicit (STARTTLS)

Выберите этот вариант, если ваш сервер SMTP требует явное безопасное соединение Explicit SSL (обычно через порт 587 или 25). В этом режиме сеанс SMTP начинается в незашифрованном канале, затем от клиента к серверу дается команда STARTTLS, чтобы переключиться на безопасное соединение с помощью протокола SSL. Режим Explicit SSL реализован через методы SecureSmtpClient и System.Net.Mail для отправки сообщений e-mail.

Требуется проверка подлинности

Поставьте галочку, если для работы с SMTP сервером необходима проверка подлинности.

Логин

Имя пользователя для авторизации на сервере SMTP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Поле для ввода пароля, назначенного поставщиком услуг интернета. Пароль не требуется и игнорируется, если используется современная проверка подлинности OAuth 2.0.

Подписывать исходящие сообщения цифровой подписью

Добавление цифровой подписи во все сообщения, отправляемые программой Fax Voip T.38 Модем. Если сообщение подписано, можно точно установить, кто является его отправителем. Действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в хранилище сертификатов в вашей системе. Рекомендуется установить сертификат в Хранилище локального компьютера чтобы иметь возможность использовать его при запуске Fax Voip T.38 Модем в качестве службы Windows. При использовании данного функционала с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , учетная запись Network Service (Сетевая служба), под которой работает служба факсов Windows, должна иметь доступ на чтение к закрытым ключам вашего сертификата. Заметим, что для просмотра подписанных сообщений получателю не требуется цифрового удостоверения.

Прозрачная подпись

При прозрачном подписывании сообщений цифровая подпись отделена от подписываемых данных. Почтовые программы, не поддерживающие кодировку S/MIME могут читать только прозрачно подписанные сообщения. Используйте эту опцию, если вы не знаете, какими почтовыми программами пользуются ваши получатели.

Непрозрачная подпись

Включение кодирования сообщений с цифровой подписью во избежание ее подделывания. При использовании этой опции, пользователи почтовых программ, не поддерживающих кодировку S/MIME, не смогут читать сообщения с цифровой подписью. Если вам известно, что получатель использует почтовую программу с поддержкой кодировки S/MIME, вы можете использовать как прозрачное, так и непрозрачное подписывание.

<Сертификат>

Нажмите для отображения диалогового окна, содержащего свойства сертификата X.509 и связанной цепочки сертификатов. Если действительный сертификат, соответствующий заданному E-mail отправителя не найден, то выводится сообщение с информацией. Чтобы можно было использовать сертификат при запуске Fax Voip T.38 Модем в качестве службы Windows, действительный цифровой сертификат должен быть установлен в Хранилище сертификатов локального компьютера в вашей системе. При использовании данного функционала с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , учетная запись Network Service (Сетевая служба), под которой работает служба факсов Windows, должна иметь доступ на чтение к закрытым ключам вашего сертификата. Если ваш сертификат установлен в Хранилище сертификатов текущего пользователя, Fax Voip T.38 Модем предлагает установить его в Хранилище сертификатов локального компьютера. Если ваш сертификат установлен в Хранилище сертификатов локального компьютера, но у учетной записи Network Service (Сетевая служба) отсутствует доступ на чтение к закрытым ключам, Fax Voip T.38 Модем предлагает предоставить доступ к закрытым ключам для службы факсов (учетная запись Network Service). Следуйте инструкциям диалоговых окон. Обратите внимание, что для проверки разрешений доступа для учетной записи Network Service (Сетевая служба), а также для установки сертификата в Хранилище сертификатов локального компьютера, требуются права администратора. Более подробную информацию можно найти в главе Получение и установка сертификата безопасности электронной почты настоящего справочного руководства.

<Тест>

Используйте эту кнопку для запуска встроенного SMTP-клиента для тестирования параметров SMTP перед использованием.

Примечания

  • Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (SMTP) .
  • Начиная с Fax Voip T.38 Модем версии 9.2.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip T.38 Модем использовали TLS версии 1.0.
  • Чтобы использовать Fax Voip T.38 Модем с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .
  • Неявное безопасное соединение Implicit SSL поддерживается с методами SecureSmtpClient и CDO.Message. Явное безопасное соединение Explicit SSL с отправкой команды STARTTLS поддерживается с методами SecureSmtpClient и System.Net.Mail.
  • Если ваш сервер SMTP не имеет валидного SSL сертификата, используйте метод SecureSmtpClient или System.Net.Mail.
  • Чтобы отправлять сообщения электронной почты с цифровой подписью, используйте метод CDO.Message.
  • Чтобы отправлять сообщения электронной почты с цифровой подписью, действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в хранилище сертификатов в вашей системе. Рекомендуется установить сертификат в Хранилище локального компьютера чтобы иметь возможность использовать его при запуске Fax Voip T.38 Модем в качестве службы Windows. При использовании данного функционала с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , учетная запись Network Service (Сетевая служба), под которой работает служба факсов Windows, должна иметь доступ на чтение к закрытым ключам вашего сертификата. Обратите внимание, что в большинстве случаев, усиленная защита закрытого ключа должна быть отключена (эта опция выбирается при установке сертификата). Более подробную информацию можно найти в главе Получение и установка сертификата безопасности электронной почты настоящего справочного руководства.
  • Fax Voip T.38 Модем отправляет все сообщения e-mail в кодировке UTF-8.
  • При использовании метода CDO.Message для отправки сообщений e-mail и наличии символов юникода в имени прикрепленного файла, эти символы могут заменяться подчеркиванием ' _ '. Проблема может наблюдаться при использовании пользовательских шаблонов имен файлов, обычно при использовании нестандартной локали для форматирования даты и времени. Подробнее см. в следующих главах: Параметры формата (Отправить по электронной почте, Microsoft Fax) , Параметры формата (Уведомления о доставке по электронной почте, Microsoft Fax) , Уведомления о доставке на адрес электронной почты отправителя (почта-на-факс) - Microsoft Fax , Уведомления о доставке (правило для почты, Microsoft Fax) . Чтобы устранить проблему, используйте метод SecureSmtpClient или System.Net.Mail для отправки сообщений e-mail.
  • Для проверки сделанных настроек воспользуйтесь кнопкой <Тест>, см. главу Отправка пробного e-mail . Для просмотра журнала отправки сообщений, используйте опцию Вести протокол отправки электронной почты, см. главу Журналы электронной почты настоящего справочного руководства.
  • При использовании стандартных шаблонов электронной почты, язык текста сообщений зависит от используемого в программе активного Языкового профиля (см. главу Многоязычная поддержка настоящего справочного руководства). Если выбран профиль Русский, то сообщения отправляются на русском языке. Если выбран профиль English (Default) или English, то сообщения отправляются на английском языке. Также вы можете использовать пользовательские шаблоны электронной почты .


Параметры OAuth 2.0

Параметры OAuth 2.0 (SMTP)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Параметры SMTP ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1.

На этой странице задаются настройки OAuth 2.0, которые будут использоваться при отправке сообщений электронной почты через сервер SMTP, см. также главу Параметры SMTP настоящего справочного руководства. Используйте кнопку <Refresh Token>, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год) и предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты, установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. После настройки параметров OAuth 2.0 и получения Refresh Token, нажмите <Применить>, чтобы сохранить настройки.

Нажмите, чтобы настроить параметры SMTP

Нажмите чтобы настроить Параметры SMTP .

<Загрузить профиль>

Нажмите, чтобы загрузить предопределенные настройки, выбранные из раскрывающегося списка справа. В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird . Можно выбрать следующие варианты (тестировалось с Fax Voip T.38 Модем):

Google / Gmail.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Gmail . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию По умолчанию или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .

Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net), Internet Explorer или По умолчанию. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Yahoo.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yahoo! . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .

Yandex.com (Fax Voip)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Yandex.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Mail.ru (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Mail.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .

Адрес авторизации

Адрес сервера авторизации (Authorization URI), на который направляется запрос на авторизацию. Сервер авторизации используется для аутентификации и авторизации и возвращает разрешение на авторизацию (код авторизации) клиентскому приложению.

Адрес получения токена

Адрес получения токена (Token URI), который используется клиентским приложением для обмена кода авторизации или Refresh Token на токен доступа (access token).

Разрешения (Scope)

Разделенный пробелами список разрешений. Разрешения OAuth 2.0 (scopes) позволяют ограничить уровень доступа, предоставляемого токену доступа (access token).

Идентификатор клиента

Публичный идентификатор клиентского приложения (Client ID).

Секретный ключ

Секретный ключ (Client Secret) используется для аутентификации подлинности приложения для API сервиса, когда приложение запрашивает доступ к учетной записи пользователя. Может быть пустой строкой для "публичного" приложения.

Адрес перенаправления

Адрес (Redirect URI), на который пользователь будет перенаправлен после того, как он разрешил приложению доступ. Он должен соответствовать одному из адресов перенаправления, зарегистрированных разработчиком при создании приложения. Сервер авторизации должен отклонить запрос, если указанный адрес не совпадает с зарегистрированным для приложения.

Адрес электр. почты

Адрес электронной почты, соответствующий учетной записи пользователя.

Refresh Token

Refresh Token предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год). Для получения Refresh Token, используйте кнопку <Refresh Token>.

<Refresh Token>

Используйте эту кнопку, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем).

Открыть запрос авторизации в этом браузере

Выберите один из вариантов ниже. Мы предлагаем 3 различных метода, так как в зависимости от почтового сервера OAuth 2.0 и параметра Адрес перенаправления (Redirect URI), который задается разработчиком при создании приложения, некоторые из них могут не работать.

Internet Explorer

Если выбран этот вариант, для обработки запроса на авторизацию используется InternetExplorer object (веб-браузер Windows Internet Explorer). Этот вариант работает со всеми провайдерами электронной почты OAuth 2.0, которые были протестированы. Обратите внимание, что этот вариант также работает в Windows 11, где Microsoft заблокировала браузер Internet Explorer.

WebBrowser (.Net)

Если выбран этот вариант, для обработки запроса на авторизацию используется элемент управления WebBrowser (.NET Framework). Обратите внимание, что этот вариант не работает с Gmail (ошибка 'неподдерживаемый браузер').

По умолчанию

Если выбран этот вариант, для обработки запроса на авторизацию используется веб-браузер по умолчанию. Обратите внимание, что этот вариант работает только с приложениями, для которых разработчик явно указал Адрес перенаправления (Redirect URI) = http://127.0.0.1. Кроме того, при этом используется случайный неиспользуемый порт, что не всегда поддерживается провайдером электронной почты OAuth 2.0. Окно браузера должно быть закрыто пользователем вручную. В наших тестах это работало только с Gmail и Microsoft (профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)). Тестировалось с Microsoft Edge и Internet Explorer в качестве веб-браузеров по умолчанию.

<Очистить>

Нажмите, чтобы очистить все текстовые поля на данной странице.

Использовать эти параметры OAuth 2.0 для POP3 / IMAP

Установите этот флажок, чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты.

Примечания

  • В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте вашего провайдера электронной почты OAuth 2.0.


Получение и установка сертификата безопасности электронной почты

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Параметры SMTP ››

Чтобы отправлять сообщения электронной почты с цифровой подписью, действительный цифровой сертификат, соответствующий заданному E-mail отправителя должен быть установлен в хранилище сертификатов в вашей системе. Рекомендуется установить сертификат в Хранилище локального компьютера чтобы иметь возможность использовать его при запуске Fax Voip T.38 Модем в качестве службы Windows. При использовании данного функционала с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , учетная запись Network Service (Сетевая служба), под которой работает служба факсов Windows, должна иметь доступ на чтение к закрытым ключам вашего сертификата. Если по каким-то причинам сертификат установлен в Хранилище текущего пользователя, усиленная защита закрытого ключа должна быть отключена чтобы обеспечить возможность подписывания исходящих сообщений в автоматическом режиме. Fax Voip T.38 Модем сначала пытается найти действительный сертификат безопасности электронной почты в Хранилище локального компьютера, и только затем в Хранилище текущего пользователя.

Получение сертификата

Цифровые сертификаты выдаются независимыми центрами сертификации. При обращении на веб-узел центра сертификации для получения сертификата перед его выпуском производится предварительная проверка подлинности для клиента. Имеются различные классы сертификатов, каждый из которых подтверждает определенный уровень надежности. Для получения дополнительных сведений посетите веб-узел центра сертификации. Можно использовать Бесплатный почтовый сертификат от Actalis .

После получения сертификата, он обычно устанавливается в Хранилище текущего пользователя. Для доступа к вашему сертификату, выполните следующие действия:

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления. В Панели управления, нажмите Сеть и интернет, а затем нажмите Свойства браузера.

2. В окне Свойства: интернет, на вкладке Содержание нажмите Сертификаты.

3. В окне Сертификаты выберите вкладку Личные и затем дважды щелкните ваш сертификат. Убедитесь, что отображается информация о наличии закрытого ключа.

Наличие действительного сертификата в Хранилище сертификатов текущего пользователя не обеспечивает автоматического подписания сообщений электронной почты если Fax Voip T.38 Модем запускается в качестве службы Windows. Сертификат должен быть установлен в Хранилище сертификатов локального компьютера. Кроме того, при использовании данного функционала с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) , учетная запись Network Service (Сетевая служба), под которой работает служба факсов Windows, должна иметь доступ на чтение к закрытым ключам вашего сертификата. Самый простой способ обеспечить эти условия - использовать Панель Управления Fax Voip T.38 Модем для правильной переустановки сертификата.

Переустановка сертификата в хранилище локального компьютера с помощью Панели управления Fax Voip T.38 Модем

Предполагается, что действительный цифровой сертификат, соответствующий заданному E-mail отправителя, уже установлен в Хранилище сертификатов текущего пользователя. Чтобы установить сертификат в Хранилище сертификатов локального компьютера, выполните следующие действия:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Электронная почта, затем нажмите SMTP.

3. Нажмите кнопку <Сертификат>.

4. В появившемся диалоговом окне нажмите Да, чтобы установить ваш сертификат в Хранилище сертификатов локального компьютера и предоставить доступ на чтение к закрытым ключам сертификата для службы факсов (учетная запись Network Service). Требуются права администратора.

5. В следующем диалоговом окне нажмите OK.

В последующих разделах показано, как вручную установить сертификат в Хранилище текущего пользователя (не рекомендуется) или в Хранилище сертификатов локального компьютера. Как и ранее, предполагается, что действительный цифровой сертификат, соответствующий заданному E-mail отправителя, уже установлен в Хранилище сертификатов текущего пользователя. Прежде всего, вы должны экспортировать сертификат вместе с закрытым ключом и сохранить его в Файле обмена личной информацией – PKCS #12 (.PFX).

Экспорт сертификата вместе с закрытым ключом

1. Переключитесь на панель Поиск, наберите панель управления, а затем выберите команду Панель управления. В Панели управления, нажмите Сеть и интернет, а затем нажмите Свойства браузера.

2. В окне Свойства: интернет, на вкладке Содержание нажмите Сертификаты.

3. В окне Сертификаты выберите ваш сертификат и затем нажмите Экспорт. Следуйте инструкциям Мастера экспорта сертификатов.

4. На странице Экспортирование закрытого ключа, выберите опцию Да, экспортировать закрытый ключ.

5. На странице Формат экспортируемого файла, выберите опцию Файл обмена личной информацией – PKCS #12 (.PFX). Выберите другие опции, кроме опции Удалить закрытый ключ после успешного экспорта как показано на рисунке ниже.

6. На следующей странице мастера введите пароль для защиты закрытого ключа.

7. На странице Имя экспортируемого файла укажите имя файла, который вы хотите экспортировать.

8. На странице Завершение работы мастера экспорта сертификатов нажмите Готово чтобы закрыть окно мастера.

После успешного завершения этой процедуры, вы можете удалить сертификат из Хранилища сертификатов, если вы планируете установить его заново. Для этого в окне Сертификаты нажмите Удалить.

Установка сертификата в Хранилище текущего пользователя (не рекомендуется)

Если по каким-то причинам вы устанавливаете сертификат в Хранилище текущего пользователя, для обеспечения подписывания исходящих сообщений в автоматическом режиме усиленная защита закрытого ключа должна быть отключена в процессе установки сертификата. В любом случае, подписывание не будет работать в случае запуска Fax Voip T.38 Модем в качестве службы Windows, а также с Методом маршрутизации для входящих факсов 'Отправить по электронной почте' (Microsoft Fax) .

1. Дважды щелкните файл .PFX, в котором был сохранен ваш сертификат с закрытым ключом.

2. В окне Мастер импорта сертификатов, на первой странице выберите опцию Текущий пользователь. Нажмите Далее и следуйте инструкциям.

3. На странице Защита с помощью закрытого ключа, в области Параметры импорта снимите галку с опции Включить усиленную защиту закрытого ключа как показано на рисунке ниже. Если вы не сделаете этого, Fax Voip не сможет автоматически подписывать исходящие сообщения. Введите пароль для закрытого ключа. Вы можете отметить другие доступные опции, если хотите. Нажмите Далее.

4. На странице Хранилище сертификатов выберите опцию Автоматически выбрать хранилище на основе типа сертификата. Нажмите Далее.

5. На странице Завершение работы мастера импорта сертификатов нажмите Готово чтобы закрыть окно мастера.

Установка сертификата в Хранилище локального компьютера (рекомендуется)

1. Дважды щелкните файл .PFX, в котором был сохранен ваш сертификат с закрытым ключом.

2. В окне Мастер импорта сертификатов, на первой странице выберите опцию Локальный компьютер. Нажмите Далее и следуйте инструкциям. Для установки сертификата в Хранилище локального компьютера, требуются права администратора.

3. Следуйте инструкциям Мастера импорта сертификатов.

4. На странице Защита с помощью закрытого ключа, введите пароль для закрытого ключа. Вы можете отметить опции, доступные в области Параметры импорта, если хотите. Нажмите Далее.

5. На странице Хранилище сертификатов выберите опцию Автоматически выбрать хранилище на основе типа сертификата. Нажмите Далее.

6. На странице Завершение работы мастера импорта сертификатов нажмите Готово чтобы закрыть окно мастера.

Для доступа к сертификатам установленным в Хранилище локального компьютера

1. Откройте окно командной строки.

2. Введите mmc и нажмите клавишу ВВОД. Обратите внимание, что для просмотра сертификатов в Хранилище локального компьютера, вы должны иметь права администратора.

3. В меню Файл выберите команду Добавить или удалить оснастку.

4. В диалоговом окне Добавление и удаление оснасток, в списке Доступные оснастки выберите Сертификаты. Нажмите Добавить.

5. В диалоговом окне Оснастка диспетчера сертификатов, выберите учетной записи компьютера и нажмите Далее.

6. В диалоговом окне Выбор компьютера, нажмите Готово.

7. В диалоговом окне Добавление и удаление оснасток, нажмите OK.

8. В окне Корень консоли, щелкните Сертификаты (локальный компьютер) для просмотра хранилищ сертификатов.

9. (Опционально). В меню Файл выберите команду Сохранить или Сохранить как чтобы сохранить консоль для дальнейшего использования.

Предоставление доступа к закрытым ключам сертификата для службы факсов

1. Откройте оснастку Сертификаты в консоли mmc, как показано в предыдущем разделе.

2. Щелкните свой сертификат правой кнопкой мыши. В контекстном меню, выберите Все задачи, а затем нажмите Управление закрытыми ключами... .

3. В окне Разрешения для ... private keys нажмите Добавить... .

4. В диалоговом окне Выбор: "Пользователи" или "Группы", введите NETWORK SERVICE, а затем нажмите Проверить имена. Нажмите OK.

5. В окне Разрешения для ... private keys, в списке Группы или пользователи, выберите NETWORK SERVICE. Предоставьте разрешение на чтение для учетной записи Network Service, как показано на рисунке ниже. Нажмите Применить.

Просмотр сертификата в приложении Fax Voip T.38 Модем

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве нажмите Электронная почта, затем нажмите SMTP.

3. Для просмотра сертификата нажмите кнопку <Сертификат>. Если действительный сертификат, соответствующий заданному E-mail отправителя найден, он будет отображен. Для проверки разрешений доступа для учетной записи Network Service (Сетевая служба), требуются права администратора.


Отправка пробного e-mail

Тестирование отправки e-mail с помощью встроенного SMTP клиента

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Параметры SMTP ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Вы можете включить опцию Вести протокол отправки электронной почты для просмотра протокола отправки e-mail сообщений. Для включения этой опции, в дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, а затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол отправки электронной почты и нажмите кнопку <Применить>.

3. В дереве Панели управления Fax Voip T.38 Модем нажмите Электронная почта, затем нажмите SMTP.

4. Нажмите кнопку <Тест> для запуска встроенного SMTP клиента. При использовании современной проверки подлинности OAuth 2.0, значок защищенного электронного письма будет отображаться в верхнем левом углу окна Отправить пробное сообщение. При отправке сообщения с цифровой подписью, будет отображаться иконка с изображением сертификата. Флажок Протокол в нижнем левом углу информирует о том, что опция Вести протокол отправки электронной почты активна.

5. Укажите адрес электронной почты получателя в поле Кому. Можно указывать не только адрес электронной почты, но также имя получателя. Можно также указать несколько получателей, которые должны быть разделены точкой с запятой. Например: sales@company.com;Support<support@company.com>. В полях Копия и Скрытая копия, можно задать получателей e-mail, которые отображаются соответственно в полях Копия и Скрытая копия сообщения электронной почты. Используйте кнопки <Кому>, <Копия> и <Скрытая копия>, чтобы выбрать получателей электронной почты из адресной книги (Контакты Windows).

6. Если вы хотите изменить тему сообщения, измените текст в поле Тема.

7. Если вы хотите изменить текст сообщения, вы можете ввести собственный текст в основном текстовом поле.

8. Для выбора e-mail вложения, нажмите кнопку <Вложить> и выберите файл. Для отправки сообщения без вложения, удалите текст из текстового поля.

9. Для отправки сообщения нажмите кнопку <Отправить>.

10. При использовании метода SecureSmtpClient для отправки сообщений электронной почты, подробности сеанса связи с сервером SMTP будут отображаться в окне Тестирование сервера исходящей почты SMTP. Чтобы закрыть окно, нажмите <Закрыть>.

11. Вы увидите окно сообщения с результатами отправки e-mail. В случае ошибки, в окне сообщения будет указан номер ошибки и ее описание. Нажмите кнопку <OK>, чтобы закрыть встроенный SMTP клиент. Для просмотра протокола отправки сообщения, в дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, затем нажмите Журналы электронной почты, а затем нажмите кнопку <Просмотр> напротив опции Вести протокол отправки электронной почты.


Параметры POP3 / IMAP

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

POP3 / IMAP сервер отвечает за прием сообщений электронной почты. Параметры POP3 / IMAP необходимо сконфигурировать для работы следующей функции Fax Voip T.38 Модем:

  • Почта-на-факс - Microsoft Fax . Отправка факсов через e-mail с использованием службы факсов Windows.

Предполагается, что у вас есть учетная запись электронной почты, полученная от поставщика услуг Интернета или системного администратора. Внимание! Для того, чтобы избежать неожиданных проблем, эта учетная запись не должна использоваться другими почтовыми клиентами для получения и отправки обычных писем электронной почты.

Авторизация по протоколу OAuth 2.0

Поставьте галочку, чтобы использовать протокол OAuth 2.0 при приеме сообщений электронной почты. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (POP3 / IMAP) . Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1.

Нажмите чтобы настроить OAuth 2.0

Нажмите чтобы настроить Параметры OAuth 2.0 (POP3 / IMAP) .

Тип сервера

Тип сервера, используемого для приема входящей электронной почты. Вы можете выбрать между POP3 и IMAP.

Сервер входящей почты

Имя сервера входящих сообщений POP3 / IMAP. Эти сведения можно получить у поставщика услуг Интернета или администратора локальной сети.

Порт

Номер порта, через который устанавливается подключение на сервере входящей почты. Обычно используется порт 110 (в случае серверов POP3) или порт 143 (в случае серверов IMAP). При использовании безопасного соединения (SSL), номер порта как правило 995 в случае серверов POP3 или 993 в случае серверов IMAP.

Подключаться через безопасное соединение (SSL)

Указывает, следует ли использовать безопасный протокол SSL (Secure Sockets Layer) при подключении к серверу POP3 / IMAP. Если серверу необходим протокол SSL, то это требование накладывается на сервер администратором сети или поставщиком услуг Интернета. Обратите внимание, что, начиная с Fax Voip T.38 Модем версии 9.2.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip T.38 Модем использовали TLS версии 1.0.

Логин

Имя пользователя для авторизации на сервере POP3 / IMAP. Обычно оно совпадает с частью адреса электронной почты, находящейся слева от знака (@).

Пароль

Поле для ввода пароля, назначенного поставщиком услуг интернета. Пароль не требуется и игнорируется, если используется современная проверка подлинности OAuth 2.0.

Проверять новые сообщения каждые ... сек.

Интервал для проверки входящих сообщений электронной почты, используемый функцией Почта-на-факс. Может быть установлен от 10 до 60 секунд.

<Тест>

Используйте эту кнопку для тестирования POP3 / IMAP перед использованием.

Примечания

  • Если при отправке электронных писем с вложением, вложения каким-то образом "теряются" (странно...), попробуйте изменить тип входящего почтового сервера с IMAP на POP3 или попробуйте с другим сервером. В зависимости от сервера IMAP и его настроек, вы можете столкнуться с этой проблемой.
  • Если ваш сервер поддерживает как POP3 так и IMAP, рекомендуется использовать POP3. В случае некоторых серверов (например в случае pop.gmail.com / imap.gmail.com), входящие e-mail сообщения, принятые и удаленные через IMAP, могут затем быть получены повторно через POP3. Это может привести к путанице.
  • Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1. Чтобы настроить OAuth 2.0, см. Параметры OAuth 2.0 (POP3 / IMAP) .
  • Начиная с Fax Voip T.38 Модем версии 9.2.1, в случае защищенного соединения (SSL) используется TLS версии 1.2. Предыдущие версии Fax Voip T.38 Модем использовали TLS версии 1.0.
  • Чтобы использовать Fax Voip T.38 Модем с аккаунтом Gmail (обычная проверка подлинности) после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .
  • При использовании безопасного соединения (SSL), недействительные SSL сертификаты сервера POP3 / IMAP игнорируются.
  • Для проверки сделанных настроек воспользуйтесь кнопкой <Тест>, см. главу Тестирование POP3 / IMAP . Для просмотра журнала отправки сообщений, используйте опцию Вести протокол приема электронной почты, см. главу Журналы электронной почты настоящего справочного руководства.


Параметры OAuth 2.0

Параметры OAuth 2.0 (POP3 / IMAP)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Параметры POP3/IMAP ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1.

На этой странице задаются настройки OAuth 2.0, которые будут использоваться при приеме сообщений электронной почты через сервер POP3 или IMAP, см. также главу Параметры POP3 / IMAP настоящего справочного руководства. Используйте кнопку <Refresh Token>, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год) и предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). После настройки параметров OAuth 2.0 и получения Refresh Token, нажмите <Применить>, чтобы сохранить настройки.

Нажмите, чтобы настроить параметры POP3/IMAP

Нажмите чтобы настроить Параметры POP3 / IMAP .

<Загрузить профиль>

Нажмите, чтобы загрузить предопределенные настройки, выбранные из раскрывающегося списка справа. В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird . Можно выбрать следующие варианты (тестировалось с Fax Voip T.38 Модем):

Google / Gmail.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Gmail . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию По умолчанию или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .

Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net), Internet Explorer или По умолчанию. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Microsoft ( Office 365 , Hotmail, Outlook.com ). Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .

Yahoo.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yahoo! . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .

Yandex.com (Fax Voip)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Yandex.com (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Yandex.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию WebBrowser (.Net) или Internet Explorer. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .

Mail.ru (Thunderbird)

Выберите этот вариант, чтобы настроить Fax Voip T.38 Модем для использования с учетной записью Mail.ru . Для получения Refresh Token, в области Открыть запрос авторизации в этом браузере, выберите опцию Internet Explorer или WebBrowser (.Net). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .

Адрес авторизации

Адрес сервера авторизации (Authorization URI), на который направляется запрос на авторизацию. Сервер авторизации используется для аутентификации и авторизации и возвращает разрешение на авторизацию (код авторизации) клиентскому приложению.

Адрес получения токена

Адрес получения токена (Token URI), который используется клиентским приложением для обмена кода авторизации или Refresh Token на токен доступа (access token).

Разрешения (Scope)

Разделенный пробелами список разрешений. Разрешения OAuth 2.0 (scopes) позволяют ограничить уровень доступа, предоставляемого токену доступа (access token).

Идентификатор клиента

Публичный идентификатор клиентского приложения (Client ID).

Секретный ключ

Секретный ключ (Client Secret) используется для аутентификации подлинности приложения для API сервиса, когда приложение запрашивает доступ к учетной записи пользователя. Может быть пустой строкой для "публичного" приложения.

Адрес перенаправления

Адрес (Redirect URI), на который пользователь будет перенаправлен после того, как он разрешил приложению доступ. Он должен соответствовать одному из адресов перенаправления, зарегистрированных разработчиком при создании приложения. Сервер авторизации должен отклонить запрос, если указанный адрес не совпадает с зарегистрированным для приложения.

Адрес электр. почты

Адрес электронной почты, соответствующий учетной записи пользователя.

Refresh Token

Refresh Token предназначен для автоматического получения токена доступа (Access Token) во время отправки или получения сообщений электронной почты (без взаимодействия с пользователем). Refresh Token действителен в течении долгого времени (обычно один год). Для получения Refresh Token, используйте кнопку <Refresh Token>.

<Refresh Token>

Используйте эту кнопку, чтобы отправить запрос на авторизацию, подтвердить данные вашей учетной записи и получить Refresh Token (процедура выполняется в отдельном окне веб-браузера и требует взаимодействия с пользователем).

Открыть запрос авторизации в этом браузере

Выберите один из вариантов ниже. Мы предлагаем 3 различных метода, так как в зависимости от почтового сервера OAuth 2.0 и параметра Адрес перенаправления (Redirect URI), который задается разработчиком при создании приложения, некоторые из них могут не работать.

Internet Explorer

Если выбран этот вариант, для обработки запроса на авторизацию используется InternetExplorer object (веб-браузер Windows Internet Explorer). Этот вариант работает со всеми провайдерами электронной почты OAuth 2.0, которые были протестированы. Обратите внимание, что этот вариант также работает в Windows 11, где Microsoft заблокировала браузер Internet Explorer.

WebBrowser (.Net)

Если выбран этот вариант, для обработки запроса на авторизацию используется элемент управления WebBrowser (.NET Framework). Обратите внимание, что этот вариант не работает с Gmail (ошибка 'неподдерживаемый браузер').

По умолчанию

Если выбран этот вариант, для обработки запроса на авторизацию используется веб-браузер по умолчанию. Обратите внимание, что этот вариант работает только с приложениями, для которых разработчик явно указал Адрес перенаправления (Redirect URI) = http://127.0.0.1. Кроме того, при этом используется случайный неиспользуемый порт, что не всегда поддерживается провайдером электронной почты OAuth 2.0. Окно браузера должно быть закрыто пользователем вручную. В наших тестах это работало только с Gmail и Microsoft (профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test)). Тестировалось с Microsoft Edge и Internet Explorer в качестве веб-браузеров по умолчанию.

<Очистить>

Нажмите, чтобы очистить все текстовые поля на данной странице.

Использовать параметры OAuth 2.0 (SMTP)

Установите этот флажок, чтобы использовать одну и ту же учетную запись для исходящих и входящих сообщений электронной почты. Если выбрана эта опция, Параметры OAuth 2.0 (SMTP) также используются для POP3 / IMAP.

Примечания

  • В качестве 'приложения OAuth 2.0', мы в основном использовали пары Идентификатор клиента / Секретный ключ, импортированные из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте вашего провайдера электронной почты OAuth 2.0.


Тестирование POP3 / IMAP

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Параметры POP3/IMAP ››

Проверка подключения к серверу POP3 / IMAP

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите POP3/IMAP. Нажмите кнопку <Тест>.

3. Подробности сеанса связи с сервером входящей почты будут отображаться в окне Тестирование сервера входящей почты. Чтобы закрыть окно, нажмите <Закрыть>. Обратите внимание, что Fax Voip T.38 Модем не загружает сообщения с сервера и не удаляет их в процессе тестирования.

Просмотр протокола POP3 / IMAP

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, затем нажмите Журналы электронной почты. Затем поставьте флажок у параметра Вести протокол приема электронной почты и нажмите кнопку <Применить>.

Для просмотра протокола приема сообщений POP3 / IMAP нажмите кнопку <Просмотр>, расположенную рядом с флажком Вести протокол приема электронной почты.


Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

Современная проверка подлинности (авторизация на основе маркеров OAuth 2.0) в настоящее время используется многими известными системами электронной почты, такими как Gmail , Microsoft ( Office 365 , Hotmail, Outlook.com ), Yahoo! , Yandex.ru , Mail.ru и постепенно замещает обычную проверку подлинности. OAuth 2.0 поддерживается, начиная с Fax Voip T.38 Модем версии 9.3.1.

Чтобы настроить OAuth 2.0 для отправки сообщений электронной почты через сервер SMTP, см. Параметры OAuth 2.0 (SMTP) .

Чтобы настроить OAuth 2.0 для приема сообщений электронной почты через сервер POP3 или IMAP, см. Параметры OAuth 2.0 (POP3 / IMAP) .

Ниже приведены примеры настройки Fax Voip T.38 Модем с провайдерами электронной почты OAuth 2.0:

  • Настройка SMTP, POP3 и IMAP с учетной записью Google (Gmail.com) с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Microsoft (Office 365, Hotmail, Outlook.com) с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Yahoo.com с использованием OAuth 2.0
  • Настройка SMTP и IMAP с учетной записью Yandex.ru с использованием OAuth 2.0
  • Настройка SMTP, POP3 и IMAP с учетной записью Mail.ru с использованием OAuth 2.0


Google (Gmail.com)

Настройка SMTP, POP3 и IMAP с учетной записью Google (Gmail.com) с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Google / Gmail.com (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Gmail . В области Открыть запрос авторизации в этом браузере, выберите По умолчанию или Internet Explorer. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войдите в аккаунт Google, выберите правильную учетную запись или убедитесь, что введен правильный адрес электронной почты, а затем нажмите Далее.

6. На следующей странице введите пароль и нажмите Далее.

7. Если для вашей учетной записи Gmail включена двухэтапная аутентификация, введите код подтверждения, полученный от Google. При необходимости установите флажок Больше не спрашивать на этом устройстве. Затем нажмите Далее.

8. На следующей странице нажмите Разрешить, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Gmail.

9. Если в области Открыть запрос авторизации в этом браузере была выбрана опция По умолчанию, закройте окно веб-браузера вручную.

10. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-10 для Параметров OAuth 2.0 (POP3 / IMAP) .

12. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Gmail

Сервер SMTP: smtp.gmail.com

Порт: 465

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Implicit

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

13. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.gmail.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

14. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.gmail.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Gmail

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Google .
  • Чтобы настроить SMTP, POP3 и IMAP с Gmail с использованием обычной проверки подлинности, после 30 Мая 2022 года, вам необходимо включить двухэтапную аутентификацию для учетной записи Gmail, а затем сгенерировать пароль приложения в разделе Безопасность. Пароль приложения следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Google. Дополнительные сведения см. на форуме Microsoft . См. также видео на YouTube .


Microsoft (Office 365, Hotmail, Outlook.com)

Настройка SMTP, POP3 и IMAP с учетной записью Microsoft (Office 365, Hotmail, Outlook.com) с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird) или Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Microsoft. В области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net) или Internet Explorer. Если на предыдущем шаге вы выбрали Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test), то также можно выбрать браузер По умолчанию. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера введите пароль и нажмите Вход.

6. На следующей странице нажмите Да, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Microsoft.

7. Если в области Открыть запрос авторизации в этом браузере была выбрана опция По умолчанию, закройте окно веб-браузера вручную.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Microsoft

Сервер SMTP: outlook.office365.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: outlook.office365.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

12. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: outlook.office365.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Microsoft

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • Профиль Microsoft / Office 365 / Hotmail / Outlook.com (Thunderbird) использует Идентификатор клиента, импортированный из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Профиль Microsoft / Office 365 / Hotmail / Outlook.com (MS Oauth Test) использует Идентификатор клиента, который мы нашли на веб-сайте EmailArchitect . Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Microsoft .
  • Обратите внимание, что отправка сообщений электронной почты через SMTP с использованием OAuth 2.0 или прием сообщений электронной почты через POP3 с использованием OAuth 2.0 может не работать. Проблема предположительно на стороне Microsoft и связана с типом учетной записи Microsoft (Office 365, Microsoft Exchange, Hotmail / Outlook.com) и ее настройками. С одной стороны, Microsoft постоянно предупреждает об отключении обычной проверки подлинности для пользователей Office 365 и Exchange Online: Прекращение поддержки обычной проверки подлинности в Exchange Online . С другой стороны, что-то может не работать и проблема сохраняется несколько дней, недель или даже месяцев. Наши последние тесты с обычной учетной записью Microsoft (Hotmail/Outlook.com) показывают, что все протоколы (подключение IMAP, POP3 и SMTP с помощью OAuth 2.0) работают должным образом (июнь 2023 г.). Однако, исходя из всего вышесказанного, для большинства учетных записей Microsoft в настоящее время представляется разумным использовать обычную проверку подлинности.


Yahoo.com

Настройка SMTP, POP3 и IMAP с учетной записью Yahoo.com с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Yahoo.com (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Yahoo! . В области Открыть запрос авторизации в этом браузере, выберите Internet Explorer или WebBrowser (.Net). Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти с использованием учетной записи Yahoo, убедитесь, что введен правильный адрес электронной почты, а затем нажмите Далее.

6. На следующей странице введите пароль и нажмите Далее.

7. На следующей странице нажмите Принять, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Yahoo!.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Сервер SMTP: smtp.mail.yahoo.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.mail.yahoo.com

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

12. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.mail.yahoo.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yahoo!

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yahoo .
  • Чтобы настроить SMTP, POP3 и IMAP с Yahoo! с использованием обычной проверки подлинности, вам необходимо сгенерировать пароль приложения в разделе Настройки безопасности учетной записи. Пароль приложения следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Yahoo!. Обратите внимание, что эта функция может быть недоступна для вновь созданных учетных записей.


Yandex.ru

Настройка SMTP и IMAP с учетной записью Yandex.ru с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Yandex.com (Fax Voip), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Yandex.ru . В области Открыть запрос авторизации в этом браузере, выберите WebBrowser (.Net) или Internet Explorer. Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти с Яндекс ID, убедитесь, что введен правильный адрес электронной почты, а затем нажмите Войти.

6. На следующей странице введите пароль и нажмите Войти.

7. На следующей странице нажмите Войти как..., чтобы подтвердить запрошенный доступ к вашему почтовому ящику Yandex.ru.

8. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

9. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-8 для Параметров OAuth 2.0 (POP3 / IMAP) .

10. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Сервер SMTP: smtp.yandex.com

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

11. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (IMAP):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.yandex.com

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Yandex.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • Профиль Yandex.com (Fax Voip) использует 'приложение OAuth 2.0' (пару Идентификатор клиента / Секретный ключ), которое было зарегистрировано нашими разработчиками. Профиль Yandex.com (Thunderbird) использует пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ) - по независящим от нас причинам в последнее время (июнь 2023) не работает и возвращает ошибку 400 redirect_uri does not match the Callback URL defined for the client при попытке сгенерировать Refresh Token. Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Yandex .
  • Обратите внимание, что прием сообщений электронной почты по протоколу POP3 с использованием cовременной проверки подлинности OAuth 2.0 в настоящее время не поддерживается в Yandex.ru . В этом случае следует использовать обычную проверку подлинности (POP3 сервер входящей почты: pop.yandex.com, порт 995).
  • Чтобы настроить SMTP, POP3 и IMAP с Yandex.ru с использованием обычной проверки подлинности, в зависимости от настроек вашего аккаунта, вы можете использовать основной пароль учетной записи, либо сгенерировать пароль приложения в разделе Безопасность.


Mail.ru

Настройка SMTP, POP3 и IMAP с учетной записью Mail.ru с использованием OAuth 2.0

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Настройка SMTP, POP3 и IMAP с использованием OAuth 2.0 ››

1. Откройте Панель управления Fax Voip T.38 Модем. В дереве нажмите Электронная почта, затем нажмите SMTP. На странице Параметры сервера исходящей почты (SMTP), установите флажок Авторизация по протоколу OAuth 2.0.

2. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. На странице Параметры сервера входящей почты (POP3/IMAP), установите флажок Авторизация по протоколу OAuth 2.0.

3. В дереве нажмите Электронная почта, затем нажмите SMTP, затем нажмите OAuth 2.0. На странице Параметры OAuth 2.0 (SMTP), установите флажок Использовать эти параметры OAuth 2.0 для POP3 / IMAP. Из раскрывающегося списка выберите Mail.ru (Thunderbird), а затем нажмите кнопку <Загрузить профиль>.

4. В текстовом поле Адрес электр. почты, введите адрес электронной почты, связанный с вашей учетной записью Mail.ru . В области Открыть запрос авторизации в этом браузере, выберите Internet Explorer или WebBrowser (.Net). Нажмите кнопку <Refresh Token>.

5. В окне веб-браузера, на странице Войти в почту, убедитесь, что введен правильный адрес электронной почты. Введите пароль, а затем нажмите Войти в почту.

6. На следующей странице нажмите Разрешить, чтобы подтвердить запрошенный доступ к вашему почтовому ящику Mail.ru.

7. Убедитесь, что Refresh Token был успешно сгенерирован. Нажмите кнопку <Применить>, чтобы сохранить настройки и Refresh Token.

8. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP, затем нажмите OAuth 2.0. Чтобы использовать 2 разные учетные записи для исходящих и входящих сообщений электронной почты, снимите флажок Использовать параметры OAuth 2.0 (SMTP), а затем повторите шаги 3-7 для Параметров OAuth 2.0 (POP3 / IMAP) .

9. В дереве нажмите Электронная почта, затем нажмите SMTP. Проверьте, что используются следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Метод отправки E-mail: SecureSmtpClient

E-mail отправителя: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Сервер SMTP: smtp.mail.ru

Порт: 587

Подключаться через безопасное соединение (SSL): ДА

Режим SSL: Explicit (STARTTLS)

Требуется проверка подлинности: ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы отправить тестовое сообщение электронной почты, см. также Отправка пробного e-mail .

10. В дереве нажмите Электронная почта, затем нажмите POP3/IMAP. Проверьте, что используются следующие настройки (POP3):

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: POP3

Сервер входящей почты: pop.mail.ru

Порт: 995

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу POP3, см. также Тестирование POP3 / IMAP .

11. Чтобы использовать протокол IMAP для получения сообщений электронной почты, используйте следующие настройки:

Авторизация по протоколу OAuth 2.0: ДА

Тип сервера: IMAP

Сервер входящей почты: imap.mail.ru

Порт: 993

Подключаться через безопасное соединение (SSL): ДА

Логин: адрес электронной почты, связанный с вашей учетной записью Mail.ru

Нажмите кнопку <Тест>, чтобы протестировать подключение к серверу IMAP, см. также Тестирование POP3 / IMAP .

Примечания

  • В качестве 'приложения OAuth 2.0', мы использовали пару Идентификатор клиента / Секретный ключ, импортированную из почтового клиента Mozilla Thunderbird (исходные коды доступны на этой странице ). Кроме того, вы можете создать собственное 'приложение OAuth 2.0', см. инструкции на веб-сайте Mail.ru .
  • Чтобы настроить SMTP, POP3 и IMAP с Mail.ru с использованием обычной проверки подлинности, вам необходимо сгенерировать пароль для внешних приложений в разделе Безопасность. Пароль для внешних приложений следует использовать в настройках Fax Voip T.38 Модем вместо основного пароля для вашей учетной записи Mail.ru.


Шаблоны электронной почты

Панель управления Fax Voip T.38 Модем ›› Электронная почта ››

Шаблоны электронной почты позволяют изменять стандартный текст сообщений e-mail, используемых в программе. Как тема, так и текст сообщения электронной почты могут быть изменены в соответствии с вашими требованиями и предпочтениями.

Fax Voip T.38 Модем отправляет сообщения e-mail в следующих случаях:

  • Почта-на-факс - Microsoft Fax . Уведомления об успешной или неудачной доставке факса на адрес электронной почты отправителя.
  • Маршрутизация входящих факсов: отправить по электронной почте (Microsoft Fax) . Пересылка принятых факсов получателям e-mail.
  • Маршрутизация исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax) . Уведомления об успешной или неудачной доставке факса на заранее заданный адрес(а) электронной почты.

Содержание e-mail сообщений различно для различных функций, таким образом каждый шаблон должен быть сконфигурирован индивидуально. В шаблонах можно использовать так называемые %переменные%, которые заменяются фактическими данными. Примеры: %CallerID%, %PagesReceived%, %Duration% и т.д. Доступные наборы переменных различны для различных шаблонов. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку Вставить переменную справа от текстового поля, а затем выберите переменную из выпадающего меню. Чтобы восстановить Тему сообщения или Текст сообщения, предлагаемые по умолчанию (не путать с встроенным в программный код шаблоном по умолчанию, см. описание опции Использовать шаблон по умолчанию), полностью очистите текстовое поле, а затем нажмите Применить.

Следующие шаблоны доступны для конфигурирования:

  • Получен новый факс (служба Microsoft Fax) . Используется с методом маршрутизации: отправить по электронной почте (Microsoft Fax) .
  • Факс успешно отправлен (служба Microsoft Fax) . Используется с функцией Почта-на-факс - Microsoft Fax и методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) в случае успешно отправленного факса.
  • Не удалось отправить факс (служба Microsoft Fax) . Используется с функцией Почта-на-факс - Microsoft Fax и методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) в случае неудачной отправки факса.
  • Не удалось создать задание факса . Используется с функцией Почта-на-факс - Microsoft Fax в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный файл в правильный формат, указан некорректный номер факса получателя, адрес электронной почты заблокирован и т.д.).

Выберите шаблон

Используйте это поле с выпадающим списком для выбора шаблона, который вы хотите изменить.

Использовать шаблон по умолчанию

Установите этот флажок, если вы не хотите настраивать выбранный шаблон.

Примечания

  • Для получения дополнительной информации по настройке конкретного шаблона, пожалуйста прочтите соответствующий раздел данной главы.


Получен новый факс (служба Microsoft Fax)

Шаблоны электронной почты: Получен новый факс (служба Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Получен новый факс (служба Microsoft Fax) используется с методом маршрутизации: отправить по электронной почте (Microsoft Fax) при пересылке принятых факсов получателям e-mail. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Получен новый факс (служба Microsoft Fax). Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (получен новый факс)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Получен новый факс (служба Microsoft Fax) можно использовать следующие переменные (заменяются фактическими данными):

  • %CallerID%. Номер телефона вызывающего устройства.
  • %CalledNumber%. Номер телефона вызываемого абонента (DID).
  • %RemoteFaxID%. Код передающего абонента (TSID), полученный от отправителя факса.
  • %LocalFaxID%. Код вызываемого абонента (CSID), переданный отправителю факса, чтобы идентифицировать вас как получателя факса.
  • %StartTime%. Время начала выполнения задания факса, связанного с приемом факсимильного документа.
  • %EndTime%. Время окончания выполнения задания факса, связанного с приемом факсимильного документа.
  • %Duration%. Общее время, прошедшее между началом и окончанием приема факса.
  • %PagesReceived%. Количество страниц в принятом факсимильном документе.
  • %DeviceName%. Имя устройства, которое приняло факсимильный документ. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
  • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с приемом факсимильного документа.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip T.38 Модем.
  • %RemoteFaxIDOrCallerID%. Механизм замещения следующий: эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае строка неизвестный отправитель.
  • %CallerIDOrRemoteFaxID%. Механизм замещения следующий: эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае строка неизвестный отправитель.
  • %CallerIDAndRemoteFaxID%. Механизм замещения следующий: эквивалентно %CallerID% (%RemoteFaxID%) если как CallerID так и Fax ID отправителя – не пустые строки; в противном случае эквивалентно %CallerID% если CallerID – не пустая строка; в противном случае эквивалентно %RemoteFaxID% если Fax ID отправителя – не пустая строка; в противном случае строка неизвестный отправитель. Пример: 19012223344 ( (901) 222-3344).

Примечания

  • При использовании метода маршрутизации: отправить по электронной почте (Microsoft Fax) , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных правил, см. главу Шаблоны электронной почты (Отправить по электронной почте, Microsoft Fax) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Факс успешно отправлен (служба Microsoft Fax)

Шаблоны электронной почты: Факс успешно отправлен (служба Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Факс успешно отправлен (служба Microsoft Fax) используется с функцией Почта-на-факс - Microsoft Fax и методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) при отправке уведомлений об успешной доставке факса на адрес электронной почты отправителя или на заранее заданный адрес(а) электронной почты соответственно. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Факс успешно отправлен (служба Microsoft Fax). Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (факс успешно отправлен)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Факс успешно отправлен (служба Microsoft Fax) можно использовать следующие переменные (заменяются фактическими данными):

  • %RecipientFaxNumber%. Номер факса получателя.
  • %RecipientName%. Имя получателя.

  • %SenderEmail%. Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс - Microsoft Fax , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %SenderName%. Имя отправителя.
  • %SenderFaxNumber%. Номер факса отправителя.
  • %SenderFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается получателю при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание переменной %LocalFaxID%.
  • %SenderCompany%. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • %SenderDepartment%. Имя отдела отправителя.
  • %SenderTitle%. Должность отправителя.
  • %SenderOfficeLocation%. Номер офиса (комнаты) отправителя.
  • %SenderHomePhone%. Номер домашнего телефона отправителя.
  • %SenderOfficePhone%. Номер рабочего телефона отправителя.
  • %SenderAddress%. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • %SenderBillingCode%. Код биллинга, связанный с отправителем.

  • %DocumentName%. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При использовании с методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) и отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
  • %HasCoverPage%. Указывает, содержит ли факс титульную страницу.
  • %Subject%. Содержит тему факса (отображается на титульной странице).
  • %PagesTotal%. Общее количество страниц в отправленном факсимильном сообщении.
  • %TiffSize%. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с отправленным факсом, в килобайтах.

  • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с %SenderFaxID%, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
  • %Priority%. Важность отправленного факса; например обычная, низкая или высокая.
  • %SubmissionTime%. Время формирования задания исходящего факса.
  • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • %StartTime%. Время начала передачи исходящего факса.
  • %EndTime%. Время окончания передачи исходящего факса.
  • %Duration%. Продолжительность передачи исходящего факса.
  • %Retries%. Число предпринятых системой неудачных попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • %DeviceName%. Имя устройства, которое использовалось при отправке факса. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
  • %Status%. Результат отправки факса. OK в случае успешной отправки факса.
  • %FaxMessageID%. Уникальный номер, который идентифицирует отправленное факсимильное сообщение. Совпадает с идентификатором, который был присвоен заданию исходящего факса при его формировании.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip T.38 Модем.

Следующие переменные являются устаревшими и поддерживаются только для совместимости с предыдущими версиями, не используйте их в новых шаблонах:

  • %FaxNumber%. Номер факса получателя. Вместо этого используйте %RecipientFaxNumber%.
  • %EmailFrom%. Адрес электронной почты отправителя. Вместо этого используйте %SenderEmail%.
  • %FaxHeader%. Текст, передаваемый в верхней части каждой страницы факса. Вместо этого используйте %SenderCompany%.
  • %OriginalFileName%. В случае создания факса функцией Почта-на-факс, исходное имя документа, включая расширение файла. Вместо этого используйте %DocumentName%.
  • %OriginalSheduledTime%. (опечатка в версиях до Fax Voip 8.1.1) Время, на которое первоначально была запланирована отправка факсимильного сообщения. Вместо этого используйте %OriginalScheduledTime%.

Примечания

  • При использовании функции Почта-на-факс - Microsoft Fax , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты, Microsoft Fax) настоящего справочного руководства.
  • При использовании метода маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных правил, см. главу Шаблоны электронной почты (Уведомления о доставке по электронной почте, Microsoft Fax) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Не удалось отправить факс (служба Microsoft Fax)

Шаблоны электронной почты: Не удалось отправить факс (служба Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Не удалось отправить факс (служба Microsoft Fax) используется с функцией Почта-на-факс - Microsoft Fax и методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) при отправке уведомлений о неудачной доставке факса на адрес электронной почты отправителя или на заранее заданный адрес(а) электронной почты соответственно. Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Не удалось отправить факс (служба Microsoft Fax). Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (не удалось отправить факс)

Тема сообщения e-mail.

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных следующими переменными: %SubmissionTime%, %OriginalScheduledTime%, %StartTime%, %EndTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Не удалось отправить факс (служба Microsoft Fax) можно использовать следующие переменные (заменяются фактическими данными):

  • %RecipientFaxNumber%. Номер факса получателя.
  • %RecipientName%. Имя получателя.

  • %SenderEmail%. Адрес электронной почты отправителя. В случае создания факса функцией Почта-на-факс - Microsoft Fax , это адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %SenderName%. Имя отправителя.
  • %SenderFaxNumber%. Номер факса отправителя.
  • %SenderFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification) для устройства отправителя, указанный в сведениях об отправителе . Передается получателю при отправке факса и может быть выведен на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Обратите внимание, что в зависимости от настроек факс сервера, значение этой переменной может отличаться от фактически переданного идентификатора факса, см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства. См. также описание переменной %LocalFaxID%.
  • %SenderCompany%. Название организации отправителя. Обычно передается в верхней части каждой страницы отправляемого факса в качестве заголовка факса (Fax Headline).
  • %SenderDepartment%. Имя отдела отправителя.
  • %SenderTitle%. Должность отправителя.
  • %SenderOfficeLocation%. Номер офиса (комнаты) отправителя.
  • %SenderHomePhone%. Номер домашнего телефона отправителя.
  • %SenderOfficePhone%. Номер рабочего телефона отправителя.
  • %SenderAddress%. Адрес отправителя. Обычно включает город, область, почтовый индекс и страну.
  • %SenderBillingCode%. Код биллинга, связанный с отправителем.

  • %DocumentName%. В случае создания факса функцией Почта-на-факс - Microsoft Fax , исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой. При использовании с методом маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) и отправке факса обычным способом (т.е. из программы Факсы и сканирование Windows), может постоянно заменяться бессмысленной строкой (например 'Test Fax'), из-за ошибок в программном обеспечении Microsoft Fax.
  • %HasCoverPage%. Указывает, содержит ли факс титульную страницу.
  • %Subject%. Содержит тему факса (отображается на титульной странице).
  • %PagesTotal%. Общее количество страниц в отправленном факсимильном сообщении.
  • %TiffSize%. Размер файла TIFF (Tagged Image File Format Class F, TIFF Class F), связанного с отправленным факсом, в килобайтах.

  • %RemoteFaxID%. Идентификатор принимающей станции (CSID, Called Subscriber Identification), принятый от получателя факса. Код CSID обычно состоит из номера факса получателя и названия организации.
  • %LocalFaxID%. Идентификатор передающей станции (TSID, Transmitting Subscriber Identification), который был фактически передан получателю. В зависимости от настроек факс сервера, он может совпадать с %SenderFaxID%, либо с TSID указанным в настройках факс устройства, которое использовалось для передачи факса.
  • %Priority%. Важность отправляемого факса; например обычная, низкая или высокая.
  • %SubmissionTime%. Время формирования задания исходящего факса.
  • %OriginalScheduledTime%. Время, на которое первоначально была запланирована отправка факсимильного сообщения.
  • %StartTime%. Время начала передачи исходящего факса.
  • %EndTime%. Время окончания передачи исходящего факса.
  • %Duration%. Продолжительность передачи исходящего факса.
  • %Retries%. Число предпринятых системой попыток отправить факс. Общее число разрешенных повторов зависит от установленного предельного значения.
  • %PagesTransferred%. Число успешно переданных страниц факса.
  • %DeviceName%. Имя устройства, которое использовалось при попытке отправить факс. Пример: Fax Voip 14.4K TAPI Voice-Fax Modem #2.
  • %Status%. Результат отправки факса. Пример: НЕТ_ОТВЕТА.
  • %StatusText%. Описание ошибки. Пример: Вызов не был отвечен.
  • %FaxMessageID%. Уникальный номер, который идентифицирует задание факса, связанное с отправкой факсимильного документа.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip T.38 Модем.

Следующие переменные являются устаревшими и поддерживаются только для совместимости с предыдущими версиями, не используйте их в новых шаблонах:

  • %FaxNumber%. Номер факса получателя. Вместо этого используйте %RecipientFaxNumber%.
  • %EmailFrom%. Адрес электронной почты отправителя. Вместо этого используйте %SenderEmail%.
  • %FaxHeader%. Текст, передаваемый в верхней части каждой страницы факса. Вместо этого используйте %SenderCompany%.
  • %OriginalFileName%. В случае создания факса функцией Почта-на-факс, исходное имя документа, включая расширение файла. Вместо этого используйте %DocumentName%.
  • %OriginalSheduledTime%. (опечатка в версиях до Fax Voip 8.1.1) Время, на которое первоначально была запланирована отправка факсимильного сообщения. Вместо этого используйте %OriginalScheduledTime%.

Примечания

  • При использовании функции Почта-на-факс - Microsoft Fax , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты, Microsoft Fax) настоящего справочного руководства.
  • При использовании метода маршрутизации: уведомления о доставке по электронной почте (Microsoft Fax) , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных правил, см. главу Шаблоны электронной почты (Уведомления о доставке по электронной почте, Microsoft Fax) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Не удалось создать задание факса

Шаблоны электронной почты: Не удалось создать задание факса

Панель управления Fax Voip T.38 Модем ›› Электронная почта ›› Шаблоны электронной почты ››

Шаблон Не удалось создать задание факса используется с функцией Почта-на-факс - Microsoft Fax в случае каких-либо ошибок при создании факса (невозможно преобразовать исходный файл в правильный формат, указан некорректный номер факса получателя, адрес электронной почты заблокирован и т.д.). Чтобы изменить этот шаблон, в поле со списком Выберите шаблон, выберите Не удалось создать задание факса. Чтобы использовать шаблон по умолчанию, установите флажок Использовать шаблон по умолчанию.

Тема сообщения (не удалось отправить факс)

Тема сообщения e-mail в случае ошибок при создании факса (невозможно преобразовать исходный файл в правильный формат, указан некорректный номер факса получателя и т.д.).

Тема сообщения (E-mail адрес заблокирован)

Тема сообщения e-mail в случае если адрес электронной почты отправителя заблокирован (в соответствии с настройками программы).

Текст сообщения

Содержание сообщения электронной почты.

Вставить переменную

Используйте эту кнопку для вставки переменной в текстовое поле слева от нее. Чтобы вставить переменную в текст, поместите курсор в нужное место (либо выделите часть текста, которую вы хотите заменить), нажмите кнопку, а затем выберите переменную из выпадающего меню. Обратите внимание, каждое текстовое поле имеет собственную кнопку Вставить переменную, которая расположена справа от текстового поля.

Форматы даты и времени

Выберите региональный стандарт (регион и язык), чтобы указать способ отображения значений даты и времени для текущего шаблона. Пример форматирования даты и времени для текущего выбора отображается ниже в поле Пример. Этот выбор влияет на отображение значений даты и времени, определенных переменной %SubmissionTime%. По умолчанию дата и время форматируются в соответствии с настройками операционной системы.

Использовать форматы даты и времени по умолчанию, в соответствии с языком интерфейса Windows

Нажмите эту кнопку, чтобы выбрать форматы даты и времени, соответствующие языку интерфейса Windows (для текущего пользователя).

С шаблоном Не удалось создать задание факса можно использовать следующие переменные (заменяются фактическими данными):

  • %FaxRecipients%. В зависимости от характера ошибки, список получателей факса, либо тема сообщения e-mail, полученного от отправителя сообщения.
  • %SenderEmail%. Адрес электронной почты отправителя, извлеченный из сообщения e-mail.
  • %EmailSubject%. Тема сообщения e-mail, полученного от отправителя сообщения.
  • %DocumentName%. Исходное имя документа, включая расширение файла. При отправке нескольких документов их имена разделяются точкой с запятой. При отправке факса, состоящего только из титульной страницы, заменяется пустой строкой.
  • %SubmissionTime%. Время получения e-mail сообщения.
  • %Status%. Краткое описание ошибки создания факса.
  • %StatusText%. Полное описание ошибки создания факса.
  • %ComputerName%. Имя компьютера, на котором установлен Fax Voip T.38 Модем.

Следующие переменные являются устаревшими и поддерживаются только для совместимости с предыдущими версиями, не используйте их в новых шаблонах:

  • %FaxNumber%. Телефонный номер получателя факса. Вместо этого используйте %FaxRecipients%.
  • %PhoneNumber%. Телефонный номер получателя факса. Вместо этого используйте %FaxRecipients%.
  • %MsgRecipients%. Список получателей факса. Вместо этого используйте %FaxRecipients%.
  • %EmailFrom%. Адрес электронной почты отправителя, извлеченный из сообщения e-mail. Вместо этого используйте %SenderEmail%.
  • %OriginalFileName%. Исходное имя документа, включая расширение файла. Вместо этого используйте %DocumentName%.

Примечания

  • При использовании функции Почта-на-факс - Microsoft Fax , вы можете создавать персонализированные шаблоны электронной почты этого типа для разных адресов электронной почты, см. главу Шаблоны электронной почты (правило для почты, Microsoft Fax) настоящего справочного руководства.
  • Для получения общей информации по шаблонам электронной почты, см. главу Шаблоны электронной почты .


Общие параметры

Панель управления Fax Voip T.38 Модем ››

  • Общие параметры и протоколы
  • Журналы маршрутизации входящих факсов (Microsoft Fax)
  • Журналы маршрутизации исходящих факсов (Microsoft Fax)
  • Журналы электронной почты
  • Журналы SendFaxMS.exe (Microsoft Fax)
  • Многоязычная поддержка
  • Параметры системы


Общие параметры и протоколы

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

Вести протокол маршрутизации вызовов

Используйте эту опцию для настройки и тестирования Маршрутизации исходящих VOIP вызовов и Маршрутизации входящих VOIP вызовов . Файл протокола вызовов содержит подробную информацию о маршруте для каждого исходящего и входящего вызова. Анализ протокола поможет выявить ошибки и при необходимости скорректировать правила маршрутизации вызовов. Мы бы рекомендовали использовать данную опцию только в процессе настройки Fax Voip T.38 Модем или в случае возникновения проблем.

<Просмотр>

Используйте эту кнопку для просмотра протокола вызовов.

<Удалить>

Используйте эту кнопку для удаления файла протокола вызовов.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.

Автоматически проверять обновления

Установите флажок, чтобы Fax Voip T.38 Модем при запуске автоматически проверял наличие новой версии программы. Если новая версия доступна, отображается уведомление в области системного трея. Чтобы загрузить и установить новую версию, нажмите на уведомление. Fax Voip T.38 Модем проверяет обновления не чаще одного раза в сутки.

Запускать Fax Voip T.38 Модем как службу Windows

Выберите эту опцию чтобы запускать Fax Voip T.38 Модем как службу Windows, см. также Настройка Fax Voip T.38 Модем в качестве службы Windows . Обычно, когда Fax Voip T.38 Модем сконфигурирован в качестве службы, он запускается под системной учетной записью (Local System). Почтовая служба Fax Voip T.38 Модем должна запускаться от имени стандартной учетной записи пользователя, см. главу Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows . Для изменения данного параметра требуются права администратора.

Служба Почта-на-факс (через Microsoft Fax) запускается от имени учетной записи:

Имя учетной записи, от имени которой запускается служба Fax Voip T.38 Modem MsFax Mail (функция Почта-на-факс - Microsoft Fax ) - текущие настройки.

<Выбрать пользователя>

Нажмите, чтобы указать имя пользователя и пароль учетной записи, которая будет использоваться для запуска почтовой службы Fax Voip T.38 Модем, см. главу Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows . Требуются права администратора.

Автоматически запускать при загрузке Windows

Если данная опция включена и Fax Voip T.38 Модем сконфигурирован для работы в качестве службы Windows, он запускается до входа пользователя в систему (как служба). Если данная опция включена и Fax Voip T.38 Модем сконфигурирован для работы в качестве приложения, Fax Voip T.38 Модем запускается сразу же после входа пользователя в систему. Если Fax Voip T.38 Модем сконфигурирован для работы в качестве службы Windows, то для изменения данного параметра требуются права администратора.

Загружать значок в трей при загрузке Windows

Включите данную опцию если вы хотите загружать значок Fax Voip T.38 Модем в трей при загрузке Windows (после входа пользователя в систему). Заметим что если Fax Voip T.38 Модем сконфигурирован для работы в качестве службы Windows, присутствие иконки в трее не является обязательным для работы.

При запуске проверять доступность COM портов

Если эта опция включена, Fax Voip T.38 Модем проверяет доступность Виртуальных COM портов в течении максимум 10-ти секунд при запуске приложения. Используется в сочетании с режимом автозапуска эмуляции Виртуальных COM портов некоторых сторонних производителей во время загрузки операционной системы. Дело в том, что если вы запускаете Fax Voip T.38 Модем, а эмуляция портов еще не запущена, то Fax Voip T.38 Модем будет впоследствии недоступен через эти порты. (Имеет смысл использовать данную опцию совместно с использованием Eterlogic.com эмулятора виртуальных серийных портов ). Заметим что данная опция не будет работать, если включена опция Запускать Fax Voip T.38 Модем как службу Windows.


Журналы маршрутизации входящих факсов (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

Вести протокол модуля расширения маршрутизации Fax Voip T.38 Модем

Вести файл журнала отладки, в котором содержится необходимая информация о работе Расширения маршрутизации Fax Voip T.38 Модем. Расширение маршрутизации интегрировано в Службу факсов Windows. Для просмотра детализированных журналов отладки для конкретных методов маршрутизации для входящих факсов (Microsoft Fax) , воспользуйтесь опциями, описанными ниже.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки. Обратите внимание, что вы не можете удалить этот файл при запущенной службе факсов.

Очистка протокола модуля расшир. маршрутизации при запуске службы факсов

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске службы факсов.

Вести протокол метода маршрутизации 'Отправить по электронной почте (MS Fax)'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов: отправить по электронной почте (Microsoft Fax) . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации факсов через e-mail. Для просмотра детализированного журнала отправки сообщений e-mail, воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол метода маршрутизации 'Сохранить в папке (MS Fax)'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов: сохранить в папке (Microsoft Fax) . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол метода маршрутизации 'Печать (MS Fax)'

Эта опция помогает настроить и протестировать метод маршрутизации для входящих факсов: печать (Microsoft Fax) . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила печати входящих факсов.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы маршрутизации исходящих факсов (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

Вести протокол методов маршрутизации исходящих факсов (Microsoft Fax)

Эта опция помогает настроить и протестировать методы маршрутизации для исходящих факсов (Microsoft Fax) : уведомления о доставке по электронной почте , сохранить в папке , печать , пользовательский . Анализ журнала поможет выявить ошибки и при необходимости скорректировать правила маршрутизации факсов. Методы маршрутизации для исходящих факсов (Microsoft Fax) вызываются из модуля Почта-на-факс - Microsoft Fax (служба Fax Voip T.38 Modem MsFax Mail) и это отражается в другом журнале отладки, используйте опцию Вести протокол функции Почта-на-факс - служба факсов Windows, см. в главе Журналы электронной почты настоящего справочного руководства. Для просмотра детализированного журнала отправки сообщений e-mail (при использовании метода маршрутизации для исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax) , воспользуйтесь опцией Вести протокол отправки электронной почты, более подробную информацию см. в главе Журналы электронной почты настоящего справочного руководства.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы электронной почты

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

Вести протокол функции Почта-на-факс - служба факсов Windows

Эта опция помогает настроить и протестировать функцию Почта-на-факс - Microsoft Fax и Методы маршрутизации для исходящих факсов (Microsoft Fax) . Рекомендуется использовать эту опцию только при конфигурировании Fax Voip T.38 Модем или при возникновении проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Очистка протокола при запуске службы Почта-на-факс

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске подсистемы Почта-на-факс - Microsoft Fax , либо при запуске службы Fax Voip T.38 Modem MsFax Mail.

Вести протокол отправки электронной почты

Используйте эту опцию для настройки и тестирования параметров SMTP . Файл журнала содержит результаты отправки каждого сообщения e-mail. Используется с методом маршрутизации для входящих факсов: отправить по электронной почте (Microsoft Fax) , методом маршрутизации для исходящих факсов: уведомления о доставке по электронной почте (Microsoft Fax) , функцией Почта-на-факс - Microsoft Fax , а также при Тестировании отправки e-mail с помощью встроенного SMTP клиента . Мы бы рекомендовали использовать данную опцию только в процессе настройки Fax Voip T.38 Модем или в случае возникновения проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Вести протокол приема электронной почты

Используйте эту опцию для выявления ошибок при конфигурировании параметров POP3 / IMAP . В файле журнала протоколируется каждая сессия POP3 / IMAP (используется с функцией Почта-на-факс - Microsoft Fax ). Мы бы рекомендовали использовать данную опцию только в процессе настройки Fax Voip T.38 Модем или в случае возникновения проблем.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Журналы SendFaxMS.exe (Microsoft Fax)

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

Журнал отладки SendFaxMS.exe

В этой области вы можете просмотреть или удалить журнал отладки, создаваемый утилитой командной строки SendFaxMS.exe (Microsoft Fax) . Журнал отладки содержит подробную информацию о работе SendFaxMS.exe. Чтобы включить журнал отладки, запустите SendFaxMS.exe с параметром командной строки /DebugLog.

<Просмотр>

Используйте эту кнопку для просмотра журнала отладки.

<Удалить>

Используйте эту кнопку для удаления файла журнала отладки.

Очистка журнала отладки при каждом запуске SendFaxMS.exe

Установите флажок, чтобы автоматически удалять файл журнала отладки при запуске SendFaxMS.exe.

Простой журнал SendFaxMS.exe

В этой области вы можете просмотреть или удалить простой журнал, создаваемый утилитой командной строки SendFaxMS.exe (Microsoft Fax) . Простой журнал содержит краткую информацию о работе SendFaxMS.exe. Чтобы включить простой журнал, запустите SendFaxMS.exe с параметром командной строки /Log.

<Просмотр>

Используйте эту кнопку для просмотра журнала.

<Удалить>

Используйте эту кнопку для удаления файла журнала.

<Открыть папку данных>

Используйте эту кнопку чтобы открыть папку с файлами журналов отладки в проводнике Windows.


Многоязычная поддержка

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

В приложении Fax Voip T.38 Модем вы можете создавать и использовать так называемые Языковые профили. Таким образом, пользователь может перевести программу Fax Voip T.38 Модем (полностью или частично) на любой желаемый язык. Файлы с языковыми настройками сохраняются в папке *{CommonAppDataFolder}\FaxVoip Modem\Language. Имя подпапки, в которой сохраняются языковые файлы отдельно взятого профиля, совпадает с именем профиля. В качестве имени профиля как правило используется название языка. Языковые файлы представляют собой стандартные ini-файлы, сохраненные в кодировке Юникод (UTF-16). Имена ini файлов фиксированы и соответствуют различным модулям программы Fax Voip T.38 Модем.

После установки Fax Voip T.38 Модем следующие стандартные профили всегда присутствуют:

  • English (Default). Зарезервированное имя. Профиль по умолчанию, встроенный в программный код. Языковые ini файлы не используются. Нельзя редактировать или удалить этот профиль, но можно создать новый профиль с его использованием.
  • English. Зарезервированное имя. После установки программы совпадает с профилем по умолчанию. Однако языковые данные загружаются из ini файлов. В отличие от профиля по умолчанию, вы можете редактировать или удалить его. Что вы должны понимать, при переустановке программы или обновлении версии, языковые данные всегда заменяются данными по умолчанию. По этой причине лучше создавать новый языковой профиль, если вы планируете кастомизировать его.
  • Русский. Зарезервированное имя. Обеспечивает поддержку русского языка в программе. При использовании русскоязычного инсталлятора устанавливается в качестве текущего. Языковые данные загружаются из ini файлов. Вы можете редактировать или удалить его. Что вы должны понимать, при переустановке программы или обновлении версии с использованием русскоязычного инсталлятора, языковые данные всегда заменяются данными из файлов установщика. По этой причине лучше создавать новый языковой профиль, если вы планируете кастомизировать его. Обратите внимание, этот пакет не входит в базовую комплектацию Fax Voip T.38 Модем (стандартная версия на английском языке) и устанавливается только при использовании русскоязычного инсталлятора.

Чтобы добавить новый Языковой профиль, обратитесь к разделу Добавление языкового профиля .

Чтобы редактировать языковые данные, обратитесь к разделу Редактирование языкового профиля .

Для получения дополнительной информации по структуре языковых ini-файлов, обратитесь к разделу Языковые файлы .

Для изменения языка программы, установите флажок для нужного элемента в списке доступных Языковых профилей, см. рисунок ниже. Нажмите кнопку <Применить> для сохранения языковых настроек. Изменения вступят в силу немедленно. Тем не менее, мы рекомендуем полностью перезагрузить Fax Voip T.38 Модем после изменения настроек языка.

В контекстной вкладке Язык, на ленте доступны следующие команды:

Языковые профили

Добавить (Ctrl + N)

Нажмите чтобы добавить Языковой профиль.

Править (Ctrl + E)

Нажмите чтобы редактировать выбранный Языковой профиль. Или вы можете дважды щелкнуть мышью на выбранной записи.

Удалить (Del)

Нажмите чтобы удалить выбранный Языковой профиль.

Выделить

Выделить все (Ctrl + A)

Нажмите чтобы выделить все записи в списке.

Снять выделение (Ctrl + O)

Нажмите чтобы отменить выделение всех записей в списке.

Обратить выделение (Ctrl + I)

Нажмите чтобы обратить выделение записей в списке.

Папка

Папка профиля

Нажмите, чтобы открыть папку с языковыми файлами выбранного Языкового профиля в проводнике Windows.

Большинство команд из контекстной вкладки Язык также доступны в контекстном меню списка.

Примечания

  • *{CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Добавление языкового профиля

Панель управления Fax Voip T.38 Модем ›› Общие параметры ›› Многоязычная поддержка ››

Новый Языковой профиль может быть создан как копия одного из существующих профилей. Чтобы добавить новый профиль, следуйте инструкциям ниже:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, затем нажмите Язык.

3. Чтобы добавить Языковой профиль, нажмите Добавить.

4. В диалоговом окне Добавление языкового профиля, в поле Введите имя языкового профиля или выберите из списка, введите или выберите имя нового профиля. Мы рекомендуем использовать название языка в качестве имени профиля, но вы можете ввести любое имя, которое вам нравится.

5. Из раскрывающегося списка Копировать данные из, выберите имя существующего профиля, из которого вы хотите скопировать языковые данные.

6. Нажмите кнопку <OK>.

Новый профиль будет создан и отображен в списке языков. Для настройки профиля (редактирования языковых данных), см. главу Редактирование языкового профиля . Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>.


Редактирование языкового профиля

Панель управления Fax Voip T.38 Модем ›› Общие параметры ›› Многоязычная поддержка ››

После создания нового Языкового профиля, вы на самом деле имеете копию одного из ранее существовавших профилей, как правило English (Default). Для того, чтобы перевести программу на нужный язык, вам необходимо отредактировать новый Языковой профиль, используя один из методов описанных ниже в этой главе.

Редактирование Языкового профиля с использованием Графического интерфейса пользователя (GUI):

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, затем нажмите Язык.

3. Выберите профиль, который вы хотите редактировать, а затем нажмите Править.

4. В диалоговом окне Редактирование языкового профиля, из раскрывающегося списка Сравнивать со следующим профилем, выберите профиль, который будет использоваться для сравнения.

5. Нажмите кнопку <OK>.

6. В окне Редактирование языкового профиля:<имя языка>, выберите Имя ini-файла и Секцию для редактирования.

Таблица, показанная на рисунке ниже, содержит следующие столбцы:

Параметр

Внутреннее имя переменной, в которой сохраняется текст, который можно перевести. Имя переменной обычно ассоциируется с соответствующим текстом на английском языке.

Столбец #2 (текст для сравнения)

Отображает текст, соответствующий профилю, который был выбран для сравнения. Этот столбец используется исключительно для подсказок, его содержимое не может быть изменено.

Столбец #3 (текст для редактирования)

Отображает текст, соответствующий профилю, который был выбран для редактирования. Вы можете редактировать текст в этом столбце, чтобы сделать свой перевод.

7. Отредактируйте текст в третьем столбце. В случае нескольких строк текста, используйте сочетание символов \n для перехода на новую строку (поддерживается не со всеми параметрами).

8. После выполнения необходимых изменений, нажмите кнопку <Закрыть>.

Все изменения автоматически сохраняются, когда вы выбираете другое Имя ini-файла либо другую Секцию, а также при закрытии окна Редактирование языкового профиля:<имя языка>.

Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>. Если профиль уже используется, перезапустите Fax Voip T.38 Модем для обновления языковых данных (или дважды измените текущий профиль).

Редактирование языковых файлов вручную:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите Общие параметры, затем нажмите Язык.

3. Выберите профиль, который вы хотите редактировать, а затем нажмите Папка профиля.

4. Отредактируйте ini-файлы вручную с помощью Блокнота или другого текстового редактора. Для получения дополнительной информации по структуре языковых ini-файлов, обратитесь к разделу Языковые файлы .

Чтобы использовать профиль, установите флажок для элемента профиля, а затем нажмите <Применить>. Если профиль уже используется, перезапустите Fax Voip T.38 Модем для обновления языковых данных (или дважды измените текущий профиль).

Примечания

  • Языковой файл SendFaxMS.txt (справка для утилиты SendFaxMS.exe) является исключением. Его нельзя редактировать используя Графический интерфейс пользователя (GUI). Этот файл необходимо редактировать вручную.


Языковые файлы

Панель управления Fax Voip T.38 Модем ›› Общие параметры ›› Многоязычная поддержка ››

Файлы с языковыми настройками сохраняются в папке *{CommonAppDataFolder}\FaxVoip Modem\Language. Имя подпапки, в которой сохраняются языковые файлы отдельно взятого профиля, совпадает с именем профиля (как правило используется название языка). Языковые файлы представляют собой стандартные ini-файлы, сохраненные в кодировке Юникод (UTF-16). Имена ini файлов фиксированы и соответствуют различным модулям программы Fax Voip T.38 Модем. Исключением является языковой файл SendFaxMS.txt (справка для утилиты SendFaxMS.exe), который не является стандартным ini-файлом.

Структура ini-файла выглядит следующим образом:

[section1]

parameter11=value11

parameter12=value12

...

[section2]

parameter21=value21

parameter22=value22

...

В случае нескольких строк текста, для перехода на новую строку используется сочетание символов \n (поддерживается не со всеми параметрами). В случае отсутствия ini-файлов, секций или отдельных параметров, Fax Voip T.38 Модем использует строки по умолчанию из языкового профиля English (default) (для отсутствующих параметров).

Вы можете редактировать языковые данные вручную, путем редактирования строковых параметров в ini-файлах. Ниже вы найдете краткое описание языковых файлов Fax Voip T.38 Модем.

FaxVoipModemConfig.ini

Языковые настройки Панели управления Fax Voip T.38 Модем.

Секции:

[Form_ModemConfig] Общие элементы главной формы.

[Help] Справочная система.

[Menu] Контекстные меню.

[Ribbon_TabMain] Лента. Основная вкладка.

[Ribbon_TabView] Лента. Вкладка Вид.

[Ribbon_TabTools] Лента. Вкладка Инструменты.

[Ribbon_TabSIPAccounts] Лента. Контекстная вкладка Учетные записи SIP.

[Ribbon_TabOutgoingPlan] Лента. Контекстная вкладка Исходящие маршруты.

[Ribbon_TabIncomingPlan] Лента. Контекстная вкладка Входящие маршруты.

[Ribbon_TabRouteMainMS] Лента. Контекстная вкладка Методы для входящих (Microsoft Fax).

[Ribbon_TabRouteEmailMS] Лента. Контекстная вкладка Отправить по почте (Microsoft Fax, методы для входящих).

[Ribbon_TabRouteFolderMS] Лента. Контекстная вкладка Сохранить в папке (Microsoft Fax, методы для входящих).

[Ribbon_TabRoutePrintMS] Лента. Контекстная вкладка Печать (Microsoft Fax, методы для входящих).

[Ribbon_TabRouteOutMainMS] Лента. Контекстная вкладка Методы для исходящих (Microsoft Fax).

[Ribbon_TabRouteOutEmailMS] Лента. Контекстная вкладка Уведомления на e-mail (Microsoft Fax, методы для исходящих).

[Ribbon_TabRouteOutFolderMS] Лента. Контекстная вкладка Сохранить в папке (Microsoft Fax, методы для исходящих).

[Ribbon_TabRouteOutPrintMS] Лента. Контекстная вкладка Печать (Microsoft Fax, методы для исходящих).

[Ribbon_TabSendFaxMSExe] Лента. Контекстная вкладка SendFaxMS.exe.

[Ribbon_TabMail2FaxMSRoute] Лента. Контекстная вкладка Почта-на-факс (Microsoft Fax).

[Ribbon_TabLanguage] Лента. Контекстная вкладка Язык.

[Ribbon_Menu] Лента. Меню ленты.

[Ribbon_Menu_SIPCodecs] Лента. Список кодеков SIP. Контекстное меню.

[Ribbon_Menu_H323Phones] Лента. Список номеров телефонов H.323. Контекстное меню.

[Ribbon_Menu_H323Codecs] Лента. Список кодеков H.323. Контекстное меню.

[Ribbon_Menu_ModemRouteIn] Лента. Маршрутизация входящих вызовов на модемы. Контекстное меню.

[TreeView] Дерево Панели управления Fax Voip T.38 Модем, отображаемое слева.

[VOIP] Страница Параметры IP-телефонии.

[VOIP_SIP] Страница Параметры SIP.

[VOIP_SIP_UserAgent] Страница Агент пользователя SIP.

[VOIP_SIP_Registrations] Страница Список учетных записей SIP.

[VOIP_SIP_T38] Страница Параметры T.38 UDPTL Redundancy (SIP).

[VOIP_SIP_Codecs] Страница Параметры кодеков SIP.

[VOIP_H323] Страница Параметры H.323.

[VOIP_H323_Gatekeeper] Страница H.323 Гейткипер.

[VOIP_H323_T38] Страница Параметры T.38 UDPTL Redundancy (H.323).

[VOIP_H323_Codecs] Страница Параметры кодеков H.323.

[VOIP_ISDNCAPI20] Страница Параметры ISDN CAPI 2.0.

[VOIP_OutgoingPlan] Страница Маршрутизация исходящих Voip вызовов.

[VOIP_IncomingPlan] Страница Маршрутизация входящих Voip вызовов.

[PortsModems] Страница Виртуальные COM порты и модемы.

[PortsModems_OutgoingPlan] Страница Маршрутизация исходящих вызовов с модемов.

[PortsModems_IncomingPlan] Страница Маршрутизация входящих вызовов на модемы.

[PortsModems_Codecs] Страница Форматы голосовых данных и системы голосовых команд модема.

[PortsModems_CallerID] Страница Параметры Caller ID (Входящие вызовы на модемы).

[Fax_IncomingMethodsMS] Страница Методы маршрутизации для входящих факсов (Microsoft Fax).

[Fax_IncomingMethodsMS_RouteThroughEmail] Страница Маршрутизация входящих факсов: отправить по электронной почте (Microsoft Fax).

[Fax_IncomingMethodsMS_StoreInFolder] Страница Маршрутизация входящих факсов: сохранить в папке (Microsoft Fax).

[Fax_IncomingMethodsMS_Print] Страница Маршрутизация входящих факсов: печать (Microsoft Fax).

[Fax_IncomingMethodsMS_Custom] Страница Пользовательская маршрутизация входящих факсов (Microsoft Fax).

[Fax_OutgoingMethodsMS] Страница Методы маршрутизации для исходящих факсов (Microsoft Fax).

[Fax_OutgoingMethodsMS_EmailReceipts] Страница Маршрутизация исходящих факсов: уведомления о доставке по e-mail (Microsoft Fax).

[Fax_OutgoingMethodsMS_StoreInFolder] Страница Маршрутизация исходящих факсов: сохранить в папке (Microsoft Fax).

[Fax_OutgoingMethodsMS_Print] Страница Маршрутизация исходящих факсов: печать (Microsoft Fax).

[Fax_OutgoingMethodsMS_Custom] Страница Пользовательская маршрутизация исходящих факсов (Microsoft Fax).

[Fax] Страница Параметры факса.

[Fax_DialingRules] Страница Набор номера (телефония Microsoft) - Microsoft Fax.

[Fax_FaxConverter] Страница Параметры конвертации в факс.

[Fax_FaxViewer] Страница Просмотр факсов.

[Fax_SendFaxMSExe] Страница SendFaxMS.exe - утилита командной строки (Microsoft Fax).

[Fax_SendFaxMSExe_Cover] Страница Титульные страницы (SendFaxMS.exe) - Microsoft Fax.

[Fax_SendFaxMSExe_Sender] Страница Сведения об отправителе (SendFaxMS.exe) - Microsoft Fax.

[Fax_SendFaxMSExe_Receipts] Страница Уведомления на e-mail (оригинал, Microsoft Fax) - SendFaxMS.exe.

[Email] Страница Факс-на-почту / Почта-на-факс и уведомления о доставке.

[Email_Mail2FaxMS] Страница Почта-на-факс - Microsoft Fax.

[Email_Mail2FaxMS_DialingRules] Страница Набор номера (Почта-на-факс) - Microsoft Fax.

[Email_Mail2FaxMS_Receipts] Страница Уведомление о доставке (Почта-на-факс) - Microsoft Fax.

[Email_Mail2FaxMS_Cover] Страница Титульные страницы (Почта-на-факс) - Microsoft Fax.

[Email_Mail2FaxMS_Sender] Страница Сведения об отправителе (Почта-на-факс) - Microsoft Fax.

[Email_Mail2FaxMS_Route] Страница Правила для почты (Почта-на-факс) - Microsoft Fax.

[Email_SMTP] Страница Параметры сервера исходящей почты (SMTP).

[Email_SMTP_OAuth2] Страница Параметры OAuth 2.0 (SMTP).

[Email_POP3IMAP] Страница Параметры сервера входящей почты (POP3/IMAP).

[Email_POP3IMAP_OAuth2] Страница Параметры OAuth 2.0 (POP3/IMAP).

[Email_Templates] Страница Шаблоны электронной почты.

[Options] Страницы Общие параметры, Журналы маршрутизации входящих факсов (Microsoft Fax), Журналы маршрутизации исходящих факсов (Microsoft Fax), Журналы электронной почты и Журналы SendFaxMS.exe (Microsoft Fax).

[Options_Language] Страница Языковые параметры.

[Options_System] Страница Операционная система.

[License] Страница Лицензии.

[About] Страница О программе.

[Form_SIPregister] Диалог Учетная запись SIP (добавление / изменение).

[Form_AddH323Number] Диалог Номер телефона (H.323).

[Form_VoipRouteOut] Диалог Правило Voip маршрутизации исходящих вызовов, общие элементы.

[Form_VoipRouteOut_General] Диалог Правило Voip маршрутизации исходящих вызовов, страница Общие.

[Form_VoipRouteOut_Fax] Диалог Правило Voip маршрутизации исходящих вызовов, страница Факс.

[Form_VoipRouteOut_Codecs] Диалог Правило Voip маршрутизации исходящих вызовов, страница Кодеки.

[Form_VoipRouteIn] Диалог Правило Voip маршрутизации входящих вызовов, общие элементы.

[Form_VoipRouteIn_General] Диалог Правило Voip маршрутизации входящих вызовов, страница Общие.

[Form_VoipRouteIn_Fax] Диалог Правило Voip маршрутизации входящих вызовов, страница Факс.

[Form_VoipRouteIn_Codecs] Диалог Правило Voip маршрутизации входящих вызовов, страница Кодеки.

[Form_COM] Диалог Выбор портов.

[Form_ChangeModems] Диалог Модемы.

[Form_ModemRouteIn] Диалог Входящие вызовы на модем.

[Form_RouteEmailMS] (Microsoft Fax) Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), общие элементы.

[Form_RouteEmailMS_General] (Microsoft Fax) Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Общие.

[Form_RouteEmailMS_Email] (Microsoft Fax) Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница E-mail.

[Form_RouteEmailMS_Format] (Microsoft Fax) Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Формат.

[Form_RouteEmailMS_Templates] (Microsoft Fax) Диалог Правило отправки по электронной почте (маршрутизация входящих факсов), страница Шаблоны.

[Form_RouteFolderMS] Диалог (Microsoft Fax) Правило сохранения в папке (маршрутизация входящих факсов), общие элементы.

[Form_RouteFolderMS_General] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Общие.

[Form_RouteFolderMS_StoreInFolder] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Сохранить в папке.

[Form_RouteFolderMS_Format] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация входящих факсов), страница Формат.

[Form_RoutePrintMS] (Microsoft Fax) Диалог Правило печати (маршрутизация входящих факсов), общие элементы.

[Form_RoutePrintMS_General] (Microsoft Fax) Диалог Правило печати (маршрутизация входящих факсов), страница Общие.

[Form_RoutePrintMS_Print] (Microsoft Fax) Диалог Правило печати (маршрутизация входящих факсов), страница Печать.

[Form_RouteOutEmailMS] (Microsoft Fax) Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutEmailMS_General] (Microsoft Fax) Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutEmailMS_Email] (Microsoft Fax) Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница E-mail.

[Form_RouteOutEmailMS_Format] (Microsoft Fax) Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Формат.

[Form_RouteOutEmailMS_Templates] (Microsoft Fax) Диалог Правило Уведомления о доставке по электронной почте (маршрутизация исходящих факсов), страница Шаблоны.

[Form_RouteOutFolderMS] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutFolderMS_General] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutFolderMS_StoreInFolder] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Сохранить в папке.

[Form_RouteOutFolderMS_Format] (Microsoft Fax) Диалог Правило сохранения в папке (маршрутизация исходящих факсов), страница Формат.

[Form_RouteOutPrintMS] (Microsoft Fax) Диалог Правило печати (маршрутизация исходящих факсов), общие элементы.

[Form_RouteOutPrintMS_General] (Microsoft Fax) Диалог Правило печати (маршрутизация исходящих факсов), страница Общие.

[Form_RouteOutPrintMS_Print] (Microsoft Fax) Диалог Правило печати (маршрутизация исходящих факсов), страница Печать.

[Form_SendFaxMSExe] Диалог Настройка параметров SendFaxMS.exe, общие элементы.

[Form_SendFaxMSExe_Recipients] Диалог Настройка параметров SendFaxMS.exe, страница Получатели.

[Form_SendFaxMSExe_Documents] Диалог Настройка параметров SendFaxMS.exe, страница Документы.

[Form_SendFaxMSExe_Converting] Диалог Настройка параметров SendFaxMS.exe, страница Конвертация.

[Form_SendFaxMSExe_Cover] Диалог Настройка параметров SendFaxMS.exe, страница Титульная страница.

[Form_SendFaxMSExe_Sender] Диалог Настройка параметров SendFaxMS.exe, страница Отправитель.

[Form_SendFaxMSExe_Schedule] Диалог Настройка параметров SendFaxMS.exe, страница Время отправки.

[Form_SendFaxMSExe_Receipts] Диалог Настройка параметров SendFaxMS.exe, страница Уведомления.

[Form_CheckFaxNumberMS] Диалог Проверка номера факса (вызывается из диалога Настройка параметров SendFaxMS.exe).

[Form_Progress] Окно, отображающее ход импорта /удаления номеров факсов (вызывается из диалога Настройка параметров SendFaxMS.exe).

[Form_SmtpMSFax] Диалог Параметры SMTP (служба факсов Windows).

[Form_Mail2FaxMSRoute] (Microsoft Fax) Диалог Правило Почта-на-факс, общие элементы.

[Form_Mail2FaxMSRoute_General] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Общие.

[Form_Mail2FaxMSRoute_DialingRules] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Набор номера.

[Form_Mail2FaxMSRoute_Receipts] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Уведомления.

[Form_Mail2FaxMSRoute_Attach] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Вложения.

[Form_Mail2FaxMSRoute_Cover] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Титульные страницы.

[Form_Mail2FaxMSRoute_Sender] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Отправитель.

[Form_Mail2FaxMSRoute_Schedule] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Время отправки.

[Form_Mail2FaxMSRoute_Templates] (Microsoft Fax) Диалог Правило Почта-на-факс, страница Шаблоны.

[Form_TestMail] Диалог Отправить пробное сообщение.

[Form_TestSmtp] Окно Тестирование сервера исходящей почты SMTP.

[Form_TestPop3] Окно Тестирование сервера входящей почты (POP3/IMAP).

[Form_Mail2FaxService] Диалог Служба Почта-на-факс.

[Form_License] Окно Лицензия Fax Voip T.38 Модем.

[Form_VerifyID] Окно Проверочные коды.

[Form_Install] Окно, отображающее ход установки виртуальных COM-портов, модемов и т.п.

[Form_AddLanguage] Диалог Добавление языкового профиля.

[Form_CompareLanguage] Диалог Редактирование языкового профиля (в котором пользователь указывает язык для сравнения).

[Form_EditLanguage] Окно Редактирование языкового профиля.

[Form_WinFaxService] Окно Параметры службы факсов Windows.

FaxVoipModemManager.ini

Языковые настройки Диспетчера Fax Voip T.38 Модем.

Секции:

[Help] Справочная система.

[Menu] Меню Fax Voip T.38 Модем в системном трее.

[Common] Общие элементы.

[Form_Trial] Окно, появляющееся в незарегистрированной версии.

SendFaxMS.ini

Языковые настройки утилиты SendFaxMS.exe (Microsoft Fax).

Секции:

[Form_Track] Окно отслеживания факса, общие элементы.

[Help] Справочная система.

[Menu] Окно отслеживания факса, главное меню.

[Toolbar] Окно отслеживания факса, подписи кнопок и всплывающие подсказки в панели инструментов.

[Ribbon_TabMain] Окно отслеживания факса. Лента. Основная вкладка.

[Ribbon_TabView] Окно отслеживания факса. Лента. Вкладка Вид.

[Ribbon_Menu] Окно отслеживания факса. Лента. Меню ленты.

[Properties] Окно отслеживания факса. Область отображения свойств факса.

[FaxStatus_Short] Состояние факса. Краткое описание.

[FaxStatus_Long] Состояние факса. Длинное описание.

[FaxExtStatus_Short] Расширенное состояние факса. Краткое описание.

[FaxExtStatus_Long] Расширенное состояние факса. Длинное описание.

[FaxProperty_Value] Значения для свойств факса.

[App_Output] Описания событий и ошибок SendFaxMS.exe.

SendFaxMS.txt

Справочный текст, отображаемый при запуске утилиты SendFaxMS.exe (Microsoft Fax) без параметров. Текстовой файл в кодировке Юникод. Его нельзя редактировать используя Графический интерфейс пользователя (GUI). Для редактирования этого файла воспользуйтесь Блокнотом или другим текстовым редактором.

TrayNotify.ini

Языковые настройки Уведомлений в трей.

Секции:

[New_Version] Уведомление Доступна новая версия...

[License] Уведомления, касающиеся лицензий.

convert.ini

Языковые настройки, касающиеся конвертации файлов в различные форматы.

Секции:

[Convert] Различные окна сообщений.

[Convert_ToFax] Тексты ошибок при преобразовании в формат факса.

Email.ini

Языковые настройки SMTP журнала, обратного вызова функций SSL, а также касающиеся подписывания сообщений e-mail.

Секции:

[SendMail] SMTP журнал.

[SSL_Callback] Обратный вызов функций SSL.

[Sign_Message] Подписывание сообщений электронной почты цифровой подписью.

[OAuth2Token] Процедура получения Refresh Token.

mailtextMSFax.ini

Языковые настройки шаблонов электронной почты по умолчанию (Microsoft Fax).

Секции:

[Fax_In] Входящие факсы, Метод маршрутизации: отправить по электронной почте.

[Fax_Out] Исходящие факсы, Почта-на-факс, Метод маршрутизации: уведомления о доставке по электронной почте.

FaxStatusMSFax.ini

Языковые настройки описаний статуса факса (Microsoft Fax).

Секции:

[Fax_ExtStatus] Расширенный статус факса.

FixPrintto.ini

Языковые настройки журнала функции Исправить команды ‘printto’.

Секции:

[Common] Общие тексты.

[Print_System] Действия, связанные с исправлениями под системной учетной записью.

[Fix_Printto] Прочие параметры.

fvwincom.ini

Языковые настройки вспомогательной утилиты (fvwincom.exe), которая используется при установке и удалении Fax Voip T.38 Модем.

Секции:

[Common] Общие тексты.

[Form_Remove] Окно Удаление Fax Voip T.38 Модем.

WinFaxService.ini

Языковые настройки утилиты установки Службы факсов Windows.

Секции:

[Form_Install] Окно, отображающее ход установки Службы факсов Windows.

[Common] Общие тексты.

FVModemBackup.ini

Языковые настройки Мастера архивации и восстановления Fax Voip T.38 Модем.

Секции:

[Form_Main] Текст в заголовке окна мастера.

[Page_Welcome] Страница приветствия Мастера архивации и восстановления Fax Voip T.38 Модем.

[Page_BackupOrRestore] Страница Архивация и восстановление Fax Voip T.38 Модем.

[Page_BackupOptions] Страница Что следует архивировать.

[Page_BackupPathAndName] Страница Имя, тип и расположение архивации.

[Page_BackupCompleted] Заключительная страница Мастера архивации и восстановления Fax Voip T.38 Модем (Архивация).

[Page_RestorePath] Страница Восстановление.

[Page_RestoreOptions] Страница Что следует восстановить.

[Page_RestoreCompleted] Заключительная страница Мастера архивации и восстановления Fax Voip T.38 Модем (Восстановление).

[Page_CannotContinue] Страница ошибки в работе Мастера архивации и восстановления Fax Voip T.38 Модем.

Примечания

  • *{CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Параметры системы

Панель управления Fax Voip T.38 Модем ›› Общие параметры ››

В панели Система отображается информация об операционной системе и о текущих параметрах системы.

Операционная система

Название операционной системы. В данном поле также отображается тип операционной системы (32-битная либо 64-битная).

Текущие параметры загрузки системы

Эта панель отображает текущее состояние опции загрузки /TESTSIGNING (тестовый режим) и текущее состояние опции загрузки /DISABLE_INTEGRITY_CHECKS (отключение обязательной проверки подписи драйверов).

Использование драйверов виртуальных COM портов

Эта панель отображает информацию о том, возможно ли использовать Fax Voip Драйвер Виртуальных COM портов при текущих параметрах загрузки операционной системы.

<Перезагрузка>

Эту кнопку можно использовать для перезагрузки операционной системы.

Примечания

  • Fax Voip T.38 Модем поставляется с собственным драйвером Виртуальных COM портов, который подписан цифровой подписью Microsoft Code Signing и полностью совместим с 64-битными версиями Windows. Возможность использования драйверов сторонних производителей сохранена но реальная необходимость использования данной функции обычно отсутствует.
  • Возможность работы со сторонними драйверами виртуальных COM портов зависит от совместимости стороннего программного обеспечения с вашей операционной системой. Примеры использования подробно обсуждаются в главе Использование Fax Voip T.38 Модем со сторонними виртуальными COM портами данного справочного руководства.


Fax Voip T.38 Модем в качестве службы Windows

Запуск Fax Voip T.38 Модем в качестве службы Windows

Fax Voip T.38 Модем может работать в качестве Службы Windows. Данная опция не устанавливается по умолчанию, необходимо сделать соответствующие настройки вручную. Перед использованием данной опции желательно убедиться, что программа Fax Voip T.38 Модем нормально функционирует в обычном режиме. Обычно, когда Fax Voip T.38 Модем устанавливается в качестве службы, он запускается под системной учетной записью (Local System).

  • Настройка Fax Voip T.38 Модем в качестве службы Windows
  • Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows
  • Описание служб Fax Voip T.38 Модем


Настройка Fax Voip T.38 Модем в качестве службы

Настройка Fax Voip T.38 Модем в качестве службы Windows

Fax Voip T.38 Модем в качестве службы Windows ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Общие параметры.

3. Включите опцию Запускать Fax Voip T.38 Модем как службу Windows. Для изменения данного параметра требуются права администратора.

4. Включите опцию Автоматически запускать при загрузке Windows если вы хотите запускать службу Fax Voip T.38 Модем до входа пользователя в систему (под системной учетной записью). Если Fax Voip T.38 Модем сконфигурирован для работы в качестве службы Windows, то для изменения данного параметра требуются права администратора.

5. Нажмите <Применить>.

6. При появлении диалогового окна, нажмите <OK>.

7. В окне Служба Почта-на-факс, укажите имя пользователя и пароль учетной записи, которая будет использоваться для запуска почтовой службы Fax Voip T.38 Модем. Имя учетной записи должно иметь формат DOMAIN\Username. По умолчанию, Fax Voip T.38 Модем предлагает использовать текущую учетную запись (с правами администратора). Не следует запускать эту службу от имени локальной системы или сетевой службы. См. также Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows . Нажмите <OK>.

8. Убедитесь, что имя выбранной учетной записи отображается в поле Служба Почта-на-факс (через Microsoft Fax) запускается от имени учетной записи, см. рисунок ниже.

9. Нажмите кнопку <СТАРТ> чтобы запустить Fax Voip T.38 Модем в качестве Службы Windows.

В строке состояния вы должны увидеть сообщение Служба Fax Voip T.38 Модем: запущена.


Описание служб Fax Voip T.38 Модем

Fax Voip T.38 Модем в качестве службы Windows ››

При выборе опции Запускать Fax Voip T.38 Модем как службу Windows, Fax Voip T.38 Модем устанавливает в системе следующие службы:

Fax Voip T.38 Modem (Fax Voip T.38 Modem service)

Основная служба, которая отвечает за работу SIP/H.323/ISDN CAPI 2.0 клиента и передачу факсов. Запускается под учетной записью Локальная система.

Fax Voip T.38 Modem Management (Fax Voip T.38 Modem Management service)

Эта служба отвечает только за вспомогательный механизм принудительного восстановления SIP регистрации . Запускается под учетной записью Локальная система.

Fax Voip T.38 Modem MsFax Mail (Fax Voip T.38 Modem Mail to Fax - Microsoft Fax service)

Эта служба отвечает за работу функции Почта-на-факс - Microsoft Fax . Также используется для вызова Методов маршрутизации для исходящих факсов (Microsoft Fax) . Если указанные функции не используются, эта служба не запускается. Эта служба должна запускаться от имени стандартной учетной записи пользователя, см. Конфигурирование почтовой системы (почта-на-факс) в качестве службы Windows .

Примечания

  • Не следует вручную устанавливать, удалять или настраивать службы Fax Voip T.38 Модем с помощью Консоли управления (Microsoft Management Console). Это может привести к непредсказуемому поведению программы. Чтобы настроить службы, см. Настройка Fax Voip T.38 Модем в качестве службы Windows .


T38 и G711 (аудио) режимы факса

Fax Voip T.38 Модем поддерживает получение и отправку факсов как по протоколу T.38, так и в аудио режиме (поверх кодеков G711-ulaw и G711-Alaw).

Как T.38 так и аудио факс (факс поверх кодека G.711) методы имеют свои преимущества и недостатки при отправке/приеме факсов через VoIP.

T.38 - наиболее надежный протокол передачи факсов через VoIP в режиме реального времени. Компенсирует задержки и потери пакетов характерные для VoIP. Поддержка T.38 должна быть обеспечена вашим SIP или H.323 провайдером IP-телефонии. Заметим, что протокол T.38 полностью совместим с использованием любого аудио кодека (поддержка G.711 не требуется).

Передача факсов по аудио каналу (G711 факс) не столь надежна. Тем не менее, этот метод может быть использован практически со всеми VoIP провайдерами, которые поддерживают кодеки G.711-ulaw либо G.711-Alaw. В этом случае, возможность и качество передачи факсов зависит от многих факторов, таких как качество VoIP терминации или надежность интернет канала на стороне клиента. Несмотря на очевидные недостатки, G711 факс часто работает очень хорошо и устойчиво со многими SIP и H.323 провайдерами.

Одной из наиболее распространенных проблем с которой часто сталкиваются пользователи является неполная поддержка T.38 со стороны VoIP провайдера. Иными словами, провайдер анонсирует поддержку T.38, но не может обеспечить T.38 для некоторых направлений исходящих вызовов. Или, например, не обеспечивает стабильную терминацию через качественные узлы для заданного направления вызовов. Fax Voip T.38 Модем умеет автоматически определять присутствие или отсутствие поддержки T.38 в момент совершения текущего вызова.

В случае отправки или получения факсов через линию ISDN CAPI 2.0 с использованием режима G711 аудио факс, не следует ожидать проблем, в силу отсутствия задержек и т.п. типичных для VoIP.


Настройка режима факса

T38 и G711 (аудио) режимы факса ››

Fax Voip T.38 Модем позволяет использовать различные режимы факса, в зависимости от правила Маршрутизации исходящих VOIP вызовов или Маршрутизации входящих VOIP вызовов. Например, все вызовы на номера начинающиеся с '00' могут быть маршрутизированы в SIP сеть провайдера DellMont (ранее Betamax) в режиме G711 факс, а все вызовы на номера начинающиеся с '8' могут быть маршрутизированы в сеть МТТ с поддержкой T38 факс. Таким образом, для настройки режимов факса для исходящих факсов, необходимо редактировать таблицу Маршрутизации исходящих VOIP вызовов . Для настройки режимов факса для входящих факсов, необходимо редактировать таблицу Маршрутизации входящих VOIP вызовов . Чтобы избежать возможных проблем при выборе правильного режима факса, настоятельно рекомендуется заранее ознакомиться с описаниями возможных режимов факса, а также с требованиями к голосовым кодекам (см. ниже).


Настройка режима исходящих факсов

T38 и G711 (аудио) режимы факса ›› Настройка режима факса ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов перейдите на вкладку Факс.

5. В области Режимы факса, поставьте или снимите галочку напротив соответствующих опций:

      • Выберите опцию Факс поверх G.711 для отправки аудио факсов.
      • Выберите опцию T.38 факс для отправки факсов по протоколу T.38.
      • При выборе опции Отправлять T.38 ре-инвайт, Fax Voip T.38 Модем будет отсылать T.38 ре-инвайт не ожидая получения T.38 ре-инвайта от вызываемой стороны.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить новые параметры для правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.

Примечания

  • Чтобы избежать возможных проблем при выборе правильного режима факса, настоятельно рекомендуется заранее ознакомиться с описаниями возможных Режимов исходящих факсов .


Настройка режима входящих факсов

T38 и G711 (аудио) режимы факса ›› Настройка режима факса ››

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация входящих вызовов перейдите на вкладку Факс.

5. В области Режимы факса, поставьте или снимите галочку напротив соответствующих опций:

      • Выберите опцию Факс поверх G.711 для приема аудио факсов.
      • Выберите опцию T.38 факс для приема факсов по протоколу T.38.
      • При выборе опции Ждать T.38 ре-инвайт, Fax Voip T.38 Модем переключится в режим T38 факс только при детектировании T.38 ре-инвайта, посланного вызывающей стороной.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить новые параметры для правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.

Примечания

  • Чтобы избежать возможных проблем при выборе правильного режима факса, настоятельно рекомендуется заранее ознакомиться с описаниями возможных Режимов входящих факсов .


Режимы исходящих факсов

Режимы исходящих факсов для Виртуальных COM портов (модемов)

T38 и G711 (аудио) режимы факса ››

При осуществлении исходящих вызовов через Виртуальные COM порты (модемы), может применяться один из четырех возможных режимов факса:

  • G711 факс
  • T38 факс
  • G711 факс + T38 факс
  • T38 факс с отправкой ре-инвайта + G711 факс

Чтобы избежать возможных проблем при выборе правильного режима факса, настоятельно рекомендуется заранее ознакомиться с описаниями возможных Режимов исходящих факсов.


G711 факс

Режим G711 факс (G711)

T38 и G711 (аудио) режимы факса ›› Режимы исходящих факсов ››

После ответа на исходящий вызов, Fax Voip T.38 Модем работает в режиме отправки G711 факс. В случае получения T.38 ре-инвайта от вызываемой стороны, Fax Voip T.38 Модем отвечает 'не поддерживается' и продолжает отправку факса в аудио режиме, если обе стороны согласились что это возможно. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Выключите опцию T.38 факс.

3. Выключите опцию Отправлять T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим с теми VoIP провайдерами, которые не поддерживают протокол T.38.
  • G.711 аудио факс режим всегда используется при отправке факса через ISDN CAPI 2.0 линию.


T38 факс

Режим T38 факс (T38)

T38 и G711 (аудио) режимы факса ›› Режимы исходящих факсов ››

При получении T.38 ре-инвайта от вызываемой стороны, Fax Voip T.38 Модем переключается в режим T.38 и отправляет факс. При отсутствии получения T.38 ре-инвайта от вызываемой стороны, отправки факса не происходит. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Выключите опцию Факс поверх G.711.

2. Включите опцию T.38 факс.

3. Выключите опцию Отправлять T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим с теми VoIP провайдерами, которые обеспечивают стабильную поддержку протокола T.38.


G711 факс + T38 факс

Режим G711 факс + T38 факс (G711,T38)

T38 и G711 (аудио) режимы факса ›› Режимы исходящих факсов ››

После ответа на исходящий вызов, Fax Voip T.38 Модем работает в режиме отправки G711 факс. В случае получения T.38 ре-инвайта от вызываемой стороны, Fax Voip T.38 Модем переключается в режим T.38 и отправляет факс по протоколу T.38. Если T.38 ре-инвайт не получен, Fax Voip T.38 Модем продолжает использовать аудио режим (G711 факс) для отправки факса. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Включите опцию T.38 факс.

3. Выключите опцию Отправлять T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим с теми SIP/H.323 провайдерами, которые не обеспечивают стабильную поддержку протокола T.38. Или, например, совместно с PBX, которая работает с разными SIP/H.323 провайдерами (как с поддержкой так и без поддержки протокола T.38).
  • Этот режим может быть использован вместо любого из вышеописанных двух режимов.


T38 факс с отправкой ре-инвайта + G711 факс

Режим T38 факс с отправкой ре-инвайта + G711 факс (T38+R,G711)

T38 и G711 (аудио) режимы факса ›› Режимы исходящих факсов ››

После ответа на исходящий вызов, Fax Voip T.38 Модем работает в режиме отправки T38 факс (отсылает T.38 ре-инвайт в направлении вызываемой стороны). В случае положительного ответа от вызываемой стороны, Fax Voip T.38 Модем отправляет факс по протоколу T.38. Если вызываемая сторона отвечает 'не поддерживается', Fax Voip T.38 Модем переключается в режим G711факс и отправляет факс как аудио. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Включите опцию T.38 факс.

3. Включите опцию Отправлять T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим только если VoIP провайдер заявляет о поддержке T.38, но по каким-то причинам не генерирует T.38 ре-инвайт при ответе факс аппарата на вызываемой стороне.
  • В зависимости от возможностей SIP/H.323 сети, CNG сигнал может не транслироваться в этом режиме.
  • Не рекомендуется использовать этот режим для отправки аудио факсов (G711 факс), т.к. в случае отсутствия T.38, вызываемая сторона не всегда способна дать корректный ответ 'не поддерживается'. В описанной ситуации переключения в режим G711 факс не произойдет и факс передан не будет.
  • Этот режим рекомендуется использовать для передачи факса по T.38, если используется ложный G.729* кодек, чтобы обеспечить генерацию CNG сигнала.


Режимы входящих факсов

Режимы входящих факсов для Виртуальных COM портов (модемов)

T38 и G711 (аудио) режимы факса ››

При входящих вызовах на Виртуальные COM порты (модемы), может применяться один из трех возможных режимов факса:

  • G711 факс
  • T38 факс + G711 факс
  • G711 факс + T38 с ожиданием ре-инвайта

Чтобы избежать возможных проблем при выборе правильного режима факса, настоятельно рекомендуется заранее ознакомиться с описаниями возможных Режимов входящих факсов.


G711 факс

Режим G711 факс (G711)

T38 и G711 (аудио) режимы факса ›› Режимы входящих факсов ››

Fax Voip T.38 Модем работает в режиме приема G711 факс. В случае получения T.38 ре-инвайта от вызывающей стороны, Fax Voip T.38 Модем отвечает 'не поддерживается' и продолжает принимать факс в аудио режиме. Для установки этого режима в правиле Маршрутизации входящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Выключите опцию T.38 факс.

3. Выключите опцию Ждать T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим с теми VoIP провайдерами, которые не поддерживают протокол T.38.
  • G.711 аудио факс режим всегда используется при приеме факса через ISDN CAPI 2.0 линию.


T38 факс + G711 факс

Режим T38 факс + G711 факс (T38,G711)

T38 и G711 (аудио) режимы факса ›› Режимы входящих факсов ››

Fax Voip T.38 Модем работает в режиме приема факса как T38 факс (шлет T.38 ре-инвайт в направлении вызывающей стороны). Если вызывающая сторона отвечает 'не поддерживается', Fax Voip T.38 Модем переключается в режим G711 факс и принимает факс как аудио. Для установки этого режима в правиле Маршрутизации входящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Включите опцию T.38 факс.

3. Выключите опцию Ждать T.38 ре-инвайт.

Примечания

  • Рекомендуется использовать этот режим с теми VoIP провайдерами, которые поддерживают протокол T.38.
  • Не рекомендуется использовать этот режим для приема аудио факсов (G711 факс), т.к. в случае отсутствия T.38, вызывающая сторона не всегда способна дать корректный ответ 'не поддерживается'. В описанной ситуации переключения в режим G711 факс не произойдет и факс принят не будет.


G711 факс + T38 с ожиданием ре-инвайта

Режим G711 факс + T38 факс с ожиданием ре-инвайта (T38R,G711)

T38 и G711 (аудио) режимы факса ›› Режимы входящих факсов ››

Fax Voip T.38 Модем работает в режиме приема G711 факс. В случае получения T.38 ре-инвайта от вызывающей стороны, Fax Voip T.38 Модем переключается в режим T.38 и принимает факс по протоколу T.38. Для установки этого режима в правиле Маршрутизации входящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Выключите опцию T.38 факс.

3. Включите опцию Ждать T.38 ре-инвайт.

Примечания

  • Этот режим может быть использован для совместимости с некоторыми SIP/H.323 провайдерами и оборудованием.
  • Этот режим также может быть использован вместо режима G711 факс, описанного выше.


Требования к аудио кодекам

Требования к голосовым кодекам

T38 и G711 (аудио) режимы факса ››

При настройке Режимов факса, вам следует уделить внимание выбору голосовых кодеков. Параметры кодеков SIP и Параметры кодеков H.323 , заданные по умолчанию, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и в настройках Маршрутизации входящих VOIP вызовов.

При выборе голосовых кодеков, вам следует руководствоваться следующими правилами:

  • T.38 факс полностью совместим с использованием любого аудио кодека. По крайней мере один аудио кодек должен быть выбран. По крайней мере один из выбранных кодеков должен поддерживаться вашей SIP или H.323 сетью.
  • G711 факс может работать только при условии использования кодеков G.711-ulaw или G.711-Alaw. Таким образом, по крайней мере один из этих двух кодеков должен быть выбран и поддерживаться вашей SIP или H.323 сетью.
  • Для предотвращения отправки или приема факсов в режиме G711 факс, вы можете убрать кодеки G.711-ulaw и G.711-Alaw из списка выбранных кодеков. Это возможно при условии, что ваш SIP или H.323 провайдер поддерживает один из других голосовых кодеков.
  • Для обеспечения совместимости с G711 факс при использовании кодеков отличных от G.711-ulaw и G.711-Alaw, настоятельно рекомендуется устанавливать наивысший приоритет для G.711-ulaw и G.711-Alaw. При переключении в режим G711 факс, Fax Voip T.38 Модем при необходимости делает ре-инвайт на кодек G.711-ulaw или G.711-Alaw. Ре-инвайт на кодек G.711 полностью поддерживается в Fax Voip T.38 Модем для случая входящих вызовов. Однако, в случае исходящих вызовов, данная функция немного недоработана, поэтому вам не следует полагаться на нее. В случае SIP, вы также можете обеспечить наивысший приоритет для кодеков G.711-ulaw и G.711-Alaw для входящих вызовов. Для этого вы должны задать наибольший приоритет для кодеков G.711-ulaw и G.711-Alaw, и дополнительно включить опцию Применять предпочтения к входящим вызовам (заметим, что данная опция не может быть рекомендована в силу несоответствия RFC).
  • Ложный G.729* кодек позволяет сообщать поддержку кодека G.729 тем T.38 факс шлюзам, которые не поддерживают G.711 и другие поддерживаемые аудио форматы; используйте этот кодек только для решения проблем совместимости. Обычно, если используется ложный G.729* кодек, для исходящих вызовов также следует использовать режим T38 факс с отправкой ре-инвайта, чтобы обеспечить генерацию CNG сигнала.


Параметры кодеков SIP по умолчанию

Параметры голосовых кодеков SIP (по умолчанию)

T38 и G711 (аудио) режимы факса ›› Требования к аудио кодекам ››

Для настройки Голосовых кодеков SIP, используемых по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP, затем нажмите Кодеки.

3. Для добавления кодека, выберите его в панели Доступные кодеки, затем нажмите кнопку <Добавить>.

4. Для удаления кодека, выберите его в панели Выбранные кодеки, затем нажмите кнопку <Удалить>.

5. Используйте кнопки <Вверх> и <Вниз> чтобы изменить порядок предпочтений для выбранных аудио кодеков. Перед тем как использовать эти кнопки, вы должны выделить один из кодеков в панели Выбранные кодеки.

6. Для того чтобы игнорировать порядок предпочтения кодеков, предлагаемый вызывающей стороной и использовать порядок предпочтения кодеков Fax Voip T.38 Модем в случае входящего вызова, поставьте галочку напротив опции Применять предпочтения к входящим вызовам. Заметим что использование этой опции не соответствует RFC3264. Тем не менее, мы сочли полезным добавить такую возможность.

7. Нажмите кнопку <Применить> чтобы сохранить параметры кодеков. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.


Параметры кодеков H.323 по умолчанию

Параметры голосовых кодеков H.323 (по умолчанию)

T38 и G711 (аудио) режимы факса ›› Требования к аудио кодекам ››

Для настройки Голосовых кодеков H.323, используемых по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите H.323, затем нажмите Кодеки.

3. Для добавления кодека, выберите его в панели Доступные кодеки, затем нажмите кнопку <Добавить>.

4. Для удаления кодека, выберите его в панели Выбранные кодеки, затем нажмите кнопку <Удалить>.

5. Используйте кнопки <Вверх> и <Вниз> чтобы изменить порядок предпочтений для выбранных аудио кодеков. Перед тем как использовать эти кнопки, вы должны выделить один из кодеков в панели Выбранные кодеки.

6. Нажмите кнопку <Применить> чтобы сохранить параметры кодеков. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.


Настройка исходящих кодеков

T38 и G711 (аудио) режимы факса ›› Требования к аудио кодекам ››

Вы можете переопределить голосовые кодеки, используемые по умолчанию в настройках правила Маршрутизации исходящих VOIP вызовов. Для этого выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов перейдите на вкладку Кодеки.

5. Чтобы иметь возможность изменить Параметры голосовых кодеков, используемые по умолчанию, снимите галочку напротив опции По умолчанию.

6. Для добавления кодека, отметьте его в списке Голосовые кодеки.

7. Для удаления кодека, снимите галочку с кодека в списке Голосовые кодеки.

8. Используйте кнопки <Вверх> и <Вниз> чтобы изменить порядок предпочтений для выбранных аудио кодеков. Перед тем как использовать эти кнопки, вы должны выделить один из кодеков в списке Голосовые кодеки.

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Нажмите кнопку <Применить> чтобы сохранить новые параметры для правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.


Настройка входящих кодеков

T38 и G711 (аудио) режимы факса ›› Требования к аудио кодекам ››

Вы можете переопределить голосовые кодеки, используемые по умолчанию в настройках правила Маршрутизации входящих VOIP вызовов. Для этого выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Для добавления нового правила нажмите Добавить. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация входящих вызовов перейдите на вкладку Кодеки.

5. Чтобы иметь возможность изменить Параметры голосовых кодеков, используемые по умолчанию, снимите галочку напротив опции По умолчанию.

6. Для добавления кодека, отметьте его в списке Голосовые кодеки.

7. Для удаления кодека, снимите галочку с кодека в списке Голосовые кодеки.

8. Используйте кнопки <Вверх> и <Вниз> чтобы изменить порядок предпочтений для выбранных аудио кодеков. Перед тем как использовать эти кнопки, вы должны выделить один из кодеков в списке Голосовые кодеки.

9. Нажмите кнопку <OK> чтобы зафиксировать изменения.

10. Нажмите кнопку <Применить> чтобы сохранить новые параметры для правил. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.


Цветные факсы через VoIP и ISDN

С помощью Fax Voip T.38 Модем возможна отправка и получение Цветных факсов через VoIP и ISDN с использованием Виртуальных COM портов (модемов). Вы можете отправлять и принимать цветные факсы как по протоколу T.38 так и в аудио режиме (факс поверх кодека G.711). Для того чтобы успешно отправлять и принимать цветные факсы, должны выполняться следующие требования:

  • Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Таким образом, ECM должен быть включен в настройках Fax Voip T.38 Модем.
  • Цветные факсы всегда передаются в высоком разрешении (204*196 dpi).
  • Ошибки в передаваемых данных не допускаются. Качество VoIP терминации должно быть достаточно хорошим, особенно при передаче цветных факсов в аудио режиме (факс поверх кодека G.711).
  • Чтобы передавать цветные факсы, соответствующее программное обеспечение, позволяющее передавать и принимать цветные факсы, должно быть установлено на вашем компьютере.
  • На противоположной стороне также должно быть установлено оборудование или программное обеспечение, способное передавать и принимать цветные факсы.

Для отправки и получения Цветных факсов через VoIP или ISDN, вам следует загрузить и установить программу Venta Fax и настроить ее для работы с Fax Voip T.38 Модем. Подробные инструкции по настройке Venta Fax для отправки и получения цветных факсов можно найти в главе Использование Fax Voip T.38 Модем с Venta Fax & Voice настоящего справочного руководства.

Мы также протестировали некоторые другие программы, позволяющие отправлять и принимать цветные факсы. К сожалению, все остальные программные реализации для цветных факсов очень низкого качества и не могут быть использованы для отправки и получения цветных факсов через сети IP-телефонии, независимо от того, функционируют ли они на стороне Fax Voip T.38 Модем, или на противоположной стороне.


Требования к VoIP сети

Требования к VoIP сети для цветных факсов

Цветные факсы через VoIP и ISDN ››

Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Практика показывает, что некоторые VoIP провайдеры по каким-либо причинам не обеспечивают поддержку режима Коррекции ошибок и это не зависит от настроек Fax Voip T.38 Модем или используемого факс программного обеспечения. Заметим, что в этом случае отправка и получение цветных факсов невозможна.

В то же время, ошибки в передаваемых данных не допускаются. Эксперименты показывают, что при использовании VoIP провайдеров с плохим качеством терминации, попытка передать цветной факс обычно заканчивается неудачей. Тем не менее, передача черно-белых факсов может быть вполне успешной в описанных случаях. Это замечание особенно справедливо для цветных факсов, передаваемых в аудио режиме (факс поверх кодека G.711).

Таким образом, требования к VoIP сети с точки зрения отправки и приема цветных факсов могут быть сформулированы следующим образом:

  • Коррекция ошибок (ECM) должна быть разрешена в вашей VoIP сети.
  • Качество VoIP терминации должно быть достаточно хорошим.


Настройка Fax Voip T.38 Модем

Настройка Fax Voip T.38 Модем для работы с цветными факсами

Цветные факсы через VoIP и ISDN ››

Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Таким образом, необходимо включить поддержку ECM в параметрах Fax Voip T.38 Модем. Заметим, что ECM всегда включена в Fax Voip T.38 Модем для режима T.38. Таким образом, если вы не планируете отправлять и принимать цветные факсы в аудио режиме (факс поверх кодека G.711), дополнительных настроек не требуется.

В то же время, ошибки в передаваемых данных не допускаются. Эксперименты показывают, что при отправке и получении цветных факсов через VoIP в аудио режиме (факс поверх кодека G.711) на скорости 14400 бит/сек, передача цветного факса обычно заканчивается неудачей. Мы бы рекомендовали отправлять и принимать цветные факсы в аудио режиме с максимальной скоростью 9600 бит/сек. Заметим, что в случае использования ISDN CAPI 2.0 линии нет необходимости уменьшать скорость передачи факса.

Чтобы обеспечить отправку и получение цветных факсов в аудио режиме, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Факс, затем нажмите Коррекция/Скорость.

3. В области Коррекция ошибок (ECM) и ограничение скорости, в настройках Аудио факс поверх G.711, включите опцию ECM (необходимо).

4. В области Коррекция ошибок (ECM) и ограничение скорости, в настройках Аудио факс поверх G.711, в поле Максимальная скорость, выберите скорость 9600 (рекомендуется при отправке/получении цветных факсов в аудио режиме через VoIP).

5. Нажмите кнопку <Применить> чтобы сохранить настройки. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.

Примечания

  • Заметим, что параметры Коррекция ошибок (ECM) и Максимальная скорость могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и Маршрутизации входящих VOIP вызовов .


Требования к факс программному обеспечению

Цветные факсы через VoIP и ISDN ››

Чтобы передавать цветные факсы, соответствующее программное обеспечение, позволяющее передавать и принимать цветные факсы, должно быть установлено на вашем компьютере.

Для отправки и получения цветных факсов через VoIP или ISDN, вам следует загрузить и установить программу Venta Fax и настроить ее для работы с Fax Voip T.38 Модем. Подробные инструкции по настройке Venta Fax для отправки и получения цветных факсов можно найти в главе Использование Fax Voip T.38 Модем с Venta Fax & Voice настоящего справочного руководства.

Мы также протестировали некоторые другие программы, позволяющие отправлять и принимать цветные факсы. К сожалению, все остальные программные реализации для цветных факсов очень низкого качества и не могут быть использованы для отправки и получения цветных факсов через сети IP-телефонии, независимо от того, функционируют ли они на стороне Fax Voip T.38 Модем, или на противоположной стороне.


Требования к противоположной стороне

Требования к противоположной стороне для цветных факсов

Цветные факсы через VoIP и ISDN ››

На противоположной стороне должно быть установлено оборудование или программное обеспечение, способное передавать и принимать цветные факсы. В качестве программного обеспечения, на противоположной стороне также может быть установлена программа Venta Fax & Voice. Заметим, что Venta Fax также может работать на PSTN линии с использованием аппаратного модема.

Если принимающий факс аппарат не имеет поддержки для работы с цветными факсами, программное обеспечение для цветных факсов обычно конвертирует цветной факс в черно-белую версию автоматически во время передачи.


Caller ID

Caller ID, известный также как Caller Identification (CID), является услугой телефонного обслуживания, она передает номер вызывающего абонента на телефонное оборудование вызываемого абонента вместе с сигналом вызова, или на этапе инициализации вызова, но перед тем как вызов отвечен. Caller ID Number позволяет получать номер телефона, а Caller ID Name позволяет видеть имя и/или фамилию абонента или название организации, где зарегистрирован телефонный номер. Информация Caller ID, передаваемая вызываемому абоненту, может отображаться на собственном дисплее телефона, или на дисплее отдельного прилагаемого оборудования. Эта информация обычно посылается один раз между первым и вторым сигналами вызова. Модем может декодировать эту информацию о вызывающем абоненте и отображать ее на мониторе компьютера. В зависимости от используемого программного обеспечения, Caller Id может использоваться с различными функциями, такими как "Черный и Белый список".


Получение Caller ID

Caller ID ››

Функции Caller ID Number и Caller ID Name поддерживаются Виртуальными COM портами (модемами) по умолчанию. Дополнительные настройки не требуются. Возможность отображать как Caller ID Number, так и Caller ID Name зависит от используемого вами факс программного обеспечения. Например, программа Факсы и сканирование Windows может отображать только номер вызывающего абонента (Caller ID Number).

Программа Venta Fax & Voice отображает как Caller ID Number, так и Caller ID Name.

Примечания

  • Функция Caller ID работает как через прямое подключение к COM порту, так и через TAPI (т.е. через драйвер модема). Fax Voip T.38 Модем устанавливает драйвер Fax Voip 14.4K TAPI Voice-Fax Modem для модемов. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку Caller ID Number и Caller ID Name. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется.
  • Передача правильного Caller ID Number не всегда возможна через VoIP сети. По этой причине, многие VoIP провайдеры используют Caller ID Name вместо Caller ID Number для передачи правильного номера вызывающего абонента.
  • Caller ID Name не поддерживается при входящих ISDN CAPI 2.0 вызовах. Fax Voip T.38 Модем всегда отображает Caller ID Name используя следующий формат: CAPI:[C]:[B], где [C] – номер контроллера, а [B] - номер B-канала.


Передача Caller ID (SIP)

Caller ID ››

При конфигурировании исходящих SIP вызовов с Fax Voip T.38 Модем, следует принять во внимание следующую информацию:

  • Если Имя пользователя SIP (SIP-ID), используемое для вызова, состоит только из цифр, оно будет передано на оборудование вызываемого абонента как Caller ID Number.
  • Отображаемое имя, используемое для вызова, передается на оборудование вызываемого абонента как Caller ID Name.

Чтобы задать Отображаемое имя и Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония.

3. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

4. В поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Имя пользователя по умолчанию может быть переопределено через параметр Имя пользователя SIP.

Чтобы задать Имя пользователя SIP, иное чем Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите SIP.

3. Выключите опцию Использовать имя пользователя по умолчанию.

4. В поле Имя пользователя SIP введите ваш номер телефона, который будет передаваться как Caller ID Number.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Имя пользователя SIP может быть переопределено при использовании Учетной записи SIP (SIP регистрация) и в настройках Маршрутизации исходящих VOIP вызовов. Отображаемое имя может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Чтобы переопределить Имя пользователя SIP и Отображаемое имя в параметрах правила Маршрутизации исходящих VOIP вызовов, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number. Чтобы иметь возможность изменить Имя пользователя, опция По умолчанию должна быть выключена. Заметим, что если вызов маршрутизируется на SIP сервер, используемый для осуществления SIP регистрации, то Имя пользователя не может быть задано произвольным образом и должно соответствовать Имени пользователя (или SIP-ID), заданному в одной из Учетных записей SIP в Списке учетных записей SIP.

5. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name. Чтобы иметь возможность изменить Отображаемое имя, опция По умолчанию должна быть выключена.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Примечания

  • Передача правильного Caller ID Number не всегда возможна через VoIP сети. По этой причине, иногда удобно вводить телефонный номер в поле Отображаемое имя. Это обеспечивает возможность передачи вашего номера как Caller ID Name вместо Caller ID Number.


Передача Caller ID (H.323)

Caller ID ››

При конфигурировании исходящих H.323 вызовов с Fax Voip T.38 Модем, следует принять во внимание следующую информацию:

  • По умолчанию, Fax Voip T.38 Модем использует верхний номер из списка Номера телефонов H.323 для передачи его на оборудование вызываемого абонента как Caller ID Number.
  • Отображаемое имя, используемое для вызова, передается на оборудование вызываемого абонента как Caller ID Name.

Чтобы задать Отображаемое имя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония.

3. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name.

4. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Что касается списка Номера телефонов H.323, вы должны понимать следующее:

  • Если H.323 ID состоит только из цифр, Fax Voip T.38 Модем автоматически добавляет его в список телефонных номеров.
  • Если вы используете регистрацию с H.323 гейткипером, и при этом используется H.235 аутентификация и H.235 логин состоит только из цифр, Fax Voip T.38 Модем автоматически добавляет H.235 логин в список телефонных номеров.
  • Любой другой телефонный номер может быть добавлен в список. Телефонные номера, заданные в этом списке, используются в процессе регистрации с H.323 гейткипером, т.е. это список телефонных номеров, на которые возможны входящие вызовы.
  • По умолчанию, Fax Voip T.38 Модем использует верхний номер из списка Номера телефонов H.323 для передачи его на оборудование вызываемого абонента как Caller ID Number.

Чтобы добавить новый номер в список Номера телефонов и использовать его в качестве Caller ID Number по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите H.323.

3. Для добавления нового телефонного номера нажмите кнопку <Добавить>.

4. В окне Номер телефона введите добавляемый номер и нажмите <OK>.

5. Используйте кнопку <Вверх> чтобы передвинуть добавленный номер в верхнюю позицию списка Номера телефонов.

6. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Caller ID Number и Caller ID Name (Отображаемое имя), заданные по умолчанию, могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов.

Чтобы переопределить Caller ID Number и Caller ID Name в параметрах правила Маршрутизации исходящих VOIP вызовов, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number. Чтобы иметь возможность изменить Имя пользователя, опция По умолчанию должна быть выключена.

5. В поле Отображаемое имя введите имя и/или фамилию, название организации, или другую информацию, которая будет передаваться как Caller ID Name. Чтобы иметь возможность изменить Отображаемое имя, опция По умолчанию должна быть выключена.

6. Нажмите кнопку <OK> чтобы зафиксировать изменения.

7. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Примечания

  • Передача правильного Caller ID Number не всегда возможна через VoIP сети. По этой причине, иногда удобно вводить телефонный номер в поле Отображаемое имя. Это обеспечивает возможность передачи вашего номера как Caller ID Name вместо Caller ID Number.


Передача Caller ID (ISDN CAPI 2.0)

Caller ID ››

При конфигурировании исходящих ISDN CAPI 2.0 вызовов с Fax Voip T.38 Модем, следует принять во внимание следующую информацию:

  • Если Имя пользователя ISDN (номер), используемое для вызова, состоит только из цифр, при совершении исходящего вызова оно будет включено в сообщение CAPI 2.0 и передано на оборудование вызываемого абонента как Caller ID Number.
  • Функция Caller ID Name не поддерживается с вызовами ISDN CAPI 2.0.

Чтобы задать Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония.

3. В поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number.

4. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Имя пользователя по умолчанию может быть переопределено через параметр Имя пользователя ISDN (номер).

Чтобы задать Имя пользователя ISDN (номер) иное чем Имя пользователя по умолчанию, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите ISDN CAPI 2.0.

3. Выключите опцию Использовать имя пользователя по умолчанию.

4. В поле Имя пользователя ISDN (номер) введите ваш номер телефона, который будет передаваться как Caller ID Number.

5. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Имя пользователя ISDN (номер) может быть переопределено в настройках Маршрутизации исходящих VOIP вызовов.

Чтобы переопределить Имя пользователя ISDN (номер) в параметрах правила Маршрутизации исходящих VOIP вызовов, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Исходящие маршруты.

3. Для редактирования существующего правила, выделите его и нажмите Править (или сделайте двойной щелчок мышью на выбранном правиле).

4. В окне правила VOIP маршрутизация исходящих вызовов, на вкладке Общие, в поле Имя пользователя введите ваш номер телефона, который будет передаваться как Caller ID Number. Чтобы иметь возможность изменить Имя пользователя, опция По умолчанию должна быть выключена.

5. Нажмите кнопку <OK> чтобы зафиксировать изменения.

6. Нажмите кнопку <Применить> чтобы сохранить обновленные параметры правил Маршрутизации исходящих VOIP вызовов. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Примечания

  • Имя пользователя, состоящее из букв, игнорируется, поэтому для включения CallerID в сообщение CAPI 2.0 следует использовать цифры.
  • В зависимости от свойств вашей ISDN карты и ISDN сети, CallerID может быть проигнорирован или переопределен на стороне ISDN оборудования.
  • В случае если вы вводите неправильный ISDN номер, не удовлетворяющий ISDN настройкам вашего оборудования, исходящий вызов может быть отклонен. Заметим, что в случае использования Имени пользователя ISDN (номера), который состоит из букв, такая ошибка невозможна.


Набор добавочного номера

Крупные компании используют добавочные телефонные номера, т.к. обычно невозможно обеспечить каждого сотрудника компании собственным телефонным номером. Связь с добавочными номерами осуществляется через коммутатор компании. Используя добавочные номера, внутренние абоненты могут легко дозвониться до любого отдела или сотрудника компании путем набора простого цифрового кода. Внешние абоненты, которые знают добавочный номер сотрудника, могут подключиться к требуемому абоненту, набрав его добавочный номер после соединения с коммутатором.

Fax Voip T.38 Модем позволяет осуществлять Набор добавочного номера. Иными словами, с Fax Voip T.38 Модем возможно набрать номер, дождаться ответа коммутатора, и затем отослать последовательность DTMF тонов в телефонную линию. Эта функция также может быть использована для работы с различными интерактивными голосовыми системами при исходящих вызовах. Например, если вы пользуетесь телефонной картой и совершаете вызов на номер доступа, вы можете автоматически ввести ПИН-код и затем телефонный номер вызываемого абонента.


Отправка факса на добавочный номер

Отправка факсимильного или голосового сообщения на добавочный номер

Набор добавочного номера ››

Для отправки факса (или голосового сообщения) на телефонный номер с внутренним расширением, необходимо вводить номер используя специальный формат.

<Номер_телефона> W <DTMF>

<Номер_телефона> - номер телефона (коммутатора)

“W” – ждать ответа на вызов

<DTMF> - последовательность DTMF сигналов передаваемая после набора основного номера и ответа на вызов, строка состоящая из следующих символов:

'0 1 2 3 4 5 6 7 8 9 * # A B C D ,'

Символ запятая (‘ , ‘) используется для добавления паузы в 2 секунды между DTMF тонами и может быть использован любое количество раз и в любом месте набираемой последовательности. Отметим также, что в случае плохой SIP сигнализации (получено сообщение 'соединение установлено', но на самом деле реального соединения еще не произошло) модификатор ‘ W ‘ может работать неправильно.

Пример #1: отправка факса на телефонный номер с внутренним расширением.

Чтобы отправить факс на добавочный номер '100' на номер '84952255050', в поле ввода номера факса, в вашей факс программе, введите:

84952255050W,100

Пример #2: отправка факса с использованием телефонной карты.

Предположим, что в ручном режиме вам необходимо выполнить следующую последовательность действий:

1) Набрать телефонный номер доступа '84959371515'.

2) Выбрать язык (нажмите '1' для выбора английского языка), затем нажать решетку ('#').

3) Ввести ПИН-код '11223344', затем нажать решетку ('#').

4) Ввести номер телефона '78313562121', на который требуется отправить факс, затем нажать решетку '#'.

5) Отправить факс в ручном режиме.

Чтобы сделать то же самое автоматически, используя например программу Факсы и сканирование Windows, просто введите следующую последовательность символов в поле Кому для ввода номера факса:

84959371515W,1#,11223344#,,78313562121#

Fax Voip T.38 Модем автоматически наберет номер доступа, дождется ответа системы на звонок, выберет язык, введет ПИН-код, требуемый номер факса и отправит факс. Паузы между наборами DTMF последовательностей будут обеспечены за счет символов запятая. Число запятых подбирается эмпирически.


Факс по запросу

Факс по запросу позволяет вызывающим абонентам получать необходимую информацию по факсу в процессе текущего вызова. Факс по запросу является идеальным электронным помощником для компаний и организаций, которые хотят сделать информацию непрерывно доступной для своих пользователей способами, отличающимися от размещения информации на веб-сайте компании. Компании, обеспечивающие продажу своей продукции или предоставляющие пользователям любую другую непрерывную информацию по факсу будут далеко впереди своих конкурентов, используя Факс по запросу.

Факс по запросу делает работу офиса более эффективной, позволяя экономить деньги и драгоценное время. Факс по запросу снижает накладные расходы на обработку запросов клиентов на получение информации, что позволяет снизить расходы на персонал, телефонию, почту и печать. Телефонные счета будут меньше, так как Факс по запросу использует технологию одного вызова, отсылая документ во время входящего вызова, совершаемого пользователем. Пользователи в свою очередь смогут оценить возможность непосредственного доступа к свежей информации.

При работе с Виртуальными COM портами (модемами), возможность построения системы Факс по запросу зависит только от вашего факс программного обеспечения. В этой главе мы покажем как построить полнофункциональную систему Факс по запросу с использованием программного обеспечения Venta Fax. В комплект Fax Voip T.38 Модем входят необходимый скрипт, а также файлы с голосовыми и факсовыми сообщениями, которые устанавливаются в папку *{CommonAppDataFolder}\FaxVoip Modem\Plugins\VentaFax.

Примечания

  • *{CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Пример VentaFax

Факс по запросу с использованием Venta Fax и Fax Voip T.38 Модем

Факс по запросу ››

Чтобы настроить программу Venta Fax & Voice для работы с Fax Voip T.38 Модем, см. главу Использование Fax Voip T.38 Модем с Venta Fax & Voice настоящего справочного руководства.

Для ознакомления с примером создания системы Факс-по-запросу с использованием Venta Fax и Fax Voip T.38 Модем, см. главу Настройка системы Факс по запросу с использованием Venta Fax и Fax Voip T.38 Модем .


T.38 и G.711 режимы факса

T.38 и G.711 режимы факса при использовании Факс по запросу

Факс по запросу ››

Если вы маршрутизируете входящие вызовы на Виртуальные COM порты (модемы) и при этом используете Факс-по-запросу, следует внимательно отнестись к выбору режима для T.38 факсов (факс отправляется по протоколу T.38 в сторону вызывающего абонента). Следует понимать, что поведение будет отличаться от стандартного, т.е. когда факс приложение принимает факс от вызывающего абонента. Заметим, что данная особенность может не позволить полноценно использовать сценарий, подобный описанному в разделе Настройка системы Факс по запросу с использованием Venta Fax и Fax Voip T.38 Модем в некоторых VoIP сетях. Напомним, что упомянутый сценарий позволяет принимать или отправлять факс в зависимости от выбора пользователя.

Для настройки режима факса при использовании Факс-по-запросу, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите IP-телефония, затем нажмите Входящие маршруты.

3. Выберите правило, которое маршрутизирует входящие вызовы на Виртуальные COM порты (модемы). Нажмите Править.

4. В окне правила VOIP маршрутизация входящих вызовов, перейдите на вкладку Факс.

5. В области Режимы факса задайте требуемый режим.

Возможны следующие режимы (поведение рассматривается с точки зрения функции Факс-по-запросу, что предполагает отправку факса во время входящего вызова):

G711 факс (G711)

Этот режим аналогичен режиму G711 факс (G711) для случая исходящих вызовов. После ответа на исходящий вызов, Fax Voip T.38 Модем работает в режиме отправки G711 факс. В случае получения T.38 ре-инвайта от вызываемой стороны, Fax Voip T.38 Модем отвечает 'не поддерживается' и продолжает отправку факса в аудио режиме, если обе стороны согласились что это возможно. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Выключите опцию T.38 факс.

3. Выключите опцию Ждать T.38 ре-инвайт.

G711 факс + T38 факс с ожиданием ре-инвайта (T38R,G711)

Этот режим аналогичен режиму G711 факс + T38 факс (G711,T38) для случая исходящих вызовов. После ответа на исходящий вызов, Fax Voip T.38 Модем работает в режиме отправки G711 факс. В случае получения T.38 ре-инвайта от вызываемой стороны, Fax Voip T.38 Модем переключается в режим T.38 и отправляет факс по протоколу T.38. Если T.38 ре-инвайт не получен, Fax Voip T.38 Модем продолжает использовать аудио режим (G711 факс) для отправки факса. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Выключите опцию T.38 факс.

3. Включите опцию Ждать T.38 ре-инвайт.

T38 факс + G711 факс (T38,G711)

Этот режим аналогичен режиму T38 факс с отправкой ре-инвайта + G711 факс (T38+R,G711) для случая исходящих вызовов. Fax Voip T.38 Модем работает в режиме отправки T38 факс (отсылает T.38 ре-инвайт в направлении вызываемой стороны). В случае положительного ответа от вызываемой стороны, Fax Voip T.38 Модем отправляет факс по протоколу T.38. Если вызываемая сторона отвечает 'не поддерживается', Fax Voip T.38 Модем переключается в режим G711факс и отправляет факс как аудио. Для установки этого режима в правиле Маршрутизации исходящих VOIP вызовов:

1. Включите опцию Факс поверх G.711.

2. Включите опцию T.38 факс.

3. Выключите опцию Ждать T.38 ре-инвайт.

6. Нажмите кнопку <OK>.

7. В главном окне Панели управления Fax Voip T.38 Модем нажмите <Применить> чтобы сохранить изменения. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами. Для этого нажмите кнопку <СТОП>, затем нажмите кнопку <СТАРТ>.

Примечания

  • При отправке факса через ISDN CAPI 2.0 линию всегда используется режим G.711 аудио факс.


Служба факсов Windows

Использование Fax Voip T.38 Модем cо службой факсов Windows

Служба факсов Windows и приложение Факсы и сканирование Windows представляют собой интегрированное факс программное обеспечение включенное во все версии Windows. Microsoft Fax является расширяемой факс платформой, которую можно использовать для развертывания совместно используемых факс ресурсов в вашей организации. Пользователи внутри организации могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере, а также использовать локальные факс устройства, привязанные к их компьютерам. Факс администраторы могут конфигурировать, управлять и следить за этими общими ресурсами факсов. Централизованное управление общими факс-устройствами на базе сервера означает более простое управление и техническое обслуживание, а также низкую стоимость. Пользователи факса могут отправлять и получать факсы без необходимости использования ручных факс-аппаратов, экономя при этом время и силы.

В процессе установки, Fax Voip T.38 Модем всегда пытается автоматически установить Службу факсов Windows на вашем компьютере, если она не установлена. Чтобы вручную установить Службу факсов Windows, следуйте инструкциям главы Установка службы факсов Windows настоящего справочного руководства.

Служба факсов Windows может работать с Виртуальными COM портами Fax Voip через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. По сравнению с драйвером стандартного модема, этот драйвер обеспечивает поддержку Caller ID. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Чтобы установить Виртуальные COM порты и связанные с ними модемы, в Панели управления Fax Voip T.38 Модем, выберите Порты и модемы, а затем нажмите кнопку <Добавить/удалить>, см. Добавление/удаление Виртуальных COM портов Fax Voip . Чтобы установить или переустановить модемы без переустановки Виртуальных COM портов, воспользуйтесь кнопкой <Модемы>, см. также Добавление/удаление модемов Fax Voip .

В процессе установки, Fax Voip T.38 Модем всегда пытается автоматически настроить Службу факсов Windows на использование устройств Fax Voip 14.4K TAPI Voice-Fax Modem для отправки и приема факсов. Чтобы вручную настроить Службу факсов Windows, следуйте инструкциям главы Настройка службы факсов настоящего справочного руководства.

В процессе установки, Fax Voip T.38 Модем настраивает Службу факсов Windows на использование 'Fax Voip T.38 Modem' в качестве Идентификатора факса для всех устройств Fax Voip 14.4K TAPI Voice-Fax Modem. Чтобы вручную настроить Идентификатор факса и Заголовок факса, следуйте инструкциям главы Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

Расширение маршрутизации Fax Voip T.38 Модем (отвечает за методы маршрутизации для входящих факсов (Microsoft Fax): e-mail, сохранить в папке, печать, пользовательский ) должно быть зарегистрировано в операционной системе для работы со Службой факсов Windows. Чтобы зарегистрировать Расширение маршрутизации Fax Voip T.38 Модем, восстановить компоненты службы факсов, а также легко настроить Службу факсов Windows для отправки/получения факсов через модемы Fax Voip в одно действие, см. Настройка службы факсов из панели управления Fax Voip T.38 Модем .

Чтобы отправить факс с помощью принтера Fax и программного обеспечения Факсы и сканирование Windows, см. Отправка факсов .

Для получения факсов с помощью программного обеспечения Факсы и сканирование Windows, см. Получение факсов .

Чтобы узнать больше о том, как отслеживать ход передачи входящих и исходящих факсов, см. Мониторинг и уведомления .

Вместе с Виртуальными COM портами (модемами) Fax Voip и Службой Microsoft Fax вы также можете использовать функцию Почта-на-факс - Microsoft Fax и методы маршрутизации для исходящих факсов (Microsoft Fax) : уведомления о доставке по электронной почте , сохранить в папке , печать , пользовательский .

Чтобы настроить факс сервер, развернутый на базе операционной системы Windows Server, для совместного использования с клиентскими компьютерами, следуйте инструкциям главы Совместное использование ресурсов факса настоящего справочного руководства.

Чтобы просматривать факсы, созданные другим пользователем, и управлять ими, следуйте инструкциям главы Доступ к факсам другого пользователя настоящего справочного руководства.

При возникновении проблем, см. Устранение неполадок службы факсов Windows .

Примечания

  • Максимально возможное количество устройств (модемов), которое можно использовать со Службой факсов Windows, зависит от операционной системы. В Windows 11, Windows 10, Windows 8/8.1 или Windows 7, вы можете использовать одно факсимильное устройство (модем). В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2, Windows Server 2008R2, Enterprise или Datacenter Edition, ограничение на количество модемов отсутствует. В других версиях Windows 2008R2, максимально допустимое число устройств (модемов) обычно равно четырем.
  • При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Настройка службы факсов из панели управления Fax Voip T.38 Модем

Служба факсов Windows ››

Вы можете легко настроить Службу факсов Windows для отправки/получения факсов через модемы Fax Voip в одно действие с помощью кнопки Настройка факс службы в Панели управления Fax Voip T.38 Модем . Эта команда также восстанавливает компоненты Службы факсов Windows на вашем компьютере (при необходимости) и осуществляет перерегистрацию Расширения маршрутизации Fax Voip T.38 Модем (отвечает за методы маршрутизации для входящих факсов - Microsoft Fax ) со Службой факсов Windows. Обратите внимание, что программа установки Fax Voip T.38 Модем автоматически выполняет указанные действия. Чтобы настроить службу факсов и зарегистрировать Расширение маршрутизации Fax Voip T.38 Модем без переустановки программы, выполните следующие действия:

1. Откройте Панель управления Fax Voip T.38 Модем. Для этого нажмите Пуск, выберите Fax Voip T.38 Modem; нажмите Панель управления Fax Voip T.38 Modem. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip T.38 Модем из меню иконки Fax Voip T.38 Модем в системном трее.

2. В Панели управления Fax Voip T.38 Модем, на вкладке Главная ленты, нажмите Настройка факс службы. Требуются права администратора.

3. Подождите, пока программа не завершит необходимые действия. Служба факсов Windows может быть перезапущена несколько раз.

4. В окне Параметры службы факсов Windows вы можете указать необходимые параметры для настройки службы факсов с модемами Fax Voip.

На компьютере с Windows 11 следует выбрать единственное устройство Fax Voip 14.4K TAPI Voice-Fax Modem, которое вы бы хотели использовать для отправки и получения факсов через службу факсов Windows.

На компьютере с Windows Server 2022, указанные вами параметры будут применены ко всем устройствам Fax Voip 14.4K TAPI Voice-Fax Modem, которые в данный момент установлены в вашей системе.

Следующие параметры могут быть настроены:

Параметры отправки и получения

Разрешить отправку факсов

Укажите, следует ли использовать модем(ы) Fax Voip для отправки факсов.

Разрешить получение факсов

Укажите, следует ли использовать модем(ы) Fax Voip для приема факсов.

Автоматически отвечать после ... звонков

Задайте число звонков на линии, после которых модем(ы) Fax Voip должны автоматически отвечать на входящий факс.

Идентификация

Использовать код устройства передающего абонента (TSID)

Если эта опция включена, то при отправке исходящего факса получателю передается идентификатор факса (TSID, Transmitting Subscriber ID), указанный в настройках факс устройства, которое использовалось для передачи факса. Если эта опция выключена, передаваемый идентификатор факса совпадает с номером факса отправителя, который указан в Сведениях об отправителе. См. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

ИД TSID

Укажите Transmitting Subscriber Identification (Код передающего абонента, TSID). TSID - это текстовая строка, идентифицирующая данного пользователя как отправителя факса. Она передается получателю при отправке факса и может быть выведена на дисплей факс-аппарата получателя. Код TSID может содержать до 20 символов текста.

ИД CSID

Укажите Called Subscriber Identification (Код вызываемого абонента, CSID). CSID - это текстовая строка, идентифицирующая данного пользователя как получателя факса. Она возвращается отправителю при получении факса и может быть выведена на дисплей факс-аппарата отправителя. Код CSID может содержать до 20 символов текста.

Я настрою факсимильные устройства самостоятельно.

Установите этот флажок, если вы не хотите, чтобы Fax Voip T.38 Модем автоматически настроил службу факсов, или если вы не хотите изменять текущую конфигурацию.

5. В окне Параметры службы факсов Windows нажмите OK.

6. Подождите, пока программа не завершит все необходимые действия. Служба факсов Windows может быть перезапущена несколько раз.

7. Для просмотра лог-файла, в диалоговом окне нажмите Да.

Ниже приведен полный список действий, производимых при выполнении команды Настройка факс службы (действия, помеченные как опциональные, не выполняются, если пользователь выбирает опцию Я настрою факсимильные устройства самостоятельно, см. рисунки выше):

  • Остановка Службы факсов Windows.
  • Установка Службы факсов Windows, если она не установлена (все поддерживаемые операционные системы).
  • Установка компонента Возможности рабочего стола, если он не установлен (Windows Server 2012/2012R2 и Windows Server 2008R2).
  • Регистрация Расширения маршрутизации Fax Voip T.38 Модем (отвечает за методы маршрутизации для входящих факсов - Microsoft Fax ) со Службой факсов Windows.
  • Настройка разрешений безопасности для Службы факсов Windows.
  • Настройка автоматического запуска Службы факсов Windows при загрузке Windows.
  • Добавление Учетной записи факса с именем 'Fax Voip T.38 Modem', если учетная запись еще не создана.
  • Настройка службы факсов для архивирования всех успешно отправленных факсов в папку Отправленные. Необходимо для обеспечения правильной работы методов маршрутизации для исходящих факсов - Microsoft Fax .
  • В Windows 11, Windows 10 версии 1709 или более поздней, а также в Windows Server 2022 и Windows Server 2019: Исправление ошибки в Microsoft Modem Device Provider из-за которой CallerID и TSID не сохраняются в базе данных службы факсов после получения факса в этих версиях Windows.
  • В Windows 11, Windows 10, Windows Server 2022, Windows Server 2019 и Windows Server 2016: Исправление ошибки в программе Факсы и сканирование Windows из-за которой кнопка 'Переслать по электронной почте' неактивна, в то время как e-mail клиент с поддержкой MAPI установлен в системе.
  • Создание ярлыка Факсы и сканирование на рабочем столе. В Windows 8 и более поздних версиях, создание ярлыка Факсы и сканирование в меню 'Пуск'. В ОС Windows Server, создание ярлыка Диспетчер службы факсов на рабочем столе и в меню 'Пуск'.
  • (опционально) Настройка Кода передающего абонента (TSID) и Кода вызываемого абонента (CSID) для всех факсимильных устройств Fax Voip 14.4K TAPI Voice-Fax Modem (по умолчанию 'Fax Voip T.38 Modem'). Настройка параметра Использовать код устройства передающего абонента (TSID), см. также в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.
  • (опционально) В Windows 11, Windows 10, Windows 8/8.1 и Windows 7: настройка выбранного факсимильного устройства Fax Voip 14.4K TAPI Voice-Fax Modem для отправки и/или приема факсов. По умолчанию разрешены как отправка, так и получение факсов.
  • (опционально) В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2: настройка всех факсимильных устройств Fax Voip 14.4K TAPI Voice-Fax Modem для отправки и/или приема факсов. По умолчанию разрешены как отправка, так и получение факсов.
  • (опционально) В Windows 11, Windows 10, Windows 8/8.1 и Windows 7: включение монитора факсов и уведомлений о факсах для выбранного факсимильного устройства Fax Voip 14.4K TAPI Voice-Fax Modem.
  • (опционально) В Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2: включение монитора факсов и уведомлений для первого факсимильного устройства Fax Voip 14.4K TAPI Voice-Fax Modem.
  • Включение / выключение методов маршрутизации факса, определенных Расширением маршрутизации Fax Voip T.38 Модем для всех факсимильных устройств Fax Voip 14.4K TAPI Voice-Fax Modem, в зависимости от текущих настроек.
  • Запуск Службы факсов Windows.


Установка службы факсов

Установка службы факсов Windows

Служба факсов Windows ››

Служба факсов Windows (приложение Факсы и сканирование Windows) обычно уже установлена по умолчанию на компьютерах с Windows 11, Windows 10, Windows 8/8.1 и Windows 7.

Служба факсов Windows (роль Факс-сервера) обычно не установлена по умолчанию на компьютерах с Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 и Windows Server 2008R2.

В процессе установки, Fax Voip T.38 Модем всегда пытается автоматически установить Службу факсов Windows на вашем компьютере, если она не установлена.

Чтобы вручную установить Службу факсов Windows в Windows 10 (ранние версии), Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10 настоящего справочного руководства.

Чтобы вручную установить Службу факсов Windows в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022 настоящего справочного руководства.

После ручной установки Службы факсов Windows, обычно необходимо зарегистрировать Расширение маршрутизации Fax Voip T.38 Модем со Службой факсов Windows, см. главу Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.


Windows 10

Чтобы установить Факсы и сканирование Windows на компьютере с Windows 10

Служба факсов Windows ›› Установка службы факсов ››

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления.

2. В Панели управления нажмите Программы, а затем нажмите Включение или отключение компонентов Windows.

3. В появившемся окне Компоненты Windows поставьте флажок у компонента Факсы и сканирование Windows, а затем нажмите OK.

Примечания

  • Инструкции выше не применимы к Windows 11 и поздним версиям Windows 10, в которых компонент Факсы и сканирование Windows всегда установлен и не может быть удален или установлен таким образом.


Windows Server 2022

Чтобы установить роль Факс-сервера на компьютере с Windows Server 2022

Служба факсов Windows ›› Установка службы факсов ››

1. Нажмите Пуск, а затем нажмите Диспетчер серверов.

2. В окне Диспетчер серверов, в левой панели выберите Добавить роли и компоненты.

3. В появившемся окне Мастер добавления ролей и компонентов, на странице Выбор ролей сервера, поставьте флажок у роли Факс-сервер.

4. В появившемся диалоговом окне нажмите Добавить компоненты чтобы добавить требуемые службы ролей.

5. В окне Мастер добавления ролей и компонентов нажмите Далее.

6. Следуйте инструкциям Мастера добавления ролей и компонентов. Для получения более подробной информации, ищите Установка роли факс-сервера в справочной системе Windows.


Настройка службы факсов

Настройка службы факсов Windows

Служба факсов Windows ››

В процессе установки, Fax Voip T.38 Модем всегда пытается автоматически настроить Службу факсов Windows на использование устройств Fax Voip 14.4K TAPI Voice-Fax Modem для отправки и приема факсов.

Чтобы вручную настроить Службу факсов Windows в Windows 11, Windows 10, Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы настроить службу факсов в Windows 11 настоящего справочного руководства.

Чтобы вручную настроить Службу факсов Windows в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы настроить службу факсов в Windows Server 2022 настоящего справочного руководства.


Windows 11

Чтобы настроить службу факсов в Windows 11

Служба факсов Windows ›› Настройка службы факсов ››

1. Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование.

Кроме того, вы можете воспользоваться командой Факсы и сканирование Windows из меню иконки Fax Voip T.38 Модем в системном трее или командой Факсы и сканирование Windows в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

3. Нажмите Подключиться к факс-модему и следуйте инструкциям.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... .

5. В окне Параметры факса, на вкладке Общие, нажмите Выбрать устройство... .

6. В диалоговом окне Выбор устройства, выберите факсимильное устройство Fax Voip 14.4K TAPI Voice-Fax Modem. Затем нажмите OK.

7. Вернувшись на вкладку Общие, поставьте флажок у параметра Разрешить устройству отправку факсов. Если вы хотите принимать входящие факсы, поставьте флажок у параметра Разрешить устройству получение факсов. Выберите опцию Автоматически отвечать... . Затем нажмите OK.


Windows Server 2022

Чтобы настроить службу факсов в Windows Server 2022

Служба факсов Windows ›› Настройка службы факсов ››

Чтобы получить доступ к приложению Факсы и сканирование Windows

Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование.

Кроме того, вы можете воспользоваться командой Факсы и сканирование Windows из меню иконки Fax Voip T.38 Модем в системном трее или командой Факсы и сканирование Windows в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

Чтобы получить доступ к Диспетчеру службы факсов

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Либо переключитесь на панель Поиск, наберите диспетчер службы факсов, а затем выберите команду Диспетчер службы факсов.

Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip 14.4K TAPI Voice-Fax Modem. В контекстном меню, нажмите Свойства.

3. В окне свойств, на вкладке Общие, поставьте флажок у параметра Отправка факсов. Чтобы иметь возможность принимать входящие факсы, поставьте флажок у параметра Получение факсов и выберите вариант Отвечать автоматически. В полях Код передающего абонента (TSID) и Код вызываемого абонента (CSID), по желанию введите ваш номер факса. Затем нажмите OK. Заметим, что эти параметры настраиваются индивидуально для каждого модема.

4. В левой панели, щелкните дважды на устройстве Fax Voip 14.4K TAPI Voice-Fax Modem, нажмите Методы для входящих, а затем в правой панели, в зависимости от ваших интересов, настройте методы для входящих факсов чтобы автоматически осуществлять Печать, Отправку по электронной почте или Сохранение в папке полученных факсов. Заметим, что методы для входящих факсов настраиваются индивидуально для каждого устройства (модема).

Добавление учетной записи факса

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

2. Нажмите Подключиться к факс-модему и следуйте инструкциям.


Совместное использование ресурсов факса

Служба факсов Windows ››

Факс сервер, развернутый на базе операционной системы Windows Server, может совместно использоваться пользователями в локальной сети. Пользователи на своих клиентских компьютерах (Windows 11, Windows 10 и т.д.) могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере.

Чтобы настроить факс сервер в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2 для совместного использования с клиентскими компьютерами, следуйте инструкциям главы Настройка факс сервера (Windows Server 2022) настоящего справочного руководства.

Чтобы подключить клиентский компьютер к факс серверу в вашей сети, следуйте инструкциям главы Настройка факс клиента (Windows 11) настоящего справочного руководства.

Примечания

  • Вы не можете совместно использовать факсимильные ресурсы рабочей станции (Windows 11, Windows 10, Windows 8/8.1 или Windows 7).
  • В инструкциях в этой главе предполагается, что оба компьютера (сервер и клиент) являются членами рабочей группы.


Настройка факс сервера

Настройка факс сервера (Windows Server 2022)

Служба факсов Windows ›› Совместное использование ресурсов факса ››

Общий доступ к принтеру факсов

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Свойства принтера. Кроме того, вы можете воспользоваться командой Принтер факсов в Панели управления Fax Voip T.38 Модем , на ленте, на вкладке Главная.

2. В окне Свойства: Fax, перейдите на вкладку Доступ, выберите Общий доступ к данному принтеру, а затем введите имя принтера, которое должно отображаться для сетевых пользователей. Нажмите OK.

Настройка учетных записей пользователей

Чтобы получить доступ к факс серверу, работающему под управлением Windows Server 2022, пользователь должен иметь учетную запись.

Чтобы добавить локальную учетную запись пользователя, выполните следующие действия:

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Управление компьютером. В окне Управление компьютером, разверните Локальные пользователи и группы, щелкните правой кнопкой мыши Пользователи, а затем выберите Новый пользователь.

2. В окне Новый пользователь, введите имя пользователя и пароль. Ниже выберите наиболее подходящие опции, связанные с тем, как будет обрабатываться пароль, нажмите Создать, а затем закройте окно.

3. В окне Управление компьютером, убедитесь, что новый пользователь отображается в списке пользователей.

Факс сервер можно настроить таким образом, чтобы учетная запись автоматически создавалась при первом использовании Факсы и сканирование Windows для отправки факса. При использовании этой опции, как только пользователь подключается к факс-серверу, учетная запись создается автоматически.

Если вы хотите ограничить количество пользователей, подключающихся к факс-серверу, вы можете отключить эту настройку. В этом случае вы должны вручную создать учетные записи для всех пользователей, которым необходим доступ к факс серверу. При такой настройке, если пользователь пытается подключиться к серверу, не имея еще учетной записи, попытка подключения не удастся.

Для автоматического создания учетных записей пользователей факс сервера, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, поставьте флажок у параметра Автоматически создавать учетные записи при подключении чтобы администратору не нужно было явно создавать каждую учетную запись пользователя. Нажмите OK.

Чтобы вручную добавить учетную запись пользователя факс сервера, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните Учетные записи.

3. В правой панели, просмотрите существующие учетные записи, а затем определите, какие новые учетные записи вы хотите добавить.

4. Чтобы добавить новую учетную запись, щелкните правой кнопкой мыши Учетные записи, выберите Создать, а затем выберите Учетная запись.

5. В окне Создание новой учетной записи, укажите имя пользователя и домен, а затем нажмите Создать. Обратите внимание, что имя пользователя должно соответствовать локальной учетной записи пользователя, которую вы создали ранее.

6. В Диспетчере службы факса (Microsoft), убедитесь, что новая учетная запись отображается в списке учетных записей.

Настройка доступа к папке "Входящие" на факс сервере

Чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для всех учетных записей, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, в области Параметры переназначения, выберите опцию Выключить чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для всех учетных записей. Нажмите OK.

Чтобы разрешить доступ к папке "Входящие" на факс сервере и просмотр входящих факсов для отдельных учетных записей, выполните следующие действия:

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Учетные записи, в области Параметры переназначения, выберите опцию Включить чтобы переназначить полученные факсимильные сообщения только отдельным учетным записям. Нажмите OK.

3. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

4. На вкладке Безопасность, нажмите Дополнительно.

5. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения, связанную с желаемой учетной записью пользователя, и нажмите Изменить. Если запись разрешения отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

6. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажок Управление папкой получения на сервере. Нажмите OK. См. картинку ниже.

7. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.


Настройка факс клиента

Настройка факс клиента (Windows 11)

Служба факсов Windows ›› Совместное использование ресурсов факса ››

Чтобы подключить клиентский компьютер к факс серверу, расположенному в вашей сети, выполните следующие действия:

1. В проводнике Windows, введите имя или адрес компьютера в вашей сети (операционная система Windows Server), на котором установлен общий факс сервер. Щелкните кнопку Переход к... или нажмите клавишу Enter.

2. В окне Безопасность Windows, введите имя пользователя и пароль, связанные с учетной записью пользователя, созданной на сервере для отправки факсов, см. главу Настройка факс сервера настоящего справочного руководства. Установите флажок Запомнить учетные данные, это очень важно. Нажмите OK.

3. Убедитесь, что принтер факсов отображается в папке.

4. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Учетные записи пользователей, а затем нажмите Управление учетными данными Windows.

5. В Диспетчере учетных данных, на странице Учетные данные Windows убедитесь, что присутствует запись, связанная с вашим сервером и учетной записью пользователя, созданной на сервере для отправки факсов. Если запись отсутствует, создайте ее, щелкнув по ссылке Добавить учетные данные Windows, см. рисунок ниже.

6. Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Нажмите Добавить... .

7. На странице Выберите факс-модем или сервер нажмите Подключиться к факс-серверу в сети.

8. На странице Введите размещение сервера факсов, введите имя или адрес компьютера в вашей сети (операционная система Windows Server), на котором установлен общий факс сервер. Следуйте инструкциям мастера.

9. Убедитесь, что учетная запись факса была успешно создана.


Конфигурирование идентификатора и заголовка факса

Служба факсов Windows ››

При отправке и получении факсов, обычно требуется задать Идентификатор факса и Заголовок факса, эти параметры конфигурируются в программном обеспечении Службы факсов Windows.

TSID (Код передающего абонента, Transmitting Subscriber Identification) - это Идентификатор факса передающей факсимильной станции. TSID - это текстовая строка, идентифицирующая данного пользователя как отправителя факса. Она передается получателю при отправке факса и может быть выведена на дисплей факс-аппарата получателя. Код TSID передается в верхней части каждой страницы отправляемого факса. Код TSID, как правило, представляет собой комбинацию из номера факса отправителя и названия организации. Код TSID может содержать до 20 символов текста.

CSID (Код вызываемого абонента, Called Subscriber Identification) - это Идентификатор факса принимающей факсимильной станции. CSID - это текстовая строка, идентифицирующая данного пользователя как получателя факса. Она возвращается отправителю при получении факса и может быть выведена на дисплей факс-аппарата отправителя. Код CSID обычно состоит из номера факса получателя и названия организации. Коды CSID и TSID пользователя могут совпадать. Код CSID может содержать до 20 символов текста.

Заголовок факса - это текстовая строка, которая также передается в верхней части каждой страницы отправляемого факса. Обычно название вашей организации. Заголовок факса может содержать до 50 символов текста.

В процессе установки, Fax Voip T.38 Модем настраивает Службу факсов Windows на использование 'Fax Voip T.38 Modem' в качестве Идентификатора факса для всех устройств Fax Voip 14.4K TAPI Voice-Fax Modem.

Чтобы настроить Идентификатор факса и Заголовок факса в Windows 11, Windows 10, Windows 8/8.1 или Windows 7, следуйте инструкциям главы Чтобы задать идентификатор факса и заголовок факса в Windows 11 настоящего справочного руководства.

Чтобы настроить Идентификатор факса и Заголовок факса в Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012/2012R2 или Windows Server 2008R2, следуйте инструкциям главы Чтобы задать идентификатор факса и заголовок факса в Windows Server 2022 настоящего справочного руководства.


Windows 11

Чтобы задать идентификатор факса и заголовок факса в Windows 11

Служба факсов Windows ›› Конфигурирование идентификатора и заголовка факса ››

Обратите внимание, что параметр Использовать код устройства передающего абонента (TSID) можно настроить с помощью кнопки Настройка факс службы в Панели управления Fax Voip T.38 Модем , см. Настройка службы факсов из панели управления Fax Voip T.38 Модем . В этом случае вам не нужно вручную редактировать реестр Windows и перезапускать службу факсов Windows.

Исходящий факс. Использовать код устройства передающего абонента (TSID).

Этот метод не позволяет переопределять Идентификатор факса (TSID).

1. Для использования этого метода следует установить значение параметра UseDeviceTsid равным 1. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Выполнить. Введите regedit; нажмите OK чтобы запустить Редактор реестра. Найдите раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax. Создайте параметр UseDeviceTsid (REG_DWORD), если он отсутствует. Установите значение параметра UseDeviceTsid равным 1 как показано на рисунке ниже.

2. Перезапустите Службу факсов Windows. Для этого в Панели управления Fax Voip T.38 Модем , из меню Файл выберите команду Перезапустить Службу факсов Windows.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... . В окне Параметры факса, на вкладке Общие, нажмите Дополнительные параметры... . В окне Дополнительные параметры, в поле ИД TSID, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите OK. В окне Параметры факса нажмите OK.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Исходящий факс. Не использовать код устройства передающего абонента (TSID).

Используя этот метод, вы можете переопределять Идентификатор факса (TSID) при создании факса.

1. Для использования этого метода следует установить значение параметра UseDeviceTsid равным 0 (нуль). Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Выполнить. Введите regedit; нажмите OK чтобы запустить Редактор реестра. Найдите раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax. Создайте параметр UseDeviceTsid (REG_DWORD), если он отсутствует. Установите значение параметра UseDeviceTsid равным 0 (нулю) как показано на рисунке ниже.

2. Перезапустите Службу факсов Windows. Для этого в Панели управления Fax Voip T.38 Модем , из меню Файл выберите команду Перезапустить Службу факсов Windows.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Входящий факс

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... . В окне Параметры факса, на вкладке Общие, нажмите Дополнительные параметры... . В окне Дополнительные параметры, в поле ИД CSID, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите OK.


Windows Server 2022

Чтобы задать идентификатор факса и заголовок факса в Windows Server 2022

Служба факсов Windows ›› Конфигурирование идентификатора и заголовка факса ››

Обратите внимание, что параметр Использовать код устройства передающего абонента (TSID) можно также настроить с помощью кнопки Настройка факс службы в Панели управления Fax Voip T.38 Модем , см. Настройка службы факсов из панели управления Fax Voip T.38 Модем .

Исходящий факс. Использовать код устройства передающего абонента (TSID).

Этот метод не позволяет переопределять Идентификатор факса (TSID).

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Исходящие, поставьте флажок у параметра Использовать код устройства передающего абонента (TSID). Нажмите Применить.

3. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip 14.4K TAPI Voice-Fax Modem. В контекстном меню, нажмите Свойства. На вкладке Общие, в поле Код передающего абонента (TSID), задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите Применить.

4. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Исходящий факс. Не использовать код устройства передающего абонента (TSID).

Используя этот метод, вы можете переопределять Идентификатор факса (TSID) при создании факса.

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс. В контекстном меню, нажмите Свойства. В окне Свойства: Факс (Локальный), на вкладке Исходящие, снимите флажок у параметра Использовать код устройства передающего абонента (TSID). Нажмите Применить.

3. В Факсы и сканирование Windows, в меню Сервис, нажмите Сведения об отправителе.... В окне Сведения об отправителе, в поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста. Нажмите OK.

Входящий факс

1. Нажмите Пуск, а затем нажмите Диспетчер серверов. В Диспетчере серверов, выберите команду Диспетчер службы факсов из меню Средства. Кроме того, вы можете воспользоваться командой Диспетчер службы факсов из меню иконки Fax Voip T.38 Модем в системном трее или командой Диспетчер службы факсов в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В Диспетчере службы факса (Microsoft), в левой панели, щелкните дважды Факс, щелкните дважды Устройства и поставщики, щелкните дважды Устройства, а затем щелкните правой кнопкой мыши устройство Fax Voip 14.4K TAPI Voice-Fax Modem. В контекстном меню, нажмите Свойства. На вкладке Общие, в поле Код вызываемого абонента (CSID), задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Нажмите Применить.


Отправка и получение факсов

Служба факсов Windows ››

  • Отправка факсов
  • Получение факсов
  • Мониторинг и уведомления


Отправка факсов

Служба факсов Windows ›› Отправка и получение факсов ››

Факс можно отправить из приложения Windows, открыв или создав документ в этом приложении, а затем распечатав его на принтере факсов. Соответствующие инструкции см. в разделе Отправка факса из приложения Windows .

Чтобы отправить факс из Панели управления Fax Voip T.38 Модем, обратитесь к разделу Отправка факса из Fax Voip T.38 Modem .

Чтобы задать Идентификатор факса и Заголовок факса, обратитесь к разделу Настройка сведений об отправителе .

Чтобы настроить качество изображения для отправляемых факсов, обратитесь к разделу Настройка качества изображения .

Чтобы отправить факс с помощью утилиты SendFaxMS.exe, см. Утилита командной строки SendFaxMS.exe . Более подробную информацию можно найти в главе Отправка факса с помощью утилиты SendFaxMS.exe - Microsoft Fax настоящего справочного руководства.

Чтобы отправить факс от имени учетной записи другого пользователя, обратитесь к разделу Отправка факса с использованием другой учетной записи .

Чтобы получить подробную информацию о том, как отслеживать ход отправки факсов, обратитесь к разделу Мониторинг и уведомления .


Отправка факса из приложения Windows

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. Выберите в списке установленный принтер факсов и нажмите Печать.

3. В окне Новый факс, введите номер факса получателя в поле Кому.

4. В поле Титульный лист, опционально выберите титульный лист, который будет передан в качестве первой страницы факса.

5. В поле Правило набора, опционально выберите правило набора номера. Правила набора номера (TAPI) применяются при преобразовании номеров факсов, введенных в каноническом формате (например +1 (425) 123-4567). Обратите внимание, что выбор конкретного правила в этом поле может изменить местоположение вызова по умолчанию, выбранное в диалоговом окне Телефон и модем в панели управления Windows. Дополнительные сведения об использовании правил набора см. в главах Набор номера (телефония Microsoft) - Microsoft Fax и Общие сведения о правилах набора номера настоящего справочного руководства.

6. Опционально, введите соответствующую информацию в поля Тема и Примечания.

7. Опционально, настройте сведения об отправителе .

8. Для отправки факса нажмите Отправка.

Ваш компьютер автоматически наберет номер факса и будет отправлять факс.


Отправка факса из Fax Voip T.38 Модем

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

1. В Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты, в группе Факсы и сканирование Windows, нажмите Создать факс.

2. В диалоговом окне Выбор факсимильного сообщения, выберите документ, который вы бы хотели отправить по факсу, затем нажмите Открыть. Любой документ, для которого доступна функция печати, можно отправить в качестве факса.

3. Следуйте инструкциям из предыдущего раздела .

Примечания

  • Вы также можете отправить факс, щелкнув правой кнопкой мыши по файлу в проводнике Windows и выбрав команду Получатель факса из подменю Отправить.


Настройка сведений об отправителе

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

Приведенные ниже инструкции позволяют переопределить Идентификатор факса и Заголовок факса при отправке факса .

1. В окне Новый факс, в меню Сервис, нажмите Сведения об отправителе... .

2. Чтобы переопределить настройки по умолчанию, в окне Сведения об отправителе, поставьте флажок Сведения об отправителе.

3. В поле Номер факса, задайте ваш Идентификатор факса. Может содержать до 20 символов текста. Обратие внимание, что вы можете переопределить Код TSID таким способом, только если опция Использовать код устройства передающего абонента (TSID) отключена, см. в главе Конфигурирование идентификатора и заголовка факса настоящего справочного руководства.

4. В поле Организация, задайте ваш Заголовок факса. Может содержать до 50 символов текста.

5. Нажмите OK.


Настройка качества изображения

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

Можно выбрать разрешение для отправляемых факсов. Различным уровням разрешения, выражаемым числом точек на дюйм, присваиваются обобщенные названия, например Обычное (200x200 точек/дюйм) или Черновое (200x100 точек/дюйм). Эти уровни разрешения не обязательно гарантируют ту же четкость, которую можно наблюдать при создании документа в приложении Windows. При просмотре факса перед отправкой изображение документа будет более четким.

Для установки параметров принтера факсов:

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Настройка печати. Кроме того, вы можете нажать Принтер факсов в Панели управления Fax Voip T.38 Модем , на ленте, на вкладке Главная, а затем нажать Настройка... .

2. В окне Настройка печати: Fax, выберите стандартное разрешение из списка Качество изображения.

Обратите внимание, что при создании и отправке факса из приложения Windows, приложение может использовать индивидуальные параметры, имеющие приоритет над глобальными параметрами настройки принтера. По этой причине мы рекомендуем вам проверить разрешение принтера непосредственно перед печатью.


Утилита командной строки SendFaxMS.exe

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

При использовании службы факсов Windows и приложения Факсы и сканирование Windows, вы можете отправить факс с помощью утилиты SendFaxMS.exe, которая включена в программное обеспечение Fax Voip T.38 Модем и позволяет автоматически создавать факс, а затем отслеживать его, подробнее см. главу Отправка факса с помощью утилиты SendFaxMS.exe - Microsoft Fax настоящего справочного руководства.

Для получения подробных сведений о параметрах командной строки SendFaxMS.exe, см. Параметры командной строки SendFaxMS.exe - Microsoft Fax .

Кроме того, в вашем распоряжении есть полезный визуальный инструмент, который позволяет легко настроить параметры командной строки, а затем запустить SendFaxMS.exe непосредственно из Панели управления Fax Voip T.38 Модем, см. Настройка и запуск SendFaxMS.exe (Microsoft Fax) из панели управления Fax Voip T.38 Модем .


Отправка факса с использованием другой учетной записи

Служба факсов Windows ›› Отправка и получение факсов ›› Отправка факсов ››

По умолчанию новый факс создается от имени текущего пользователя, который вошел в систему. В этой главе объясняется, как отправить факс, используя другую учетную запись факса. Например, это может быть полезно, когда несколько пользователей хотят совместно использовать одну учетную запись факса и иметь доступ к исходящим факсам, созданным любым из этих пользователей.

Чтобы отправить факс из программы Факсы и сканирование Windows

1. Запустите приложение Факсы и сканирование Windows под учетной записью другого пользователя, см. Доступ к факсам другого пользователя .

2. На панели инструментов нажмите кнопку Создать факс, чтобы открыть диалоговое окно Новый факс.

3. В окне Новый факс, введите номер факса получателя в поле Кому.

4. В поле Титульный лист, опционально выберите титульный лист, который будет передан в качестве первой страницы факса.

5. Опционально, введите соответствующую информацию в поля Тема и Примечания.

6. Опционально, настройте сведения об отправителе .

7. Вы можете прикрепить документ к факсимильному сообщению с помощью кнопки Вложение файла на панели инструментов, вставить изображение в тело факса с помощью кнопки Вложить изображение, а таже вставить отсканированный документ с помощью кнопки Вложить отсканированный документ.

8. Для отправки факса нажмите Отправка.

Чтобы отправить факс из приложения Windows

Приложение Факсы и сканирование Windows должно быть заранее запущено под учетной записью другого пользователя, см. Доступ к факсам другого пользователя . Процедура аналогична описанной в главе Отправка факса из приложения Windows , однако по умолчанию при печати на принтер факсов, вы получите сообщение об ошибке, как показано на рисунке ниже.

В качестве обходного пути следует предоставить доступ на чтение к временной папке текущего пользователя для учетной записи пользователя, под которой запущено приложение Факсы и сканирование Windows. Чтобы настроить разрешения, выполните следующие действия:

1. В проводнике Windows, откройте папку, содержащую временную папку текущего пользователя. Временная папка (%temp%) для учетной записи текущего пользователя обычно C:\Users\<Account Name>\AppData\Local\Temp\.

2. Щелкните правой кнопкой мыши папку Temp. В контекстном меню, нажмите Свойства. В окне Свойства: Temp перейдите на вкладку Безопасность. Нажмите Изменить... .

3. В окне Разрешения для ... Temp, в списке Группы или пользователи, убедитесь, что присутствует запись, связанная с учетной записью пользователя, под которой запущено приложение Факсы и сканирование Windows. Если запись отсутствует, нажмите Добавить, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

4. В окне Разрешения для ... Temp, в списке Группы или пользователи, выберите запись, связанную с учетной записью пользователя, под которой запущено приложение Факсы и сканирование Windows. Предоставьте разрешение на Чтение для этой учетной записи, как показано на рисунке ниже. Нажмите Применить.

Чтобы отправить факс, выполните следующие действия:

1. Убедитесь, что приложение Факсы и сканирование Windows уже запущено под нужной учетной записью другого пользователя, см. Доступ к факсам другого пользователя . Не закрывайте главное окно приложения Факсы и сканирование Windows.

2. Следуйте инструкциям главы Отправка факса из приложения Windows .

Новый факс будет создан от имени учетной записи пользователя, под которой запущено приложение Факсы и сканирование Windows, а не под учетной записью текущего пользователя.


Получение факсов

Служба факсов Windows ›› Отправка и получение факсов ››

Если вы сконфигурировали Службу факсов Windows автоматически получать факсы, ваш компьютер будет автоматически отвечать на входящие вызовы и сохранять полученные факсы в приложении Факсы и сканирование Windows.

Чтобы получить подробную информацию о том, как отслеживать ход приема факсов, обратитесь к разделу Мониторинг и уведомления .

Для просмотра принятых факсов

1. Переключитесь на панель Поиск, наберите факсы и сканирование, а затем нажмите Факсы и сканирование. Кроме того, вы можете воспользоваться командой Факсы и сканирование Windows из меню иконки Fax Voip T.38 Модем в системном трее или командой Факсы и сканирование Windows в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты.

2. В левой панели, выберите Входящие для просмотра принятых факсов.


Мониторинг и уведомления

Служба факсов Windows ›› Отправка и получение факсов ››

В уведомлениях о факсах сообщается о различных аспектах работы службы факсов, например, о ходе передачи входящих и исходящих факсов, а также об исходе отправки или приема факса - успех или неудача. Уведомления бывают двух категорий:

  • Визуальные уведомления. Включают значок в области уведомлений, выноску с сообщением рядом со значком и монитор факсов.
  • Звуковые уведомления. Оповещения о событиях факса с помощью звукового сигнала.

Монитор факсов

Монитор факсов показывает информацию о ходе процесса отправки или приема факса через локальное факсимильное устройство.

Вы можете настроить Монитор факсов для показа следующих визуальных уведомлений:

  • Отображать ход приема или отправки факса.
  • Сообщать об успехах и сбоях при отправке и приеме факсов.

Также можно настроить звуковые уведомления о следующих событиях:

  • звонок на линии факса
  • получен новый факс
  • факс отправлен
  • в факсе обнаружена ошибка

Если Монитор факсов открыт, вы можете вручную прервать отправку или прием факса, нажав кнопку Прервать.

Монитор факсов отображает информацию о ходе процесса отправки или приема факса, включая следующие сведения:

  • Состояние. Текущее состояние исходящего или входящего факса.
  • Истекшее время. Время, прошедшее с момента инициирования приема или передачи факса.
  • Кому/От кого. Данные об отправителе или получателе.

Установка параметров уведомлений в Windows 11

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса... .

2. На вкладке Отслеживание, сконфигурируйте необходимые параметры, как показано на рисунке ниже.

3. Нажмите Параметры звуковых уведомлений... . Сконфигурируйте необходимые параметры, как показано на рисунке ниже. Нажмите OK.

4. В окне Параметры факса нажмите Применить.

Установка параметров уведомлений в Windows Server 2022

Обратите внимание, что на компьютере с операционной системой Windows Server уведомления о факсах могут быть включены только для одного выбранного факсимильного устройства.

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование, а затем нажмите Устройства и принтеры. Щелкните правой кнопкой мыши по принтеру Fax. В контекстном меню, нажмите Свойства принтера. Кроме того, вы можете воспользоваться командой Принтер факсов в Панели управления Fax Voip T.38 Модем , на ленте, на вкладке Главная.

2. На вкладке Отслеживание, выберите факсимильное устройство, для которого нужно настроить параметры отслеживания и уведомления. Сконфигурируйте необходимые параметры, как показано на рисунке ниже.

3. Нажмите Настройка звуковых уведомлений... . Сконфигурируйте необходимые параметры, как показано на рисунке ниже. Нажмите OK.

4. В окне Свойства: Fax нажмите Применить.


Доступ к факсам другого пользователя

Служба факсов Windows ››

В этой главе объясняется, как под текущей учетной записью получить доступ к факсам, созданным другим пользователем. Например, администратор факс сервера хочет просматривать факсы, созданные другими пользователями, и управлять ими. Или какая-то служба, работающая под другой учетной записью, автоматически создает факсимильные задания, и вам необходимо иметь доступ к этим факсам, примером является функция Почта-на-факс - Microsoft Fax из пакета Fax Voip T.38 Модем.

Запуск программы Факсы и сканирование Windows под другой учетной записью

1. Щелкните правой кнопкой мыши по кнопке Пуск чтобы открыть меню, из меню выберите Командная строка.

2. В командной строке выполните следующую команду:

runas.exe /savecred /user:SERVER1\FaxUser %windir%\system32\WFS.exe

В нашем примере SERVER1\FaxUser - это локальная учетная запись пользователя (включая имя компьютера), к факсам которого мы хотим получить доступ.

3. При необходимости введите пароль для пользователя, указанного в командной строке, а затем нажмите ENTER. Параметр /savecred используется для сохранения учетных данных и позволяет избежать ввода пароля при последующих запусках.

Приложение Факсы и сканирование Windows будет запущено под указанной учетной записью, а не под учетной записью текущего пользователя.

Кроме того, вы можете создать ярлык, чтобы запускать Факсы и сканирование Windows. Параметр ярлыка Объект должен быть таким, как показано ниже:

C:\Windows\System32\runas.exe /savecred /user:SERVER1\FaxUser %windir%\system32\WFS.exe

Добавление учетной записи факса

Перед добавлением учетной записи факса, необходимо предоставить разрешение на Просмотр конфигурации службы на факс сервере для пользователя, от имени которого запущено приложение Факсы и сканирование Windows. Чтобы настроить разрешения, выполните следующие действия:

1. В Windows 11, в Факсы и сканирование Windows, в меню Сервис, нажмите Параметры факса..., а затем перейдите на вкладку Безопасность. В Windows Server 2022, в Диспетчере службы факса (Microsoft), в левой панели, щелкните правой кнопкой мыши по узлу Факс; в контекстном меню, нажмите Свойства; в окне Свойства: Факс (Локальный) перейдите на вкладку Безопасность.

2. На вкладке Безопасность, нажмите Дополнительно.

3. В окне Дополнительные параметры безопасности для "Факс", выберите запись разрешения, связанную с желаемой учетной записью пользователя, и нажмите Изменить. Если запись разрешения отсутствует в списке, нажмите Добавить, нажмите Выберите субъект, введите имя учетной записи пользователя, нажмите Проверить имена, нажмите OK.

4. В окне Элемент разрешения для "Факс", нажмите Отображение дополнительных разрешений. Установите флажок Просмотр конфигурации службы. Нажмите OK. См. картинку ниже.

5. В окне Дополнительные параметры безопасности для "Факс", нажмите OK.

Чтобы добавить учетную запись факса, выполните следующие действия:

1. В Факсы и сканирование Windows, в меню Сервис, нажмите Учетные записи факса... . Если ни одной учетной записи еще не создано, нажмите Добавить... .

2. Нажмите Подключиться к факс-модему и следуйте инструкциям.

Для отправки факса

Чтобы отправить факс от имени учетной записи другого пользователя, см. Отправка факса с использованием другой учетной записи .


Устранение неполадок службы факсов Windows

Служба факсов Windows ››

Проблемы с CallerID в Windows 11, Windows 10 версии 1709 или более поздней, Windows Server 2022 и Windows Server 2019

Проблема: Caller ID и TSID (Код передающего абонента, Transmitting Subscriber Identification) не сохраняются в базе данных службы факсов после получения факса в этих версиях Windows. Вы можете видеть эту информацию при получении факса (например, в Мониторе факсов), но она становится недоступной после завершения приема факса, соответствующие поля в папке Входящие, в приложении Факсы и сканирование Windows, остаются пустыми. Кроме того, не удается извлечь Caller ID и TSID при помощи Fax Service API, в частности, Методы маршрутизации для входящих факсов (Microsoft Fax) не работают должным образом. Проблема не проявляется при получении факсов через устройства, которые не являются модемами и стандартный поставщик Microsoft Modem Device Provider не используется. Например, эта ошибка не влияет на работу программного обеспечения Fax Voip Windows Fax Service Provider (Fax Voip FSP).

Решение: Вам следует заменить библиотеку FXST30.dll аналогичным файлом из более ранних версий Windows 10. Вы можете найти библиотеки Windows 10 версии 1703 (как 64-битную, так и 32-битную) в папке установки Fax Voip T.38 Модем, скорее всего, путь будет следующим: C:\Program Files (x86)\FaxVoip Modem\FXST30_DLL\Win10_1703\.

Обратите внимание, что Fax Voip T.38 Модем исправляет эту ошибку автоматически во время установки программы. Также ошибку можно исправить, воспользовавшись командой Настройка факс службы в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты, см. также главу Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Команда 'Переслать по электронной почте' неактивна в приложении Факсы и сканирование в Windows 11, Windows 10, Windows Server 2022, Windows Server 2019 или Windows Server 2016

Проблема: Кнопка 'Переслать по электронной почте', находящаяся на панели инструментов в приложении Факсы и сканирование Windows неактивна, и вы не можете отправлять сообщения электронной почты напрямую из программы. В то же время почтовый клиент с поддержкой MAPI установлен и правильно настроен в вашей системе, и вы можете отправлять электронную почту с помощью команды Отправить -> Адресат или используя команду отправки e-mail в других приложениях, таких как Paint, WordPad и т.д. Обычно в этом случае команда 'Переслать по электронной почте' также должна быть доступна и в Факсы и сканирование Windows. В качестве почтовой программы с поддержкой MAPI, вы можете использовать классическое программное обеспечение Почта Windows (ранее Outlook Express), которое, кстати, может быть легко установлено в Windows 11 или Windows 10 с помощью инструмента Windows Mail Restore Tool , разработанного нашей компанией. Другими примерами почтовых программ с поддержкой MAPI являются Microsoft Outlook, Mozilla Thunderbird и т.д.

Решение: Чтобы устранить проблему и сделать доступной кнопку 'Переслать по электронной почте' в Факсы и сканирование Windows, необходимо создать параметр 'MAPI' = '1' (REG_SZ) в следующем разделе реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem

Обратите внимание, что Fax Voip T.38 Модем исправляет эту ошибку автоматически во время установки программы. Также ошибку можно исправить, воспользовавшись командой Настройка факс службы в Панели управления Fax Voip T.38 Модем , на вкладке Главная ленты, см. также главу Настройка службы факсов из панели управления Fax Voip T.38 Модем настоящего справочного руководства.

Проблемы в Windows 8.1 / Windows Server 2012 R2

Обратите внимание, что описанная ниже проблема устранена на стороне Microsoft в Накопительном пакете обновлений для Windows RT 8.1, Windows 8.1 и Windows Server 2012 R2 - Ноябрь 2014 (KB3000850) и в настоящее время отсутствует. Если вы столкнулись с этой проблемой на вашем компьютере с Windows 8.1 или Windows Server 2012 R2, в настоящее время мы бы рекомендовали обновить вашу систему до последней версии.

Проблема: Служба факсов перестает работать. В системном журнале отображается следующее сообщение об ошибке:

Поставщик службы факсов "Поставщик модема (Майкрософт)" будет закрыт из-за обнаруженной ошибки.

Код ошибки: 0xC0000005

Этот код ошибки показывает причину ошибки.

Создан отчет об ошибке Windows, включающий подробные сведения об этой ошибке.

Служба факсов будет перезапущена.

-------------

Имя сбойного приложения: fxssvc.exe, версия: 6.3.9600.16384, метка времени: 0x5215e627

Имя сбойного модуля: fxst30.dll, версия: 6.3.9600.16384, Путь сбойного приложения: C:\Windows\system32\fxssvc.exe

Путь сбойного модуля: C:\Windows\system32\fxst30.dll

Решение: может быть найдено в статье 8.1 broke my Windows Fax :

https://social.technet.microsoft.com/Forums/windows/en-US/57611007-4d60-4fe6-b81d-4b2c809e3a2a/81-broke-my-windows-fax

Согласно этой статье, вам необходимо заменить имеющуюся библиотеку FXST30.dll на аналогичный файл из Windows 7. Вы можете найти библиотеки Windows 7 (как 64-битную, так и 32-битную) в папке установки Fax Voip T.38 Модем, скорее всего, путь будет следующим: C:\Program Files (x86)\FaxVoip Modem\FXST30_DLL\Win7\.

Примечания

  • Нам не удалось воспроизвести проблему на наших тестовых компьютерах. Однако некоторые из наших пользователей столкнулись с данной проблемой и вышеприведенное решение помогло.
  • Если приведенное решение не решает проблему полностью, попробуйте использовать Eltima Virtual Serial Port Driver . Этот драйвер чуть более отказоустойчив в случае ошибок на стороне факс программного обеспечения. Чтобы использовать драйвер от фирмы Eltima вместо Fax Voip Драйвера Виртуальных COM портов, см. инструкции в главе Использование Fax Voip T.38 Модем с драйвером Eltima настоящего справочного руководства.
  • При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами

С помощью Fax Voip T.38 Модем вы можете настроить и использовать Службу факсов Windows или любое другое стороннее факс-голосовое приложение для отправки/приема факсов или аудио сообщений через VoIP без аппаратных модемов. Fax Voip T.38 Модем эмулирует голосовые факс модемы (Fax Class 1). Виртуальные COM порты (модемы) являются мостом между вашим факс или голосовым программным обеспечением и VoIP.

Чтобы сконфигурировать ваше факс (голосовое) приложение, выберите устройство Fax Voip 14.4K TAPI Voice-Fax Modem в настройках вашего приложения. В зависимости от вашего программного обеспечения, возможно потребуется указать последовательный порт вместо модема. В этом случае выберите порт, связанный с Fax Voip T.38 Модем, например COM20. Также, как правило нужно настроить ваше программное обеспечение автоматически отвечать на входящие вызовы.

Fax Voip T.38 Модем был успешно протестирован со многими хорошо известными факсовыми программами, в том числе с поддержкой голосовых функций. Чтобы помочь вам успешно сконфигурировать ваше любимое факс программное обеспечение для работы с Виртуальными COM портами (модемами) Fax Voip, мы подготовили подробные инструкции по настройке некоторых наиболее популярных программ:

  • Использование Fax Voip T.38 Модем cо службой факсов Windows *
  • Использование Fax Voip T.38 Модем с CallStation
  • Использование Fax Voip T.38 Модем с программой FaxTalk Messenger Pro 7.5
  • Использование Fax Voip T.38 Модем с программой BVRP Classic Phone Tools 9
  • Использование Fax Voip T.38 Модем с Venta Fax & Voice
  • Использование Fax Voip T.38 Модем с программой FaxAmatic

Примечания

  • Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы Fax Voip T.38 Модем. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .
  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Использование Fax Voip T.38 Модем с CallStation

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ››

К сожалению, веб-сайт Impulse Technology (imptec.com) более не доступен (январь 2018 года). Программное обеспечение CallStation 6.0.0 можно загрузить с веб-сайта Fax Voip T.38 Модем . Чтобы установить CallStation, следуйте инструкциям мастера установки этой программы.

CallStation представляет собой очень простую, но полнофункциональную телефонную утилиту, в которой реализованы функции автоответчика с возможностью приема факсов.

CallStation является TAPI совместимым приложением и может работать с Fax Voip T.38 Модем только через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. TAPI (Telephony Application Programming Interface) – интерфейс программирования приложений для телефонии, разработанный компаниями Intel и Microsoft, позволяющий подключать ПК, работающие под управлением Windows, к системам телефонии. Не нужно беспокоиться о строках инициализации модема или выборе номера COM-порта. В отличии от многих других продуктов, таких как FaxTalk Messenger Pro или BVRP Classic Phone Tools , CallStation не использует так называемый сквозной режим при работе с голосовыми модемами.

По сравнению с драйвером стандартного модема, драйвер Fax Voip 14.4K TAPI Voice-Fax Modem обеспечивает поддержку функций Caller ID Number и Caller ID Name. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Чтобы установить Виртуальные COM порты и связанные с ними модемы, в Панели управления Fax Voip T.38 Модем, выберите Порты и модемы, а затем нажмите кнопку <Добавить/удалить>, см. Добавление/удаление Виртуальных COM портов Fax Voip . Чтобы установить или переустановить модемы без переустановки Виртуальных COM портов, воспользуйтесь кнопкой <Модемы>, см. также Добавление/удаление модемов Fax Voip .

Fax Voip T.38 Модем поставляется с TAPI-совместимым драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem. С этим драйвером голосовые функции модема поддерживаются не только в сквозном режиме, но и через стандартные TAPI функции. Стандартный драйвер Unimodem аудиоустройство с полным дуплексом автоматически устанавливается в Windows при установке драйвера модема.

При работе с использованием драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem через TAPI и выключенным сквозным режимом, всегда используется 8-bit unsigned linear PCM at 8000 Hz format.

Процедура установки драйвера модема Fax Voip 14.4K TAPI Voice-Fax Modem также исправляет хорошо известную ошибку воспроизведения в Unimodem Transform Module в Windows Vista и выше (включая Windows 11 и Windows 10, как 64-битную так и 32-битную версии), которая выражается в отсутствии воспроизведения аудио в телефонную линию через модем. Любое приложение телефонии, использующее стандартный аудио драйвер модема для проигрывания аудио сталкивается с указанной проблемой. Эта проблема обсуждалась в течение многих лет на форумах Microsoft , но по каким-то причинам не была решена Microsoft до сих пор.

Кроме того, в Fax Voip T.38 Модем реализована функция Аппаратного разрыва соединения путем детектирования потери сигнала CD с помощью понижения сигнала DTR. Этот механизм используется в CallStation и многих других TAPI приложениях для сброса модема.

Примечания

  • Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы Fax Voip T.38 Модем. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .


Конфигурирование модема в CallStation

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

1. Запустите программу CallStation.

2. В главном окне программы, в меню Settings, нажмите Main Options.

3. В окне Main Options, на вкладке Modem, из выпадающего списка Use this modem выберите FaxVoip 14.4K TAPI Voice-Fax Modem.

4. В области Optional Modem Features поставьте галку CallerID.

5. Нажмите <OK>.

Примечания

  • Если вы только что установили новый драйвер модема FaxVoip 14.4K TAPI Voice-Fax Modem, вам необходимо перезагрузить компьютер перед тем как конфигурировать модем с CallStation. В противном случае вы получите сообщение об ошибке аудио драйвера модема.


Автоответчик

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

Для автоматического ответа на входящие вызовы и записи голосовых сообщений, выполните следующие шаги:

1. Запустите программу CallStation.

2. В главном окне программы, в меню Voice, поставьте галку Answer Calls.

3. В меню Settings, нажмите Voice Options.

4. В диалоговом окне Voice Options, на вкладке General, поставьте галку Screen calls while taking a message для возможности прослушивания телефонной линии через звуковую карту компьютера во время записи сообщения вызывающим абонентом.

5. Отключите опцию Discard message if manually stopped. В противном случае, голосовое сообщение может быть удалено случайным образом.

6. Нажмите <OK>.

При поступлении вызова, обычно отображается всплывающее окно. Чтобы немедленно отправить вызов автоответчику, нажмите кнопку Take Msg.

Или же вы можете подождать, и система автоматически ответит на вызов после выбранного количества звонков. В то время как ваше приветствие воспроизводится, вызывающий абонент может нажать клавишу '1' на своем телефоне с тональным набором, чтобы пропустить оставшуюся часть приветствия.

Если опция Call Screening включена, вы можете прослушивать через вашу звуковую карту, как звонящий оставляет сообщение. Если вы решили, что вы хотите остановить запись, в то время как вызывающий абонент оставляет сообщение, просто нажмите кнопку Stop Msg, чтобы прервать работу автоответчика. Вызывающий абонент также может прервать работу автоответчика, нажав клавишу звездочка (*) на своем телефоне с тональным набором.

Когда сообщение оставлено, индикатор New Message, отображающий общее количество новых вызовов, увеличивается на единицу. Новые вызовы помечаются в журнале вызовов (Call Log) иконкой "кассетный магнитофон" со звездочкой. Для прослушивания любого сообщения в журнале вызовов, просто используйте элементы управления воспроизведением на панели инструментов.

Примечания

  • Функции Caller ID Number и Caller ID Name поддерживаются программой CallStation и драйвером Fax Voip 14.4K TAPI Voice-Fax Modem.


Прием факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

Для автоматического обнаружения входящих факсимильных вызовов, выполните следующие шаги:

1. Запустите программу CallStation.

2. В главном окне программы, в меню Fax, поставьте галку Receive Faxes.

Автоответчик также должен быть включен для автоматического обнаружения факса.

Когда автоответчик отвечает на вызов, как только он начинает проигрывать приветствие, CallStation начнет прослушивание линии на предмет обнаружения тонального сигнала факса.

При обнаружении сигнала факса, проигрывание приветствия будет остановлено и CallStation переключится в режим приема факса. Если отображается всплывающее окно, текст заголовка окна изменится на CallStation – Receiving a Fax. Статус факса будет отображаться в нижней части "дисплея", а набор кнопок поменяется. Нажмите кнопку Details (сведения), чтобы развернуть окно и увидеть более подробную информацию о принимаемом факсе.

После получения факса, вызов добавляется в журнал вызовов (Call Log) и помечается красной буквой 'F', чтобы указать, что это был факсимильный вызов. Индикатор New Faxes, отображающий количество новых принятых факсов, увеличивается на единицу (если при приеме факса не произошла ошибка). Для просмотра факса, дважды щелкните его в журнале вызовов. Или нажмите кнопку Fax Manager на панели инструментов, выделите нужный факс в списке, и нажмите кнопку View.

Для получения факса вручную

Если вы знаете, что входящий вызов является факсимильным, без предварительного ответа на него, просто нажмите кнопку Receive Fax во всплывающем окне CallStation – Incoming Call.


Пересылка голосовых сообщений

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

Эта функция позволяет автоматически пересылать сообщения на заранее заданный номер телефона. Например, при пересылке сообщений на ваш мобильный телефон, можно получать сообщения независимо от того, где вы находитесь.

После того, как вызывающий абонент оставил сообщение, CallStation наберет телефонный номер и сообщит вам, что у вас есть новое сообщение. Просто введите ваш код доступа, и сообщение будет воспроизводиться. После проигрывания сообщения вы будете находиться в режиме Удаленного доступа . В этом режиме вы можете получить доступ к старым сообщениям, измененить настройки или просто повесить трубку.

Чтобы настроить эту функцию, выполните следующие шаги:

1. Запустите программу CallStation.

2. В главном окне программы, в меню Settings, нажмите Voice Options.

3. В диалоговом окне Voice Options, на вкладке Message Forwarding, в поле Forward to this phone number введите номер телефона, на который вы хотите пересылать сообщения.

4. На вкладке Remote Access, в поле Access code введите четырехзначный код, который вы хотели бы использовать для удаленного доступа к сообщениям.

5. Нажмите <OK>.

6. В главном окне программы, в меню Voice, поставьте галку Forward Messages.


Пересылка факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

Функция автоматической пересылки факсов позволяет пересылать принятые факсы (после приема) на другой номер факса.

После приема факса CallStation наберет номер факса и отправит принятый факс на другой факсимильный аппарат.

Чтобы настроить эту функцию, выполните следующие шаги:

1. Запустите программу CallStation.

2. В главном окне программы, в меню Settings, нажмите Fax Options.

3. В окне Fax Options, на вкладке General, в поле Forward to this fax number введите телефонный номер факсимильного аппарата, на который вы хотите пересылать факсы.

4. Нажмите <OK>.

5. В главном окне программы, в меню Fax, поставьте галку Forward Faxes.

Для пересылки факса вручную

1. Запустите программу CallStation.

2. В главном окне программы, нажмите кнопку Fax Manager на панели инструментов.

3. В окне Fax Manager, выделите нужный факс в списке, и нажмите кнопку Forward.

4. В диалоге Fax Forward введите номер факса. Нажмите <OK>.

Программа CallStation автоматически наберет номер факса и будет отправлять факс.


Удаленный доступ

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с CallStation ››

Вы можете легко получить доступ к вашим сообщениям с любого телефона с тональным набором. CallStation использует речевой движок для создания простых голосовых меню.

При доступе к сообщениям, CallStation запросит у вас код доступа. Это предотвращает получение несанкционированного доступа к сообщениям.

Чтобы задать код доступа, выполните следующие шаги:

1. Запустите программу CallStation.

2. В главном окне программы, в меню Settings, нажмите Voice Options.

3. На вкладке Remote Access, в текстовом поле Access code введите четырехзначный код, который вы хотели бы использовать для удаленного доступа к сообщениям.

4. Из раскрывающегося списка Press ... to enter Remote Access mode, выберите какую клавишу (на клавиатуре телефона) вы хотите нажимать во время приветствия для перехода в режим удаленного доступа. По умолчанию используется '0'.

5. Нажмите <OK>.

Для доступа к сообщениям наберите ваш номер телефона, дождитесь ответа CallStation, затем нажмите клавишу '0' в любой момент во время проигрывания приветствия.

Если отображается всплывающее окно, переключение в режим удаленного доступа (Remote Access Mode) отображается в этом окне.

CallStation попросит вас ввести код доступа. Введите ваш четырехзначный код. Вам будут предложены следующие варианты:

  • Нажмите 1 чтобы прослушать новые сообщения.
  • Нажмите 2 чтобы прослушать старые сообщения.
  • Нажмите 3 для перехода к опциям настройки.

При проигрывании сообщений, CallStation проговаривает время/дату в конце каждого сообщения, так что вы точно знаете, когда было получено сообщение. CallStation также может проговаривать номер телефона вызывающего абонента. Во время прослушивания сообщений, вам доступны следующие варианты:

  • Нажмите 1 чтобы повторить сообщение.
  • Нажмите 2 чтобы перейти к следующему сообщению.
  • Нажмите 3 чтобы удалить сообщение после прослушивания.
  • Нажмите # чтобы прервать сообщение.

Если, находясь в главном меню, вы нажмете 3 для перехода к опциям настройки, вам будут предложены следующие варианты:

  • Нажмите 1 чтобы изменить текущее приветствие.
  • Нажмите 2 чтобы изменить количество звонков перед ответом.
  • Нажмите 3 чтобы изменить режим сбережения.
  • Нажмите # для возврата в главное меню.

Просто нажмите нужную клавишу и следуйте инструкциям.


Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro

Использование Fax Voip T.38 Модем с программой FaxTalk Messenger Pro 7.5

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ››

Программное обеспечение FaxTalk Messenger Pro 7.5 можно загрузить с веб-сайта Fax Voip T.38 Модем . Чтобы установить FaxTalk Messenger Pro 7.5, следуйте инструкциям мастера установки этой программы. Для получения дополнительной информации посетите веб-сайт FaxTalk.com .

Внимание! Не используйте последнюю версию FaxTalk, которая доступна для скачивания на официальном сайте. Из-за многочисленных ошибок в FaxTalk Messenger Pro 9 и FaxTalk Messenger Pro 8, они не работают с модемами Fax Voip. И хотя модем правильно обнаруживается во время установки программы, FaxTalk затем непрерывно генерирует бессмысленные ошибки при любой попытке инициализации модема. Если вы хотите использовать более новые версии, обратитесь в службу поддержки FaxTalk для решения указанных проблем.

В настоящее время мы рекомендуем вам использовать старую версию FaxTalk Messenger Pro 7.5, которая не содержит ошибок и успешно протестирована с Fax Voip T.38 Модем в Windows 11, Windows Server 2022 и на более старых системах. При покупке лицензии FaxTalk, просите ключ для указанной версии. Чтобы загрузить FaxTalk Messenger Pro 7.5, используйте ссылку ниже:

https://www.t38faxvoip.com/downloads/ftmpdemo.exe

FaxTalk Messenger Pro 7.5 может работать с Виртуальными COM портами Fax Voip через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. По сравнению с драйвером стандартного модема, драйвер Fax Voip 14.4K TAPI Voice-Fax Modem обеспечивает поддержку функций Caller ID Number и Caller ID Name. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Чтобы установить Виртуальные COM порты и связанные с ними модемы, в Панели управления Fax Voip T.38 Модем, выберите Порты и модемы, а затем нажмите кнопку <Добавить/удалить>, см. Добавление/удаление Виртуальных COM портов Fax Voip . Чтобы установить или переустановить модемы без переустановки Виртуальных COM портов, воспользуйтесь кнопкой <Модемы>, см. также Добавление/удаление модемов Fax Voip .

Примечания

  • Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы Fax Voip T.38 Модем. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .


Конфигурирование модема в FaxTalk

Конфигурирование модема в FaxTalk Messenger Pro

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro ››

1. Запустите программу FaxTalk Messenger Pro.

2. В главном окне программы, в меню Tools, выберите команду Options.

3. В дереве окна настроек FaxTalk Messenger Pro Settings, выберите Modem, затем выберите запись о модеме в таблице и нажмите кнопку <Change>.

4. Следуйте инструкциям мастера. В окне Modem Selection (выбор модема), выберите из списка доступных модемов модем Fax Voip 14.4K TAPI Voice-Fax Modem, привязанный к одному из Виртуальных COM портов Fax Voip, а затем нажмите кнопку <Next> для запуска процедуры Авто-определения модема.

5. По завершении процедуры Авто-определения модема, вы можете просмотреть результат. Система факсимильных команд модема будет определена как Fax Class 1. Система голосовых команд модема будет определена как Conexant SP3131. Вам следует согласиться с результатами Авто-определения. Заметим, что вы можете вручную выбрать другую Систему голосовых команд для модема Fax Voip, если на предыдущем шаге поставите флажок у параметра Don’t query the modem, I will select it from a list (Не опрашивать модем, я выберу его из списка). Некоторые Системы голосовых команд, предлагаемые программой будут совместимы с Fax Voip T.38 Модем, другие нет.

6. В окне Modem Query, нажмите кнопку <Finish>.

7. В окне FaxTalk Messenger Pro Settings, нажмите кнопку <OK>.


Отправка факса

Отправка факса из приложения FaxTalk Messenger Pro

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. В диалоговом окне Печать, выберите принтер FaxTalk Messenger Pro 7.5. Затем нажмите Печать.

3. В окне мастера Fax Wizard (шаг 1), введите номер факса получателя в поле Fax, а затем нажмите кнопку <Next>.

4. На завершающей странице мастера, нажмите кнопку <Send>.

Программа FaxTalk Messenger Pro автоматически наберет номер факса и будет отправлять факс.


Голосовая и факсимильная почта

Настройка голосовой и факсимильной почты

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro ››

1. В главном окне программы FaxTalk Messenger Pro, в меню Tools, выберите команду Options.

2. В дереве окна настроек FaxTalk Messenger Pro Settings, выберите Voice Messaging. На странице конфигурации Voice Messaging, выберите почтовый ящик (Main Mailbox 1) и нажмите кнопку <Properties>.

3. В окне Main Mailbox Properties сделайте необходимые настройки.

4. Для того, чтобы проигрывать голосовое приветствие перед получением факса или записью голосового сообщения, поставьте флажок у параметра Play greeting to caller (проигрывать приветствие звонящему).

5. Выберите желаемое действие из списка Perform the following action. Выберите вариант Take Message, если вы хотите иметь возможность записать голосовое сообщение. Выберите вариант Receive Fax, если вы хотите переключиться в режим приема факса непосредственно после проигрывания голосового приветствия или немедленно после ответа на входящий вызов. Выберите вариант Hang Up (повесить трубку), если вы не хотите принимать факсимильные и голосовые сообщения после проигрывания голосового приветствия.

6. Поставьте флажок у параметра Automatically detect incoming faxes (автоматически детектировать входящие факсы), если вы хотите, чтобы программа детектировала и принимала факс в режиме проигрывания голосового приветствия или записи голосового сообщения.

7. Нажмите кнопку <OK>.


Удаленный доступ к голосовой и факсимильной почте

Настройка Удаленного доступа к голосовой и факсимильной почте

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro ››

Удаленный доступ к почтовому ящику (Remote Access to Mailbox) позволяет пользователю звонить из удаленного местоположения и проверять полученные голосовые и факсимильные сообщения. Пользователь может управлять почтовым ящиком удаленно, используя DTMF тона. Функция Распознавания DTMF поддерживается программой Fax Voip T.38 Модем. FaxTalk Messenger Pro предоставляет большой набор функций удаленного управления: вы можете прослушивать и управлять голосовыми сообщениями, перезаписывать голосовое приветствие автоответчика удаленно, прослушивать информацию о принятых факсах, и т.д. Для включения функции Удаленного доступа к почтовому ящику, выполните следующие шаги:

1. В главном окне программы FaxTalk Messenger Pro, в меню Tools, выберите команду Options.

2. В дереве окна настроек FaxTalk Messenger Pro Settings, выберите Voice Messaging. На странице конфигурации Voice Messaging, выберите почтовый ящик (Main Mailbox 1) и нажмите кнопку <Properties>.

3. В окне Main Mailbox Properties, в области Remote access settings, поставьте флажок у параметра This mailbox can be accessed remotely (этот почтовый ящик может быть доступен удаленно).

4. В поле Password for remote access is: введите пин-код для доступа к почтовому ящику, если это необходимо.

5. Нажмите кнопку <OK>.


Получение входящих факсов и голосовых сообщений

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxTalk Messenger Pro ››

По умолчанию, программа FaxTalk Messenger Pro автоматически запускается при загрузке операционной системы и способна автоматически отвечать на входящие вызовы. В зависимости от сделанных настроек (см. в разделах Настройка голосовой и факсимильной почты и Настройка Удаленного доступа к голосовой и факсимильной почте текущей главы), после автоматического ответа на вызов, FaxTalk Messenger Pro может:

1. Принимать факс.

2. Осуществлять запись голосового сообщения.

3. Обеспечивать звонящему Удаленный доступ к голосовой и факсимильной почте.

Во время проигрывания голосового сообщения, доступны следующие дополнительные возможности:

1. Немедленно начать запись голосового сообщения, путем нажатия *1 (звездочка + 1).

2. Немедленно начать прием факса, путем нажатия *2 (звездочка + 2).

3. Получить Удаленный доступ к голосовой и факсимильной почте путем нажатия # + 1 + #, где '1' является номером почтового ящика.

Примечания

  • Функции Caller ID Number и Caller ID Name поддерживаются программой FaxTalk Messenger Pro и Виртуальными COM портами (модемами) Fax Voip.


Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools

Использование Fax Voip T.38 Модем с программой BVRP Classic Phone Tools 9

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ››

Программное обеспечение BVRP Classic Phone Tools 9 можно загрузить с веб-сайта Fax Voip T.38 Модем . Чтобы установить BVRP Classic Phone Tools 9, следуйте инструкциям мастера установки этой программы. Чтобы приобрести лицензию, свяжитесь со службой поддержки Avanquest Software .

Мы не рекомендуем использовать BVRP Classic Phone Tools версии ниже 9, потому что некоторые голосовые функции, описанные в данном руководстве могут не функционировать правильно в более ранних версиях.

BVRP Classic Phone Tools 9 может работать с Виртуальными COM портами Fax Voip через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. По сравнению с драйвером стандартного модема, драйвер Fax Voip 14.4K TAPI Voice-Fax Modem обеспечивает поддержку функций Caller ID Number и Caller ID Name. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Чтобы установить Виртуальные COM порты и связанные с ними модемы, в Панели управления Fax Voip T.38 Модем, выберите Порты и модемы, а затем нажмите кнопку <Добавить/удалить>, см. Добавление/удаление Виртуальных COM портов Fax Voip . Чтобы установить или переустановить модемы без переустановки Виртуальных COM портов, воспользуйтесь кнопкой <Модемы>, см. также Добавление/удаление модемов Fax Voip .

Примечания

  • Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы Fax Voip T.38 Модем. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .


Конфигурирование модема в BVRP

Конфигурирование модема в BVRP Classic Phone Tools

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools ››

1. Запустите программу BVRP Classic Phone Tools.

2. В главном окне программы, нажмите кнопку <MENUS>, и последовательно выберите в меню Setup, а затем General Setup.

3. В окне настроек General Setup перейдите на вкладку Communication, и нажмите кнопку <Change modem>.

4. Следуйте инструкциям мастера Device Configuration wizard. В списке модемов выберите модем Fax Voip 14.4K TAPI Voice-Fax Modem, привязанный к одному из Виртуальных COM портов Fax Voip, а затем нажмите кнопку <Next> для перехода к следующему шагу.

5. На следующем шаге, убедитесь что программа Fax Voip T.38 Модем запущена. Нажмите кнопку <Next> для запуска процедуры Авто-определения модема.

6. По завершении процедуры Авто-определения модема, вы можете просмотреть результат. Система факсимильных команд модема будет определена как Fax Class 1. Система голосовых команд модема будет определена как Voice IS101 Lucent Handset Mulaw. Вам следует согласиться с результатами Авто-определения. Заметим, что вы можете вручную выбрать другую Систему голосовых команд для модема Fax Voip, если на предыдущем шаге поставите флажок у параметра Do not automatically detect the driver. Некоторые Системы голосовых команд, предлагаемые программой будут совместимы с Fax Voip T.38 Модем, другие нет.

7. Нажмите кнопку <Next>, а затем нажмите кнопку <Finish>.

8. В окне настроек General Setup, на вкладке Communication, пожалуйста убедитесь, что в поле Loudspeaker выбрано значение Off, а в поле Mode в области Reception, выбрано значение Fax (даже если вы намереваетесь использовать автоответчик Answering machine). Иными словами, вы должны осуществить настройки, как показано на рисунке ниже.

9. Нажмите кнопку <OK>, чтобы закрыть окно General Setup и сохранить параметры.


Удаленное управление сообщениями

Настройка функции Удаленного управления сообщениями

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools ››

Функция Удаленного управления сообщениями (Remote Message Retrieval) позволяет пользователю звонить из удаленного местоположения и проверять полученные голосовые сообщения. Пользователь может управлять голосовым почтовым ящиком удаленно, используя DTMF тона. Функция Распознавания DTMF поддерживается программой Fax Voip T.38 Модем. Следует отметить, что функция Удаленного управления сообщениями в программе BVRP Classic Phone Tools весьма проста и удобна. Например, для реализации аналогичной функциональности в программе Venta Fax, пользователь должен писать специальные скрипты, что под силу далеко не каждому. Честно говоря, мы заметили некоторые странности при использовании команды Listening to all messages (Прослушать все сообщения), см. ниже, но в целом функция работает весьма неплохо.

1. В главном окне программы, нажмите кнопку <MENUS>, и последовательно выберите в меню Setup, а затем Answering Machine Setup.

2. В окне настроек General Setup, на вкладке Voice, нажмите кнопку <Remote Msg. Retrieval>.

3. В окне Remote Message Retrieval, в поле Access Code, задайте цифровой код доступа. Этот код (пин-код, пароль) необходимо будет вводить каждый раз при звонке на вашу систему для удаленного доступа к сообщениям. Код должен состоять из 4-х цифр.

4. Назначьте различные цифры (телефонные клавиши) для каждой из следующих команд: Message replay (повтор сообщения), Next message (следующее сообщение), Deleting a message (удаление сообщения), Listen to all messages (прослушать все сообщения).

5. Нажмите <OK>.

6. Для использования этой функции, вам следует переключиться в режим Greeting and record (Приветствие и запись) для входящих вызовов (см. в разделе Получение входящих факсов и голосовых сообщений текущей главы). Access Code должен вводиться во время прослушивания голосового приветствия автоответчика.


Отправка факса

Отправка факса из приложения BVRP Classic Phone Tools

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. В диалоговом окне Печать, выберите принтер CAPTURE FAX. Затем нажмите Печать.

3. В окне мастера отправки факсов BVRP Send Fax Wizard, введите номер факса получателя в поле Recipient Fax #, а затем нажмите кнопку <Next>.

4. На завершающей странице мастера, нажмите кнопку <Finish>.

5. В окне подтверждения Confirm Transmission, нажмите кнопку <Send>.

Программа BVRP Classic Phone Tools автоматически наберет номер факса и будет отправлять факс.


Получение входящих факсов и голосовых сообщений

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с BVRP Classic Phone Tools ››

1. Запустите программу BVRP Classic Phone Tools.

2. В левой панели главного окна программы, нажмите кнопку <VOICE MAIL>.

3. Активируйте желаемый режим для факса и автоответчика, выбрав его в нижней правой панели главного окна программы. Кнопка рядом с названием выбранного режима будет подсвечена зеленым цветом.

4. Выберите (активируйте) режим Answering machine off (автоответчик выключен), чтобы принимать только факсы и не использовать Голосовые функции модема.

5. Выберите (активируйте) режим Greeting only (только голосовое приветствие), если вы не хотите принимать как факсы, так и голосовые сообщения. Например, вы можете использовать голосовое приветствие следующего содержания: “We are not able to take a call at this time. Please try again later”. (“В настоящее время мы не можем ответить на вызов. Пожалуйста, повторите попытку позже”). После проигрывания приветствия, программа “вешает трубку”.

6. Выберите (активируйте) режим Greeting & record (Приветствие и запись), если вы хотите получать как факсы, так и голосовые сообщения. После прослушивания голосового приветствия, вы можете оставить голосовое сообщение или отправить факс. Этот режим также можно использовать с функцией Удаленного управления сообщениями , описанной выше. Access Code (пин-код) должен вводиться во время прослушивания голосового приветствия автоответчика.

Ваш компьютер будет автоматически отвечать на входящие вызовы и сохранять полученные факсы и голосовые сообщения.

Примечания

  • Функции Caller ID Number и Caller ID Name поддерживаются программой BVRP Classic Phone Tools и Виртуальными COM портами (модемами) Fax Voip.


Использование Fax Voip T.38 Модем с Venta Fax & Voice

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ››

Чтобы установить Venta Fax & Voice, следуйте инструкциям мастера установки этой программы.

Venta Fax & Voice может работать с Виртуальными COM портами Fax Voip через прямое подключение к COM порту или через драйвер модема Fax Voip 14.4K TAPI Voice-Fax Modem. По сравнению с драйвером стандартного модема, драйвер Fax Voip 14.4K TAPI Voice-Fax Modem обеспечивает поддержку функций Caller ID Number и Caller ID Name. Добавление модемов с использованием опции Телефон и модем в Панели управления Windows не рекомендуется. Чтобы установить Виртуальные COM порты и связанные с ними модемы, в Панели управления Fax Voip T.38 Модем, выберите Порты и модемы, а затем нажмите кнопку <Добавить/удалить>, см. Добавление/удаление Виртуальных COM портов Fax Voip . Чтобы установить или переустановить модемы без переустановки Виртуальных COM портов, воспользуйтесь кнопкой <Модемы>, см. также Добавление/удаление модемов Fax Voip .

Примечания

  • Обратите внимание, что модемы Fax Voip автоматически настраиваются для работы со Службой факсов Windows в процессе установки программы Fax Voip T.38 Модем. Перед настройкой любого другого стандартного факс/голосового приложения, необходимо вручную отключить отправку и получение факсов в приложении Факсы и сканирование Windows (Диспетчере службы факсов), см. Настройка службы факсов Windows .


Конфигурирование модема и системы голосовых команд

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. Запустите программу Venta Fax. В главном окне программы, на панели инструментов, нажмите Настройка.

2. В окне Настройка параметров выберите Модем, затем выберите Взаимодействие с модемом.

Для работы через драйвер модема, в панели Модем – Взаимодействие с модемом, выберите опцию через TAPI, а затем из списка выберите модем Fax Voip 14.4K TAPI Voice-Fax Modem. В диалоговом окне подтверждения нажмите <Да>, чтобы перейти к процедуре определения системы команд модема.

Чтобы подключиться к Виртуальному COM порту Fax Voip напрямую, в панели Модем – Взаимодействие с модемом, выберите опцию через порт, а затем из списка выберите один из Виртуальных COM портов Fax Voip, например COM20. В диалоговом окне подтверждения нажмите <Да>, чтобы перейти к процедуре определения системы команд модема.

3. В панели Модем – Свойства, нажмите кнопку <Определить>. Система голосовых команд модема будет определена как Conexant/Rockwell (V.253). Вам следует согласиться с результатами Авто-определения. Заметим, что на вкладке Голос, в поле Система команд, вы можете вручную выбрать другую Систему голосовых команд для модема Fax Voip. Fax Voip T.38 Модем корректно поддерживает следующие из предлагаемых в списке Системы голосовых команд: V.253, Conexant/Rockwell (V.253) и Conexant/Rockwell (V.253) (2).

4. Нажмите кнопку <Применить> чтобы сохранить настройки.


Формат голосовых данных модема

Настройка формата голосовых данных модема

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

2. В окне Настройка параметров выберите Голос, затем выберите Общие.

3. Venta Fax устанавливает Формат голосовых данных модема в процессе авто-детектирования Системы голосовых команд модема (см. в предыдущем разделе ). По умолчанию, Форматом голосовых данных для модема Fax Voip является PCM/8bits/8000Hz.

4. Чтобы изменить используемый Формат голосовых данных модема, в панели Голос – Общие, выберите другой формат из списка Формат голосовых данных модема. Из предлагаемых в списке вариантов, Fax Voip T.38 Модем корректно поддерживает голосовые форматы PCM/8bits/8000Hz, A-LAW/8bits/8000Hz и uLAW/8bits/8000Hz.

5. Нажмите кнопку <Применить> чтобы сохранить настройки.

Примечания

  • Fax Voip T.38 Модем также поддерживает формат 16-bit linear PCM at 8000 Hz. Чтобы использовать этот Формат голосовых данных с Venta Fax, вам следует вручную выбрать Систему голосовых команд V.253 на странице Модем-Свойства, вкладка Голос, поле Система команд. А затем выбрать PCM/16bits/8000Hz на странице Голос-Общие как описано в текущей главе.


Реплика перед передачей факса

Настройка реплики перед передачей факса

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

Заметим, что в большинстве стран не практикуется использование одной и той же телефонной линии для голоса и факса. В зависимости от версии Venta Fax, опция Реплика перед передачей факса может быть выключена по умолчанию. Как только соединение будет установлено, программа немедленно приступает к отправке факса. Однако, в некоторых странах, например в России, ситуация когда человек отвечает на вызов, а затем нажимает кнопку 'Старт' на факсимильном аппарате, является абсолютно нормальной. Функция Реплика перед передачей факса работает следующим образом: после того как соединение установлено, Venta Fax осуществляет анализ голоса в телефонной линии. Если на вызов ответил человек, Venta Fax транслирует в линию Голосовое приветствие, а затем отправляет факс. Подчеркнем, что использование этой функции не рекомендуется, если не предполагается, что на вызов будет отвечать человек.

Чтобы активировать Реплику перед передачей факса, выполните следующие шаги:

1. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

2. В окне Настройка параметров выберите Факс, затем выберите Общие.

3. Снимите флажок у параметра Отключать голосовой режим при передаче факса. Нажмите кнопку <Применить>.

4. В окне Настройка параметров выберите Папки и файлы, затем выберите Служебные файлы.

5. Поставьте флажок у параметра Реплика перед передачей факса и выберите файл с расширением wav, содержащий желаемое приветствие. Вы можете использовать стандартный файл (intro1.wav) либо записать свое собственное голосовое приветствие. Нажмите кнопку <Применить> чтобы сохранить настройки.


Голосовое приветствие автоответчика

Настройка голосового приветствия автоответчика

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

2. В окне Настройка параметров выберите Папки и файлы, затем выберите Служебные файлы.

3. Поставьте флажок у параметра Вступительная реплика автоответчика и выберите файл с расширением wav, содержащий желаемую реплику. Вы можете использовать стандартный файл (greet1.wav) либо записать свое собственное голосовое приветствие.

4. Поставьте флажок у параметра Заключительная реплика автоответчика и выберите файл с расширением wav, содержащий желаемую реплику. Вы можете использовать стандартный файл (final1.wav) либо записать свою собственную реплику.

5. Нажмите кнопку <Применить> чтобы сохранить настройки.


Удаленное управление автоответчиком

Настройка функции удаленного управления автоответчиком

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. В левой панели главного окна программы Venta Fax, нажмите маленькую кнопку справа от кнопки Ред. сценариев (см. рисунок ниже).

2. Из меню выберите имя скрипта, который вы бы хотели использовать в качестве сценария для вашего Автоответчика, например скрипт 2mailbox. В комплект Venta Fax входит несколько стандартных скриптов. Вы также можете создавать свои собственные скрипты. Для этого следует обратиться к справочному руководству программы Venta Fax.

3. В окне Редактора сценариев, из меню Действия выберите команду Использовать загруженный сценарий как рабочий. Затем закройте окно Редактора сценариев.

4. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

5. В окне Настройка параметров выберите Папки и файлы, затем выберите Служебные файлы.

6. Убедитесь в наличие флажка у параметра Файл сценария дистанционного управления автоответчиком. Проверьте, что путь к выбранному вами файлу скрипта (в нашем примере файл 2mailbox.vfa) задан в текстовом поле ниже. Нажмите кнопку <Применить>.

7. В окне Настройка параметров выберите Прием, затем выберите Автоматический.

8. Поставьте флажок у параметра Переходить в режим дистанционного управления автоответчиком сразу после ответа на звонок. Эта опция позволяет запускать выбранный скрипт немедленно после ответа на входящий вызов.

9. Нажмите кнопку <Применить> чтобы сохранить настройки.

Используя скрипты, вы можете управлять автоответчиком удаленно, используя DTMF тона. Функция Распознавания DTMF поддерживается программой Fax Voip T.38 Модем.


Прослушивание линии через динамики

Для прослушивания телефонной линии через динамики компьютера

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. Запустите программу Venta Fax.

2. В правой панели главного окна программы Venta Fax, нажмите (активируйте) кнопку Синхронное воспроизведение с изображением динамика (см. рисунок ниже).

Данная функция позволяет прослушивать линию как в случае входящих, так и в случае исходящих вызовов вплоть до момента перехода программы в режим факса.

Заметим, что для прослушивания линии во время исходящих факсовых вызовов, не следует отключать голосовой режим при передаче факса. Для проверки, в окне Настройка параметров, на вкладке Факс – Общие, убедитесь, что отсутствует флажок у параметра Отключать голосовой режим при передаче факса (см. рисунок ниже).


Отправка факса

Отправка факса из приложения Venta Fax & Voice

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. В диалоговом окне Печать, выберите принтер VentaFax. Затем нажмите Печать.

3. В окне Мастера подготовки сообщения программы Venta Fax, нажмите кнопку <Далее>.

4. На странице “Шаг 3” мастера, введите номер факса получателя в поле Номер, нажмите кнопку <Готово>.

Программа Venta Fax автоматически наберет номер факса и будет отправлять факс.


Отправка голосового сообщения

Отправка голосового сообщения при помощи Venta Fax & Voice

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

Для отправки голосового сообщения

1. Запустите программу Venta Fax. В главном окне программы, на панели инструментов, нажмите Передать.

2. В окне Передача сообщения, в области Сообщение, выберите звуковой файл, который вы бы хотели передать в качестве голосового сообщения.

3. В окне Передача сообщения, в поле Номер, задайте номер телефона получателя сообщения, а затем нажмите кнопку <Передать с набором номера>.

Программа Venta Fax автоматически наберет номер телефона, дождется ответа на вызов и воспроизведет голосовое сообщение в линию.


Получение входящих факсов и голосовых сообщений

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

1. Запустите программу Venta Fax.

2. В правой панели главного окна программы Venta Fax, задайте требуемый режим ответа на входящие вызовы для вашего факса и автоответчика.

3. Включите опцию Реплика, если вы хотите воспроизводить в телефонную линию Голосовое приветствие автоответчика перед тем как Принимать факс или (и) Записывать голосовое сообщение.

4. Включите опцию Факс, если вы хотите иметь возможность Принимать факсы.

5. Включите опцию Запись, если вы хотите иметь возможность вести Запись голосовых сообщений.

6. Включите опцию АОН, чтобы получать информацию Caller ID.

7. Нажмите кнопку <auto>.

Программа Venta Fax будет автоматически отвечать на входящие VoIP вызовы и сохранять полученные факсы и голосовые сообщения.

Примечания

  • Функции Caller ID Number и Caller ID Name поддерживаются программой Venta Fax & Voice и Виртуальными COM портами (модемами).
  • В русскоязычной версии программы Venta Fax может потребоваться дополнительная настройка функции Caller ID. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка, в окне Настройка параметров, на вкладке Определение номера звонящего – Общие, выберите опцию Евро АОН (Caller ID) и нажмите Применить.


Факс по запросу

Настройка системы Факс по запросу с использованием Venta Fax и Fax Voip T.38 Модем

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

В комплект Fax Voip T.38 Модем входят необходимый скрипт, а также файлы с голосовыми и факсовыми сообщениями, которые устанавливаются в папку *{CommonAppDataFolder}\FaxVoip Modem\Plugins\VentaFax. Чтобы установить и настроить программу Venta Fax для работы с Виртуальными COM портами (модемами), следуйте инструкциям в предыдущих разделах этой главы.

Для настройки и тестирования системы Факс-по-запросу на базе Venta Fax и Fax Voip, выполните следующие шаги:

1. Запустите программу Venta Fax. В главном окне программы Venta Fax, в левой панели нажмите кнопку Редактор сценариев для запуска Редактора сценариев.

2. В окне Редактора сценариев, в меню Файл, нажмите Открыть. В диалоговом окне Открыть перейдите в папку *{CommonAppDataFolder}\FaxVoip Modem\Plugins\VentaFax, выберите файл fax_on_demand.vfa и затем нажмите Открыть.

3. В окне Редактора сценариев, в меню Действия, нажмите Использовать загруженный сценарий как рабочий. Закройте Редактор сценариев.

4. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

5. В окне Настройка параметров выберите Модем, затем выберите Свойства.

6. В панели Модем – Свойства, на вкладке Голос, снимите галочку напротив опции Не использовать голосовые функции модема. Нажмите кнопку <Применить>.

7. В окне Настройка параметров выберите Папки и файлы, затем выберите Служебные файлы. Включите опцию Файл сценария дистанционного управления автоответчиком и убедитесь, что в текстовом поле ниже выбран файл скрипта *{CommonAppDataFolder}\FaxVoip Modem\Plugins\VentaFax\fax_on_demand.vfa. Нажмите кнопку <Применить>.

8. В окне Настройка параметров выберите Прием, затем выберите Автоматический. Включите опцию Переходить в режим дистанционного управления автоответчиком сразу после ответа на звонок. Эта опция позволяет запускать скрипт немедленно после ответа на входящий звонок. Нажмите кнопку <Применить> чтобы сохранить настройки.

9. В главном окне программы Venta Fax, нажмите кнопку <auto>.

Venta Fax будет автоматически отвечать на входящие VoIP вызовы и запускать скрипт fax_on_demand.vfa.

После ответа на вызов, могут быть выбраны следующие действия:

      • При нажатии клавиши 1 и затем нажатии клавиши 1, Venta Fax будет отправлять документ fax#1.tif вызывающему абоненту (Факс-по-запросу).
      • При нажатии клавиши 1 и затем нажатии клавиши 2, Venta Fax будет отправлять документ fax#2.tif вызывающему абоненту (Факс-по-запросу).
      • При нажатии клавиши 1 и затем нажатии клавиши 3, Venta Fax будет отправлять документ fax#3.tif вызывающему абоненту (Факс-по-запросу).
      • При нажатии клавиши 2, Venta Fax будет принимать факс от вызывающего абонента (стандартное поведение).
      • При нажатии клавиши 3, Venta Fax перейдет в режим записи голосового сообщения.

Примечания

  • *{CommonAppDataFolder} – системная папка содержащая данные приложений, общая для всех пользователей компьютера. Путь к этой папке обычно C:\ProgramData.


Модуль VentaEngine

Venta Fax & Voice драйвер (VentaEngine)

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

Приложение Venta Fax & Voice функционирует на базе более компактного модуля, так называемого VentaEngine. VentaEngine поддерживает почти все функции работы с факсом и голосом, которые присутствуют в основном приложении. VentaEngine является независимым приложением, и может быть использовано для автоматизации отправки и получения факсов и голосовых сообщений.

Чтобы открыть приложение VentaEngine, выполните следующие шаги:

1. Запустите программу Venta Fax.

2. В системном трее найдите иконку Venta Fax. Щелкните по этой иконке правой кнопкой мыши для вызова контекстного меню.

3. Из контекстного меню выберите команду VentaEngine.

При помощи модуля VentaEngine, вы можете контролировать факсовые и голосовые события визуально (см. рисунки ниже). Первый рисунок иллюстрирует процесс передачи факса.

Следующий рисунок иллюстрирует процесс записи голосового сообщения.


Цветные факсы

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ››

С помощью программы Venta Fax & Voice вы можете отправлять и получать Цветные факсы через VoIP и ISDN, через Виртуальные COM порты (модемы) Fax Voip. Вы можете отправлять и принимать цветные факсы как по протоколу T.38 так и в аудио режиме (факс поверх кодека G.711). Для того чтобы успешно отправлять и принимать цветные факсы, должны выполняться следующие требования:

  • Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Таким образом, ECM должен быть включен в настройках Fax Voip T.38 Модем и в настройках Venta Fax.
  • Цветные факсы всегда передаются в высоком разрешении (204*196 dpi).
  • Ошибки в передаваемых данных не допускаются. Качество VoIP терминации должно быть достаточно хорошим, особенно при передаче цветных факсов в аудио режиме (факс поверх кодека G.711).
  • Чтобы передавать цветные факсы, должны быть осуществлены соответствующие настройки принтера VentaFax и программы Venta Fax.
  • На противоположной стороне также должно быть установлено оборудование или программное обеспечение, способное передавать и принимать цветные факсы.


Требования к VoIP сети

Требования к VOIP сети для цветных факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Практика показывает, что некоторые VoIP провайдеры по каким-либо причинам не обеспечивают поддержку режима Коррекции ошибок и это не зависит от настроек Fax Voip T.38 Модем или настроек Venta Fax. Заметим, что в этом случае отправка и получение цветных факсов невозможна.

В то же время, ошибки в передаваемых данных не допускаются. Эксперименты показывают, что при использовании VoIP провайдеров с плохим качеством терминации, попытка передать цветной факс обычно заканчивается неудачей. Тем не менее, передача черно-белых факсов может быть вполне успешной в описанных случаях. Это замечание особенно справедливо для цветных факсов, передаваемых в аудио режиме (факс поверх кодека G.711).

Таким образом, требования к VoIP сети с точки зрения отправки и приема цветных факсов могут быть сформулированы следующим образом:

  • Коррекция ошибок (ECM) должна быть разрешена в вашей VoIP сети.
  • Качество VoIP терминации должно быть достаточно хорошим.


Настройка Fax Voip T.38 Модем

Настройка Fax Voip T.38 Модем для работы с цветными факсами

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Цветные факсы всегда передаются в режиме Коррекции ошибок (ECM). Таким образом, необходимо включить поддержку ECM в параметрах Fax Voip T.38 Модем. Заметим, что ECM всегда включена в Fax Voip T.38 Модем для режима T.38. Таким образом, если вы не планируете отправлять и принимать цветные факсы в аудио режиме (факс поверх кодека G.711), дополнительных настроек не требуется.

В то же время, ошибки в передаваемых данных не допускаются. Эксперименты показывают, что при отправке и получении цветных факсов через VoIP в аудио режиме (факс поверх кодека G.711) на скорости 14400 бит/сек, передача цветного факса обычно заканчивается неудачей. Мы бы рекомендовали отправлять и принимать цветные факсы в аудио режиме с максимальной скоростью 9600 бит/сек. Заметим, что в случае использования ISDN CAPI 2.0 линии нет необходимости уменьшать скорость передачи факса.

Чтобы обеспечить отправку и получение цветных факсов в аудио режиме, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем.

2. Нажмите Факс, затем нажмите Коррекция/Скорость.

3. В области Коррекция ошибок (ECM) и ограничение скорости, в настройках Аудио факс поверх G.711, включите опцию ECM (необходимо).

4. В области Коррекция ошибок (ECM) и ограничение скорости, в настройках Аудио факс поверх G.711, в поле Максимальная скорость, выберите скорость 9600 (рекомендуется при отправке/получении цветных факсов в аудио режиме через VoIP).

5. Нажмите кнопку <Применить> чтобы сохранить настройки. Не забудьте перезапустить Fax Voip T.38 Модем для того чтобы работать с новыми параметрами.

Примечания

  • Заметим, что параметры Коррекция ошибок (ECM) и Максимальная скорость могут быть переопределены в настройках Маршрутизации исходящих VOIP вызовов и Маршрутизации входящих VOIP вызовов .


Настройка Venta Fax для отправки цветных факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Чтобы настроить отправку цветных факсов, выполните следующие шаги:

1. Переключитесь на панель Поиск, наберите панель управления, а затем нажмите Панель управления. В Панели управления нажмите Оборудование, а затем нажмите Устройства и принтеры.

2. В папке Устройства и принтеры, щелкните правой кнопкой мыши на принтере VentaFax. В контекстном меню, нажмите Свойства принтера.

3. В окне Свойства: VentaFax, на вкладке Общие, нажмите кнопку Настройка.

4. В окне Настройка печати: VentaFax, на вкладке Бумага и качество печати, в области Цвет, выберите опцию Цветная печать, а затем нажмите Применить.

5. Нажмите кнопку Дополнительно.

6. В окне Дополнительные возможности: VentaFax, выберите Качество печати: 200x200 dots per inch. Цветные факсы всегда передаются в высоком разрешении (204*196 dpi).

7. Выберите Режим цветной печати: True Color (24 разряда).

8. Выберите Compression for color tiff: LZW (рекомендовано). Вариант LZW обеспечивает сжатие без потери качества. Это особенно важно, если подготовленный цветной факс будет отправляться на разные факс-аппараты, и заранее не известно, работают ли они в цветном режиме или только в черно-белом. Лучшее качество черно-белого факса получается, если исходный цветной факс был сформирован без потери качества.

9. Нажмите OK чтобы вернуться к окну Настройка печати: VentaFax.

10. В окне Настройка печати: VentaFax, нажмите Применить, а затем нажмите OK.

11. В окне Свойства: VentaFax, нажмите OK.

12. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

13. В окне Настройка параметров выберите Факс, затем выберите Формат.

14. В панели Факс – Формат, перейдите на вкладку Цветные факсы.

15. На вкладке Цветные факсы, в области Качество факса при передаче, установите желаемую величину Качества факса. Не используйте слишком высокое качество, т.к. это сильно увеличит объем передаваемых данных и следовательно время передачи факса. Использование низкого качества приводит к сильному искажению передаваемых изображений, и также не может быть рекомендовано. Согласно нашим наблюдениям, использование Качество=20 дает малое время передачи (около 3 минут для полноценных фотографий на скорости факса 14400 бит/сек), при сохранении нормального качества изображения, поэтому может быть рекомендовано.

16. Нажмите кнопку <Применить> чтобы сохранить настройки.

Примечания

  • Объем данных, передаваемых по телефонной линии, напрямую не связан с размером подготовленного файла. Во время передачи данные подвергаются дополнительному сжатию. Степень сжатия и, как следствие, качество, определяется параметром Качество факса при передаче на вкладке Факс – Формат – Цветные факсы.
  • При формировании факса обычно рекомендуется использовать LZW-сжатие (для цветных факсов установлено по умолчанию в настройках принтера Ventafax). Размер файла при этом может оказаться в несколько раз большим, чем при использовании JPEG-сжатия. Однако, это не повлияет на объем передаваемых данных.
  • Если окажется, что на принимающей стороне факс-аппарат не умеет принимать цветные факсы, программе Venta Fax придется преобразовать факс к черно-белому формату. При этом черно-белый факс, полученный из цветного с JPEG-сжатием среднего или минимального качества, может получиться с некоторыми дефектами. Например, в нем могут появиться лишние точки вокруг черных символов. Поэтому лучше создавать факсы с использованием LZW-сжатия, чтобы гарантировать отсутствие снижения качества.
  • Другим аргументом в пользу LZW служит также то, что файлы TIFF, сжатые этим способом, могут быть просмотрены стандартными средствами Windows. С другой стороны, для просмотра файлов TIFF со сжатием JPEG потребуются дополнительные программы просмотра с расширенными возможностями (например, ACDSee).


Настройка Venta Fax для приема цветных факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Чтобы настроить прием цветных факсов, выполните следующие шаги:

1. В главном окне программы Venta Fax, на панели инструментов, нажмите Настройка.

2. В окне Настройка параметров выберите Факс, затем выберите Формат.

3. В панели Факс – Формат, перейдите на вкладку Цветные факсы.

4. На вкладке Цветные факсы, в области Способ сжатия принятых факсов, выберите LZW (рекомендуется).

5. Нажмите кнопку <Применить> чтобы сохранить настройки.

Примечания

  • Объем данных, полученных по телефонной линии, не зависит от настроек Venta Fax для случая входящих факсов.
  • При сохранении принятого факсимильного документа, рекомендуется использовать сжатие LZW. Верно, что размер файла при этом может оказаться в несколько раз большим, чем при использовании JPEG-сжатия. Однако, файлы TIFF, сжатые этим способом, могут быть просмотрены стандартными средствами Windows. С другой стороны, для просмотра файлов TIFF со сжатием JPEG потребуются дополнительные программы просмотра с расширенными возможностями (например, ACDSee).


Требования к противоположной стороне

Требования к противоположной стороне для цветных факсов

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

На противоположной стороне должно быть установлено оборудование или программное обеспечение, способное передавать и принимать цветные факсы. В качестве программного обеспечения, на противоположной стороне также может быть установлена программа Venta Fax & Voice. Заметим, что Venta Fax также может работать на PSTN линии с использованием аппаратного модема. Мы также протестировали некоторые другие программы, позволяющие отправлять и принимать цветные факсы. К сожалению, все остальные программные реализации для цветных факсов очень низкого качества и не могут быть использованы для отправки и получения цветных факсов через сети IP-телефонии, независимо от того, функционируют ли они на стороне Fax Voip T.38 Модем, или на противоположной стороне.

Если принимающий факс аппарат не имеет поддержки для работы с цветными факсами, цветной факс будет автоматически преобразован в черно-белую версию во время передачи.


Отправка цветных факсов

Отправка цветных факсов из приложения Venta Fax & Voice

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Для того чтобы отправить Цветной факс, сделайте соответствующие настройки и следуйте инструкциям раздела Отправка факса из приложения Venta Fax & Voice настоящей главы.

Если факс действительно передается в цветном режиме, в главном окне приложения Venta Fax вы увидите текст Передача страницы (color).


Прием цветных факсов

Прием цветных факсов приложением Venta Fax & Voice

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с Venta Fax & Voice ›› Цветные факсы ››

Чтобы принимать факсы, следуйте инструкциям раздела Получение входящих факсов и голосовых сообщений настоящей главы. Venta Fax автоматически детектирует Цветные факсы.

Если факс принимается в цветном режиме, в главном окне приложения Venta Fax вы увидите текст Прием страницы (color).


Использование Fax Voip T.38 Модем с FaxAmatic

Использование Fax Voip T.38 Модем с программой FaxAmatic

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ››

Программу FaxAmatic можно загрузить с веб-сайта ElectraSoft .

Самым сложным моментом при настройке FaxAmatic для работы с Fax Voip T.38 Модем является конфигурирование параметров модема. FaxAmatic не поддерживает TAPI, и поэтому не может быть использован с драйвером модема Fax Voip 14.4K TAPI Voice-Fax Modem. В то же время настройки, предлагаемые программой FaxAmatic по умолчанию, непригодны для работы с Fax Voip T.38 Модем через прямое подключение к Виртуальному COM порту. Таким образом, при настройке FaxAmatic, мы настоятельно рекомендуем внимательно следовать прилагаемой инструкции.


Конфигурирование FaxAmatic

Конфигурирование FaxAmatic для работы с Fax Voip T.38 Модем

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxAmatic ››

1. Запустите программу FaxAmatic.

2. Выберите вкладку Configure, а затем вкладку Modem1.

3. В поле COM-port, выберите один из Виртуальных COM портов Fax Voip.

4. В поле FaxModem Initialization String, введите команду ATE0V1.

5. В области Flow Control, выберите вариант Xon/Xoff.

6. В поле Class Override выберите Систему факсимильных команд модема Class1.

7. В поле When Dialing, Use выберите Tone (тоновый режим набора номера).

8. В группе phone-line / COM-port (modem baud rate speed) выберите опцию Line 14400 - Port 19200 (newer modem).

9. В группе Modem Usage выберите опцию Send and Receive Fax (отправка и получение факсов).

10. Убедитесь, что ваши настройки сохранены.


Отправка факса

Отправка факса из приложения FaxAmatic

Использование Fax Voip T.38 Модем с факсовыми и голосовыми программами ›› Использование Fax Voip T.38 Модем с FaxAmatic ››

Для отправки факса

1. Откройте или создайте документ в приложении Windows, в котором имеется функция печати.

2. Выберите команду Печать. В диалоговом окне Печать, выберите принтер ElectraSoft NT Print to Fax (ElectraSoft amd64 Fax). Затем нажмите Печать.

3. В приложении FaxAmatic, на вкладке Send Fax, введите имя получателя факса в поле To и номер факса получателя в поле Fax #.

4. Для просмотра факса, используйте кнопку View Fax.

5. Для замены отправляемого факсимильного документа, используйте кнопку Get Fax.

6. По желанию вы можете включить в факс титульную страницу, для чего следует выбрать опцию Include Cover page в группе настроек Cover page.

7. В группе Mode, выберите Fine, чтобы передавать факс с разрешением 200x200, либо выберите Coarse чтобы передавать факс с разрешением 200x100.

8. Нажмите кнопку Send Fax to Single Recipient чтобы отправить факс.

Программа FaxAmatic автоматически наберет номер факса и будет отправлять факс.


Примеры настройки с операторами VoIP

При отправке и приеме факсов через VoIP, настоятельно рекомендуется воспользоваться услугами тех операторов IP-телефонии, которые предоставляют поддержку T.38. Протокол T.38 - наиболее надежный протокол передачи факсов через VoIP в режиме реального времени. Компенсирует задержки и потери пакетов характерные для VoIP.

Ниже приведены примеры VoIP (SIP) операторов, которые поддерживают T.38:

  • Настройка c YouMagic (МТТ)
  • Настройка с Телфин

Fax Voip T.38 Модем также поддерживает отправку/прием факсов по аудио каналу (факс поверх кодека G.711). Это может быть полезно при работе с VoIP операторами, которые не поддерживают T.38, но при этом обеспечивают достойное качество голосового канала. См. примеры ниже:

  • Настройка с Мультифон (Мегафон)
  • Настройка с Dellmont (Betamax)


Youmagic.com (МТТ)

Настройка Fax Voip T.38 Модем c оператором YouMagic (проект МТТ)

Примеры настройки с операторами VoIP ››

Youmagic.com – SIP проект оператора связи МТТ (ОАО «Межрегиональный Транзит Телеком»). Из характерных особенностей: качественная поддержка T.38, предоставление городских телефонных номеров в Москве и некоторых других городах. Получить учетную запись можно, зарегистрировавшись на веб-сайте оператора .

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): номер телефона, предоставленный оператором

Пароль: пароль

Сервер регистрации: voip.mtt.ru

Настройка маршрутизации исходящих вызовов

На вкладке общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: voip.mtt.ru

Имя пользователя: номер телефона, предоставленный оператором

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.


Телфин

Настройка Fax Voip T.38 Модем c оператором Телфин

Примеры настройки с операторами VoIP ››

Telphin.ru – SIP оператор, поддерживающий передачу факсов по протоколу T.38. Получить учетную запись можно, зарегистрировавшись на веб-сайте оператора . Данному оператору также принадлежит проект telMe .

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): SIP-ID, предоставленный оператором

Пароль: пароль

Сервер регистрации: sip.telphin.com:5068

Прокси-сервер: voice.telphin.com:5068

Настройка маршрутизации исходящих вызовов

На вкладке общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: sip.telphin.com:5068

Прокси-сервер: voice.telphin.com:5068

Имя пользователя: SIP-ID, предоставленный оператором

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра T.38 факс.


Мультифон (Мегафон)

Настройка Fax Voip T.38 Модем c оператором Мультифон (проект Мегафон)

Примеры настройки с операторами VoIP ››

Мультифон – SIP проект оператора мобильной связи Мегафон . Из характерных особенностей: передача факса поверх кодека G.711, поддержка схемы Tel URI для исходящих SIP вызовов, поддержка не только SIP через UDP, но и SIP через TCP. Для регистрации необходимо являться абонентом Мегафон , скачать приложение Мультифон и произвести регистрацию с его помощью. Полученную учетную запись можно затем использовать в программе Fax Voip T.38 Модем для передачи факсов.

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): номер вашего мобильного телефона

Пароль: пароль

Сервер регистрации: multifon.ru

Настройка маршрутизации исходящих вызовов

На вкладке общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: multifon.ru

Имя пользователя: номер вашего мобильного телефона

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Остальные опции желательно отключить.

Настройка маршрутизации входящих вызовов

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Остальные опции желательно отключить.

Для установки переадресации вызовов на SIP клиент (Fax Voip T.38 Модем), можно использовать http-запрос следующего вида:

https://sm.megafon.ru/sm/client/routing/set?login=<login>&password=<password>&routing=<routing>

routing

Режим приёма входящих вызовов:
0 – только на мобильный
1 – только SIP (в программный или аппаратный SIP- телефон)
2 – параллельный вызов


Dellmont (Betamax)

Настройка Fax Voip T.38 Модем c операторами DellMont (Betamax)

Примеры настройки с операторами VoIP ››

Существует огромное количество SIP провайдеров, которые ассоциируются с компанией DellMont (Betamax) , например VoipBuster . Операторы этой группы не поддерживают протокол T.38. Качество передачи факса поверх кодека G.711 сильно зависит от страны, куда посылается факс. При звонках в Европу качество очень хорошее, при звонках в Россию качество в целом удовлетворительное. Для регистрации необходимо посетить веб-сайт одного из провайдеров данной группы. Тарифы на разных сайтах могут отличаться. Список провайдеров приведен ниже.

Настройка учетной записи SIP

Имя пользователя (или SIP-ID): имя пользователя, полученное при регистрации

Пароль: пароль, полученный при регистрации

Сервер регистрации: sip.voipbuster.com (подходит для любого из провайдеров этой группы)

Настройка маршрутизации исходящих вызовов

На вкладке общие, в области Маршрутизировать вызов, проверьте, что используются следующие настройки:

VOIP протокол: SIP

Сервер SIP: sip.voipbuster.com

Имя пользователя: имя пользователя, полученное при регистрации

На вкладке Факс, в области Режимы факса, проверьте, что стоит флажок у параметра Факс поверх G.711. Остальные опции желательно отключить.

Набираемый номер вводится в формате 00<код_страны><код_города><номер_телефона>.

Список провайдеров DellMont (Betamax)

        • Nonoh
        • 12Voip
        • Free Call
        • InternetCalls.com
        • JustVoip
        • VoipCheap.com
        • VoipCheap.co.uk
        • Low-rate Voip
        • NetAppel
        • PoivY
        • Sip Discount
        • VoipBuster
        • VoipRaider
        • VoipDiscount
        • VoipStunt
        • WebCall Direct
        • SMS Discount
        • SMSListo
        • VoipWise
        • Voice Trading
        • InterVoip.com
        • DialNow
        • VoipBusterPro
        • CallEasy.com
        • VoipZoom
        • ActionVoip
        • VoipBlast.com
        • Jumblo
        • VoipGain
        • Telbo
        • Rynga.com
        • PowerVoip.com
        • CheapVoip
        • BestVOIPReselling
        • CallingCredit.Com


Лицензии

  • Виды лицензий
  • Просмотр текущей лицензии
  • Покупка лицензии
  • Добавление/изменение лицензии
  • Обновление до версии 9
  • Политика лицензионной поддержки
  • Часто задаваемые вопросы (FAQ)


Виды лицензий

Лицензии ››

В настоящее время для Fax Voip T.38 Модем предлагаются следующие лицензии:

Лицензия Fax Voip T.38 Модем Виртуальные COM порты (версия 9)

В зависимости от приобретенной лицензии, вы можете одновременно использовать один или более Виртуальный COM порт (голосовой факс-модем). Данный тип лицензии позволяет:

  • Отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы через SIP, H.323 сети IP-телефонии и через линию ISDN CAPI 2.0 с использованием стандартных факс программ ( Служба факсов Windows / Факсы и сканирование *, WinFax Pro, а также любые другие программы, умеющие работать с факс модемами или COM портами напрямую).
  • Отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы, а также голосовые сообщения через SIP, H.323 сети IP-телефонии и через линию ISDN CAPI 2.0 с использованием программ для работы с голосовыми факс-модемами ( BVRP Classic Phone Tools 9 , FaxTalk Messenger Pro 7.5 , CallStation , Venta Fax & Voice и другие).
  • Использовать функцию Почта-на-факс - Microsoft Fax . Поддержка нескольких e-mail вложений, титульные страницы , правила для почты , шаблоны электронной почты .
  • Использовать базовую маршрутизацию для входящих факсов - Microsoft Fax (Расширение маршрутизации Fax Voip T.38 Модем): Отправить по электронной почте , Сохранить в папке , Печать с ограниченным количеством правил.
  • Использовать пользовательскую маршрутизацию входящих факсов - Microsoft Fax (Расширение маршрутизации Fax Voip T.38 Модем).
  • Использовать базовую маршрутизацию для исходящих факсов - Microsoft Fax : Уведомления о доставке по электронной почте , Сохранить в папке , Печать с ограниченным количеством правил.
  • Использовать пользовательскую маршрутизацию исходящих факсов - Microsoft Fax .
  • Использовать утилиту командной строки SendFaxMS.exe - Microsoft Fax для отправки факсов.

Лицензия Fax Voip T.38 Модем расширенная маршрутизация факсов (E-mail, Сохранить в папке, Печать) (версия 9)

Чтобы использовать данную лицензию, вам необходимо также приобрести и установить лицензию Fax Voip T.38 Модем Виртуальные COM порты (модемы). Эта лицензия позволяет существенно увеличить максимальное количество правил, которые разрешено использовать со следующими методами маршрутизации для входящих факсов (Microsoft Fax) и методами маршрутизации для исходящих факсов (Microsoft Fax) :

  • Отправить по электронной почте - Microsoft Fax (маршрутизация входящих факсов, расширение маршрутизации Fax Voip T.38 Модем)
  • Сохранить в папке - Microsoft Fax (маршрутизация входящих факсов, расширение маршрутизации Fax Voip T.38 Модем)
  • Печать - Microsoft Fax (маршрутизация входящих факсов, расширение маршрутизации Fax Voip T.38 Модем)
  • Уведомления о доставке по электронной почте - Microsoft Fax (маршрутизация исходящих факсов)
  • Сохранить в папке - Microsoft Fax (маршрутизация исходящих факсов)
  • Печать - Microsoft Fax (маршрутизация исходящих факсов)

Примечания

  • (* : При работе с Microsoft Fax и приложением Факсы и сканирование Windows, в настоящее время мы рекомендуем использовать другой продукт, Fax Voip Windows Fax Service Provider (Fax Voip FSP). Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Корректно определяется сигнал 'занято'. В Fax Voip FSP реализовано Расширение маршрутизации Fax Voip FSP, которое интегрируется в службу факсов Windows. Fax Voip FSP сохраняет Номер вызываемого абонента (DID) в поле Сведения о маршрутизации, которое в частности доступно в программном обеспечении Факсы и сканирование Windows, в свойствах входящего факса (обходные методы не используются). Методы маршрутизации для исходящих факсов, реализованные в Fax Voip FSP, работают независимо от учетной записи пользователя, под которой было создано задание факса. Использование Fax Service Provider (FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.


Просмотр текущей лицензии

Лицензии ››

1. Откройте Панель управления Fax Voip T.38 Модем. Для этого в меню Пуск выберите последовательно команды Fax Voip T.38 Modem и Панель управления Fax Voip T.38 Modem. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip T.38 Модем из меню иконки Fax Voip T.38 Модем в системном трее.

2. Для просмотра текущего состояния лицензии, в дереве Панели управления Fax Voip T.38 Модем нажмите О программе.

3. Для просмотра подробной информации о текущей лицензии, в дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия. Вкладка Лицензии содержит информацию о числе Виртуальных COM портов, лицензированных на вашем компьютере. Также отображается информация о максимальном количестве доступных правил для методов маршрутизации факсов.


Покупка лицензии

Лицензии ››

1. Чтобы купить лицензию Fax Voip T.38 Модем, следует посетить веб-сайт программы:

https://www.t38faxvoip.ru/buy.htm

2. Откройте Панель управления Fax Voip T.38 Модем. Для этого нажмите Пуск, выберите Fax Voip T.38 Modem; нажмите Панель управления Fax Voip T.38 Modem. Кроме того, вы можете воспользоваться командой Панель управления Fax Voip T.38 Модем из меню иконки Fax Voip T.38 Модем в системном трее.

3. В дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия, затем нажмите кнопку Купить.

4. Если вы не смогли найти требуемой лицензии среди предлагаемых вариантов, например, желаете приобрести не стандартное количество Виртуальных COM портов или правил расширенной маршрутизации факсов, пожалуйста свяжитесь с нашим отделом продаж ( sales@t38faxvoip.ru ) и обсудите детали вашей будущей лицензии. Заметим, что лицензия Расширенная маршрутизация факсов должна приобретаться отдельно.

5. После осуществления платежа, в дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия, затем нажмите Регистрация.

6. В окне Лицензия Fax Voip T.38 Модем, в области Для получения лицензионного ключа, отображается уникальный для вашего компьютера идентификатор системы, так называемый System ID. Эта информация необходима для того, чтобы сгенерировать ваш лицензионный ключ. Вам следует выделить ваш SystemID, копировать и вставить ваш SystemID в ваш документ (e-mail). Следует также предоставить информацию, подтверждающую оплату программы. Письмо следует отправить на наш адрес электронной почты sales@t38faxvoip.ru .

7. Как правило, по зачислению оплаты за лицензию, мы сами отправляем вам письмо с предложением прислать ваш System ID. При оплате продукта следует указывать действительный адрес электронной почты, чтобы было возможно связаться с вами.

Примечания

  • Ваш SystemID зависит от оборудования вашего компьютера. Если Вы планируете делать какие-либо изменения с оборудованием, пожалуйста сделайте это перед получением Лицензионного Ключа.
  • Если у вас уже имеются ранее купленные лицензии и вы бы хотели увеличить число Виртуальных COM портов (модемов) или правил расширенной маршрутизации факсов на вашем компьютере, пожалуйста проинформируйте наш отдел продаж об этом. Изменение типа Лицензии потребует замены Лицензионного Ключа.
  • В случае одновременной покупки лицензии Виртуальные COM порты (модемы) и лицензии Расширенная маршрутизация факсов, в вашем e-mail содержащем SystemID, пожалуйста укажите, что обе лицензии предназначаются для одного и того же компьютера.
  • Если у вас уже имеются ранее купленные лицензии Виртуальные COM порты (модемы) и вы желаете добавить лицензию Расширенная маршрутизация факсов, чтобы увеличить число правил маршрутизации факсов на вашем компьютере, пожалуйста обеспечьте нас необходимой информацией о вашей действующей лицензии Виртуальные COM порты (модемы). Добавление лицензии Расширенная маршрутизация факсов потребует замены Лицензионного Ключа.


Добавление/изменение лицензии

Лицензии ››

1. Чтобы Добавить новую лицензию или заменить ваш Лицензионный ключ, в дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия, затем нажмите кнопку Регистрация.

2. Скопируйте Лицензионную информацию из сообщения e-mail и вставьте ее в текстовое поле Лицензионная информация в области Для активации лицензионного ключа в окне Лицензия Fax Voip T.38 Модем. Первое число указывает на количество Виртуальных COM портов (модемов), третье – на количество правил Расширенной маршрутизации факсов, второе является нулем и зарезервировано для будущего использования.

3. Скопируйте Лицензионный ключ из сообщения e-mail и вставьте его в текстовое поле Лицензионный ключ в области Для активации лицензионного ключа в окне Лицензия Fax Voip T.38 Модем.

4. Нажмите кнопку Обновить. Для активации Лицензионного ключа требуются права администратора.

5. Подождите, пока Fax Voip T.38 Модем настроит и перезапустит службы.

6. В области системного трея нажмите на сообщение Лицензия активирована. Перезапустите Fax Voip T.38 Модем, нажав на ярлык Fax Voip T.38 Modem на рабочем столе либо любым другим способом.

7. Откройте Панель управления Fax Voip T.38 Модем, дважды щелкнув иконку Fax Voip T.38 Модем в системном трее. В дереве Панели управления Fax Voip T.38 Модем нажмите О программе для проверки состояния лицензии.

8. Для просмотра подробной информации о лицензии, в дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия.

Примечания

  • Пожалуйста сохраните ваш SystemID и сообщение электронной почты, содержащее Лицензионный ключ.
  • Лицензионный ключ проверяется, перед тем как он будет сохранен в реестре Windows. Таким образом, возможность случайного ввода недействительного лицензионного ключа исключается.
  • Чтобы удалить лицензионный ключ, нажмите кнопку Удалить. Требуются права администратора.


Обновление до версии 9

Обновление до Fax Voip T.38 Модем версии 9

Лицензии ››

Если вы используете старую версию Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней), вы можете обновиться до Fax Voip T.38 Модем версии 9 со скидкой. Опция Обновиться до Fax Voip T.38 Модем версии 9 доступна только для компьютера, на котором Fax Voip T38 Fax & Voice был лицензирован ранее.

Обновление до приложения Fax Voip T.38 Модем доступно только для пользователей, имеющих лицензию Fax Voip Виртуальные COM порты (Fax Voip T38 Fax & Voice версии 8 или более ранней).

При наличии лицензии Fax Voip Внутренние VOIP/ISDN факс/аудио линии (Fax Voip T38 Fax & Voice версии 8 или более ранней), вы можете обновиться до приложения Fax Voip T.38 Консоль версии 9.

Если у вас имеются оба типа лицензий (Fax Voip T38 Fax & Voice версии 8 или более ранней), вы можете установить Fax Voip T.38 Модем (версии 9) и Fax Voip T.38 Консоль (версии 9) и обновить ваши лицензии независимо друг от друга.

Для обновления вашей текущей лицензии, выполните следующие шаги:

1. Откройте Панель управления Fax Voip T.38 Модем. Для этого в меню Пуск выберите последовательно команды Fax Voip T.38 Modem и Панель управления Fax Voip T.38 Modem.

2. В дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия.

3. В списке Лицензии должны отображаться все лицензии, действительные для предыдущих версий Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней). Кнопка <Апгрейд> должна быть видима и доступна. Если по каким-либо причинам вы не видите ваших старых лицензий, пожалуйста свяжитесь с нашим отделом продаж .

4. Нажмите кнопку <Апгрейд>. Вы будете перенаправлены на страницу оплаты, где вы сможете заплатить за обновление вашей текущей лицензии до лицензии 9-й версии.

5. После осуществления платежа, в дереве Панели управления Fax Voip T.38 Модем нажмите Лицензия, затем нажмите Регистрация.

6. В окне Лицензия Fax Voip T.38 Модем, в области Для обновления лицензии, нажмите на ссылку Нажмите, чтобы показать проверочные коды. Для выполнения этого действия требуются права администратора.

7. Скопируйте и вставьте следующую информацию в ваш документ (e-mail):

      • SystemID (заканчивается -FV9)
      • Проверочный код #1 (заканчивается -FV91)
      • Проверочный код #2 (заканчивается -FV92, только если отображен)

SystemID требуется для генерации лицензионного ключа. Проверочные коды необходимы для проверки того, что Fax Voip T.38 Модем действительно установлен на компьютере, для которого вам выдавалась действительная лицензия для предыдущих версий Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней).

8. E-mail, содержащий SystemID и Проверочные коды, следует отправить на наш адрес электронной почты sales@t38faxvoip.ru .

9. После получения нового лицензионного ключа, следуйте инструкциям главы Добавление/изменение лицензии настоящего справочного руководства.

Примечания

  • При обновлении до Fax Voip T.38 Модем версии 9, ваш жесткий диск проверяется, чтобы убедиться, что вы являетесь лицензированным пользователем программного продукта Fax Voip T38 Fax & Voice. Наличие пробных версий Fax Voip T.38 Модем не является подтверждением на право использования продукта. Вы не сможете установить обновление до Fax Voip T.38 Модем версии 9, если на вашем компьютере отсутствует установленная ранее действительная лицензия Fax Voip T38 Fax & Voice.
  • Вы можете обновить только существующую лицензию Fax Voip Виртуальные COM порты (такое же количество Виртуальных COM портов и правил для методов маршрутизации факсов). Если вы хотите приобрести дополнительные Виртуальные COM порты или правила для методов маршрутизации факсов, вы должны приобрести соответствующие лицензии отдельно.
  • При наличии лицензии Fax Voip Внутренние VOIP/ISDN факс/аудио линии (Fax Voip T38 Fax & Voice версии 8 или более ранней), вы можете обновиться до приложения Fax Voip T.38 Консоль версии 9.
  • Если у вас имеются оба типа лицензий (Fax Voip T38 Fax & Voice версии 8 или более ранней), вы можете установить Fax Voip T.38 Модем (версии 9) и Fax Voip T.38 Консоль (версии 9) и обновить ваши лицензии независимо друг от друга.
  • Обновление лицензии не предполагает перенос лицензии на другой компьютер и осуществляется на компьютере, для которого Fax Voip T38 Fax & Voice был лицензирован ранее.
  • Размер скидки, предоставляемый в случае обновления лицензии, зависит от текущей политики Fax Voip Software и может изменяться.
  • По любым вопросам касательно права обновления или требований к обновлению, пожалуйста отправьте сообщение e-mail в наш отдел продаж .


Политика лицензионной поддержки

Лицензии ››

Срок лицензионной поддержки устанавливается один календарный год со дня приобретения лицензии.

  • Лицензионный ключ привязан к единственному компьютеру и генерируется на основе уникального для вашего компьютера идентификатора системы System ID. По умолчанию генерируется постоянный лицензионный ключ, не ограниченный во времени.
  • Бесплатная замена лицензионного ключа (генерация нового ключа для другого System ID) при замене или изменении аппаратной части компьютера, переустановке операционной системы и т.п. возможна в течении срока лицензионной поддержки (1 год). По умолчанию, интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. В любом случае, бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз.
  • При бесплатной замене лицензионного ключа, предыдущий лицензионный ключ (System ID) блокируется и добавляется в черный список. Таким образом, вы не сможете когда-либо использовать Fax Voip T.38 Модем на вашем старом компьютере после такой замены лицензионного ключа.
  • Пользователь лицензионной версии программы имеет право на платное продление срока лицензионной поддержки. Стоимость продления срока лицензионной поддержки на один год устанавливается в размере 30% от текущей стоимости вашей лицензии на момент продления.
  • По любым вопросам, касающихся лицензионной поддержки, пожалуйста свяжитесь с нашим отделом продаж по электронной почте.


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Лицензии ››

Я хочу купить Fax Voip T.38 Модем. Как я могу сделать это?

Пожалуйста посетите страницу оплаты программы на нашем веб-сайте . Выберите лицензию которую вы бы хотели приобрести и нажмите Купить. Следуйте инструкциям платежной системы. Если вы российская организация, и для бухгалтерского учета вам требуются документы установленного образца (счет-фактура, торг-12), рекомендуем осуществлять покупку через одного из наших представителей в РФ, например allsoft.ru .

Я собираюсь приобрести Fax Voip T.38 Модем. Какую лицензию мне купить? Какой тип лицензии мне нужен?

Подробное описание лицензий можно найти в главе Виды лицензий настоящего справочного руководства, а также на странице оплаты программы на нашем веб-сайте . Лицензия Fax Voip T.38 Модем Виртуальные COM порты позволяет отправлять/принимать факсы при помощи стандартной факс программы . Лицензии также различаются по количеству портов, что соответствует количеству факсов, которые вы можете отправлять/принимать одновременно. Лицензия Fax Voip T.38 Модем расширенная маршрутизация факсов является дополнением к лицензии Fax Voip T.38 Модем Виртуальные COM порты и нужна для маршрутизации факсов большому количеству адресатов (например по e-mail).

Какую лицензию предоставляет пробная версия?

Fax Voip T.38 Модем ТРИАЛ работает следующим образом:

Fax Voip T.38 Модем

лицензия 2 Виртуальных COM порта

(T38/G711Fax/ISDN/Voice модема)

но в течении ограниченного пробного периода времени 15 дней.

Я бы хотел купить "Fax Voip T.38 Модем Лицензия 9 Виртуальных COM портов (T38/G711Fax/Voice модемов)", но не вижу такой лицензии на странице оплаты... Как мне купить ее?

Мы можем продать любое количество Виртуальных COM портов (модемов). Если вы не видите требуемой лицензии на странице оплаты программы на нашем веб-сайте , пожалуйста свяжитесь с нашим отделом продаж и мы вышлем вам необходимую ссылку на оплату требуемой лицензии.

Я оплатил лицензию. Где мой лицензионный ключ?...

Как упомянуто в главе Покупка лицензии настоящего справочного руководства, после осуществления платежа вам следует отправить ваш SystemID в наш отдел продаж . Ваш SystemID необходим для того, чтобы сгенерировать ваш лицензионный ключ. Как правило, по зачислению оплаты за лицензию, мы сами отправляем вам письмо с предложением прислать ваш System ID. При оплате продукта следует указывать действительный адрес электронной почты, чтобы было возможно связаться с вами. Обычно мы пытаемся связаться с вами в течении нескольких часов после получения денег от вас (но не позднее 48 часов, согласно требованиям платежной системы).

Я уже приобрел лицензию “Fax Voip T.38 Модем Лицензия 2 Виртуальных COM порта (T38/G711Fax/Voice модема)”. Мы бы хотели добавить лицензию на “2 Виртуальных COM порта” к нашей лицензии, чтобы иметь “Fax Voip T.38 Модем Лицензия 4 Виртуальных COM порта (T38/G711Fax/Voice модема)”. Что я должен делать?

Пожалуйста посетите наш веб-сайт . Чтобы добавить “2 Виртуальных COM порта”, вы должны оплатить лицензию Fax Voip T.38 Модем лицензия 2 Виртуальных COM порта (T38/G711Fax/Voice модема) и связаться с нашим отделом продаж . Мы заменим ваш текущий лицензионный ключ новым ключом (предполагается тот же компьютер) Fax Voip T.38 Модем лицензия 4 Виртуальных COM порта (T38/G711Fax/Voice модема). Если вы не видите на странице оплаты требуемой лицензии, которую вы хотели бы добавить, свяжитесь с нашим отделом продаж и мы вышлем вам необходимую ссылку на оплату требуемой лицензии.

Я оплатил лицензию, пожалуйста вышлите мне мой лицензионный ключ. Я установил Fax Voip T.38 Модем на временный сервер, на следующей неделе я установлю Fax Voip T.38 Модем на новый сервер. (В следующем месяце, году, я собираюсь покупать новый компьютер или буду менять мой жесткий диск...) Могу ли я просить другой лицензионный ключ позже?

Чтобы было возможно попросить другой лицензионный ключ позже, вы можете попросить временный лицензионный ключ (с датой окончания лицензии). В этом случае вы сможете попросить другой лицензионный ключ (даже для другого компьютера) ближе к концу срока действия текущего ключа. Если вы хотите получить временный лицензионный ключ вместо постоянного, следует попросить нас об этом до получения лицензионного ключа. По умолчанию, мы высылаем вам постоянный лицензионный ключ, привязанный к единственному SystemID.

Что произойдет с моей лицензией, если я переустановлю Fax Voip T.38 Модем? Что произойдет с моей лицензией, если я переустановлю Windows? Могу ли я просить новый лицензионный ключ?

При удалении и переустановке Fax Voip T.38 Модем, ваш лицензионный ключ сохраняется в системном реестре Windows. Не нужно вводить его повторно.

Лицензия привязана к единственному компьютеру (SystemID). При использовании нормального аппаратного компьютера, SystemID зависит только от вашего оборудования и не зависит от версии операционной системы Windows или от конкретной установки. После переустановки Windows, вы можете использовать ваш лицензионный ключ без каких-либо проблем. В этом случае, вы должны повторно ввести лицензионный ключ согласно стандартным инструкциям. При использовании Виртуальной машины, SystemID не сохраняется ввиду отсутствия оборудования как такового. Вам следует устанавливать Fax Voip T.38 Модем на нормальный аппаратный компьютер чтобы избежать подобных проблем. Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз.

Где я могу загрузить пробную версию “16 Виртуальных COM портов” (или “8 Виртуальных COM портов”)?

2 Виртуальных COM порта (модема), доступные во время пробного периода, более чем достаточно для тестирования. Другие линии будут работать точно также. Если вам необходимо большее количество линий, вы должны купить лицензию .

Я использую стационарный компьютер дома, но также имею ноутбук, который обычно беру с собой в путешествие. Также, я иногда работаю на компьютере в офисе... Я никогда не использую оба компьютера одновременно. Не могли бы вы прислать лицензионный ключ, который будет работать на обеих машинах?

Лицензия привязана к единственному компьютеру. Если вы хотите использовать Fax Voip T.38 Модем на нескольких компьютерах, вам следует приобрести отдельную лицензию для каждого из них.

Наш пробный период закончился. Могу ли я продлить пробный период? (Как сбросить пробный период?)

Мы не знаем как сбросить пробный период на вашем компьютере. Мы также не знаем, как взломать нашу защиту. 15 дней это более чем достаточно для тестирования. Если вы собираетесь использовать Fax Voip T.38 Модем по истечении 15 дней, вы должны купить лицензию .

Мы хорошо известная компания, наша продукция известна во всем мире... Не могли бы вы прислать нам лицензионный ключ, в идеале не привязанный к конкретному компьютеру, т.к. у нас много компьютеров, используемых для тестирования..?

15 дней это более чем достаточно для тестирования. Если вы собираетесь использовать Fax Voip T.38 Модем по истечении 15 дней, вы должны купить лицензию . Лицензия привязана к единственному компьютеру, поэтому вам необходимо приобрести отдельную лицензию для каждого компьютера, на котором вы намерены использовать Fax Voip T.38 Модем. Известные успешные компании обычно не задают таких вопросов. Кроме того, наши цены являются относительно низкими.

Мой жесткий диск (материнская плата) умер, что было так неожиданно... Не могли бы вы выслать мне другую лицензию?

Мы не рекомендуем устанавливать наше программное обеспечение на старые компьютеры с плохими жесткими дисками. Следует также отметить, что срок службы жесткого диска, обычно составляет не менее 2-3-х лет (это при очень грубом обращении). Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я клонировал мой жесткий диск с использованием специальной утилиты, отключил старый диск (из-за аппаратных проблем) и начал работу с использованием нового диска. Но Fax Voip T.38 Модем теперь не лицензирован. Затем я удалил Fax Voip T.38 Модем с моего компьютера, перезагрузил компьютер и установил Fax Voip T.38 Модем заново. Но опять та же проблема...

Лицензия привязана к единственному компьютеру (SystemID). Ваш SystemID не может быть “клонирован”, т.к. определяется вашим физическим оборудованием (в частности зависит от жесткого диска). Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я переустановил Windows и мой SystemID изменился. Я использую Виртуальную машину (VMWare и т.п.) и мой виртуальный сервер рухнул в прошлую пятницу. Не могли бы вы прислать мне другую лицензию?

Мы категорически не рекомендуем устанавливать Fax Voip T.38 Модем на Виртуальную машину. Виртуальные машины чрезвычайно неустойчивы и требуют частых переустановок, при которых SystemID не сохраняется ввиду отсутствия оборудования как такового. Пожалуйста установите Fax Voip T.38 Модем на нормальный аппаратный компьютер. В любом случае вы можете попросить новый лицензионный ключ в течении срока лицензионной поддержки (1 год). Интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. Бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз. Пожалуйста свяжитесь с нашим отделом продаж .

Я решил использовать Fax Voip T.38 Модем на другом компьютере. Не могли бы вы прислать мне новую лицензию? (Как я могу перенести лицензию?)

Лицензия привязана к единственному компьютеру. Бесплатная замена лицензионного ключа возможна в течении срока лицензионной поддержки (1 год), но не более 2-х (двух) раз. При бесплатной замене лицензионного ключа, предыдущий лицензионный ключ (System ID) блокируется и добавляется в черный список. Таким образом, вы не сможете когда-либо использовать Fax Voip T.38 Модем на вашем старом компьютере после такой замены лицензионного ключа.

Я хочу перепродавать вашу программу. Что я должен делать? Могу ли я получать специальные скидки?

Пожалуйста свяжитесь с нашим отделом продаж .

Я установил новую версию Fax Voip T.38 Модем 9.x.x. Я имею действительный лицензионный ключ, установленный на моем компьютере, но Fax Voip T.38 Модем показывает, что я работаю с пробной версией. В чем может быть проблема?...

Скорее всего ваша лицензия позволяет работать с Fax Voip версии 8.3.1 или более ранней. Вы можете обновиться до Fax Voip T.38 Модем версии 9 , воспользовавшись специальной скидкой.

Мы использовали пиратскую копию Windows и были вынуждены уничтожить наши компьютеры (с установленной лицензией Fax Voip T.38 Модем).... Не могли бы вы прислать мне другую лицензию Fax Voip T.38 Модем?

Извините, но в этом случае, вы определенно должны купить новую лицензию Fax Voip T.38 Модем .


Мастер архивации и восстановления

Мастер архивации и восстановления Fax Voip T.38 Модем

Мастер архивации и восстановления Fax Voip T.38 Модем позволяет выполнять следующие задачи:

  • Сохранение текущей конфигурации Fax Voip T.38 Модем и файлов, созданных в процессе работы программы.
  • Восстановление конфигурации Fax Voip T.38 Модем и файлов пользователя из резервной копии.
  • Перемещение текущей конфигурации Fax Voip T.38 Модем и файлов пользователя на другой компьютер.

Для запуска Мастера архивации и восстановления Fax Voip T.38 Модем требуются права администратора.

Вы можете запустить Мастер архивации и восстановления Fax Voip T.38 Модем одним из нижеследующих способов:

  • В Панели управления Fax Voip T.38 Модем , нажмите Мастер архивации и восстановления на вкладке Инструменты на ленте.
  • В меню Fax Voip T.38 Модем в системном трее выберите Мастер архивации и восстановления. См. также в главе Опции меню в системном трее настоящего справочного руководства.
  • Можно также открыть Мастер архивации и восстановления Fax Voip T.38 Модем запустив файл FVModemBackup.exe. Этот файл находится в папке, в которую установлен Fax Voip T.38 Модем, обычно C:\Program Files\FaxVoip Modem.

Примечания

  • С помощью Мастера архивации и восстановления Fax Voip T.38 Модем вы также можете импортировать настройки из резервных копий, созданных в более ранних версиях Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней), см. Использование мастера архивации и восстановления Fax Voip T.38 Модем с предыдущими версиями .


Сохранение параметров и файлов

Сохранение текущих параметров и файлов Fax Voip T.38 Модем

Мастер архивации и восстановления ››

1. Запустите Мастер архивации и восстановления Fax Voip T.38 Модем . Для запуска Мастера архивации и восстановления Fax Voip T.38 Модем требуются права администратора. Нажмите <Далее>.

2. На странице Архивация и восстановление Fax Voip T.38 Модем, выберите Архивация параметров и файлов Fax Voip T.38 Модем. Нажмите <Далее>.

3. На странице Что следует архивировать отметьте необходимые опции, а затем нажмите <Далее>.

Следующие опции сохранения доступны:

Все параметры Fax Voip T.38 Модем и файлы созданные в процессе работы программы

Выберите этот вариант чтобы сохранить все параметры конфигурации Fax Voip T.38 Модем и все файлы, созданные в процессе работы программы.

Предоставить возможность выбора объектов для архивации

Выберите этот вариант чтобы выборочно сохранить ваши настройки и файлы. Отметьте объекты, которые необходимо сохранить.

Лицензионный ключ

Отметьте эту опцию чтобы сохранить ваш лицензионный ключ. Обратите внимание, что ваш лицензионный ключ привязан к текущему компьютеру (SystemID) и не может быть перенесен на другой компьютер. Не используйте эту опцию при переносе конфигурации на другой компьютер.

Параметры (SIP, H.323, CAPI 2.0, Маршрутизация вызовов, Факс, E-mail...)

Отметьте эту опцию чтобы сохранить текущую конфигурацию.

Методы для входящих (Отправить по e-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы сохранить ваши настройки для Методов маршрутизации для входящих факсов (Microsoft Fax) .

Методы для исходящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы сохранить ваши настройки для Методов маршрутизации для исходящих факсов (Microsoft Fax) .

Правила для почты (Почта-на-факс - Microsoft Fax)

Отметьте эту опцию чтобы сохранить ваши Правила для почты (почта-на-факс) - Microsoft Fax .

4. На следующей странице выберите папку для сохранения резервной копии. Введите имя новой папки, в которую будут скопированы резервные файлы. По умолчанию мастер предлагает создать папку на рабочем столе. Нажмите <Далее> чтобы начать архивирование.

5. На завершающей странице мастера вы можете отметить опцию Показать файлы резервной копии, чтобы открыть папку с сохраненными файлами в проводнике Windows. Чтобы закрыть окно мастера, нажмите <Готово>.


Восстановление параметров и файлов

Восстановление параметров и файлов Fax Voip T.38 Модем

Мастер архивации и восстановления ››

1. Запустите Мастер архивации и восстановления Fax Voip T.38 Модем . Для запуска Мастера архивации и восстановления Fax Voip T.38 Модем требуются права администратора. Нажмите <Далее>.

2. На странице Архивация и восстановление Fax Voip T.38 Модем, выберите Восстановление параметров и файлов Fax Voip T.38 Модем. Нажмите <Далее>.

3. На следующей странице укажите папку, в которой сохранены параметры и файлы Fax Voip T.38 Модем. Нажмите <Далее>.

4. На странице Что следует восстановить отметьте необходимые опции, а затем нажмите <Далее> чтобы начать процедуру восстановления.

Следующие опции восстановления доступны:

Восстановить Лицензионный ключ

Отметьте эту опцию чтобы восстановить ваш лицензионный ключ. Обратите внимание, что ваш лицензионный ключ привязан к текущему компьютеру (SystemID) и не может быть перенесен на другой компьютер.

Восстановить Параметры (SIP, H.323, CAPI 2.0, Маршрутизация, Факс, E-mail...)

Отметьте эту опцию чтобы восстановить вашу конфигурацию.

Восстановить Методы для входящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы восстановить ваши настройки для Методов маршрутизации для входящих факсов (Microsoft Fax) .

Восстановить Методы для исходящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы восстановить ваши настройки для Методов маршрутизации для исходящих факсов (Microsoft Fax) .

Восстановить правила для почты (Почта-на-факс - Microsoft Fax)

Отметьте эту опцию чтобы восстановить ваши Правила для почты (почта-на-факс) - Microsoft Fax .

5. На завершающей странице мастера нажмите <Готово>.


Использование мастера с предыдущими версиями

Использование мастера архивации и восстановления Fax Voip T.38 Модем с предыдущими версиями

Мастер архивации и восстановления ››

Перемещение настроек из Fax Voip версии 8.3.1 (или более ранней) в Fax Voip T.38 Модем версии 9.1.1 (или более поздней)

С помощью Мастера архивации и восстановления Fax Voip T.38 Модем вы можете импортировать настройки из резервных копий, созданных в более ранних версиях Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней).

Чтобы сохранить предыдущие настройки (Fax Voip T38 Fax & Voice версии 8 или более ранней), запустите Мастер архивации и восстановления Fax Voip (входит в состав Fax Voip T38 Fax & Voice версии 8 или более ранней) перед удалением старой версии.

Отсутствует обратная совместимость между Fax Voip T.38 Модем версии 9.1.1 и более ранними версиями Fax Voip, т.е. вы не можете переместить конфигурацию из Fax Voip T.38 Модем в более раннюю версию Fax Voip (Fax Voip T38 Fax & Voice версии 8 или более ранней).


Удаление Fax Voip T.38 Модем

  • Чтобы удалить Fax Voip T.38 Модем


Чтобы удалить Fax Voip T.38 Модем

Удаление программного обеспечения Fax Voip T.38 Модем

Удаление Fax Voip T.38 Модем ››

Чтобы удалить Fax Voip T.38 Модем с локального компьютера

1. Закройте все компоненты Fax Voip T.38 Модем, чтобы избежать возможных проблем.

2. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Приложения и возможности.

3. В списке установленных программ выделите запись Fax Voip T.38 Модем (Fax Voip 9.X.X). Нажмите кнопку Удалить.

4. В окне мастера Удаление Fax Voip T.38 Модем нажмите Удалить.

5. Отметьте опции удаления и затем нажмите Далее. Для сохранения настроек и файлов созданных в процессе работы программы, оставьте опции по умолчанию как показано на рисунке ниже.

Доступны следующие варианты удаления Fax Voip T.38 Модем:

Все файлы

Выберите эту опцию, чтобы полностью удалить программу с вашего компьютера. Все настройки, а также файлы созданные в процессе работы программы (файлы протоколов и т.д.) будут удалены. Будьте внимательны! Удаленные документы не могут быть восстановлены.

Указанные файлы

Выберите эту опцию чтобы сохранить настройки и файлы созданные в процессе работы программы. Отметьте объекты подлежащие удалению.

Файлы программы

Эта опция всегда выбрана и не может быть изменена.

Виртуальные COM порты и модемы

Эта опция всегда выбрана и не может быть изменена.

Расширение маршрутизации факсов (служба факсов Windows)

Эта опция всегда выбрана и не может быть изменена.

Параметры (SIP, H.323, CAPI 2.0, Маршруты, Факс, E-mail...)

Отметьте эту опцию чтобы удалить текущую конфигурацию. Эта опция также удаляет пользовательские Шаблоны электронной почты и Языковые профили (включая профили, созданные пользователем).

Методы для входящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы удалить настройки для Методов маршрутизации для входящих факсов (Microsoft Fax) .

Методы для исходящих (E-mail, Сохранить в папке, Печать)

Отметьте эту опцию чтобы удалить настройки для Методов маршрутизации для исходящих факсов (Microsoft Fax) .

Правила для почты (Почта-на-факс - Microsoft Fax)

Отметьте эту опцию чтобы удалить Правила для почты (почта-на-факс) - Microsoft Fax .

Файлы созданные в процессе работы программы

Отметьте эту опцию чтобы удалить файлы созданные в процессе работы программы (файлы протоколов и т.д.). Будьте внимательны! Удаленные документы не могут быть восстановлены.

6. На завершающей странице мастера Удаление Fax Voip T.38 Модем нажмите Готово.


Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу

Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу (RDP)

При помощи Подключения к удаленному рабочему столу (RDP), вы можете удаленно настраивать параметры приложений и запускать приложения на вашем компьютере. RDP является стандартным компонентом операционной системы Windows, нет необходимости загружать и устанавливать громоздское, часто некачественное программное обеспечение сторонних производителей. Вы можете использовать RDP для удаленной установки и настройки приложения Fax Voip T.38 Модем. При этом следует использовать учетную запись администратора.

Для осуществления необходимых настроек на компьютере, на котором установлен Fax Voip T.38 Модем, следуйте инструкциям раздела Настройка RDP на компьютере, к которому требуется подключиться настоящей главы.

Чтобы подключиться к компьютеру, на котором установлен Fax Voip T.38 Модем, с другого компьютера, следуйте инструкциям раздела Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP) настоящей главы.

Вы также можете работать с Fax Voip T.38 Модем через RDP, но следует принять во внимание, что некоторые функции могут работать некорректно или не работать вовсе. Мы также не можем гарантировать правильного функционирования программы в случае нескольких подключений к серверной операционной системе через терминальные сессии.

Некоторые из наиболее известных проблем и их решений при подключении через RDP, описаны в разделе Устранение неполадок при использовании удаленного рабочего стола (RDP) настоящей главы.

Заметим, что если вы нуждаетесь в удаленной поддержке , вы должны предоставить доступ к вашему компьютеру через стандартное RDP подключение, как описано в этой главе. Следует особо отметить, что наши эксперты не используют никакого другого программного обеспечения для осуществления удаленной поддержки .


Настройка RDP на компьютере, к которому требуется подключиться

Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу ››

Чтобы разрешить удаленные подключения на компьютере, к которому требуется подключиться:

1. Щелкните правой кнопкой мыши кнопку Пуск; в контекстном меню, нажмите Система. В окне О системе нажмите Дополнительные параметры системы.

2. В окне Свойства системы, на вкладке Удаленный доступ, в группе Удаленный рабочий стол, выберите опцию Разрешить удаленные подключения к этому компьютеру. Снимите галку Разрешить подключения только с компьютеров, на которых работает удаленный рабочий стол с проверкой подлинности на уровне сети чтобы иметь возможность доступа к вашему компьютеру с компьютеров, на которых установлены старые операционные системы.

3. Если вы являетесь администратором компьютера, ваша текущая учетная запись будет автоматически добавлена в список удаленных пользователей и вы можете пропустить оставшиеся действия.

4. Нажмите OK или Применить, чтобы сохранить параметры.

Примечания

  • Функция Подключение к удаленному рабочему столу включена не во все версии Windows. См. также документацию к вашей версии операционной системы Windows.


Подключение к удаленному компьютеру с помощью RDP

Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP)

Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу ››

Для запуска удаленного рабочего стола на компьютере, с которого происходит подключение:

1. Переключитесь на панель Поиск, наберите подключение к удаленному рабочему столу, а затем нажмите Подключение к удаленному рабочему столу.

2. В окне Подключение к удаленному рабочему столу, в поле Компьютер, введите имя компьютера, к которому требуется подключиться, а затем щелкните Подключить. (Вместо имени компьютера можно также ввести его IP-адрес).

3. После подключения к удаленному компьютеру, вам будет предложено ввести учетные данные.

Примечания

  • Версия клиента подключения к удаленному рабочему столу зависит от типа и версии операционной системы Windows, версии Service Pack и т.п. См. также документацию по вашей операционной системе Windows.


Устранение неполадок при использовании RDP

Устранение неполадок при использовании удаленного рабочего стола (RDP)

Запуск Fax Voip T.38 Модем через подключение к удаленному рабочему столу ››

Я сталкиваюсь с большим количеством проблем, пытаясь работать с Fax Voip T.38 Модем через подключение RDP. В чем может быть проблема?

При доступе к компьютеру, на котором установлен Fax Voip T.38 Модем, вам следует использовать учетную запись администратора.

Я не могу нормально работать с моей факс программой через подключение RDP. Что делать?

Попробуйте найти ответ на этот вопрос в документации на вашу факс программу, либо свяжитесь с разработчиками вашего софта. Есть вероятность, что ваша факс программа не предназначена для работы через RDP.


Проблемы Виртуальных Машин

В настоящее время, установка операционной системы Windows на Виртуальную машину весьма популярна. Десятки и сотни разработчиков утверждают, что их Виртуальные машины обеспечивают точно такие же условия, как обеспечивает обычный аппаратный компьютер. Согласно их утверждениям, нет никакой разницы между операционной системой, установленной на Виртуальную машину и операционной системой, установленной обычным способом.

К сожалению, на практике, картина может быть гораздо более печальной. Ваша система нестабильна, вы вынуждены часто переустанавливать ее. У вас часто возникают проблемы при использовании стандартных функций, драйверов и т.д. Ваши любимые программы не работают правильно или дают сбой в самый неподходящий момент. Вы начинаете винить разработчиков программного обеспечения и говорить, что они пишут некачественные программы.

Итак, возможно ли установить Fax Voip T.38 Модем на Виртуальную машину? Будет ли он работать на ней?

Да, вы можете. Но... Компания FaxVoip Software не дает никаких гарантий и не несет никакой ответственности, если программа Fax Voip T.38 Модем не будет работать правильно, будучи установленной на Виртуальную машину. Fax Voip T.38 Модем является достаточно сложным приложением с технической точки зрения. Не удивительно, что любой из тщательно скрываемых недостатков вашей Виртуальной машины может всплыть и вызвать ошибку. В случае возникновения ошибки, которая не подтверждается путем воспроизведения такой же проблемы на аппаратном компьютере, с установленной на нем такой же операционной системы, наши эксперты наврядли смогут помочь вам. Мы тестируем нашу программу на нормальных аппаратных компьютерах и никогда не используем Виртуальные машины. Может быть ваша Виртуальная машина и самая лучшая в мире, но пожалуйста, попытайтесь решить проблему с ее разработчиками, ведь именно они, а не мы, и не разработчики Windows настаивают на том, что "Виртуальная машина работает так же хорошо".

Иными словами, мы настоятельно рекомендуем, чтобы вы устанавливали Fax Voip T.38 Модем на нормальный аппаратный компьютер.

Ответы на вопросы, часто задаваемые пользователями Виртуальных машин можно найти в разделе Часто задаваемые вопросы (FAQ) текущей главы.


Часто задаваемые вопросы

Часто задаваемые вопросы (FAQ)

Проблемы Виртуальных Машин ››

Я переустановил Windows и мой SystemID изменился. Я использую Виртуальную машину (VMWare и т.п.) и мой виртуальный сервер рухнул в прошлую пятницу. Не могли бы вы прислать мне другую лицензию?

Мы категорически не рекомендуем устанавливать Fax Voip T.38 Модем на Виртуальную машину. Виртуальные машины чрезвычайно неустойчивы и требуют частых переустановок, при которых SystemID не сохраняется ввиду отсутствия оборудования как такового. Пожалуйста установите Fax Voip T.38 Модем на нормальный аппаратный компьютер. Если вы все-таки решили игнорировать наши рекомендации и установить Fax Voip T.38 Модем на Виртуальной машине, имейте ввиду следующее. В любом случае вы можете попросить новый лицензионный ключ в течении срока лицензионной поддержки (1 год). Интервал между заменами лицензионного ключа не может быть менее 3-х месяцев. Бесплатная замена лицензионного ключа в течении срока лицензионной поддержки разрешена не более 2-х (двух) раз.

У меня есть одна проблема с вашим программным обеспечением. На моей VMWare, Windows 11 (Windows 10, Windows 8.1), когда я отправляю (принимаю) факс, нет никаких проблем. Но затем Fax Voip T.38 Модем рушится. Есть ли у вас какие-либо предложения, что я могу сделать?

Вы можете установить Fax Voip T.38 Модем на такую же операционную систему, но установленную на нормальный аппаратный компьютер.

Наши специалисты не очень хорошие эксперты по части Виртуальных машин и мы готовы признать это. Пожалуйста, адресуйте ваш вопрос в техническую поддержку VMware. Они безусловно являются высококлассными специалистами в области Windows и обязаны обеспечить правильную работу Windows-совместимого программного обеспечения на своей виртуальной системе.

Привет, я только что обновился до Fax Voip T.38 Модем версии 9 и теперь не могу запустить Панель управления Fax Voip T.38 Модем. В системном журнале я вижу: Faulting application FaxVoipModemConfig.exe, version 9.1.0.1, faulting module kernel32.dll... У меня никогда никогда не было такой ошибки при использовании предыдущей версии. Я использую VMWare... Вы можете решить эту проблему?

Мы не даем никаких гарантий нормальной работы Fax Voip T.38 Модем, если программа установлена на Виртуальную машину. Может быть мы добавили какую-нибудь новую функцию, которая использует например WIN API, которая не использовалась в предыдущей версии Fax Voip. Вероятно поддержка этой функции не доработана в вашей Виртуальной машине. Пожалуйста свяжитесь со службой поддержки вашей VM и попросите их исправить проблему.

Собираетесь ли вы осуществлять поддержку Виртуальных Машин в будущем?

Мы занимаемся поддержкой правильного функционирования нашей программы на операционных системах Microsoft Windows . Обеспечение правильного функционирования самой операционной системы, определенно является задачей тех, кто разрабатывает оборудование, на котором эта система функционирует. В случае Виртуальной машины, это задача разработчиков вашей Виртуальной машины.


Техническая поддержка

Вы можете связаться с нашей службой технической поддержки, отправив сообщение e-mail по адресу support@t38faxvoip.ru

Для получения самой свежей информации о нашей программе, пожалуйста, посетите наш веб-сайт https://www.t38faxvoip.ru

По вопросам покупки и лицензирования Fax Voip T.38 Модем, обращайтесь по адресу sales@t38faxvoip.ru

Примечания

  • Наши эксперты всегда рады помочь вам с помощью Удаленной поддержки .


Удаленная поддержка

Техническая поддержка ››

В случае нестандартных проблем, а также для ускорения решения возникших проблем, наши эксперты могут помочь вам с помощью Удаленной поддержки и решить проблему непосредственно на вашем компьютере. Чтобы использовать данную возможность, вы должны предоставить доступ к вашему компьютеру через Подключение к удаленному рабочему столу (RDP) . Для получения Удаленной поддержки, пожалуйста свяжитесь с нашей службой поддержки .

Часто задаваемые вопросы (FAQ)

Как настроить мой компьютер, чтобы ваши специалисты смогли получить к нему доступ и оказать удаленную помощь?

Вам следует настроить доступ через Подключение к удаленному рабочему столу на вашем компьютере, где установлен Fax Voip T.38 Модем. Для этого воспользуйтесь инструкциями в главе Настройка RDP на компьютере, к которому требуется подключиться настоящего справочного руководства.

Какую программу вы используете для удаленного доступа к моему компьютеру?

Наши специалисты используют стандартный клиент для Подключения к удаленному рабочему столу от фирмы Microsoft, который входит в комплектацию операционной системы Windows. Мы используем стандартную процедуру, описанную в главе Подключение к удаленному компьютеру с помощью подключения к удаленному рабочему столу (RDP) настоящего справочного руководства.

Какие необходимые данные я должен сообщить вам?

Вы должны сообщить нам IP-адрес вашего компьютера, Имя пользователя (должен являться администратором) и Пароль. Естественно, вы должны объяснить суть возникшей проблемы нашему эксперту. Необходимость Удаленной поддержки должна быть согласована с нашей службой поддержки . Если вы используете Виртуальную машину , мы просим проинформировать нас об этом заранее. Напомним, что наши эксперты не занимаются решением специфических проблем виртуальных машин.

На моем компьютере установлена программа TeamView (GoTo Meeting), мой Session ID 666-666-666 и действителен в течении ближайших 10 минут (3-х часов). TeamView это очень хорошая программа. Я буду в офисе еще 40 минут (до 8 часов вечера по моему местному времени). Не могли бы вы взглянуть на мою проблему?

Наши специалисты не используют программное обеспечение сторонних производителей для удаленного доступа к вашему компьютеру. Упомянутые вами программы не установлены на наших компьютерах и не могут быть использованы по соображениям безопасности.

Обратите внимание, что Удаленная поддержка обычно предлагается в случае непонятных проблем, которые не могут быть решены в обычном порядке в течении 5 минут. Нашим экспертам обычно требуется какое-то время, чтобы понять проблему на компьютере клиента и попытаться найти решение. После предварительного согласования и предоставления доступа к вашему компьютеру, наш специалист изучит проблему в течение последующих 24 часов (обычно раньше) и свяжется с вами.

Почему я должен давать вам доступ к своему компьютеру? Я не могу дать вам пароль администратора. Что вы собираетесь делать на моем компьютере?

Странный вопрос... Вы попросили решить вашу проблему и просите об Удаленной поддержке. Естественно, наши специалисты будут заниматься исключительно проблемами программы Fax Voip T.38 Модем на вашем компьютере.

Без доступа с правами администратора мы, скорее всего, не сможет понять и решить проблему, так что это необходимо.

Конечно, только вы сами принимаете окончательное решение о предоставлении или не предоставлении доступа к вашему компьютеру.

В настоящее время у меня нет лицензии на вашу программу. (Fax Voip T.38 Модем установлен в качестве пробной версии). Могу я просить вас о предоставлении удаленной помощи?

Да, конечно. Пожалуйста свяжитесь с нашей службой поддержки . Заметим только, что клиенты, оплатившие лицензию, имеют преимущественное право на получение любого вида технической поддержки.


Другие продукты

  • Fax Voip Windows Fax Service Provider
  • Fax Voip T.38 Консоль
  • Fax Voip Softphone
  • Windows Mail Restore Tool for Windows 10, 8.1 and 7


Fax Voip Windows Fax Service Provider

Другие продукты ››

Fax Voip Windows Fax Service Provider
T.38 и аудио факс, SIP, H.323

https://www.t38faxvoip.ru/fsp

Позволяет Microsoft Fax и приложению Факсы и сканирование, которые встроены в Windows, отправлять и принимать T.38 и аудио факсы через VoIP. ECM (Коррекция ошибок). Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip FSP

Fax Voip Windows Fax Service Provider (Fax Voip FSP) позволяет Microsoft Fax и приложению Факсы и сканирование Windows, которые встроены в Windows, отправлять и принимать T.38 и аудио (поверх кодека G.711) факсы с использованием вашей VoIP (SIP или H.323) инфраструктуры без каких-либо дополнительных затрат.

Служба факсов Windows и приложение Факсы и сканирование Windows представляют собой интегрированное факс программное обеспечение включенное во все версии Windows. Microsoft Fax является расширяемой факс платформой, которую можно использовать для развертывания совместно используемых факс ресурсов в вашей организации. Пользователи внутри организации могут устанавливать соединение с удаленным факс принтером на сетевом факс сервере и отправлять и принимать факсы используя общие факсимильные устройства расположенные на сервере, а также использовать локальные факс устройства, привязанные к их компьютерам. Факс администраторы могут конфигурировать, управлять и следить за этими общими ресурсами факсов. Централизованное управление общими факс-устройствами на базе сервера означает более простое управление и техническое обслуживание, а также низкую стоимость. Пользователи факса могут отправлять и получать факсы без необходимости использования ручных факс-аппаратов, экономя при этом время и силы.

Fax Voip FSP заменяет стандартного поставщика Microsoft Modem Device Provider поставщиком Fax Voip T.38/G.711FAX Device Provider. Это позволяет наиболее эффективно использовать службу факсов Windows. В частности, поддерживается ECM (Коррекция ошибок). Также корректно определяется сигнал 'занято'. Использование провайдера службы факсов (Fax Service Provider, FSP) вместо Виртуальных COM портов и модемов значительно повышает надежность вашей системы факсимильной связи.

Fax Voip FSP позволяет приложению Windows Fax and Scan получать Caller ID и Номер вызываемого абонента (DID) - через Сведения о маршрутизации.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Функция Почта-на-факс позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Расширение маршрутизации Fax Voip FSP позволяет маршрутизировать входящие факсы в зависимости от номера вызывающего абонента (Caller ID) и номера вызываемого абонента (DID), используя следующие методы маршрутизации для входящих факсов: отправить по электронной почте, сохранить в папке, печать. Пользовательская маршрутизация входящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов: уведомления о доставке по электронной почте, сохранить в папке, печать позволяют маршрутизировать исходящие факсы в зависимости от номера факса получателя, учетной записи пользователя, который отправил факс, а также успешной или неудачной доставки факса. Пользовательская маршрутизация исходящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса.

Fax Voip FSP был успешно протестирован с YouMagic , Телфин , Мультифон , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими VoIP операторами.


Fax Voip T.38 Консоль

Другие продукты ››

Fax Voip T.38 Консоль
T.38 и аудио факс. SIP, H.323, ISDN CAPI 2.0

https://www.t38faxvoip.ru/console

T.38 и аудио факс для SIP/H.323/ISDN CAPI 2.0. Поддержка одновременных SIP регистраций. Маршрутизация вызовов. Отправка аудио сообщений. Почта-на-факс. Маршрутизация входящих факсов: через e-mail, сохранить в папке, печать, пользовательская маршрутизация, факс-по-запросу. Маршрутизация исходящих факсов: уведомления на e-mail, сохранить в папке, печать, пользовательская маршрутизация.

О программе Fax Voip T.38 Консоль

Fax Voip T.38 Консоль позволяет отправлять и получать T.38 и аудио (поверх кодека G.711) факсы и отправлять аудио сообщения с использованием любого провайдера IP-телефонии (SIP или H.323). Решение не требует установки какого-либо стороннего факс-голосового программного обеспечения.

На рисунке ниже показано как работает приложение Fax Voip T.38 Консоль.

Поддержка Одновременных SIP регистраций и Маршрутизации вызовов делает вашу систему наиболее гибкой, а также позволяет одновременно работать с несколькими SIP и H.323 операторами.

Вы можете отправлять T.38, аудио и CAPI факсы через Виртуальный принтер Fax Voip и принимать факсы напрямую в TIFF, PDF или SFF файлы. Управлять факсами можно через приложение Fax Voip T.38 Консоль.

Можно отправлять не только факсы, но также аудио сообщения.

Fax Voip T.38 Консоль – полнофункциональная система для отправки факсов и аудио сообщений через e-mail (Почта-на-факс и Аудио через почту) и получения факсов на e-mail (Факс-на-почту).

Функция Почта-на-факс (аудио через почту) позволяет отправлять факсы непосредственно из приложения электронной почты. Текст e-mail сообщения будет отображен на титульной странице факса, в то время как любые прикрепленные документы (например, в формате PDF, TIFF или TXT) будут преобразованы в дополнительные страницы факса. Факс может быть отправлен нескольким получателям, можно смешивать различные типы e-mail вложений.

Методы маршрутизации для входящих факсов: отправить по электронной почте, сохранить в папке, печать позволяют маршрутизировать входящие факсы получателям в сети. Пользовательская маршрутизация входящих факсов позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после получения факса.

Методы маршрутизации для исходящих факсов и аудио сообщений: уведомления о доставке по электронной почте, сохранить в папке, печать позволяют маршрутизировать исходящие факсы и аудио сообщения в зависимости от номера получателя, а также успешной или неудачной доставки факса или аудио сообщения. Пользовательская маршрутизация исходящих факсов и аудио сообщений позволяет легко добавлять любые функции маршрутизации с помощью пользовательского приложения, которое запускается после отправки факса или аудио сообщения.

Функция Факс по запросу позволяет вызывающим абонентам получать необходимую информацию по факсу в процессе текущего вызова.

Fax Voip T.38 Консоль хорошо работает с такими операторами IP-телефонии, как YouMagic (МТТ) , Телфин , Мультифон (Мегафон) , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими.


Fax Voip Softphone

Другие продукты ››

Fax Voip Softphone
Phone, Fax, Call Recording, Random Calls

https://www.t38faxvoip.com/phone

https://www.t38modem.com/phone

SIP/H.323 софтфон. Запись телефонных разговоров. Проигрывание аудио сообщений в телефонную линию. Отправка и прием T.38 и аудио факсов. Мелодия на удержании. Перевод и переадресация вызовов. Телефонная книга. Журнал. Функция случайных телефонных вызовов.

О программе Fax Voip Softphone

Fax Voip Softphone является мощным и уникальным SIP / H.323 программным телефоном при помощи которого можно осуществлять телефонные вызовы, записывать разговор по телефону, воспроизводить аудио файлы в телефонную линию, а также отправлять и принимать T.38 и аудио факсы. Весь функционал доступен в рамках единственного приложения с использованием любого провайдера IP телефонии (VoIP). Fax Voip Softphone поддерживает такие функции как Мелодия на удержании, Перевод Вызова и Переадресация вызова.

Audio - Fax панель позволяет отправлять заранее подготовленные факсы и аудио сообщения в один клик.

Используя Log Book (журнал), вы можете легко просматривать историю вызовов, просматривать полученные и отправленные факсы, а также прослушивать записи разговоров и отправленные аудио сообщения.

Phone Book (телефонная книга) является удобным местом хранения информации о ваших контактах.

Функция Random Phone Calls (случайные телефонные вызовы) может быть полезна для вашего бизнеса, а также для различных тестовых целей. Эта функция позволяет автоматически осуществлять повторяющиеся телефонные вызовы на один или несколько заданных номеров. Также эта функция позволяет проигрывать в линию аудио сообщения и вести запись разговоров.

Используя Fax Voip Softphone Control Panel (панель управления), вы легко можете настроить софтфон в соответствии с вашими требованиями.

Fax Voip Softphone был успешно протестирован с YouMagic , Телфин , Мультифон , T38FAX , CALLCentric , babyTEL , MondoTalk и многими другими VoIP операторами.


Windows Mail Restore Tool for Windows 10, 8.1 and 7

Другие продукты ››

Windows Mail Restore Tool
for Windows 10, 8.1 and 7

https://www.winmail10.com

Позволяет использовать классическое программное обеспечение Почта Windows (ранее Outlook Express) на компьютере под управлением Windows 10, Windows 8.1 или Windows 7. Автоматическое восстановление после обновлений. Резервное копирование и восстановление хранилища сообщений и настроек. Многоязычная поддержка.

О программе WM Restore Tool

Windows Mail Restore Tool (WM Restore Tool) позволяет использовать классическое программное обеспечение Почта Windows (ранее Outlook Express) на компьютере под управлением Windows 10, Windows 8.1 или Windows 7. Windows Mail (ранее Outlook Express), один из наиболее популярных клиентов электронной почты по всему миру, теперь доступен снова для всех новых версий Windows.

В Windows Mail есть все инструменты, необходимые для работы с электронной почтой и новостями. Доступные языки интерфейса Windows Mail: английский, немецкий, французский, испанский, итальянский, японский, китайский (упрощенный), китайский (традиционный), арабский, болгарский, хорватский, чешский, датский, голландский, эстонский, финский, греческий, иврит, корейский, латышский, литовский, норвежский, польский, португальский (Бразилия), португальский (Португалия), румынский, русский, сербский, словацкий, словенский, шведский, тайский, турецкий, украинский.

Windows Mail поддерживает следующие почтовые и новостные протоколы: POP3 (Post Office Protocol 3), SMTP (Simple Mail Transfer Protocol), IMAP (Internet Message Access Protocol), NNTP (Network News Transfer Protocol). Благодаря поддержке SSL, вы можете легко настроить Windows Mail для использования с Gmail , Hotmail (Live, Outlook.com) и многими другими службами электронной почты. Windows Mail полностью совместима с функциями обмена сообщениями Simple MAPI . Кроме того, Windows Mail имеет документированный интерфейс прикладного программирования (API) основанный на Component Object Model (COM).

Инструмент WM Restore Tool предоставляет вам дополнительный набор полезных инструментов при работе с приложением Windows Mail. Вы можете легко создать резервную копию, восстановить или переместить на другой компьютер свои настройки и хранилище сообщений Windows Mail.